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Introduction

Help System

The detailed help system of WaveLab Pro enables you to look up interface features 
and get information from within the program.

Accessing the Help System

There are several ways of accessing the help system.

• To open the WaveLab Pro help, select Help > Contents.

• To open the manual in PDF format, select Help > PDF Documentation.

• To show tooltips, move the mouse over an interface icon.

• To open the help for an active dialog, click the question mark icon on the title 
bar (Windows) or in the dialog (Mac OS) to show the Help button, and then 
click the Help button, or press [F1] (Windows) or [Command]-[?] (Mac OS).

• To use the menu help, move the mouse over a menu item.

• To see information on what kind of editing can be performed when using the 
mouse and modifier keys in the Audio Montage window, move the mouse 
over the montage window. The help text is displayed on the info line at the 
bottom of the window.

To open the “What’s This” help, you have the following possibilities:

• In any window, press [Shift]-[F1] and move the mouse over an interface item, 
or select Help > What’s This?.

• In a dialog, select the question mark icon on any title bar (Windows) or in the 
dialog (Mac OS), and move the mouse over an interface item or a menu 
option.

• Some “What’s this” tooltips include a link to a dedicated help topic.

RELATED LINKS

Info Line on page 282
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About the Program Versions

The documentation covers the operating systems Windows and Mac OS X.

Features and settings that are specific to one of these platforms are clearly 
indicated. In all other cases, the descriptions and procedures in the documentation 
are valid for Windows and Mac OS X.

Some points to consider:

• The screenshots are taken from a Windows operating system.

• Some functions that are available on the File menu on Windows operating 
systems can be found in the program name menu on Mac OS X operating 
systems.

Conventions

In our documentation, we use typographical elements and mark-ups to structure 
information.

Typographical Elements

The following typographical elements mark the following purposes.

PREREQUISITE

Requires you to complete an action or to fulfill a condition before starting a 
procedure.

PROCEDURE

Lists the steps that you must take to achieve a specific result.

IMPORTANT

Informs you about issues that might affect the system, the connected 
hardware, or that might bring a risk of data loss.

NOTE

Informs you about issues that you should consider.

EXAMPLE

Provides you with an example.

RESULT

Shows the result of the procedure.

AFTER COMPLETING THIS TASK

Informs you about actions or tasks that you can undertake after completing 
the procedure.
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RELATED LINKS

Lists related topics that you can find in this documentation.

Mark-Ups

Bold text indicates the name of a menu, option, function, dialog, window, etc.

EXAMPLE

To open the Layout Options pop-up menu, click Layout Options in the top right 
corner of the Audio Editor.

If bold text is separated by a greater-than symbol, this indicates a sequence of 
different menus to open.

EXAMPLE

Select File > Save As.

Key Commands

Many of the default key commands use modifier keys, some of which are different 
depending on the operating system.

For example, the default key command for Undo is [Ctrl]-[Z] on Windows and 
[Command]-[Z] on Mac OS X. When key commands with modifier keys are 
described in this manual, they are shown with the Windows modifier key first, in the 
following way:

• [Win modifier key]/[Mac modifier key]-[key]

EXAMPLE

[Ctrl]/[Command]-[Z] signifies: press [Ctrl] on Windows or [Command] on Mac OS 
X, then press [Z].

Similarly, [Alt]/[Option]-[X] signifies: press [Alt] on Windows or [Option] on Mac OS 
X, then press [X].

How You Can Reach Us

On the Help menu in WaveLab Pro, you find items linking to additional information.
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The menu contains links to various Steinberg web pages. Selecting a menu item 
automatically launches your browser and opens the page. On these pages, you can 
find support and compatibility information, answers to frequently asked questions, 
information about updates and other Steinberg products, etc. This requires that you 
have a web browser installed on your computer, and a working Internet connection.
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Setting Up Your System

Before you start working, you need to make some settings.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

Make sure that all equipment is turned off before making any connections.

Connecting Audio

Your system setup depends on many different factors, for example, the kind of 
project that you want to create, the external equipment that you want to use, or the 
computer hardware available to you.

Audio Cards and Background Playback

When you activate playback or recording in WaveLab Pro, other applications 
cannot access the audio card. Likewise, if another application uses the audio card, 
WaveLab Pro is unable to play back. The Windows MME driver is an exception from 
this.

You can run WaveLab Pro together with other applications and always give the 
active application access to the audio card.

PROCEDURE

1. Select File > Preferences > VST Audio Connections.

2. Select the Options tab.

3. Activate Release Driver.

4. Do one of the following:
• If you want to release the driver when WaveLab Pro is in the background, 

activate When WaveLab Pro is in Background.

• If you want to release the driver only when Cubase is in the foreground, activate 
When Cubase is in Foreground.
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Latency

Latency is the delay between when audio is sent from the program and when you 
actually hear it. While a very low latency can be crucial in a real-time DAW 
application such as Steinberg Nuendo or Cubase, this is not strictly the case with 
WaveLab Pro.

When working with WaveLab Pro, the important issues are optimum and stable 
playback and editing precision.

The latency in an audio system depends on the audio hardware, its drivers, and 
settings. In case of dropouts, crackles, or glitches during playback, raise the Buffer 
Number setting on the Options tab in the VST Audio Connections, or increase 
the buffer size in the ASIO control panel, specific to the audio card.

RELATED LINKS

VST Audio Connections Tab on page 13

Defining VST Audio Connections

To be able to play back and record audio in WaveLab Pro, you must specify how 
the internal input and output channels in WaveLab Pro are connected to your sound 
card and which device you intend to use for audio playback and recording.

You can define the buffer settings for your device as well as set up connections to 
external gear, such as external effects units. You should select at least two channels 
for stereo playback and recording.

If you have no third-party audio card, you can select the Windows MME driver or 
Built-in Audio (Mac) options. You can also use MME with most third party audio 
cards, with the advantage that you can record and play at different sample rates. 
However, Windows MME drivers do not allow audio monitoring in the Recording 
dialog or multichannel operation, and other drivers generally offer better sound 
quality and performance.

RELATED LINKS

VST Audio Connections Tab on page 13

Selecting an ASIO Driver

Audio Stream Input/Output (ASIO) is a computer device driver protocol for digital 
audio specified by Steinberg. It provides a low-latency and high fidelity interface 
between a software application and the soundcard of a computer.

PROCEDURE

1. Select File > Preferences > VST Audio Connections.

2. Open the Audio Device pop-up menu and select your ASIO driver.
The ASIO Plug-ins tab and the Control Panel button are activated.
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3. Optional: Click Control Panel and make your settings.

4. On the ASIO Plug-ins tab, select the audio ports that are used for recording 
and monitor input of the ASIO plug-ins.

Selecting a Windows MME Driver

PROCEDURE

1. Select File > Options > VST Audio Connections.

2. Open the Audio Device pop-up menu and select Windows MME.

3. On the Playback tab, select the audio ports that are used for playback.

4. On the Recording tab, select the audio ports that used for recording and 
monitor input.

VST Audio Connections Tab

This tab allows you to specify how the internal input and output channels in 
WaveLab Pro are connected to your sound card and which device you want to use 
for audio playback and recording.

• To open the VST Audio Connections tab, select File > Options > VST 
Audio Connections.

Global Settings

Audio Device

Allows you to select the audio device that you want to use for playback and 
recording audio. If you do not have a third-party audio card, you can select the 
Windows MME driver or Built-in Audio (Mac) options.

Control Panel

When you select an ASIO driver, the Control Panel button is activated. Click 
the button to open the settings application of your sound card, which is 
usually installed with the sound card. Depending on your sound card and 
driver, this provides settings for buffer size, digital formats, additional I/O 
connections, etc.

Refresh

This button causes audio devices to be evaluated again to reflect device 
changes.
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Playback Tab

This tab allows you to select and name audio ports that are used for playback. If you 
are monitoring on a surround system, specify your surround speaker outputs here.

You can also specify the Preferred Sample Rate for playback. Furthermore, you 
can rename the channels and set up the Speaker Configuration to be able to 
switch between different speakers.

Recording Tab

This tab allows you to select and name your audio ports that are used for recording 
and input monitoring. The inputs that you define here are then available in the 
Recording dialog. Furthermore, you can rename the channels and select the 
Speaker Configuration.
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External Gear Tab

This tab allows you to select inputs from and outputs to external audio processing 
equipment. The name of this tab corresponds to the installed driver, for example, 
ASIO Plug-ins.

Options Tab

This tab allows you to specify the number of buffers and the control driver 
functionality.

Buffer Number

Increasing this value improves the elasticity of audio streaming to avoid 
dropouts.

MME Specific – Buffer Size

Increasing this value improves the elasticity of audio streaming to avoid 
dropouts. This is only available when an MME driver is selected.

Initialize Streaming Engine at First Use

Initializes the audio streaming engine when playback or recording are used for 
the first time. If this option is deactivated, the audio streaming engine is 
initialized at program startup.

Reset Driver When Changing Sample Rate

Resets the driver when sample rate is changed. When playback or recording 
must be set to a new sample rate, some audio device drivers must be fully 
reset to work properly. This operation takes some time.

Perform Short Fade In/Out When Starting/Stopping Playback

Performs a short fade in when starting playback and a short fade out when 
stopping playback. This avoids clicks that are caused by waveforms that are 
not starting on a zero-crossing point.

Release Driver

Allows you to run WaveLab Pro together with other applications and always 
give the active application access to the audio card.

• If When WaveLab Pro is in Background is activated, the driver is 
released when WaveLab Pro is in the background.
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• If When Cubase is in Foreground is activated, the driver is released 
when Cubase is in the foreground.

CD/DVD Recorders

For general instructions on installing internal or connecting external recorders via 
USB or Firewire, refer to the instruction manual for your computer or your recorder.

Make sure to have the latest firmware version installed on your recorder unit. For CD 
recorders, the existing firmware must support disc-at-once mode. In addition, 
running a unit with older firmware can prevent you from writing sub-index markers 
into the tracks, for example.

Remote Devices

You can use remote devices to remote-control WaveLab Pro.

Several commands can be controlled with knobs and sliders of your remote control 
device. For all commands that can be assigned to a keyboard shortcut, a MIDI 
trigger can also be assigned.

Remote Devices Tab

This tab allows you to select a device to remote-control WaveLab Pro, and see and 
edit the control map of MIDI control devices.

• To open the Remote Devices tab, select File > Preferences > Remote 
Devices.
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Device Editing Tab

This tab lets you select a MIDI control device, see the control map, assign 
WaveLab Pro commands to MIDI controls, and import/export control assignments.

Device Menu

Select the MIDI device to edit. Select MIDI Shortcuts for Menus to define 
the MIDI input port that is used for MIDI shortcuts. The shortcuts can then be 
assigned on the Shortcuts tab.

Select MIDI Control Device #1 – #10 to select a slot for a connected MIDI 
control device. You can then assign a device by selecting a MIDI input port 
and output port.

Active

Activates the selected device and scans the MIDI ports.

In-Port/Out-Port

Select the MIDI input/output ports of the device that you want to use.

Edit Map

Activates the edit mode of the MIDI control map for the selected device. To 
leave the edit mode, click again.
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Save

Saves the modifications that have been made to the MIDI control map.

Undo

Undoes the modifications that have been made to the MIDI control map.

Reset

If the map has a factory preset, clicking Reset resets all changes that have 
been made to the map. If the map has no factory preset, the map is cleared.

Import

Opens the file browser where you can select a map definition file (XML file). 
This kind of file can be supplied by a MIDI device manufacturer or another 
WaveLab Pro user, for example.

Export

Lets you export a map definition file (XML file). This file can be sent to another 
WaveLab Pro user, for example.

Name

Lets you enter a map name.

Only Display Assignments

If this option is activated, the control map only displays the parameters that 
are associated with a remote control.

Expand/Collapse

Expands/collapses the folder tree of the control map.

WaveLab Pro Action List

This folder tree lists the parameters that you can remote-control. The top 
folder represent contexts. The related parameters can only be controlled if the 
context is active. For example, if an audio file is active.

A remote control can be used in several contexts if these are exclusive. For 
example, parameters that can be used for an active audio file or an active 
audio montage.

The Global folder contain the parameters that can always be controlled.

Control Editor – Save

If a control has been created or modified, click this button to save it.

Control Editor – Undo

If a control has been modified, click this button to undo the changes.

Control Editor – Clear

Erases the selected control’s definition.

Control Name

Lets you enter a name for the control. Each control must have a name.
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Type

In the Type section, you can edit the type of the selected control.

When more than one type of control can be assigned to a parameter, you can 
select a type from the first pop-up menu. You can choose between relative 
and absolute editing for some parameters. For example, a Master Section 
slider can be associated to a remote motorized fader (absolute editing), or to 
an infinite knob (relative editing).

Several protocols are supported to interpret the MIDI messages. You can 
select the protocol that you want to use from the second menu. The MIDI 
Learn function can automatically change this protocol, according to the 
received MIDI messages.

Remote controls send messages but can also receive messages from 
WaveLab Pro, to light up a button or move a motorized fader, for example. You 
can select the mode to use from the third menu.

Message

Activates the MIDI Learn function. If this option is activated, you can use the 
control (knob, fader, etc.) on your MIDI controller. When MIDI messages are 
received, they are analyzed after the MIDI activity stops for several 
milliseconds. The result is displayed in the Message field. The result is then 
used by WaveLab Pro as the control identifier.

Clear

Erases the MIDI event that identifies the control.

Conditions

A modifier is a WaveLab Pro parameter that can be activated by a MIDI 
control (for example, a foot switch) or a computer key ([Ctrl]/[Command], 
[Shift], etc.). By associating a remote control with one or two modifiers, you 
can use a single remote control to edit different parameters.

Options Tab

This tab lets you use the MIDI Learn function to assign a control of a MIDI remote 
control device to a function.

Emulate Mouse Wheel

If this option is activated, the AI knob of Steinberg controllers acts as a mouse 
wheel in the WaveLab Pro user interface, except for plug-ins.

Edit Focused Numeric Field

If this option is activated, the AI knob Steinberg controllers can be used to edit 
the focused numeric field that you find in many WaveLab Pro windows and 
dialogs.
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Selecting a MIDI Remote Control Device

PREREQUISITE 

The MIDI remote control device is connected to your PC/Mac.

PROCEDURE

1. Select File > Preferences > Remote Devices.

2. On the Device Editing tab, select one of the MIDI control device slots or the 
MIDI Shortcuts for Menus option from the pop-up menu at the top.

3. Select Active to activate the selected device.

4. From the In-Port and Out-Port pop-up menus, select a MIDI input port and 
output port.

Assigning a MIDI Controller to a Parameter

If you are using a Steinberg remote control device, for example, the CC121, the 
controls are already assigned to parameters. You can customize these default 
settings.

PREREQUISITE 

You have set up your MIDI remote control device.

PROCEDURE

1. Select File > Preferences > Remote Devices.

2. From the pop-up menu at the top of the dialog, select your MIDI control 
device.

3. On the Device Editing tab, click the Edit Map button.

4. In the tree structure, click the parameter that you want to remote-control.

5. In the Control Editor section, enter a name in the Control Name field.

6. Select the type of control.
Depending on the type of control on the MIDI remote control device, you must select 
a control with relative values (knob), trigger values (button), or absolute values (fader).

7. Click in the Message field, and on your MIDI remote control device, move the 
control that you want to assign.
The name of the controller is displayed in the Message field.

8. Click Save to the right of the This Control is Modified message.

9. Click Save to the right of the Edit Map button.

RESULT 

The MIDI controller is now assigned to the function.
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Assigning Custom Parameters to Plug-ins

You can assign custom parameters to many VST 3 plug-ins.

PREREQUISITE 

In the Remote Devices tab, assign the controls of your MIDI controller to the 
plug-in custom parameters. If you are using the Steinberg CC121 controller, the 
parameters are assigned by default.

PROCEDURE

1. From the Master Section or the Effects window, open the plug-in that you 
want to control with the MIDI remote control device.

2. [Ctrl]/[Command]-click the circle icon at the top of the plug-in window to 
enter the Edit mode.

3. Click OK.
The icon indicates that you are in MIDI learn mode.

4. Move the mouse over a plug-in parameter, and move the MIDI control that you 
want to assign.
Repeat this for all the parameters and controls that you want to assign.

5. When finished, click the tool icon to exit Edit mode, and click OK.

RESULT 

The assignment is saved. You can now control the assigned parameters with your 
MIDI remote control device. A plug-in can be controlled via the custom parameter 
if the Remote Control Mode is activated and only one plug-in can be activated at 
a time.

When a plug-in is activated for remote control, it also has precedence over other 
application settings that are controlled by the same parameter.

To remove all remote control assignments on the plug-in, hold [Ctrl]/[Command] 
and [Shift], and click the Remote Control Mode button.

RELATED LINKS

CC121 Advanced Integration Controller on page 22

Importing and Exporting Remote Control Definition Files

Map definition files are XML files, containing control assignments for your remote 
devices. You can exchange them with other users or save a backup copy.

In the Remote Devices tab, select the Device Editing tab.
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• To import a map definition file, click Import, browse to the location of the map 
definition file, and select the file.

• To export a map definition file, click Export, and browse to the location where 
you want to save the file.

Editing Changes in the Remote Control Devices Settings

Changes that have been made to the map, for example, changing the name of a 
control, can be saved, reset, undone, and removed in the Control Editor section of 
the Remote Devices tab.

• To save any changes that you have made, click Save.

• To restore the factory preset of a MIDI remote control device, click Reset. If 
the control device does not have factory presets, the map is cleared.

• To undo your last action, click Undo.

• To remove the control definition of the selected control or to unassign the 
selected control, click Clear.

Using Modifiers for Remote Controlling Parameters

You can use the same controller for controlling different parameters, using one or 
two modifiers. A modifier can be a MIDI control (for example, a foot switch) or a 
modifier key on your computer keyboard (for example, [Shift] and/or 
[Ctrl]/[Command]).

To determine one or two modifiers, open the Remote Devices tab, and when 
editing a parameter, select the modifiers from the Conditions section.

You can use the [Shift] and [Alt]/[Option] modifiers to alter the edit steps of infinite 
knob controls as follows:

• Press [Shift] to edit values in small steps.

• Press [Alt]/[Option] to edit values in bigger steps.

CC121 Advanced Integration Controller

You can use Steinberg’s CC121 Advanced Integration Controller to control 
WaveLab Pro.

This section describes the WaveLab Pro factory preset for the CC121. For detailed 
information on how to use the controller, refer to the manual that came with the 
CC121. Note that the CC121 was originally designed for Cubase. The following 
mapping combines the WaveLab Pro functionality with the CC121 controls. The 
controls that are not listed in the following paragraph are not assigned to a 
parameter.
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Channel Section

You can use all controls of the CC121 channel section, except the fader, to control 
the elements of the selected track in a WaveLab Pro audio montage. You can use 
the fader for the Master Section.

Fader

Controls the Master Section fader.

PAN knob

Controls the gain of the selected track.

Mute

Mutes/Unmutes the selected track.

Solo

Activates/Deactivates solo for the selected track.

CHANNEL SELECT

Selects the previous/next track in the audio montage.

To move the cursor to the previous/next clip edge in the audio montage, hold 
[Alt]/[Option]. To move the cursor to the previous/next region edge, hold 
[Shift]. To move the cursor to the previous/next marker in the Audio Editor, 
hold [Ctrl]/[Command].

EQ Section

With the EQ section you can easily control the Steinberg Studio EQ plug-in.

If the EQ TYPE button is activated on the CC121, you can adjust the parameters 
of the focused Studio-EQ. All necessary EQ parameters, such as Q/F/G of each 
band, EQ TYPE selection, and ALL BYPASS on/off can be set. You can switch to 
WaveLab Pro navigation mode by turning off the EQ TYPE button. In WaveLab Pro 
navigation mode, you get access to alternative functions, such as scrolling, 
zooming, and switching between windows.

EQ TYPE activated:

Bandwidth knobs (Q)

Adjusts the Q (bandwidth) of each EQ band.

Frequency knobs (F)

Adjusts the center frequency of each EQ band.

Gain knobs (G)

Adjusts the gain of each EQ band.

ON

Activates/Deactivates the EQ bands.
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ALL BYPASS

Activates/Deactivates bypass for all plug-ins in the Master Section.

EQ TYPE deactivated:

LOW ON

Opens the Audio Editor.

LOW-MID ON

Opens the Audio Montage window.

HIGH-MID ON

Opens the Batch Processor window.

HIGH ON

Opens the preferences tab.

EQ-1 knob for the EQ Gain (G)

Scrolls left/right on the timeline.

EQ-2 knob for the EQ Gain (G)

Adjusts the horizontal zoom on the timeline.

EQ-3 knob for the EQ Gain (G)

Adjusts the vertical zoom on the timeline.

EQ-4 knob for the EQ Gain (G)

Scrolls tracks on the Audio Montage window or scrolls vertically on the 
Audio Editor.

EQ-1 knob for the EQ Frequency (F)

Scrolls left/right on the overview timeline of the Audio Editor.

EQ-2 knob for the EQ Frequency (F)

Horizontally zooms in/out on the overview timeline of the Audio Editor.

EQ-3 knob for the EQ Frequency (F)

Vertically zooms in/out on the overview timeline of the Audio Editor.

EQ-4 knob for the EQ Frequency (F)

Vertically scrolls on the overview timeline of the Audio Editor.

Transport Section

In this section you can control the transport functions of WaveLab Pro.

Previous button

Moves the cursor position to the left.
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Rewind button

Moves the edit cursor position to the left.

Forward button

Moves the edit cursor position to the right.

Next button

Moves the cursor position to the right.

Cycle button

Activates/Deactivates Cycle mode.

Stop button

Stops playback. Press again to move the cursor to the previous start position. 
Press a third time to move the cursor to the beginning of the project.

Play button

Starts playback.

Record button

Press once to open the Recording dialog. Press again to start the recording. 
Press a third time to stop recording. The recorded file opens in the Audio 
Editor.

Function Section

In this section, you can adjust functions, such as fades and envelope level, by using 
the VALUE knob.

VALUE knob

Rotate this knob to adjust the assigned function. Press the knob to reset the 
parameter to its default value.

FUNCTION button 1

Adjusts the fade in settings of the active clip.

FUNCTION button 2

Adjusts the fade out settings of the active clip.

FUNCTION button 3

Adjusts the envelope level of the active clip.

FUNCTION button 4

The element clicked last in the Nudge section of the Edit tab in the Audio 
Montage window is assigned to this button.
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AI Knob Section

WaveLab Pro can be controlled with the AI knob of Steinberg’s CC121, CI2+, and 
CMC-AI controllers. With the AI knob, you can control the parameter that the 
mouse points to.

NOTE

The AI knob only works on parameters that are automatable.

In this section you can control parameters via the AI knob.

AI KNOB

Controls the VST 3 plug-in parameters, emulates the mouse wheel, for 
example, for scrolling, and lets you edit a focused numeric field. To control a 
parameter with the AI knob, move the mouse cursor over the parameter that 
you want to control, and move the AI knob. You can activate/deactivate the 
emulation of the mouse wheel and the editing of the focused numeric field in 
the Options tab.

LOCK

When the mouse cursor points to a parameter, press LOCK to control this 
parameter regardless of the position of the mouse cursor.

JOG

Activates Jog mode. While Jog mode is activated, press LOCK to enter 
shuttle mode.

CUBASE READY Indicator

The CUBASE READY indicator has no function in WaveLab Pro.

Foot Switch Section

The foot switch has the same function as [Shift]. Press and hold the foot switch 
while turning the AI knob to fine tune parameters.
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WaveLab Pro Concepts

This chapter describes general concepts that you will use when working with 
WaveLab Pro. Getting accustomed with these procedures allows you to work more 
effectively with the program.

General Editing Rules

The common editing operations apply to any Steinberg product.

• To select and move interface items, and to select ranges, click and drag with 
the mouse.

• Use the keys of your computer keyboard to enter numeric values and text, to 
navigate lists and other selectable interface items, and to control the transport 
functions.

• Common operations like cut, copy, paste, or the selection of multiple items 
can be performed using standard keyboard shortcuts.

NOTE

The behavior of your product is also governed by your preference settings.

Startup Dialog

When WaveLab Pro starts, the Startup dialog opens where you can select which 
project or project template you want to open.
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Create

Empty Project

Creates an empty project.

My Default Project Template

Opens the default startup project template. The default project is defined on 
the Template page. If no default project is defined, an empty project is 
created.

Templates

Allows you to open a template in a new project.

Open

Last Project

Opens the project that you last used in WaveLab Pro, including all files that 
were open.

Recent Project

Allows you to open a recently used project.

Recent Files

Allows you to open a recently used file.

Browse

Allows you to select the files that you want to open.
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Use as Default (Do Not Show This Dialog Again)

If this option is activated, the option that you select is used from now on and 
the startup screen does not open anymore. To display the Startup dialog, 
even if this option has been activated, press [Ctrl]/[Command] when starting 
WaveLab Pro.

RELATED LINKS

Workspace Layout on page 658

Basic Window Handling

WaveLab Pro follows the basic guidelines for the Windows/Mac OS interface, 
which means that Windows/Mac OS standard procedures apply.

Closing Windows

• To close a file group tab or a file tab, click the X button of the corresponding 
tab or press [Ctrl]/[Command]-[W].

• To close a file tab without saving your changes, hold [Ctrl]/[Command]-[Shift], 
and click the X button of the tab. This avoids having to confirm a warning 
message whenever you want to close an unsaved tab.

• To close all files of a file group at once, right-click a file group tab and select 
Close All Files.

• To close all file tabs but the selected file tab, right-click a file tab and select 
Close All But This.

• To individually select the file tabs that you want to close, right-click a file group 
tab and select Select Files to Close. This opens the Files to Close dialog, 
where you can select the files that you want to close.

• By default, files are removed from the project when you close them. To keep 
the files in the project even when you close them, right-click a file tab and 
activate Keep in Project after Closing.

RELATED LINKS

Permanently in Project vs. Temporarily in Project on page 74

Switching Between Files

You can have multiple files open and switch between them.

• To bring a file to the front, click the corresponding tab.

• To cycle between the files, hold [Ctrl]/[Command], and press [Tab] 
continuously.
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• To cycle back and forth between the last two active files, press 
[Ctrl]/[Command]-[Tab]. Between each step you have to release all keys.

• To cycle backwards, press [Ctrl]/[Command]-[Shift]-[Tab].

• To toggle between the active file and the last edited file, press [F5].

Selecting Audio

Almost all types of editing and processing that you perform in WaveLab Pro operate 
on the audio selection. There are numerous ways to make an audio selection.

• To select the whole audio file, double-click it. If the audio file contains markers, 
triple-click it.

Selecting a Range by Dragging

The standard way to select a range in the wave window is to click and drag.

If you drag all the way to the left or right side of the wave window, it scrolls 
automatically, allowing you to select larger sections than what can be shown in the 
wave window. The speed of the scrolling depends on how far from the wave 
window edge you are.

Audio Range Selection in an Audio File

You can edit, process, or play back selections of an audio file.

• To access the audio range selection options, in the Audio Editor, select the 
Edit tab.

The following selection options are available in the Time Selection section:

Range

If you click Range, the Range Selection dialog opens. In this dialog, you can 
define selection ranges very accurately.

If you click the arrow to the right of the Range button, the presets list opens. 
In the presets list, you can select between the selection range factory presets 
and your custom presets.

All

Selects the entire waveform.

Toggle

Toggles the selection range on/off.

Extend

Opens a menu where you can select the following options:



WaveLab Pro Concepts
Selecting Audio

31

• Extend to Start of File extends the selection to the start of the audio 
file. If there is no selection, a selection is created from the edit cursor 
position.

• Extend to End of File extends the selection to the end of the audio file. 
If there is no selection, a selection is created from the edit cursor 
position.

• Extend to Previous Marker extends the left edge of the selection to the 
nearest marker to the left or the start of the audio file. If there is no 
selection, a selection is extended until the edit cursor position.

• Extend to Next Marker extends the right edge of the selection to the 
nearest marker to the right or the end of the audio file. If there is no 
selection, a selection is extended until the next marker position.

• Extend to Cursor extends the selection to the edit cursor position.

• From Start of File Until Cursor selects the range between the start of 
the audio file and the edit cursor position.

• From Cursor to End of File selects the range between the edit cursor 
position and the end of the audio file.

• From Cursor to Previous Marker selects the range between the edit 
cursor position and the previous marker or the start of the audio file.

• From Cursor to Next Marker selects the range between the edit 
cursor position and the next marker or the end of the audio file.

• From Playback Position to End of Audio File creates a selection 
range from the playback position to the end of the audio file. If no 
playback is taking place, the position of the edit cursor is used.

• From Playback Position to Start of Audio File creates a selection 
range from the playback position to start of the audio file. If no playback 
is taking place, the position of the edit cursor is used.

• Double Selection Length doubles the length of the current selection 
range.

• Halve Selection Length halves the length of the current selection 
range.

Channels

Opens are menu where you can select the following options:

• Extend to All Channels extends the current selection range to all 
channels.

• Left Channel Only reduces the current selection range to the left 
channel only.

• Right Channel Only reduces the current selection range to the right 
channel only.

Regions

Opens are menu where you can select the following options:



WaveLab Pro Concepts
Selecting Audio

32

• CD Track selects the range between the two CD track markers that 
encompass the edit cursor.

• Loop Region selects the range between the two loop markers that 
encompass the edit cursor.

• Exclusion Region selects the range between the two exclusion 
markers that encompass the edit cursor.

• Generic Region selects the range between the two generic markers 
that encompass the edit cursor.

RELATED LINKS

Range Selection Dialog on page 33

Audio Range Selection in an Audio Montage

You can edit, process, or play back selections of an audio montage.

• To access the audio range selection options, in the Audio Montage window, 
select the Edit tab.

The following selection options are available in the Range section:

Range

If you click the Range button, the Range Selection dialog opens. In this 
dialog, you can define selection ranges very accurately.

If you click the arrow on the right of the Range button, the presets list opens. 
In the presets list, you can select between the selection range factory presets 
and your custom presets.

Extend

Opens are menu where you can select the following options:

• Double Selection Length doubles the length of the current selection 
range.

• Halve Selection Length halves the length of the current selection 
range.

• From Playback Position to End of Montage creates a selection range 
from the playback position to the end of the audio montage. If no 
playback is taking place, the position of the edit cursor is used.

• From Playback Position to Start of Montage creates a selection 
range from the playback position to start of the audio montage. If no 
playback is taking place, the position of the edit cursor is used.

Toggle

Toggles the current selection range on/off.

RELATED LINKS

Range Selection Dialog on page 33
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Range Selection Dialog

This dialog allows you to specify an audio range for editing, processing, or playing 
back.

• In the Audio Editor or the Audio Montage window, select the Edit tab, and 
click Range.

From/To Sections

Zero/End

The selection begins at the start/end of the file.

Cursor

The selection begins at the edit cursor.

Start/End of Selection

The selection begins at the start/end of the selection range.

Marker (with Name)

The selection begins at the marker that is selected from the pop-up menu 
below.

Offset (±)

Allows you to specify an offset for the selected position.

Custom

Allows you to specify a start/end time for the selection.

Options Section

Specify Length

Allows you to specify the selection length.
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Set as Selection Length

Clicking this button freezes the current selection length. This is useful if you 
want to move the selection.

Round Down Length

If this option is activated, the selection length is rounded down to the length 
specified in the value field.

Snap to Zero-Crossing

If this option is activated, the start and the end of a selected range always 
snap to a zero-crossing point of the waveform.

Channels

Select whether the selection spans the left channel, the right channel, or both.

Play Section

With the play options, you can preview the specified audio range.

Play to

Plays the range before the specified position.

Play from

Plays the range after the specified position.

Play Once

Plays the selection once.

Play Looped

Plays the selection in a loop.

Play Duration

Sets the playback length. Note that this overrides the From/To parameters.

Memorizing Selection Length and Cursor Position

You can copy the length of a selection range and the edit cursor position to an 
internal memory. This is useful if you want to use these values in several places in 
WaveLab Pro.

• To save the length of the active selection range, in the Audio Editor or the 
Audio Montage window, select the Edit tab, and right-click Copy. Here, 
select Memorize Selection Length.

• To save the position of the edit cursor, in the Audio Editor or the Audio 
Montage window, select the Edit tab, and right-click Copy. Here, select 
Memorize Cursor Position.

• To apply the memorized information, right-click any time edit field and select 
Set Memorized Position or Set Memorized Duration.
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Selecting in Stereo Files

If you are working on stereo material in the Audio Editor, you can apply an operation 
to one channel only or to the entire stereo material.

Which channel is selected when you click and drag in the wave window depends 
on where you position the mouse cursor. The pointer shape indicates which channel 
will be affected.

The following pointer shapes are available:

Select left channel

Clicking in the upper half of the left channel selects the left channel.

Select both channels

Clicking in the middle area between the left and the right channel selects both 
channels.

Select right channel

Clicking in the lower half of the right channel selects the right channel.

Switching the Selection Between Channels

You can switch the channel selection that you have made for a channel to all 
channels or switch the selection to the other channel.

PROCEDURE

1. In the wave window of the Audio Editor, select a range.

2. Select the Edit tab.

3. In the Time Selection section, click Channels and select one of the following 
options:
• Extend to All Channels

• Left Channel Only

• Right Channel Only

You can press [Tab] to switch between the different channel selections.
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Selecting in the Overview of the Audio Editor

The ranges that you select in the overview of the Audio Editor also apply to the main 
view.

PROCEDURE

• In the wave window of the Audio Editor, hold down [Ctrl]/[Command] and 
click and drag in the overview.

Moving a Selection Range

If a selection range has the correct length, but the wrong position, you can move it.

PROCEDURE

1. In the wave window, hold down [Ctrl]/[Command]-[Shift].

2. Click in the middle of the selection and drag to the left/right.

Extending and Reducing the Selection

You can resize a selection range in the wave window or the montage window.

There are several ways to extend/reduce the selection:

• Select a range, [Shift]-click outside the selection range, and drag to the 
left/right, or click and drag the edges of the selection range to the left/right.

• To extend the selection to the previous/next boundary (marker or start/end of 
file), press [Shift] and double-click the non-selected area between the 
boundaries.

Extending and Reducing the Selection Using the Cursor Keys

• To move the start/end of a selection in the wave window to the left/right, hold 
down [Shift] and press the left/right cursor keys. To move it in bigger steps, 
press the [Page Up]/[Page Down] keys.

• To extend a selection to the previous/next boundary in the wave window 
(marker or start/end of the audio file), hold down [Ctrl]/[Command]+[Shift] 
and press the left/right cursor keys.

Deleting Selections

There are several options for deleting a selected range.
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Audio Editor

The following options can be found on the Edit tab in the Cutting section.

Crop

Removes the data outside the selection.

Delete

Removes the selection. The audio to the right of the selection is moved to the 
left to fill the gap.

Smooth Delete

Removes the selection. Crossfades are inserted at the edges. You can edit 
the default crossfade length and its type in the Audio Files Preferences, on 
the Editing tab.

Audio Montage Window

The following options can be found on the Edit tab in the Selection section.

Crop Clip

Removes the data outside the selection.

Erase Selected Range

Erases the clip parts inside the selection range on the selected track, without 
filling the gap.

Erase Selected Range on All Tracks

To access this option, click the arrow icon at the right of the Erase Selected 
Range option. Erases the clip parts inside the selection range on all tracks, 
without filling the gap.

Delete Selected Range

If there is a selection range, the clip parts inside the selection range on the 
selected track are deleted and the right section of the clips is moved to the 
left to fill the gap.

If there is no selection, the selected clips are deleted.

Delete Selected Range on All Tracks

To access this option, click the arrow icon at the right of the Delete Selected 
Clips option. Deletes the clip parts inside the selection range on all tracks and 
moves the right section of the clips to the left to fill the gap.

Sliders

At various places in WaveLab Pro, slider controls are available to change 
parameters. There are a number of ways to change the value of a slider.
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• Position the mouse over the slider and use the mouse wheel without clicking. 
Hold [Ctrl]/[Command] while using the mouse wheel to scroll faster. This 
modifier also applies to the zoom wheels. To move a slider, click and drag it.

• To move the slider handle to a position, click the slider at any position.

• To move the slider handle in smaller steps, right-click or click below the 
handle. Keep the mouse button pressed to automatically step to the next 
value.

• To reset the slider to the default value, if available, [Ctrl]/[Command]-click the 
slider, or click using the third mouse button, or double-click the handle.

Renaming Items in Tables

You can rename items in tables in the Markers window, the CD window, and the 
Clips window.

• To rename an item, double-click it or select it, and press [Return], and enter 
the new name.

• To rename the previous/next item, press [Up Arrow] or [Down Arrow]. This 
way you move the focus on the previous/next item, while staying in the edit 
mode.

File Browser

The File Browser window allows you to browse files from within WaveLab Pro. The 
Auto Play Mode is useful for speeding up the process of auditioning sound files.

The File Browser window provides you with all the standard browsing functions. It 
features additional controls to audition audio files and any marker defined regions. 
You can use it to open or insert files by dragging them to another location.

You can also choose to only view specific file types.

File Browser Window

In this window, you can browse files and open them in WaveLab Pro.

• To open the File Browser window, select Tool Windows > File Browser.
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Back/Forward/Parent Directory

Allows you to navigate through the list and file hierarchy.

Location

This menu lets you select a file location to browse and lists the recently used 
locations.

Auto-Play Mode

Automatically starts playback of the selected file.

Play Selected Audio File

Plays the selected audio file.

Search

If this button is activated, you can enter text in the search field.

File format list

Allows you to select which file format to display.

Folder tree

Shows the folders that are available on your computer.

Favorite folders

You can add your favorite folders by dragging them from the folder tree.

File list

Shows the file name, size, type, modification date, and other information about 
the file.

Create Folder

Allows you to create a new folder. Right-click in the file list and select Create 
Folder.

Audio Regions

If the selected file contains region markers, the regions are displayed in the 
Audio Regions section. You can drag regions onto a track.
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Tab Groups

With tab groups, you can view the content of different files, tool windows, or meters 
at the same time, without having to navigate through different windows. Each tab 
group has its own content and tab bar.

In a Control Window, a tab group can contain tool windows and meters. You can 
have three file tab groups.

Empty File Tab Groups
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File Tab Groups with Audio Montages

Tab Groups in Control Window

RELATED LINKS

Control Window on page 49
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Creating File Tab Groups

PROCEDURE

1. In the top right of a file tab window, open the Tab Group pop-up menu.

2. Select Create a Tab Group (Split Vertically) or Create a Tab Group (Split 
Horizontally).

Creating File Tab Groups in Empty Tab Groups

PROCEDURE

• In the top right of an empty file tab group, click Create a Tab Group (Split 
Vertically) or Create a Tab Group (Split Horizontally).

Using Tab Groups

The Tab Group button in the top right of each tab window allows you to maximize, 
move, and close tab groups. Tabs are used differently depending on the type of 
window.

Tool Window Tab Groups

• To hide a tool window tab group, open the Tool Window Tab Group Options 
pop-up menu and select Hide All.

• To reorder tabs in a tab group, drag the tab horizontally to a new position on 
the tab bar.

• To dock the tab group to another location, open the Tool Window Tab Group 
Options pop-up menu and select Dock Tab Group Elsewhere. Now you can 
select where to dock the tab group.

• To dock the tab group to the Control Window, open the Tool Window Tab 
Group Options pop-up menu and select Dock Tab Group to Control 
Window.

Now you can select to which Control Window you want to dock the tab 
group.
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File Tab Groups

• To close a file tab group, click the Tab Group button and select Hide All.

• To reorder tabs in a tab group, drag the tab horizontally to a new position on 
the tab bar.

• To move a tab to another project, drag the tab to another project.

• To paste the content of a tab into an audio file, drag the tab onto the 
waveform. The tab is inserted at the cursor position.

• To maximize the active file tab group, open the File Tab Group Options 
pop-up menu, and select Hide Other File Tab Groups.

To show all file tab groups, open the File Tab Group Options pop-up menu, 
and select Show Other File Tab Groups.

You can also double-click the file tab header of a tab group to show/hide 
other file tab groups.

Peak Files

A peak file (extension .gpk) is automatically created by WaveLab Pro each time an 
audio file is modified or opened in WaveLab Pro for the first time. The peak file 
contains information about the waveform and determines how it is drawn in the 
wave window or the montage window.

Peak files speed up the time it takes to draw the corresponding waveform. By 
default, the peak file is saved in the same location as the audio file.

Setting the Peak File Behavior

The peak file behavior can be set in the Audio Files Preferences on the File tab.

• To save peak files in another location, activate Create Peak Files in an 
Independent Folder, select Edit, and specify another file location.

• To create peak files when writing audio files, activate Create Peak Files 
When Writing Audio Files.

• To delete peak files when closing audio files, activate Delete Peak Files 
When Closing Audio Files.

RELATED LINKS

Audio Files Preferences on page 706
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Rebuilding Peak Displays

Normally, peak files are automatically updated when the date of the peak file is older 
than the date of the audio file. However, it can happen that the date of the audio file 
is not automatically updated. In this case you can force a rebuild of the peak file.

PROCEDURE

1. In the Audio Editor, select the View tab.

2. In the Peaks section, click Rebuild Files.

Companion Files

Companion files (extension .vs) contain Master Section presets and view settings 
for audio files. If this feature is activated when you save a file, the settings are 
recreated the next time that you load the file.

Companion files are only available in the Audio Editor.

The following view settings are included in companion files:

• Window size and position

• Zoom level

• Scroll position

• Display mode (Waveform/Spectrum/Loudness)

• Snapshots

• Master Section presets associated with the file

Deleting a companion file does not alter the audio contents. Master Section 
presets are specific to WaveLab Pro and can therefore not be integrated inside the 
various audio file headers.

Storing Companion Files in Another Location

By default, companion files are saved in the same location as the audio file. 
However, you can select another file location.

PROCEDURE

1. Select File > Preferences > Folders.

2. Click Companion Files and specify another file location.
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EBU Loudness Standard R-128

The EBU loudness recommendation R-128 establishes well-defined methods to 
measure loudness, dynamics, and peak values, and also defines reference values to 
achieve for these measurements. Though the reference values are intended for the 
broadcast world, the measurement methods are helpful in any application dealing 
with audio and loudness control.

WaveLab Pro supports these audio measurements in many places, for metering, 
audio analysis, and processing. The following text gives some basic information 
about the EBU R-128 standard.

Loudness Measurement

This method takes into account the frequency sensitivity of the human ear to 
loudness levels. There are 3 types of measurements:

1) Integrated loudness, also called program loudness: this reports how loud an 
audio piece is, on average. This measurement uses a gating method to ignore 
long periods of silence.

2) Short-term loudness: this measures the loudness every 1 second on an audio 
block of 3 seconds. This gives information about the loudest audio passages.

3) Momentary loudness: every 100 ms, a range of 400 ms of audio is measured. 
This gives instantaneous feedback about the loudness.

Loudness Range

This measures the dynamics of the audio signal. It reports the ratio between the 
loudest and the quietest (but non-silent) sections. The audio is divided into small 
blocks. There is one audio block every second and each block lasts 3 seconds 
(analyzed blocks overlap).

The top 10 % of the quiet blocks and the top 5 % of the loud blocks are excluded 
from the final analysis. The calculated loudness range is the ratio between the 
loudest and quietest remaining audio blocks. This measurement helps to decide if 
and how much compression or expansion can or should be applied to the audio.

True Peaks

When a digital signal is converted to an analog signal, the EBU R-128 recommends 
measuring an estimation of the real peaks, rather than relying on digital peaks, to 
avoid clipping and distortion. This is accomplished by over-sampling the signal 4 
times and retaining the peak values.

Naming and Units

The EBU R-128 proposes naming and units conventions:

• A relative measurement, such as a value relative to a reference level: “LU” as 
“Loudness Unit” (1 LU is 1 dB).
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• An absolute measurement, “LUFS” as “Loudness Unit Full Scale”. 1 LUFS 
can be understood as 1 dB in the AES-17 scaling.

When WaveLab Pro relates to the EBU R-128 loudness, these units are used 
rather than dB.
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Workspace Window

The Workspace window provides an editing and playback environment for each 
particular file type. Each environment allows functions according to the specific 
purpose of each file type.

• Audio Editor for viewing and editing audio files.

• Audio Montage window for assembling and editing audio montages.

• Batch Processor window for processing a list of audio files with offline 
effects, VST plug-ins, and Master Section presets.

• Podcast Editor for preparing and uploading podcasts.

• Basic Audio CD window for assembling and writing Basic Audio CDs.

• DVD-Audio window for authoring DVD-Audio and writing it to DVD.

• Script Editor for writing and executing scripts in WaveLab Pro.

• Control Window for hosting and organizing tool windows, especially in a 
multi-monitor setup.

The Workspace window is highly customizable to match your workflow.

Elements of the Workspace Window

The Workspace window contains the following elements:

• A menu bar

• Tab groups to host the files to edit. You can move the content of a tab to 
another tab, create a new empty tab, display the file path, and access other 
functions by right-clicking.

• A set of tool windows. Which tools are available depends on the file type you 
are working on. The tool windows can be activated/deactivated individually.

Audio Editor

The Audio Editor provides tools and functions for sample-accurate audio editing, 
high-quality analysis, and processing.

Features include various metering tools, a signal generator, a compare function, and 
a tool for correcting errors.
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The wave window gives you a graphical representation of the audio file and allows 
you to view, play back, and edit the file.

RELATED LINKS

Audio File Editing on page 129

Audio Montage

In the Audio Montage window, you assemble audio clips into a montage. You can 
arrange, edit, and play back clips on an unlimited number of both stereo or mono 
tracks.

Features include track and clip-based effects, volume and pan automation, and 
wide-ranging fade and crossfade functions. You can use the Audio Montage 
window for creating music CDs, mastering, multimedia work, radio spot production, 
etc. You can create multitrack compositions and author professional audio CDs or 
DVD-Audio. Depending on the channel configuration of the montage, you can route 
each track to different surround channels (up to 6) or non-surround channels (up to 
8).

You can place any number of clips on an audio track. A clip contains a reference to 
a source audio file on your hard disk, as well as start and end positions in the file.

The montage window gives you a graphical representation of clips on tracks. In it 
you can view, play back, and edit the tracks and clips.

RELATED LINKS

Audio Montage on page 233

Batch Processor

This editor allows you to batch process any number of audio files or audio montage 
files using the plug-ins and presets of the Master Section, offline effects, and other 
plug-ins that are unique to batch processing.

You can save the processed file in a different file format, rename files, and run an 
external application when the batch is finished.

RELATED LINKS

Batch Processing on page 586

Podcast Editor

In the Podcast Editor, you assemble, define, and publish your podcast to the 
Internet.
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RELATED LINKS

Podcasts on page 649

Basic Audio CD

In the Basic Audio CD window, all tracks of the Basic Audio CD are listed. Here 
you can assemble and write Basic Audio CDs that are compatible with the Red 
Book standard.

RELATED LINKS

Basic Audio CD on page 483

DVD-Audio

In the DVD-Audio window, you author DVD-Audio and write it to DVD.

RELATED LINKS

DVD-Audio on page 492

Script Editor

In the Script Editor, you write and execute scripts.

RELATED LINKS

Scripting on page 679

Control Window

A Control Window can contain multiple tool windows and meter windows. This is 
useful if you have multiple monitors. You can place the Control Window on your 
secondary display and use it to manage the tool windows and meter windows that 
you use most.

You can create up to 4 different control windows.
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Docking Tool Windows and Meters in a Control Window

You can dock any tool window and meter window in a Control Window.

PROCEDURE

1. Right-click the tab of the tool window or meter that you want to dock in the 
Control Window.

2. Select Dock to Control Window and select one of the Control Windows 
from the submenu.

Docking Tab Groups in a Control Window

You can dock tab groups in a Control Window.

PROCEDURE

1. Click the Options button on the right of the caption bar of a tab group.

2. Select Dock Tab Group to Control Window and select a Control Window 
from the submenu.

File Tab

The File tab is the control center of WaveLab Pro. Here, you can save, open, render, 
import, and export files. It also gives you detailed information about your files and 
allows you to set up the WaveLab Pro preferences.
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Info

Provides information about the active file and allows you to edit the audio 
properties of audio files and audio montages.

New

Allows you to create audio files, audio montages, batch processors, file 
groups, projects, Basic Audio CDs, DVD-Audio files, podcasts, and script 
files. You can create new files or use a template.

Open

Allows you to open audio files, audio montages, batch processors, projects, 
Basic Audio CDs, DVD-Audio files, podcasts, or script files.

You can also open files that you have previously copied to the clipboard in the 
File Explorer/Mac OS Finder.

Import

Allows you to open different file formats. The following formats are supported:

• Audio File to Montage

• DDP

• CD Cue

• AES-31

• XML

• Unknown Audio
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• File Groups

You can also import audio CD tracks from an audio CD.

Save As

Allows you to save the active file or the project. You can specify the name, file 
format, and location. You can also save a copy of the active file.

Save All

Allows you to save all changed files of your project at once. The file list gives 
you an overview of all files that have been changed.

You can use the filter to show all changed files, only audio files, only audio 
montages, or all other files, for example, batch processor files.

Export

Allows you to render the active file, export the file group to a text file, export 
audio montages to AES-31 and XML, and upload the audio file to 
SoundCloud.

Preferences

Allows you to view and change the preferences of WaveLab Pro. You can set 
up the preferences for the following parts of WaveLab Pro:

• Global

• VST Audio Connections

• Shortcuts

• Plug-ins

• Remote Devices

• Folders

• Variables

• Audio Files

• Audio Montages

Tools

Allows you to access the following tools:

• DDP to CD

• Data CD/DVD

• Auto Split Audio Files

• Signal Generator

• DTMF Generator

• Batch Conversion

• Batch Renaming

RELATED LINKS

Info Tab on page 53
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Configuring the Software on page 700

Info Tab

The Info tab provides information about the active file and allows you to edit the 
audio properties of audio files and audio montages.

• To open the Info tab, select the File tab, and click Info.

Depending on the selected file, different information and options are available.

Name

Displays the name, file extension, and file location of the active file. You can 
edit these attributes.

File Properties

Displays the size, date, and file format of the active file.

Audio Properties

For audio files, this displays the bit resolution, channels, and sample rate of 
the active file.

For audio montages, this displays the mode, channels, and sample rate of the 
active file.

You can edit these attributes.
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Sample Attributes (audio files only)

Displays the musical attributes tune, key range, and velocity range.

Meta-Data

Displays the meta data of the active file.

Copy to Clipboard

Opens a menu from which you can select which information about the active 
file you want to copy to the clipboard.

Reveal in File Explorer/Mac OS Finder

Opens the File Explorer/Mac OS Finder to show the location of the active file.

Delete

Deletes the active file.

Tool Windows

Throughout WaveLab Pro there are various tool windows available that allow you to 
view, analyze, and edit the active file.

Generally, the content of a tool window is synchronized with the active file, with the 
exception of the audio meters which displays the audio file being played back. Tool 
windows can be docked and undocked, and saved in your custom layouts. Some 
tool windows are only available for specific file types.

The tool windows can be accessed via the Tool Windows menu.

Opening and Closing Tool Windows

You can close all tool windows that you do not need for your project.

• To open a tool window, select Tool Windows and select a tool window.

• To close a docked tool window, right-click the tool window tab and select 
Hide.

• To close an undocked tool window, click its X button.

Meter Windows

WaveLab Pro contains a variety of audio meters that you can use for monitoring and 
analyzing audio. Meters can be used to monitor audio during playback, rendering, 
and recording. Furthermore, you can use them to analyze audio sections when 
playback is stopped.

The meter windows can be accessed via the Meters menu.
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Opening and Closing Meter Windows

You can close all meter windows you do not need for your project.

• To open a meter window, select Meters and select a meter window.

• To close a docked meter window, right-click the meter window tab and select 
Hide.

• To close an undocked meter window, click its X button.

Slide-Out Windows

Slide-out windows are hidden in the frame of the Workspace window. When you 
hover the mouse pointer over the window name, the window slides out. It is hidden 
again, when you click anywhere else.

Slide-out window tab

An open slide-out window

Docking and Undocking Tool Windows and Meter 
Windows

Tool windows and meter windows can be used as docked windows, as floating 
windows, or as a slide-out window. You can freely drag around the windows and 
dock them at various locations.

• To undock a tool window or meter window, drag the corresponding tab to 
another position.

Now the tool window or meter window is a floating window which can be 
freely moved.

• To dock a tool window or meter window, click and hold the caption bar or click 
the Options button on the right of the caption bar and select Dock Tab 
Group Elsewhere.
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Yellow symbols indicate locations for docked windows, pink symbols indicate 
locations for slide-out windows. Drag the window to one of the locations.

• To dock a floating tool window or meter window at its last docked position, 
click the Options  button on the right of the caption bar and select Dock 
to Last Place Again.

• To dock a tool window or meter window to the Control Window, click the 
Options button on the right of the caption bar and select Dock to Control 
Window. You can then select to which Control Window you want to dock the 
tool window or meter window.

You can also drag and drop a tool window or meter window to the Control 
Window.

RELATED LINKS

Slide-Out Windows on page 55
Control Window on page 49

Setting the Transparency for Floating Windows

You can make the tool windows and meter windows become transparent if they are 
not the active window. For this, specify the transparency value in the global 
preferences and activate the transparency for each window individually.
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• To specify the transparency value, select File > Preferences > Global, and 
select the Display tab. In the Tool Windows section, specify the value in the 
Window Transparency field.

• To activate the transparency for a tool window or meter window, click the Tab 
Group button at the top right of the window, and select Auto Transparency.

RELATED LINKS

Global Preferences on page 700

Hiding the Caption Bar in Floating Meter Windows

To save screen space, the caption bar of floating meter windows can automatically 
be hidden if the window is not the active window. This can be set individually for 
each floating window.

PROCEDURE

1. In a floating meter window, click the Options  button at the top right of the 
window.

2. Select Auto Caption Bar.

Command Bar

The command bar of file windows allows you to create, open, and save files, and 
undo/redo changes. You can also use the text field to quickly find and access open 
files, and to trigger keywords.

New

Allows you to create an audio file, audio montage, batch processor, file group, 
project, Basic Audio CD, DVD-Audio, podcast, and script file. You can create 
new files or use a template.

Open

Allows you to open an audio file, audio montage, batch processor, project, 
Basic Audio CD, DVD-Audio, podcast, or script file.

Save

Saves the active file.
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Save As

Allows you to save the active file. You can specify the name, file format, and 
location. You can also save a copy of the active file.

Trigger Cubase Update

Updates the Cubase project if the active file was opened via the Edit in 
WaveLab option.

Undo

Allows you to undo changes.

Redo

Allows you to redo changes that were undone.

Navigate Backwards/Navigate Forwards

In the Audio Editor and Audio Montage window, this allows you to navigate 
to the previous/next cursor position, zoom factor, or selection range without 
undoing/redoing the edit operation.

File Search and Keywords

The text field allows you to search for open files and apply keywords.

Keywords are custom words that are assigned to a function in the Customize 
Commands dialog or to a preset in the Shortcut Definitions dialog.

Customize Command Bar

Allows you to select the buttons that you want to display on the command bar.

Maximize Window

Maximizes the window. To restore the window size, click the button again.

Layout Options

Allows you to determine the position of the command bar, transport bar, and 
file group tabs.

RELATED LINKS

WaveLab Exchange on page 583

Status Bar

The status bar at the bottom of the screen of the Audio Editor and the Audio 
Montage window shows information about the active window using the units 
specified in the rulers.

The information displayed on the status bar is updated depending on the cursor 
position and on the audio selection that you have made.
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Time/Level (dB)

Displays the time of the audio file at the mouse cursor position. In the Audio 
Editor, it also displays the level.

Audio Information at Edit Cursor

Displays the time at the position of the edit cursor. This information changes 
if you reposition the cursor.

• To define the cursor position, click the Audio Information at Edit 
Cursor field to open the Cursor Position dialog.

• To focus the cursor position, right-click the Audio Information at Edit 
Cursor field.

Audio Selection Indicator (Audio Editor)/Audio Range Indicator (Audio 
Montage)

In the Audio Editor, this displays the length of the current selection, or the 
total length of the audio file if no selection has been made.

In the Audio Montage window, this displays the length of the audio selection 
if a clip is selected, or the size of the audio montage.

If you have zoomed in, you can right-click the indicator to display the selected 
audio range, the active clip, or the whole file. Left-click the indicator to open 
the Audio Range dialog, where you can define or refine a selection.

Zoom Indicator

Displays the current zoom factor.

• To open a pop-up menu, that allows you to make additional zoom 
settings, click the indicator.

• To open the Zoom Factor dialog, that allows you to edit the zoom 
factor, right-click the indicator.

Sampler Key Indicator (Audio Editor only)

Indicates the key of the current audio file (if defined). Click the indicator to 
open the Sample Attributes window.

Audio Properties Indicator

In the Audio Editor, this displays the bit resolution and the sample rate. It also 
indicates whether the audio file is mono or stereo. Click the indicator to open 
the Audio Properties dialog.

In the Audio Montage window, this displays the number of audio channels 
and the sample rate of the audio montage. Click the indicator to open the 
Audio Montage Properties dialog.
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Bypass Master Section

If this button is activated, the Master Section is bypassed. If the button is 
deactivated, the audio is played through the Master Section.

Master Section Preset Setting pop-up menu

• Save Master Section Preset opens the Save Master Section Preset 
dialog, where you can save the active Master Section configuration 
inside the companion file or audio montage.

• Load Master Section Preset applies the Master Section with the 
configuration previously saved to the audio file or audio montage.

• If Include Master Section Preset when Rendering as Super Clip is 
activated, the Master Section preset that is saved with the audio 
montage is used when rendering super clips of audio montages (Audio 
Montage window only).

Background Information

The status bar shows the progress of some background operations, such as 
rendering an effect. The operation can be paused or canceled using the 
provided buttons.

Context Menus

Throughout WaveLab Pro, various context menus are available. These menus group 
the commands and/or options that are specific to the active window.

The context menus appear if you right-click specific areas and are useful for 
speeding up your workflow.

For example, right-click a file tab to open a context menu with some relevant file 
options. Right-clicking the ruler of the waveform window brings up the Time Ruler 
context menu that allows you to access a number of options for changing the time 
ruler display format.

You can find most context menu commands in the tabs, in the file window and in the 
main menus, but some commands are only available in context menus. If you search 
for a function, right-click the current working window to check if it has a context 
menu.
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Context menu in the montage window

Time Ruler and Level Ruler

In the Audio Editor, you can display a time and a level ruler in the wave window. In 
the Audio Montage window, you can display a time ruler in the montage window.

You can also determine which time and level units the rulers show.

Time Ruler

Level Ruler (Audio Editor only)
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Time Ruler and Level Ruler Options

You can specify the time and level (amplitude) formats for each ruler in each wave 
window and the time formats for each ruler in the montage window separately by 
right-clicking the ruler and selecting a format from the pop-up menu.

Time Ruler Menu

Timecode

Displays frames per second for various SMPTE timecode types and for CD 
resolution.

You can specify the timecode type in the Time Format dialog.

Clock

Displays time units.

Samples

Displays positions as number of samples. The number of samples per second 
depends on the sample rate of the audio file. For example, at 44.1 kHz, there 
are 44100 samples per second.

Bars and Beats

Displays bars and beats.

File Size (Audio Editor only)

Displays positions in megabytes. Decimals represent kilobytes.

Show grid (Audio Montage window only)

Displays vertical lines in the montage window, aligned with time ruler marks.

Time Format

Opens the Time Format dialog, that allows you to edit the appearance of the 
time ruler formats.

Save Current Settings as Default

If this option is activated, the time ruler uses the current time format in all new 
wave windows or montage windows.

Set Ruler’s Origin to Start of File

If this option is activated, the ruler’s zero position is set to the beginning of the 
first sample.

Set Ruler’s Origin at Cursor

If this option is activated, the ruler’s zero position is set to the current edit 
cursor position.

Set Ruler’s Origin to BWF Reference (Audio Editor only)

If this option is activated, the first sample matches the BWF time reference, 
provided that the time reference is available.
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Show Playback Range

If this option is activated, the time ruler displays the audio range that is played 
with the Play Audio Range command.

Show Playback Anchor

If this option is activated, a marker is displayed below the time ruler to indicate 
the audio anchor that corresponds to the Play From and Play To commands.

Show Pre-/Post-Roll

If this option is activated, the pre-roll and post-roll times are displayed.

RELATED LINKS

Time Format Dialog on page 64

Level Ruler Menu (Audio Editor only)

dB

Sets the level format to decibels.

+-100 %

Sets the level format to percentage.

Normalized +1/-1

Sets the level format to a ruler gradation corresponding to 32-bit float audio.

16-bit Range

Sets the level format to a ruler gradation corresponding to 16-bit audio.

24-bit Range

Sets the level format to a ruler gradation corresponding to 24-bit audio.

Save Current Settings as Default

If this option is activated, the level ruler uses the current level format in all new 
wave windows.

Working With a Meter-Based Display

If your working material is tempo-based, you can select the meter format (bars, 
beats, and ticks) for the ruler legend. This makes it easier to find musically related 
cutting points.

PROCEDURE

1. In the wave window or the montage window, right-click the time ruler, and 
select Bars and Beats.

2. Right-click the time ruler, and select Time Format.

3. On the Meter tab, set the Time Signature and Tempo to values that match 
your audio file.
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4. Set the Ticks per Quarter Note setting to a number that you feel comfortable 
with.
For example, this can be the same value that is used by your MIDI sequencer.

5. Click OK.

Setting the Edit Cursor Position

Many operations, such as playback and selection, depend on the current edit cursor 
position. For example, playback often starts at the edit cursor position. The current 
edit cursor position is indicated by a vertical flashing line.

There are various ways to move the edit cursor:

• Click somewhere in the wave window, the montage window, or the time ruler. 
If you have made a selection, click the time ruler to prevent deselecting.

• Click and drag in the time ruler.

• Use the transport controls.

• In the Audio Editor and Audio Montage window, select the View tab and use 
the options in the Cursor section.

• Use the cursor keys.

• Double-click a marker.

Setting the Ruler Start Position

By default, the audio file starts at the ruler position 0. However, you can set the 0 
position to another position of the file.

PROCEDURE

1. In the wave window or the montage window, right-click the time ruler, and 
select Time Format.

2. Select the Offset tab.

3. Select one of the Time Ruler Offset options, and click OK.

Time Format Dialog

In this dialog, you can customize the time format of the ruler. The time format of the 
ruler is also used in various time fields, for example, the status bar and some dialogs.

• To open the Time Format dialog, right-click the ruler in the Audio Editor or 
Audio Montage window, and select Time Format.

In the Audio Editor, you can set different time formats for the overview display 
and the main display.
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Timecode Tab

On this tab, you can configure the appearance of the Timecode option.

Frames per Second

Lists standard frame rates. From the pop-up menu, select Other to enter a 
custom frame rate. You can also choose which frames or units are displayed.

Show Absolute Frames

Shows the time format as a number of frames, without other time elements.

Show Quarter Frames

Adds the quarter frame number to the time format.

Show Hundredth Frames

Adds the number of a hundredth of a frame to the time format.

Show Units

Adds time units to the time format of the ruler.

Clock Tab

On this tab, you can configure the appearance of the Clock option.

Show Units

Adds time units to the time format of the ruler.

Compact

Shows the time without unit indicators.

Meter Tab

On this tab, you can configure the appearance of the Bars and Beats option.
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Time Signature

Lets you edit the time signature used to display the time represented as a 
musical notation.

Tempo

Lets you edit the tempo used to display the time represented as a musical 
notation.

Ticks per Quarter Note

Lets you edit the number of ticks per quarter note. These are used to display 
times that are compatible with your sequencer.

Offset Tab

On this tab, you can configure the Time Ruler Offset.

Zero (Default)

Deactivates the time offset in the ruler.

Set Zero-Point at Cursor Position

Sets the current cursor position to be the starting point of the ruler.

Set Zero-Point at BWF Time Reference (Audio Editor only)

If the audio file contains BWF meta-data, the corresponding time reference 
value is used as offset.

Set Time of First Sample

Specifies the time that corresponds to the zero point of the ruler.

Managing Tabs

A tab is a container for a file in WaveLab Pro. There are file group tabs and file tabs. 
You can open several tabs, but only one can be active at a time. The Tabs context 
menu of the file group tabs and file tabs offer tab related options.

File Group Tabs

The following options are available when you right-click a file group tab.

Save Modified Files

Allows you to specify which of the modified files of the file group you want to 
save.

Close All Files

Closes all file tabs.
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Select Files to Close

Opens the Files to Close dialog which allows you to specify the files to be 
closed.

Set Temporary Files to Permanent Files

Adds all files to the file group that are not a permanent part of the file group.

Close and Remove from Project

Closes the file group and removes it from the project.

Remove Other File Groups from Project

Removes all file groups but the active file group from the project.

Rename

Allows you to rename the file group.

Export File Names

Allows you to create a text file that lists all files that are used in the file group.

File Tabs

The following options are available when you right-click a file tab.

Check Tab/Uncheck Tab

Checks/Unchecks the tab. This allows you to render all file tabs at once via 
the Render tab.

To check/uncheck all tabs at once, activate/deactivate the checkbox at the 
right of the file tabs.

You can also drag the selected tabs to another file tab.

Add to

Allows you to add the active file to another editor.

Close

Closes the active tab.

Close All But This

Closes all files but the active file.

Keep in Project after Closing

If this option is activated, the file remains in the project after you close the file.

You can open the file again from the Project Manager window.

Info

Displays information about the active file.
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Reveal in File Explorer/Mac OS Finder

Opens the File Explorer/Mac OS Finder to show the location of the file.

Copy to Clipboard

Opens a menu, from which you can select which information about the file you 
want to copy to the clipboard.

Recent Files

Allows you to open recently used files.

New (Based on Active File)

Allows you to open a new file tab with the same settings of the source tab. 
This option is available if you right-click the empty area next to the file tabs.

Files to Close Dialog

In this dialog, you can specify which files you want to close.

• To open the Files to Close dialog, right-click a file group tab and select 
Select Files to Close.

Files list

Displays all open files. You can set a checkmark for the files that you want to 
close. By default, only the active file will remain open and all other files will be 
closed.

All/None

Allows you to select and deselect all files.

Temporary Project Files

Allows you to select all files that are opened in WaveLab Pro, but not set to 
Permanently in Project in the Project Manager.

Permanent Project Files

Allows you to select all files that are opened in WaveLab Pro and set to 
Permanently in Project in the Project Manager.
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Close Files

Closes the selected files.

RELATED LINKS

Project Manager Window on page 73

Activating Full Screen Mode

PROCEDURE

• Select Workspace > Full Screen.

Log Window

This window allows you to view log messages that have been issued by 
WaveLab Pro.

For example, when using the scripting language of WaveLab Pro, the logWindow( ) 
function outputs messages to this window. Toggle buttons allow you to filter the 
types of messages that are displayed.

• To open the Log window, select Tool Windows > Log.

Clear

Removes all messages from the window.

Show Errors

If this option is activated, error messages are displayed.

Show Warnings

If this option is activated, warning messages are displayed.

Show Notes

If this option is activated, notes are displayed.
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Project Handling

Opening Files

PROCEDURE

1. Select File > Open.

2. Select the file type that you want to open.
For example, Audio File.

3. From the file browser, select the file that you want to open.

4. Click Open.

Opening Files from the Clipboard

You can open files in WaveLab Pro that you have previously copied to the clipboard 
in the File Explorer/Mac OS Finder.

PROCEDURE

1. In the File Explorer/Mac OS Finder, copy the files that you want to open to the 
clipboard.

2. In WaveLab Pro, select File > Open.

3. Click Open Files from Clipboard.

RESULT 

The files open in new file tabs.

Automatically Opening Files in a Dedicated Tab Group

You can specify a precedented file type for each tab group. Files that open after 
rendering, audio files that you open from an audio montage, or files that you open 
via the File Explorer/Mac OS Finder are automatically opened in the corresponding 
tab group for this file type.

• To specify a precedented file type for a tab group, click File Tab Group 
Options  at the header of a tab group, and select a file type.
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WaveLab Projects

A project file (extension *.wpr) is the central document in WaveLab Pro. A project 
file contains references to media data.

Only one project can be open at a time. When you open a previously saved project 
or create a new project, the currently opened project is closed.

Each project can contain multiple file groups. Each file group has its own tab.

You can save your complete production as a project and open it on any 
WaveLab Pro workstation. For this, the source files must be available on the target 
workstation at the same relative or absolute path.

The Project Manager window gives you access to the files inside the project.

The active project is automatically saved and can be reloaded the next time that you 
start WaveLab Pro. If you create a new project, this will be the default project. The 
default project file is saved in the following location:

Windows

AppData\Roaming\Steinberg\WaveLab Pro 9\Cache\
DefProject.wpr

Mac

/Users/YourName/Library/Preferences/WaveLab Pro 9/
Cache/DefProject.wpr

RELATED LINKS

File Groups on page 75
Project Manager Window on page 73
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Creating Projects

You can create empty projects or projects that are based on a template.

PROCEDURE

1. Select File > New.

2. Click Project.

3. Do one of the following:
• To create an empty project, click Create Empty.

• To create a project that is based on a template, click Templates, and select a 
template.

RESULT 

If you selected Create Empty, a new, untitled project is created. If you selected a 
template, the new project is based on this template and includes the corresponding 
layout and settings.

RELATED LINKS

Templates on page 96
Creating a Template on page 96

Creating Default Projects

You can define a default project that you can select when starting WaveLab Pro. 
You specify the default project when creating a template.

PROCEDURE

1. Select File > New.

2. Select Project > Templates.

3. Click Add Template.

4. In the Project Template dialog, activate Set as Default Project.

5. Enter a project name.

6. Click Save.

RESULT 

The default project is created. You can select it in the WaveLab Pro Startup dialog.

To set another project template as the default project template, right-click the 
corresponding template and select Set as Default Project.

RELATED LINKS

Startup Dialog on page 27
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Saving Projects

The active project is automatically saved as a project file that can be reopened the 
next time that you start WaveLab Pro. However, you can also manually save the 
active project as a project file. This allows you to give the project a name and save 
the project file at another location.

To keep your projects as manageable as possible, make sure that you save project 
files and all related files in the corresponding project folders and subfolders.

PROCEDURE

1. Select File > Save As.

2. Click Project.

3. Enter the name and a file location.

4. Click Save.

Project Manager Window

The Project Manager window gives you access to all project files in WaveLab Pro 
and allows you to edit them.

• To open the Project Manager window, select Tool Windows > Project 
Manager.

You can click on a file or file group to bring it to focus. If the file or file group is not 
already open in WaveLab Pro, it is opened.

The toolbar contains the following options:

Sort Files by Type

If this option is activated, the files are grouped in subfolders according to their 
file type.

Select Multiple Files (for Drag and Drop)

If this option is activated, you can select multiple files in the projects list. You 
can then drag the files to an audio montage, for example.

Rename Selected File Group

Allows you to rename the selected group.
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The projects list contains the following options:

Open Status 

This column shows if a file is open in WaveLab Pro or not. To close a file, click 
its X button.

If a file is set to Permanently in Project, the corresponding file tab is closed, 
but the file remains available in the Project Manager. You can click the file 
name to reopen the file. If the file is set to Temporarily in Project, the 
corresponding file tab is closed and the file is removed from the Project 
Manager.

Permanently in Project/Temporarily in Project 

In this column, you can define if a file should be included as permanent part 
of the project or if the file is only temporarily needed in the project.

The lock icon indicates that the corresponding file is a permanent part of the 
project. The clock icon indicates that the corresponding file is temporarily in 
the project. Click the icon to change the file status.

If you drag files from the File Explorer/Mac OS Finder onto the file list in the 
Project Manager, the files are added permanently to the project. This allows 
you to quickly add multiple files to a project.

Modification Status 

In this column, you can see if a file in the project has been modified. Files that 
have been modified are indicated by a checkmark.

RELATED LINKS

Permanently in Project vs. Temporarily in Project on page 74

Permanently in Project vs. Temporarily in Project

Project can contain files that are permanently or temporarily in the project.

Permanent files

Files that are set to be permanently in the project stay part of the project even 
when you close the file.

Temporary files

Files that are set to be temporarily in the project are removed from the project 
once you close the file. When you close the project file, these remain in the 
project just like permanent files do.

When you open a new file, it is considered a temporary file. If you want to keep the 
file in the project even when you close the project, you must set the file to 
permanent.

RELATED LINKS

Project Manager Window on page 73
Changing the Permanent/Temporary Status of a File on page 75
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Changing the Permanent/Temporary Status of a File

To change the file status, do one of the following:

• Right-click a file tab of a temporary file and select Keep in Project after 
Closing.

• In the Project Manager, click the Permanently in Project/Temporarily in 
Project column of a file to change its status.

File Groups

File groups are part of WaveLab Pro projects. Each project can contain multiple file 
groups.

A file group can contain different file types. For example, audio files, audio 
montages, and batch processor files. This allows you to organize all files in one file 
group. You can also organize each file type in a different file group to have a better 
overview. In this case, the file group icon changes to the icon of the corresponding 
file type.

Each file group can contain multiple, customizable tab groups. For each tab group, 
you can define a type precedence to instruct WaveLab Pro in which tab group a file 
of a given type should be opened by default.

You can export file groups as text files. File groups can also be imported in a project 
via a text file that contains file paths. These file groups open as a new file group tab.

The file group options are available via the context menu of the file group tabs.

The tab color of a file group indicates whether a file group contains modified files 
that have not been saved yet.

RELATED LINKS

Tab Colors on page 93

Creating File Groups

You can create empty file groups or file groups that are based on a template.

PROCEDURE

1. Select File > New.

2. Click File Group.

3. Do one of the following:
• To create an empty file group, click Custom, select one of the options, and 

click Create.

• To create a file group that is based on a template, click Templates, and select 
a template.
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RESULT 

A new file group is created. If you selected a template, the new file group is based 
on this template and includes the corresponding layout and settings.

RELATED LINKS

Project Manager Window on page 73
Templates on page 96

Saving File Groups

File groups are automatically saved with the project.

RELATED LINKS

Saving Projects on page 73

Exporting File Groups as Text

You can export the names of the files inside a file group to a text file that contains 
the file paths.

PROCEDURE

1. Select File > Export.

2. Click File Group to TXT.

3. Specify a file name and location.

4. Click Export.

Searching for Open Files

The File Search and Keywords field in the command bar allows you to search in 
all file tabs and access them. This allows you to quickly switch between file tabs if 
a lot of files are open.

• To open a file tab, click in the File Search and Keywords field or press 
[Ctrl]/[Command]-[F], and start typing the file name that you want to access.

Once you stop typing or when you press [Return], the first file tab that 
contains the search term is activated.

• To jump to the next file tab that contains the search term, press 
[Ctrl]/[Command]-[Tab].

• To jump to the previous file tab that contains the search term, press 
[Ctrl]/[Command]-[Shift]-[Tab].

• To switch back to the last file tab that was active before searching, delete the 
text in the search field.
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RELATED LINKS

Command Bar on page 57

Value Editing

At various places in the program, numerical values can be edited by using a 
combination of text fields and knobs.

Values are sometimes composed of several elements, for example, 12 mn 30 sec 
120 ms. Each value can be edited by using any of the following methods:

• To change a value, click in a value field and type a new value, or click the small 
arrows in the value field.

• To change the value by one unit at a time, press the [Left Arrow] and [Right 
Arrow] keys.

• To change the value by several units, press the [Page Up] and [Page Down] 
keys.

• To change the value using the mouse wheel, position the mouse cursor over 
a value, and use the mouse wheel, or use the AI knob of your MIDI controller.

• To change the value with the mouse, click a value and drag the mouse up or 
down.

• To jump to the maximum and minimum values, press the [Home] and [End] 
keys.

• To move from one element of the value to another, press the [Left Arrow] and 
[Right Arrow] keys.

Drag Operations

WaveLab Pro makes much use of drag-and-drop techniques to perform various 
operations, some of which can only be performed this way. These are referred to as 
drag operations in this documentation.

• To drag an object, click and hold with the mouse when positioned on the 
object and drag it. Drop the object by releasing the button.

Many types of objects can be dragged between different source and destination 
locations, for example, files, text, clips, items in a list, and markers.

NOTE

It is also possible to drag and drop files from WaveLab Pro to Steinberg’s Nuendo.

• To reorder a tab within its own tabbed group, drag horizontally. To move a tab 
to another window, drag vertically.
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• To open a file, drag it from the File Browser window of WaveLab Pro, from 
the file browser of your operating system, or from another application to the 
tab bar.

• To create a copy of a file, drag its tab vertically to another position of the tab 
bar, then press [Ctrl]/[Command], and release the mouse button.

• You can dock and undock tool windows and meter windows via dragging.

RELATED LINKS

Docking and Undocking Tool Windows and Meter Windows on page 55

Dragging in the Audio Editor and Audio Montage Window

• To insert an audio file in another audio file, drag the title bar of the file onto the 
waveform of another file. You can also drag an audio file from the File 
Browser window, the file browser of your operating system, or from another 
application into the Audio Editor.

• To move a marker, drag it to another position on the time ruler.

• To create a copy of a marker, press [Shift], and drag it to another position on 
the time ruler.

• To delete a marker, drag it upwards outside the time ruler.

• To copy an audio selection, drag a selected region of audio onto the waveform 
area of the same file or another file.

• To change the extent of a selection range, position the edit cursor at the 
start/end of the selection range, and drag to the left or right.

• To move the edit cursor without losing the current selection, and to snap it to 
an anchor, press [Shift], and move the mouse near the audio file/montage 
cursor. The mouse cursor shape changes and you can drag the cursor left and 
right.

• To move the edit cursor without changing or losing the current selection, 
press [Shift], click the edit cursor, and drag it to another position.

• To scroll the waveform horizontally, click the bar above the time ruler and drag 
left or right. You can also click anywhere on the waveform using the 3rd 
mouse button, and drag left or right.

• To create a generic marker from a selected text, drop the text that you have 
selected in an external application onto the time ruler. The text becomes the 
marker name.

• To create a stereo copy of a mono file, or a mixed copy of a stereo file, drag a 
tab to another position of the tab bar, press [Ctrl]-[Alt] (Windows) or 
[Option]-[Ctrl] (Mac), and release the mouse button.
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Dragging in the Podcast Window

• To reorder episodes in the episodes list, drag them to another position.

Dragging in the Master Section

• To change the order of processing, drag effects between different effects 
slots.

Dragging in the Batch Processor Window

• To change the order in which plug-ins are processed, drag the plug-ins within 
the audio plug-in chain window.

• To add a file to a batch process, drag its file tab to the batch conversion tool 
or batch processor.

Undoing and Redoing Actions

You can undo and redo as many steps as you like. The only limitation is the available 
hard disk space.

By default, when undoing or redoing any operation in the Audio Editor or the Audio 
Montage window, the zoom factor, cursor position, scroll position, clip selection 
status, and time range are restored to the state before the operation.

• To exclude the scroll and zoom settings when undoing/redoing, select File > 
Preferences > Global, select the Display tab, and deactivate Undo/Redo 
Does Not Scroll/Zoom Audio. 

This is useful if you make an operation, zoom in on the changed area, and then 
undo the step to see the change, for example. When you do this, you do not 
want snapshots to be restored and change your scroll and zoom settings.

• To undo or redo a step, click Undo  or Redo  in the title bar of the Audio 
Editor or Audio Montage window.

Undo/Redo and History in the Audio Montage

The Undo/Redo function in the Audio Montage window is identical with the 
Undo/Redo function in the Audio Editor. However, the Audio Montage window 
provides additional Undo/Redo functions and a History window. This window 
allows you to view a history of all recent editing activities in the audio montage and 
to revert to a previous state.

Each audio montage has its own history.
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The following options are available in the History window.

• To open the History window, select Tool Windows > History.

• To revert the current audio montage to a previous state, double-click the 
operation to which you want to return.

• To undo all operations, select Functions > Undo All Operations.

• To undo all operations since the last saving command, select Functions > 
Undo All Operations since the Last Saving Command.

• To redo all operations, select Functions > Redo All Operations.

• To clear the history, select Functions > Clear.

This frees up memory, hard disk space, and any involved audio file.

NOTE

When you save an audio file, the undo history is cleared automatically. This is 
not the case for audio montages.

The following options are available in the Audio Montages Preferences.

• To group similar operations in the undo history, select File > Preferences > 
Audio Montages. On the All Audio Montages tab, activate Group Similar 
Operations.

This groups all operations of the same type to one single operation, as soon 
as an operation of another type is performed.

• To clear the history after each saving, select File > Preferences > Audio 
Montages. On the All Audio Montages tab, activate Clear After Each 
Saving.

History Window

In this window, you can see all the operations that have been performed in the audio 
montage and revert to a previous state.

• To open the History window, open an audio montage and select Tool 
Windows > History.

Status

Shows which operations are done and undone.
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Operation

Shows the type of the performed operation.

Time

Shows the time at which the operation was performed.

Description

Describes the performed operation in detail.

Navigating Backwards and Forwards

In audio files and audio montages, you can navigate to the previous/next cursor 
position, zoom factor, and selection range without undoing/redoing the edit 
operation.

PROCEDURE

1. In the Audio Editor or Audio Montage window, select the View tab.

2. In the Navigate section, click Backwards or Forwards.

Zooming

Horizontal Zooming

• When you zoom out as far as possible, the entire file fits in the window.

• When you zoom in as far as possible, each sample occupies several pixels on 
the screen. This allows for sample-accurate editing of waveforms.

Vertical Zooming

• When you zoom out as far as possible, the height of the wave fits in the 
window.

• As you progressively zoom in, the display only shows a part of the total height. 
The vertical scrollbar lets you adjust exactly which section is shown. Check 
the ruler to see which part of the waveform is shown in the display.

• To optimize the vertical zoom of the waveform, press [Ctrl]/[Command], the 
time ruler, keep the mouse button pressed, and drag the mouse up or down.

High Zoom Level

• When the zooming level is very high, each sample is shown with a step and a 
bullet. The steps show the real digitized state, while the bullets make it easier 
to see the samples, especially for zeroed samples.
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• The curve also represents an estimation of the analog reconstructed signal to 
give hints on true peaks.

Zooming in the Overview and Main View Sections (Audio Editor Only)

• You can have different zoom levels in the overview and in the main view 
section. In the overview, a range indicator on the time ruler indicates which 
section of the file is displayed in the main view.

The range indicator is only shown if Sync with Other View is deactivated.

• To adjust the zoom level, drag the edges of the range indicator.

• To scroll in the main view, drag the range indicator. The range indicator is 
located at the top of the overview display.

• To adjust the zoom level using the scrollbar, drag the edges of the scrollbar.

Zooming Using the Zoom Controls

Both the main view and the overview have horizontal and vertical zoom controls.
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• To zoom horizontally, click the Horizontal Zoom control, and drag left or right, 
or use the mouse wheel.

• To zoom vertically, click the Vertical Zoom control, and drag up or down, or 
use the mouse wheel.

• To fully zoom-out, double-click the zoom controls.

Zooming Using the Zoom Tool

The Zoom tool is used to zoom in a specific section of the waveform so that it 
occupies the entire wave window. This is only available in the Audio Editor.

Using the Zoom Tool in the Main View

The selection that you make in the main view of the wave window is magnified and 
fills up the entire main view.

PROCEDURE

1. In the Audio Editor, select the View tab.

2. In the Tools section, click Zoom .

3. In the main view of the wave window, click and drag left or right, and release 
the mouse button.
The selected part of the wave now occupies the entire main view.

Using the Zoom Tool in the Overview

The selection that you make in the overview of the wave window is displayed in the 
main view.

PROCEDURE

• In the overview of the wave window, click and drag left or right, and release 
the mouse button.
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RESULT 

The selected range of the waveform is shown in the main view.

Zooming Using the Mouse

With the mouse, you can change the zoom factor by clicking and dragging or by 
using the mouse wheel.

• To zoom horizontally, in the wave window or the montage window, position 
the mouse cursor over the time ruler, click, and drag up or down.

• To zoom horizontally while maintaining the cursor position, position the mouse 
cursor over the time ruler, press [Shift], and drag up or down.

For this, you can also use the mouse wheel. Press [Ctrl]/[Command]-[Shift], 
point at a waveform, and use the mouse wheel.

• To zoom horizontally around the mouse cursor position using the mouse 
wheel, press [Ctrl]/[Command], point at a waveform, and use the mouse 
wheel.

• To zoom horizontally around the edit cursor position, press 
[Ctrl]/[Command]-[Shift], point at a waveform, and use the mouse wheel.

• To zoom vertically using the mouse wheel, press [Shift], point at a waveform, 
and use the mouse wheel.

Audio Editor Only

• To zoom vertically, in the wave window, position the mouse cursor over the 
level ruler, click, and drag left or right.

• To reset the vertical zoom to 0 dB, double-click the level ruler.

• To set the vertical zoom to the best value, that is, the current minimum and 
maximum displayed samples, make sure that the level ruler is set to 0 dB, and 
double-click the level ruler.

Zooming Using the Keyboard

A quick way to zoom the active wave or montage window is to use the arrow keys 
on the computer keyboard.

• To zoom horizontally in the active wave window or montage window, press 
[Up Arrow] or [Down Arrow].

• To zoom vertically in the active wave/montage window, hold [Shift], and press 
[Up Arrow] or [Down Arrow].

• To zoom vertically to fit the available height, press 
[Ctrl]/[Command]-[Shift]-[Up Arrow].

• To zoom out fully, press [Ctrl]/[Command]-[Down Arrow].
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• To zoom in fully, press [Ctrl]/[Command]-[Up Arrow].

NOTE

You can increase or decrease the zoom steps with the Interval for Zoom Key 
Command option. You can set this option in the Global Preferences on the 
Options tab.

RELATED LINKS

Global Preferences on page 700

Zoom Options

The zoom options allow you to quickly access various zoom settings.

The zoom options are available in the Audio Editor and the Audio Montage 
window on the View tab in the Zoom section.

Time

Opens a pop-up menu that allows you to adjust the zoom to display the 
selected time range. Zoom in 1:1 zooms in so that one pixel on the screen 
represents one sample.

To edit the zoom factor, click Edit Zoom Factor. This opens the Zoom Factor 
dialog, where you can edit the following settings:

• Set Time Range allows you to specify the time range that you want to 
display.

• Samples per Screen Point allows you to specify how many audio 
samples are summarized in each screen point.

• Screen Points per Sample allows you to specify how many screen 
points are used to represent a single audio sample.

Zoom

Activates the Zoom tool that allows you to define a time range that is zoomed 
in.

Zoom Selection

Zooms the window so that the current selection occupies the entire montage 
window.

Display Whole Clip (Audio Montage window only)

Adjusts the view to display the active clip.

Microscope

Zooms in as far as possible.

Zoom in Audio (10x)/Zoom out Audio (10x)

Zooms in/out in big steps.
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Zoom in Audio/Zoom out Audio

Zooms in/out in small steps.

Level

Adjusts the zoom to only display samples below the selected dB value.

Optimize Vertical Zoom (Audio Editor only)

Changes the vertical zoom factor so that the peaks are clearly visible. This 
adjustment is done according to the section of the wave that is visible in the 
wave/montage window.

Reset Zoom to 0 dB

Adjusts the zoom to display audio levels up to 0 dB.

Zoom in Vertically/Zoom out Vertically

Zooms in/out to show waveforms with a lower/higher level.

Zooming in the Audio Montage

Zooming options in the Audio Montage window are almost similar to those in the 
Audio Editor. However, there are additional zooming options for tracks and the 
Wave Matching window for displaying a close-up view of the beginning of the 
selected track.

RELATED LINKS

Wave Matching Window on page 338

Zoom Buttons in the Audio Montage

The zoom buttons in the Audio Montage window allow you to apply zoom presets.

• To only display the selected track, or also the tracks below and/or above the 
selected track, click the corresponding buttons.

• To set the zoom setting to fit the active clips in 25 %, 50 %, or 100 % of the 
available space, click the corresponding buttons.
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• To select a specific area, click [Ctrl]/[Command], and drag the rectangle over 
the tracks and clips that you want to zoom in on.

Displaying More or Less Tracks

The number of tracks that are displayed in the Audio Montage window can be 
changed with the zoom controls in the lower right corner of the montage window.

• To display more tracks, click the smaller magnifying glass icon.

• To display fewer tracks, click the larger magnifying glass icon.

• To make a single track fit the whole montage window, click the numbered 
button in the track control area, and select Zoom from the pop-up menu.

You can also right-click the lower area of a track, and select Display Whole 
Clip from the pop-up menu.

Presets

You can create presets to save commonly used settings. WaveLab Pro provides a 
selection of factory presets that can be used by most dialogs.

You can save customized presets. The next time that you load the program, the 
presets are available.

Presets are saved as single files and can be organized in subfolders. The root folder 
of the preset is different for each type of preset and cannot be changed.

Saving a Preset

PROCEDURE

1. Open the dialog that you want to use and modify the parameters.

2. Open the Presets pop-up menu and select Save As.

3. Optional: Click the folder icon and enter a name for the subfolder that you 
want to use as the location for this preset.

4. Type in a name.

5. Click Save.
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Loading Presets

To apply a saved preset or a factory preset to a dialog or plug-in, you must load the 
preset.

PROCEDURE

1. In the dialog, open the Presets pop-up menu.

2. Select the preset that you want to apply.

Modifying a Preset

You can modify a preset and save the changes.

PROCEDURE

1. Open the dialog that you want to use.

2. Load the preset that you want to modify.

3. Modify the parameters of the dialog.

4. Open the Presets pop-up menu and select Save.

Deleting a Preset

PROCEDURE

1. Open the dialog that you want to use.

2. Select the preset that you want to delete.

3. Open the Presets pop-up menu and select Organize Presets.

4. In the File Explorer/Mac OS Finder, select the preset file that you want to 
delete, and press [Delete].

Saving and Restoring Temporary Presets

Some dialogs allow you to save and load up to 5 temporary presets. This is useful 
if you want to quickly test and compare different settings.
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Saving Presets Temporarily

PROCEDURE

1. Open the dialog that you want to use and make your settings.

2. Open the Presets pop-up menu.

3. From the Store Temporarily submenu, select a slot.

Restoring Temporary Presets

PROCEDURE

1. Open the dialog in which you have saved a preset.

2. Open the Presets pop-up menu.

3. From the Restore submenu, select a preset.
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Recently Used Files

All files that you have recently used in WaveLab Pro are saved in a list. This helps 
you to gain fast access to recent projects. You can open recently used files via the 
File menu or the Recent Files tab, which displays more files and offers additional 
options.

Opening Recently Used Files

PROCEDURE

1. Select File > Open.

2. Select the file type that you want to open.

3. Click Recent Files.

4. Optional: Use the search field to enter the name of the file that you are looking 
for.

5. Select the file that you want to open

6. Click Open.

Recent Files Tab

This tab allows you to view and manage all the files that you have recently used in 
WaveLab Pro. You can search for files, open multiple files at once, and remove 
individual files or files that cannot be located.

• To open the Recent Files tab, select File > Open, select one of the file types, 
and click Recent Files.
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Only Show Files Created by WaveLab Pro

Only shows the files that have not been opened since they were created by 
WaveLab Pro. For example, a file that is rendered has this status until it is 
opened.

Search field

Lets you search for text in the Name or Path column, depending on which 
column is selected.

Remove Non-Existing Files

Removes those files from the list that cannot be located on the media.

Remove Selected Files

Removes all selected files from the list.

Open

Opens the selected files.

Filtering Recently Used Files by Name

The search field in the Recent Files tab allows you to filter the files list by name.

• To specify whether the Name or the Path column is used, click the Name or 
Path column header.

• To search for a file, enter the text that you want to search for in the search field.

• To switch the focus from the search field to the list of recently used files, press 
[Down Arrow].

• To switch the focus from the list of recently used files to the search field, press 
[Ctrl]/[Command]-[F].

Setting the Number of Recently Used Files to Display

PROCEDURE

1. Select File > Preferences > Global.

2. In the Global Preferences window, select the Display tab.

3. In the History section, set the maximum number of items to be listed in the 
following areas:
• Recent File menus

• Recent Files tab

• Recent Folders menu
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Favorite Files

You can add files that you are using regularly to the favorite files list.

• To open the favorite files list, select File > Open, select the file type, and click 
Favorites.

• To add the open file to the favorite files list, click Add Current File.

• To open a file from the favorite files list, select a file from the file list, and click 
Open.

• To remove files from the favorite files list, select the files that you want to 
remove, and click Remove Selected Files.

• To remove files from the list that are no longer present on the media, click 
Remove Non-Existing Files.

Favorite Files Tab

This tab allows you to display and edit the favorite files list.

• To open the Favorite Files tab, select File > Open, select the file type, and 
click Favorites.

List of favorite files

Shows the favorite files.

Search

Lets you filter the favorite files list by name.

Remove Non-Existing Files

Removes files from the list that are no longer present on the media.

Remove Selected Files

Removes all selected files from the list.

Add Current File

Adds the open file to the favorites list.
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Only Show Files Created by WaveLab Pro

If this option is activated, the list displays only files that were created by 
WaveLab Pro, but have not yet been opened.

This allows you to quickly access files that were created in WaveLab Pro via 
the Save As or Render option, for example.

Open

Opens the selected files in WaveLab Pro.

Filtering Favorite Files

The search field in the Favorite Files tab allows you to filter the favorite files list by 
name.

• In the Favorite Files tab, enter the text that you want to search for in the 
search field.

• To switch the focus from the search field to the favorite files list, press [Down 
Arrow].

• To switch the focus from the favorite files list to the search field, press 
[Ctrl]/[Command]-[F].

RELATED LINKS

Favorite Files Tab on page 92

Save and Save As

• Once a file has been saved, select File > Save, or press 
[Ctrl]/[Command]-[S] to update the file and make the changes permanent.

• If you want to specify a new name, location, and/or file format, select File > 
Save As.

NOTE

In the Audio Editor, all save operations except Save Copy clear the undo history, 
which means that after saving you cannot undo or redo.

Tab Colors

The line above tabs gives information on whether a file is saved or not, and whether 
the file has been rendered in Cubase.

White

The file is not modified.
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Green (Audio Editor only)

The file uses a decoded file format and is saved.

Red

The file has been modified and changes have not been saved yet.

Yellow

The file has been rendered in Cubase.

Unsaved Changes Indicator

When you have made changes to a file, an asterisk is displayed next to the file name 
until you save the file.

Saving Multiple Files at Once

You can save some or all open files at once.

PROCEDURE

1. Open the File window and click Save All.

2. Select the files that you want to save.

3. Click Save.

Saving a Copy of a File

You can save copies of files that you are working on.

PROCEDURE

1. Select File > Save As.

2. Specify a name and location.

3. Right-click Save and select Save Copy.
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Reverting to Saved File

You can revert the file that you are working on back to its last saved state. This 
undoes all the changes made to the file since it was last saved.

PROCEDURE

1. Select File > Open.

2. Select the file type that you want to open.

3. Click Revert to Saved File.

4. In the warning dialog, click Yes to revert to the last saved state.

RESULT 

The last saved version of the file is loaded from disk.

Automatic Backups

You can automatically create backups of your files.

For example, if you select Save As and specify a file name that is already used in 
that folder, you will be asked if you want to replace the existing file or replace the 
existing file and rename the old file. If you click Replace and Keep Old, the backup 
name of the audio file that is replaced will be the original name, with .bak added at 
the end.

About Saving Audio Montages

The saving operations for audio montages are the same as for audio files. However, 
there are things to note when saving audio montages.

• Audio montage files only contain references to audio files. If you want to 
rename audio files that are referenced by audio montages, rename the audio 
files in the Info window of the Audio Editor. All clip references are updated 
automatically.

• If the audio montage contains clips that refer to untitled audio files, save these 
audio files before saving the audio montage.

RELATED LINKS

Renaming Files on page 101
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Templates

You can save file settings that you regularly use as templates. Templates are useful 
when creating new audio files, audio montages, podcasts, projects, or batch 
processors.

Templates Tab

This tab shows all templates, and allows you to create and open templates.

• To open the Templates tab, select File > New, select a file type, and click 
Templates.

List of the available templates

Lists all saved templates.

Add Template

Allows you to add a new template or update an existing template.

Use Template Name as Default File Name

If this option is activated and you click Add Template, a new file is created 
and uses the name of the template. If this option is deactivated, the name of 
the new file is “untitled”.

Explore

Opens the folder where the template files are located. Here, you can rename 
and delete templates.

Creating a Template

You can create a template from an active audio montage, audio file, podcast, 
project, or batch processor file and use it as a basis for newly created files.

PREREQUISITE 

Select the file that you want to base your template on.

PROCEDURE

1. Select File > New.

2. Select the file type for which you want to create a template.
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3. Click Templates.

4. In the Templates tab, do one of the following.
• To create a new template, click Add Template, make your settings, and click 

Create.

• To update an existing template, click Add Template, enter the name of the 
template that you want to update, and click Create.

5. Optional: If you want to use the template name as the default file name, 
activate Use Template Name as Default File Name.

6. When saving or updating an audio file template or an audio montage template, 
you can make additional settings.
• When saving an audio file template, the Audio File Template dialog opens. 

Here, you can select whether WaveLab Pro should attach an audio file format.

• When saving an audio montage template, the Audio Montage Template 
dialog opens. Here, you can select whether to include track plug-ins, clips, 
and/or markers. Also select whether WaveLab Pro should attach an audio file 
format.

Audio File Templates

The Audio File Template dialog displays the audio properties of the audio file 
template that you are creating. You can also specify whether to always associate a 
specific audio file configuration with optional meta-data when creating an audio file 
template or not.

• To open the Audio File Template dialog, select File > New, click Audio File, 
and click Templates. In the Templates tab, click Add Template.

Attach Audio File Format

If this option is activated, whenever you open the Render or Save As dialogs, 
the audio file configuration specified below is proposed by default.

Template Name

Allows you to enter a name for the template.
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Audio Montage Templates

In the Audio Montage Template dialog, you can set various options when creating 
an audio montage template.

• To open the Audio Montage Template dialog, select File > New, click 
Audio Montage, and click Templates. In the Templates tab, click Add 
Template.

Include Clips

If this option is activated, clips are saved in the template.

Include Track and Master Plug-ins

If this option is activated, track plug-ins and master plug-ins are saved in the 
template.

Include Markers

If this option is activated, markers are saved in the template.

Attach Audio File Format

If this option is activated, whenever you open the Render dialog, the audio file 
configuration specified below is proposed by default.

Template Name

Allows you to enter a name for the template.

File Group Templates

The File Group Template dialog displays the file group name on which the 
template that you are creating is based on. You can also specify whether to include 
links to the files inside the file group in the template and specify the template name.

• To open the File Group Template dialog, select File > New, click File 
Group, and click Templates. In the Templates tab, click Add Template.
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Include Links to the Files Inside the File Group

If this option is activated, the links to the files that are included in the file group 
are included in the template.

Template Name

Allows you to enter a name for the template.

Project Templates

In the Project Template dialog, you can set various options when creating a project 
template.

• To open the Project Template dialog, select File > New, click Project, and 
click Templates. In the Templates tab, click Add Template.

Include Links to the Files Inside the Project

If this option is activated, the links to the files that are included in the project 
are included in the template.

Set as Default Project

If this option is activated, the template is used as the default project when you 
start WaveLab Pro.

Template Name

Allows you to enter a name for the template.
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Creating a File From a Template

You can create a file from a template to use its settings.

PROCEDURE

1. Select File > New.

2. Select the file type that you want to create.

3. Click Templates.

4. From the list of the available templates, select the template that you want to 
take as the basis of the new file.

Deleting Templates

PROCEDURE

1. Select File > New.

2. Select the file type for which you want to delete templates.

3. Click Templates.

4. Click Explore.

5. In the File Explorer/Mac OS Finder, delete the templates.

Renaming Templates

PROCEDURE

1. Select File > New.

2. Select the file type for which you want to rename templates.

3. Click Templates.

4. Click Explore.

5. In the File Explorer/Mac OS Finder, rename the templates.

File Renaming

You can rename a file and update all references automatically. For example, if you 
rename an audio file named India to Sitar, all open files that reference the file 
India are updated to reference the file as Sitar.

Audio files, peak files, and marker files are also renamed accordingly.

The following files use audio file references:
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• Audio montages

• Basic Audio CDs

• DVD-Audio projects

Renaming Files

PREREQUISITE 

If you want to rename a file that is referenced by other files, open the files that 
reference the file that you are about to rename in WaveLab Pro.

PROCEDURE

1. Open the file that you want to rename.

2. Select the File tab.

3. Click Info.

4. In the Name section, enter the new name and/or a new file location.

5. Select a file suffix from the drop-down list.

6. Click Apply Changes.

Naming Schemes

When rendering audio files or audio montages, you can create multiple files that are 
named according to a naming scheme.

Defining Naming Schemes

You can define a naming scheme by combining name attributes that determine the 
structure of the file names for the rendered audio files or audio montages.

PROCEDURE

1. In the Naming Scheme dialog, click Add Attribute and select which 
attributes you want to add.

2. In the Settings section, make your settings.

3. Click OK.

RELATED LINKS

Naming Scheme Dialog on page 102
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Naming Scheme Dialog

The Naming Scheme dialog allows you to define naming schemes for the audio 
files or audio montages that you want to render. You can save naming schemes as 
presets.

• To open the Naming Scheme dialog, select the Render tab in the Audio 
Editor or Audio Montage window, and activate Named File in the Result 
section. Then open the Scheme pop-up menu in the Output section, and 
select Edit Naming Scheme.

Add Attribute

Allows you to add a naming scheme attribute.

Used Attributes

Shows the naming scheme attributes. You can rearrange the attributes by 
dragging.

Separator

Allows you to select a separator.

Counter Start

Allows you to select the counter start.

Digit Number

Allows you to select the style of the digit number.

Ignore for Single File Rendering

If this option is activated, the naming scheme is only applied when rendering 
more than one file.

Preview

Displays a preview of your current settings.

Presets

Allows you to save and apply naming scheme presets.
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Deleting Files

You can delete the active file from within WaveLab Pro.

PREREQUISITE 

The file that you want to delete is not copied to the clipboard, is not pasted into 
another file that is open, and is not open in another application.

PROCEDURE

1. Open the file that you want to delete.

2. Select the File tab.

3. Click Info.

4. Click Delete.

5. Click OK.

RESULT 

The file, including its peak and marker files, is deleted.

Temporary Files

Temporary files are used for specific operations, such as the undo/redo functions. 
You can specify where WaveLab Pro saves its temporary files.

You can specify up to three different folders for saving temporary files. If you have 
access to more than one drive, saving your temporary files on separate physical 
drives (not partitions) can speed up performance considerably.

For example, if your source files are located on the C: drive, you could specify 
D:\temp and E:\temp as temporary folders. This improves the performance and 
reduces disc fragmentation.

RELATED LINKS

Specifying Folders on page 104

Work Folders vs. Document Folders

WaveLab Pro distinguishes between two types of folders: work folders and 
document folders.

• In work folders, temporary files are saved.

• Document folders contain WaveLab Pro-specific files, such as audio files, 
audio montages, etc.
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Specifying Folders

You can specify which document folder should open when you perform an open or 
save operation. You can also specify up to three work folders for temporary files.

PROCEDURE

1. Open the file for which you want to specify folders.

2. Select File > Preferences > Folders.

3. On the Folders tab, click the type of folder for which you want to specify a 
location.

4. Specify a location in the Folder field.

5. Optional: Depending on the selected type of folder, you can make additional 
settings.

Folders Tab

On this tab, you can specify default document folders and work folders for each file 
type.

• To open the Folders tab, select File > Preferences > Folders.

In the list on the left, you specify the folder type that you want to make settings for.
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Folder for Temporary Files #1/#2/#3

You can specify three folders for saving temporary files. If your system 
comprises multiple hard disks, specifying one folder for temporary files on 
each of these hard disks can speed up file operations.

Companion Files

Specify a folder for saving companion files, that is, Master Section presets 
and view settings for audio files.

Cache Folder

Activate Use Cache Folder for Decoded Files to specify a cache folder. The 
cache folder contains wave files that are created when you are working with 
files in compressed file formats, such as MP3 files. To prevent the cache 
folder from growing indefinitely, WaveLab Pro checks the date of each file in 
this folder and deletes files that were created before a specific number of 
days.

If Use Cache Folder for Decoded Files is deactivated, the compressed files 
are decoded each time they are opened.

Audio File – Open Folder/Save Folder

The default open and save folders for audio files.

Audio Montage – Open Folder/Save Folder

The default open and save folders for audio montage files.

Basic Audio CD – Open Folder/Save Folder

The default open and save folders for Basic Audio CD files.

Batch Processor – Open Folder/Save Folder

The default open and save folders for Batch Processor files.

DVD-Audio Project – Open Folder/Save Folder

The default open and save folders for DVD-Audio Project files.

File Group – Open Folder/Save Folder

The default open and save folders for File Group files.

Podcast – Open Folder/Save Folder

The default open and save folders for podcast files.

Project – Open Folder/Save Folder

The default open and save folders for project files.

Script (Audio File/Audio Montage) – Open Folder/Save Folder

The default open and save folders for script files.

Depending on the selected item, different settings are available on the right side of 
the dialog.
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Current Folder

In this field, the folder that is used as default is displayed. You can click the 
folder button to the right to navigate to a folder, or to create a new folder.

Keep Last Used

Uses the last folder for saving or opening files of the selected type.

Change When Save Folder Changes/Change When Open Folder Changes

Updates the default open folder when you change the default save folder, and 
vice versa. Activate this option for both the save folder and the open folder if 
you want a specific file type to use the same folder for saving and for opening 
this type of file.

On Opening the Application, Revert to This Folder

Activate this option to restore a specific folder each time you open 
WaveLab Pro. This way, any changes to save/open folders are only temporary 
and are reset when you restart WaveLab Pro.

Exporting to SoundCloud

SoundCloud is an online platform for uploading and sharing your audio recordings. 
You can export an audio file from WaveLab Pro to your SoundCloud account.

If you do not have a SoundCloud account, visit www.soundcloud.com to register.

PROCEDURE

1. Select File > Export

2. Click Export to SoundCloud.

3. Once you have logged in to your SoundCloud account, the file upload starts.

AFTER COMPLETING THIS TASK 

After uploading the audio file, you can edit the privacy settings and add meta data 
in SoundCloud.

Copying Audio Information to the Clipboard

You can copy information about the name and location of the selected audio file, 
including any selection information and cursor position. This information can be 
pasted into an external text application.
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This is useful if you need accurate file path/selection information when writing a 
script, for example.

PROCEDURE

1. Click the File tab.

2. Click Info.

3. Click Copy to Clipboard and select the information that you want to copy to 
the clipboard.

Setting the Focus on the Current File

If you are editing inside a floating window or a tool window and you want to switch 
the focus back to a wave/montage window, you can use the Set Focus on Current 
File option.

PROCEDURE

• In any window, press [Ctrl]/[Command]-[F12], to set the focus on the 
wave/montage window.



108

Playback

Transport Bar

With this command bar you can control playback of an audio file or audio montage, 
navigate between various positions in an audio file or audio montage, and open the 
Recording dialog.

The transport bar is available in the Audio Editor and in the Audio Montage 
window.

By default, the extended transport bar options are hidden.

• To activate the extended transport bar, click Extend Transport Bar on the 
transport bar.

Presets

Lets you save and apply presets.

Jog and Shuttle

Activates the Jog and Shuttle mode.

Playback Speed

Opens a menu where you can specify the playback speed.

Perform Pre-Roll/Perform Post-Roll

Activates pre-roll or post-roll for the commands Play from Anchor, Play until 
Anchor, and Play Audio Range.

Right-click the button to select the pre-roll or post-roll length and to specify 
to which commands you want to apply pre-roll/post-roll to. To edit the 
pre-roll/post-roll times, select Edit Pre-Roll and Post-Roll Times.

Play Audio Range

Plays the selected audio range. Post-roll and Pre-roll settings are taken into 
account. Right-click the button to open a menu with related options and auto 
selection modes.

• If Auto Select Range is activated, the range is automatically selected 
according to the editing actions.
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• If Auto Replay While Editing is activated, playback is automatically 
restarted when you hold down the mouse button while editing ranges, 
and use the shortcuts to trigger playback. This is useful to find a loop, 
for example.
This option works even if the automated selection mode is deactivated.

• If Solo Track When Editing is activated and you keep the mouse button 
pressed when editing ranges in the montage window, the track is 
soloed when you start playback using the shortcuts for Play Audio 
Range, Play from Anchor, or Play until Anchor. This option is only 
available in the Audio Montage window.

You can select different audio ranges for playback:

• Time Selection

• Region between Marker Pairs

• Clip (audio montage only)

• Crossfade (audio montage only)

• Fade In (audio montage only)

• Fade Out (audio montage only)

Play until Anchor/Play from Anchor

Plays until or from anchor. Pre-roll and post-roll settings are taken into 
account. Right-click the button to open a menu with related options and auto 
selection modes.

• If Auto Select Anchor is activated, the anchor is automatically selected 
according to the editing actions.

• If Auto Replay While Editing is activated, playback is automatically 
restarted when you hold down the mouse button while editing anchors, 
and use the shortcuts to trigger playback. This is useful to find a loop, 
for example.
This option works even when the automated selection mode is 
deactivated.

• If Solo Track When Editing is activated and you keep the mouse button 
pressed when editing anchors in the montage window, the track is 
soloed when you start playback using the shortcuts for Play Audio 
Range, Play from Anchor, or Play until Anchor. This option is only 
available in the Audio Montage window.

You can select which anchor to use as reference for the commands Play from 
Anchor and Play until Anchor. When there are multiple possibilities, for 
example, multiple markers, the last selected item is used as a reference 
anchor or, if no item was selected, the closest item near the edit cursor 
position is used.

You can select one of the following anchors:

• Edit Cursor

• Start of File
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• Start of Selected Time Range

• End of Selected Time Range

• Any Marker

• Region Start Marker

• Region End Marker

• Clip Start (audio montage only)

• Clip End (audio montage only)

• Selected Envelope Point in Active Clip (audio montage only)

When an anchor is detected, for example, a region marker pair, this is 
indicated by a green anchor marker.

Move Cursor to Start of File/Move Cursor to End of File

Moves the edit cursor to the start/end of the file.

Move Playback Position Backwards/Move Playback Position Forwards

Moves the edit cursor position to the left/right. If you click during playback, 
playback jumps to the new edit cursor position.

To move the edit cursor to the start/end of the file, press [Ctrl]/[Command], 
and click the Move Playback Position Backwards/Forwards button.

Navigation anchors allow you to move the edit cursor to specific positions in 
the audio file or audio montage. Right-click the Move Playback Position 
Backwards/Forwards buttons to open the Navigation Anchors pop-up 
menu. Here, you can set the type of navigation anchor. If you click during 
playback, playback continues from the anchor position.

Loop

Activates the loop mode. Right-click the loop button to select whether to loop 
continuously or only a few times.

Stop Playback

Stops playback. If playback is already stopped, the edit cursor is moved to the 
previous start position. Right-click the button to open the Move Cursor Back 
to Start Position pop-up menu.

• If After Standard Playback is activated, the edit cursor jumps back to 
the start position when regular playback stops.

• If After Automated Playback is activated, the edit cursor jumps back 
to the start position when playback stops after the Play from Anchor, 
Play until Anchor, or Play Audio Range options.
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Start Playback from Cursor

Starts playing back the active audio file or audio montage from the edit cursor 
position. This option can also be used to play back other sources, for example, 
the selected Basic Audio CD track or the active clip in the Clips window.

If the audio being played back is not the active audio file, the Play button has 
a different color. This happens if you switch to another file window during 
playback, for example.

The playback button when playing back in the active window (left) and when 
playing in another window (right).

You can also start playback from the last stop position. Right-click the button 
to open the Lead Sequence pop-up menu.

• If you select Start, playback starts from the cursor position.

• If you select Resume from Last Interruption, playback starts from the 
last stop position.

Record

Opens the Recording dialog.

Time Display

Displays the edit cursor or playback position. Click to select another time unit.

Transport Bar in the Podcast Editor and Batch Processor Window

In the Podcast Editor and Batch Processor window, a simplified transport bar 
allows you to play back the selected podcast episode and selected batch process 
source files and destination files.

Play Button

Clicking the Play button on the transport bar starts playing back the active audio file 
or audio montage from the edit cursor position. It can also be used to play back 
other sources, for example, the selected Basic Audio CD track or the active clip in 
the Clips window.

You can also use the Space bar or the [Enter] key on your keyboard to start 
playback. Pressing [Space] during playback stops playback, pressing [Enter] during 
playback makes playback restart from the last start position.

If the Loop button is activated, the audio selection is looped, if available. Otherwise, 
the region defined by loop markers is looped. If there are no selection ranges or loop 
markers, the entire file is looped.

The standard play command is not influenced by the Play Audio Range, Play from 
Anchor, and Play until Anchor options.
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Stop Button

The result of clicking the Stop button or on the transport bar or [0] on your numeric 
keypad depends on the current situation.

• If you trigger Stop in stop mode, the edit cursor moves either to the previous 
playback start marker, or to the selection start (whatever is closer), until the 
start of the file is reached.

• If there is no selection or if the edit cursor is positioned to the left of the 
selection, it is moved to the beginning of the file instead.

Playing Back Audio Ranges

You can play back audio ranges using the Play Audio Range options on the 
transport bar.

PROCEDURE

1. On the transport bar, right-click Play Audio Range and select the range type 
that you want to play back.

2. Optional: Activate Perform Pre-Roll and/or Perform Post-Roll.

3. Position the edit cursor inside the range that you want to play back or make a 
selection range.
This selected range and, if activated, the pre-roll and post-roll times are displayed on 
the time ruler.

4. To play back the selected range, click Play Audio Range on the transport bar 
or press [F6].

RESULT 

The selected range is played back. Pre-roll and post-roll settings are taken into 
account. If the Loop mode is active, pre-roll is used before the first loop only, and 
post-roll is only used after the last loop.



Playback
Transport Bar

113

Playing Back From an Anchor or Until an Anchor

You can play back audio from an anchor or until a specified anchor using the Play 
from Anchor or Play until Anchor options on the transport bar.

PROCEDURE

1. On the transport bar, right-click Play from Anchor or Play until Anchor, and 
select an anchor type.

2. Depending on the selected anchor type, position the edit cursor in the wave 
window or montage window inside the range that you want to play back.
For example, if you have selected Region Start Marker, click somewhere in the area 
of the region marker pair from which you want to play back from/to. The green anchor 
marker jumps to the selected anchor.

3. Optional: Activate Perform Pre-Roll and/or Perform Post-Roll.

4. To play back from the anchor marker, click the Play From Anchor button on 
the transport bar or press [F7]. To play back until the anchor marker, click the 
Play Until Anchor button on the transport bar or press [F8].

RESULT 

Playback starts from the anchor or stops at the anchor. Pre-roll and post-roll 
settings are taken into account.

“Play From Anchor” and “Play Until Anchor” Functions

You can play back audio from an anchor or until an anchor using the Play from 
Anchor or Play until Anchor functions on the transport bar. These playback 
functions behave differently depending on the pre-roll and post-roll settings.

Play from Anchor

• If post-roll is activated, playback starts at the anchor position and stops 
after the post-roll time. If no post-roll is selected, playback continues 
until the end of the audio file or audio montage.

• If pre-roll is activated, playback starts from the selected anchor, minus 
the pre-roll time.

• If pre-roll and post-roll are activated, playback starts from the selected 
anchor, minus the pre-roll time and stops after the anchor point plus the 
post roll time.

• If the loop mode is activated, the pre-roll and post-roll settings are taken 
into account. This way you can play a loop around the edit cursor 
position, without having to make further range settings.
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Play until Anchor

• Playback starts from the cursor, and stops at the selected anchor. If the 
cursor is beyond the selected anchor, playback starts at the selected 
anchor. If pre-roll is activated, it is taken into account.

• If pre-roll is activated, playback starts from the selected anchor minus 
the pre-roll time, until the selected anchor.

• If no anchor is selected, Play until Anchor is deactivated.

• The loop settings have no effect.

Using the Auto Selection Mode

You can use the auto selection mode in combination with the playback shortcuts to 
play back audio ranges or anchors. This makes it easy to monitor your editing 
actions.

PROCEDURE

1. On the transport bar, right-click the Play Until Anchor button and activate 
Auto Select Anchor.

2. Right-click the Play Audio Range button and activate Auto Select Range.

3. In the wave window or the montage window, do one of the following:
• Make a selection range.

• Click inside the area of a marker pair.

• Click a fade in, fade out, or crossfade.

• Click anywhere in the wave/montage window.

• Drag a marker.

Depending on your action, the most appropriate range, or anchor, is selected. For 
example, if you click inside a marker pair, this region is selected as playback range.

The time ruler shows the selected range or anchor.

NOTE

In Auto Select Anchor and Auto Select Range mode, you can still change some 
range and anchor options on the transport bar to play a different range/anchor. 
However, the range/anchor are reselected when you start editing again with the 
mouse.

4. Use the playback shortcuts to start playback.
• To play back the selected audio range, press [F6].

• To play back from an anchor, press [F7].

• To play back until an anchor, press [F8].

RESULT 

The selection range is played back, or play back starts from the anchor or stops at 
the anchor. Pre-roll and post-roll settings are taken into account.
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NOTE

A selection range has priority over any other range. To allow other ranges to be 
auto-selected, deselect the selection range.

Using Auto Replay While Editing

You can automatically re-trigger playback while editing audio with the mouse. This 
is useful if you want to monitor the adjustment of a selection boundary, for example.

PROCEDURE

1. On the transport bar, right-click the Play Until Anchor button and activate 
Auto Replay While Editing.

2. In the wave window or the montage window, make a selection range and keep 
the mouse button pressed.

3. Start playback by using one of the following shortcuts:
• To play back the selected audio range, press [F6].

• To play back from an anchor, press [F7].

• To play back until an anchor, press [F8].

4. Drag the cursor to the right or left.
The selection range is adjusted and played back until you release the mouse button. 
When playback ends, the new selection range is played back.

Skipping Sections During Playback

You can automatically skip a selected audio range during playback. This way, you 
can audition what the material would sound like without specific sections.

PROCEDURE

1. On the transport bar, activate Skip Range .

2. Activate Perform Pre-Roll and Perform Post-Roll.

3. If you want to use the Play Audio Range function, activate one of the Ranges 
modes.

4. Depending on the Ranges mode, do one of the following:
• If you have activated Time Selection, make an audio selection in the wave 

window.

• If you have activated Region Between Marker Pairs, click between a marker 
pair.

The audio range that will be skipped is displayed on the time ruler along with the 
pre-roll and post-roll times.
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5. Select Play Audio Range, or press [F6].

RESULT 

The selected range is skipped during playback.

You can also use the factory preset for skipping selections during playback. 
Activate Skip Range, make an audio selection, and press [Shift]-[F6].

NOTE

This mode also works with the Start Playback from Cursor button if there is a time 
selection or if exclusion start and end markers are set. In this case, the pre-roll and 
post-roll times are ignored.

Loop Playback

Loop points are updated continuously during playback. If you change the loop start 
or end during playback, the loop changes. This way, you can audition selection 
points for rhythmic material.

If you loop a section in an audio montage, playback loops within the boundaries of 
the current selection range. This selection range may be on any track, even if it is 
empty. The vertical position of the selection range is of no relevance for loop 
playback, only the left and right selection boundaries matter.

Pre-Roll and Post-Roll

You can start playback slightly before a specific position (pre-roll) and stop 
playback slightly after another position (post-roll). This gives you a brief context if 
you are auditioning a clip, for example.

The position can be an anchor or the start or end of a range. The pre-roll and 
post-roll times are displayed in the time ruler.

To activate pre-roll and/or post-roll, activate Perform Post-Roll and Perform 
Pre-Roll on the transport bar.

When right-clicking the pre-roll or post-roll button on the transport bar, you can 
select a pre-roll/post-roll time. Here, you can also select a play option for the 
pre-roll/post-roll, and you can open the Pre-Roll and Post-Roll Times dialog.



Playback
Transport Bar

117

Pre-Roll and Post-Roll Times Dialog

This dialog allows you to define a short, an average, and a long pre-roll and post-roll 
time. These settings are global to WaveLab Pro.

• To open the Pre-Roll and Post-Roll Times dialog, right-click the pre-roll or 
post-roll button on the transport bar, and select Edit Pre-Roll and Post-Roll 
Times.

Playback Speed Dialog

This dialog allows you to specify the playback speed of the active audio file and all 
clips of the active audio montage.

• To open the Playback Speed dialog, right-click Playback Speed on the 
transport bar, and select Edit Playback Speed.
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Presets

You can enter a name to save the settings as a preset and select them from 
the Playback Speed pop-up menu later.

Speed Factor

Sets the playback speed as a percentage of the normal speed.

Time Stretching

Compared to the speed coefficient, this is the inverse, a deceleration 
coefficient. This value is equivalent to the percentage found in the Time 
Stretching dialog.

Keep Constant Pitch (Pure Time Stretching)

Indicates the time stretching.

Quality

Allows you to select a quality. The Best and High quality modes provide the 
highest quality, but are also the most CPU intensive. In most cases, the 
Standard quality is sufficient.

Acceleration by Skipping Low Level Regions

If this option is activated, regions of the audio that are below the threshold 
level are skipped during playback.

Level Detection Sensitivity

Determines the sensitivity of the level detection analysis.

Level under Which Audio Is Skipped

Determines the threshold level for a region to be skipped during playback.

Bypass Effects and Master Section

If this option is activated, all active effects in the audio montage and all global 
effects in the Master Section are bypassed. This saves processing power 
and usually the plug-ins are not needed trying to locate audio material.

Bypass Audio Meters

If this option is activated, all meters are bypassed to save processing power.

NOTE

Changing the playback speed does not change the original audio, but only the 
playback speed in WaveLab Pro.

Playback Shortcuts

In addition to the buttons on the transport bar, there are shortcuts to control the 
playback.
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Space bar

Start/Stop playback. This shortcut can be used even when the wave window 
or montage window is not the active window.

0 on numeric keypad

Stops playback. If the playback is stopped and you press this shortcut, the 
edit cursor moves either to the previous playback start marker, or to the 
selection start (whatever is closer), until the start of the file is reached. This is 
the same as clicking Stop on the transport bar. This shortcut can be used 
even if the wave window or montage window is not the active window.

Enter

Starts playback. If pressed during playback, playback restarts from the 
previous start position. This is the same as clicking Start Playback from 
Cursor on the transport bar.

[F6]

Starts playback of the selected range, depending on the selected option in 
the Ranges section of the transport bar.

[F7]

Starts playback from the selected anchor, depending on the selected option 
in the Anchors section of the transport bar.

[F8]

Starts playback until the selected anchor, depending on the selected option 
in the Anchors section of the transport bar.

Save Transport Bar Preset Dialog

In this dialog, you can save a transport bar setup as preset.

• To open the Save Transport Bar Preset dialog, click the Presets field on the 
transport bar, and select Save As.
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Path

Opens the root folder of the preset in the File Explorer/Mac OS Finder. Here, 
you can create subfolders for your presets.

Presets list

Lists all existing presets.

Name

Lets you specify a name for your preset.

Create Shortcut for Selecting the Preset

If this option is activated and you click Save, the Shortcut Definitions dialog 
opens, where you can define a shortcut for this preset.

If a preset already has an assigned shortcut, this option is grayed out. To 
change the existing shortcut, double-click the preset name in the presets list.

When a Preset Is Selected

This lets you assign a customized playback command to a shortcut. For 
example, you can set a shortcut to play a range with a short pre-roll/post-roll, 
and another shortcut to play a range without a pre-roll/post-roll.

When Playback Stops, Restore Previous Transport Settings

If this option is activated, the settings are restored to as they were before 
playback start. This is useful to trigger a special play task, and automatically 
switch back to the standard settings as soon as playback is finished.
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Changing the Position of the Transport Bar

You can position the transport bar at the top, middle, or bottom of the file window.

PROCEDURE

1. In the title bar of the Audio Editor or Audio Montage window, click Layout 
Options.

2. In the Transport Bar section, select whether to position the transport bar at 
the Top, Middle, or Bottom.

Hiding the Transport Bar

PROCEDURE

1. In the title bar of the Audio Editor or Audio Montage window, click Layout 
Options.

2. In the Transport Bar section, select Hidden.

Starting Playback From the Ruler

You can use the ruler to jump to a position and start playback from there.

• Double-clicking the ruler starts playback from that position. Playback 
continues until you click Stop Playback or until the end of the audio file or 
audio montage.

• To set the playback position to a specific position, click the ruler during 
playback. This also applies for clicking the time rulers of another audio file or 
audio montage, which allows you to quickly switch playback between audio 
files or audio montages.

• To start playback from a marker position, press [Ctrl]/[Command] and 
double-click the marker.

Using the Play Tool

This tool allows you to play back from any position on one or both stereo channels.

PROCEDURE

1. In the Audio Editor, select the Edit tab.

2. In the Tools section, select the Play tool, or press and hold [Alt]/[Option].
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3. In the wave window, click at the position where you want playback to start.
The cursor shape indicates whether the left (L) or the right (R) channel is played back. 
If mid/side mode is activated, the cursor shape indicates whether the mid (M) or the 
side (S) channel is played back. Using the Play tool in the middle of the channels plays 
back both channels.

RESULT 

Playback continues for as long as you keep the mouse button pressed, or until the 
audio file ends. After playback has stopped, the cursor is moved to the playback 
start position.

RELATED LINKS

Mid and Side Editing on page 175

Playback Scrubbing

Playback scrubbing helps you find a specific position in an audio file, by restarting 
playback repeatedly when you click and drag on the time ruler during playback or 
when using the Play tool.

Scrubbing Using the Play Tool

PROCEDURE

1. In the Audio Editor, select the Edit tab.

2. In the Tools section, select the Play tool, or press and hold [Alt]/[Option].

3. Click in the wave window.
Playback starts at the position where you clicked.

RELATED LINKS

Playback Scrubbing Preferences on page 123

Scrubbing Using the Time Ruler

PROCEDURE

1. Start playback.

2. Click the time ruler and hold the mouse button pressed, and drag left or right.
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3. When you are done scrubbing, release the mouse button.
The audio is played back from the edit cursor position and a small section is looped 
once.

Playback Scrubbing Preferences

You can define the behavior of the Play tool in the Audio Files Preferences.

Select File > Preferences > Audio Files. The following options are available in the 
Playback Scrubbing section.

• If Restrict to Play Tool is activated, scrubbing is not available when you click 
and drag on the time ruler during playback.

• The Sensitivity setting determines the length of the audio loop that is played 
once when click and drag on the time ruler with the Play tool.

Timecode Window

This window can display the recorded time, the time offset in relation to various 
positions, and dynamic colors according to the context. During playback, the song 
position is displayed. If nothing is played back, the edit cursor position is displayed.

• To open the Timecode window, select Meters > Timecode.

View Menu

Edit Colors

Opens the Timecode Colors dialog, where you can edit the colors of the 
Timecode window.
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Reduced Precision

If this option is activated, the timecode display show less digits.

Positive Times

If this option is activated, positive values are displayed. If Negative Times is 
also activated, the closest offset, negative or positive, is displayed.

Negative Times

If this option is activated, negative values are displayed. If Positive Times is 
also activated, the closest offset, negative or positive, is displayed.

File Start/File End

Displays the position in relation to the origin of the time ruler. The time format 
is displayed according to the ruler.

Offset Display

Lets you select from which position you want to display the offset. The 
following positions are available: edit cursor, selection start/end, marker, CD 
track start/end, clip start/end.

Recorded Time

If this option is activated, the Timecode window displays the recorded time 
when you start recording.

Recorded Time (from Last Marker)

If this option is activated, the Timecode window displays the recorded time 
since the last dropped marker when you start recording.

Jog/Shuttle Function

This function allows you to play back audio forwards or backwards, at any speed. 
This is useful for finding exact spots in the audio file and audio montage.

NOTE

The Jog and Shuttle functions are CPU intensive. If you experience playback 
problems, try reducing the window size.



Playback
Scroll During Playback

125

Using the Jog Function

This can be viewed as dragging the audio past a playback point, much like dragging 
a reel-to-reel tape past the playback head.

PROCEDURE

1. Zoom in on the wave window or the montage window, so that you get a good 
visual feedback.

2. On the transport bar, activate Jog and Shuttle.
A vertical line is shown in the middle of the wave/montage window. This is the 
playback point.

3. Click in the area above the time ruler and drag to the left or right, to play back 
the audio.
Dragging to the left of the line plays the audio forwards, dragging to the right plays 
the audio backwards.

Using the Shuttle Function

This can be viewed as playing back with a continuous control for tape speed and 
direction.

PROCEDURE

1. Zoom in on the wave window or the montage window, so that you get a good 
visual feedback.

2. On the transport bar, activate Jog and Shuttle.
A vertical line is shown in the middle of the wave/montage window. This is the 
playback point.

3. Click in the wave/montage window and drag to the left or right of the vertical 
line.
Clicking to the left of the line plays the audio backwards, clicking to the right plays the 
audio forwards.

The playback speed is determined by the distance from the line to the pointer. The 
further away from the line you move the pointer, the faster the playback.

4. Release the mouse button to stop playback.

5. Deactivate Jog and Shuttle on the transport bar.

Scroll During Playback

You can determine how the view should be scrolled in Play mode.

• To set the scroll mode, open the Audio Editor or the Audio Montage 
window, select the View tab, and activate one of the options in the Playback 
section.
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Steady View

Disables scrolling.

View Follows Cursor

The view automatically scrolls to keep the playback cursor visible.

Scroll View

Scrolls the view to keep the playback cursor centered.

NOTE

If you get dropouts during playback, activate Steady View.

Playback in the Audio Montage Window

Playback in the Audio Montage window works the same way as in the Audio 
Editor. However, there are some things to note.

Mute and Solo Tracks

You can mute or solo tracks in an audio montage by using the corresponding 
buttons in the track control area.

• When a track is muted, the mute button is yellow.

• When a track is soloed, the solo button is red.

• Solo can only be activated for one track at a time. However, you can unmute 
other tracks when Solo is active if you want to listen to a combination of 
tracks.

RELATED LINKS

Track Control Area on page 234

Muting Individual Clips

PROCEDURE

1. Select Tool Windows > Clips.

2. Select the clips that you want to mute, and select Functions > 
Mute/Unmute Selected Clips, or check the box in the Mute column.
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Playing Back Individual Clips

You can play back an individual clip on a track. Overlapping clips or clips on other 
tracks are muted.

PROCEDURE

1. In the montage window, right-click the lower part of the clip that you want to 
play back.

2. On the menu, select one of the following play options:
• To play back the clip, select Play Clip.

• To play back the clip with pre-roll, select Play Clip with Pre-Roll.

Playing Back a Selection Range of a Track

You can select a section of a clip and play it back. Overlapping clips or clips on 
other tracks are muted.

PROCEDURE

1. In the montage window, make a selection range, either in a clip or in an empty 
section of a track.

2. Right-click the selection range, and select Play Clip Inside Selection Range.

Speaker Configuration

You can configure up to 8 speaker setups to switch between different audio 
speaker configuration without latency. This allows you to compare the sound on 
different speaker setups.

After setting up the speaker configurations in the VST Audio Connections tab, the 
configurations can be selected from the bottom of the Master Section.

The switching between different setups is done at the lowest level, right before 
sending the audio to the hardware, and without any plug-in processing.

A gain can be set individually for each configuration.

• The speaker gain is not taken into account by the meters. This means that the 
signal could clip even if the meters do not indicate clipping.

• The speaker gain has no effect on file rendering or CD writing.

• Because a gain affects samples, any dither settings are reset when changing 
the gain. This has an effect when monitoring quiet music passages.
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The speaker configuration #1 is active on startup and should remain the default 
configuration, without a gain change.

The gain settings are saved with the active configuration. To save the gain settings 
of the speaker configurations as a preset, open the VST Audio Connections tab, 
and save the speaker configurations as a preset.

RELATED LINKS

Speaker Configuration Pane on page 423
VST Audio Connections Tab on page 13

Speaker Configuration LED Colors

The speaker configuration LEDs indicate if gain is applied to the audio. The LED is 
located in the Speaker Configuration pane at the bottom of the Master Section.

Dark green

No gain is applied and dithering is preserved.

Red

Positive gain is applied, dithering is canceled, and there is a risk of clipping.

Orange

Negative gain is applied without the risk of clipping, but dithering is canceled.

RELATED LINKS

Master Section on page 402

Setting Up the Speaker Configuration

PROCEDURE

1. Select File > Preferences > VST Audio Connections.

2. In the VST Audio Connections tab, select an Audio Device.

3. On the Playback tab, select the speaker configuration that you want to edit.

4. Select and name the audio ports used for playback.

5. On the Recording tab, select the speaker configuration that you want to edit.

6. Select and name the audio ports used for recording and input monitoring.

NOTE

The input selection is not affected by the speaker configuration.
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Audio File Editing

Audio file editing refers to opening, editing, and saving audio files.

Wave Window

The wave window displays audio files graphically. Here, you view, play back, and 
edit individual audio files.

The wave window consists of two displays. You can use one display as an overview 
to navigate through the project and the other as the main view for editing.

You can select different display modes for the two displays. For example, one 
display can show the waveform and the other the loudness.
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You can synchronize the waveform displays so that they display the same part of 
the audio file, by clicking Sync with Other View.

Display Modes

In the wave window, the upper and the lower displays can independently be set to 
one of three display modes.

• The Waveform tab displays the waveform of the audio file.

• The Spectrum tab displays the audio as a spectrogram.

• The Loudness tab displays the loudness graphs of the audio file.

Waveform Tab

The Waveform tab displays the waveform of the audio file. The horizontal axis 
shows the time and the vertical axis the amplitude.
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RELATED LINKS

Audio Files Preferences on page 706

Spectrum Tab

This tab allows you to view the level intensity of each area in the frequency 
spectrum.

The Spectrum tab in conjunction with the Spectrum Editor is a unique editing and 
restoration tool.

RELATED LINKS

Spectrum Editing on page 533

Spectrogram Options

In this dialog, you can define how the frequency spectrum is displayed.

• To open the Spectrogram Options dialog, select the Spectrum tab in the 
Audio Editor, and click Edit Settings.
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Colors

Displays the frequency spectrum in colors.

Black & White

Displays the frequency spectrum in black and white. Frequencies with a high 
intensity are displayed in white, and frequencies with a low intensity in black.

White & Black

Displays the frequency spectrum in black and white. Frequencies with a high 
intensity are displayed in black, and frequencies with a low intensity in white.

Logarithmic Frequency Scale

If this option is activated, the frequency spectrum is displayed on a logarithmic 
scale instead of a linear scale, thus spacing the octaves equally. This models 
the perception of pitch of the human ear more closely. However, for audio 
restoration purposes the linear scale is more useful, because you typically 
want to edit higher frequencies which can be located more easily on a linear 
scale.

Display Frequencies Higher Than

Any frequency below this level is not displayed in the spectrogram. Increasing 
this value allows you to focus the display on the audible part of the spectrum.

Audio Gain for Analysis

Allows you to apply gain to the analyzed signal without changing the level of 
the original audio. This helps you find low-level artifacts.

Resolution

Sets the number of samples that are analyzed to create the spectrogram. If 
you specify a higher value, more frequencies are analyzed but they are located 
less accurately in the time domain.

Loudness Tab

The curves on the Loudness tab represent the loudness over time in an audio file.
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Because isolated peaks do not alter the perceived loudness of audio material very 
much, this display represents the loudness of an audio file more accurately than the 
waveform display.

This display mode also gives you an overview of the compression or dynamic range 
of an audio file. For example, the more peaks and valley expressions in the curve, the 
more dynamics in the audio. An even curve with few peaks indicates that the 
material is compressed with a limited dynamic range.

RELATED LINKS

EBU Loudness Standard R-128 on page 45

Loudness Envelope Curves

The loudness envelope curves represent the average loudness of the signal in 
different areas of the frequency spectrum. These curves are shown in the Loudness 
display of the wave window.

The following loudness curves are available:

1) Momentary loudness (100 ms resolution)

2) Short-term loudness (1 sec resolution)

3) Integrated loudness (loudness of the entire file)

4) Loudness range

5) True peak hints

The curves can be shown individually or in any combination. Which curves are 
displayed and what frequency area they represent is specified in the Loudness 
Display Settings dialog.
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NOTE

The resolution is 100 ms, which means the momentary loudness information is 
collected every 100 ms and the short-term loudness every second to match the 
EBU standard. This is the same for true peaks. A clipping indicator is displayed 
when a 400 ms audio region contains one or more over peaks.

RELATED LINKS

Loudness Display Settings Dialog on page 134

Loudness Display Settings Dialog

In this dialog, you can specify how the loudness waveform is displayed.

• To open the Loudness Display Settings dialog, select the Loudness tab in 
the Audio Editor, and click Edit Settings.

Momentary Loudness/Short-Term Loudness

Color

Lets you edit the color of the associated element.

Curve Thickness

Lets you customize the curve thickness. If Auto Thickness is selected, the 
curve thickness increases when zooming in.

Show Range

If this option is activated, the dynamic range is visualized. This displays the 
difference between the recent minimum and maximum loudness values. The 
wider the band, the wider the dynamics.
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Range Transparency

Lets you specify the transparency of the range section.

Range Inertia

Determines the inertia of the loudness range, that is, how fast the range edges 
meet each other after a new minimum or maximum loudness is reported.

Integrated Loudness/Loudness Range/True Peaks

Color

Lets you edit the color of the associated element.

Curve Thickness

Lets you customize the curve thickness. If Auto Thickness is selected, the 
curve thickness increases when zooming in.

Only Show Hot Points (True Peaks section only)

If this option is activated, the curve is hidden and only the peak overloads are 
displayed as red bullets.

Axes

Upper/Reference/Lower

Lets you activate several axes, and edit their color and position in the loudness 
tab to get a visual reference.

Additional Color Settings

Background/Selected Background

Lets you edit the color of the associated element.

Additional Options

Curve Smoothing

If this option is activated, the transitions between the loudness measurements 
are smoothly drawn. This is less accurate when abrupt changes occur.

Apply to All Open Files

If this option is activated, the settings are applied to all open audio files when 
you click OK.

Magnetic Bounds in Audio Files

Some positions, such as markers or selection edges, can be defined as magnetic. 
Dragged elements can snap to these positions. This makes it easier to position 
items accurately.
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For example, if you move a marker and it gets close to one of the magnetic bounds, 
the marker snaps to this position. A label is displayed, indicating the snap position.

To place the cursor at a magnetic position, click the time line and keep the mouse 
button pressed. When you now move the cursor, it jumps to the next magnetic 
bound.

Magnets Menu

On this pop-up menu, you can specify which positions should be magnetic. If Snap 
to Magnets is activated, items that you move snap to these positions.

• To open the Magnets pop-up menu, select the Edit tab in the Audio Editor, 
and click Magnets.

You can let items snap to the following positions:

Start of File/End of File

Elements snap to the start/end of the file when they are moved near these 
positions.

Time Ruler Marks

Elements snap to the time ruler grid when they are moved near these 
positions.

Markers

Elements snap to marker positions when they are moved near these positions.

Selection Edges

Elements snap to the selection edges when they are moved near these 
positions.

Cursor

Elements snap to the edit cursor when they are moved near the cursor.

Zero Crossing

A zero crossing is a point where the waveform crosses the zero level axis. When you 
perform editing operations, such as cutting, pasting, or dragging, make sure that the 
material is inserted at a zero crossing.

If you do not perform these operations at zero crossings, this can result in 
discontinuities in the wave, which are perceived as clicks or pops in the sound.



Audio File Editing
Wave Window

137

Activate Zero-Crossing on the Edit tab of the Audio Editor to make sure that the 
selections that you make are always adjusted so that they start and end at the 
nearest zero crossing.

Setting Up the Zero Crossing Detection

You can let selection edges automatically snap to the nearest zero crossing point. 
In the Audio Files Preferences dialog, you can specify whether to allow snap at 
high zoom factors, and specify the scan range for the zero crossing detection.

PROCEDURE

1. In the Audio Editor, select the Edit tab.

2. In the Snapping section, activate Zero-Crossing.

3. Select File > Preferences > Audio Files.

4. In the Audio Files Preferences tab, select the Editing tab.

5. Make your settings in the Snap Selection to Zero-Crossing section.

6. Click OK.

Moving the Cursor Position to the Closest Zero Crossing

You can automatically move the cursor position to the closest zero crossing.

PROCEDURE

1. In the Audio Editor, select the View tab.

2. In the Cursor section, click Snap to Zero-Crossing.
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Audio Editor Tabs

The tabs in the Audio Editor give you access to the tools and options you need to 
edit audio files.

View Tab

Navigate

Backwards/Forwards

Navigates to the previous/next cursor position, zoom factor, and selection 
range.

Zoom

Time

Opens a pop-up menu that allows you to adjust the zoom to display the 
selected time range. Zoom in 1:1 zooms in so that one pixel on the screen 
represents one sample.

To edit the zoom factor, click Edit Zoom Factor. This opens the Zoom Factor 
dialog, where you can edit the following settings:

• Set Time Range allows you to specify the time range that you want to 
display.

• Samples per Screen Point allows you to specify how many audio 
samples are summarized in each screen point.

• Screen Points per Sample allows you to specify how many screen 
points are used to represent a single audio sample.

Zoom

Activates the Zoom tool that allows you to define a time range that is zoomed 
in.

Zoom Selection

Zooms the window so that the current selection occupies the entire montage 
window.

Microscope

Zooms in as far as possible.
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Zoom in Audio (10x)/Zoom out Audio (10x)

Zooms in/out in big steps.

View All

Zooms out as far as possible.

Zoom in Audio/Zoom out Audio

Zooms in/out in small steps.

Level

Adjusts the zoom to only display samples below the selected dB value.

Optimize Vertical Zoom

Changes the vertical zoom factor so that the peaks are clearly visible. This 
adjustment is done according to the section of the wave that is visible in the 
wave/montage window.

Reset Zoom to 0 dB

Adjusts the zoom to display audio levels up to 0 dB.

Zoom in Vertically/Zoom out Vertically

Zooms in/out to show waveforms with a lower/higher level.

Cursor

Move Cursor to Start of File/Move Cursor to End of File

Moves the cursor to the start/end of the file.

Previous Marker/Next Marker

Moves the cursor to the previous/next marker.

Start of Selection/End of Selection

Moves the cursor to the start/end of the selected time range.

Previous Region Edge/Next Region Edge

Moves the cursor to the previous/next region edge.

Snap to Zero-Crossing

Moves the edit cursor to the nearest zero crossing point.

Edit Cursor Position

Opens the Cursor Position dialog where you can edit the cursor position.

Scroll

Start/End

Displays the start/end of the audio without moving the cursor.
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Start of Selection/End of Selection

Displays the start/end of the audio selection without moving the cursor.

Cursor

Displays the cursor position.

Playback

Steady View

Deactivates scrolling.

View Follows Cursor

Automatically scrolls the view to keep the playback cursor visible.

Scroll View

Scrolls the view to keep the playback cursor centered.

Snapshots

Allows you to take, recall, and edit snapshots.

Presets

The buttons 1, 2, and 3 allow you to save a snapshot of the scroll position, 
zoom factor, cursor position, and audio selection. The rightmost preset button 
is a global preset that is available for all audio montages.

Options

Allows you to select which settings are restored when applying a snapshot 
preset. The following options are available:

• Scroll Position and Zoom

• Cursor Position

• Audio Selection

Peaks

Rebuild Peak Display

Normally, peak files are automatically updated when the date of the peak file 
is older than the date of the audio file. However, it can happen that the date 
of the audio file is wrong and therefore not automatically updated. In this 
option allows you to rebuild the peak file.
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Edit Tab

Tools

Time Selection

Tool that allows you to select a time range.

Spectrum Selection

Tool that allows you to select a frequency range.

Pen

Tool that allows you to redraw the waveform in the wave window. This can be 
used to quickly repair waveform errors.

Play

Tool that allows you to play back the audio file at the position where you click.

Time Selection

Range

Opens the Audio Range dialog, where you can define selection ranges very 
accurately.

Extend

This pop-up menu contains various options for creating or extending selection 
ranges.

Toggle

Toggles the current audio selection.

All

Selects the entire waveform.

Channels

This pop-up menu allows you to change the channel selection.

• Extend to All Channels extends the current selection range to all 
channels.

• Left Channel Only reduces the current selection range to the left 
channel only.

• Right Channel Only reduces the current selection range to the right 
channel only.
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Regions

This pop-up menu allows you to select a range between two markers.

• CD Track selects the range between the two CD track markers that 
encompass the edit cursor.

• Loop Region selects the range between the two loop markers that 
encompass the edit cursor.

• Exclusion Region selects the range between the two exclusion 
markers that encompass the edit cursor.

• Generic Region selects the range between the two generic markers 
that encompass the edit cursor.

Clipboard

Cut

Cuts the active clip to the clipboard.

Copy

Copies the active clip to the clipboard.

Right-click Copy to open a pop-up menu with additional options:

• Memorize Cursor Position copies the position of the edit cursor to the 
clipboard.

• Memorize Selection Length copies the length of the active selection 
range to the clipboard.

Paste

Pastes the clipboard content.

Right-click Paste to open a pop-up menu that allows you to select a paste 
type.

• Overwrite replaces the audio at the paste position.

• Append adds the pasted audio after the end of the file.

• Prepend adds the pasted audio before the beginning of the file.

• Multiple Copies opens a dialog in which you can enter the number of 
copies that you want to create.

• Mix blends two files into each other, starting at the selection or, if there 
is no selection, at the cursor position.
If you select Mix, a dialog opens, allowing you to specify the gain for the 
audio on the clipboard and at the destination. All the data on the 
clipboard is always mixed in, regardless of the length of the selection.

Paste and Crossfade

Pastes the clipboard content and creates a crossfade.

Right-click Paste and Crossfade to open a pop-up menu that allows you to 
select a crossfade type for pasting.
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• Linear (Equal Gain) changes the level linearly.

• Sinus (Equal Power) changes the level according to a sine curve, the 
power of the mix remains constant.

• Square-Root (Equal Power) changes the level according to a 
square-root curve, the power of the mix remains constant.

Cutting

Crop

Deletes the data outside the selection.

Delete

Deletes the selection. The audio to the right of the selection is moved to the 
left to fill the gap.

Smooth Delete

Deletes the selection and inserts crossfades at the edges. You can edit the 
default length and type for the crossfade in the Audio Files Preferences, on 
the Editing tab.

Mute Selection

Replaces the audio selection with silence.

Silence Generator

Opens the Silence Generator dialog that allows you to insert silence or 
background noise in an audio file.

Swap Stereo Channels

Moves the audio in the left channel to the right channel, and vice versa.

Nudge

Nudge Left

Nudges the audio selection to the left.

Nudge Right

Nudges the audio selection to the right.

Snapping

Zero-Crossing

If this option is activated, the start and the end of a selected range always 
snap to a zero-crossing point of the waveform.

Snap to Magnets

If this option is activated, moved elements such as clip edges, time selection 
edges, cursor, and markers snap to the magnets that are activated on the 
Magnets pop-up menu.
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Insert Tab

Markers

Marker Name

Lets you enter the name of the start and end marker. If nothing is entered, a 
generic name is used.

To edit the default names, open the Markers window, and select Functions 
> Default Marker Names.

Different Name for End Marker

If this option is activated, you can enter a different name for the end marker.

If this option is deactivated, the name of the start marker is also used for the 
end marker.

Create Marker

Allows you to create different types of markers and marker pairs at the edit 
cursor position or at the selection range.

Audio File

At Start

Allows you to insert an audio file at the start of the active audio file.

At End

Allows you to insert an audio file at the end of the active audio file.

At Cursor

Allows you to insert an audio file at the cursor position.

Process Tab
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Level

Gain

Opens the Gain dialog where you can apply a gain to change the level of an 
audio file.

Envelope

Opens the Envelope dialog where you can create a level envelope which can 
be applied to a selected range or a entire audio file.

This is useful if you want to even out loud and quiet parts or create a 
sophisticated fade in/fade out, for example.

Remove DC Offset

DC offset in a file affects the loudness. Remove DC Offset sets the DC offset 
to zero.

Normalizing

Level

Opens the Level Normalizer dialog where you can change the peak level of 
an audio file.

Loudness

Opens the Loudness Normalizer dialog where you can specify the loudness 
of a file.

Pan

Opens the Pan Normalizer dialog which allows you to ensure that both 
channels of a stereo file have the same level or loudness, and helps you to get 
the best possible stereo balance.

Fading

Fade In/Fade Out

Allows you to apply a fade in or fade out. Right-click the button to open the 
Curve pop-up menu.

Curve

Allows you to select preset fade curves.

• Linear changes the level linearly.

• Sinus (*) changes the level according to a sine curve. When used in a 
crossfade, the loudness (RMS) remains constant during the transition.

• Square-Root (*) changes the level according to a square-root curve. 
When used in a crossfade, the loudness (RMS) remains constant 
during the transition.

• Sinusoid changes the level according to a sine curve.

• Logarithmic changes the level according to a logarithmic curve.
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• Exponential changes the level according to an exponential curve.

• Exponential+ changes the level according to a more pronounced 
exponential curve.

Time & Pitch

Time Stretching

Opens the Time Stretching dialog where you can change the duration of an 
audio selection.

Pitch Shifting

Opens the Pitch Shifting dialog where can change the pitch of your audio.

Resample

Opens the Sample Rate dialog where you can change the sample rate of 
your audio.

Pitch Bend

Opens the Pitch Bend dialog where you can gradually change the pitch of 
your audio using an envelope curve.

Pitch Quantizing

Opens the Pitch Quantizing dialog where you can automatically detect and 
correct the pitch of your audio. The input signal is quantized to discrete notes.

Reverse

Creates a backwards-tape effect.

Correct

Error Correction

Lets you select the default error correction method.

• Linear Interpolation draws a straight line between the first and the last 
selected samples.

• Optimal for Small Clicks – 1 ms is optimal to remove clicks smaller 
than 1 ms.

• Optimal for Common Clicks – 3 ms is optimal to remove clicks smaller 
than 3 ms.

• Waveform Replacement – 500 ms replaces the corrupt samples with 
the best match detected in the material up to 500 milliseconds to the 
left/right.

• Waveform Replacement – 4 s replaces the corrupt samples with the 
best match detected in the material up to 4 seconds to the left/right.

• Waveform Replacement – Left 6 s replaces the corrupt samples with 
the best match detected in the material up to 6 seconds to the left.
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• Waveform Replacement – Right 6 s replaces the corrupt samples with 
the best match detected in the material up to 6 seconds to the right.

Loop

Tweaker

Opens the Loop Tweaker dialog where you can adjust the loop start and end 
points, and crossfade the loop boundaries.

Tone Uniformizer

Opens the Loop Tone Uniformizer dialog where you can create loops from 
sounds that are not optimal for looping.

Split

Auto Split

Opens the Auto Split dialog where you can specify how to split clips.

Other

Invert Phase

Turns the signal upside down.

Effect Morphing

Opens the Effect Morphing dialog, where you can gradually mix two audio 
ranges that have different effects/processing applied to them.

External Tools

Allows you to execute and configure external tools.

Analyze Tab

Tools

Global Analysis

Opens the Global Analysis dialog where you can analyze peaks, loudness, 
pitch, DC offset, and errors in the audio file.
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Audio File Comparator

Opens the Audio File Comparator dialog where you can compare two audio 
files.

3D Frequency Analysis

Opens the 3D Frequency Analysis dialog where you can define which 
frequency range is analyzed and modify the appearance of the graph for the 
3D frequency analysis.

Monitoring

Playback

This is the standard metering mode, in which the meters reflect the audio that 
is played back. Metering occurs after the Master Section, which means that 
effects, dithering, and master faders are taken into account. You can monitor 
playback in audio files, audio montages, audio CD track lists, etc.

Audio Input

In this mode, the meters reflect the audio input. Typically, this is the mode to 
use when recording. The Master Section settings are not taken into account.

File Rendering

In this mode, you can monitor what is being written to disk during file 
rendering or recording. Average and min/max peak values are calculated. 
After rendering, the meters freeze until you refresh or change the monitor 
mode.

Edit Cursor

In this mode, the meters are static, showing the levels and other values for the 
audio at the position of the edit cursor, in stop mode. This allows you to 
analyze a specific position in an audio file in real-time. The Master Section 
settings are not taken into account.

Audio Selection

In this mode the meters display the average values calculated for a selected 
range. The Master Section settings are not taken into account.

When you change the selection, you have to update the meter displays by 
clicking Update Selection Analysis.

Freeze Meters

This mode freezes the values for all open meters. The meters remain frozen 
until you select another monitor mode or deactivate Freeze Meters.

Floating Meters

Show/Hide

Shows/Hides floating meters.
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Render Tab

Source

Auto Select Source

If this option is activated, the source is automatically selected according to the 
selection that you make in the audio file. If there is no selection, the whole 
audio file is processed.

The Source pop-up menu allows you to select which part of the audio file you want 
to process. The following options are available:

Whole File

Processes and renders the whole audio range.

Selected Audio Range

Processes and renders the selected audio range.

Specific Region

Processes and renders a specific audio range to an independent file.

Specify the region to process on the pop-up menu.

All Regions

Processes and renders each marked audio range to an independent file. By 
defining multiple isolated regions in an audio file, you can process them in one 
operation.

Specify the type of regions to process on the pop-up menu.

Result

In Place

If this option is activated, the rendered audio range replaces the source audio 
range.

Unnamed File

If this option is activated, the rendered file is named untitled.

Named File

If this option is activated, you can specify a name for the rendered file.
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Output

Name

Allows you to enter a name for the rendered file. Clicking the arrow icon opens 
a pop-up menu that offers you several naming options.

Scheme

Allows you to specify a naming scheme for the file name.

Location

Allows you to select a destination folder for the rendered files.

Format

Opens a pop-up menu where you can select a single file format or multiple file 
formats.

Options

Depending on the selected source, different options are available.

Bypass Master Section

If this option is activated, the plug-ins and gain of the Master Section are 
bypassed when rendering.

Exclude Master Section Bypassed Plug-ins

If this option is activated, the plug-ins that are bypassed in the Master 
Section during playback are not used for rendering.

Fade In/Out at Boundaries

If this option is activated, a fade is performed at the audio range boundaries 
when a new file is created, or a crossfade with the adjacent audio is created 
if the audio range is processed in place.

Crossfades allow for smooth transitions between the processed and the 
non-processed parts. The crossfade time and shape are set in the Audio 
Files Preferences. If the fade time is longer than half the length of the 
processed file, the fade is not performed.

No Reverb Tail

If this option is activated, the audio tail produced by effects such as reverb is 
not included in the rendered file.

Some plug-ins do not transfer information on the tail duration to WaveLab. In 
this case, this option has no effect. For such plug-ins, you can add the 
Silence plug-in to add extra samples at the end of the file.

Copy Markers

If this option is activated, the markers that are included in the range to process 
are copied to the rendered file.



Audio File Editing
File Handling in the Audio Editor

151

Skip Exclusion Region

If this option is activated, muted audio ranges are skipped and not included in 
the result.

Open Resulting Audio File

If this option is activated, every rendered file is opened in a new window.

Open Files in New File Group

If this option is activated, the rendered audio file is imported in a new file 
group.

Bypass Master Section on Resulting Audio File

If this option is activated, playback of the resulting audio file bypasses the 
entire Master Section. This setting can be toggled by clicking the button at 
the bottom right of the wave window or montage window.

NOTE

It is recommended to activate this option, because this way, you do not 
monitor new files through the effects that have already been applied to them.

Include Pause before Track

If this option is activated and you render CD tracks, a pause is included before 
each CD track in the rendered file.

Include Pause after Track

If this option is activated and you render CD tracks, a pause is included after 
each CD track in the rendered file.

Upload to SoundCloud

If this option is activated, the rendered file is uploaded to SoundCloud.

Render

Start

Starts the rendering process.

File Handling in the Audio Editor

Mono/Stereo Handling

WaveLab Pro is very flexible in its handling of stereo. All editing operations can be 
performed on either one channel or on both.
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Supported File Formats

WaveLab Pro can open and save audio files in a number of file formats.

Wave (.wav)

The following bit resolutions are supported: 8 bit, 16 bit, 20 bit, 24 bit, and 
32 bit (float).

Wave 64 (.w64)

This file format is very similar to the Wave format but with one important 
difference: it allows you to record and/or edit files of virtually any length. 
Standard Wave files are limited to 2 GB (stereo files) in WaveLab Pro.

NOTE

Wave 64 does not support meta-data. If you need large files and meta-data, 
use Wave files and activate the RF64 option.

WavPack (.wv/.wvc)

This file format allows digital audio to be losslessly compressed, including 
32 bit float audio files.

RF64

In the Audio Files Preferences, on the File tab, you can activate the RF64 
file format support. If this is activated, the standard Wave file format switches 
automatically to the RF64 file format as soon as the file size exceeds 2 GB, 
without any performance loss or interruption. This is useful when recording 
very long sessions. A RF64 file has the extension .wav, but it can only be 
opened with an application that supports the RF64 standard if the file 
exceeds 2 GB.

AIFF (.aif, .aiff, .snd)

Audio Interchange File Format, a standard defined by Apple Computers Inc. 
The following bit resolutions are supported: 8 bit, 16 bit, 20 bit, and 24 bit.

MPEG-1 Layer 3 (.mp3)

The most common audio compression format. The major advantage of MPEG 
compression is that the file size is significantly reduced, while there is little 
degradation of sound quality.

NOTE

When you open an MPEG compressed file in WaveLab Pro, the file is 
converted to a temporary wave file. On saving, the temporary wave file is 
converted back to MP3.

MPEG-1 Layer 2 (.mp2, .mpa, .mpg, .mus)

MP2 (sometimes referred to as “Musicam files”) is a common file format in the 
broadcast industry.
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Original Sound Quality (.osq, read only)

This is the proprietary lossless compressed audio format of WaveLab Pro.

Sound Designer II (.sd2)

This audio file format is used by Digidesign applications (such as Pro Tools). 
The following bit resolutions are supported: 8 bit, 16 bit, and 24 bit.

U-LAW (.ulaw, .vox)

This is an audio encoding and compression technique supported by 
Windows and Web phones, using 8 bit resolution. The U.S. telephone system 
uses U-law encoding for digitization.

A-LAW (.alaw, .vox)

This is an audio encoding and compression technique for telephony, using 
8-bit resolution. The EU telephone system uses A-law encoding for 
digitization.

Sun/Java (.snd, .au)

This is an audio file format used on Sun and NeXT computers. The following 
bit resolutions are supported: 8 bit, 16 bit, and 24 bit.

ADPCM – Microsoft/Dialogic (.vox)

This is a format commonly used for games and telephony applications. It 
offers a lower bit rate than linear PCM and therefore requires less storage 
space/bandwidth.

Ogg Vorbis (.ogg)

Ogg Vorbis is a compressed file format that is open, patent-free, and which 
creates very small audio files maintaining comparatively high audio quality.

Text/Excel (.txt)

This is a text representation of a waveform. By saving an audio file as a text file 
and then opening it in a spreadsheet application such as Excel, you can view 
it in textual, decimal form, and edit the sample values. When you open a text 
file representing a waveform in WaveLab Pro, it is decoded and opened as an 
audio file. These files are not compressed in any way, so they can become 
very large.

When using 32-bit float files, the .txt format is not 100 % lossless. This is 
because it is not possible to express a binary floating point value in textual 
decimal form without some precision loss.

Windows Media Audio (.wma, .asf)

Microsoft’s own compressed format. WaveLab Pro lets you import/export 
audio in this format (Windows only). To import/export audio in WMA surround 
format, Windows Media Player 9 or later must be installed on your system.

Ensoniq Paris (.paf)

Used by the Ensoniq Paris™ system. The following bit resolutions are 
supported: 16 bit and 24 bit.
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Raw PCM files (.raw, .bin, .pcm, .$$$)

In this format, no information about bit resolution or sample rate is included. If 
you open a file in this format, WaveLab Pro asks you to specify the bit 
resolution and sample rate. If this is not done correctly, the file will not play 
back as intended.

FLAC (.flac)

Free Lossless Audio Codec (FLAC) is a codec which allows digital audio to 
be losslessly compressed.

AAC (.aac)

Advanced Audio Coding (AAC) is a codec that allows lossy compression and 
encoding scheme for digital audio.

NOTE

The “$$$” file type is a temporary file format of WaveLab Pro. If you experience a 
computer crash, you may restore some of your work by opening any “$$$” files on 
your hard disk.

20-bit, 24-bit, and 32-bit Float Files

You do not need a 20-bit or 24-bit audio card to take advantage of the fact that 
WaveLab Pro can handle 20-bit and 24-bit audio files. Any processing or editing 
performed on the files is always done at full resolution (32-bit float), even if your card 
does not support the full resolution.

For playback, WaveLab Pro automatically adapts to the card that you have installed.

Creating a New Audio File

You can create an empty audio file, to assemble material from other audio files, for 
example.

PROCEDURE

1. Select File > New.

2. Click Audio File > Custom.

3. Specify the audio properties and click Create.

Saving an Audio File

PROCEDURE

1. Do one of the following:
• To save an audio file that has never been saved before, select File > Save As.
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• To save an audio file that has been saved before, click the Save button, or 
select File > Save.

2. In the Save As window, specify a file name and location.

3. Click Save.

Saving in Another Format

You can change the file format, sampling frequency, bit resolution, and stereo/mono 
status when saving.

PROCEDURE

1. Select File > Save As.

2. In the Save As window, specify a file name and location.

3. Click in the Format field and select Edit.

4. In the Audio File Format dialog, set the file format and specify the properties.

5. Click OK.

6. Click Save.

RESULT 

A new file is created. The original file is not affected by the operation.

Audio File Format Dialog

In this dialog, you can change various file settings when saving.

• To open the Audio File Format dialog, select File > Export, and select 
Render > Single or Render > Multi. Then activate Named File, click in the 
Format field, and select Edit Single Format.

This dialog can also be opened from various other locations in WaveLab Pro.
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Type

Select an audio file type. This affects which options are available on the Audio 
Format menu.

File Extension

Select a file extension that is compatible with the current file type.

Audio Format

Select an audio format that is compatible with the current file type.

Channels

Specify the number of audio channels for the files to be created. For 
multichannel audio montages, you can create multiple files.

Sample Rate

Select a sample rate for the audio file. If you change this setting, a sample rate 
conversion takes place.

IMPORTANT

Use this only for simple conversions. For professional results, use the 
Resample plug-in and add limiting and dithering.

Bit Resolution

Select a bit resolution for the audio file. This option is only available for 
specific file types.

IMPORTANT

Reducing the bit resolution is only advised for simple conversions. For 
professional results, it is recommended to add dithering in the Master 
Section.

Meta-Data

Lets you make meta-data settings that are saved with the file. This option is 
only available for some file types.

• If Do Not Save Anything is selected, no meta-data are saved with the 
file.

• If Inherit from Source File is selected, the meta-data of the source file 
are used. If the source meta-data is empty, the default meta-data is 
used, if available. For example, this can be used to create Wave files 
with a Unique Material Identifier (BWF standard).

• If selecting Specific to This Configuration is selected, you can edit the 
meta-data, or replace it with a meta-data preset. To edit the meta-data, 
open the meta-data pop-up menu again, and select Edit.
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Single File Format/Multiple File Format

Switches between the Audio File Format dialog and the Multi Audio File 
Format dialog.

Changing the Format

When changing the sample rate, bit resolution, and number of channels of an audio 
file, several operations are performed.

Sample Rate

If a new sample rate is specified, a sample rate conversion is performed.

Bit Resolution

If a different bit resolution is specified, the file is either truncated down to 8 
bits, or padded up to 64 bits. If you are converting to a lower bit resolution, 
you should consider adding dithering.

Mono/Stereo

If the file is converted from mono to stereo, the same material is used in both 
channels. If the conversion is from stereo to mono, a mix of the two channels 
is created.

NOTE

• If you only want to change the bit resolution, you can do this in the Audio 
Properties section of the Info window instead, and then save the audio file.

• For high quality mastering purposes, it is not recommended to change the 
sample rate and number of channels using the Audio Properties section, but 
instead use plug-ins and functions of the Master Section.

Saving a Selection as an Audio File

You can save a selection in the open audio file as a new audio file.

PROCEDURE

1. In the wave window, make a selection range.

2. In the Audio Editor, select the Render tab.

3. In the Source section, open the pop-up menu and select Selected Audio 
Range.

4. In the Output section, specify a file name and location.

5. Open the Format menu and select Edit Single Format.

6. In the Audio File Format dialog, specify the output format and click OK.

7. In the Render section, click Start.
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Saving Left/Right Channel as Audio File

You can save each channel individually into a separate file. Use this option when 
editing dual mono files, for example.

PROCEDURE

1. In the Audio Editor, select the Render tab.

2. In the Output section, specify a file name and location.

3. Open the Format menu and select Edit Single Format.

4. In the Audio File Format dialog, open the Channels pop-up menu, and 
select Left Channel or Right Channel.

5. Make additional output settings and click OK.

6. In the Render section, click Start.

Encoding Audio Files

Audio can be saved in different formats. The process of converting audio to another 
format is called encoding. When saving audio files, you can specify various 
encoding options for some file formats.

MP3 Encoding Dialog

You can edit the encoding options when you save an MP3 audio file.

You can open the MP3 Encoding dialog from most places where you can select an 
output file format. For example, open an audio file, select File > Save As, click in 
the Format field, and select Edit. In the Audio File Format dialog, select MPEG-1 
Layer 3 (MP3) as type, click the Encoding field, and select Edit.
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Encoder

Lets you select the encoder (Fraunhofer or Lame).

Constant/Variable Bit Rate

The bit rate is related to the quantity of data used to encode the audio signal. 
The higher the value, the better the quality, but the larger the output file. If you 
choose Variable Bit Rate, the rate changes, according to the complexity of 
the audio material.

Highest Quality (Slowest)/Fastest

Select the quality that you want to achieve. The higher the quality, the more 
resources and time are required to analyze and compress the audio signal.

NOTE

Highest Quality (Slowest) can require a specific sample rate for the audio 
file. If this is the case and the sample rate is different from the input sample 
rate, a message is displayed.

When you use the Lame encoder, you can make additional settings on the 
Advanced tab.

Allow Intensity Stereo Coding

Decreases the bit rate by reorganizing the intensity information between the 
channels.

Specify as Original Recording

Marks the encoded file as the original recording.

Write Private Bit

This is a custom flag.

Write Copyright Flag

Marks the encoded file as copyright protected.

Write Check-Sum

Allows other applications to check the integrity of the file.

Create Long Frames

Saves space by writing fewer headers in the file (not compatible with all 
decoders).

AAC Encoding Dialog

You can edit the encoding options when you save an AAC audio file.

You can open the AAC Encoding dialog from most places where you can select an 
output file format. For example, open an audio file, select File > Save As, click in 
the Format field, and select Edit. In the Audio File Format dialog, select AAC 
(Advanced Audio Coding) as type, click the Encoding field, and select Edit.
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Container

Specifies the container for the AAC file. A container is a file format that can 
contain compressed audio data and meta-data.

• MPEG-4 (recommended format for iTunes)

• 3GPP (3rd Generation Partnership Project)

• ADIF (Audio Data Interchange Format)

• ADTS (Audio Data Transport Stream)

• ADTS (with CRC)

• LATM LOAS (Low Overhead Audio Stream)

Audio Compression Method

Lets you select the audio compression method.

• LC (Low Complexity, iTunes standard)

• HE (High Efficiency)

• HE v2 (High Efficiency, Parametric Stereo)

• HD 16 bit (Lossless)

• HD 24 bit (Lossless)

LC (Low Complexity) does not mean lower quality, but less compression 
attempts. It is used for best audio quality.

HE (High Efficiency) is an extension of Low Complexity AAC (AAC LC) and 
is optimized for low-bit-rate applications, for example, streaming audio.

HE v2 enhances the compression efficiency of stereo signals. HE formats 
provide extremely compressed audio files with a high quality sound.
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HD is an extension to the MPEG-4 standard and allows lossless audio 
compression that is scalable to lossy compression. This means that the 
decoding can be lossless or lossy, depending on the decoder settings. 
However, the file size is larger than with the other compression methods.

Constant/Variable Bit Rate

The bit rate is related to the quantity of data that is used to encode the audio 
signal. The higher the value, the better the quality, but the larger the output 
file. If you choose Variable Bit Rate, the rate changes over time according to 
the complexity of the audio material.

Quality

Select the quality that you want to achieve. The higher the quality, the more 
resources and time are required to analyze and compress the audio signal.

NOTE

Highest Quality can require a particular sample rate for the audio file.

MPEG-1 Layer 2 Encoding Dialog

You can edit the encoding options when you save an MPEG-1 Layer 2 (MP2) audio 
file.

You can open the MPEG-1 Layer 2 Encoding dialog from most places where you 
can select an output file format. For example, open an audio file, select File > Save 
As, click in the Format field, and select Edit. In the Audio File Format dialog, select 
MPEG-1 Layer 2 as type, click the Encoding field, and select Edit.

Bit Rate

Determines the bit rate. The bit rate is related to the quantity of data that is 
used to encode the audio signal. The higher the value, the better the quality, 
but the larger the output file.

Stereo Encoding

In Standard mode, the encoder does not use the correlation between 
channels. However, the encoder can take space from a channel that is easy 
to encode and use it for a complicated channel.
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In Joint mode, the encoder uses the existing correlations between the two 
channels to increase the ratio quality/space.

In Dual mode, both channels are independently encoded. This mode is 
recommended for signals with independent channels.

Specify as Original Recording

Marks the encoded file as the original recording.

Write Private Bit

This is a custom flag.

Write Copyright Flag

Marks the encoded file as copyright protected.

Write Check-Sum

Allows other applications to check the integrity of the file.

Encode Peaks (Ancillary Data)

This must be activated for compatibility with specific systems, for example, 
DIGAS.

FLAC Encoding Dialog

You can edit the encoding options when you save a FLAC audio file.

You can open the FLAC Encoding dialog from most places where you can select 
an output file format. For example, open an audio file, select File > Save As, click 
in the Format field, and select Edit. In the Audio File Format dialog, select FLAC 
as type, click the Encoding field, and select Edit.

Compression Level

Lets you specify the compression level. The more compression, the slower the 
encoding.
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Ogg Vorbis Dialog

You can edit the encoding options when you save an Ogg Vorbis audio file.

You can open the Ogg Vorbis dialog from most places where you can select an 
output file format. For example, open an audio file, select File > Save As, click in 
the Format field, and select Edit. In the Audio File Format dialog, select Ogg 
Vorbis as type, click the Encoding field, and select Edit.

Average Bit Rate

If this option is activated, the average bit rate in the file remains constant 
during encoding. Because the file size is proportional to time, the localization 
of a given point is easier, but it can result in a lower quality compared to the 
Variable Bit Rate option.

Variable Bit Rate

If this option is activated, the bit rate in the file will vary during encoding, 
depending on the complexity of the material. This can give a better quality/size 
ratio in the resulting file.

In the Quality field, select the quality. Lower quality settings result in smaller 
files.

Windows Media Audio Encoding Dialog

You can edit the encoding options when you save a Windows Media Audio (WMA) 
audio file. This dialog is only available in on Windows systems.

You can open the Windows Media Audio dialog from most places where you can 
select an output file format. For example, open an audio file, select File > Save As, 
click in the Format field, and select Edit. In the Audio File Format dialog, select 
Windows Media Audio (WMA) as type, click the Encoding field, and select Edit.
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Encoder

Sets the encoder.

Output Sample Rate

Sets the output sample rate of the encoded file. The higher the sample rate, 
the higher the quality, but the larger the output file.

Output Bit Resolution

Sets the output bit resolution of the encoded file. This parameter is not 
available for all encoders.

Channels and Bit Rate

The available items here depend on the selected encoding method and the 
output sample rate.

VBR (Variable Bit Rate)

If this option is activated, the bit rate in the file will vary during the encoding, 
depending on the complexity of the material. This can produce a better 
quality/size ratio in the output file.

In the Quality field, select the quality. Lower quality settings result in smaller 
files.

Two-Pass Encoding

If this option is activated, the encoding quality increases, but the process 
takes twice as long.

Constrained Bit Rate

This option is available when the VBR and Two-Pass Encoding options are 
activated. This is used to maintain the bit rate within limits to avoid peaks. This 
is recommended for media, such as CD or DVD.
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Creating an Audio Montage from an Audio File

You can export audio files to an audio montage, including all markers that you have 
set in the audio file.

PROCEDURE

1. In the Audio Editor, open the audio file that you want export to an audio 
montage.

2. Optional: If you want to use a specific time range of the audio file, create a 
selection range in the wave window.

3. Select File > New.

4. Select Audio Montage > From Current File.

5. In the From Current Audio File section, click Insert Audio File in New 
Montage.

6. Click Create.

7. In the Create Audio Montage from Audio File dialog, select whether to 
import the whole file or the selected audio range.

8. Optional: Decide if you want to perform any of the following marker 
operations:
• Import Markers

• Split at Generic Region Markers

• Split at CD Track Markers

9. Click OK.

Inserting Audio Files into Another Audio File

You can assemble an audio file from several audio files.

PROCEDURE

1. In the Audio Editor, open the audio file in which you want to insert another 
audio file.

2. If you want to insert an audio file at the edit cursor position, make sure that 
Snap to Magnets is activated, and that Cursor is activated on the Magnet 
pop-up menu.
The edit cursor snaps to the nearest zero crossing. This avoids glitches.

3. Select the Insert tab.

4. In the Audio File section, select one of the following insert options:
• At Start

• At End
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• At Cursor

If you select At Cursor, the audio file is cut at the insert position. The part after the 
cut is moved to the right.

5. On the pop-up menu, select the audio file that you want to insert.

RELATED LINKS

Magnetic Bounds in Audio Files on page 135

Turning Selections Into New Files

You can turn selections into new files via drag and drop or by using the Render tab 
in the Audio Editor.

Turning Selections Into New Files By Dragging

PROCEDURE

1. Make a selection in the wave window.

2. Drag the selection to the tab bar above the wave window and release the 
mouse button.

RESULT 

The selection opens in a new stereo window.

Turning Selections Into New Files Using the Menu

PROCEDURE

1. Make a selection in the wave window.

2. Right-click the selection and select Copy Selection to New Window.

3. From the submenu, select one of the following options:
• Exact Copy

• Stereo Version

• Mono Mixdown

• Mono Mixdown (Subtract Right Channel from Left Channel)

RESULT 

The selection opens in a new stereo or mono window.
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Special File Format Dialog

When opening files via the Unknown Audio option, you can specify how to 
interpret the format of the audio file that you want to open.

• To open the Special File Format dialog, select File > Import, click 
Unknown Audio, and select the file that you want to open.

Sample Format

Specifies the binary representation of the samples in the file.

Byte Order

Specifies the order in which bytes should be interpreted. This only applies for 
16 bit or more.

Channels

Specifies the number of audio channels in the audio file.

Data to Ignore (Number of Bytes)

Specifies how many bytes at the start and end of the audio file are ignored.

Sample Rate

Specifies the sample rate of the audio file.

File Extension

Specifies the default file name extension for the audio file. When the file 
selector opens after closing this dialog, only the file with this extension is 
displayed.
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Dual Mono Files

Dual mono files are two mono files that are the left and right channels of a stereo 
recording. You can open several dual mono files at the same time and have them 
grouped automatically, provided the files have channel tags in their file names.

You can open dual mono files like stereo files in the Audio Editor, the Audio 
Montage window, and the Batch Processor window.

In the Audio Files Preferences, on the File tab, you can set the channel ID for the 
left and right channel, and the channel ID to add to dual mono files when saving the 
files. Up to 7 name descriptors can be defined, each of which can be of the type 
Suffix or Advanced.

In the Advanced mode, the channel ID can be located anywhere in a file name. For 
this purpose, a name pattern must be defined. This name pattern must have a 
{capture} section.

Name matching is not case sensitive and the file extension is ignored.

By default, WaveLab Pro recognizes the file name endings “.L/.R”, “-L/-R”, or 
“_L/_R” as the left and right channels.

Allowing Opening of Dual Mono Files

NOTE

To avoid accidentally opening two separate mono files as a dual mono file, you 
should only activate Allow Opening of Dual Mono Files when you are opening 
dual mono files.

PROCEDURE

1. Select File > Preferences > Audio Files.

2. Select the File tab.

3. Activate Allow Opening of Dual Mono Files.

4. If you want to open several dual mono files at the same time, define the naming 
scheme of the dual mono files in the Dual Mono File Identification section.

Opening Dual Mono Files in the Audio Editor

PREREQUISITE 

Activate Allow Opening of Dual Mono Files and place the dual mono files in the 
same folder.

PROCEDURE

1. Open the audio file in which you want to open the dual mono files.

2. Select File > Open.
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3. Select Audio File > Browse.

4. Browse to the file location.

5. Select the dual mono files that you want to open and click Open.

RELATED LINKS

Allowing Opening of Dual Mono Files on page 168

Opening Dual Mono Files in the Audio Montage Window

PREREQUISITE 

Activate Allow Opening of Dual Mono Files and place the dual mono files in the 
same folder.

PROCEDURE

1. Open the audio montage in which you want to open the dual mono files.

2. Select File > Open.

3. Select Audio Files > Browse.

4. Browse to the file location.

5. Select the dual mono files that you want to open, and click Open.

6. In the Insert Audio Files dialog, make your settings.

7. Click OK.

Opening Dual Mono Files in the Batch Processor Window

PREREQUISITE 

Activate Allow Opening of Dual Mono Files and place the dual mono files in the 
same folder.

PROCEDURE

• In the Batch Processor window, drag the dual mono files from the File 
Browser window to the Files to Process list, or use the Insert options on the 
Edit tab.

Dual mono files are displayed in purple in the list.
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Converting From Stereo to Mono and From Mono to Stereo

You can convert audio files from mono to stereo and from stereo to mono. 
Converting a mono file into a stereo file produces an audio file that contains the 
same material in both channels, for example for further processing into real stereo. 
Converting a stereo file into a mono file mixes the stereo channels to a mono 
channel.

Converting a Selection From Stereo to Mono

PROCEDURE

1. Make a stereo selection in the wave window.

2. Select File > New.

3. Select Audio File > From Current File.

4. Select one of the following options:
• To mix the left and right stereo channels when converting to mono, click Mono 

Mixdown.

• To mix the left channel with the inverse of the right channel when converting to 
mono, click Mono Mixdown (Subtract Right Channel from Left Channel).
The resulting mono wave contains the difference between the channels. For 
example, this allows you to verify that a wave file really is a true stereo file rather 
than a mono file converted to stereo format.

RESULT 

The selection opens in a new mono window.

Converting From Stereo to Mono While Saving

PROCEDURE

1. Make a stereo selection in the wave window.

2. Select File > Save As.

3. In the Save As window, specify a file name and location.

4. Click in the Format field and select Edit.

5. In the Audio File Format dialog, open the Channels menu and select one of 
the mono settings.
For example, when selecting Mono (Mix -3 dB), the resulting audio file is attenuated 
by 3 dB.

6. Click OK.

7. Click Save.
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Converting a Selection From Mono to Stereo

PROCEDURE

1. Make a mono selection in the wave window.

2. Select File > New.

3. Select Audio File > From Current File.

4. Click Stereo Version.

5. Click Create.

RESULT 

The selection opens in a new stereo window.

Swapping Channels in a Stereo File

You can swap the two channels in an audio file, that is, you can move the audio in 
the left channel to the right channel, and the audio in the right channel to the left 
channel.

• To swap the channels of the whole audio file in the Audio Editor, select the 
Edit tab, and in the Cutting section, click Swap Stereo Channels.

• To swap the channels only a selected range of the audio file, make a selection 
range in the wave window, select the Edit tab, and in the Cutting section, 
click Swap Stereo Channels.

Special Paste Options

On the Paste pop-up menu in the Audio Editor, you find additional paste options.

• To access the special paste option, open the Audio Editor, select the Edit 
tab, and in the Clipboard section, right-click Paste.

Overwrite

Overwrites data in the destination file, rather than moving data to make room 
for the inserted audio. How much is overwritten depends on the selection in 
the destination file:

• If there is no selection in the destination file, a section with the same 
length as the pasted selection is overwritten.

• If there is a selection in the destination file, the pasted selection 
replaces that selection.

Append

Adds the pasted audio after the end of the file.
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Prepend

Adds the pasted audio before the beginning of the file.

Multiple Copies

Opens a dialog in which you can enter the number of copies that you want to 
create.

Mix

Blends two files into each other, starting at the selection or, if there is no 
selection, at the cursor position.

• When you select the Mix option, a dialog opens, allowing you to specify 
the gain for the audio on the clipboard and at the destination.

• All the data on the clipboard is always mixed in, regardless of the length 
of the selection.

Moving Audio

You can rearrange the order of the audio in a file by dragging, and cutting and 
pasting.

Moving Audio by Dragging

PREREQUISITE 

Decide whether you want to use Snap Selection to Zero-Crossing.

PROCEDURE

1. In the wave window, make a selection.

2. Drag the selection to a position outside the selection in the same file, or to 
another wave window.

RESULT 

The selection is removed from its original position and inserted where you drop it.

NOTE

To undo a move between two files you must first undo the paste in the destination 
window and then undo the cut operation in the source window.
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Moving Audio Using Cut and Paste

PREREQUISITE 

Decide whether you want to use Snap Selection to Zero-Crossing.

PROCEDURE

1. In the wave window, make a selection.

2. Use one of the following copy methods:
• In the Audio Editor, select the Edit tab, and click Cut.

• Press [Ctrl]/[Command]-[X].

3. Select how you want to insert the selection:
• If you want to insert the audio, click once at the position in the same file or in 

another file.

• If you want to replace a section of audio, select it.

4. To paste the selection, do one of the following:
• In the Audio Editor, select the Edit tab, and click Paste.

• Press [Ctrl]/[Command]-[V].

RESULT 

The selection is removed from its original position and inserted where you drop it.

NOTE

To undo a move between two files you must first undo the paste in the destination 
window and then undo the cut operation in the source window.

Moving Audio by Nudging

The nudge left/right tools can be used to move the audio in small steps within a file.

PROCEDURE

1. In the wave window, make a selection.

2. In the Audio Editor, select the Edit tab.

3. In the Nudge section, click Nudge Left or Nudge Right.

RESULT 

The audio is moved one pixel. Exactly how much this is depends on how far you are 
zoomed in. For example, if the status bar displays x1:256, the selection is moved 
256 samples. The moved section overwrites the audio at that position.
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Copying Audio

You can copy sections of audio within the same file or between audio files.

Stereo/Mono Handling

When you drag or copy stereo or mono files to other locations, the target location 
determines how the files are inserted.

Stereo/Mono is handled as follows when you drag between files:

Stereo/Mono is handled as follows when you copy and paste files:

Sample Rate Conflicts

If you copy or move audio from one window to another, and the sample rates of the 
two files are not the same, the copied/moved sound plays back at the wrong pitch 
(speed). The program warns you if this is about to happen.

While mixing sample rates can be used as an effect, it is most often not intended. 
There are two ways to get around this:

• Convert the sample rate of the source file to the same rate as the destination 
file before editing.

Dragged section Drop wave Action

Stereo Stereo The dragged audio is always inserted into both 
channels.

Stereo Mono Only the left channel is inserted.

Mono Stereo What happens depends on the vertical drop position. 
This is indicated by the cursor shape. The selection 
can be inserted into only one of the channels, or the 
same material can be inserted into both channels.

Copied section Paste wave Action

Stereo Stereo If the wave cursor extends across both channels of the 
destination file, the material is inserted into both 
channels.

Stereo Stereo If the wave cursor is only in one channel, the audio is 
only pasted in that channel. Material from the left 
channel is pasted in the left channel and material from 
the right channel is pasted in the right channel.

Stereo Mono Only the left channel is pasted.

Mono Stereo What happens depends on whether the wave cursor 
is in one channel or both. The audio is either pasted in 
one of the channels, or the same material is inserted 
into both channels.
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• Convert the sample rate of the destination file to the same rate as the source 
file before adding the audio.

Copying Audio Using Copy and Paste

PREREQUISITE 

Decide whether you want to use Snap Selection to Zero-Crossing.

PROCEDURE

1. In the wave window, make a selection.

2. Use one of the following copy methods:
• In the Audio Editor, select the Edit tab, and click Copy.

• Press [Ctrl]/[Command]-[C].

3. Select how you want to insert the selection:
• If you want to insert the audio, click once at the position in the same file or in 

another file.

• If you want to replace a section of audio, select it.

4. To paste the selection, do one of the following:
• In the Audio Editor, select the Edit tab, and click Paste.

• Press [Ctrl]/[Command]-[V].

Copying Audio by Dragging

PREREQUISITE 

Decide whether you want to use Snap Selection to Zero-Crossing.

PROCEDURE

1. In the wave window, make a selection.

2. Click the middle of the selection, and drag it to a position outside the selection 
in the same file, or to another wave window.

RESULT 

The selection is inserted at the indicated point. The audio that previously began at 
that point is moved to the right.

Mid and Side Editing

You can edit, process, and monitor audio material in the left/right and in the mid/side 
domain. Mid/Side editing can be applied on the waveform view and in spectrum 
editing mode. This allows you to do surgical spectrum editing only on the mid or on 
the side channel, for example.
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You can switch between left/right and mid/side mode with the LR/MS button at the 
bottom left of the overview and the main view. The upper track displays the mid 
signal and the lower track displays the side signal. The overview and main view have 
independent LR/MS controls. This allows you to display the left/right channels in the 
overview and the mid/side channels in the main view, for example.

When you render the audio, the channels are automatically encoded back to 
left/right mode.

The waveform display and the cursor shape indicate whether L/R or M/S mode is 
activated.

You can apply offline processes like Gain and Level independently on the mid and 
on the side channel. With the playback tool, you can play back the mid or side 
channel independently.

Changing the Audio Properties

You can change the sample rate and bit resolution of audio files.

Changing these values does not process the audio file in any way (in contrast to 
using Save As). However, the following rules apply:

• If you change the sample rate, the file plays back at a new pitch.

• If you change the bit resolution, the file is converted to the new resolution the 
next time you save it.

NOTE

There is no undo for this. If you save a file with a lower bit resolution, the file is 
converted permanently.

PROCEDURE

1. In the Audio Editor, open an audio file.

2. Select the File tab.

3. Click Info.

4. In the Audio Properties section, specify a new Sample Rate and/or Bit 
Resolution.

5. Click Apply Changes.

RELATED LINKS

Info Tab on page 53
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Meta-Data

Meta-data consists of attributes that describe the audio contents, for example, the 
title of the track, the author, or the date the track was recorded. Depending on the 
file format of the selected audio file, this data varies.

When opening an audio file, audio montage, or batch process, the meta-data found 
in the file is loaded. You can create different meta-data presets for audio files, audio 
montages, and batch processes. When creating a new file from a template, this file 
can inherit the meta-data of the preset, if available.

A preview of the meta-data is displayed in the Meta-Data window. To view the 
complete meta-data of a file and to be able to edit the meta-data, select Tool 
Windows > Meta-Data and click the Edit button.

Not all file formats can save meta-data. Depending on the output file format, all 
meta-data or only part of the meta-data is saved in an audio file. The following file 
formats can contain meta-data:

• .wav

• .mp3

• .ogg

• .wma

• .flac

• .aac

For MP3, the following meta-data types are available:

• ID3 v1 and ID3 v2, including picture support, and ReplayGain standard

AAC is used for MPEG4 (iTunes compatible) and 3GPP containers.

NOTE

• AAC is not ID3v2 compatible. However, in WaveLab Pro it uses the same 
editor.

• The meta-data codes that are followed by an “(i)” indicate the iTunes 
compatible fields. Lyrics and pictures are also iTunes compatible.

For WAV, the following meta-data types are available:

• RIFF

• BWF markers

• BWF version 2 (EBU R-128 loudness support)
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• BWF support for USID and UMID standards (Unique Source Identifier and 
Unique Material Identifier)

• iXML (with EBU R-128 loudness support)

• aXML (BWF standard to attach XML data)

• CART (AES standard, dedicated to broadcast needs)

• MD5 (Extra tab)

• ID3, including picture support

When saving or recording an audio file in the Audio File Format dialog, you can 
specify whether not to use any meta-data, inherit the meta-data from the source file, 
or edit the meta-data of the file.

Meta-data can be entered manually or generated automatically.

The following options can be generated automatically:

• Unique Source Identifier (BWF, Basics tab)

• UMID (BWF, Unique Material Identifier (UMID) tab)

• Loudness and true peak values* (BWF, Loudness tab)

• Insert BWF data (iXML tab)

• Time markers (CART tab)

• MD5 checksum* (Extra tab)

• ReplayGain information* (ID3, ID3 v2 tab)

• USID (BWF, Basics tab)

(*) These options cause a file analysis while the file is written, which means that the 
file writing process can take longer.

WaveLab Pro includes several meta-data presets. They are used as examples and 
can be customized to your needs. You can load meta-data presets from the 
Meta-Data Presets pop-up menu in the Audio File Format dialog, or from the 
Meta-Data dialog.

RELATED LINKS

Audio File Format Dialog on page 155

Meta-Data Dialog

This dialog allows you to define the meta-data to be embedded in your audio file.

• To open the Meta-Data dialog, open the Meta-Data window and click Edit.
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Depending on the file type, the meta-data is handled differently.

Meta-Data dialog for WAV files

When opening the Meta-Data dialog for files in the Audio Editor, you can edit the 
meta-data that is saved in the audio file. This meta-data is saved to disk later.

When opening the Meta-Data dialog for files in the Audio Montage window or the 
Batch Processor window, you can edit the meta-data for the WAV, MP3, and AAC 
audio files that are created when rendering the audio montage or processing 
through the batch processor. If you render to WAV, MP3, or AAC formats, the 
meta-data will be associated to these files.

NOTE

The meta-data codes that are followed by an “(i)” indicate the iTunes compatible 
fields. Lyrics and pictures are also iTunes compatible.

Meta-Data Presets

In the Meta-Data dialog, you can save meta-data presets and apply these presets 
to other files. Meta-data presets can be applied to WAV, MP3, and AAC files.

The Use as Default for New .wav Files option allows you to define a set of 
meta-data as default.

When you create a new file, and do not add any meta-data, this default meta-data 
is applied to the file when saving it. For example, you can save or record WAV files 
with BWF meta-data and automatically add a Unique Material Identifier.

To edit the default meta-data preset, select Load Default, and edit the preset.
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CART and Markers

WaveLab Pro reads the CART markers, if any, and merges them with the existing 
markers of the file.

The CART standard can contain up to 8 markers. WaveLab Pro saves them if their 
names conform to the CART standard.

If Generate Time Markers is activated in the CART tab of the Meta-Data dialog, 
the markers are generated if at least one CART text field has content. Otherwise, 
the CART data is meant to be unused.

To be able to merge the CART markers with the markers of a file when rendering a 
file, the option Copy Markers must be activated in the Render dialog.

Meta-Data and Variables

Variables make handling meta-data more efficient. You can use the available 
variable options to quickly add meta-data to a file, without having to type the same 
information multiple times.

You can also quickly add available information such as dates or file names.

The idea behind this is to set up the meta-data and variables once, and then be able 
to output various file versions from the project.

Example of Using Meta-Data and Variables

Let’s say you have an audio montage that contains CD tracks and want to render all 
CD tracks to individual audio files, including meta-data information. You have 
already added some CD-Text to each track.

The CD-Text of each CD track is automatically available in the CD Meta-Data 
dialog and can be used as variables.

Now you want to add information that is not available as CD-Text, for example, the 
year of the CD track and a comment, to have these information available in the 
rendered audio files.

1) In the CD window, select Functions > Edit CD Meta-Data, and fill out the 
@CdTrackYear@ and @CdTrackInfo1@ fields. Use the scroll-bar on the 
right of the dialog to select the other tracks, and add the information for all 
tracks. Close the dialog.

2) Edit the meta-data in the Meta-Data dialog. Set up the ID3 v2 fields using the 
variables. Click the arrow icon to open the variables and text snippets pop-up 
menu for a field. You can also fill out other meta-data chunks, such as BWF, 
RIFF, or CART, or add an album picture. Or you could apply a previously set 
up meta-data preset to add meta-data.

3) Once the information is complete, open the Render tab in the Audio 
Montage window. In the Source section, open the pop-up menu and select 
All Regions. Open the Marker pop-up menu and select CD Tracks.
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4) Click in the Format field, and click Single File Format. In the Audio File 
Format dialog, open the Meta-Data pop-up menu, and select Inherit from 
Source File. Click OK to close the dialog.

5) In the Render tab, in the Render section, click Start to render the files.

Result: When you now open the rendered audio files and look at the meta-data, you 
can see that the variables were replaced with the meta-data that has been set up 
for each track.

RELATED LINKS

Variables and Text Snippets on page 676
CD Window on page 358

Meta-Data in the Batch Processor Window

You can batch process meta-data. For this, you must set up the Meta-Data dialog 
for batch processes, and apply the meta-data to the files of the batch process.

In the Batch Processor window, on the Format tab, the following options are 
available in the Batch Meta-Data pop-up menu:

• If you do not want the batch meta-data to change the meta-data of the files in 
the batch, select Ignore.

• If you want to merge the meta-data of the batch with the meta-data of the 
source files (WAV files only), select Merge.

• If you want to replace the meta-data of the source files with the meta-data of 
the batch, select Replace.

Examples for Merging Meta-Data

A simple example would be if you have 1000 files with a mistake in a copyright field 
of their meta-data. With this batch option, you can preserve the meta-data of the 
files, and edit only the copyright field.

However, the merge option can also be used for complex batch meta-data. You can 
process an audio file and specify which meta-data to use from the source audio file 
and which from the batch meta-data. For this, use the Merge Codes options in the 
Meta-Data dialog for batch processes.
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If you enter #Source# in a value field, the value of the source audio file’s meta-data 
is used when batch processing. If you enter #Remove# in a value field, the 
corresponding value of the source audio file’s meta-data is removed when batch 
processing. In order to set up the merging process, you must set up these codes in 
the value field that you want to merge.

An example on how to merge meta-data while using the #Source# and #Remove# 
options:

• The batch process contains an audio file that already has meta-data.

• The batch meta-data is set up.

When starting the batch process, the meta-data are merged in the following way:

• If value field “A” in the audio file meta-data contains the text “Jazz”, while value 
field “A” is empty in the batch meta-data, the resulting output file has the text 
“Jazz” in value field “A”.

• If value field “B” in the batch meta-data contains the text “Modern”, while value 
field “B” in the audio file meta-data is empty, the resulting output file has the 
text “Modern” in value field “B”.

• If value field “C” contains text both in the source audio file and in the batch 
meta-data, some more editing in the Meta-Data dialog for batch processes is 
necessary to specify which meta-data should be used.

Examples on how to use the #Source# and #Remove# codes:

• No code is used, the source audio file has the text “Piano”, and the batch 
meta-data has the text “Trumpet”. Result: “Piano” is retained, because the 
source audio file meta-data has precedence over the batch meta-data.

• The source audio file has the text “Piano”, and the batch meta-data has the 
text “Electric #Source#”. Result: The resulting output file has the text “Electric 
Piano”.

• The source audio file has the text “Piano”, and the batch meta-data has the 
text “#Remove#”. Result: “Piano” is removed from the value field.

• The source audio file has the text “Piano”, and the batch meta-data has the 
text “#Remove#Trumpet”. Result: “Piano” is removed, and “Trumpet” is 
added.
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Snapshots

You can save a number of snapshots of your audio file, to capture the current scroll 
position, zoom factor, cursor position, and audio selection.

You can recall a snapshot at any time and update snapshots.

Selecting a saved snapshot restores all of its view settings. You can also choose to 
recall only specific view properties by activating the corresponding options for a 
snapshot.

RELATED LINKS

Snapshots on page 140

Capturing the Current View

Capturing the current view saves the current zoom factor, cursor position, scroll 
position, and time range.

PROCEDURE

1. Set up the view of the wave window.

2. Select the View tab.

3. In the Snapshots section, click Take Snapshot.

4. Click one of the preset buttons to save the snapshot.

RESULT 

The snapshot is saved and can be recalled by clicking the corresponding preset 
button.

Recalling a Snapshot

PROCEDURE

1. In the Audio Editor, select the View tab.

2. In the Snapshots section, open the Options pop-up menu.

3. Activate the view settings that you want to recall.

4. Click a Preset button.
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Updating Snapshots

You can update a previously captured snapshot with the current view.

PROCEDURE

1. Set up the view of the wave window.

2. Select the View tab.

3. In the Snapshots section, click Take Snapshot.

4. Click the preset button that you want to update.

RESULT 

The new snapshot replaces the selected snapshot.

Silence Generator Dialog

This dialog allows you to insert silence or background noise in an audio file.

• To open the Silence Generator dialog, select the Edit tab in the Audio 
Editor, and click Silence Generator.

Type of Silence

To insert digital silence, activate True Silence.

• Background Noise (File Will Be Looped If Needed) allows you to 
select an audio file containing ambient noise.

• Gain to Apply to This File lowers or raises the gain of the background 
noise.
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Silence Duration

As Selection uses the duration of the active audio selection as the duration 
of the silent section. Specify the duration of the silent section in the value field 
below.

Edges

Fade In/Fade Out performs a crossfade at the start and end of the silent 
section for smoother transitions. Specify the fade time in the value field below.

Destination

• Replace Selection replaces the current audio selection with the silent 
section.

• Insert at Cursor inserts the silent section at the cursor position.

• From End of File Until Cursor extends the audio file with silence up to 
the cursor position. Activating this option also defines the silence 
duration and ignores the Silence Duration setting.

True Silence vs. Background Noise

Recordings can sound unnatural when you insert true silence. This is particularly 
true for voice recordings and field recordings, where a natural background noise is 
often present. To produce more natural results, you can insert a file with background 
noise.

The file that you specify must have the same properties (stereo/mono, sample rate, 
etc.) as the file in which you want to insert the silence. The file can be any length – 
if the silence region is longer than the file, the file is looped.

Replacing a Selection with Silence

You can replace a section of an audio file with true silence or background noise.

PROCEDURE

1. In the Audio Editor, make a selection.

2. Select the Edit tab.

3. In the Cutting section, click Silence Generator.

4. In the Silence Generator dialog, select the type of silence:
• True Silence

• Background Noise. For this option you must select a file containing the 
background noise.

5. Set the silence duration to As Selection, and the destination to Replace 
Selection.

6. Click Apply.
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Inserting Silence

You can insert a specified length of true silence or a background noise at any 
position of the audio file.

PROCEDURE

1. In the Audio Editor, set the cursor where you want the inserted silence to 
begin.

2. Select the Edit tab.

3. In the Cutting section, click Silence Generator.

4. In the Silence Generator, select the type of silence:
• True Silence

• Background Noise
For this option you need to select a file containing the background noise.

5. Deactivate As Selection, and specify the length.

6. Set the destination to Insert at Cursor.

7. Click Apply.

Muting a Selection

The Mute Selection function replaces the selection with true silence.

PROCEDURE

1. In the wave window of the Audio Editor, make a selection.

2. Select the Edit tab.

3. In the Cutting section, click Mute Selection.

Waveform Restoration with the Pen Tool

The Pen tool allows you to redraw the waveform in the wave window. This can be 
used to quickly repair waveform errors. The Pen tool can be used if the zoom 
resolution is set to 1:8 (one pixel on the screen equals 8 samples) or higher.

• To redraw the waveform, select the Pen tool on the Edit tab of the Audio 
Editor, click in the waveform, and draw the new waveform.
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• To redraw the waveform of both channels at once, press [Shift] during the 
drawing process.
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Audio Analysis

WaveLab Pro provides you with a comprehensive set of tools for analyzing your 
audio and for detecting any errors.

For example, you can use the suite of audio meters or the 3D Frequency Analysis. 
There are also several tools that help you examine any sample of your audio for 
errors or anomalies.

You can compare two audio files with the Audio File Comparator tool and view 
audio in a Spectrum or Loudness view.

Error Detection and Correction

You can search for unwanted clicks and digital artifacts in an audio file. You can use 
several detection and restoration methods to detect, mark and name, jump to, play 
back, and remove individual audio errors.

You can also restore damaged portions of an audio file by using waveform 
replacement. The Error Correction window gives you access to the error detection 
and correction tools.

NOTE

Because errors can have multiple origins and effects, various algorithms are needed 
to cover these cases. Experience with the settings to find the best parameters to 
detect the errors in your files.

Selecting an Error Detection and Correction Method

Before searching for errors in your audio file, set up the error detection and 
correction methods. Try out different settings.

PROCEDURE

1. In the Audio Editor, select Tool Windows > Error Correction.

2. In the Error Correction window, select the Detection tab.

3. Select an error detection method from the Error Detection Method menu, 
and set the parameters.
Depending on the method that you have selected, different detection parameters are 
available.
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4. Select the Correction tab.

5. Select an error correction method from the Default Error Correction Method 
menu.

AFTER COMPLETING THIS TASK 

When you have selected error detection and correction methods, you can continue 
to detect and correct errors in the active audio file.

Strategies to Detect and Correct Errors

There are several strategies for detecting and correcting errors. Depending on the 
error, some detection and correction methods are more successful than others.

Set up the error detection and correction methods before following these 
strategies.

• To correct an error, select a range in the audio part that contains the error, 
then in the Error Correction window, select Correct Error or Mark for 
Correction.

• To automatically locate the next error, in the Error Correction window, select 
Detect Next Error, then select Correct Error or Mark for Correction.

• To detect all errors in the selected range, select Detect All Errors. Then you 
can browse the detected errors and correct them individually. You can also 
select Correct All Marked Errors.

Correcting Individual Errors

You can detect and correct individual errors using different detection methods and 
parameter settings for each error. This is useful when errors are difficult to correct.

PROCEDURE

1. In the Audio Editor, open the audio file in which you want to correct errors.

2. Select Tool Windows > Error Correction.

3. In the Error Correction window, select the Detection tab.

4. Select an error detection method from the Error Correction Method menu, 
and set the parameters.
Depending on the method that you have selected, different detection parameters are 
available.
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5. Click Detect Next Error.
WaveLab Pro analyzes the audio file from the beginning and stops at the first 
detected error.

AFTER COMPLETING THIS TASK 

In the browse and correct section you now have several options for how to proceed. 
For example, you can correct the error, detect the next error, or mark the error for 
later restoration.

RELATED LINKS

Error Correction Window on page 190

Automatically Detecting and Correcting Errors

Use WaveLab Pro to automatically remove all detected click noise errors.

PROCEDURE

1. In the Audio Editor, open the audio file in which you want to correct errors.

2. Select Tool Windows > Error Correction.

3. In the Error Correction window, click Detect All Errors.
WaveLab Pro searches the complete file and inserts a pair of markers for each 
detected error.

4. In the Correction tab, select a correction method from the Default Error 
Correction Method menu.
A description of what the selected method does is displayed below the Default Error 
Correction Method menu.

5. Click Correct All Marked Errors.

RESULT 

WaveLab Pro automatically corrects all detected errors.

Error Correction Window

This window provides access to the error detection and correction tools.

• To open the Error Correction window, open the Audio Editor, and select 
Tool Windows > Error Correction.
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Detection Tab

On this tab, you can specify how to detect errors.

Error Detection Method

Lets you select the error detection method. Depending on which method you 
have selected, different detection parameters are available.

Threshold

Specifies the threshold value for the error detection. Lower values detect 
softer clicks.

Detection

Specifies the lower limit of the analyzed frequency range.

Detection Width

Specifies whether to detect short or long error lengths. This option is only 
available if the error click detection method Click Detection 2 is selected.

Correction Tab

On this tab, you can specify the method that is used to correct errors.

Default Error Correction Method

Lets you select the default error correction method.
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• Linear Interpolation draws a straight line between the first and the last 
selected samples.

• Optimal for Small Clicks – 1 ms is optimal to remove clicks smaller 
than 1 ms.

• Optimal for Common Clicks – 3 ms is optimal to remove clicks smaller 
than 3 ms.

• Waveform Replacement – 500 ms replaces the corrupt samples with 
the best match detected in the material up to 500 milliseconds to the 
left/right.

• Waveform Replacement – 4 s replaces the corrupt samples with the 
best match detected in the material up to 4 seconds to the left/right.

• Waveform Replacement – Left 6 s replaces the corrupt samples with 
the best match detected in the material up to 6 seconds to the left.

• Waveform Replacement – Right 6 s replaces the corrupt samples with 
the best match detected in the material up to 6 seconds to the right.

Search Area Tab

On this tab, you can specify the range of audio that you want to search for errors.

Scan Range

• Entire File searches the whole audio file for errors.

• Specific Audio Range searches the selected audio range for errors. 
Once defined, you can change the audio selection without altering this 
search area.
The text field displays the active scan area.

Scan Start Position

• Start at Cursor starts the search at the edit cursor position.

• Start at Beginning of Scan Range starts the search at the beginning 
of the defined search area.
The text field displays the scan start position.
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Options Tab

This tab provides a range of preferences for playing back, viewing, and marking any 
detected errors.

Set Markers around Corrected Errors

Creates correction markers around the audio section each time an error is 
corrected. This area can be larger than the marked error area when 
crossfades are performed by the corrector.

Remove Markers after Correction

Removes the error marker each time an error is corrected.

Zoom Level

Specifies the zoom level when displaying an error.

Adjust Selection by This Number of Samples

Defines by how many samples the selection edges are moved, when you use 
the Adjust Selection buttons to adjust the error area.

Auto-Play

Automatically plays back the error area after it has been detected or 
corrected.

Pre-Roll Time

Specifies a pre-roll time to play some audio before the start of the error 
section.

Post-Roll Time

Specifies a post-roll time to play some audio after the end of the error section.

Override Global Shortcuts

Gives priority to the error correction shortcuts if these shortcuts are also used 
elsewhere in WaveLab Pro. Use this when you are working mainly with this 
tool. However, this option should be deactivated when you are done with the 
error correction.
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Browse and Correct Section

In this section, you can step through your defined search region detecting each 
error in turn. You can choose to correct errors or mark them for later correction. 
There are controls to jump between error markers and to make fine adjustments to 
the selection. You can also automatically detect and correct all marked errors in the 
search region.

Detect Next Error

Searches for the next error, starting at a specified position or at the end of the 
last detected error.

Back to Previous Error

Returns to the last detected error.

Correct Error

Restores the audio selection with the default correction method. You can 
select another correction method from the pop-up menu.

Mark for Correction

Sets a pair of error markers to the audio selection without performing any 
correction.

Unmark

Deletes the error markers surrounding the audio selection.

Play

Starts playback of the current audio selection while taking into account the 
pre-roll and post-roll settings.

Adjust Selection

The green arrows move the left edge of the selection to the left/right. The 
orange arrows move the right edge of the selection to the left/right. This lets 
you finely adjust an audio selection that was suggested by the detection 
function.

Macro

• Detect All Errors searches the specified range from the beginning to 
the end and creates pairs of error markers for each detected error 
without performing any correction.

• Correct All Marked Errors restores the audio located within each pair 
of error markers in the specified range.
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Previous/Next Correction Mark

Jumps to the previous/next correction marker pair.

Previous/Next Error Mark

Jumps to the previous/next error marker pair.

Jump to Previous Error After Correction/Jump to Next Error After Correction

Automatically jumps to the previous/next marked error when you click Correct 
Error.

Global Analysis

In WaveLab Pro you can perform advanced analysis on your audio to identify areas 
with specific properties. This helps you find problem areas such as glitches or 
clipped samples. You can also check general information, such as the pitch of a 
sound.

If you analyze a section of an audio file, WaveLab Pro scans the section or the audio 
file and extracts information which is displayed in the dialog. WaveLab Pro also 
marks sections of the file that meet specific characteristics, for example, sections 
that are very loud or almost silent. You can then browse between these points, set 
markers, or zoom in on markers. On most of the tabs, you find settings that 
determine exactly how the analysis is performed. Each tab focuses on a particular 
analysis area.

You perform the global analysis in the Global Analysis dialog. This dialog consists 
of the following tabs that provide different analysis types:

• The Peaks tab lets you find individual samples with very high values.

• The Loudness tab lets you find sections with high intensity.

• The Pitch tab lets you find the exact pitch of a sound or section.

• The Extra tab provides information about DC offsets and the significant bit 
resolution.

• The Errors tab lets you find glitches and sections where the audio has been 
clipped.

Most of the analysis types provide a number of positions in the file that indicate 
peaks, glitches, etc. These points are called “hot points”.
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Opening the Global Analysis Dialog

The Global Analysis dialog provides various analysis options.

PROCEDURE

1. In the wave window, select a range in the audio file that you want to analyze.
If you want to analyze the entire file, press [Ctrl]/[Command]-[A]. If Process Whole 
File If There Is No Selection is activated in the Audio Files Preferences, the whole 
file is analyzed automatically provided that no selection has been made.

2. In the Audio Editor, select the Analyze tab.

3. In the Tools section, click Global Analysis.

4. Optional: Click Open New Global Analysis Dialog  at the top of the 
Global Analysis dialog to open another Global Analysis dialog.

Choosing the Analysis Type

Several types of analysis can be performed. Each of them takes some time, so make 
sure that only the types that you need are included in the analysis.

Select the analysis types in the Global Analysis dialog by activating them in the 
corresponding tabs.

• To include the peaks analysis, select the Peaks tab and activate Find Peaks.

• To include the loudness analysis, select the Loudness tab and activate 
Analyze Loudness.

• To include the pitch analysis, select the Pitch tab and activate Find Average 
Pitch.

• To include the extra analysis, select the Extra tab and activate Find DC 
Offset.

• To include the errors analysis, select the Errors tab and activate Find 
Possible Glitches and Find Clipped Samples.

Global Analysis – Peaks Tab

On this tab, you can make settings that help you find digital peak and true peak 
values in the audio, that is, single samples with very high values.

• In the Global Analysis dialog, select the Peaks tab.
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Find Peaks

Enables peak analysis.

Digital/True

Displays the highest peak in the analyzed section. When you click this value, 
the number of peaks that are detected in the selection is shown in the 
Number of Hot Points section in the lower left corner of the dialog. You can 
use the hot points to move the cursor between the peaks.

At Cursor

Displays the level at the current audio file cursor position at the time of the 
analysis.

Maximum Number of Peaks to Report

Restricts the number of reported peaks. For example, setting this to 1 reports 
only the highest peak.

Minimum Time Between 2 Peaks

Controls the distance between peaks, so they do not appear too close to 
each other. For example, setting this to 1 s ensures that there is always at 
least one second between reported peaks.

Results of the Analysis

The Find Peaks fields show the highest peak in the analyzed section and the level 
of the sample at the wave cursor position at the time of the analysis.

Global Analysis – Loudness Tab

On this tab, you can make settings that help you find sections that are perceived by 
the human ear as louder or weaker in volume. To find sections that the ear perceives 
as significant in volume, you must look at a longer section of audio.

• In the Global Analysis dialog, select the Loudness tab.

The following options are available for the Raw Loudness tab and the EBU R-128 
tab:
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Maximum Number of Loudness Points to Report

Restricts the number of reported hot points. The highest points are reported. 
For example, setting this to 1 reports only the loudest section or one of the 
sections that have the same highest value.

Minimum Time between 2 Points

Controls the distance between points, so they do not appear too close to 
each other. For example, setting this to 1 s ensures that there is always at 
least one second between reported points.

Raw Loudness

Analyze Loudness

Enables RMS loudness analysis.

Average

Displays the overall loudness of the analyzed selection.

Maximum

Displays the level of the loudest section in the analyzed selection. Clicking this 
value displays the number of loud sections detected within the selection in the 
Number of Hot Points section in the lower left corner of the dialog.

Minimum

Displays the level of the quietest section in the analyzed selection. Clicking 
this value displays the number of weak sections that are detected within the 
selection in the Number of Hot Points section in the lower left corner of the 
dialog. This provides adequate information about the signal-to-noise ratio 
(SNR) of the audio material.

Around Cursor

Displays the loudness at the audio file cursor position at the time of the 
analysis.



Audio Analysis
Global Analysis

199

Resolution

The length of audio to be measured and averaged. If this value is lowered, 
short passages of loud/weak audio are detected. If the value is raised, the 
sound must be loud/weak for a longer period to result in a hot point.

Threshold (for the Average)

Ensures that the average value is calculated correctly for recordings with 
pauses. The value that you set here determines a threshold below which any 
detected audio is considered to be silence, and is therefore excluded from 
average value calculations.

EBU R-128

Integrated Loudness

Displays the integrated loudness of the analyzed selection, also known as 
programme loudness, according to the EBU R-128 specification. This 
indicates how loud the audio is on average.

Loudness Range

Displays the loudness range according to the EBU R-128 specification. It is 
based on a statistical distribution of loudness within a programme, thereby 
excluding the extremes.

Short-Term Loudness: Maximum

Displays the level of the loudest 3 seconds section in the analyzed selection. 
When you click this value, the number of loud sections that are detected 
within the selection is shown in the Number of Hot Points section in the 
lower left corner of the dialog.

Short-Term Loudness: Minimum

Displays the level of the quietest 3 seconds section in the analyzed selection. 
When you click this value, the number of quiet sections that are detected 
within the selection is shown in the Number of Hot Points section in the 
lower left corner of the dialog. This provides adequate information about the 
signal-to-noise ratio (SNR) of the audio material.
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Momentary Loudness: Maximum

Displays the level of the loudest very short section (400 milliseconds) in the 
analyzed selection. When you click this value, the number of loud sections 
that are detected within the selection is shown in the Number of Hot Points 
section in the lower left corner of the dialog.

Momentary Loudness: Minimum

Displays the level of the quietest very short section (400 milliseconds) in the 
analyzed selection. When you click this value, the number of quiet sections 
that are detected within the selection is shown in the Number of Hot Points 
section in the lower left corner of the dialog.

RELATED LINKS

EBU Loudness Standard R-128 on page 45

Global Analysis – Pitch Tab

On this tab, you can make settings that help you finding the average pitch of an 
audio section.

• In the Global Analysis dialog, select the Pitch tab.

Settings on this tab allow you to gather information for pitch shifting, for example, to 
get one sound in tune with another. The display shows the pitch for each channel, 
in Hertz (Hz) and as semitones and cents (hundredths of a semitone). Because the 
display shows an overall value for the entire analyzed section, the hot point controls 
in the lower section of the dialog are not used on this tab.

Usage guidelines for the Pitch tab:

• The result is an average value for the whole selection.

• The method only works on monophonic material, not on chords or harmonies.

• The algorithm assumes that the analyzed section has a reasonably stable 
pitch.

• The material must be relatively well isolated from other sounds.

• It is preferable to analyze the sustain portion of a sound rather than the attack. 
The pitch is usually not stable during the attack.

• Some synthetic sounds may have a weak fundamental (first harmonic) which 
can irritate the algorithm.
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Global Analysis – Extra Tab

This tab shows the average DC Offset of the analyzed section and the Apparent 
Bit Resolution.

• In the Global Analysis dialog, select the Extra tab.

The Apparent Bit Resolution attempts to detect the actual resolution in the audio. 
This is useful, for example, if you want to check, whether a 24-bit file really uses 24 
bits or if it was actually recorded with 16-bit resolution and then expanded to 24 
bits.

NOTE

For more accurate results on the bit resolution, use the Bit Meter.

RELATED LINKS

Bit Meter on page 479

Errors Detection

You can detect errors, such as glitches and sections where the audio has clipped. 
For a more advanced error detection, use the Error Correction window.

Glitches

• These are disruptions in the audio. Glitches may occur after problematic 
digital transfers, after careless editing, etc. They manifest themselves as 
“clicks” or “pops” in the audio.

Clipping

• A digital system has a finite number of levels that it can represent properly. 
When recorded sound levels are too high or when the system cannot handle 
levels that have been raised by digital processing, hard clipping occurs that 
you can hear as strong distortion.

A sine waveform before clipping and after.
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Result of the Analysis

This reports the number of glitches and clipping instances that have been detected.

Global Analysis – Errors Tab

This tab helps you find glitches and sections where the audio has clipped.

• In the Global Analysis dialog, select the Errors tab.

Maximum Number of Error Points to Report

Allows you to restrict the reported numbers of hot points.

Minimum Time between 2 Points to Report

Controls the distance between points, so they do not appear too close to 
each other. For example, setting this to 1 s ensures that there is always at 
least one second between reported points.

Find Possible Glitches

Enables glitch analysis.

• Threshold sets the value at which a change in level is considered to be 
a glitch. The higher the value, the less sensitive the detection.

• Sensitivity is a length value that represents the length of time in which 
the waveform must exceed the threshold to be reported as a glitch. The 
higher the value, the less sensitive the detection.

• Output Format displays the number of clipping occurrences that are 
detected by the analysis. Clicking this value displays the number of clips 
in the Number of Hot Points section in the lower left corner of the 
dialog.

NOTE

Make sure that the points that are detected by the algorithm are real glitches. 
Zoom in and play back to check whether the detected points really indicate a 
problem.

Find Clipped Samples

Enables clipping analysis.
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• Threshold checks for a number of consecutive samples at full value, to 
determine whether clipping has occurred. The Threshold setting 
determines the exact number of these consecutive samples that must 
occur for the program to report clipping.

• Output Format displays the number of clipping occurrences that are 
detected by the analysis. Clicking this value displays the number of clips 
in the Number of Hot Points section in the lower left corner of the 
dialog.

Performing a Global Analysis

PREREQUISITE 

In the Audio Editor, select the Analyze tab, click Global Analysis, and select the 
tab that you want to include in the analysis.

PROCEDURE

1. In the Global Analysis dialog, set up the parameters.
Most of the tabs have settings that determine how the analysis should be performed.

2. If the Peak or Loudness tab is selected, move the cursor to the position that 
you want to analyze.
The Peak and Loudness tabs report values for the position of the cursor.

3. Click Analyze.

Results of the Global Analysis

Depending on the analysis type, one or several values are returned for the analyzed 
audio.

For the Pitch and Extra analyses, only one value is returned. The other analysis 
types provide a number of positions in the file that indicate peaks, glitches, etc. 
These points are called hot points.
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Checking the Results of the Global Analysis

The results of the global analysis are marked with hot points. You can browse 
through these points to see the results of the analysis.

PREREQUISITE 

In the Audio Editor, select the Analyze tab, click Global Analysis, and perform the 
analysis.

PROCEDURE

1. In the Global Analysis dialog, click the tab that represents the values that you 
want to check.

2. Check the display for maximum/minimum values in the entire analyzed section.

3. Decide which of these values you want to browse.

4. Click the value.

5. Check the Number of Hot Points value at the bottom of the dialog.
The value shows the number of positions that were detected by the analysis.

6. Use the scrollbar below the Number of Hot Points value to browse between 
the detected positions.
The edit cursor shows the position in the wave window.

7. To browse another property, click the corresponding tab, and then the value 
button.

NOTE

The result of the analysis is saved until you close the dialog or click Analyze again.

RELATED LINKS

Performing a Global Analysis on page 203

Creating Markers at Hot Points

Creating markers at hot points simplifies browsing the results of the global analysis.

PREREQUISITE 

In the Audio Editor, select the Analyze tab, click Global Analysis, and perform the 
analysis.

PROCEDURE

1. In the Global Analysis dialog, select the analysis type for which you want to 
create markers at hot points.
You can add markers for only one channel at a time.

2. Click the Create Markers at Hot Points button.
Temporary markers are added at all hot points.
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RESULT 

The markers are named using the following principle: “Hot point number (Channel)”. 
For example, a marker at the third hot point in the left channel would be labeled “3 
(L)”.

RELATED LINKS

Performing a Global Analysis on page 203

Focusing Hot Points

After a global analysis, you can focus the display on a specific hot point.

PREREQUISITE 

In the Audio Editor, select the Analyze tab, click Global Analysis, and perform the 
analysis.

PROCEDURE

1. Use the Number of Hot Points scroll bar to move the position indicator to 
the position in which you are.

2. Click Focus.
The wave window zooms in on the selected point. The Global Analysis dialog is 
reduced to the bottom part.

3. To return to the full view of the Global Analysis dialog, click Focus again.

Audio File Comparator

You can compare audio files to find differences.

Use the Audio File Comparator for the following:

• Seeing and hearing the effect of using an equalizer

• Checking the noise added by a processor

• Checking the effects of data compression

• Comparing two versions of an apparent similar recording to see if they are 
really the same

You can create a delta audio file that contains only the differences between the two 
compared audio files. To see and hear small differences easily, you can amplify 
them.

Markers can be automatically added at positions in the audio file where differences 
are detected.
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Audio File Comparator Dialog

In this dialog, you can compare two audio files.

• To open the Audio File Comparator dialog, select the Analyze tab in the 
Audio Editor and click Audio File Comparator.

Files to Compare

Allows you to select the two audio files that you want to compare.

Generate Delta File

If this option is activated, a delta file is created that contains only the 
differences between the two compared files.

Difference Amplification

Amplifies the differences in the delta file to facilitate seeing and hearing them.

Create Markers at Points of Difference

Creates markers at points where differences are detected. You can create 
differences in the first, the second, or the delta file.

Maximum Number of Markers

Sets the maximum number of markers to be inserted.

Minimum Time Between Two Markers

Determines the density of the generated difference markers.

Comparing Audio Files

The file comparator lets you see the differences between two files.

PROCEDURE

1. Open the audio files that you want to compare.

2. In the Audio Editor, select the Analyze tab.
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3. In the Tools section, click Audio File Comparator.

4. If more than two audio files are open, select the two files that you want to 
compare.

5. Optional: Activate Generate Delta File.
This creates a new audio file that contains only the differences between the compared 
audio files.

6. Optional: Make marker settings in the Create Markers at Points of 
Differences section.
This creates markers at differing points to facilitate finding the differences.

7. Click OK.

3D Frequency Analysis

Using the 3D Frequency Analysis, you can view an audio file in the frequency 
domain.

Use the 3D Frequency Analysis for the following:

• Viewing the frequency spectrum distribution in a mix

• Identifying which frequencies can be reduced or boosted as a basis for 
equalizing

• Viewing parts of the frequency spectrum that are occupied by a background 
noise that you want to filter out

A wave display (time domain) informs you about the start and end of a sound in a 
file, but lacks information about the timbral contents of the file that a frequency 
graph (frequency domain) provides. The graph that is used in WaveLab Pro is often 
referred to as an FFT (Fast Fourier Transform) plot. If you select a stereo recording, 
a mix of the two channels is analyzed.

The wheel control allows you to view the frequency spectrum from different angles. 
For example, you can open several 3D Frequency Analysis windows, each with a 
different perspective. This allows you to get a better view of an otherwise crowded 
graph.
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Creating a Graph for 3D Frequency Analysis

The length of the selected audio affects the accuracy of the analysis. For short 
selections, the result is more detailed. Consider making a separate analysis of the 
attack in which the most drastic variations occur.

PROCEDURE

1. In the wave window, select the section of the file that you want to analyze.
If you make no selection, the whole audio file is analyzed.

2. In the Audio Editor, select the Analysis tab.

3. In the Tools section, click 3D Frequency Analysis.
The audio is analyzed.

4. To edit the analysis parameters, click 3D Analysis Options.

5. Adjust the parameters and click OK.
The audio is re-analyzed.

3D Analysis Options

In the options dialog of the 3D Frequency Analysis dialog, you can define which 
frequency range is analyzed and modify the appearance of the graph for the 3D 
frequency analysis.

• In the 3D Frequency Analysis dialog, click the 3D Analysis Options button.
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Top/Bottom Frequency

Specifies the highest/lowest frequency of the range.

Logarithmic Ruler (Octaves)

Divides the frequency ruler in equally spaced octaves.

Amplitude

Select whether you want the peaks to be proportional to their amplitude 
(Linear) or to their power (Logarithmic with Decibel Scale).

Colors

Defines the color scheme of the graph.

Background

Defines the background color.
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Offline Processing

Offline processes are useful for a variety of editing purposes and creative effects, 
for example, if the computer is too slow for real-time processing or if the editing 
requires more than one pass.

After the processing the audio file is permanently altered.

Applying Processing

Processing can be applied to a selection or to a whole file. For some operations 
processing the entire file is necessary.

NOTE

If Process Whole File If There Is No Selection is activated in the Editing tab of 
the Audio Files Preferences, the whole file is automatically processed if no 
selection exists.

PROCEDURE

1. In the wave window, make a selection.

2. In the Audio Editor, select the Process tab.

3. Select the type of processing that you want to apply.

4. If a dialog opens, make the settings and click Apply to render the effect to file.

Gain Dialog

In this dialog, you can apply a gain to change the level of an audio file.

• To open the Gain dialog, select the Process tab in the Audio Editor, and 
click Gain in the Level section.
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Click Find Current Peak Level to obtain a report on the peak level of the audio 
selection, or the whole file if there is no selection. This is useful if you want to 
calculate how much you can increase the overall gain of a file without clipping 
(exceeding 0 dB), for example.

This processor also lets you add clipping. Clipping is when the gain is raised to a 
point where distortion is added. While this is normally not intended, mild clipping 
can add some punch, for example, to accentuate the attack of a drum sound.

Level Normalizer Dialog

In this dialog, you can change the peak level of an audio file.

• To open the Level Normalizer dialog, select the Process tab in the Audio 
Editor, and click Level in the Normalizing section.

This dialog is also available as a multipass plug-in in the Batch Processor window.

Peak Level

Enter the peak level (in dB) that you want the audio selection to have.

Stereo Link

Applies the gain to both channels.

Reference

In this pop-up menu, select whether WaveLab Pro uses sample values (digital 
peaks) or analog reconstructed values (true peaks).

Mix to Mono

Mixes the left and the right channel. The resulting mono file has the specified 
peak level. This ensures a mix without clipping.
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Find Current Peak Value

Creates a report on the peak level of the current audio selection or the whole 
audio file if there is no selection.

Loudness Normalizer

You can use the Loudness Normalizer to achieve a specific loudness.

Increasing the loudness to a specific value can provoke clipping. To remedy this, a 
peak limiter (Peak Master plug-in) can be part of the process. The Loudness 
Normalizer raises the loudness and limits peaks in the signal at the same time if 
needed, to achieve the wanted loudness.

This process happens in several stages, first an analysis and then the final 
rendering.

Loudness Normalizer Dialog

In this dialog, you can specify the loudness of a file.

• To open the Loudness Normalizer dialog, select the Process tab in the 
Audio Editor, and click Loudness in the Normalizing section.

This dialog is also available as a multipass plug-in in the Batch Processor window.

Loudness (EBU R-128)

Loudness to Achieve

If the loudness cannot be achieved with a simple positive gain change, a 
limiter must come into action to prevent clipping.
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Here, specify the loudness that you want to achieve. The EBU R-128 
recommendation for broadcast is -23 dB.

Specifying high values might require a gain outside the normal capabilities of 
the limiter, which can cause distortion.

It is recommended to use Statistics after specifying a loudness. This way you 
know how much the gain needs to be raised and if peak limiting needs to be 
applied. If heavy limiting is necessary this might degrade the audio quality. In 
such cases a warning is shown after applying the process, allowing you to 
undo it.

Catch Loudness from Audio Selection

Sets the Loudness to Achieve value to the average loudness found in the 
audio file.

Reference

This pop-up menu allows you to select a reference: the loudness of the entire 
file (EBU R-128 recommendation), the average loudest 3 second audio 
section (Top of Loudness Range), or the loudest 3 seconds audio section 
(Maximum Short-Term Loudness).

Peaks

In this pop-up menu, select whether WaveLab Pro should limit the sample 
values (Digital Peaks) or the analog reconstructed samples (True Peaks).

Peak Limiter

Max Peak Level

Here, specify the maximum peak level of the resulting audio. The lower this 
value, the lower the loudness.

Softness

Affects how the peak master operates. A high setting maximizes the perceived 
loudness effect, but can result in a slight harshness of the sound.

Adjust this parameter to optimize the balance between sound quality and the 
effect that you want to achieve.

Pre-Processing Options

Remove DC Offset

DC offset in the file affects the loudness computation. Therefore it is 
recommended that you keep this option activated.
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Attempts/Analysis

Tolerance (+/-)

If the Loudness to Achieve requires peak limiting, this also reduces the 
loudness to some degree. This cannot be computed in advance and cannot 
be automatically applied to the gain change. Instead, several simulation 
passes are performed to find the best possible gain. This option lets you 
define the precision of the result that you want to achieve.

Maximum Number of Passes

WaveLab Pro performs as many analysis passes as needed to match the 
precision that you want to achieve. Use this option to specify the maximum 
number of passes to be performed.

Authorized Peak Compression

As too much compression degrades the audio quality, you can specify a limit 
for the applied compression. The value can be set between -1 and -20 dB. 
Consider to lower the Loudness to Achieve, as this renders better results.

Warn If Unmatched

If this option is activated, you are warned if the normalizing process does not 
meet the specified loudness/precision. This option is not available during 
batch processing.

Statistics

Opens a window that shows you information about the file to be processed. 
It shows any DC offset, the current loudness, the current peak level, and the 
required gain to achieve the specified loudness. Furthermore, you are 
informed if limiting is required.

RELATED LINKS

EBU Loudness Standard R-128 on page 45

Pan Normalizer Dialog

This dialog allows you to ensure that both channels of a stereo file have the same 
level or loudness, and helps you to get the best possible stereo balance.

• To open the Pan Normalizer dialog, select the Process tab in the Audio 
Editor, and click Pan in the Normalizing section.

This dialog is also available as a multipass plug-in in the Batch Processor window.
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This process first analyzes the audio and then renders any required level changes. 
You must have a stereo selection in a stereo file to apply this process.

Peak Level

Raises the channel with the lowest peak level to match the peak level of the 
other channel.

Loudness (EBU R-128)

Analyzes the loudness of both channels and adjusts their gain so that both 
channels get the same loudness. No clipping can be introduced using the pan 
normalizer.

Remove DC Offset

Removes DC offsets which affect the loudness computation. We recommend 
to keep this option activated.

Analyze Channel Difference

Shows the current loudness ratio between the left and right channels. The 
result changes depending on the selected Peak/Loudness mode.

Envelope Dialog

In this dialog, you can create a level envelope which can be applied to a selected 
range or a whole audio file. This is useful if you want to even-out loud and quiet parts 
or create a sophisticated fade in or fade out, for example.

• To open the Envelope dialog, select the Process tab in the Audio Editor, 
and click Envelope in the Level section.
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The dialog shows a waveform with an envelope curve (initially a straight line). A 
vertical ruler displays the level in dB, and the horizontal ruler displays the timeline.

The following options are available:

• Undo/Redo the Last Operation

• Deselect the Envelope Points

• Delete the Selected Envelope Points

• Reset the Selected Envelope Points

• Reset the Whole Envelope

• Flip the Envelope Around the Horizontal Axis

• Reverse the Envelope Time Sequence

• Toggle the Envelope Smoothing

Basic Envelope Operations

By adding points to the envelope curve you can create an envelope curve that 
changes the volume of the material over time. When you point the mouse in the 
display or move a point, the current position and level change is shown in the field 
above the display.

• To add a point, double click the envelope curve.

• To select a point, click it.

• To select several points, click and drag the selection rectangle.

• To move a point, click and drag it. If more than one point is selected, all points 
are moved.

• To move the whole curve up or down, click the envelope curve, and drag up 
or down.
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• To move the curve segments vertically, click the curve and drag up or down.

• To move two points horizontally, press [Shift], click the curve segment 
between two points, and drag left or right.

• To move two points vertically, press [Ctrl]/[Command], click the curve 
segment between two points, and drag up or down.

Fades in Audio Files

A fade in is a gradual increase in level and a fade out is a gradual decrease in level.

You can create fades by selecting an individual fading type for each fade in/fade 
out.

Creating a Fade In and Fade Out

PROCEDURE

1. In the wave window, make a selection.

2. In the Audio Editor, select the Process tab.

3. Depending whether you want to create a fade in or a fade out, select one of 
the following options in the Fading section:
• To apply the default fade type, click the Fade In or Fade Out icon.

• To select another fade type, click Fade In or Fade Out below the fade icon. 
From the pop-up menu, select the type of fade that you want to create.
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Crossfades

A crossfade is a gradual fade between two sounds, where one is faded in and the 
other faded out. You can automatically create a crossfade when pasting an audio 
section into another.

Creating Crossfades

The material that you want to crossfade can either be in two different sections of the 
same audio file or in two different audio files.

PROCEDURE

1. In the wave window, select the section that you want to fade in.

2. Select the Edit tab.

3. In the Clipboard section, click Copy.

4. Select the section that you want to fade out.
The length of this selection determines the length of the actual crossfade (check the 
length on the status bar). The section can be within the selected audio file or in 
another wave window. However, the selection must not be longer than the selection 
that you just copied.

5. Select the Edit tab.

6. Depending whether you want to create a fade in or a fade out, select one of 
the following options in the Clipboard section:
• To apply the default crossfade type, click the Paste and Crossfade icon.

• To select another crossfade type, click Paste and Crossfade below the 
crossfade icon. From the pop-up menu, select the type of crossfade that you 
want to create.

RESULT 

The crossfade is created. Any material that originally appeared after the selection in 
the file into which you paste, is moved so that it now appears after the pasted 
material.

Any excess material in the copied selection appears after the fade at full level.

NOTE

If both files already have full level sections in the crossfade area (for example, if you 
have normalized both files), clipping and distortion might occur. If this happens, 
reduce the amplitude of both files by 3 dB to 6 dB and try again.

AFTER COMPLETING THIS TASK 

Play back the file and adjust the crossfade if necessary.
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Paste and Crossfade Options

These options allow you to select a crossfade type for pasting.

• Select the Edit tab in the Audio Editor, and click Paste and Crossfade in the 
Clipboard section.

Linear (Equal Gain)

Level changes linearly.

Sinus (Equal Power)

Level changes according to a sine curve, the power of the mix remains 
constant.

Square-Root (Equal Power)

Level changes according to a square-root curve, the power of the mix remains 
constant.

Phase Inverting

Inverting the phase turns the signal upside down. The most common use for this 
function is to fix a stereo recording if one of the channels has been recorded out of 
phase with the other.

Inverting the Audio Phase

PROCEDURE

1. Optional: If you only want to invert the phase for a specific time range of the 
audio file, create a selection range in the wave window.

2. In the Audio Editor, select the Process tab.

3. In the Other section, click Invert Phase.

Inverting the Phase of an Audio Montage Track

PROCEDURE

1. In the Audio Montage window, select the Process tab.

2. In the Process section, click Invert Phase.

RESULT 

An inverted phase is indicated by an icon in the montage window.
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Reversing Audio

You can reverse an audio file or a part of an audio file as if playing a tape backwards.

PROCEDURE

1. Optional: If you only want to reverse a specific time range of the audio file, 
create a selection range in the wave window.

2. In the Audio Editor, select the Process tab.

3. In the Time & Pitch section, click Reverse.

DC Offset

A DC offset is when there is a too large DC (direct current) component in the signal. 
This most often appears due to mismatches between various types of recording 
equipment.

A DC offset is problematic for the following reasons:

• It affects the zero crossing position.

• Some processing options do not give optimal results when performed on files 
with a DC offset.

Removing DC Offset

PROCEDURE

1. In the Audio Editor, open the audio file that you want to check for DC offset 
and that you want to fix.

2. Select the Process tab.
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3. In the Level section, click Remove DC Offset.
A dialog opens, stating the amount of DC offset in the audio file. You can also create 
a selection range in the wave window and select this option to only show the DC 
offset in the selection range.

NOTE

This function should be applied to whole files, because the problem is normally 
present throughout the entire recording.

4. Click OK to remove the DC offset.

Time Stretching

Time stretching is an operation that allows you to change the length of a recording 
without affecting its pitch.

With time stretching you can make audio material longer or shorter. This function is 
most often used to make a section of audio fit in with some other material. You 
select the material to be stretched and use the options in the Time Stretching 
dialog to find a stretch factor. This is done by specifying a length or a tempo, 
according to what the situation requires.

Time Stretching Dialog

In this dialog, you can change the duration of an audio selection, usually without 
changing its pitch. You can stretch a selection to a specified duration (in minutes, 
seconds, and milliseconds), tempo (in bpm), or stretch factor (as percentage).

• To open the Time Stretching dialog, select the Process tab in the Audio 
Editor, and click Time Stretching in the Time & Pitch section.

This dialog is also available as a monopass plug-in in the Batch Processor window.
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Source (Audio Selection)

Duration

If Edit Tempo is activated, you can change the tempo of the audio source. 
The number of bars and beats and the stretch factor is updated automatically.

If Edit Bars is activated, you can set the number of bars and beats and the 
signature for the audio source. The source tempo and according the stretch 
factor is automatically updated.

Result

Target Duration

If this option is activated, the audio source changes its duration.

Target Tempo

If this option is activated, the audio source changes its tempo. For this to work, 
you must specify the original tempo or the number of bars and beats.

Target Stretch Factor

Indicates how much the audio duration changes. This parameter is 
automatically updated when you edit the other parameters, but you can also 
activate this option to edit it manually.

Reset

Resets the stretch factor to 100 %, that is no stretch.

Method

Preserve Pitch

If this option is activated, the pitch of the audio material is not affected when 
you apply time stretch. If this option is deactivated, the pitch changes 
proportionally with the time stretch ratio.

Method pop-up menu

Auto/Preview: Automatically selects the best time/frequency trade-off for 
real-time/preview performance. This is the fastest setting, but might not 
provide optimal results in all cases.

Time Localization ++ (Instruments, Voices): Selects full time localization. 
This is a good setting for single instruments and solo voices.

Time Localization +: Selects the time/frequency localization with the 
emphasis on time localization. If the previous mode produces echo artifacts, 
try this option.

Average Time/Frequency Localization: Sets the time/frequency 
localization halfway between the time and frequency domains. It is the best 
setting for all general purpose signals.

Frequency Localization +: Selects time/frequency localization with the 
emphasis on frequency localization. This is a good setting for classical music.
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Frequency Localization ++ (Complex Mixes): Selects the highest possible 
frequency localization. This setting might not work well on material with many 
sharp attack transients, but it can produce good results with less 
transient/percussive material.

Transcribe Mode (for Large Changes): This uses a content aware algorithm 
to time stretch and pitch shift music by up to 4 times the original length 
without losing information critical to transcription, such as attack transients.

Quality pop-up menu

The High Quality and Best (Slow) modes provide high quality time 
stretching, but the processing takes longer. For most uses, the Standard 
Quality mode is sufficient.

Use Modulation Envelope

If this option is activated, the stretch factor is modulated over time. In the 
Result section, you can set the Maximum Stretch Factor for the modulation 
envelope.

Time Stretching Limitations

Time stretch is a complicated Digital Signal Processing (DSP) operation, that 
always affects the sound quality to some extent.

• For speech, stretch factors within a ±30 % range provide good results.

• For composite music, try to limit the range to ±10 %.

• For sensitive material, like solo piano, try to limit the range to ±3 %.

ZTX Time Stretching Processor

The ZTX engine is a high quality time stretcher. It produces the best quality results 
possible, but takes longer to process.
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Pitch Shift

Pitch shift allows you to detect and to change the pitch of a sound, with or without 
affecting its length. This is useful for fixing an off-key vocal note in a live recording, 
or for tuning the pitch of a kick drum sample to fit a particular song, for example.

Pitch Shifting Dialog

In this dialog, you can change the pitch of a sound.

• To open the Pitch Shifting dialog, select the Process tab in the Audio 
Editor, and click Pitch Shifting in the Time & Pitch section.

This dialog is also available as a monopass plug-in in the Batch Processor window.

Semitones

Specifies the amount of pitch change in semitones.

Cents

Specifies the amount of pitch change in cents.

Find Current Pitch of Audio Selection

Analyzes the pitch of the selected audio and displays it below this button.

According to the current pitch, compute the required shift to match the key 
hereafter

Click to adjust Amount of Pitch parameters automatically, based on the 
detected pitch and the pitch specified in the value field below this button.

Pitch field

Specifies the resulting pitch.

Length Preservation

Specifies how the length of the selection is affected by the operation:

• A setting of 100 means that the length of the audio remains unchanged.
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• A setting of 0 means that the program behaves like a tape recorder, 
when the speed of its tape is changed. For example, if you raise the 
pitch by one octave, the audio is half as long.

• Intermediate values give results in between these two extremes.

For large transposition values, the lower this setting, the better the quality of 
the effect.

Method pop-up menu

Auto/Preview: Automatically selects the best time/frequency trade-off for 
real-time/preview performance. This is the fastest setting, but might not 
provide optimal results in all cases.

Time Localization ++ (Instruments, Voices): Selects full time localization. 
This is a good setting for single instruments and solo voices.

Time Localization +: Selects the time/frequency localization with the 
emphasis on time localization. If the previous mode produces echo artifacts, 
try this option.

Average Time/Frequency Localization: Sets the time/frequency 
localization halfway between the time and frequency domains. It is the best 
setting for all general purpose signals.

Frequency Localization +: Selects the time/frequency localization with the 
emphasis on frequency localization. This is a good setting for classical music.

Frequency Localization ++ (Complex Mixes): Selects the highest possible 
frequency localization. This setting might not work well on material with many 
sharp attack transients, but it can produce good results with less 
transient/percussive material.

Transcribe Mode (for Large Changes): This uses a content aware algorithm 
to time stretch and pitch shift music by up to 4 times the original length 
without losing information critical to transcription, such as attack transients.

Quality pop-up menu

The High Quality and Best (Slow) modes provide high quality time 
stretching, but the processing takes longer. For most uses, the Standard 
Quality mode is sufficient.

Correct Formants

If this option is activated, changing the pitch of vocal material gives a more 
realistic result. When processing non-vocal material leave this option 
deactivated, because it uses a slightly slower processing algorithm.

NOTE

This algorithm might cause a noticeable increase in signal level.
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Modulate Formants Correction

If this option is activated, the formant correction is modulated over time.

NOTE

If the envelope is not used and the formant correction is activated, a 100 % 
correction is performed.

Pitch Quantizing Dialog

This dialog allows you to automatically detect and correct the pitch of an audio file. 
The input signal is quantized to discrete notes.

• To open the Pitch Quantizing dialog, select the Process tab in the Audio 
Editor, and click Pitch Quantizing in the Time & Pitch section.

This dialog is also available as a monopass plug-in in the Batch Processor window.

Pitch quantize works best on recordings that have monophonic signals, such as 
voice or single instruments.

Reference Frequency

Defines the reference tuning (in Hz) for the pitch shift.

Liaison Time

Defines the time it takes for the correction to reach the full correction amount. 
Typically, sung notes are slightly unstable at the beginning, because the 
attack phase of a sound has a higher amount of noise and because singers 
gradually adjust their tuning after the onset of the note.

The slur time makes the pitch shift sound more natural, because it mimics this 
effect.

Preserve Formants

If this option is activated, the formants are corrected according to the pitch 
shift amount.

Quality pop-up menu

The High Quality and Best (Slow) modes provide high quality time 
stretching, but the processing takes longer. For most uses, the Standard 
Quality mode is sufficient.
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Pitch Bend

Pitch bend allows you to change the pitch of a sound over time. Changing the pitch 
using pitch bend affects its duration unless Preserve Duration is activated.

This function can be used for creating the classic tape stop effect, or for blending 
the tempo/pitch of one track into another, for example.

You can draw the curve that you want the pitch to follow. The pitch offset is 
displayed on the vertical ruler of the envelope and the range of the envelope effects 
can be adjusted. Positive pitch values produce sounds with a higher pitch and a 
shorter length, negative values produce sounds with a lower pitch and a longer 
length.

If Preserve Duration is activated, you can choose the algorithm that is used to 
perform the pitch bend operation. Depending on the type of audio material you are 
processing, choose the appropriate mode. You can also adjust the quality used 
when processing the pitch bend. The quality setting and the selected mode affect 
the processing time for this effect.

Pitch Bend Dialog

In this dialog, you can gradually change the pitch of a sound using an envelope 
curve.

• To open the Pitch Bend dialog, select the Process tab in the Audio Editor, 
and click Pitch Bend in the Time & Pitch section.

The following options are available at the top of the dialog:

• Undo/Redo the Last Operation

• Deselect the Envelope Points

• Delete the Selected Envelope Points

• Reset the Selected Envelope Points
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• Reset the Whole Envelope

• Flip the Envelope Around the Horizontal Axis

• Reverse the Envelope Time Sequence

• Toggle the Envelope Smoothing

The following options are available at the bottom of the dialog:

Preserve Duration

If this option is activated, a time stretching process is applied to compensate 
for the change of duration caused by the pitch modifications.

Method pop-up menu

Auto/Preview: Automatically selects the best time/frequency trade-off for 
real-time/preview performance. This is the fastest setting, but might not 
provide optimal results in all cases.

Time Localization ++ (Instruments, Voices): Selects full time localization. 
This is a good setting for single instruments and solo voices.

Time Localization +: Selects the time/frequency localization with the 
emphasis on time localization. If the previous mode produces echo artifacts, 
try this option.

Average Time/Frequency Localization: Sets the time/frequency 
localization halfway between the time and frequency domains. It is the best 
setting for all general purpose signals.

Frequency Localization +: Selects the time/frequency localization with the 
emphasis on frequency localization. This is a good setting for classical music.

Frequency Localization ++ (Complex Mixes): Selects the highest possible 
frequency localization. This setting might not work well on material with many 
sharp attack transients, but it can produce good results with less 
transient/percussive material.

Transcribe Mode (for Large Changes): This uses a content aware algorithm 
to time stretch and pitch shift music by up to 4 times the original length 
without losing information critical to transcription, such as attack transients.

Varies with Envelope

If this option is activated, time stretching is continuously applied, but varies, 
depending on the pitch changes. If this option is deactivated, time stretching 
is applied equally to all audio parts.

In both cases, the global audio duration is preserved. The option is activated 
by default because this gives a more natural result. Note however, that this 
affects the quality of the audio.

Quality pop-up menu

The High Quality and Best (Slow) modes provide high quality time 
stretching, but the processing takes longer. For most uses, the Standard 
Quality mode is sufficient.
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Range (Semitones)

Specifies the maximum range in semitones for the pitch change. When you 
change this value, this is indicated in the vertical ruler.

Resample

You can change the sample rate of a recording. This is useful if the file that you want 
to use in an audio system was recorded at a sample rate that this system does not 
support.

NOTE

• Sample rate conversion from a low frequency upwards does not improve the 
sound quality. The high frequencies that were lost cannot be restored by a 
conversion.

• If you resample to a lower frequency, high frequency material is lost. 
Therefore, converting down and then up again leads to a degradation in 
sound quality.

NOTE

Using the Resampler plug-in in the quality mode High to change the sample rate 
results in the same quality as when using the Resample option in the Audio Editor. 
However, that is only the case if the sample rate in the Sample Rate dialog exists 
in the values of the Resampler Sample Rate pop-up menu. If you choose a custom 
sample rate, another algorithm is used, which results in a lower quality of what the 
Resampler can achieve.

Converting a Sample Rate

NOTE

Sample rate conversion is always applied to the entire file.

PROCEDURE

1. In the Audio Editor, select the Process tab.

2. In the Time & Pitch section, click Resample.

3. In the Sample Rate dialog, select a sample rate from the pop-up menu.

4. Click OK.
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Effect Morphing

Effect morphing allows you to smoothly morph from one effect to another, or from 
an unprocessed audio segment to a processed audio segment.

Effect morphing always involves two audio ranges. For example, two versions of the 
same audio range, of which one is processed and the other unprocessed.

Effect Morphing Dialog

In this dialog, you can gradually mix two audio ranges that have different effects or 
processing applied to them.

• To open the Effect Morphing dialog, select the Process tab in the Audio 
Editor, and click Effect Morphing in the Other section.

The dialog consists of a waveform display that shows the current selection and an 
envelope curve (by default a straight line) in the middle. By adding points to the 
envelope, you can create a curve that is used for the morphing process.

The following options are available at the top of the dialog:

• Undo/Redo the Last Operation

• Deselect the Envelope Points

• Delete the Selected Envelope Points

• Reset the Selected Envelope Points

• Reset the Whole Envelope

• Flip the Envelope Around the Horizontal Axis

• Reverse the Envelope Time Sequence

• Toggle the Envelope Smoothing

The following options are available in the lower right corner of the dialog:
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Mix Current Selection With

Unprocessed Selection mixes the audio selection with the unprocessed 
version of the same audio.

Clipboard mixes the audio selection with the clipboard.

RELATED LINKS

Basic Envelope Operations on page 216

Setting Up the Effect Morphing

PROCEDURE

1. In the Audio Editor, open the two audio files that you want to apply effect 
morphing to.
Effect morphing always involves two audio ranges.

2. In the wave window, make a selection range over the time that you want the 
effect morphing to take place.

3. Process this range by using any Master Section effects or offline processing.
You cannot use processing/effects that alter the length of the selection, for example, 
time stretching.

4. Select the Process tab.

5. In the Other section, click Effect Morphing.

6. Make sure that Unprocessed Selection is activated.
The current processed selection is mixed with an unprocessed version of the same 
selection.

7. Adjust your envelope points over time between 0 % and 100 %.
This determines the level and direction of the morph. For example, starting at 100 % 
and ending at 0 % fades out the effect.

8. Click Apply.
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Morphing Effects of Differently Processed Audio Segments

Effect morphing can take place between two differently processed audio segments.

PREREQUISITE 

In the Audio Editor, make a range selection and process the selection.

PROCEDURE

1. Select the result, and press [Ctrl]/[Command]-[C].

2. Undo the processing.

3. Process the selection again, this time with a different effect.

4. Select the Process tab.

5. In the Other section, click Effect Morphing.

6. In the Effect Morphing dialog, activate Clipboard.

7. Click Apply.

RESULT 

The curve enables you to morph between two different processing methods.

NOTE

The clipboard can also be a copy from another wave file, but the clipboard size and 
the selection size must match.
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Audio Montage

The audio montage is a multichannel and multitrack non-destructive editing 
environment that allows you to arrange, edit, play back, and record audio clips.

Non-destructive means that when you delete or change a part of an audio file, the 
audio is not deleted or permanently changed. Instead, a set of pointers keeps track 
of all the edits, so that these can be readily reversed.

The non-destructive editing functions include both track- and clip-based effects, 
volume and pan automation, as well as wide-ranging fade and crossfade functions. 
The multichannel support makes it possible to create surround mixes that can be 
written to DVD-Audio compatible discs.

The audio montage is a great tool for audio CD or DVD-Audio creation, mastering, 
multimedia work, radio spot production, etc.

Basic Terminology

Audio montages can contain an unlimited number of stereo or mono audio tracks. 
You can use them to structure your work graphically or logically. Depending on the 
channel configuration of the audio montage, you can route each track to a stereo 
output or route each track to different surround channels (up to 6) or non-surround 
audio channels (up to 8).

On an audio track, you can place any number of clips. Clips are containers for the 
audio, and include a number of settings and functions such as volume and pan 
curves, fades, etc.

A clip contains a reference to a source audio file on your hard disk, as well as start 
and end positions in the file, which means that clips can play back sections of the 
source audio files. Any number of clips can reference the same source file.

In addition to audio tracks, you can create DVD-Audio picture tracks in the audio 
montage.

Montage Window

The montage window is where you assemble your audio montage. This is where you 
view, play back, and edit audio montages.

The montage window gives you a graphical representation of the tracks and clips.
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Track Control Area

The track control area offers several options regarding the track.

Fold/Unfold Track

Folds/Unfolds the track.

Mute

Mutes the track.

Solo

Solos the track.

FX

Opens the Effects pop-up menu where you can select effects for the track. 
A blue icon indicates that a track has track effects.

Track number button

Opens the track menu that contains track-related options.

Audio Track Dispatching

Opens the Audio Track Dispatching dialog where you can route a track to 
an output channel.

Track Name

Opens the Track Name dialog where you can enter a name for the track.
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Track Pop-up Menu

This pop-up menu contains all track-related options.

• To open the Track pop-up menu, click the number button of a track in the 
track control area.

Add Stereo Track

Adds a stereo track below the active track.

Add Mono Track

Adds a mono track below the active track.

Add Picture Track

Adds a picture track below the active track.

Move Track Up

Moves the track one position up in the track list.

Move Track Down

Moves the track one position down in the track list.

Split into Left/Right Mono Tracks

Converts the stereo track into two mono tracks that represent the left and 
right channels of a stereo track. This does not alter the audio material.
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Split into Mid/Side Mono Tracks

Converts the stereo track into two mono tracks that represent the mid and 
side channels. This assumes that each channel of a stereo track is a mid/side 
recording. This does not alter the audio material.

Duplicate Track

Creates a copy of the active track. The duplicate is added below the active 
track.

Remove Track

Deletes the active track.

Mute

Mutes the active track.

Solo

Solos the active track.

Route to Master Section

Routes the audio signal of the active track to the Master Section input.

Route to Master Section and Upper Track

Routes the audio signal of the active track to the Master Section input and 
to the modulation input of the Ducker clip plug-in.

Route to Upper Track Only

Routes the audio signal of the active track to the modulation input of the 
Ducker clip plug-in.

Record at Cursor

Opens the Recording dialog to start recording at the cursor position.

Lock

If this option is activated, you cannot edit the track.

Half-Height

Reduces the track height to half the current size.

Quarter-Height

Reduces the track height to a quarter of the current size.

Zoom

Shows the active track in the full available height.

Color

Opens a submenu where you can select a color for the active track.

RELATED LINKS

Ducker on page 725
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Audio Montage Tabs

The tabs in the Audio Montage window give you access to the tools and options 
you need for editing audio montages. For example, you can edit the envelope curves 
and fades in clips, make zoom settings, analyze the audio, and render the audio 
montage.

View Tab

Navigate

Backwards/Forwards

Navigates to the previous/next cursor position, zoom factor, and selection 
range.

Zoom

Zoom

Activates the Zoom tool that allows you to define a time range that is zoomed 
in.

Time

Opens a pop-up menu that allows you to adjust the zoom to display the 
selected time range. Zoom in 1:1 zooms in so that one pixel on the screen 
represents one sample.

To edit the zoom factor, click Edit Zoom Factor. This opens the Zoom Factor 
dialog, where you can edit the following settings:

• Set Time Range allows you to specify the time range that you want to 
display.

• Samples per Screen Point allows you to specify how many audio 
samples are summarized in each screen point.

• Screen Points per Sample allows you to specify how many screen 
points are used to represent a single audio sample.

Zoom Selection

Zooms the window so that the current selection occupies the entire montage 
window.
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Microscope

Zooms in as far as possible.

View All

Zooms out as far as possible.

Display Whole Clip

Adjusts the view to display the active clip.

Zoom in Audio (10x)/Zoom out Audio (10x)

Zooms in/out in big steps.

Zoom in Audio/Zoom out Audio

Zooms in/out in small steps.

Zoom in Vertically/Zoom out Vertically

Zooms in/out to show waveforms with a lower/higher level.

Level

Adjusts the zoom to only display samples below the selected dB value.

Reset Zoom to 0 dB

Adjusts the zoom to display audio levels up to 0 dB.

Cursor

Move Cursor to Start of File/Move Cursor to End of File

Moves the cursor to the start/end of the file.

Previous Marker/Next Marker

Moves the cursor to the previous/next marker.

Start of Selection/End of Selection

Moves the cursor to the start/end of the selected time range.

Previous Region Edge/Next Region Edge

Moves the cursor to the previous/next region edge.

Edit Cursor Position

Opens the Cursor Position dialog where you can edit the cursor position.

Previous Clip Edge/Next Clip Edge

Moves the cursor to the previous/next clip edge.

Scroll

Start/End

Displays the start/end of the audio without moving the cursor.
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Start of Selection/End of Selection

Displays the start/end of the audio selection without moving the cursor.

Cursor

Displays the cursor position.

Playback

Steady View

Deactivates scrolling.

View Follows Cursor

Automatically scrolls the view to keep the playback cursor visible.

Scroll View

Scrolls the view to keep the playback cursor centered.

Clip

Ruler

If this option is activated, the markers of the source audio file are displayed in 
the clip, together with a ruler.

Color

Allows you to apply a color to the active clip.

Tracks

Display More Tracks/Display Fewer Tracks

Allows you to change the number of tracks that are displayed in the montage 
window.

Focus on Previous Track/Focus on Next Track

Sets the focus on the previous/next track.

Snapshots

Allows you to take, recall, and edit snapshots.

Take Snapshot

Activates/Deactivates the snapshot function. If this option is activated, click 
on a preset button to save a snapshot.

Presets

The buttons 1, 2, and 3 allow you to save a snapshot of the scroll position, 
zoom factor, cursor position, audio selection, and clip selection. The rightmost 
preset button is a global preset that is available for all audio montages.
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Options

Allows you to select which settings are restored when applying a snapshot 
preset. The following options are available:

• Scroll Position and Zoom

• Cursor Position

• Audio Selection

• Clip Selection

Peaks

Update Peak Files

Updates the peak files of the audio file.

Map Waveform to Level

If this option is activated, changes in the level envelope are reflected in the 
waveform.

Edit Tab

Source

Edit Source

Opens source file of the clip in the Audio Editor.

Edit Cubase Project

Opens the Cubase project relating to the clip.

Time Selection

Range

Opens the Audio Range dialog where you can define selection ranges very 
accurately.

Right-click Range to open the Preset pop-up menu. Here, you can select 
factory presets and custom presets.

Extend

Allows you to edit the selection range in the following ways:
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• Double Selection Length doubles the length of the selection range.

• Halve Selection Length halves the length of the selection range.

• From Playback Position to End of File creates a selection range from 
the playback position to the end of the file. If playback is not active, the 
position of the edit cursor is used.

• From Playback Position to Start of File creates a selection range from 
the playback position to the start of the file. If playback is not active, the 
position of the edit cursor is used.

Toggle

Toggles the selection range on/off.

Clipboard

Cut

Cuts the active clip to the clipboard.

Copy

Copies the active clip to the clipboard.

Right-click Copy to open a pop-up menu with additional options:

• Memorize Cursor Position copies the position of the edit cursor to the 
clipboard.

• Memorize Selection Length copies the length of the active selection 
range to the clipboard.

Paste

Pastes the clipboard content.

Right-click Paste to open a pop-up menu with additional paste options.

Split

Split Selected Clips

Splits the selected clips at the edit cursor or playback cursor position.

Split Clips on All Tracks

Splits the clips on all tracks at the edit cursor or playback cursor position.

Removal

Crop Clip

Removes the areas of the clip that are outside the selection range.

Erase Selected Range

Erases the part of the clip that lies inside the selection range on the selected 
track, without filling the gap.
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To erase the selection range on all tracks, right-click Erase Selected Range 
and select Erase Selected Range on All Tracks.

Delete Selected Range

Deletes the part of the clip that lies inside the selection range on the selected 
track and moves the right section of the clip to the left to fill the gap.

To delete the selection range on all tracks, right-click Delete Selected Range 
and select Delete Selected Range on All Tracks.

Nudge

Target

This pop-up menu allows you to select which items are affected by the nudge 
function.

• Auto Select Item automatically selects what should be nudged, 
depending on your last action. For example, if your last action was to 
select or move a clip, the Clip Position option is automatically selected.

• Clip Position moves the selected clips.

• Clip’s Left/Right Edge resizes the active clip.

• Clip’s Fade In/Fade Out moves the fade in/fade out junction points of 
the active clip. For stereo envelopes, both sides are adjusted.

• Clip’s Crossfade narrows or widens the crossfade zone by moving the 
junction points of both clips in the crossfade. This only works if you 
select the second clip (the one on the right) in a crossfade pair.

• Edit Cursor moves the edit cursor.

• Left Edge of Selected Time Range/Right Edge of Selected Time 
Range moves the left/right edge of a selection range.

• Selected Marker moves the selected audio montage marker. To select 
a marker, click it in the area above the ruler.

• Volume of Active Clip adjusts the volume of the active clip step by step 
according to the Gain setting in the Audio Montages Preferences.

• Volume of All Selected Clips adjusts the volume of all selected clips 
step by step according to the Gain setting in the Audio Montages 
Preferences.

• Pan of Active Clip adjusts the pan of the active clip. Nudge + pans to 
the left and Nudge – to the right.

• Pan of All Selected Clips adjusts the pan of all selected clips. Nudge 
+ pans to the left and Nudge – to the right.

• Surround Pan of Active Clip adjusts the Pan of the active clip. Nudge 
+ pans to the left and Nudge – to the right.

• Surround Pan of All Selected Clips adjusts the Pan of all selected 
clips. Nudge + pans to the left and Nudge – to the right.
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Nudge Left

Nudges the target to the left or down, by the amount that is defined in the 
Audio Montages Preferences.

Right-click Nudge Left to open a pop-up menu that allows you to change the 
nudge amplitude.

Nudge Right

Nudges the target to the right or up, by the amount that is defined in the Audio 
Montages Preferences.

Right-click Nudge Right to open a pop-up menu that allows you to change 
the nudge amplitude.

Ripple

None

Deactivates the auto-shift function.

Track

If this option is activated and you move a clip horizontally, all clips on the 
selected track that are located to the right of the edited clip are also moved. 
This option also applies when moving or resizing clips, and when inserting or 
pasting more than one clip at the same time.

Global

If this option is activated and you move a clip horizontally, all clips on all tracks 
that are located to the right of the edited clip are also moved. This option is 
taken into account when moving or resizing clips, and when inserting or 
pasting more than one clip at the same time.

Auto Grouping

None

Deactivates auto-grouping.

Track

If this option is activated and you move a clip horizontally, all overlapping or 
adjacent clips on the same track are also moved.

Global

If this option is activated and you move a clip horizontally, all vertically 
overlapping clips on all tracks are also moved.

Snapping

Crossfading

This pop-up menu allows you to make snapping settings for crossfades.
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• If Snap to Waveform When Crossfading is activated and you create a 
crossfade by dragging a clip towards another one located on its left 
side, the position of the moved clip is automatically adjusted to obtain a 
good correspondence between the clip waveforms. This correlation 
process provides a crossfade that is aligned in phase.

• If Create Crossfade and Snap to Waveform When Snapping to Left 
Clip is activated and you move a clip to let its start snap to the end of 
another clip on its left, the clip is slightly moved to the left to create a 
short crossfade that is based on an optimal correlation between the two 
waveforms. This correlation process provides a crossfade that is 
aligned in phase.

• If Create Crossfade When Snapping to Left Clip is activated and you 
move a clip to let its start snap to the end of another clip on its left, the 
clip is slightly moved to the left to create a crossfade.
The length of the crossfade is the fade in length of the clip on the right. 
If the fade in length is zero, the fade out length of the left clip is used as 
a basis instead. If that length is also zero, the Create Crossfade and 
Snap to Waveform When Snapping to left clip function is performed if 
activated.

Snap to Magnets

If this option is activated, moved elements such as clip edges, time selection 
edges, cursor, and markers snap to the magnets that are activated on the 
Magnets pop-up menu.

Magnets

This pop-up menu allows you to select which items should be magnetic.

Clip

Create from Selection

Allows you to create clips from the selection range. If no clip is overlapping 
the selection, an empty clip is created.

Repeat Clip

Opens the Repeat Clip dialog where you can specify how clips should be 
repeated.

Mute

 Mutes the active clip.

Lock

This pop-up menu allows you to lock the active clip.

• If Full Lock is activated, the clip is locked to prevent accidental editing.

• If Time Lock is activated, the position and size of a clip are locked. 
Other editing options are still possible.

Cue Point

This pop-up menu allows you to make cue point settings.
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• Set at Cursor sets the cue point to a fixed position from the start of the 
clip.

• Set at Default Gap Position sets the cue point before the start of the 
clip, at a distance governed by the default pre-gap position.

• Follows Fade In End Point sets the cue point to the fade in end point.

• Follows Fade Out Start Point sets the cue point to the fade out start 
point.

• If Custom Cue End is activated, you can set the end cue point at a 
custom position from the end of the clip. This option allows you to edit 
the gap individually for each clip.
If this option is deactivated, the default gap that is defined in the Audio 
Montages Preferences is used.

• End Offset opens the End Cue Point Offset dialog that allows you to 
set the end cue point at a custom position from the end of the clip.

Insert Tab

Markers

Marker Name

Lets you enter the name of the start and end marker. If nothing is entered, a 
generic name is used.

To edit the default names, open the Markers window, and select Functions 
> Default Marker Names.

Different Name for End Marker

If this option is activated, you can enter a different name for the end marker.

If this option is deactivated, the name of the start marker is also used for the 
end marker.

Create Marker

Allows you to create different types of markers and marker pairs at the edit 
cursor position or at the selection range.
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Import

Audio Files

Allows you to select one or more audio files to insert at the edit cursor position 
on the selected track.

Clip Files

Opens the file browser where you can select one or more clips to insert at the 
edit cursor position on the selected track. If you import several clips at the 
same time, they are lined up in alphabetical order, according to their file 
names, and separated according to the set pre-gap.

Surround Audio File

Allows you to select a surround audio file to insert at the edit cursor position 
on the selected track. For this, the audio montage must be set to 
Multichannel (DVD-Audio Compatible) with 6 Channels. Each file is placed 
on a different track, and routed to the corresponding surround output. Mono 
surround channels are placed on mono tracks and stereo surround channels 
on stereo tracks.

Audio Montages

Allows you to select an audio montage to insert at the edit cursor position on 
the selected track.

Selected Clip

Replace Audio File

Allows you to make the clip refer to another audio file while retaining all clip 
settings. The audio file must be at least as long as the end position of the clip. 
You cannot substitute a stereo file with a mono file or vice versa. Clicking the 
arrow icon opens the list of recently used folders.

Clone and Substitute

Creates a copy of the source audio file and makes the clip refer to this new 
file. As a result, you can modify the new source file without affecting other 
clips of the original audio file. The cloned audio file is saved in the implicit 
folder that is specified in the Audio Montages Preferences.

Process Tab
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Loudness

Meta Normalizer

Opens the Loudness Meta Normalizer dialog where you can adjust the 
loudness of each clip in the audio montage so that they get the same 
loudness. You can also adjust the whole output, while taking the EBU R-128 
audio measurement recommendation and a true peak analysis into account.

Process

Time-Stretch to Cursor

Opens the Time Stretching dialog that allows you to time-stretch the clip so 
that it ends at the audio montage edit cursor position. When this function is 
used, a clone of the original audio file is created, containing the audio range 
used in the clip. The process is applied to the clone, and the clip refers to this 
file instead. Neither the original audio file nor other clips that refer to the same 
audio file are affected. The cloned audio file is saved in the implicit folder that 
is specified in the Audio Montages Preferences.

Pitch Shifting

Opens the Pitch Shifting dialog where you can change the pitch of the clip. 
When this function is used, a clone of the original audio file is created that 
contains the audio range used in the clip. The process is applied to the clone, 
and the clip refers to this file instead. Neither the original audio file nor other 
clips that refer to the same audio file are affected. The cloned audio file is 
saved in the implicit folder that is specified in the Audio Montages 
Preferences.

Invert Phase

Inverts the phase of the clip. An inverted phase is indicated by an icon in the 
wave window.

Split

Auto Split

Opens the Auto Split dialog where you can specify how to split clips.

Fade Tab
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Edit

Fade In/Fade Out

Allows you to switch between the fade in and the fade out settings.

Zoom

Zoom to Fade Range

Adjusts the view to display the fade in/fade out part of the active clip.

Shape

Curve

Allows you to select preset fade curves.

• Linear changes the level linearly.

• Sinus (*) changes the level according to a sine curve. When used in a 
crossfade, the loudness (RMS) remains constant during the transition.

• Square-Root (*) changes the level according to a square-root curve. 
When used in a crossfade, the loudness (RMS) remains constant 
during the transition.

• Sinusoid changes the level according to a sine curve.

• Logarithmic changes the level according to a logarithmic curve.

• Exponential changes the level according to an exponential curve.

• Exponential+ changes the level according to a more pronounced 
exponential curve.

Variations

When creating a crossfade, the fade in/fade out shape changes to optimize 
the volume evolution during the crossfade. The following options are available:

• If Pure Shape is selected, the fade shape is not changed and is used 
as defined. This is the default setting when any fade in/fade out preset 
is selected.

• If Amplitude Compensation is selected for a fade in/fade out curve in 
a crossfade, the summed fade in/fade out gains remain constant along 
the crossfade region. This option is recommended for short crossfades.

• Medium Compensation provides an intermediary between amplitude 
compensation and power compensation. This option is recommended 
if the other two compensation options do not provide the expected 
result.

• If Power Compensation is selected, the power of the crossfade 
remains constant along the crossfade region. Crossfading between 
completely different types of audio material can sometimes cause 
harmonics to cancel each other out at the crossfade splice point, 
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causing the volume to drop. Constant power crossfades compensate 
for this. Using either the Sinus (*) or Square-Root (*) fade presets for 
a fade in/fade out provide a constant power crossfade without selecting 
this option.

NOTE

Selecting a compensation option for a single fade (not a crossfade) changes 
the shape of the curve. However, the actual compensation is only applied 
when the fade becomes part of a crossfade.

Time

Fade Time

Allows you to specify a fade in/fade out time for the clip.

Apply Fade Time

Applies the specified clip fade in/fade out time.

Clip Options

Hide Curve Points

Hides the envelope curve points. This way, they cannot be edited with the 
mouse. However, you can drag the whole curve up or down.

Automatic Changes

If this option is activated, the fade in/fade out is not changed automatically, for 
example, by automatic crossfading of overlapping clips. This option is useful 
if you have set a fade that you do not want to be altered, even though you may 
want to overlap the clip with another clip. This option is individual for each clip, 
as opposed to the global No Automatic Crossfading.

Smoothing

Rounds the resulting envelope curve angles. This produces smoother, more 
natural envelope curves.

Clipboard

Copy

Copies the fade in/fade out shape to the clipboard.

Paste

This pop-up menu allows you to set the paste behavior.

• Paste Shape Only replaces the fade in/fade out shape with the shape 
that was copied to the clipboard. The original length is preserved.

• Paste to Selected Clips replaces the fade in/fade out shape in all 
selected clips with the shape that was copied to the clipboard.
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Preset

Presets

This pop-up menu allows you to save and restore fade presets, and set up the 
default settings for automatic fades and crossfades.

Apply Default

Replaces the current fade in/fade out with the default setting that is specified 
on the Presets pop-up menu.

Options

Overlaps

This pop-up menu allows you to set the automatic crossfading behavior.

• If No Automatic Crossfading is activated, no automatic crossfading is 
performed when clips overlap.

• If Free Overlaps is activated, automatic crossfades are created when a 
clip overlaps another clip on the same track. The length of the overlap 
determines the length of the crossfade.

• If Fade-In Constrains Overlaps is activated, the fade in length of a clip 
constrains the maximum possible overlap, and thus the crossfade time. 
If the clip on the right side, that is, the clip with the fade in in the overlap, 
is moved to the left past the set overlap time, the other clip is 
progressively resized. Moving the other clip to the right into the clip that 
contains the fade in in the overlap produces the same result.

• If Fade-Out Constrains Overlaps is activated, the fade out length of a 
clip constrains the maximum possible overlap, and thus the crossfade 
time. If the clip on the left side, that is, the clip with the fade out in the 
overlap, is moved to the right past the set overlap time, the other clip is 
progressively resized. Moving the other clip to the left into the clip that 
contains the fade out in the overlap produces the same result.

Automatic Crossfading

This pop-up menu allows you to make automatic crossfading settings.

• If Allow Automatic Crossfading with Clips on Selected Track is 
activated, crossfades are automatically created when you move a clip so 
that it overlaps another clip that is located on the selected track.

• If Allow Multiple Automatic Crossfades is activated, crossfades are 
automatically created for all moved clips that overlap other clips on their 
track. If this option is deactivated, a crossfade is only created for the clip 
that you drag, even if several clips are moved simultaneously.

Options

• If Create Default Fades in New Clips is activated, all new clips get the 
default fade in and fade out shape and length. For clips that are created 
by splitting a clip, only the default fade time is used.
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• If Lock Fade Times When Adjusting Clip Edges is activated, the 
defined fade in and fade out lengths are locked to the clip start or end, 
even if you adjust the clip edges. This means that if you resize a clip by 
dragging its edge, the corresponding fade junction point moves 
accordingly, while maintaining the fade length.

Envelope Tab

Selector

Envelope Type

Sets the type of the envelope. Depending on the selected type, different 
options are available.

Pan Law

Lets you select a pan mode. This option is only available if the Pan envelope 
type is selected.

Lock Mouse Editing

If this option is activated, all envelopes are locked and cannot be edited with 
the mouse. The envelopes and their points are still displayed.

Zoom

Zoom to Envelope Range

Adjusts the view to display the active envelope of the active clip.

Level

Reset All

Resets the envelope to its neutral form.

Reset to 0 dB

Replaces the segments between the fade in and fade out points with a single 
neutral segment.

Ducking

Opens the Ducking Settings dialog. This dialog allows you to create ducking 
effects between clips on two adjacent tracks where the level or send effect of 
one clip is modified every time that clips are present on the other track.
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Mute Selection

Adds level envelope points and draws a curve to mute the selection by 
lowering the level to zero with default 20 ms fall and rise times.

Raise Selection

Adds level envelope points and draws a curve to raise the audio level of the 
selection with 20 ms fall and rise times. You can drag the created segment up 
and down to adjust the level.

Clip Options

Hide Curve Points

Hides the envelope curve points. This way, they cannot be edited with the 
mouse. However, you can drag the whole curve up or down.

Envelope after Effects

Places the level/fade envelope after the clip effect section. This is useful if you 
are using dynamic processors that alter the level of the clip.

Smoothing

Smoothes the resulting envelope curve angles. This produces more natural 
envelope curves.

Shape

Copy

Copies the envelope shape into a dedicated clipboard while excluding any 
fade part.

Paste

Replaces the current envelope shape with the one in the clipboard without 
altering any fade part.

Convert

• Convert to Stereo creates independent envelopes for the left and right 
channels.

• Convert to Mono combines the envelopes of the left and right channels 
into a single envelope.

Selected Points

Delete

Deletes the selected envelope points in the active clip.

Deselect

Deselects the selected envelope points in the active clip.
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Reset

Resets the selected points in the active clip to their default level.

Preset

Presets

This pop-up menu allows you to save and restore envelope presets.

Analyze Tab

Monitoring

Playback

This is the standard metering mode, in which the meters reflect the audio that 
is played back. Metering occurs after the Master Section, which means that 
effects, dithering, and master faders are taken into account. You can monitor 
playback in audio files, audio montages, audio CD track lists, etc.

Audio Input

In this mode, the meters reflect the audio input. Typically, this is the mode to 
use when recording. The Master Section settings are not taken into account.

File Rendering

In this mode, you can monitor what is being written to disk during file 
rendering or recording. Average and min/max peak values are calculated. 
After rendering, the meters freeze until you refresh or change the monitor 
mode.

Freeze Meters

This mode freezes the values for all open meters. The meters remain frozen 
until you select another monitor mode or deactivate Freeze Meters.

Floating Meters

Show/Hide

Shows/Hides floating meters.
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Render Tab

Source

Auto Select Source

If this option is activated, the source option changes according to the 
selection that you make in the audio file. If there is no selection, the whole 
audio montage is processed.

The Source pop-up menu allows you to select which part of the audio 
montage you want to process. The following options are available:

Whole Montage

Processes and renders the whole audio range.

Selected Audio Range

Processes and renders the selected audio range.

Union of Selected Clips

Processes and renders the audio range that starts with the first selected clip 
and ends with the last selected clip. Only the selected clips are included in 
the process.

Selected CD Track

Processes and renders the selected CD track in the CD window.

CD Track Group

Processes and renders the CD track group that you can select on the pop-up 
menu below this option.

Specific Region

Processes and renders a specific audio range to an independent file.

Specify the region to process on the pop-up menu.

All CD Tracks in Group

Processes and renders all CD tracks in the selected CD track group.

All Regions

Processes and renders each marked audio range to an independent file. By 
defining multiple isolated regions in an audio file, you can process them in one 
operation.

Specify the type of regions to process on the pop-up menu.
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All Clip Groups

Processes and renders each audio montage group to an independent file. The 
group names are used as file names.

All Selected Clips

Processes and renders each selected clip to an independent file. The clip 
names are used as file names.

Result

CD/DDP

Allows you to burn a CD or generate a DDP file from the audio montage.

Unnamed File

If this option is activated, the rendered file is named untitled.

Named File

If this option is activated, you can specify a name for the rendered file.

Output

Name

Allows you to enter a name for the rendered file. Clicking the arrow icon opens 
a pop-up menu that offers you several naming options.

Scheme

Allows you to specify a naming scheme for the file name.

Location

Allows you to select a destination folder for the rendered files.

Format

Opens a pop-up menu where you can select a single file format or multiple file 
formats.

Options

Depending on the selected source, different options are available.

Bypass Master Section

If this option is activated, the plug-ins and gain of the Master Section are 
bypassed when rendering.

Exclude Master Section Bypassed Plug-ins

If this option is activated, the plug-ins that are bypassed in the Master 
Section during playback are not used for rendering.
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Fade In/Out at Boundaries

If this option is activated, a fade is performed at the audio range boundaries 
when a new file is created, or a crossfade with the adjacent audio is created 
if the audio range is processed in place.

Crossfades allow for smooth transitions between the processed and the 
non-processed parts. The crossfade time and shape are set in the Audio 
Files Preferences. If the fade time is longer than half the length of the 
processed file, the fade is not performed.

No Reverb Tail

If this option is activated, the audio tail produced by effects such as reverb is 
not included in the rendered file.

Some plug-ins do not transfer information on the tail duration to WaveLab. In 
this case, this option has no effect. For such plug-ins, you can add the 
Silence plug-in to add extra samples at the end of the file.

Copy Markers

If this option is activated, the markers that are included in the range to process 
are copied to the rendered file.

Create Basic Audio CD

If this option is activated, a file of the whole audio montage, including clip 
effects and master effects, is created. Then a Basic Audio CD window opens.

Create CD Image and Cue Sheet

If this option is activated, the audio montage is exported as a CD image with 
an accompanying cue sheet. A cue sheet is a text file identifying the CD tracks 
in the image file. The cue sheet and the image file it describes can then be 
imported into any CD recording application that supports this function 
(including WaveLab) and written onto a CD.

Create Audio Montage from Result

If this option is activated, the rendered audio file is imported in a new audio 
montage.

Open Resulting Audio File

If this option is activated, every rendered file is opened in a new window.

Open Files in New File Group

If this option is activated, the rendered audio file is imported in a new file 
group.

Bypass Master Section on Resulting Audio File

If this option is activated, playback of the resulting audio file bypasses the 
entire Master Section. This setting can be toggled by clicking the button at 
the bottom right of the wave window or montage window.

NOTE

It is recommended to activate this option, because this way, you do not 
monitor new files through the effects that have already been applied to them.
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Include Pause before Track

If this option is activated and you render CD tracks, a pause is included before 
each CD track in the rendered file.

Include Pause after Track

If this option is activated and you render CD tracks, a pause is included after 
each CD track in the rendered file.

Render Audio File, Do Not Change Audio Montage

If this option is activated, the selected CD track is rendered to a separate 
audio file.

Replace On Same Audio Montage Track

If this option is activated, the rendered file replaces the clips on the selected 
montage track.

Add to Next Empty Audio Montage Track

If this option is activated, the rendered file is added to the next empty audio 
montage track. The original clips are preserved.

Add to New Audio Montage Track

If this option is activated, the rendered file is added to a new audio montage 
track. The original clips are preserved.

Bypass Clip Plug-ins

If this option is activated, the selected clips are rendered without their clip 
effects.

Bypass Volume/Pan Envelopes

If this option is activated, the selected clips are rendered without volume and 
pan envelopes.

Replace Clips with Rendered Audio Files

If this option is activated, the rendered audio files replace the selected clips.

Upload to SoundCloud

If this option is activated, the rendered file is uploaded to SoundCloud.

Render

Start

Starts the rendering process.

Signal Flow in the Audio Montage

The audio signal flow passes through the various sections of WaveLab Pro in a 
certain way.
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1) The audio samples are read.

2) Clip envelope (unless post-effects mode is active)

3) Clip effects

4) Clip envelope (if post-effects mode is active)

5) Clip pan

6) Individual clip gain (Clips window)

7) Clips are mixed into the track slot (for example, overlapping clips).

8) Track effects

9) Track level settings/surround pan

10) Each track is mixed into a bus that has as many channels as defined by the 
audio properties of the audio montage (between 1 to 8).

11) The audio channels are processed through the plug-ins of the master output.

12) The channels are sent to the Master Section input.

Signal Flow in the Master Section

1) Channels/sample rate can change at each plug-in slot.

2) Master Section meters

3) Final Effects/Dithering pane in the Master Section

4) Playback Processing pane

5) Independent meters

6) Speaker gain for playback

7) Playback or file format rendering

Creating New Audio Montages

PROCEDURE

1. Select File > New.

2. Select Audio Montage > Custom.

3. Specify the audio properties and click Create.

Audio Montage Properties

You can define the mode (stereo, mono, or multichannel), the number of audio 
channels, and the sample rate of the audio montage.

You can set these properties when you create a new audio montage.

• To change the properties for the selected audio montage, select the File tab 
and click Info, or click the Audio Montage Properties button at the bottom 
right of the montage window.
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Mode

Lets you select the following modes for audio montage projects.

• Stereo (CD Compatible)

• Multichannel (DVD-Audio Compatible)

• Multichannel (Free Configuration)

Channels

Lets you define the number of audio channels and their configuration at the 
output of the audio montage. This is only available in Multichannel 
(DVD-Audio Compatible) mode.

Enable Additional DVD-Audio Configurations

Enables additional DVD-Audio channel configurations on the channels 
pop-up menu. This is only available in Multichannel (DVD-Audio 
Compatible) mode.

This option is only available if you access the Audio Montage Properties via 
the Audio Montage Properties button at the bottom right of the montage 
window.

Sample Rate

Lets you select the sample rate for the audio montage.

Alternative Ways of Creating New Audio Montages

There are several ways to create a new audio montage.

• Import cue sheets/CD images as audio montage

• Import audio CD tracks to an audio montage

• Convert a Basic Audio CD into an audio montage

• Create an audio montage from a wave file with the Auto Split function

• Import an AES-31 project file to an audio montage

• Import an XML text file to an audio montage

• Convert wave files to an audio montage

• When you render, you can open the resulting file into a montage.
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• Duplicating audio montages

• Import DDP files to an audio montage.

• Press [Ctrl]/[Option] and drag a montage tab on the tab bar.

• Double-click an empty section of the tab bar

• From a script

RELATED LINKS

Audio Montage Duplicates on page 260

Audio Montage Duplicates

You can duplicate audio montages in various ways.

Empty (With Same Properties)

Creates a new audio montage with the channel settings and sample rate of 
the original audio montage, without any clips.

Exact Duplicate (Using the Same Audio Files)

Creates an exact duplicate of the original audio montage and lets the new 
clips reference to the original audio files. The duplicated audio montage uses 
the channel settings and sample rate of the original audio montage.

This is useful if you want to create several versions of the audio montage, for 
example, to experiment with variations. However, any processing or editing 
that you apply to the actual audio files are reflected in all audio montages.

You can also press [Ctrl]/[Command], drag a tab, and drop it on the tab bar 
to create a exact duplicate of an audio montage.

Customized Duplicate

Allows you to specify which parts of the audio montage to include in the 
duplicate of this audio montage.

Duplicate (Recreate Audio Files)

Allows you to copy the audio montage together with its audio files to create a 
new self-contained audio montage. There are several uses for complete 
cloning:

• Edit and process the audio files without affecting other audio montages.

• Create different versions of the audio montage that focus on specific 
aspects of the audio montage by removing any unused audio sections.

• Split audio files and give them specific names.
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• Reduce the size of an audio montage project by only using the needed 
audio material.

NOTE

Duplicate (Recreate Audio Files) does not render effects to files.

RELATED LINKS

Duplicating Audio Montages on page 261

Duplicating Audio Montages

PROCEDURE

1. Open the audio montage that you want to duplicate.

2. In the Audio Montage window, select the File tab.

3. Select New > Audio Montage > From Current File.

4. In the From Current Audio Montage section, select one of the following:
• Empty (With Same Properties)

• Exact Duplicate (Using the Same Audio Files)

• Customized Duplicate

• Duplicate (Recreate Audio Files)

5. Do one of the following:
• If you have selected Empty (With Same Properties) or Exact Duplicate 

(Recreate Audio Files), click Create.

• If you have selected Customized Duplicate or Duplicate (Recreate Audio 
Files), make your settings and click OK.

RESULT 

A duplicate of the audio montage opens in another tab.

Create Customized Audio Montage Duplicate Dialog

In this dialog, you can specify which parts of an audio montage you want to include 
in the duplicate.

• To open the Create Customized Audio Montage Duplicate dialog, open an 
audio montage and select the File tab. Select New > Audio Montage > 
From Current File, select Customized Duplicate, and click Create.
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Do Not Import Clips

If this option is activated, the clips of the source audio montage are not 
imported. For example, this can be used to open an audio montage with all the 
CD markers in place and to insert alternate audio clips to compare them with 
the original audio montage.

Import Markers

If this option is activated, the markers of the source audio montage are 
imported.

Import Track and Master Plug-ins

If this option is activated, the track and master plug-ins of the source audio 
montage are imported.

Duplicate with New Audio Files

If this option is activated, you can replace the audio files of the source audio 
montage with new audio files. For this, specify the folder that contains the new 
audio files.

If the audio files that you want to use as replacement have different file names 
than the source audio files, you can specify the differences between the 
source files and the new files.

For example, if the file piano_96k.wav is replaced by the file 
piano_44k.wav, specify 96k in the Old Files field and 44k in the New 
Files field.

If no matching audio files are available, you can create empty clips instead and 
later replace the empty clips with audio files.

If there is a difference between the sample rate of the source montage and 
the sample rate of the new montage, the position, length, envelope, and 
marker settings are adjusted accordingly.
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Duplicate Audio Montage by Recreating Audio Files Dialog

You can create a copy of the audio montage in which the actual audio files are 
duplicated to create a new self-contained audio montage. In this dialog, you can 
specify how the selected audio montage is duplicated.

• To open the Duplicate Audio Montage by Recreating Audio Files dialog, 
open an audio montage and select the File tab. Select New > Audio 
Montage > From Current File, select Duplicate (Recreate Audio Files), 
and click Create.

Name of Audio Montage Duplicate

Specifies the file name of the audio montage duplicate.

Location

The location where you want to create the audio montage duplicate and its 
audio files.

Exact Audio File Duplicates

If this option is activated, the cloned audio files are exact copies of the original 
files. Unused ranges are not removed.

The files are recreated and saved in an uncompressed format. For example, 
an MP3 file that is included in an audio montage will be recreated as a PCM 
file. In other words, the content is recreated, not the file format.

Combine Audio Files into as Few Audio Files as Possible

If this option is activated, all used ranges in the original audio files are copied 
and combined into a single audio file to which the clips in the clone refer. The 
file gets the same name as the audio montage clone file.

NOTE

If the audio montage contains both mono and stereo clips, there will be two 
combined audio files, one for mono material (with the suffix “M”) and one for 
stereo material (with the suffix “S”).
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Remove Unused Ranges

If this option is activated, the same number of audio files is created, but any 
unused ranges in the files are removed. This reduces the file size.

Split Files to Remove Unused Ranges

If this option is activated, unused ranges in the files are removed, and the file 
is split into several new files when a range is removed.

Create One File per Clip

If this option is activated, every clip in the audio montage clone refers to a 
unique file, containing only the audio that is used in the clip. The files are 
named after the clips. A number is added if several clips have the same name.

Create One File per Clip (Avoid Duplicates)

If this option is activated, every clip in the audio montage clone refers to a 
unique file, containing only the audio that is used in the clip. The files are 
named after the clips. However, if two clips use the same audio range, a 
common file is created for these clips.

Clip Margins

Allows you to add a number of seconds before and after the beginning and 
end of the clip range in the created audio files. This allows you to lengthen the 
clips in the cloned audio montage at a later stage.

Use File Names as Clip Names

If this option is activated, the clips in the cloned audio montage get the name 
of the corresponding audio file.

Copy Audio File Markers

If this option is activated, the markers in the original audio files are included in 
the recreated files.

Creating an Audio Montage from an Audio File

You can export audio files to an audio montage, including all markers that you have 
set in the audio file.

PROCEDURE

1. In the Audio Editor, open the audio file that you want export to an audio 
montage.

2. Optional: If you want to use a specific time range of the audio file, create a 
selection range in the wave window.

3. Select File > New.

4. Select Audio Montage > From Current File.

5. In the From Current Audio File section, click Insert Audio File in New 
Montage.

6. Click Create.
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7. In the Create Audio Montage from Audio File dialog, select whether to 
import the whole file or the selected audio range.

8. Optional: Decide if you want to perform any of the following marker 
operations:
• Import Markers

• Split at Generic Region Markers

• Split at CD Track Markers

9. Click OK.

Import Options for Audio Montages

You can import different files into your audio montage, for example, audio files, audio 
montages, and DDP images.

The following import options are available via the Import section on the Insert tab 
of the Audio Montage window:

• To import audio files, click Audio Files and select the audio files that you want 
to import at the edit cursor position on the selected track.

If you import a single audio file, the Paste pop-up menu opens. Here, you can 
specify how the clip should be inserted, whether existing clips should be 
affected, etc.

If you import multiple audio files, the Insert Audio Files dialog opens. Here, 
you can specify where to insert the files.

• To import clips, click Clips and select the clips that you want to import at the 
edit cursor position on the selected track.

If you import several clips at the same time, they are inserted in alphabetical 
order, according to their file names, and separated according to the set 
Pre-Gap.

• To import audio montages, click Audio Montages and select the audio 
montages that you want to import at the edit cursor position on the selected 
track.

• To import surround audio files, click Surround Audio File and select the file 
that you want to import at the edit cursor position on the selected track.

The audio montage must be set to Multichannel (DVD-Audio Compatible) 
mode with 6 Channels. Each file is placed on a different track, and routed to 
the corresponding surround output. Mono surround channels are placed on 
mono tracks and stereo surround channels on stereo tracks.

To access the following import options, select File > Import.

• To import audio files, click Audio Files to Montage, select the audio files that 
you want to import, and click Import.
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• To import a DDP image, click DDP. In the file browser, select the file that you 
want to import, and click Import.

• To import a CD cue file with its audio data, click CD Cue. In the file browser, 
select the file that you want to import, and click Import.

• To import an AES-31 file, click AES-31. In the file browser, select the file that 
you want to import, and click Import.

• To import an audio montage that has been saved as an XML file, click XML. 
In the file browser, select the file that you want to import, and click Import.

• To open audio files that have an unknown format, click Unknown Audio. Via 
the Special File Format dialog, you can specify how to interpret the format 
of the audio file that you want to open.

• To import CD tracks from an audio CD, click Audio CD. Via the Import Audio 
CD dialog, browse for the audio CD tracks to extract.

• To import a file group, click File Group. In the file browser, select the file 
group that you want to import, and click Import.

RELATED LINKS

Mismatched Sample Rates When Inserting Audio Files on page 277
Inserting Multiple Clips on page 266
Audio Montages within Audio Montages on page 308

Inserting Multiple Clips

When you add multiple audio clips to an audio montage by importing them from disk 
or by using drag and drop, the Insert Audio Files dialog opens.

Arrow Up/Down

Moves the selected file up/down in the list.

Add File

Opens the file browser where you can select files to be added to the list.
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Remove File

Removes the selected file from the list.

Line up Files on Current Track (Linear)

If this option is activated, the clips are added to the audio montage, lined up 
contiguously on a single track and spaced according to the Pre-Gap. The 
pre-gap can be defined in the Audio Montages Preferences.

Stagger Files on Two Alternating Tracks (Linear)

If this option is activated, the clips are added to the audio montage, lined up 
contiguously on two alternating tracks.

Place Each File on Separate Track (Stacked/Non-Linear)

If this option is activated, the clips are added to the audio montage on 
separate tracks, according to the following settings.

• If Start Inserting below Selected Track is activated, the new tracks for 
the added files are inserted below the selected track.

• If Use Existing Tracks (Create New Tracks If Necessary) is 
activated, the files are added to the existing tracks. If there are more files 
than existing tracks, new tracks are created.

Shift Existing Clips to the Right

If this option is activated, any existing clips in the audio montage are moved 
to the right by an amount equaling the length of the first new added file.

Missing Files in the Audio Montage Dialog

This dialog opens when you open an audio montage, and some audio files that the 
audio montage refers to cannot be found. You can then search for the files or select 
a replacement.
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Missing Original Files

Lists the files that cannot be found. Each file can be replaced by an existing 
file. To search replacements for multiple files, select the files and specify a 
new path in the Where to Search field.

A file with a green checkmark is associated with a valid replacement. A file 
with a red checkmark is not yet associated with a valid replacement, but there 
are possible replacement candidates available at the bottom of this dialog.

Find Files with the Same Name

Instructs WaveLab Pro to find all files with the same name in the folder 
specified in the Where to Search field.

Replace Selected Files With

Replaces the missing files with a single specific file.

Reset

Removes all possible replacements for the selected missing files.

Where to Search

Lets you specify a location for searching files. Click Find Files with the Same 
Name to start the search.

Replacement List

Lists the files that can be used as a replacement. You can also drag a file into 
the list from the File Explorer/Mac OS Finder.

Assembling the Audio Montage

You assemble your audio montage by adding tracks and clips.

In the audio montage, only one track can be selected at a time. This selected track 
has a different color for the track control area. Some WaveLab Pro functions are 
always applied to the selected track.

Tracks

Tracks form the structure that is used to organize clips. The tracks can be 
mono/stereo audio tracks or picture tracks.

• Audio tracks allow you to add clips to an audio montage.

• Picture tracks allow you to add pictures to an audio montage. These are 
shown when you play back the final DVD-Audio.
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Adding Tracks

You can add stereo tracks, mono tracks, and picture tracks.

PROCEDURE

1. In the Audio Montage window, click the number button of a track to open the 
Track pop-up menu.

2. Select the track type that you want to add to your audio montage.

RESULT 

The new track is added below the selected track. If you want to place it above the 
selected track, press [Ctrl]/[Command] when adding the new track.

Adding Pictures to a Picture Track

PREREQUISITE 

In the Audio Montage window, add a picture track to your audio montage.

PROCEDURE

1. On the picture track, set the edit cursor to the position where you want to 
insert the picture.

2. Right-click an empty area of the picture track and click Insert Files.

3. Select a picture and click Open.

RELATED LINKS

Adding Tracks on page 269

Moving Tracks in the Track View

You can change the order of the tracks in the montage window.

PROCEDURE

1. In the Audio Montage window, click the number button of a track.

2. On the pop-up menu, select Move Track Up or Move Track Down.
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Removing Tracks

Removing a track with clips also removes the clips. However, the audio files to 
which the clips refer are not affected.

PROCEDURE

1. In the Audio Montage window, click the number button of the track that you 
want to remove.

2. On the pop-up menu, select Remove Track.

Grouping CD Tracks

You can render grouped CD tracks simultaneously and create audio CD reports for 
grouped tracks.

PREREQUISITE 

In the montage window, create CD tracks.

PROCEDURE

1. Select Tool Windows > CD.

2. In the CD window, click in the Group column of a CD track and select a 
group.

RELATED LINKS

CD Window on page 358
Audio CD Reports on page 509
Render Tab on page 254

Folding and Unfolding Tracks

To save screen space, you can fold tracks that do not need to be visible.

• To fold a track, click the arrow button at the top left corner of the track control 
area.

• To unfold a folded track, click the button again, or double-click anywhere on 
the folded track.

Locking and Unlocking Tracks

You can lock tracks to prevent them from being accidentally moved, edited, or 
deleted.

• To lock a track, click the number button of the track and activate Lock.
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• To unlock a track, click the locked track, or click the number button of the 
track, and deactivate Lock.

Left/Right and Mid/Side Mono Tracks

You can split a stereo audio track into two mono tracks, either in Left/Right or 
Mid/Side mode. This is a virtual split which does not affect or create audio files.

When you split into mid/side mono tracks, the upper track displays the mid signal 
and the lower track displays the side signal. This allows you to process the mid or 
side signal with any effect plug-in independently, and use independent envelopes.

The mid/side signals are automatically converted back to left/right signal at the 
montage output.

Splitting Stereo Tracks into Mono Tracks

You can split stereo tracks into left/right or mid/side mono tracks. This is a virtual 
split which does not affect or create audio files.

PROCEDURE

1. In the Audio Montage window, click the number button of the track that you 
want to split.

2. Do one of the following:
• To split the stereo track into two left/right mono tracks, select Split into 

Left/Right Mono Tracks.

• To split the stereo track into two mid/side mono tracks, select Split into 
Mid/Side Mono Tracks.
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RESULT 

The track is split. If there are clips on the track, the two stereo sides are now 
separate clips, allowing you to move, edit, or process them independently. If the 
track has no clips, this is the same as deleting the track and inserting two new mono 
tracks.

The mono tracks are automatically grouped and can only be moved and resized 
together.

When you drag a stereo clip onto a mid/side mono track, the stereo clip is 
automatically split into mid and side signals. During playback and rendering, the 
mid/side channels are automatically combined to left/right channels at the montage 
output.

Clips

A clip contains a reference to a source audio file on your hard disk as well as start 
and end positions in the file, volume and pan curves, fades, etc. This allows clips to 
play back smaller sections of their source audio files.

Any number of clips can reference the same source file. Because a clip only 
references to the original source file, it contains no audio data. Any number of clips 
can reference the same source file.

You can also use envelopes and effects on clips.

You can see the clips of the active audio montage in the Clips window.

3 clips on a track

Adding Audio Clips to the Audio Montage

You create clips by inserting audio into the audio montage. There are several ways 
to do this.

NOTE

You cannot add a mono clip to a stereo track or vice versa.
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Dragging Audio from the Wave Window

PROCEDURE

1. In the wave window of the Audio Editor, select the audio section that you 
want the clip to refer to.

2. Drag the selection onto a track of the audio montage.
If you want to add the whole audio file, drag the tab on a track.

3. Select an insert option from the pop-up menu that opens when you release 
the mouse button.

RESULT 

A clip is created, named after the original file.

Inserting Audio from Open Wave Windows Using the Insert Menu

PROCEDURE

1. In the montage window, right-click an empty area of a track.

2. From the pop-up menu, select the audio file that you want to insert as clip.

Inserting Audio Using Copy and Paste

PROCEDURE

1. In the wave window of the Audio Editor, select the audio section to which you 
want the clip to refer to.

2. Select the Edit tab and click Copy, or press [Ctrl]/[Command]-[C].

3. In the montage window, select the track where you want to insert the clip.
The clip insert position is indicated by the edit cursor.

4. Select the Edit tab and click Paste, or press [Ctrl]/[Command]-[V].

5. Select an insert option from the pop-up menu.
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Dragging Audio Files From the File Browser Tool Window

NOTE

The following can also be done from the File Explorer/Mac OS Finder.

PROCEDURE

1. Select Tool Windows > File Browser.

2. In the File Browser window, select the audio files to which you want the clip 
to refer, and drag them on a track.
• If you have selected a single audio file, the Paste pop-up menu opens.

• If you have selected several audio files, the Insert Audio Files dialog opens.

3. Do one of the following:
• If you have selected a single audio file, select an insert option from the pop-up 

menu.

• If you have selected several audio files, specify how the files should be ordered 
and placed, and click OK. Then select an insert option from the pop-up menu.

Dragging Regions From the File Browser Tool Window

If you have defined marker regions in an audio file, you can drag these regions from 
the File Browser window onto a track.

PROCEDURE

1. Select Tool Windows > File Browser.

2. In the File Browser window, select the audio file to which you want the clip 
to refer.
On the right side of the File Browser window, a list shows the available audio regions 
of the selected file.

3. Drag any region to the track.

4. Select an insert option from the pop-up menu.

RELATED LINKS

File Browser Window on page 38

Importing Audio Files

PROCEDURE

1. In the montage window, select the track on which you want to insert the clip.
The clip insert position is indicated by the edit cursor.

2. Right-click an empty area on the track, and select Insert Audio Files from the 
pop-up menu.
• If you have selected a single audio file, the Paste pop-up menu opens.
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• If you have selected several audio files via the Browse option, select the audio 
files that you want to import as clips, and click Open. The Insert Audio Files 
dialog opens.

3. Do one of the following:
• If you have selected a single audio file, select an insert option from the pop-up 

menu.

• If you have selected several audio files, specify how the files should be ordered 
and placed, and click OK. Then select an insert option from the pop-up menu.

Copying Clips From Another Audio Montage

If you have opened more than one audio montage, you can copy clips from one 
audio montage to another, either by using drag and drop or by using copy and 
paste.

Dragging Clips From the Clips Tool Window

You can add clips by dragging them from the same audio montage.

PROCEDURE

1. Select Tool Windows > Clips.

2. Select one or several clips, and drag them to a track.
If you drag a single clip on a clip on the track, you must select an insert option from 
the pop-up menu.

Clip Inserting Options

When dragging a single clip on another clip, you can choose between different clip 
inserting options. For example, you can create default fades. You can also insert 
multiple clips at the same time.

You can insert clips by pasting, importing from disk, using drag and drop, etc.

Single Clip Inserting

If you insert a single clip at a position in an audio montage that contains another clip, 
a pop-up menu opens. By selecting one of the menu items, you specify how the clip 
should be inserted, whether existing clips should be affected or not, etc.
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Add/Mix

Inserts the clip without affecting any clips that already exist on the destination 
track. However, if an inserted audio clip partially overlaps another audio clip, 
a crossfade is created in the overlapping zone provided that an auto 
crossfade option is active.

Insert & Shift Clips Right (Track)

All clips to the right of the inserted clip (on the same track) are moved to the 
right.

Insert & Shift Clips Right (Global)

All clips to the right of the inserted clip (on all tracks) are moved to the right.

Split/Insert

Only available if the insertion point is within an existing clip (audio tracks only). 
The existing clip is split and the right section is moved to the right. Other clips 
are not affected.

Split/Insert & Shift Clips Right (Track)

Applies the Split/Insert function and moves all other clips on the same track 
to the right (audio tracks only).

Split/Insert & Shift Clips Right (Global)

Applies the Split/Insert function and moves all other clips on all tracks to the 
right (audio tracks only).

Replace Selected Range

Only available if there is a selection range on the destination track. The clip 
with the selection range is split at the selection range edges, the inserted clip 
replaces the range, and the section to the right of the range is moved to the 
left or right (depending on the length of the inserted clip and the length of the 
selection range), to close gaps behind the inserted clip.
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Replace Selected Range (Trim Source Accordingly)

Only available if there is a selection range on the destination track and if that 
selection range is shorter than the range of the clip that is to be inserted. The 
inserted clip overwrites only the selected range. If necessary, the range to be 
inserted is trimmed according to the current selection.

Replace Selected Range & Shift Clips Right (Track)

Applies the Replace Selected Range function and moves all other clips on 
the same track to the right.

Replace Selected Range & Shift Clips Right (Global)

Applies the Replace Selected Range function and moves all other clips on 
all tracks to the right.

Overwrite from Cursor

Inserts the clip at the edit cursor position. If the inserted clip overlaps any 
other clips, the overlapped regions are removed from the existing clips.

Make Next Selection the Default Paste Function

If this option is activated, you can select a default option from the menu. This 
default option is used when inserting audio. However, if the option is not 
compatible with the context, it is not processed and the default option is 
deactivated. For example, when using Replace Selected Range while there 
is no range selected.

• To deactivate the default insert action, select the Edit tab, right-click the 
Paste button, and select Cancel Default Insert Action.

Close Menu

No clip is added.

Mismatched Sample Rates When Inserting Audio Files

When inserting audio files with a different sample rate than the sample rates of the 
audio montage, WaveLab Pro can create and use resampled versions of the files.

The resampled file versions are created in the implicit folder that is defined in the 
Audio Montages Preferences. The name of the file is the name of the original file 
name with the new sample rate as suffix. If the resampled file already exists, it is not 
recreated. However, you can also activate the option Recreate Resampled Files 
in the Mismatched Sample Rates dialog.

This creates a 32-bit float file without any dithering process.

If you modify the original audio file, you must use the Replace Audio File option in 
the Insert tab of the Audio Montage window to select the modified audio file. This 
will recreate the resampled file.
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Mismatched Sample Rates Dialog

This dialog opens when you insert an audio file with a different sample rate than the 
sample rate of the audio montage. It allows you to create a resampled copy of the 
audio file.

You can specify the quality of the resample conversion in the Global Preferences.

Recreate Resampled Files

If this option is activated and a resampled file exists, it is recreated. Otherwise, 
the existing version is used. Activate this option if the original audio file has 
been modified and you want to recreate its resampled version.

RELATED LINKS

Resample Conversion Quality on page 703

Empty Clips

If the audio file of a clip is missing, an empty clip displays the length and position of 
the missing clip.

Empty clips are useful for the following:

• As place holders, to create audio montage templates with empty clips.

• As an alternative to muting a clip. The difference is that for empty clips no 
audio is copied when cloning the audio montage.

• To define regions. Because a clip has a start and end point in the audio 
montage, it defines a range which can be used as a reference for any purpose.
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Creating Empty Clips

You can create an empty clip from a selection range.

PROCEDURE

1. In the montage window, select a range.

2. Right-click an empty area of the track, and select Create Empty Clip from 
Selection Range.

Removing the Source of Clips

You can create an empty clip by removing a source file of a clip. This does not delete 
the audio file from the disk.

PROCEDURE

1. In the montage window, select the clip for which you want to remove the 
source audio file.

2. Select the Insert tab.

3. In the Selected Clip section, click Replace Audio File, and select Remove 
Source.

Saving and Loading Clips

You can save clips to disk as separate files. This is useful if you have, for example, 
created a perfect fade, envelope, or clip effect configuration, but want to continue 
experimenting with the clip in the audio montage.

By saving the clip, you can always revert to the perfect version by reloading it. 
However, saved clips are still a reference to the original source file and contain no 
audio data.

Saving Clips

PROCEDURE

1. In the montage window, right-click the bottom area of a clip.

2. From the pop-up menu, select Save Clip.

3. In the Save Clip As dialog, specify a name and location, and click Save.
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Loading Clips

PREREQUISITE 

Select a stereo track for stereo clips and a mono track for mono clips.

PROCEDURE

1. In the montage window, on an empty part of a track, right-click where you 
want to insert the clips.

2. From the pop-up menu, select Insert Clip Files.

3. Select a .clip file, and click Open.

RESULT 

The clips are inserted on the selected track. If you selected more than one clip, the 
first clip is positioned at the audio montage cursor, and any following clips are 
placed according to the default pre-gap time that is set in the Audio Montages 
Preferences. When you import several clips, they are sorted alphabetically 
according to their the file names.

Rearranging Clips

You can freely arrange clips in the montage window.

Selected and Active Clips

There is a distinction between selected and active clips. Some editing functions can 
only be processed on an individual clip or active clip, while others can be processed 
on multiple clips or selected clips.

• A selected clip is a clip that you have selected using any of the selecting clips 
procedures. Several clips can be selected at the same time. This allows you 
to edit multiple clips at the same time using functions such as copy, delete, 
move, etc. Selected clips have a different background color. Right-clicking in 
the top part of a clip opens the Clip Selection Range menu.

• An active clip is the clip that you selected, clicked, or edited last. Only one clip 
can be active at a time. By default, the active clip is distinguished by a 
highlighted name label. Some functions can only be processed on a active 
clip. Right-clicking in the lower part of a clip opens the Active Clip menu.

Mouse Zones

Basic rearranging of clips in the audio montage is achieved by clicking and dragging 
with the mouse. However, the results of dragging with the mouse depend on where 
in the clip you click. The different areas in a clip are called mouse zones.
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By default, the mouse zones have the following basic functionalities:

Top Clip Area

• Copy a clip by dragging.

• Open the source file by double-clicking.

• Split at cursor position by double-clicking the edit cursor 
or pressing [S].

Upper Clip Area

• Select a range.

• Open the Clip Selection Range menu by right-clicking.

Lower and Bottom Clip Area

• Move a clip by dragging.

• Open the Active Clip menu by right-clicking.
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When you move the mouse cursor over a mouse zone, the info line at the bottom 
left indicates the corresponding actions.

Info Line

The info line at the bottom of the Audio Montage window shows what happens 
when you click the mouse button with or without modifier keys, depending on the 
cursor position.

Clip Edges

• Resize a clip by dragging the edges, while keeping the audio 
source static.

• Resize the left or right side of a clip while letting the audio follow 
by holding [Ctrl]/[Command] and dragging the left or right edges.

Clip Name

• Rename the clip by double-clicking.
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• To activate/deactivate the info line, open the Audio Montages Preferences, 
and on the All Audio Montages tab, activate/deactivate Display Indications 
of Possible Actions.

The following symbols are used on the info line:

Single-click

Indicates what happens when you click.

Double-click

Indicates what happens when you double-click.

Right-click

Indicates that you can right-click to display a menu. The name of the menu is 
displayed to the right of the symbol.

[Ctrl]/[Command]-click

Indicates that you can [Ctrl]/[Command]-click for an additional function.

[Alt]/[Option]-click

Indicates that you can [Alt]/[Option]-click for an additional function.

[Shift]-click

Indicates that you can [Shift]-click for an additional function.

Drag up/down

Indicates what happens when you click and drag up or down.

Drag left/right

Indicates what happens when you click and drag left or right.

Drag in any direction

Indicates what happens when you click and drag an item in any direction 
within the audio montage.

Drag out of the audio montage

Indicates what happens when you click and drag an item out of the audio 
montage.

Moving/Resizing clips or changing envelope values

This indicates that you are moving or resizing clips, or changing envelope 
values, for example.

Combined modifier keys

Indicates that you can use combined modifier keys.

Magnetic Bounds in Audio Montages

Some positions, such as markers or the start and end of a clip, can be defined as 
magnetic. Dragged elements can snap to these positions. This makes it easier to 
position items accurately.
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For example, when you move or resize a clip, and its edges or its cue point get close 
to one of the magnetic bounds, the clip snaps to this position. A label is displayed, 
indicating the snap position.

To place the cursor at a magnetic position, click the time line and hold the mouse 
button pressed. When you now move the cursor vertically, the cursor jumps to the 
next magnetic bound.

Activating Snapping to Magnets

To make use of the magnetic bounds function, Snap to Magnets must be activated.

PROCEDURE

1. In the Audio Montage window, select the Edit tab.

2. In the Snapping section, activate Snap to Magnets.

Magnets Menu

In this pop-up menu, you can specify which positions should be magnetic. When 
Snap to Magnets is activated, items that you move snap to these positions.

• To open the Magnets pop-up menu, select the Edit tab in the Audio 
Montage window, and click Magnets in the Snapping section.

You can let items snap to the following positions:

Start of Montage

Makes the start of the audio montage magnetic.

Clip Start

Makes the start of the clips magnetic.

Clip End

Makes the end of the clips magnetic.

Clip Cue Point

Makes the cue point in the clips magnetic.

Clip End Cue Point

Makes the position that is located after the clip end magnetic. If this option is 
deactivated, all end cue points are invisible in the audio montage.

Time Ruler Marks

Makes the main time units that are displayed in the ruler magnetic.
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Markers

Makes the markers magnetic.

Markers in Audio Sources

Makes the markers in the original audio files of the clip magnetic if they are 
visible.

Time Selection Edges

Makes the edges of the selected time range magnetic.

Cursor

Makes the edit cursor magnetic.

Selecting Clips

You can edit multiple selected clips at once.

• To select a clip, click the lower clip area. Selected clips are displayed in a 
different color.

• To select multiple clips, [Ctrl]/[Command]-click the lower clip areas.

• To select a range of clips, [Shift]-click them.

• To select several adjacent clips, double-click the upper clip area, and after the 
second click, drag to select the adjacent clips.

• To select several clips on several tracks with a selection rectangle, hold down 
[Ctrl]/[Command]-[Shift], and drag the rectangle.

• To choose between several clip selection options, open the Clips window 
and select an option from the Select menu, or right-click the top clip area of 
a track and select from the Clip Selection Range pop-up menu.

Selection Ranges in Audio Montages

A selection range is a selected area on a track. The selection range can be entirely 
or partially within a clip or an empty section of the track.

Selection ranges are useful for the following:

• To edit clips by cutting or erasing the selection, or trimming the clip to the 
selection.

• To create a new clip by dragging the selection range to another track.

• To open a montage window with the selection range from the source audio 
file by dragging the selection range to the Audio Editor.

• To play back only the selection range, either the whole audio montage or only 
the clip with the intersecting clip part.

• To loop the playback within the selection by activating the loop and selecting 
the Loop mode on the transport bar.
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Creating and Editing Selection Ranges in Audio Montages

You can resize, create, move, and remove selection ranges.

• To create a selection range in an empty area on a track, click and drag with 
the mouse. The start and end position and the length of the range are 
displayed on the info line.

• To create a selection range within a clip, click and drag with the mouse in the 
upper clip area. The start and end position and the length of the range are 
displayed on the info line.

• To create a selection range of the area between two markers, double-click 
between the markers.

• To create a selection range from a region marker pair, press [Shift], and 
double-click the start or end marker. In the Markers window, you can also 
double-click the Length field of a region marker.

• To create a selection range from a CD track, open the CD window and 
double-click the number to the left of the corresponding track.

• To create a selection range from a clip, open the Clips window and 
[Alt]/[Option]-click the number to the left of the corresponding clip. To zoom 
in on the selected clip, double-click the number to the left of the clip.

• To resize a selection range, [Shift]-click and drag to the left or to the right, or 
click and drag the edges of the selection range.

• To move a selection range, press [Ctrl]/[Command] and [Shift], and drag the 
selection range to the left or right.

• To deselect a selection range, click elsewhere in the audio montage, or press 
[Esc].

Clip Context Menus

Many editing functions for clips can be accessed via the clip context menus. 
Depending on where you right-click the clip, different context menus are available.

1) Fade in section
Opens the Fade In pop-up menu where you can edit the fade in.

2) Bottom area of a clip
Opens the Active Clip pop-up menu where you can edit the active clip.
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3) Upper area of a clip
Opens the Clip Selection Range pop-up menu where you can select specific 
areas of a clip, lock a clip, etc.

4) Sustain section
Opens the Envelope pop-up menu where you can edit the envelope.

5) Clip name
Opens the Effects pop-up menu where you can add effects to the clip.

6) Fade out section
Opens the Fade Out pop-up menu where you can edit the fade out.

Clip Editing

All clips are displayed in the Clips window. In this window, you can edit and 
rearrange clips and drag them into the audio montage.

The active clip is highlighted in the clips list.

RELATED LINKS

Clips Window on page 287

Clips Window

This window contains a list of the clips that are placed in the active audio montage 
together with additional information about the clips.

• To open the Clips window, open an audio montage and select Tool Windows 
> Clips.

Clip List

In the clip list columns, you can edit the following settings for each clip:

• Name

• Track number

• Pre-gap
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• Start and end time

• Length

• Gain

• Comment

You can also mute and lock clips, search for clip names, and play back a clip with 
or without pre-gap. The playback buttons work in the following way:

From Start with Pre-Roll ( )

Playback from start with a pre-roll.

You can also press [Alt]/[Option] and click  to play back from the start with 
a short pre-roll.

From Start ( )

Playback from start.

The FX icon indicates that a clip contains one or more plug-ins. Double-clicking the 
FX icon opens the Effects window.

• To zoom in on the clip, click the name of the clip.

• To select the time range corresponding to the clip, [Alt]/[Option]-click the 
number to the left of the clip name.

• To zoom in and select the time range at the same time, double-click the 
number to the left of the clip name.

Select Menu

Select All Clips

Selects all clips in the audio montage.

Select Clips on Selected Track

Selects all clips that are included in the selected track.

Select Clips Inside Selected Time Range

Selects all clips that are fully encompassed in the selected time range on all 
tracks.

Select Clips Located Before the Cursor (on Selected Track)

Selects all clips that have their end point to the left of the cursor on the 
selected track.

Select Clips Located Before the Cursor (on All Tracks)

Selects all clips that have their end point to the left of the cursor on all tracks.

Select Clips Located After the Cursor (on Selected Track)

Selects all clips that start to the right of the cursor on the selected track.
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Select Clips Located After the Cursor (on All Tracks)

Selects all clips that start to the right of the cursor on all tracks.

Inverse Selection

Deselects all selected clips and selects all other clips.

Deselect All Clips

Deselects all selected clips.

Functions Menu

Create Super Clip from Selected Clips

Replaces the selected clips with a super clip that refers to a sub-montage.

Export Clip List as Text

Opens a plain text version of the clip list in the default text editor.

Batch Renaming

Opens the Batch Renaming dialog in which you can batch-rename any 
number of clips.

Use Audio File Name for Selected Audio Clips

Names each clip after the audio file to which it refers.

Update BWF Time Stamps (Selected Clips)

Updates the time stamp of each audio file that is referenced by a selected clip 
to reflect the clip position in the audio montage.

The file header of a WAV audio file may contain a time stamp in the Broadcast 
Wave Format. This time stamp makes it possible to insert audio at precise 
positions in different applications. The audio files are marked as modified and 
must be saved.

Move Selected Clips to Their Related BWF Time Stamp

Moves the selected clips to the positions that are contained in their source 
audio files, provided the audio files contain a time stamp.

Align Clips

Opens the Align Clips dialog which lets you align all selected clips on the 
selected track relatively to one another.

Resize Selected Clips to Match the Active Clip

Uses the length of the active clip as reference to change the length of all 
selected clips.

Mute/Unmute Selected Clips

Mutes/unmutes all selected clips.

Lock/Unlock Selected Clips

Locks the clip to avoid that it is accidentally edited.
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Lock/Unlock Moving and Resizing

Locks the position and size of a clip. Other editing options are still possible.

Show/Hide Clip Ruler and Markers of Source File

Changes the visibility of the ruler and the marker display of the source audio 
files for all selected clips.

Options Menu

Only Show Selected Clips

If this option is activated, only clips that are selected in the montage window 
are displayed. This is useful to display only the clips that belong to a specific 
group (Groups window) or to a specific audio file (File Browser window).

Show Audio Clips

If this option is activated, only audio clips are displayed.

Show Picture Clips

If this option is activated, only picture clips are displayed.

Show Global Pre-Gaps

Displays the length of the gap between the start of a clip and the end of the 
previous clip on any track in the Pre-Gap column. If the clips overlap, the 
length is displayed in red.

Show Pre-Gaps by Track

Displays the length of the gap between the start of a clip and the end of the 
previous clip on the same track. If the clips overlap, the length is displayed in 
red.

Zoom the Clip When Selected

If this option is activated when you select a clip in the list, the clip fills the track 
area in the most efficient way.

Make Clip Entirely Visible When Selected

If this option is activated when you select a clip in the list, the track area is 
scrolled and/or zoomed to display the whole clip.

Customize Command Bar

Opens the Customize Commands dialog which contains options to hide or 
show specific command bar buttons.

Filtering Clip Names

The search field in the Clips window allows you to filter the clips list.

You can perform a text search in the Name and Comment columns. To perform a 
text search in the Comment column, this column must be sorted. Otherwise, the 
name column is searched. The Select All function selects the filtered items.
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• To search for clips, click in the search field, and enter text.

• To switch the focus from the search field to the clips list, press the arrow 
down key.

• To switch the focus from the clips list to the search field, press 
[Ctrl]/[Command]-[F].

Align Clips Dialog

This dialog allows you to align clips at specific positions and add a space between 
them. You must select at least two clips to use this function.

• To open the Align Clips dialog, open the Clips window, and select Functions 
> Align Clips.

NOTE

Clips can be moved independently from the group to which it belongs.

Place Clips One after the Other (Use End Cue Points as Reference)

Positions the selected clips successively on the selected track. Each clip is 
aligned at the end cue point of the preceding clip.

Place Clips One after the Other with Gap

Positions the selected clips on the selected track. In the time field, specify the 
time between the end of a clip and the start of the next clip.

Place Clips One after the Other with Crossfade

Positions the selected clips on the selected track and creates crossfades 
between them. In the time field, specify the crossfade time.
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Place Every

Lets each clip start at the specified interval from the start of the preceding clip. 
In this case, the clips can overlap each other. In the time field, specify the 
interval between the start of a clip and the start of the next one.

Treat Overlapping Clips on a Track as One Unit

All overlapping or adjacent clips on a track are treated as one unit. This means 
that all clips are aligned with the same offset.

Treat Overlapping Clips as One Unit, Regardless of Their Tracks

All overlapping or adjacent clips on a track are treated as one unit, even if they 
are on different tracks. This means that all clips are aligned with the same 
offset.

Only Align Selected Clips

If this option is activated, only selected clips are moved. If a group of 
overlapping clips contains a clip that is not selected, the group is not moved.

Only Align Clips of Selected Track

If this option is activated, only clips of the selected track are moved. For 
example, if a group of overlapping clips contains a clip that is not part of the 
selected track, the group is not moved.

Reordering Clips in Audio Montages By Dragging

In the Clips window, you can re-order clips by dragging them to another position in 
the list.

PROCEDURE

1. Open the Clips window.

2. In the clip list, drag a clip to another position in the list.
The option Move Overlapping Clips Together is taken into account.

You can move more than one clip at the same time, by selecting multiple clips and 
dragging them. If more than one clip is selected, all clips between the leftmost 
selected clip and the rightmost selected clips are moved.

RELATED LINKS

Clips Window on page 287

Exporting the Clip List as Text

You can export clip list information like names, source files, tracks, and clip length.

PROCEDURE

1. Open the Clips window.

2. In the Clips window, select Functions > Export Clip List as Text.
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3. Activate the option for the information that you want to export.

4. Select the output format from the pop-up menu.

5. Click OK.

RESULT 

The clip list opens in the selected output format. If you select Print, the Print 
Preview window opens. The text file is saved in the folder for temporary files.

RELATED LINKS

Temporary Files on page 103

Export Clip List as Text Dialog

This dialog allows you to export the clip list in various file formats, or to print it out. 
You can select what clip information is included in the exported file.

• To open the Export Clip List as Text dialog, open the Clips window, and 
select Functions > Export Clip List as Text.

Moving and Crossfading Clips

You can let clips overlap other clips, move them, and create crossfades between 
clips.
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Moving Clips

NOTE

The channel configuration of the clip must match the destination track.

PROCEDURE

1. In the montage window, select the clips that you want to move.

2. Click the lower clip area, and drag the clips in any direction.
While dragging, the info line displays the current start position of the clip.

Moving Clips with Auto Grouping

The options for auto grouping allow you to specify how clips are moved. The options 
can be selected in the Audio Montage window, on the Edit tab, in the Auto 
Grouping section.

RELATED LINKS

Options for Moving and Crossfading Clips on page 295

Optimized Crossfades When Snapping to Other Clips

If you line up clips so that one clip ends exactly where the next one starts, for 
example, by using the Magnets option, the waveforms at the intersection point 
probably do not match. To avoid sudden level changes, that may result in pops and 
clicks, you can optimize the crossfade when snapping to other clips.

On the Edit tab, in the Snapping section, open the Crossfading pop-up menu, and 
activate Snap to Waveform When Crossfading. When this option is activated and 
you move a clip so that its start snaps to the end of another clip, the following 
happens:

• WaveLab Pro scans the waveforms of the clips within a short range to find the 
position where the waveforms of the two clips match best. This is the same 
automatic phase matching as in the Wave Matching window. You can specify 
how far you want the program to scan into the clips, by selecting a search 
range on the menu of the Wave Matching window.

• The position of the clip that you moved is adjusted slightly to achieve the best 
possible match between the waveforms. This creates a short crossfade.

NOTE

This function only applies when moving from right to left, for example, when you let 
the start of the moved clip snap to the end of the clip on the left.

RELATED LINKS

Magnetic Bounds in Audio Montages on page 283
Wave Matching Window on page 338
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Overlapping Clips

You can move clips so that they overlap each other.

Note the following:

• The tracks in the audio montage are polyphonic, which means that each track 
can play back several overlapping clips at the same time. Overlapping clips 
are transparent, allowing you to see the underlying clips and their waveforms.

• To select an overlapped clip, click the bottom clip area of the crossfade area.

• There are crossfading options that automatically adjust the level envelope 
curves when you overlap clips.

Options for Moving and Crossfading Clips

There are several options that help you when moving and crossfading clips. You can 
choose how you want clips to be handled when they are moved, decide whether 
automatic fades are created or not, and select the behavior of clips when they are 
moved.

Ripple

The ripple options are available in the Edit tab of the Audio Montage window.

Track

If this option is activated and you move a clip horizontally, all clips on the 
selected track that are located to the right of the edited clip are also moved. 
This option also applies when moving or resizing clips, and when inserting or 
pasting more than one clip at the same time.

Global

If this option is activated and you move a clip horizontally, all clips on all tracks 
that are located to the right of the edited clip are also moved. This option is 
taken into account when moving or resizing clips, and when inserting or 
pasting more than one clip at the same time.

Auto Grouping

The auto grouping options are available in the Edit tab of the Audio Montage 
window.

Track

If this option is activated and you move a clip horizontally, all overlapping or 
adjacent clips on the same track are also moved.

Global

If this option is activated and you move a clip horizontally, all vertically 
overlapping clips on all tracks are also moved.
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Crossfading

The following crossfading options are available in the Fade tab of the Audio 
Montage window in the Options section.

Overlaps

This pop-up menu allows you to set the automatic crossfading behavior.

• If No Automatic Crossfading is activated, no automatic crossfading is 
performed when clips overlap.

• If Free Overlaps is activated, automatic crossfades are created when a 
clip overlaps another clip on the same track. The length of the overlap 
determines the length of the crossfade.

• If Fade-In Constrains Overlaps is activated, the fade in length of a clip 
constrains the maximum possible overlap, and thus the crossfade time. 
If the clip on the right side, that is, the clip with the fade in in the overlap, 
is moved to the left past the set overlap time, the other clip is 
progressively resized. Moving the other clip to the right into the clip that 
contains the fade in in the overlap produces the same result.

• If Fade-Out Constrains Overlaps is activated, the fade out length of a 
clip constrains the maximum possible overlap, and thus the crossfade 
time. If the clip on the left side, that is, the clip with the fade out in the 
overlap, is moved to the right past the set overlap time, the other clip is 
progressively resized. Moving the other clip to the left into the clip that 
contains the fade out in the overlap produces the same result.

Automatic Crossfading

This pop-up menu allows you to make automatic crossfading settings.

• If Allow Automatic Crossfading with Clips on Selected Track is 
activated, crossfades are automatically created when you move a clip so 
that it overlaps another clip that is located on the selected track.

• If Allow Multiple Automatic Crossfades is activated, crossfades are 
automatically created for all moved clips that overlap other clips on their 
track. If this option is deactivated, a crossfade is only created for the clip 
that you drag, even if several clips are moved simultaneously.

Options

• If Create Default Fades in New Clips is activated, all new clips get the 
default fade in and fade out shape and length. For clips that are created 
by splitting a clip, only the default fade time is used.

• If Lock Fade Times When Adjusting Clip Edges is activated, the 
defined fade in and fade out lengths are locked to the clip start or end, 
even if you adjust the clip edges. This means that if you resize a clip by 
dragging its edge, the corresponding fade junction point moves 
accordingly, while maintaining the fade length.

The following crossfading options are available in the Edit tab of the Audio 
Montage window, in the Snapping section.
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Crossfading

This pop-up menu allows you to make snapping settings for crossfades.

• If Snap to Waveform When Crossfading is activated and you create a 
crossfade by dragging a clip towards another one located on its left 
side, the position of the moved clip is automatically adjusted to obtain a 
good correspondence between the clip waveforms. This correlation 
process provides a crossfade that is aligned in phase.

• If Create Crossfade and Snap to Waveform When Snapping to Left 
Clip is activated and you move a clip to let its start snap to the end of 
another clip on its left, the clip is slightly moved to the left to create a 
short crossfade that is based on an optimal correlation between the two 
waveforms. This correlation process provides a crossfade that is 
aligned in phase.

• If Create Crossfade When Snapping to Left Clip is activated and you 
move a clip to let its start snap to the end of another clip on its left, the 
clip is slightly moved to the left to create a crossfade.
The length of the crossfade is the fade in length of the clip on the right. 
If the fade in length is zero, the fade out length of the left clip is used as 
a basis instead. If that length is also zero, the Create Crossfade and 
Snap to Waveform When Snapping to left clip function is performed if 
activated.

Creating Clips from Selection Ranges

You can create clips from a selection range. If no clip is overlapping the selection, 
an empty clip is created.

PROCEDURE

1. In the montage window, select a clip.

2. Select a range in the clip.

3. Select the Edit tab.

4. In the Clip section, click Create from Selection.
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Duplicating Clips

NOTE

The channel configuration of the clip must match the destination track.

PROCEDURE

1. In the montage window, select one or more clips.

2. Click the upper clip area and drag the clips in any direction.
While you are dragging, a dotted line indicates where the first of the copied clips will 
be placed. The position is also indicated on the info line.

If you dragged a single clip, a pop-up menu opens. Select the option that you want 
to apply to the duplicate of the clip. The ripple and auto grouping settings are taken 
into account.

Duplicating with Ripple and Auto Grouping

If you duplicate more than one clip, the auto grouping and ripple settings affect the 
result.

The following options are available on the Edit tab, in the Ripple section:

• If Track is activated and you move a clip horizontally, all clips on the selected 
track that are located to the right of the edited clip are also moved.

• If Group is activated and you move a clip a clip horizontally, all clips on all 
tracks that are located to the right of the edited clip are also moved.

The following options are available on the Edit tab, in the Auto Grouping section:

• If Track is activated and you move a clip horizontally, all overlapping or 
adjacent clips on the same track are also moved.

• If Group is activated and you move a clip horizontally, all vertically overlapping 
clips on all tracks are moved.

Repeating Clips

You can make a number of copies of a clip and position them at various intervals on 
the current track of your audio montage.

NOTE

Repeating clips does not create overlapping clips.

PROCEDURE

1. In the montage window, select the clip that you want to repeat.

2. Optional: Place the edit cursor.
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3. Select the Edit tab.

4. In the Clip section, click Repeat Clip.

5. In the Repeat Clip dialog, select one of the following options:
• Select Count, and specify the number of copies.

• Select Repeat Until Cursor.

6. Select one of the Placement options.

7. Click OK.

RESULT 

The clips are repeated. If you chose Repeat Until Cursor, the last clip starts to the 
left of the audio montage cursor.

Repeat Clip Dialog

This dialog allows you to specify the number of clones to produce and control their 
placement, alignment, and spacing.

• To open the Repeat Clip dialog, select the Edit tab in the Audio Montage 
window, and click Repeat Clip in the Clip section.

Number of Clones

Count creates the specified number of clones.

Repeat until Cursor creates clones up to the edit cursor.
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Placement

Place Clips One after the Other places the clips one after the other on the 
track.

Use End Cue Points as Reference places the selected clips one after the 
other on the focused track. Each clip is aligned with the end cue point of the 
preceding clip.

Gap between Clips sets the gap duration between clips.

Place Every places the copied clips in the time interval that you set in the field 
below. This is the interval between two succeeding clip starts.

Align with Clips of Selected Track aligns the copied clips with the starting 
position of the clips on the selected track, including any offset value that you 
can set in the Offset field.

Insert Copies at Markers aligns the copied clips with specific markers. 
Specify these markers on the menus below.

Creating New Clips by Dragging Selections

You can drag selection ranges to create a new clip.

PROCEDURE

1. In the montage window, select a range.
If the selection range covers more than one clip, only the section that is part of the 
active clip is copied.

2. Click the upper clip area and drag the selection to the new position.
When you are dragging, the position of the pointer is displayed on the info line. The 
magnets settings are taken into account.

3. Select one of the insert options.

NOTE

Envelopes and effects are not included when you copy selection ranges.

Clip Resizing

In this context, resizing usually means moving the start and end points of a clip. This 
reveals more or less of the original audio file. You can keep the audio source static 
relative to the time line of the audio montage, or relative to the resized edge of the 
clip.

Resize Clips With a Static Audio Source

To resize clips, click the left or right edge of the clip and move the start or end point 
to the left or to the right.
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The start and end positions and the length of the clip are displayed on the info line 
while you are dragging. You cannot drag the edge of a clip past the start or end 
point of the audio file to which it refers.

When you drag the right edge of a clip, the Ripple settings are taken into account. 
If Track is activated, all the following clips on the track are moved when you resize 
the clip. If Global is activated, all clips on all tracks in the audio montage are moved.

If you press [Alt]/[Option], all selected clips are resized by the same value.

Resize Clips With Tied Audio Sources

You can resize a clip while having the audio source tied to the edge that you are 
moving. You [Ctrl]/[Command]-click the left or right edge of the clip and move the 
start or end point to the left or to the right.

The start and end positions and the length of the clip are displayed on the info line 
while you are dragging. Magnetic bounds and the auto grouping options apply.

If you press [Alt]/[Option]-[Ctrl]/[Command] when resizing, all selected clips are 
resized by the same value.

RELATED LINKS

Options for Moving and Crossfading Clips on page 295

Resizing Clips by Cropping

You can crop clips to remove material at the beginning and end of a clip.

PROCEDURE

1. In the montage window, select a clip range.

2. Select the Edit tab.

3. In the Removal section, click Crop Clip.

RESULT 

The clip is resized so that is contains only the selected audio.
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Sliding Audio in Clips

You slide the audio in a clip. This moves the section of the audio source that the clip 
refers to.

PROCEDURE

1. In the montage window, position the mouse cursor over the lower area of the 
clip.

2. Press [Ctrl]/[Command]-[Alt]/[Option], and drag left or right to slide the audio 
source.

Moving Clips With Fixed Audio Sources

You can move the clip while the audio source remains fixed in position.

PROCEDURE

1. In the montage window, position the mouse cursor over the lower area of the 
clip.

2. Press [Shift]-[Alt]/[Option], and drag left or right to move the clip.

This reveals other sections of the underlying audio source.
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Splitting Clips

PREREQUISITE 

Decide whether you want to automatically create crossfades between the left and 
right clip. To activate/deactivate this option, select the Fade tab, click Options in 
the Options section, and activate/deactivate Create Default Fades in New Clips.

PROCEDURE

1. In the montage window, click the position where you want to split the clip.

2. Position the mouse cursor on the edit cursor position in the top clip area.
The cursor becomes a pair of scissors.

3. Double-click.

RESULT 

The clip is split in two. The two clips have the same name and settings. Envelopes 
and fades are converted so that the two clips play back as if they were still one clip.

To split clips on all tracks, select the Edit tab, right-click Split Clip in the Split 
section, and select Split Clips on All Tracks.

Erase Selections of Clips

You can erase a selection range within a clip.

Erasing Parts of Clips Inside Selection Ranges

Erasing the part of a clip inside a selection range results in a gap between the two 
resulting clips.

PROCEDURE

1. In the montage window, select a range in a clip.

2. Select the Edit tab.

3. In the Removal section, click Erase Selected Range.
If Snap to Waveform when Crossfading or Create Crossfade when Snapping to 
Left Clip are activated, the position of the right clip is adjusted for the best possible 
phase match between the clips.

The auto grouping settings are taken into account.

RELATED LINKS

Snapping on page 243
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Deleting Parts of Clips Inside Selection Ranges and Patching Up

Deleting the part of a clip inside a selection range removes the selected range 
moves the right section of the clip to the left to fill the gap.

PROCEDURE

1. In the montage window, select a range in a clip.

2. Select the Edit tab.

3. In the Removal section, click Delete Selected Range.
If any of the automatic crossfading modes or the option Create Default Fades in 
New Clips are activated, a default crossfade is created between the resulting two 
clips. This creates a clean transition.

Deleting Clips

• Right-click a clip and select Delete.

• Select a clip and press [Delete]. To ensure that there is no selection range, 
press [ESC].

Locking Clips

You can lock clips to prevent them from being accidentally moved, edited, or 
deleted.

PROCEDURE

1. In the montage window, select a clip.

2. Do one of the following:
• Select the Edit tab, open the Lock pop-up menu in the Clip section, and 

activate Full Lock or Time Lock.

• In the Clips window, select Functions, and activate Lock/Unlock Selected 
Clips or Lock/Unlock Moving and Resizing.

RESULT 

A lock symbol indicates that a clip is locked.

Unlocking Clips

Use one of the following methods to unlock a clip:
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• Click in the lower area of the locked clip, and click Yes in the message.

• Select the Edit tab, open the Lock pop-up menu in the Clip section, and 
deactivate Full Lock or Time Lock.

Clips and Cue Points

A cue point is a defined position marker that belongs to a clip. It may be positioned 
inside or outside the clip. Cue points are displayed as dotted vertical lines.

When you move a clip, its cue point is magnetic to any edges, markers, or positions 
that are activated on the Magnets menu. Magnetic cue points allow for easy 
selection. There are several uses for this:

• Set the cue point at a relevant position in the audio to align the clip with other 
clips, etc.

• Set the cue point before the start of a clip to position clips in a row with 
pre-defined spaces.

• Set the cue point at the fade in or fade out point of a clip to maintain defined 
fade lengths when crossfading.

NOTE

Each clip can only have one cue point. If you select another cue point insert option, 
the cue point is moved to a new position.

Adding Cue Points

You can add one cue point for each clip.

PROCEDURE

1. In the audio montage, click the clip position where you want to set a cue point.

2. Select the Edit tab.

3. In the Clip section, open the Cue Point pop-up menu.

4. Select one of the following options:
• Set at Cursor

• Set at Default Gap Position

• Follows Fade In End Point
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• Follows Fade Out Start Point

5. Optional: Select Custom Cue End and specify a custom cue end point.

About Nudging

Nudging in the montage window allows you to make fine adjustments. You can 
nudge clips, objects, and properties.

Each time that you use the nudge function, the selected element is nudged by a 
specific amount. By holding down user-specified modifier keys, you can nudge the 
element by smaller or larger amounts.

Magnetic bounds are not taken into account. Nudged elements do not snap to 
positions but can be moved freely.

Nudging

PROCEDURE

1. In the montage window, select the objects that you want to nudge.

2. Select the Edit tab.

3. In the Nudge section, click Target.

4. In the Target pop-up menu, activate the elements that you want to nudge or 
activate Auto Select Item.

5. Click Nudge - or Nudge + in the Nudge section or use the nudge icons on 
the transport bar.
By holding down the user specified modifier keys, you can nudge the element by 
smaller or larger amounts.

Setting the Default Nudge Impulse

You can set the nudge value that is used to adjust the elements. The large, small, 
and micro impulses are relative to the default value.

PROCEDURE

1. Select File > Preferences > Audio Montages.

2. Select the All Audio Montages tab.

3. In the Basic Amplitudes for Nudging section, specify a default time for the 
nudge impulse in the Time field.

4. In the Gain field, specify the default impulse gain for the nudging volume.
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Elements That Can Be Nudged

The Target pop-up menu lists the elements and properties that can be nudged.

• To open the Target pop-up menus, select the Edit tab in the Audio Montage 
window, and right-click Target in the Nudge section.

Auto Select Item

Attempts to automatically select what should be nudged, depending on your 
last action. For example, if your last action was to select or move a clip, the 
Clip Position option is automatically selected in the Target menu. In most 
cases, this allows you to use the nudge feature without having to manually 
select nudge elements on the submenu.

Clip Position

Moves all selected clips.

Clip’s Left/Right Edge

Resizes the active clip. This function is similar to resizing with a static audio 
source.

Clip’s Fade In/Fade Out

Moves the fade in/fade out junction points of the active clip. If the envelope is 
a stereo envelope, both sides are adjusted.

Clip’s Crossfade

Narrows or widens the crossfade zone by moving the junction points of both 
clips in the crossfade. This nudging only functions if you select the second 
clip (the one to the right) in a crossfade pair.

Edit Cursor

Moves the edit cursor.

Left Edge of Selected Time Range

Moves the left edge of a selection range.

Right Edge of Selected Time Range

Moves the right edge of a selection range.

Selected Marker

Moves the selected audio montage marker. To select a marker, click it in the 
area above the ruler.

Volume of Active Clip

Adjusts the volume of the active clip step by step according to the Gain 
setting in the Audio Montages Preferences.

Volume of All Selected Clips

Adjusts the volume of all selected clips step by step according to the Gain 
setting in the Audio Montages Preferences.
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Pan of Active Clip

Adjusts the pan of the active clip. Nudge + pans to the left and Nudge - to 
the right.

Pan of All Selected Clips

Adjusts the pan of all selected clips. Nudge + pans to the left and Nudge - 
to the right.

Surround Pan of Active Clip

Adjusts the pan of the active clip. Nudge + pans to the left and Nudge - to 
the right.

Surround Pan of All Selected Clips

Adjusts the pan of all selected clips. Nudge + pans to the left and Nudge - 
to the right.

Displaying Clips in Mid and Side View

• To activate the mid/side view, right-click the upper area of a clip, and select 
Show/Hide Mid/Side Channels.

NOTE

This does not affect playback and plug-in processing.

Audio Montages within Audio Montages

You can insert external audio montages in an audio montage or gather several clips 
of an audio montage to an internal sub-montage. This makes it easy to build large 
audio montages while hiding edit complexities inside other audio montages.

This also increases the performance of your system as it provides options to freeze 
edits and audio effects in cached audio files.

RELATED LINKS

Super Clips on page 308

Super Clips

A super clip is the representation of an audio montage within an audio montage. It 
refers to an audio file that is rendered from either an internal sub-montage or an 
external sub-montage.

A super clip behaves like any other clip. To edit the tracks and clips in a super clip, 
you can reopen it and then render the changes to update the super clip.

A super clip can either be a mono or a stereo audio montage.
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An example: You have an album that is composed of 15 songs. Each song requires 
complex edits. In this case you can create 15 super clips, of which each one 
represents a song. The main audio montage will be composed of these super clips, 
while each song can have its own audio montage.

Moreover, because super clips can represent external audio montages with 
different sample rates, you could provide your songs in high-resolution audio (96k 
sample rate), and build an audio montage album in 44.1k for a CD and another 
album at 96k for a DVD-Audio, for example.

External Sub-Montages

A super clip can refer to an external sub-montage which is an audio montage in 
another file. An external sub-montage is independent from the audio montage in 
which you insert it.

External sub-montages can be shared between projects and used in audio 
montages with a different sample rate. They can be nested to any depth.

External sub-montage files can contain other external audio montages to any depth.

Super clips that refer to external sub-montages are indicated by an external 
sub-montage icon.

A super clip that refers to an external sub-montage is also called X-Clip.

NOTE

An external sub-montage is a normal audio montage. The term “external” is to point 
out its inclusion in another audio montage.

Internal Sub-Montages

A super clip can refer to an internal sub-montage, which is an audio montage that 
is saved in the same file as the audio montage of the super clip. Such a super clip 
can be regarded as a folder that contains another audio montage.

Internal sub-montages are handled within a single audio montage file. For example, 
when you have finished editing specific clips of your audio montage, you can render 
them as a super clip.

An internal sub-montage cannot contain another internal sub-montage. However, it 
can contain super clips that represent external audio montages.

Super clips that are internal sub-montages are indicated by an internal 
sub-montage icon.

A super clip that refers to an internal sub-montage is also called I-Clip.
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Creating a Super Clip

You can render clips of an audio montage to a super clip. This super clip can be 
part of an internal sub-montage or an external audio montage.

PROCEDURE

1. Open the audio montage in which you want to create a super clip.

2. In the montage window or in the Clips window, select the clips that you want 
to render to a super clip.

3. Select one of the following options:
• Right-click in the upper half of one of the selected clips, and select Create 

Super Clip from Selected Clips.

• In the Clips window, select Functions > Create Super Clip from Selected 
Clips.

4. In the Create Super Clip dialog, decide whether to create an I-Clip (internal 
sub-montage) or an X-Clip (external sub-montage).

5. Optional: Enter a name for the super clip.

6. Click OK.

RESULT 

The clips are rendered as a super clip inside the audio montage.

Create Super Clip Dialog When Creating Super Clips from Selected Clips

In this dialog, you specify how to create super clips for internal and external 
sub-montages.

• To open the Create Super Clip dialog, right-click the upper half of one or 
several selected clips, and select Create Super Clip from Selected Clips.
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Name

Allows you to specify a name for the super clip. For X-Clips, the name is also 
used for the audio montage.

Create I-Clip (Internal Sub-Montage)

Creates a new audio montage inside the open audio montage and inserts a 
super clip to reference it.

Place I-Clip pop-up menu

If you create a sub-montage from clips that reside on different tracks, the 
pop-up menu allows you to specify on which track the super clip is inserted.

Export as External Audio Montage and Create X-Clip (External Sub-Montage)

Creates an independent audio montage and a super clip that refers to this 
audio montage.

Destination

Lets you select the destination folder of the external sub-montage.

Include Track Effects

If this option is activated, the track effects are included in the sub-montage. If 
you want to keep the super clip on the track, deactivate this option.

NOTE

Output effects are not included to prevent double processing.

Create Super Clip Dialog When Inserting External Audio Montages

In this dialog, you can select whether to create X-Clips or I-Clips when inserting an 
external audio montage in another audio montage.
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Create X-Clip (External Sub-Montage)

The super clip refers to the audio montage file.

Make a Deep Copy and Create I-Clip (Internal Sub-Montage)

The audio montage is copied into the other audio montage. The super clip 
refers to this independent copy.

Inserting External Sub-Montages into Audio Montages

You can insert an external sub-montage as a super clip into another audio montage.

PROCEDURE

1. Open the audio montage in which you want to insert another audio montage.

2. Do one of the following:
• Right-click an empty area of the montage window, select Insert Audio 

Montages > Browse, select the audio montages that you want to insert, and 
click Open.

• Drag the audio montage that you want to insert from the File Explorer/Mac OS 
Finder or from inside WaveLab Pro and drop it in the montage window.

3. In the Create Super Clip dialog, select whether to create an X-Clip or an 
I-Clip, and click OK.

4. From the pop-up menu, select how to add and mix the external sub-montage.

RESULT 

The external sub-montage is rendered, and the resulting super clip is inserted at the 
edit cursor position.
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Editing Super Clips

You can reopen the sources of super clips, edit the clips that they contain, and 
apply the changes to update the super clips of the external or internal audio 
montages.

The changes in the internal or external audio montage are applied to the parent 
audio montage when the sub-montages are rendered.

Editing External Sub-Montages of Super Clips

PROCEDURE

1. In the montage window, right-click the bottom area of a super clip of an 
external sub-montage and select Edit Source, or double-click at the top area 
of the super clip.
The external sub-montage opens in another tab.

2. Edit the external sub-montage, and save the changes.

3. Decide on how you want to update the audio montage.
• To apply the changes to all audio montages that refer to the updated audio 

montage, select File > Export, and select Render > Render Super Clip.

• To apply the changes to a single audio montage, go back to the audio montage 
that contains the external sub-montage that you have updated. Select the 
updated audio montage, open the Files window, and select Menu > Update 
Rendering of Selected Audio Montage.

4. Save the audio montage.

Editing Internal Sub-Montages of Super Clips

PROCEDURE

1. In the montage window, right-click the bottom area of a super clip of an 
internal sub-montage and select Edit Source, or double-click the top area of 
the super clip.
The internal sub-montage opens in another tab.

2. Edit the clips of the internal sub-montage, and save the changes.

RESULT 

The changes are automatically rendered to update the super clip.

Freezing External Sub-Montages

Freezing external sub-montages renders the external sub-montage to an audio file 
while converting the super clips into regular clips.



Audio Montage
Managing Source Files of Clips

314

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

Once a sub-montage has been frozen, it is no longer possible to edit it as an audio 
montage.

PROCEDURE

1. In the montage window, select the external sub-montage that you want to 
freeze.

2. In the Files window, select Menu > Freeze External Sub-Montage.

3. Specify a name and a location, and click Save.

Managing Source Files of Clips

The Files window helps you to manage files that are used in the current audio 
montage.

It displays all files that are used by clips in the current audio montage along with 
their location, size, and last modification date. In addition, the following file 
operations are available:

• Replace files in the audio montage

• Rename files (all internal clip references are updated)

• Open files that are used in the audio montage in the Audio Editor

• Export file names as text

Files Window

This window helps you to manage files that are used in the current audio montage, 
including internal and external montages.

• To open the Files window, open an audio montage, and select Tool Windows 
> Files.
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Files List

The files list shows the names, dates, sizes, and paths of the files that are used in 
the current audio montage. The Clips column shows how often a clip uses the 
corresponding audio file. The location and type of the files determine how paths are 
displayed:

• If the path is relative to the file audio montage location, the path is displayed 
in green.

• If the path is on the same partition as the audio montage, for example in a 
subfolder, the path is displayed in blue.

• If the path is on another partition, the path is displayed in red.

• Internal sub-montages have no path.

Menu

Update Rendering of Selected Audio Montage

Renders the focused audio montage to a new audio file. This is necessary to 
forward the changes that you have made in the selected sub-montage to the 
open audio montage.

Update Outdated Renderings

Renders all audio montages that have been modified since their rendered 
audio file was created.

Replace With

Allows you to replace the selected file with another one.

Freeze External Sub-Montage

Renders the external sub-montage to an audio file while converting the super 
clips into regular clips.

Rename File

Lets you change the file name. The internal references of the audio montage 
are updated accordingly.

Export File Names as Text

Creates a text file that lists all files that are used in the active audio montage.

Select Clips of Selected File

Selects all clips that refer to the selected file.

Edit Source

Opens the selected files in the Audio Editor. If the selected files are 
sub-montages, the related audio montage opens in the Audio Montage 
window.

Reveal in File Explorer

Opens the File Explorer/Mac OS Finder to locate the selected file.
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Customize Command Bar

Opens the Customize Commands dialog which contains options to hide or 
show specific command bar buttons.

Replacing Source Files of Clips

You can replace a source file of a clip with another file and have all clips that refer 
to the old source file refer to the new source file.

PROCEDURE

1. Open an audio montage.

2. Select Tool Windows > Files.

3. In the Files window, select the file that you want to exchange.

4. Select Menu > Replace With.

5. Select the replacing file.

Changing Names and File Locations of Audio Files

You can change the name and location of an audio file in your audio montage 
project. All clips that reference this file are automatically updated.

PROCEDURE

1. Open an audio montage.

2. Select Tool Windows > Files.

3. In the Files window, select the file that you want to rename.

4. Select Menu > Rename File.

5. In the Rename File dialog, enter a new name.

6. To enter a new file location, activate Change Folder, and enter a new file 
location.

7. Optional: If you want the related clips to change their name according to the 
new file name, activate Rename Related Clips as File Name.

8. Click OK.
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Exporting File Names as Text

You can export the file names list as text to various formats. The list contains the 
names and paths of the audio files in the active audio montage.

PREREQUISITE 

Set up your audio montage.

PROCEDURE

1. Open an audio montage.

2. Select Tool Windows > Files.

3. In the Files window, select Menu > Export File Names as Text.

4. Choose the information that you want to export and the output format.

5. Click OK.

RESULT 

The file names list opens in the selected output format. When selecting Print, the 
Print Preview window opens. The text file is saved in the specified folder for 
temporary files.

Editing Source Files of Clips

Editing the audio montage may require that you process or edit the actual audio files 
that are referenced by the clips.

Use one of the following methods to edit the source file of a clip:

• Right-click the bottom area of the clip that you want to edit, and select Edit 
Source, or double-click the top area of the clip. The source file of the clip 
opens in the Audio Editor. Edit the clip, save it, and return to the audio 
montage.

• Drag the clip and drop it in the Audio Editor.

Note the following:

• Any editing that you perform this way affects the source audio file and thereby 
all clips that use the audio file, including clips in other audio montages.

• You can undo/redo all changes in audio files. These changes are reflected 
immediately in all open audio montages.

• If you use File > Save As to save the source audio file with a different name, 
all open audio montages that refer to the file now refer to the new file.
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Cloning and Substituting Source Files of Clips

Cloning an audio source file avoids the risk that other clips are affected when the 
source file of a clip is edited.

Use the Clone and Substitute function to create a copy of the audio source file, 
and make the clip reference to the new file. As a result, you can edit the source file 
without affecting other clips or the original audio file.

The cloned audio file has the original file name with the suffix _#X, where X is a 
number. The cloned audio file is saved in the implicit folder that is specified in the 
Audio Montages Preferences on the Active Audio Montage tab.

The implicit folder is used when WaveLab Pro needs to create new files that can be 
referenced by an audio montage. Files that are saved in the implicit folder are not 
temporary, that is, they are not deleted when you close WaveLab Pro. This is 
necessary because the audio montage contains references to the files.

Cloning and Substituting Source Files of Clips

PROCEDURE

• In the montage window, right-click the bottom area of a clip, and select Clone 
and Substitute.

RESULT 

A clone of the source file replaces the selected clip. All clips that are referring to the 
original file are referenced to the new file.

Replacing Audio Files of Clips

You can replace the audio file of a clip to compare different takes.

NOTE

You cannot replace a stereo file with a mono file and vice versa.

PROCEDURE

1. In the montage window, right-click the bottom area of a clip, and select 
Replace Audio File.

2. Select the file to which you want to reference, and click Open.

RESULT 

The selected audio file replaces the clip. All clip settings are retained. Clip 
references to the replaced file are still available.
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Track Activity Indicator

The track activity indicator shows the volume level for audio tracks. It is located on 
the right side of the track control area in the Audio Montage window.

The track activity indicator provides an overview of which tracks are playing back 
audio at what approximate level.

Envelopes for Clips

For clips in the audio montage, you can create envelopes for level and fades, for 
panning, and for effects that are routed to a clip.

You can create an independent level envelope curve to automate level, to create 
fades and crossfades, and to mute clip sections.

You can also draw pan envelopes to automate pan settings for clips. For mono clips, 
pan governs the left/right position in the stereo field. For stereo clips, pan sets the 
left/right balance.

Edit the envelope settings in the Envelope tab, or by right-clicking an envelope 
curve. The settings menu is different, depending on whether you click the fade in 
part, the fade out part, or the sustain part.

RELATED LINKS

Routing a Plug-in to a Clip on page 351

How Envelopes are Displayed

By default, all clips display a level envelope curve. You can view the envelope as 
three separate envelopes: the fade in part, the sustain part, and the fade out part.

The points on the left and right side of the curve are the fade in and fade out junction 
points that separate the fade parts from the sustain part.
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The envelope curve indicates if points, fade ins, or fade outs have been defined. In 
addition to the curve, changes in the level envelope are also reflected in the 
waveform.

You can activate/deactivate the Map Waveform to Level option in the Peaks 
section of the View tab.

Selecting Envelopes

You can select volume/fade envelopes and pan envelopes.

PROCEDURE

1. In the montage window, select a clip.

2. Select the Envelope tab.

3. In the Selector section, open the Envelope Type pop-up menu, and select 
which envelope to edit.

Hiding Envelope Curves

All clips display envelopes by default. You can hide these envelopes. However, 
hidden envelopes are still active.

PROCEDURE

1. In the montage window, select a clip.

2. Select the Envelope tab.

3. In the Selector section, open the Envelope Type pop-up menu, and select 
Hide All.

Clip Envelope Editing

Curve points allow you to create volume curves, pan curves, and fade curves for a 
clip. You can edit the envelope curve by adding and moving curve points.

Editing Curve Points

Many of the editing operations that are commonly used in the context of your 
computer operating system can be applied when editing curve points. On top of 
these, a number of specific procedures apply.

• To add a curve point, double-click the envelope curve.

• To delete a curve point, double-click the curve point. The curve point between 
the sustain and fade parts of the envelope cannot be deleted.
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• To delete multiple curve points, select the curve points that you want to 
delete, right-click one of the points, and select Delete Selected Points.

• To select a range of points, [Alt]/[Option]-click and drag to create a selection 
rectangle.

• To move all selected points, click one of the selected points and drag.

• To raise or lower the value of two consecutive curve points, 
[Ctrl]/[Command]-click the segment between the points and drag up or 
down.

• To change the time position of two consecutive curve points, [Shift]-click the 
segment between the points and drag left or right.

• To raise or lower the entire envelope curve, make sure that no curve point is 
selected, click the envelope curve, and drag up or down. Do not drag a 
segment that is limited by selected points.

• To adjust the envelopes in all selected clips, hold down [Alt]/[Option], and 
drag any envelope curve up or down. This is a quick way to adjust the level or 
pan of multiple clips at the same time and also to adjust both sides of a stereo 
envelope simultaneously.

• To move a fade in/fade out point vertically, [Ctrl]/[Command]-click and drag 
the fade point.

• To change the level or the fade in/out time of multiple envelopes at the same 
time, select the clips that you want to edit, press [Alt]/[Option], and edit the 
envelope with the mouse.

Resetting Curve Points

You can reset curve points to the default level 0 dB.

• To reset a single point to 0 dB, select the point, right-click it, and select Reset 
Selected Points.

• To reset the whole envelope curve to default, right-click the envelope curve, 
and select Reset Level to 0 dB.

Copying Envelopes

You can copy envelope curves from other clips.

PROCEDURE

1. In the montage window, right-click an envelope curve, and select Copy 
Shape.

2. Right-click the envelope curve of the destination clip, and select Paste 
Shape.
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Raising Selection Levels

You can raise the audio level with specific fall and rise times (by default 20 ms) and 
then adjust the level.

PROCEDURE

1. In the montage window, in a clip, select the range for the section that you want 
to raise in level.

2. Right-click the envelope curve, and select Raise Level of Selection with 
Envelope.
The level of the selection range is raised.

3. Click the envelope of the selection range and drag up or down to adjust the 
level.

Muting Selected Ranges of Clips

You can mute a selected range by lowering the volume to -144 dB.

Muted sections are not affected when you drag the envelope curve up or down.

PROCEDURE

1. In the montage window, in a clip, make a selection range for the section that 
you want to mute.

2. Right-click the envelope curve, and select Mute selection with envelope.

RESULT 

The section is muted. A fade in and fade out of 20 ms is applied to the muted 
section.
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Envelope Smoothing

To produce smoother, more natural envelope curves, you can activate the 
Smoothing function.

• To activate this function, select the Envelope tab, and activate Smoothing in 
the Clip Options section.

Creating Envelope Presets

You can create envelope presets that you can later recall and apply to other clips. 
There are separate presets for the sustain parts (envelope presets) and the fade 
parts.

PROCEDURE

1. In the montage window, activate the clip with the envelope curve that you 
want to save as a preset.

2. Select the Envelope tab.

3. In the Preset section, open the Presets pop-up menu.

4. Select Save As.

5. In the Save Preset As dialog, enter a name for the preset, and click Save.

Applying Envelope Presets

PROCEDURE

1. In the montage window, activate the clip to which you want to apply the 
envelope preset.

2. Select the Envelope tab.

3. In the Preset section, open the Presets pop-up menu.

4. Select a preset from the list.

RESULT 

The envelope curve is applied.
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NOTE

Level envelope presets can only be applied to level envelopes. Other envelope 
presets such as pan and effect presets can be applied to any other non-level 
envelope, but not to level envelopes.

Locking an Envelope Curve

When an envelope curve is locked, the level envelope curve points are hidden and 
cannot be edited with the mouse. However, you can drag the whole curve up or 
down.

PROCEDURE

1. In the montage window, activate the clip that you want to lock.

2. Select the Envelope tab.

3. In the Clip Options section, activate Hide Curve Points.

Locking All Envelope Curves

If you lock all envelope curves globally, they cannot be edited with the mouse.

PROCEDURE

1. In the Audio Montage window, select the Envelope tab.

2. In the Selector section, activate Lock Mouse Editing.

RESULT 

The envelopes and their points are still displayed, but cannot be selected or edited.

Changing Overall Level Envelopes of Clips

The default envelope curve contains no level envelope points, but you can use it to 
change the overall level for a clip.

PROCEDURE

1. In the montage window, place the mouse cursor on the envelope curve.
The mouse cursor takes the shape of a circle with two arrows that point up and down.

2. Click and drag the curve up or down to change the clip envelope level.
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Converting Envelopes to Mono or Stereo

It is possible to display two level envelope curves for stereo clips, allowing you to 
control the level separately for the left and right channels.

NOTE

Only level envelopes can be converted to stereo.

PROCEDURE

1. In the montage window, select a clip.

2. Select the Envelope tab.

3. In the Shape section, click Convert.

4. Select Convert to Stereo or Convert to Mono.

Pan Modes

The power of the sum of the channels drops by about 3 dB if a signal is panned hard 
left or right, compared to the same signal being panned center. This can be 
compensated with pan modes.

Experiment with the modes to hear which fits best. The pan modes can be set for 
tracks, clips, and the montage output.

• To set the pan modes for clips, use the Pan Law pop-up menu in the 
Envelope tab, or use the Pan Law pop-up menu and knob in the Effects 
window.

• To set the pan modes for tracks and the montage output, use the Pan Law 
pop-up menu and knob in the Effects window.

The following pan modes are available:

Channel Damp (0 dB/Mute)

This mode does not compensate for power loss at all. If a signal is panned 
hard left or right, the power of the sum of the channels drops by 3 dB.

Constant Power (+3 dB/Mute)

This is the default mode. Regardless of the pan position, the power of the sum 
of the channels remains constant.

Channel Boost (+4.5 dB/Mute)

If this mode is selected and a signal is panned hard left or right, the power of 
the sum of the channels is higher than with a signal-panned center.
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Channel Boost (+6 dB/Mute)

If this mode is selected and a signal is panned hard left or right, the power of 
the sum of the channels is higher than with a signal-panned center. This is the 
same as the previous option, but with even greater power boost.

Modulating Audio With Other Audio

You can use the audio signal of one track to modulate the compression factor of 
another track. The signal of the upper audio track (clip) is usually called the carrier 
signal, because it contains the audio to be transmitted.

The Ducker clip plug-in is used for this purpose as it lowers the volume of one 
signal whenever another signal is present.

RELATED LINKS

Ducking Clips on page 326

Ducking Clips

Ducking happens when the level or send effect of one clip is modified through the 
presence of another signal on another track or channel. You can create ducking 
effects between clips on two adjacent tracks.

If you use the Ducking option, the presence of another clip on an adjacent track 
causes ducking.

A typical application for ducking would be a music track with a commentary 
voice-over on another track. Whenever the commentary voice starts, the level of the 
music track is lowered by a specific level through automatically created level 
envelope curves.

You can also create a ducking effect for effect envelopes that are routed to a clip. 
Each clip plug-in has its independent envelope. When the envelope is all the way 
down, only the wet signal is applied. When the envelope is all the way up, the 
processed/wet signal is at its maximum.
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NOTE

• The method of ducking clips is independent from clip modulation, though they 
share some concepts. Ducking clips is more flexible but needs more manual 
adjustments.

• The clips that cause ducking must be positioned completely inside the time 
range of the clip to which ducking is applied.

• If the clips that cause ducking contain silent passages, ducking does not 
function properly. These clips must be edited so that each phrase is a 
separate clip without any silence.

• When Ducking is performed it is applied to one clip at a time. For example, if 
the music consists of several clips that have been spliced together, only one 
of the clips is ducked by the voice-over. To solve this issue, you can to repeat 
the function for each clip or use the Render function in the Master Section 
to create a specific (single) file from the separate clips and re-import this as 
a new clip in the audio montage.

RELATED LINKS

Routing a Plug-in to a Clip on page 351

Creating Voice-Over Ducking Effects

In the following example, the track to which ducking is applied contains music and 
an adjacent track that causes ducking contains a voice-over.

PROCEDURE

1. In the montage window, place the clips that contain the music and the 
voice-over on separate adjacent tracks.
The voice-over clips must be located inside the time range of the music clip.

2. Select the clip containing the music.

3. Select the Envelope tab.

4. In the Selector section, open the Envelope Type pop-up menu, and select 
Volume/Fades.

5. In the Level section, click Ducking.
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6. In the Ducking Settings dialog, make your settings.
Depending on whether the voice-over track is above or below the music track, you 
must select Previous Track or Next Track.

7. Click OK.

RESULT 

The level of the music is automatically lowered by the voice-over clips.

RELATED LINKS

Routing a Plug-in to a Clip on page 351

Ducking Settings

In the Ducking Settings dialog, you can create ducking effects.

• To open the Ducking Settings dialog, select the Envelope tab in the Audio 
Montage window, and click Ducking in the Level section.

Fall Region

Balance Clip Fade In ignores any duration or gap settings in the Fall Region 
section. Instead, the ducking envelope lowers the volume from the fade in end 
position of the voice-over clip.

Duration allows you to set the time it takes for the level to fall when ducking 
starts.

Gap before Clip allows you to set the time between the end of the fall region 
and the start of the voice clip.

Rise Region

Balance Clip Fade Out ignores any duration or gap settings in the Rise 
Region section. Instead, the ducking envelope raises the volume from the 
fade out start position of the voice-over clip.

Duration allows you to set the time it takes for the level to rise to the original 
level after ducking ends.

Gap before Clip allows you to set the time between the end of the voice clip 
and the start of the Rise region.
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Modulator Clips

Previous Track and Next Track define whether the modulator track should 
be the one before (Previous Track) or after (Next Track) the track that is to 
be ducked.

If Only Selected Clips is activated, only the selected clips on the modulator 
track cause ducking.

Damp Factor

Sets the amount of ducking, that is, the degree of attenuation that is applied 
to the affected clip.

Fades and Crossfades in Audio Montages

A fade in is a gradual increase in level and a fade out is a gradual decrease in level. 
A crossfade is a gradual fade between two sounds, where one is faded in and the 
other faded out.

Creating Fades

By default, all clips display fade in and fade out junction points. These can be 
dragged horizontally to create a fade in or fade out for a clip.

You can add envelope points to a fade just as with level envelopes.

• To create a fade in, click the fade in point at the start of a clip, and drag it to 
the right.

• To create a fade out, click the fade out point at the end of a clip, and drag it 
to the left.

• To create a fade in or fade out at a specific time position, use set Apply Fade 
Time option in the Fade tab. Enter the time value in the time field and click 
Apply Fade Time.

• To move a fade in/fade out point vertically, press [Ctrl]/[Command] while 
dragging.

The resulting fade in/fade out curve is displayed in the clip, and the fade is also 
reflected in the waveform. If you position the mouse over the fade in point, the fade 
in time is displayed in seconds and milliseconds and the volume in dB.
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Fade In and Fade Out Menus

In this menu, you can select various preset fade curves and other fade-related 
options.

• To open the Fade In or Fade Out pop-up menu, right-click the fade in or fade 
out points.

Zoom to Fade In Range/Zoom to Fade Out Range

Adjusts the view to mainly display the fade in/fade out part of the active clip.

Copy

Copies the fade in/fade out shape to the clipboard.

Paste

Replaces the fade in/fade out shape and length with the shape and length that 
was copied to the clipboard.

Paste Shape Only

Replaces the fade in/fade out shape with the shape that was copied to the 
clipboard. The original length is preserved.

Paste to Selected Clips

Replaces the fade in/fade out shape of all selected clips with the shape that 
was copied to the clipboard. The original length is preserved.

Linear

Changes the level linearly.

Sinus (*)

Changes the level according to the first quarter period of the sine curve. 
When used in a crossfade, the loudness (RMS) remains constant during the 
transition.

Square-root (*)

Changes the level according to the square-root curve. When used in a 
crossfade, the loudness (RMS) remains constant during the transition.



Audio Montage
Fades and Crossfades in Audio Montages

331

Sinusoid

Changes the level according to a half period part of the sine curve.

Logarithmic

Changes the level logarithmically.

Exponential

Changes the level exponentially.

Exponential+

Changes the level strongly exponential.



Audio Montage
Fades and Crossfades in Audio Montages

332

Saving Fade Ins/Fade Outs as Default

The default fade in/fade out curve shape is linear. You can change this setting and 
define a default shape and/or length separately for fade ins and fade outs.

PROCEDURE

1. In the montage window, drag the fade in/fade out point to the position that you 
want to set as default.

2. Select the Fades tab.

3. In the Edit section, activate Fade In or Fade Out.

4. In the Preset section, open the Presets menu.

5. Depending on whether you want to save the current fade as default for fades 
and/or crossfades, select one of the following options:
• Save Current Fade as Default for Automatic Fade Ins/Fade Outs

• Save as Default for Automatic Crossfades

RESULT 

When you select a clip and click Apply Default in the Fade tab, the saved fade is 
applied. In addition, when you create a new clip and Create Default Fades in New 
Clips is activated, the default fade is used.

NOTE

The default fades are saved for each audio montage. If you want to use the same 
default fade for several audio montages, you should update the audio montage 
template file.

Applying Default Fade Ins/Fade Outs

PROCEDURE

1. In the montage window, select the clip for which you want to apply the default 
fade in/fade out.

2. Select the Fade tab.

3. In the Edit section, select Fade In or Fade Out.

4. In the Preset section, click Apply Default.

RESULT 

The fade in/fade out time is set to the defined default value.
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Applying Default Fades to New Clips

All new clips that are imported or recorded in the audio montage get the default fade 
in and fade out shape and length if Create Default Fades in New Clips is active. 
In this case, the default crossfade shapes are used. This also applies to clips that 
are created by splitting clips.

PROCEDURE

1. Open an audio montage and select the Fade tab.

2. In the Options section, open the Options pop-up menu.

3. Activate Create Default Fades in New Clips.

Locking Fade Times When Adjusting Clip Edges

PROCEDURE

1. Open an audio montage and select the Fade tab.

2. In the Options section, open the Options pop-up menu.

3. Activate Lock Fade Times When Adjusting Clip Edges.

RESULT 

The defined fade in/fade out length is locked to the clip start or end, even if you 
adjust the clip edges.

Copying Fades

You can copy a fade in or fade out and paste it in another clip.

PROCEDURE

1. In the montage window, right-click a fade in/fade out point, and select Copy.

2. Right-click the fade in/fade out point for which you want to apply the fade, and 
select Paste.

RESULT 

The fade is applied to the clip.
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Setting Fade/Level Envelopes After the Effects

When using dynamic processors that alter the level of the clip, it is useful to place 
the level/fade envelope after the clip effect section.

PROCEDURE

1. Open an audio montage and select the Envelope tab.

2. In the Selector section, make sure that Volume/Fades is selected.

3. In the Clip Options section, activate Envelope after Effects.

Deactivating Automatic Fade Changes for Individual Clips

You can deactivate automatic fade changes for individual clips. This can be used if 
you have set a fade that you do not want to be altered in any way, even though you 
may want to overlap the clip with another clip.

PROCEDURE

1. In the montage window, select the clip for which you want to disable 
automatic fade changes.

2. Select the Fade tab.

3. In the Clip Options section, deactivate Automatic Changes.

Creating Automatic Crossfades in Audio Montages

Crossfades in audio montages can be created automatically when clip edges 
overlap. You can specify the type of crossfade that is performed.

PROCEDURE

1. Open an audio montage and select the Fade tab.

2. In the Options section, open the Overlaps pop-up menu and select one of 
the following crossfade types:
• Free Overlaps

• Fade-In Constrains Overlaps

• Fade-Out Constrains Overlaps

3. Move a clip so that it overlaps the edge of another clip.

RESULT 

The crossfade is automatically created in the overlap.
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Crossfade Editing

You can create crossfades with independent shapes and lengths for the fade in and 
fade out curves.

The default automatic crossfade is linear. It uses the same shape and fade lengths 
for fade in and fade out. The following rules apply:

• A crossfade includes fade in and fade out.

• You can edit the fade in and fade out curves in crossfades in the same way 
as fades.

• To resize the crossfade time symmetrically, press [Shift], click the crossfade 
area, and drag left and right.

• To move the crossfade region while keeping its length, press 
[Ctrl]/[Command], click the crossfade area, and drag left and right.

• When you move a clip so that it overlaps another clip to create a crossfade, 
and neither clip has a defined fade in the overlap, a default crossfade is 
created if one of the auto crossfade options is activated.

• When moving a clip with a defined fade curve so that it overlaps another clip 
without a defined fade, the unmoved clip automatically gets the same fade 
shape as the moved clip, with amplitude compensation. This only applies if the 
fade out length of the unmoved clip is set to zero.

• If both clips have different defined fade curves, an asymmetrical crossfade is 
created.

Additionally, other factors govern the result when creating crossfades. In the 
following example a pre-defined fade out and an undefined fade in are used. What 
happens depends on the type of fade out curve that is used.

• If the fade out is a preset (except Sinus (*) or Square-Root (*)) that uses 
Pure Shape, the corresponding fade in gets the same preset with amplitude 
compensation.
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• If the fade out is a preset that uses a compensation attribute, the fade in gets 
the same preset, but with Pure Shape activated, for the compensation to take 
effect.

• If the fade out uses either the Sinus (*) or Square-Root (*) presets with the 
Pure Shape setting, the fade in gets the same preset also with the Pure 
Shape setting. In fact, power compensation is used. This is because the 
Sinus (*) and Square-Root (*) curves provide constant power crossfades by 
themselves.

RELATED LINKS

Options for Moving and Crossfading Clips on page 295

Crossfading with Fade Constrained Overlaps

PREREQUISITE 

To use fade in/fade out constrained overlaps, there must be a defined (not set to 
zero) fade in/fade out in the overlap. Otherwise, Free Overlaps is activated for that 
crossfade.

The following description applies to fade in constrained overlaps and fade out 
constrained overlaps. For the latter, however, the defined fade out length constrains 
the overlap, and accordingly, the left edge of the right clip is adjusted.

PROCEDURE

1. Open an audio montage and select the Fade tab.

2. In the Options section, open the Overlaps pop-up menu.

3. Activate Fade In Constrains Overlaps.

4. On a track that contains several clips, create a fade in curve in a clip.

5. Drag the clip to the left so that it overlaps another clip, past the right clip edge.
A crossfade is created in the overlap.

6. Continue dragging the clip, so that the fade in point of the dragged clip 
overlaps the right edge of the left clip.

7. Drag the clip to the right again.
The resized clip is gradually uncovered. The original clip length is memorized, so you 
can later restore the resized clips.

8. Separate the two clips again without creating an overlap so that they return to 
the original left/right position relative to each other.

9. Drag the left clip to the right so that it overlaps the other clip, and continue 
dragging to the right.
The right edge of the left clip is progressively resized as you drag the clip further to 
the right.

Fade constrained overlaps can also be used with the options Allow Multiple 
Automatic Crossfades and Allow Automatic Crossfading with Clips on Selected 
Track.
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RELATED LINKS

Automatic Crossfading on page 250

Crossfades Between Clips

The Wave Matching window shows a magnified view of the beginning of the 
selected clip and allows you to adjust the crossfade point for two adjacent clips.

The main purpose of this is to help you splice two consecutive clips together. The 
zoom view displays the end of the left clip and the start of the right clip. This type of 
splicing is achieved by applying short crossfades.

There are two main types of crossfades:

Artistic crossfades

For example, if you want to crossfade two songs to make a nice transition. 
Usually, these types of crossfades are quite long and can easily be created 
from the audio montage window.

Patch crossfades

For example, if you want to replace a section of audio, without audible 
discontinuity in the resulting audio. In this case, short crossfades should be 
used. These crossfades are best created in the Wave Matching window.

RELATED LINKS

Wave Matching Window on page 338

Adjusting Crossfades Between Clips

Adjusting the crossfades between clips is important to avoid clicks at the junction 
points. WaveLab Pro analyzes the waveforms to automatically find the best 
crossfade offsets.

PROCEDURE

1. In the montage window, on a track, align the two clips that you want next to 
each other.

2. Select the clip that is located on the right.

3. Select Tool Windows > Wave Matching.
This shows a close-up of the two clips.

4. In the Wave Matching window, set the zoom factor using the icons above the 
zoom view, or select a zoom factor from the Menu.
If you activate Menu > Automatic Level Zooming, the waveforms are automatically 
zoomed vertically to fill out the zoom view.

5. If necessary, move or resize the clip located on the right in the zoom view.

6. Set the search range using the icons above the zoom view, or select a search 
range from the Menu.

7. Decide whether you want to move the right clip to the left or to the right.
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• To move the clip to the left, select Menu > Move to Left (Match Waveform).

• To move the clip to the right, select Menu > Move to Right (Match 
Waveform). This is useful if the two clips are already overlapping.

RESULT 

WaveLab Pro scans the audio to the left of the splice point and moves the clip on 
the right to the position which provides the best possible phase match, to avoid 
harmonic cancellation. When the clip on the right is moved over the clip on the left, 
a short crossfade is automatically created.

RELATED LINKS

Wave Matching Window on page 338

Wave Matching Window

In the Wave Matching window, you can find the best crossfade point for two 
adjacent clips.

• To open the Wave Matching window, open an audio montage and select 
Tool Windows > Wave Matching.

On the Menu, you have the following options:

Move to Left (Match Waveform)

Scans the audio to the left of the splice point and finds the best possible 
phase match to avoid harmonic cancellation. The clip on the right is moved 
over the clip on the left. This automatically creates a short crossfade, ensuring 
the smoothest possible splice.

Move to Right (Match Waveform)

Scans the audio to the right of the splice point and finds the best possible 
phase match to avoid harmonic cancellation. The clip on the right is moved 
further to the right. This automatically creates a short crossfade, ensuring the 
smoothest possible splice. This function is useful if the two clips already 
overlap.

Search Range

Determines how WaveLab Pro scans the clips when searching for the best 
possible phase match. Higher values result in greater accuracy but also 
longer processing times. If the sounds contain a lot of bass, avoid the shortest 
search range setting.
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Zoom

Sets the zoom factor. For example, 1:4 means that 1 pixel on the screen 
corresponds to 4 audio samples.

Automatic Level Zooming

Automatically zooms the waveform vertically to fill the view.

Show Envelope

Displays the envelope curves of the clips in the view. Which curves are 
displayed depends on the settings of each clip.

Clip Time Stretching

You can adjust the length of a clip by using time stretching.

The best results are achieved when using small or moderate amounts of time 
stretch.

NOTE

Avoid time stretching of already time stretched material.

When you perform time stretching on a clip, a copy of the original audio file is 
created that contains the audio range that is used in the clip. The time stretch is 
applied to the copy, and the clip now references the copy.

• The copied audio file has the same name as the original, but with the suffix 
“_#X” where X is a number.

• The copied audio file is saved in the implicit folder that is specified in the 
Audio Montages Preferences.

Time-Stretching Clips

PROCEDURE

1. In the montage window, move the edit cursor to the position where you want 
the clip to end.

2. Right-click the lower part of the clip that you want to time-stretch, and select 
Time Stretch to Cursor.

3. In the Time Stretching dialog, edit your settings, and click OK.
Only the Method section is available for editing, because the other settings are 
determined by the edit cursor position.

RESULT 

The clip is stretched or compressed so that it ends at the edit cursor position.
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NOTE

Because the new copied audio file contains exactly the audio range that the clip 
uses, it is not possible to lengthen the clip by resizing after Time Stretch to Cursor 
has been applied.

RELATED LINKS

Time Stretching Dialog on page 221

Clip Pitch Shifting

You can adjust the pitch of a clip by using pitch shifting.

When you perform pitch shifting on a clip, a copy of the original audio file is created 
that contains the audio range that is used in the clip. The pitch shift is applied to the 
copy, and the clip references the copy.

• The copied audio file has the same name as the original, but with the suffix 
“_#X” where X is a number.

• The copied audio file is saved in the implicit folder that is specified in the 
Audio Montages Preferences.

Pitch-Shifting Clips

PROCEDURE

1. In the montage window, right-click the lower part of a clip for which you want 
to apply pitch shifting, and select Pitch Shifting.

2. In the Pitch Shifting dialog, edit your settings, and click OK.

RELATED LINKS

Pitch Shifting Dialog on page 224

Effects for Tracks, Clips, and the Montage Output

You can add VST effect plug-ins to individual clips, tracks, or the output of an audio 
montage. Clip effects affect individual clips only, track effects affect all clips on a 
track, and the montage output affects the whole audio montage.

Only VST 2 and VST 3 plug-ins can be used in the audio montage. Each clip, audio 
track, and the montage output can be independently processed by up to 10 VST 
effect plug-ins.

Effects are configured as follows:

• As inserts, where the entire audio is processed by the effects.
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• As send effects (split mode), where the balance between the unprocessed 
sound and the effect send level can be controlled by effect envelope curves 
(clip effects and specific VST 2 plug-ins only).

An icon in front of a clip name indicates that effects are applied to a clip.

Hovering over a clip name shows the effects that are used for the clip.

NOTE

• Only clip effects for clips that are active at the current playback position 
consume CPU power. Track and montage output effects are always active.

• The first time that you play an audio montage after is has been opened or 
copied, the program has to load all effects into memory. If you have many 
effects, this can result in a short silence before the playback starts.

• Effects that are used for tracks must support stereo audio, even if the audio 
track is mono.

Montage Output Effects

You can add montage output effects to an audio montage. While the Master 
Section is shared among all audio montages, the montage output effects are local 
to each montage. This allows you to have a fully embedded project, without needing 
to use the Master Section.

The montage output effects are located at the output of the audio montage.

NOTE

If you want to use a dithering plug-in, place it in the montage output.

Effects Window

This window lets you add effect plug-ins to tracks, clips, and the montage output, 
import the plug-ins from the Master Section, and make pan and gain settings.

• To open the Effects window, open an audio montage and select Tool 
Windows > Effects.
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Menu

Clip Effects

Displays the plug-ins of the active clip.

Track Effects

Displays the plug-ins of the active track.

Output Effects

Displays the plug-ins of the montage output.

Add Slot

Adds a slot into which an audio plug-in can be inserted.

Remove Selected Plug-ins

Removes the selected plug-ins.

Remove Selected Plug-ins from Selected Clips

Removes the plug-ins from the selected clips.

Copy

Copies the selected plug-in and its settings to the clipboard.

Copy All

Copies the settings of all plug-ins to the clipboard.

Paste (Insert)

Inserts the plug-in that was copied to the clipboard before the first selected 
slot. If no slot is selected, the plug-in is inserted at the end of the plug-in list.

Paste (Replace)

Replaces the selected plug-in with the plug-in that was copied to the 
clipboard. If no slot has been added, a new slot is created.

Paste to Selected Clips

Replaces the selected plug-in with the plug-in that was copied to the 
clipboard on all selected clips. If no slots have been added, new slots are 
created.
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Load Plug-in Chain

Replaces the current plug-ins with a plug-in chain that has been saved on 
disk.

Save Plug-in Chain

Saves the current plug-in chain as a preset.

Import Master Section Plug-ins

Imports the plug-ins that are loaded in the Master Section. Existing plug-ins 
are overwritten.

Close All Windows

Closes all plug-in windows that relate to this audio montage.

Plug-in Map

Opens the Plug-in Map dialog that displays all plug-ins that are used in the 
audio montage and the clips and tracks that are using them.

Bypass All Plug-ins

If this option is activated, all plug-ins of the active clip or track are bypassed 
during playback.

Bypass All Plug-ins in the Montage

If this option is activated, all plug-ins of the active audio montage are 
bypassed during playback.

Plug-in Window Handling

Opens the Plug-in Window Handling dialog where you can set up the 
appearance of plug-in windows.

Customize Command Bar

Opens the Customize Commands dialog which contains options to hide or 
show specific command bar buttons.

Effects List

The effects list displays the effect plug-ins of the selected track, clip, or montage 
output. In the list, you can replace effect plug-ins, change the effect order, and edit 
the Send Level and Tail of effects.

Plug-in window icon

Opens the plug-in window.
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Effect Name

Clicking an effect name opens the Plug-ins menu where you can select a new 
effect. The checkbox allows you to activate/deactivate the clips.

Preset

Shows the preset that is used by the plug-in. If no preset is used, this field is 
empty.

Channel Processing

Allows you to specify which channel to process. If you select one channel, the 
other channel is bypassed.

Routing

Allows you to set the routing of the processed signal. You can control the mix 
between the dry and the processed signal with an envelope. The following 
routing options are available:

• Insert (Standard)

• Blend Wet into Dry (Send)

• Parallel Processing

Edit Automation Envelope opens the Envelope tab and selects the 
automation envelope.

Latency

Shows the latency in the audio path. Plug-ins with latency cannot be used for 
adjusting the send level.

Tail (clip effects only)

Some effects, such as reverb and delay, produce audio tails. This means that 
the effect sound continues after the clip sound ends. For example, if you add 
echo to a clip without specifying a tail value, the echo effect is muted as soon 
as the clip ends. Set the tail length so that the effect is allowed to decay 
naturally. If you add another plug-in to the clip that also produces a tail, there 
is no need to set a separate tail value for this plug-in, unless you want the 
decay to sum up. The overall tail length for the clip is the sum of the tail of each 
plug-in. The maximum tail setting is 30 seconds.

Gain/Pan Section

In this section, you can edit Gain and Pan settings for each clip and track.
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Global Gain Section

In this section, you can set the global gain for the active audio montage. This gain 
can be applied before or after the montage output, depending on the setting of the 
pre/post button on the left of this section. Pre is the default setting.

The Loudness Meta Normalizer can change the global gain to set the audio 
montage output loudness, for example, to match the EBU R-128 recommendation.

RELATED LINKS

Pan Modes on page 325

Adding Effects to a Track, a Clip, or to the Montage Output

You can add effect plug-ins to every track and clip of the audio montage, and to the 
output of the audio montage.

Adding Effects Via the Effects Window

PROCEDURE

1. Open an audio montage.

2. Select Tool Windows > Effects.

3. In the Effects window, select the Clip, Track, or Montage section.

4. Click Add Slot.

5. In the Effect Name column, select the added slot.

6. Select a plug-in.

RESULT 

The selected effect opens in a window.
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NOTE

You can add effects during playback. However, if you add an effect with a latency 
larger than zero, it is better to stop and restart playback to avoid timing 
discrepancies. In addition, a small number of VST plug-ins may change its latency 
depending on the parameter settings. If that is the case, make sure to stop and 
restart playback after the latency is changed.

Additional Ways of Adding Effects

• To add an effect to a track, click the FX button in the track control area, select 
Add Effect, and select an effect from the menu.

• To add an effect to a clip in the montage window, right-click the clip name, 
select Add Effect, and select an effect from the menu.

Adding the Master Section Effects to the Track, Clip, or Montage Output

You can add the Master Section effects to a clip, a track or the output of an audio 
montage.

PREREQUISITE 

Set up the Master Section plug-ins.

PROCEDURE

1. Open an audio montage.

2. Select Tool Windows > Effects.

3. In the Effects window, select the track, clip, or montage output to which you 
want to add the Master Section effects.

4. Select Menu > Import Master Section Plug-ins.

RESULT 

The Master Section effects are added to the selected track, active clip, or montage 
output.
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NOTE

To copy a single Master Section effect, drag it from a Master Section slot to the 
effects list of the Effects window.

Removing Effects from Tracks, Clips, or the Montage Output

PROCEDURE

1. Open an audio montage.

2. Select Tool Windows > Effects.

3. In the Effects window, select the Clip section, Track section, or Output 
section.

4. Click the effect that you want to remove, and select Remove Plug-in.

RESULT 

The effect is removed from the slot.

Rearranging the Order of Effects

The order of the effects in the list determines the processing order.

PROCEDURE

1. Open an audio montage.

2. Select Tool Windows > Effects.

3. In the Effects window, in the effects list, drag the effect that you want to 
rearrange to another position.

Applying Plug-in Chain Presets to Tracks, Clips, or the Montage 
Output

You can save the plug-in chain of a track, a clip, or the montage output as a preset 
and apply it to other clips or tracks, or to the montage output of another audio 
montage.

PROCEDURE

1. Open an audio montage.

2. Select Tool Windows > Effects.

3. In the Effects window, set up your plug-in chain.

4. Select Menu > Save Plug-in Chain.

5. Enter a name and the file location for the effect chain, and click Save.
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6. Select the track, clip, or montage output to which you want to apply the effect 
chain.

7. Select Menu > Load Plug-in Chain.

8. Select a plug-in chain, and click Open.

Copying Effect Settings to Tracks, Clips, or the Montage Output

You can copy the effect and its settings of a track, a clip, or the montage output to 
other tracks, clips, or the montage output of the same or another audio montage.

PROCEDURE

1. Open an audio montage.

2. Select Tool Windows > Effects.

3. In the Effects window, select the effect from which you want to copy the 
settings.

4. Select Menu > Copy.

5. Decide whether you want to paste the effect settings to a new slot or replace 
an existing effect.
• To paste the effect settings to a new slot, add a new slot, and select Menu > 

Paste (Insert).

• To replace an existing effect, select the effect, and select Menu > Paste 
(Replace).

• To copy the effect settings to multiple clips, select the clips, and select Menu 
> Paste to Selected Clips.

Undoing Effect Changes

You can undo/redo changes to the effect settings. However, WaveLab Pro only 
registers the changes when the Effects window loses focus.

PROCEDURE

1. In the plug-in window, click another window to lose focus of the plug-in in 
which you want to undo the settings.

2. Go back to the plug-in in which you want to undo the settings.

3. On the command bar, click Undo or Redo.

Channel Processing

In the Master Section, in plug-in windows, and in the Effects window, you can 
specify for each plug-in which channels to process. This allows you to use each 
plug-in in mid/side mode, for example.
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You can process all channels or only the left, right, mid, or side channel. When you 
select one channel, the other channel is bypassed.

To use a different plug-ins for each channel, use one effect slot for each channel.

Insert

Stereo

All channels are processed by the plug-in.

Left

Only the left channel is processed by the plug-in.

Right

Only the right channel is processed by the plug-in.

Mid

Only the mid channel is processed by the plug-in.

Side

Only the side channel is processed by the plug-in.

Send (Return to Stereo)

Left

Only the left channel of the plug-in is processed. The left wet signal of the 
plug-in is mixed to the left/right dry signal.

Right

Only the right channel of the plug-in is processed. The right wet signal of the 
plug-in is mixed to the left/right dry signal.

Mid

Only the mid channel of the plug-in is processed. The mid wet signal of the 
plug-in is mixed to the mid/side dry signal.

Side

Only the side channel of the plug-in is processed. The side wet signal of the 
plug-in is mixed to the mid/side dry signal.

Setting Up the Channel Processing

You can set up which channel to process in the Master Section, in plug-in 
windows, and in the Effects window.

Channel Processing in the Master Section

In the Master Section, on the Effects pane, click Channel Processing, and select 
which channel you want to process.
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Channel Processing in Plug-in Windows

In a plug-in window, click Channel Processing and select which channel you want 
to process.

Channel Processing in the Effects Window

In the Effects window, click in the Channel Processing column for a plug-in and 
select which channel you want to process.
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Clip Plug-in Routing

You can route clip plug-ins to a clip. This, in conjunction with envelopes, allows you 
to control which part of the clip is processed by the plug-in.

Each clip plug-in has its independent envelope. When the envelope is all the way 
down, only the wet signal is applied. When the envelope is all the way up, the 
processed/wet signal is at its maximum.

The automation envelope can be independent for the left and right audio channels.

The following routing options are available:

Insert (Standard)

Replaces the dry signal with the processed signal.

Blend Wet into Dry (Send)

Mixes the wet part of the plug-in output with the dry signal. The amount of 
mixing is determined by a fixed gain and/or an automation envelope. The 
corresponding envelope can be selected in the Selector section of the 
Envelope tab in the Audio Montage window.

Parallel Processing

Mixes the processed signal with the dry signal. The level of the dry signal 
remains unchanged. The amount of mixing is determined by a fixed gain 
and/or an automation envelope. The corresponding envelope can be selected 
in the Selector section of the Envelope tab in the Audio Montage window.

This mode can be used for parallel compression.

The Edit Automation Envelope option opens the Envelope tab and selects the 
automation envelope.

RELATED LINKS

Routing a Plug-in to a Clip on page 351
Ducking Clips on page 326

Routing a Plug-in to a Clip

You can route a plug-in to an entire clip or only to parts of the clip.

PROCEDURE

1. Select Tool Windows > Effects.

2. In the Effects window, select the Clip section.

3. Click Add Slot.

4. In the Effect Name column, select the added slot.

5. Select a plug-in.
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6. Click in the Routing column and select one of the following routing options:
• Insert (Standard)

• Blend Wet into Dry (Send)

• Parallel Processing

7. If you have selected Blend Wet into Dry (Parallel) or Parallel Processing, 
you can edit the effect envelope to route the plug-in only to parts of the clip. 
Click in the Routing column and select Edit Automation Envelope.
The Envelope tab in the Audio Montage window opens and the plug-in is selected 
as envelope type.

8. In the montage window, edit the envelope curve.

RELATED LINKS

Adding Effects Via the Effects Window on page 345
Ducking Clips on page 326
Envelopes for Clips on page 319

Using Effect Envelopes

You can automate the effect send level for clip effects that use Split Mode by using 
effect envelope curves.

PREREQUISITE 

Set up a Split Mode effect plug-in for a clip.

PROCEDURE

1. Open an audio montage.

2. Select the Envelope tab.

3. In the Envelope Type pop-up menu, select the effect that you want to use for 
the envelope curve.

4. Create the envelope curve.

RELATED LINKS

Effects for Tracks, Clips, and the Montage Output on page 340

Setting Pan and Gain for Effects

You can set the Pan and the Gain of the effects for each clip and track individually.

PROCEDURE

1. Open an audio montage.

2. Select Tool Windows > Effects.

3. In the Effects window, select a clip or track.
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4. Adjust the Pan and the Gain using the controls on the left of the Effects 
window.

Setting the Global Gain for Effects

You can set a global gain for the montage output effects of your audio montage and 
apply it before or after the montage output effects.

PROCEDURE

1. Open an audio montage.

2. Select Tool Windows > Effects.

3. In the Effects window, select Output.

4. Adjust the global gain using the fader on the left of the Effects window.

5. Click the pre/post button to apply the global gain before  or after  the 
montage output effects.
If you use a dithering plug-in, set the gain to be pre-master.

Plug-in Window

In this window, you can display the effect plug-ins that are used for a track, clip, or 
the montage output. You can display all effects in one plug-in window or have 
separate windows for each effect, for all track effects, all clip effects, or all montage 
output effects.
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Plug-in chain window

Single plug-in window

When you add a new effect plug-in to a track, a clip, or the montage output, the 
plug-in window opens automatically. In the plug-in window, the effects are 
displayed in a plug-in chain by default. To change the processing order of the 
effects, you can drag each effect to a new position in the chain.

You can adjust the handling of the effects in the plug-in window in the Plug-in 
Window Handling dialog.

RELATED LINKS

Plug-in Window Handling Dialog on page 356

Opening the Plug-in Window

You can open the plug-in window from different locations.

• To open the plug-in window from the Effects window, in the effects list, click 
the plug-in window icon to the left of a plug-in.

• To open the plug-in window for a clip from the montage window, right-click 
the bottom part of a clip, and select Edit Plug-ins. You can also right-click 
the clip name and select a plug-in.

• To open the plug-in window for a track, click the FX button in the track control 
area.
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Adding Effects From Within the Plug-in Window

Effects that are added to a clip, track, or the montage output in the Effects window 
are automatically displayed in the plug-in window. However, you can also add 
effects to a track or a clip from within the plug-in window.

PROCEDURE

1. In the Plug-in Window Handling dialog, activate Use Plug-in Chain 
Windows.

2. Open the plug-in window for the clip, track, or montage output to which you 
want to add an effect.

3. In the plug-in window, click the Add Plug-in button.

4. Select an effect from the menu.
The effect is added at the end of the plug-in chain.

5. Optional: If you want to move the added effect in the plug-in chain, drag it to 
another position.

RELATED LINKS

Plug-in Window Handling Dialog on page 356

Changing Effects From Within the Plug-in Window

PROCEDURE

1. Open the plug-in window for the clip, track, or montage output for which you 
want to change an effect.

2. Click the plug-in menu icon, and select a new effect from the menu.

3. Optional: If you want to move the changed effect in a plug-in chain window, 
drag it to another position.
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Switching Between Track, Clip, and Montage Output Effects in Plug-in 
Windows

In the plug-in window, you can switch between the effect chains of clips, tracks, and 
the montage output. You can also switch between plug-in windows, when you have 
opened several plug-in windows.

• To skip through the clip and track effects of the active audio montage, use the 
left and right arrow icons.

• When using one plug-in window for both clips and tracks of an audio 
montage, you can switch between the plug-ins of the active clip or the track 
that contains the active clip by clicking the Show Clip Plug-ins or Show 
Track Plug-ins icons.

• To lock a plug-in window, activate Lock Window. If this option is activated, 
and you select another track or clip, another plug-in window opens. If this 
option is deactivated, and you select another track or clip, the effects are 
displayed in the same plug-in window.

NOTE

The Lock Window button is only visible if Use Plug-in Chain Windows and 
Unlimited Number of Open Windows is activated.

Closing All Plug-in Windows

PROCEDURE

1. Open an audio montage.

2. Select Tool Windows > Effects.

3. In the Effects window, select Menu > Close All Windows.

Plug-in Window Handling Dialog

In this dialog, you can set up the appearance and behavior of the plug-in windows.
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• To open the Plug-in Window Handling dialog, open the Effects window and 
select Menu > Plug-in Window Handling.

Use One Window Per Plug-in

If this option is activated, each plug-in opens in an individual window.

Close Other Windows When Opening a New One

Closes all open plug-in windows of an audio montage each time that you 
open a new plug-in window. This means that only one plug-in is displayed at 
a time for a each audio montage.

Use Plug-in Chain Windows

Shows all open plug-ins in the plug-in window as tabs, which allows you to 
quickly switch between the plug-ins.

Unlimited Number of Open Windows

Allows for an unlimited number of plug-in chain windows to be open at the 
same time. There can be one window for each track and one for each clip.

Lock Window on Opening

Automatically locks a plug-in each time that a plug-in chain window is opened.

If a plug-in window is locked, and you select another track or clip, another 
plug-in window opens. If this option is deactivated, and you select another 
track or clip, the effects are displayed in the same plug-in window.

Use One Window for Clips and One for Tracks

Uses one plug-in window for all clips, one for all tracks, and one for the 
montage output.

Use One Window per Montage

Uses one plug-in window for the clips, tracks, and the montage output of an 
audio montage.

Auto Switch between Tracks and Clips

If this option is activated and you click the track control area of a track, the 
plug-in window switches to display the track plug-ins. If you click a clip, the 
plug-in window switches to display the clip plug-ins.

About the CD Window

The CD window combines the functions for creating an audio CD or DVD-Audio 
within WaveLab Pro.

It displays a list of CD tracks along with information about each track. You can edit 
each track and the playback properties of the CD, check the conformity to the Red 
Book standards, add and edit CD-Text, add UPC/EAN and ISRC codes, generate 
a CD report, and write the CD.
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When you select a clip in the montage window, the corresponding track is 
highlighted in the CD window.

A CD track in the audio montage is defined by CD markers.

You can reorder CD tracks in the CD track list using drag and drop.

CD Markers

A track in the audio montage is defined by CD track start and end markers or CD 
track splice markers.

• CD track splice markers indicate the end of one track and the start of the next.

• If you delete the CD markers defining a track, the track is deleted from the CD 
window.

• If you edit a marker position of a CD track, the change is reflected in the track 
in the CD window.

• The name of a CD track is the name of the CD track start marker. Editing the 
marker name also changes the CD track name, and vice versa.

CD Window

In this window, you can create an audio CD or DVD-Audio.

• To open the CD window, open an audio montage and select Tool Windows 
> CD.

Track List

From Start with Pre-Roll 

Plays back the corresponding track from the start with a pre-roll.

You can also press [Alt]/[Option] and click  to play back the corresponding 
track from the start with a short pre-roll.

From Start 

Plays back the corresponding track from the start.

You can also hold [Ctrl]/[Command] and double-click a CD track start marker 
triangle to start playback from the marker position.
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Name

Shows the track name. To change the name, double-click in the 
corresponding cell, and enter a new value.

Group

Allows you to define track groups.

Pause

Shows the pause between two tracks.

Start

Shows the start position of the track.

End

Shows the end position of the track.

Length

Shows the time value from the CD track start position to the corresponding 
end or splice marker.

Pre-Gap

Shows the pre-gap of a track.

Post-Gap

Shows the post-gap of a track.

Lock

The lock icon indicates a track copy protection flag. Note that not all CD-R 
units can handle this flag.

Emphasis

The rainbow-colored symbol indicates the emphasis flag. This setting is used 
to indicate if the track was recorded with emphasis or not. 
Activating/Deactivating this option does not apply/remove emphasis from the 
audio. It is just an indicator for how the file was created.

ISRC

Lets you enter an ISRC code. To change the code, double-click the 
corresponding cell, and enter a new value.

CD-Text

Lets you specify the CD-Text. To change the CD-Text, double-click the 
corresponding cell, and enter a new value.

Comment

Allows you to enter a comment. To enter a comment, double-click a cell.
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Functions Menu

Write Audio CD or DDP

Opens a dialog that allows you to write a CD or DDP.

Check CD Conformity

Verifies that the settings for the audio montage are in accordance with the 
Red Book standard.

CD Wizard

Opens a dialog that helps you generate and adjust CD markers.

Edit CD-Text

Opens the CD-Text Editor that allows you to enter descriptive text for the 
tracks that are written on CD.

Edit CD Meta-Data

Opens the CD Meta-Data editor that allows you to associate meta-data with 
each CD track. When rendering CD tracks via the Render dialog, the audio 
files inherit this meta-data.

Import ISRC Codes from Text File

Allows you to import a text file that contains ISRC codes.

Generate Audio CD Report

Opens a dialog that lets you create a text report that describes the contents 
of the audio CD.

Rename CD Tracks as CD Text

Replaces the name of each CD track with the name that is specified in the 
CD-Text Title field.

Play Previous CD-Track/Play Next CD-Track

This is used to audition the track before/after the selected track. This depends 
on the pre-roll settings.

Play All CD-Track Starts

This is used to check the transitions between all tracks. In the Edit Playback 
Times dialog of the CD window, you can set the playback length for this 
function.

Options Menu

Audio in Pauses

Usually, when you create a CD, only the sections between track markers are 
written, and the pauses between tracks are replaced by silence. However, if 
Audio in Pauses is activated, the exact image of the audio montage is written, 
including any audio between tracks. This makes it possible to hear audio 
either between CD tracks or before the first track, for example, to create a 
hidden track.
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Preserve Post-Pauses when Reordering

If this option is activated, the pause after a CD track is preserved when you 
reorder tracks. If this option is deactivated, the pause before a CD track is 
preserved when you reorder tracks.

Show Times Relative to Track #1

If this option is activated, the start of track #1 is the time code reference, 
excluding any pause before that track.

Show Times Relative to CD’s Absolute Zero

If this option is activated, the beginning of the CD, including any pause before 
track #1, is the time code reference.

Time Code with CD Frames

If this option is activated, the time code is displayed in hours, minutes, 
seconds, and CD frames.

Time Code with Milliseconds

If this option is activated, the time code is displayed in hours, minutes, 
seconds, and milliseconds.

Pre-Roll Mode

If this option is activated, all tracks start with a pre-roll time when they are 
played back using the commands of the CD window.

Edit Playback Times

Opens a dialog where you can adjust the time values that are related to CD 
track playback.

Customize Command Bar

Opens the Customize Commands dialog which contains options to hide or 
show specific command bar buttons.

Toolbar

The following indicators are only available on the toolbar of the CD window:

Position in CD Track

Indicates the position of the playback/edit cursor, relative to the start of the 
CD track in which it is located.

UPC/EAN Code

Opens a dialog in which you can specify an UPC/EAN code.

Edit Playback Times Dialog

In this dialog, you can edit time values that are related to the playback of the CD 
track when using the playback commands of the CD window.
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• To open the Edit Playback Times dialog, open the CD window and select 
Options > Edit Playback Times.

CD Track Pre-Roll

Specifies how much time before the start of a CD track is played back to help 
you evaluate the transition between CD tracks.

Add One Second of Silence before Playback

If this option is activated, WaveLab Pro waits one second before starting 
playback of the next CD track start.

Test Time

Specifies the playback length of CD track starts for the Play All CD-Track 
Starts function in the CD window.

Meta-Data for CD Tracks

You can associate meta-data with individual CD tracks or with an entire CD. When 
rendering CD tracks via the Render dialog, the audio files can inherit this meta-data.

Because standard CD Text is not unicode, it does not always provide the optimum 
text data. To solve this issue, WaveLab Pro provides variables.

For CD tracks, there are two type of variables:

• Auto variables

• Custom variables

Auto variables are automatically added by WaveLab Pro. For example, ISRC, track 
names, and CD-Text. Custom variables can be manually edited to add additional 
meta-data for the track.

• To see and edit the CD track meta-data, open the CD window, and select 
Functions > Edit CD Meta-Data.
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NOTE

In this dialog, you prepare the meta-data. How they are, is specified in the 
Meta-Data dialog.

RELATED LINKS

Meta-Data on page 177

Creating Audio CD Tracks From Clips

The CD Wizard tool lets you generate CD track and splice markers from clip regions 
and crossfade points. You can use the Check CD conformity option to check 
whether the audio montage is ready for writing to audio CD.

PROCEDURE

1. Make sure that the audio montage contains the material that you want on the 
audio CD.
CD tracks must have a length of at least 4 seconds.

2. In the CD window, select Functions > CD Wizard.

3. Edit the settings in the CD Wizard dialog, and click Apply.

4. Audition the tracks in the CD window, and make corrections if necessary.

5. In the CD window, select Functions > Check CD Conformity.
• If a warning message appears, make corrections and check the CD conformity 

again.

• If no warning message appears, the audio montage is ready to be written to an 
audio CD.

CD Wizard Dialog

In this dialog, you can generate and adjust CD markers for audio montages.

• To open the CD Wizard dialog, open the CD window and select Functions > 
CD Wizard.

Generate CD Track Markers

If this option is activated, the CD Wizard automatically generates CD track 
markers according to the sub-options.

Create Markers at Clip Boundaries

If this option is activated, CD track start and end markers are added at the 
beginning and end of all non-overlapping clips.



Audio Montage
About the CD Window

364

Use Splice Markers (Keep Pauses within Tracks)

If this option is activated, single splice markers are generated instead of 
start/end markers. Instead of a standard pause, pause spaces are generated. 
The pauses are kept within tracks. This can be useful for electronic 
distribution and for compatibility with portable players.

Create Markers at Crossfade Points

If this option is activated, CD track splice markers are created at all crossfade 
intersection points. Activate this option if you have clips that overlap each 
other and that should become different tracks on the CD.

Keep Locked CD Track Markers

Normally, any previously created CD track markers in the montage are 
removed by the CD Wizard. If Keep Locked CD Track Markers is activated, 
the locked CD track markers are kept.

CD Marker Naming

Allows you to set up a naming scheme.

Start Marker

On this menu, you can select a naming scheme for the CD track start markers. 
The following options are available:

• As Clips: The name of the closest clip.

• Specific Name: The name specified below.

• Specific Name + Number X: The name and a number.

• Specific Name + Number XX: The name and a number that is padded 
on the left with 0.

• Specific Name + Number (Auto): As Specific Name + Number XX, 
but only if the number of tracks is greater than 10.

• Number X + Specific Name: A number and a name.

• Number XX + Specific Name: A number that is padded on the left with 
0 and a name.

• Number (Auto) + Specific Name: As Number XX + Specific Name, 
but only if the number of tracks is greater than 10.

• Custom: Opens the Rename Markers dialog where you can rename 
multiple markers according to specified settings.

End Marker

On this menu, you can select the name of the CD track end marker. The 
following options are available:

• No Name

• As Start Marker

• As Start Marker + “(End)”

• Custom
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Adjust Pauses before Tracks

If this option is activated, pauses before tracks are automatically adjusted 
according to the sub-options.

Set Time

If this option is activated, you can specify the length of the pauses between 
tracks.

Round Existing Pauses to Closest Second

If this option is activated, the existing pauses between tracks are rounded to 
seconds.

Do Not Change First Pause

If this option is activated, the pause between the start of the montage and the 
first track is not changed. If you change the length of the pauses to anything 
other than 2 seconds and want to be conform to the Red Book standard, you 
must activate this option.

Adjust Gaps between Markers and Sound (as CD Frames)

If this option is activated, small adjustments to the spacing before and after 
the CD track markers are made according to the sub-options. This is useful 
to ensure that a low-quality CD player does not miss the start of tracks or cuts 
them off before their actual end. In most cases, the default settings are 
sufficient.

Silence after First Track Start Marker

Lets you add a few frames of silence before the first track of the CD. Usually, 
the pause needs to be longer for the first track than for the other tracks to 
ensure that a low quality CD player does not miss the start of the first track.

Silence after Track Start Marker

Lets you add a few frames of silence before each track on the CD to ensure 
that a low quality CD player does not miss the start of tracks.

Silence before Each Track End Marker

Lets you add a few frames of silence after each track of the CD to ensure that 
a low quality CD player does not cut off tracks before their actual end.

Silence before Last Track End Marker

Lets you add a few frames of silence after the last track of the CD to ensure 
that a low quality CD player does not cut off the end of the track or that the 
listener is not disturbed by any clicks or motor noise that the player makes at 
the end of a CD.

Ensure Required Minimum Size for CD Tracks

If this option is activated, markers are adjusted to ensure that each CD track 
has the minimum length that the Red Book standard requires.

Quantize CD Markers to Nearest CD Frame

If this option is activated, markers are quantized to the nearest CD frame.
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Generate ISRC Codes

If this option is activated, ISRC codes for the CD tracks are created. Each 
code is based on the code that is specified in this option, but with an ending 
number that is set according to the order of the tracks.

UPC/EAN Code (13 Digits)

Lets you specify an optional UPC/EAN code for the CD.

RELATED LINKS

Batch Renaming Dialog for Markers on page 635

Audio in Pauses

Normally, when you write an audio montage on an audio CD, only the sections 
between the CD markers are written, and the pauses between tracks are replaced 
by silence. However, if Audio in Pauses is activated, the exact image of the audio 
montage is written on the CD, including any audio between tracks.

Using Audio in Pauses

The following describes two use cases for the Audio in Pauses function.

Adjusting CD Track Markers to Hide Audio Sections

If you have a live recording with a section of applause between two songs, you can 
move the track markers so that the applause section is between the tracks and 
activate Audio in Pauses. Thus the applause cannot be heard if you play any of the 
two tracks on their own, but you can hear it when playing through the CD tracks.

PROCEDURE

1. In the montage window, place the CD track end marker of the first track at the 
position where the music ends, but before the applause section.

2. If necessary, place the CD track start marker of the following track at the 
position where the music starts.

3. In the CD window, select Options > Audio in Pauses.
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Placing a Clip Before Track 1

You can create a hidden CD track before track 1, for example.

PROCEDURE

1. In the montage window, place a clip without CD track markers prior to the first 
track start marker in the audio montage.

NOTE

It is recommended that you do not place the hidden track at the very start of the 
montage but leave a little room between the montage start and the start of the hidden 
track.

2. In the CD window, select Options > Audio in Pauses.

3. Proceed with writing the CD.
To hear the hidden track after writing the disc, rewind from the start of track 1.

Snapshots

You can save a number of snapshots of your audio montage, to capture the current 
scroll position, zoom factor, cursor position, audio selection, and clip selection 
status.

You can recall a snapshot at any time and update snapshots.

Selecting a saved snapshot restores all of its view settings. You can also choose to 
recall only specific view properties by activating the corresponding options for a 
snapshot.

RELATED LINKS

Snapshots on page 239

Capturing the Current View

Capturing the current view saves the current zoom factor, cursor position, scroll 
position, clip selection status, and time range.

PROCEDURE

1. Set up the view of the montage window.

2. Select the View tab.

3. In the Snapshots section, click Take Snapshot .

4. Click one of the preset buttons to save the snapshot.
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RESULT 

The snapshot is saved and can be recalled by clicking the corresponding preset 
button.

Updating Snapshots

You can update a snapshot with the current view.

PROCEDURE

1. Set up the view of the montage window.

2. Select the View tab.

3. In the Snapshots section, click Take Snapshot .

4. Click the preset button that you want to update.

RESULT 

The new snapshot replaces the selected snapshot.

Mixing Down – The Render Function

The Render function allows you to mix down the whole audio montage or sections 
of it to a single audio file or to several files in case of a multichannel audio montage. 
It also allows you to render to an audio CD, to a CD image and cue sheet, or to a 
new audio montage.

A mixdown is necessary to produce an audio file from the audio montage. The 
Render function can be used for the following purposes:

• Write a CD from a CPU-intensive audio montage, because it allows you to 
first render all track and clip effect processing to recreate a new audio 
montage and then write the CD in a second pass.

• Render audio files, audio montages, or marker regions in audio montages to 
multiple file formats at the same time.

• Render surround channels as multiple files while retaining the stereo/mono 
status of the individual surround channels.

• Create a CD image and cue sheet.

• Render audio montages to a single file or render various parts of a montage 
to multiple audio files in one operation. For example, you can render regions, 
groups, clips, or CD tracks.

RELATED LINKS

Rendering on page 424
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Rendering to Audio File

You can render to a single audio file format or to multiple audio file formats at the 
same time.

PREREQUISITE 

Set up your audio montage. If you want to render to multiple file formats, create file 
format presets.

PROCEDURE

1. In the Audio Montage window, select the Render tab.

2. In the Source section, specify which part of the audio file you want to render.

3. In the Results section, activate Named File.

4. In the Output section, click the Format field and do one of the following:
• If you want to render to one audio format, select Edit Single Format.

• If you want to render to multiple file formats, select Edit Multi Format.

5. Make your settings in the Audio File Format dialog.
• To add multiple file formats in the Multi Audio File Format dialog, click Plus 

 and select the file format presets that you want to render to.

6. Click OK.

7. Optional: Make additional settings on the Render tab.

8. In the Render section, click Start.

RESULT 

The audio montage is rendered.

If you render a surround mix to Multi Stereo/Mono files, the mono/stereo status of 
the rendered files reflects the mono/stereo status of the surround channels. If the 
audio montage uses a 6 channel (5.1) surround mode, two stereo files (Lf/Rf and 
Ls/Rs) and two mono files (C/Lfe) are rendered. The names of the rendered files 
reflect the name of the surround channel to which they belong.

If you render an 8 channel configuration using the Multi Stereo/Mono option, the 
channels are grouped as logical pairs (1-2, 3-4, etc.). For tracks that are routed to 
only one channel in a pair, a mono file is created.

Under Windows, you can also render single multichannel surround files in the WMA 
5.1 and 7.1 formats. Use the Windows Media Audio 9 Professional encoder.

RELATED LINKS

Multi Audio File Format Dialog on page 426
Creating Multiple Audio File Format Presets on page 426
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Loudness Meta Normalizer

This tool is a key mastering component to ensure that all songs get the same 
loudness and to prevent clipping. It allows you to adjust the loudness of each clip 
in the audio montage so that they all have the same loudness. It is also possible to 
adjust the loudness of the audio montage mixdown as well as the loudness at the 
Master Section output.

This tool operates on gains. It does not affect the underlying audio files or use any 
audio compressor.

If it is not possible to modify the loudness of a particular clip without clipping, the 
level of the other clips is reduced so that all clips still achieve the same loudness. 
This does not happen if the Ignore Peaks option on the Peaks pop-up menu in the 
Loudness Meta Normalizer dialog is selected.

To avoid clipping at the Master Section stage, you can limit the mixdown output of 
the audio montage before it goes into the Master Section and/or the Master 
Section output.

The loudness is calculated according to the EBU R-128 recommendation. The 
reference loudness can either be the loudness of the loudest clip, of a specific clip, 
or a custom value.

There are three possible loudness references:

• Loudness of an entire file (EBU R-128 recommendation).

• Top of a loudness range, that is, the average loudest 3 second audio section 
of a file. This ensures that a single unusually loud sound is not taken into 
account for the reference.

• Maximum short-term loudness, that is, the maximum loudness that is found in 
a 3 second audio section of the file, for example, the loudness of a short music 
passage.

NOTE

• The audio path in the audio montage uses 32-bit floating point processing. 
You can therefore overload it, for example, use levels above 0 dB in clips, 
without causing clipping in the signal path. The only section of the audio path 
that can introduce clipping is the output of the Master Section or the output 
of the audio montage. Both of these issues can also be solved by the 
Loudness Meta Normalizer.

• Because loudness requires several seconds of audio to be correctly 
calculated, this tool should not be used for very short clips (under 3 seconds).

Loudness Meta Normalizer Dialog

In this dialog, you can adjust the loudness of each clip in the audio montage so that 
they get the same loudness. You can also adjust the whole output, while taking the 
EBU R-128 audio measurement recommendation and a true peak analysis into 
account.
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• To open the Loudness Meta Normalizer dialog, select the Process tab in 
the Audio Montage window, and click Meta Normalizer in the Loudness 
section.

Clips, Master Section Output, and Audio Montage Output

• If Clips is activated, the gain settings of all clips in the audio montage are 
adjusted individually so that all clips play back at equal loudness.

• If Audio Montage Output is activated, the gain setting of the audio montage 
is modified so that the audio montage mixdown matches a specific loudness.

• If Master Section Output is activated, the Master Section gain is adjusted 
so that the audio montage mixdown that is processed through all Master 
Section plug-ins matches a specific loudness. The audio montage itself is not 
modified by this operation.

The following options are available for the gain settings of clips, the audio montage 
output, and the Master Section output.

Match loudness menu

Select whether the audio montage output should match a specific loudness. 
The following options are available:

• Do Not Change Loudness

• Match Loudest Clip

• Match Loudness of Active Clip

• Match Specific Loudness

• Equalize Peak Levels
The highest peak is used as reference.

Loudness

Determines the loudness to match. For example, specify -23 LUFS if you want 
to follow the EBU R-128 recommendation for broadcast.

Reference menu

Select the loudness that WaveLab Pro should reference:

• Loudness of Entire Clip (EBU R-128 recommendation)

• Top of Loudness Range (average loudest 3 second audio section)

• Maximum Short-Term Loudness (loudest 3 seconds audio section)

Peaks menu

Select whether WaveLab Pro should limit the sample values (digital peaks), 
the analog reconstructed samples (true peaks), or ignore the peaks.

Maximum Peak

Determines the maximum peak value that must not be exceeded.
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Force Equal Loudness

If Limit True Peaks or Limit Digital Peaks is selected, some clip might not 
reach the required gain for the reference loudness. In that case, activate 
Force Equal Loudness to reduce the loudness of the clip that is used as a 
reference to achieve equal loudness across all clips.

Additional Options

Exclude Audio Montage Effects

If this option is activated, audio montage effects are not taken into account 
when you use the Loudness Meta Normalizer for processing.

Only Selected Clips

If this option is activated, only the selected clips are processed with the 
Loudness Meta Normalizer.

Show Log

If this option is activated, a log window opens after the process to show the 
analysis result.

Test Only

If this option is activated, a test analysis is performed. A log window opens to 
show the result of this analysis. The test analysis does not apply the loudness 
settings to the audio.

Navigator Window

This window displays an overview of the entire active audio montage and allows you 
to quickly navigate in it.

• To open the Navigator window, open an audio montage and select Tool 
Windows > Navigator.

Each clip is represented by a colored block. The visible window content is shown 
by a black rectangle.

Navigating in the Navigator Window

The Navigator window allows you to quickly find positions in large audio montages.
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Dragging with the mouse in any direction scrolls the main audio montage window, 
allowing you to navigate to a location in your audio montage.

• To adjust the visible range of the active window, you can resize the rectangle 
vertically and horizontally by dragging its edges. You can also resize by 
[Shift]-clicking in the rectangle edges and dragging.

• To zoom in on a clip, click its corresponding block. If the clip is inside the 
rectangle, double-click it.

• To completely zoom out, right-click anywhere in the window.

Notes Window

This window allows you to enter notes about the current audio montage session.

• To open the Notes window, open an audio montage and select Tool 
Windows > Notes.

You can enter the text directly in this window and use the standard HTML text editor 
controls to format the text, and to add images and lists. The notes are saved with 
the audio montage.

Groups

Groups are selections of clips that can be accessed via the Groups window or by 
clicking any clip of a group.

A clip cannot be part of more than one group. If you add a clip to a group, it is 
automatically removed from any other group. You can select a specific color for a 
group to make it easy to discern it in the track view.

You can render all groups as individual files in the Render dialog of the Master 
Section.

• To create nested groups, drag a group into another group.

• To deactivate a group, deactivate its checkbox in the list. If a group is 
deactivated, you can move the individual clips.

• To rename a group, double-click its name and enter a new name.

• To select all clips of a group in your audio montage for editing, click the group.
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RELATED LINKS

Super Clips on page 308

Groups Window

This window displays a list of the groups that are part of the current audio montage.

• To open the Groups window, open an audio montage and select Tool 
Windows > Groups.

Group Selected Clips

Creates a group from all selected clips.

Remove Selected Group

Removes the group that is selected in the list. The clips themselves are not 
removed from the montage.

Click Selects Group

If this option is activated, selecting a clip in the track view automatically 
selects all clips in the same group.

If this option is deactivated, selecting a whole group requires that you click the 
group name in the groups view list. This is useful if you want to be able to 
modify the relative positions of clips in the group without having to remove 
them from the group.

Color

Lets you select a color for the group.

Customize Command Bar

Opens the Customize Commands dialog which contains options to hide or 
show specific command bar buttons.

Grouping Clips

PROCEDURE

1. In the montage window, select the clips that you want to group.

2. In the Groups window, select Functions > Group Selected Clips.

3. Enter a name for the group, and click OK.



Audio Montage
Audio Montage Backups

375

RESULT 

The new group is displayed in the group list. The group name is prepended to the 
names of the clips that are included in the group.

Adding Clips to an Existing Group

PROCEDURE

1. In the montage window, select the clips that you want to add to a group.

2. In the Groups window, select Functions > Group Selected Clips.

3. Select the group to which you want to add the clips, and click OK.

Removing Groups

PROCEDURE

1. In the Groups window, select a group.

2. Select Functions > Remove Selected Group.

RESULT 

The group is removed. The clips themselves are not removed from the montage.

Coloring Groups

PROCEDURE

1. In the Groups window, select a group.

2. Open the Color menu and select a color.
Any individual color selections for the clips override the group color.

Audio Montage Backups

The audio montage backup mechanism allows you to maintain previous versions of 
saved audio montages and to automatically save audio montages.

Whenever you save an audio montage, the previously saved version is copied to the 
subfolder Backup.mon which is located in the same folder as the audio montage 
file. This backup folder is automatically created by WaveLab Pro. The backup files 
are named “Montage_#X”, where “Montage” is the name of the audio montage and 
“X” is a number.
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You can specify how many previous versions you want to keep (maximum 1000). 
Once the specified number of backups is reached, the oldest file is overwritten each 
time that the audio montage is backed up.

NOTE

The numbers in the backup file names are not related to the age of the backup files. 
Instead, you must check the dates of the files to know which backup is the most 
recent.

Unsaved and untitled audio montages are also backed up. The backup files for 
untitled audio montages are saved in the temporary folder, and use a number as 
name, so that the files are called “Y_#X”, where “Y” is a number identifying the 
audio montage, and “X” is the number of the backup file.

Setting Up the Audio Montage Backup

You can specify the number of audio montage backups and define how often the 
backup should be performed.

PROCEDURE

1. In the Audio Montages Preferences, select the All Audio Montages tab.

2. In the Backups section, specify the maximum number of backups.
To deactivate the backup function, set this setting to 0.

3. Optional: Activate Auto Save, and specify how often the backup should be 
performed.

Opening an Audio Montage Backup

You can open the backup of an audio montage to restore a former version of the 
audio montage.

PROCEDURE

1. Select File > Open.

2. Click Audio Montage.

3. Do one of the following:
• To close the current unsaved audio montage and open the last saved version, 

click Revert to Saved File. This replaces the current audio montage.

• To open the saved version in a new window without closing the current, 
unsaved version, click Revert to Backup.
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Multichannel Operations in the Audio Montage

WaveLab Pro supports the use of up to 8 ASIO inputs and outputs. If you use a 
multichannel audio interface with an ASIO driver, you can route audio montage 
tracks to up to 8 separate channel outputs and to up to 6 surround outputs.

You can also record up to 8 channels simultaneously. This automatically creates 
new tracks in the montage, one for each recorded channel or channel pair.

To be able to use WaveLab Pro for multichannel/surround projects, you need an 
audio card/interface with multiple inputs and outputs. You must also set up an ASIO 
driver in the VST Audio Connections tab and specify how the internal input/output 
channels are connected to your audio card.

RELATED LINKS

VST Audio Connections Tab on page 13

Multichannel Configuration

You can configure the number of channels to use for each audio montage.

The are two operational modes that you can use for multichannel operation:

• In the Multichannel (DVD-Audio Compatible) mode, in surround mode, 
tracks can be routed to one or several surround output channels (Left/Right 
Front, Center, etc.). You can assign up to 6 surround channels.

• In the Multichannel (Free Configuration) mode, channels refer to the names 
of the 8 WaveLab Pro output channels instead of the surround channels. 
Track channels can be routed to one (mono tracks) or two (stereo tracks) of 
the 8 available output channels.

Which configuration you should select depends on a number of factors:

• The number of outputs that are available on your audio card. If you only have 
4 outputs on your card, you can only use surround formats with 4 or less 
channels.

• Whether or not you intend to mix the audio montage to a surround format. If 
not, select the Stereo mode or the 8 Channels mode.

• The intended use of the final surround mix. For example, if you want your mix 
to be compatible with the 5.1 surround set-up, select the 6 Channels mode.

All multichannel configurations except the free configuration mode have surround 
formats and are internally assigned to surround channels in WaveLab Pro. This 
means that the channels go through the Master Section and then to the audio card.
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Assigning Track Channels to Output Channels

When you select a multichannel configuration, you must create and assign track 
channels to surround output channels manually.

PROCEDURE

1. In the Audio Montage window, in the track control area, click Audio Track 
Dispatching for an audio track.

2. In the Audio Track Dispatching dialog, route each channel of the track to an 
output channel by activating the corresponding channels.
Which channels are available depends on the selected channel configuration.

3. Click OK.

RESULT 

If you have selected a surround format, you can route a track channel to several or 
all surround output channels. If you select more than one output channel for a stereo 
track channel, the Surround Panner automatically opens in the track control area for 
the corresponding track.

Audio Track Dispatching Dialog

In this dialog, you set up to which channels the top and bottom audio channels of a 
track in the audio montage are sent. The available channels depend on the selected 
channel configuration.

• To open the Audio Track Dispatching dialog, click Audio Track 
Dispatching for an audio track in the track control area of the Audio Montage 
window.
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Top Audio Channel Is Sent To

Lets you select to which audio montage audio outputs the left channel of the 
track is sent.

Bottom Audio Channel Is Sent To

Lets you select to which audio montage audio outputs the right channel of the 
track is sent.

Low Pass Filtering of the LFE Channel

If an LFE output is selected, a low pass filter (12 dB/octave) can be applied to 
the track signal so that only the low frequency content can pass. The cutoff 
frequency for the filter can be adjusted.

Surround Panning

You can use surround panning to position a track freely in the surround image.

The Surround Panner lets you adjust the pan of your audio between surround 
channels. Each track can have its own Surround Panner, and several of these 
windows can be open at the same time.
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Using Surround Panning

You can route any audio montage channel of a track to a surround channel or to a 
combination of surround channels using the Audio Track Dispatching dialog. 
However, if you also want to position a track freely in the surround image, you can 
use the surround panner.

PREREQUISITE 

In this example, it is assumed that you have set up an audio montage in 5.1 surround 
format and that you want to use the surround panner for a stereo track.

PROCEDURE

1. In the Audio Montage window, in the track control area, click Audio Track 
Dispatching for the track that you want to use for surround panning.

2. In the Audio Track Dispatching dialog, activate the surround channels.
You can activate different surround channel combinations for the top (left) and bottom 
(right) audio channels.

3. Click OK.
A Surround Panner display opens in the track control area.

4. Click and drag in the surround panner display to make coarse adjustments.
For a more precise control of the imaging, right-click the surround panner display to 
open the Surround Panner dialog.

5. In the Surround Panner dialog, click the blue square and move the mouse.
This pans the audio of the top channel. The other channel is automatically mirrored 
horizontally. Right-click the display to choose from a number of positioning presets.

6. To view and edit the other channel, click the gray square.
The gray square turns to red, and red speaker lines indicate the speaker levels.

7. When you have finished your settings, click Close.

Surround Panner Dialog

This dialog allows you to adjust the pan of your audio between surround sound 
channels.
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Set up a multichannel, DVD-Audio compatible, audio montage, and select 2 or more 
output channels per track channel. For each track that is set to Surround in the 
Audio Track Dispatching dialog, a small Surround Panner is displayed in the track 
view.

• To open the Surround Panner dialog, right-click on the small surround 
panner.

In the graphic display, the positions of the left/right audio channels of the clip are 
shown as small squares. The signal levels of the individual speakers are indicated 
by colored lines from the speakers to the center of the display.

The graphic display shows the surround imaging of either the top (blue) track audio 
channel, or the bottom (red) track audio channel. The color of the speaker lines 
shows which channel is selected for viewing and editing.

If you are viewing the top channel, you see a blue square indicating the position of 
the audio. The other, gray square represents the other channel. Click the gray 
square to view and edit this channel. The gray square turns to red and red speaker 
lines indicate the speaker levels.
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Center

Determines how much the track signal should be mixed into the audio 
montage output corresponding to the center speaker. This is only available if 
the center channel is activated in the Audio Track Dispatching dialog.

Divergence

Determines the attenuation curve that is used when positioning sound 
sources. If this is set to 0 %, positioning a sound source on a speaker sets all 
other speakers to zero level, except for the center speaker which depends on 
the center level. With higher values, the other speakers receive a percentage 
of the sound source. This makes the sound less localized.

Front/Rear Ratio

Determines how much the front and rear levels are affected by the vertical 
positioning in the Surround Panner dialog. The higher the ratio, the less 
difference exists between sounds that are panned front and rear. If set to 
100 %, the rear and front levels are always the same.

Constant Power

Determines whether the loudness (RMS) or the level of the summed signals 
is preserved. If set to 100 %, the total loudness is the same regardless of 
panning settings. If set to 0 %, the total level is preserved.

LFE Gain

Sets the amount of signal that is sent to the LFE channel. This is only available 
if the LFE channel is activated in the Audio Track Dispatching dialog.

Copy

Copies the settings of the selected Surround Panner to the clipboard.

Paste

Applies the copied settings to the Surround Panner.
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Presets menu

Right-click the graphic display of the Surround Panner to select from different 
surround panning presets.

Surround Pan Envelopes

You can automate the surround panning for individual clips using envelopes. This is 
slightly different from using regular volume and pan envelopes.

• Internally, there is a single surround pan envelope where each envelope point 
contains a complete surround state (left-right position, front-rear position, and 
LFE amount).

• When you look at the envelope for a clip, you can choose to view either the 
left-right, front-rear, or the LFE curve.

• When setting envelope points for either one of the envelope types, that point 
is automatically added to the other envelope types at the same position in the 
clip.

Setting Up Surround Panning Envelopes

You can use the Surround Panner to program each envelope point. This makes it 
easy to set up automated surround panning for a clip.

If you want the signal to start at the front center position, then move to the left rear 
speaker, and finally move to the right rear speaker, do the following:

PROCEDURE

1. In the Audio Montage window, set up a track for surround panning by 
activating the surround channels in the Audio Track Dispatching dialog.

2. Select the clip, and select the Envelope tab.

3. In the Selector section, select one of the Surround Pan envelopes.
For example, Surround Pan (Left <-> Right).

4. In the montage window, double-click the envelope to add a new envelope 
point in the middle of the clip.
This determines the position where the signal reaches the left rear speaker. Only the 
position in the clip is important when you create envelope points at this stage, not the 
vertical position of the point.

5. In the track control area, right-click the Surround Panner display.

6. In the montage window, select the envelope point at the start of the clip.

7. Use the Surround Panner dialog to position the sound. In our example, the 
panning should start in the front center position. Drag the position square to 
the top middle of the display. You can also right-click the display and select 
the Front Center preset.
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8. In the montage window, select the next envelope point in the clip, and in the 
dialog, drag the position square to the lower left corner of the display. You can 
also right-click the display and select the Rear Left preset.

9. In the montage window, select the last envelope point, and in the dialog, drag 
the position square to the lower right corner of the display. You can also 
right-click the display and select the Rear Right preset.
The left-right surround envelope curve now looks like this:

10. On the Envelope tab, in the Selector section, select Surround Pan (Front 
<-> Rear).
The Front-Rear surround envelope curve looks like this:

11. Play back the clip.
You should hear the sound move from center front to left rear to right rear.

12. To create more complex surround panning, add more envelope points and 
program these in the same way.

Editing Envelope Curves

You can edit the envelope curves without affecting other panning settings, by 
adjusting their points in the clip. This can be useful if you only want to change the 
LFE amount without affecting panning, or if you only want to change the left-right 
panning without affecting front-rear panning and vice versa.

NOTE

If you move an envelope point in time, all surround pan envelopes are affected in the 
same way.
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Multichannel (DVD-Audio Compatible) Mode

If Multichannel (DVD-Audio Compatible) mode is activated for an audio montage, 
you can choose between various multichannel configurations.

In the Info dialog of the audio montage, select Multichannel (DVD-Audio 
Compatible). On the Channels menu, the following multichannel configurations 
are available:

Left/Right Front (Lf, Rf)

This is used in all surround configurations. These correspond to standard 
left/right stereo speaker positions in front of the listener.

Center (C)

This is placed in between the Lf/Rf surround speakers.

Low Frequency Effects (LFE)

The LFE channel is connected to a subwoofer and provides low frequency 
content (normally below 120 Hz). It can be used to provide special low 
frequency effects like deep rumbles, explosions, etc. For each channel that is 
routed to the LFE channel, there is a low-pass filter that allows you to extend 
or lower the low frequency range that is reproduced by the LFE channel.

Surround (S)

This is sometimes referred to as the back surround channel and is normally 
placed in between the left/right surround channels.

Left/Right Surround (Ls, Rs)

These are placed behind the listening position, mirroring the left/right front 
speakers.

Free Configuration Mode

If Multichannel (Free Configuration) mode is selected, you can route track 
channels to one of the 8 output channels. This mode is not surround oriented and 
allows you to use the audio montage as an 8 channel recording/playback 
environment.

• To activate this mode, open the Info dialog of the audio montage, and from 
the Mode menu, select Multichannel (Free Configuration).

Channels are grouped as stereo pairs (1-2, 3-4, etc.), which is reflected in the 
Master Section and when rendering to multiple files.
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Enable Additional DVD-Audio Configurations

The DVD-Audio specification allows for mixed sample resolutions within the same 
channel configuration, which therefore needs to be divided into two separate 
groups. For example, the Lf/Rf channel group could, according to the standard, 
have a higher sample rate resolution than the other surround channels in the same 
configuration.

The slash in the surround channel menu indicates which channels belong to which 
group.

However, the use of mixed resolutions is not supported in WaveLab Pro and 
deactivated by default.

• To activate additional DVD-Audio configurations, click the Audio Montage 
Properties button below the montage window. Then, in the Audio Montage 
Properties dialog, select Multichannel (DVD-Audio Compatible), and 
activate Enable Additional DVD-Audio Configurations.

Multichannel Recording

You can record up to 8 channels simultaneously in the audio montage.

Multichannel Recording Preparations

PREREQUISITE 

Set up how the inputs on your audio card are connected to the internal channels of 
WaveLab Pro.

PROCEDURE

1. On the transport bar, click Record, or press [*] on the numeric key pad.

2. In the File to Create section, select whether to create a named file or a 
temporary file.

3. If you want to create a named file, specify a file name and the location where 
you want to save the file.

4. Click the audio format text to open the Audio File Format dialog.

5. Select the audio file format.

6. On the Channels menu, select Multi Stereo/Mono or Multi Mono.
Multi Stereo/Mono produces single stereo or mono files, depending on the 
activated channels in the Recording Channels dialog. The channels are logically 
grouped as pairs (1-2, 3-4, etc.). This governs the mono/stereo status of the 
recorded files and the tracks they will end up on. For example, if you have activated 
the channels 1, 2, and 3, one stereo file (containing channels 1 and 2) and one mono 
file (channel 3) will be created.
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7. Click OK.

8. On the menu below the file format, select Add to Selected Track of 
Montage.

9. Click Set Input, activate the channels from which you want to record, and 
click OK.
For each of the activated recording channels, a meter is displayed in the Recording 
dialog.

10. Optional: Make further settings.

Recording a Multichannel Project

PREREQUISITE 

Prepare a multichannel recording.

PROCEDURE

1. In the montage window, set the edit cursor where you want to start recording.

2. In the Recording dialog, click Record.

3. When you have finished recording, click Stop.
When you record on multiple channels, new tracks are automatically created in the 
audio montage, one for each mono or stereo clip that is recorded. Each track is routed 
to the same output by default, but can be routed to any output that is used in the 
current configuration in the Audio Track Dispatching dialog.

RESULT 

If you have activated more than 2 input channels in the Recording Channels dialog 
and select any channel option except the Multi Mono or Multi Stereo/Mono 
options, the activated recording inputs are mixed and produce a single file (or two 
if you selected Dual Mono).

Multichannel Configurations in the Master Section

The Master Section automatically rearranges itself when starting playback of a 
multichannel audio montage. You can rearrange the Master Section without 
starting playback by clicking Rearrange in the Settings menu at the top of the 
Master Section.

The output channels for the selected channel configuration are displayed in the 
Master Section, with one level fader and clip indicator for each output channel.
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RELATED LINKS

Master Section on page 402

Monitoring a Stereo Mixdown of Multichannel Configurations

In the Master Section, you can monitor a stereo mixdown of a multichannel 
configuration. This allows you to preview a stereo mixdown setting for a DVD-Audio 
project, for example.

PROCEDURE

1. In the Master Section, open the Master Level pane.

2. Below the master meter, click Audio Channel Monitoring.

3. Select Mix to Stereo.

Master Effects and Multichannel Audio Montages

Handling effects for a multichannel audio montage is similar to handling effects 
when working in stereo mode. However, not all plug-ins support multichannel 
operations. In this case, a warning is displayed when you try to insert them.

XML Export and Import of Audio Montages

You can export and import audio montages as XML.

This option can be used for the following:

• Change many file names that are used by the audio montage.

• Generate audio montages from scratch or from a template.
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• Compare two audio montages with a text file comparing tool.

Exporting and Importing XML Files

• To export an audio montage to XML, select File > Export and select Audio 
Montage to XML. Then specify a name and file location, and click Export.

• To import an audio montage that was saved as an XML file, select File > 
Import and select XML. Then select the XML file and click Import.

AES-31 Files Export and Import

The AES-31 standard is an open file interchange format for overcoming format 
incompatibility issues between different audio hardware and software. It can be 
used for transferring projects from one workstation to another, retaining time 
positions of events, fades, etc.

AES-31 uses Broadcast Wave as the default audio file format. AES-31 files can be 
transferred to and used with any digital audio workstation that supports AES-31, 
regardless of the used hardware and software, as long as the workstation can read 
Broadcast Wave files.

The exported files are XML files but with the extension .adl (audio decision list).

Exporting AES-31 Files

When exporting audio montages to an AES-31 file, the file contains all audio track 
data, including audio file references.

PROCEDURE

1. Select File > Export.

2. Click Audio Montage to AES-31.

3. Specify a name and file location, and click Export.

4. In the AES-31 Export Options dialog, edit the settings and click OK.

AES-31 Export Options Dialog

• To open the AES-31 Export Options dialog, select File > Export and select 
Audio Montage to AES-31. Then specify a name and file location, and click 
Export.



Audio Montage
AES-31 Files Export and Import

390

Render Linear Fades as Audio Files

If this option is activated, linear fades, which are dynamically computed by 
WaveLab Pro, are rendered to small audio files while preserving the exact 
audio effect.

Render Curved Fades as Audio Files

If this option is activated, complex fades, which are dynamically computed by 
WaveLab Pro, are rendered to small audio files while preserving the exact 
audio effect.

Render Crossfades as Audio Files

If this option is activated, crossfades, which are dynamically computed by 
WaveLab Pro, are rendered to small audio files while preserving the exact 
audio effect.

Skip Muted Clips

If this option is activated, muted clips are not included in the AES-31 file.

After Exporting, Import File

If this option is activated, the exported file is immediately imported. This lets 
you check the export result.

Importing AES-31 Files

PROCEDURE

1. Select File > Import.

2. Click AES-31.

3. In the file browser, select the AES-31 file that you want to import, and click 
Import.

4. In the AES-31 Import Options dialog, edit the settings and click OK.

RESULT 

The imported AES-31 file opens as a new, untitled audio montage that contains all 
the audio tracks that are saved in the AES-31 file.

AES-31 Import Options Dialog

• To open the AES-31 Import Options dialog, select File > Import and select 
AES-31. Then select the AES-31 file and click Import.

Use Linear Fade Files, If Available (Otherwise, Create Dynamic Fades)

If this option is activated, the available audio files for linear fades are used. If 
no files are available, dynamic fades are created.
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Use Curved Fade Files, If Available (Otherwise, Create Dynamic Fades)

If this option is activated, the available audio files for complex fades are used. 
If no files are available, dynamic fades are created.

Importing AES-31 Files Created in Nuendo

By importing an AES-31 file, you can import a project that was created in 
Steinberg’s Nuendo into WaveLab Pro, for example.

In this case, it is possible to add specific codes to the marker names in Nuendo to 
facilitate their conversion into WaveLab Pro-specific markers. For example, if an 
AES-31 file that was exported in Nuendo is imported into WaveLab Pro, the 
markers that it contains are interpreted as WaveLab Pro markers upon import.

For the CD track markers, you can use the following codes:

• In Nuendo, a marker track must be created for the specific markers.

• When importing AES-31 projects that contain specific markers, the marker 
codes are not displayed in WaveLab Pro.

Marker Type Marker Code Example Marker Name

CD track start [t-start] “So it begins [t-start]”

CD track end [t-end] “The end [t-end] of the road”

CD track splice [t-splice] Intermission [t-splice]

CD track index [t-index] [t-index] Hello
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Recording

You can record audio in the Audio Editor and in the Audio Montage window.

Setting Up the Recording Dialog

Before you start recording, set up the Recording dialog.

PROCEDURE

1. In the Audio Editor or the Audio Montage window, click the Record button, 
or press [*] on the numeric key pad.

2. In the File to Create section, open the pop-up menu, and select whether you 
want to record a named file or a temporary file.

3. In the File to Create section, select a file name and the location where you 
want to save your file.

4. Select the audio format by doing one of the following:
• Click the down arrow button to select a preset audio format.

• Click the audio format text to open the Audio File Format dialog, select the 
format, and click OK.

5. Select whether you want to record to an audio file or an audio montage track, 
by selecting one of the following options:
• Create New Audio File Window

• Add to Active Audio File

• Add to Selected Track of Montage

6. Select an Input mode, depending on whether you want to record the audio 
card input or the playback output of the Master Section.

7. Select Set Input, activate the channels that you want to record to, and click 
OK.
For each of the activated recording channels, a meter is displayed in the Recording 
dialog.

8. Select whether you want the Level or the Spectrum display.

9. Optional: Make further settings in the Options section, and on the Options 
and Values tabs.
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10. Click Record to start recording.
If you have selected one of the Auto-start options, the recording goes into Pause 
mode until the specified Auto-start criteria are met.

The background of the Recording dialog turns red to indicate that you are recording.

11. Optional: Pause the recording by clicking the Pause button.

12. Optional: Drop markers during recording by clicking the drop marker buttons.

13. When you have finished recording, click Stop.

14. Optional: If you want to record another take, click Record again.

Dropping Markers During Recording

When you are recording, you can click the marker buttons to add markers to the 
recorded file.

PROCEDURE

1. Open the Recording dialog.

2. Optional: If you want to name the markers that you drop rather than using 
generic markers, do the following:
• Select the Options tab and activate Confirm Name of Markers to Drop.

• On the Method tab, enter the name in the Next Marker Name field.

3. Make your settings and start recording.

4. Select the type of marker that you want to drop.
• To drop a numbered generic marker, click the yellow marker button, or press 

[Ctrl]/[Command]-M.

• To drop numbered generic region start and end markers, click the white 
buttons, or press [Ctrl]/[Command]-L/[Ctrl]/[Command]-R.

When you chose to confirm marker names to drop, a dialog opens each time that you 
drop a marker. In this dialog, you can enter a name and specify an offset, which allows 
you to place a marker at a specific time before you triggered the command.

RESULT 

The markers are dropped each time that you click the marker button.

NOTE

If you insert two or more region start markers in a row with no region end markers 
in between, only the last of these start markers is kept. The same applies for region 
end markers.
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Recording Dialog

In this dialog, you can make recording settings and start recording an audio file.

• To open the Recording dialog, open the Audio Editor or the Audio Montage 
window, and on the transport bar, click Record.

Main Buttons

Record

Starts recording. Depending on the recording options, the Pause mode is 
activated.

Split Now

Opens the audio already recorded in a new window while recording 
continues. By clicking this button, you can decide when the file is split. The 
button is activated if you are recording a named file, you are not pausing, and 
Split Mode is not activated.

Pause

Pauses recording.

Stop

Stops recording.

Discard

Stops recording and deletes anything recorded so far.

Method Tab

On this tab, you can define options for starting, stopping, and pausing the recording 
automatically. You can select an input device and choose to start a recording at a 
specific time or stop if after a specific duration.
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File to Create

Specify whether you want to record a temporary file to be saved later, or 
record to a file with a specific name and location.

Auto Number From

If this option is activated and you record multiple files, increasing numbers are 
added to the file names of the files.

Name

The name of the file to be written, without the path. When typing, all files in 
the selected folder that start with the same letters are displayed. To display all 
files in the selected folder, click the list icon.

Location

Specifies the folder where you want to save the recording.

Audio File Format

Opens the Audio File Format dialog, where you can specify the file format.

Location of the Recording

Specifies where the audio is recorded:

• If Create New Audio File Window is selected, the audio is recorded in 
a new audio file window.

• If Add to Active Audio File is selected, the audio is recorded in the 
active audio file window at the edit cursor position (if no audio file 
window exists, a new one is created).

• If Add to Selected Track of Montage is selected, the audio is recorded 
in an existing audio montage at the edit cursor position (if no audio 
montage exists, a new one is created).

Input

Specify if you want to record the audio device input or the audio output from 
the Master Section.

Set Input

If you are using an ASIO driver, this button opens the Recording Channels 
dialog, where you can activate channels for recording. Up to 8 input channels 
can be used simultaneously. When additional inputs are selected, the number 
of meters in the dialog is automatically updated.
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Auto-Start if Sound Detected

If this option is activated, recording starts when the audio input level exceeds 
the threshold level specified on the Values tab.

Auto-Start at given Time

If this option is activated, recording starts at a specified time. Specify the time 
on the Values tab.

Auto-Stop after given Duration

If this option is activated, recording stops automatically after the duration 
specified on the Values tab.

Auto-Stop if Silence

If this option is activated, recording automatically stops when the audio input 
level drops below a specified threshold level and stays there for a specific 
amount of time. Specify the level and the duration on the Values tab.

Auto-Pause if Silence

If this option is activated, recording automatically pauses when the audio input 
level drops below a specified threshold level and stays there for a specific 
amount of time. Specify the level and the duration on the Values tab.

Auto-Create Markers at Pause Point

If this option is activated, a generic marker is created each time you click 
Pause during recording.

Auto-Create Markers at Silence Points

If this option is activated, a generic marker is created each time the audio input 
level drops below a specified threshold level and stays there for a specific 
amount of time. Specify the level and the duration on the Values tab.

Split Mode

If this option is activated, the recording is split into several audio files. The files 
can be split either by size, that is, after a specific amount of MB, or by duration, 
that is, after a specific amount of time. Split Mode is useful if you make long 
continuous audio recordings, such as live recordings.

• This option is only available when Named File is selected.

• Split files are contiguous, that is, there are not gaps between the files.

• Selecting Split Mode automatically activates the Auto Number option 
for audio file names.

NOTE

It is recommended to save each Split Mode recording in an empty folder. This 
prevents the Auto Number option from creating files with names that already 
exist in this location.
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Options Tab

On this tab, you can make additional settings for the recording process.

Activate Monitoring When Opening Record Window

If this option is activated, the meters are activated when the Recording dialog 
opens. If this option is deactivated, the meters and the audio thru are 
displayed when pressing Record or activating Monitor.

Deactivate Monitoring When Ending Recording

If this option is activated, the meters and the audio thru are deactivated when 
recording ends. This releases the audio device input.

Stop Playback When Monitoring or Recording

If this option is activated, playback stops before monitoring or recording 
starts.

Show Discard Button

Determines whether the Discard button is visible or hidden.

Confirm when Discarding Recording

If this option is activated, you are asked to confirm before discarding a 
recording.

Confirm when Stopping Recording

If this option is activated, you are asked to confirm before stopping a 
recording.

Confirm Name of Markers to Drop

If this option is activated, you are asked to enter a name for the last dropped 
marker.

Open Audio File in WaveLab Pro after Recording

If this option is activated, the audio files are opened in WaveLab Pro after 
recording.

Add Markers when Inserting Recording in Audio File

If this option is activated and a recording is inserted into an audio file, markers 
are added encompassing the new samples.

After Recording, Move Edit Cursor at the End

If this option is activated, the edit cursor is moved to the end of the recording.
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Values Tab

On this tab, you can define values for the various recording options.

Auto-Start on Sound – Threshold (RMS)

Specify the sound level that will trigger recording.

Auto-Start on Sound – Record Previous Samples

Allows you to include a short section of audio before the start point, to capture 
attacks, for example. It is only relevant if Auto-Start if Sound Detected is 
activated.

Silence Detection – Threshold (RMS)/Silence Duration Required

The threshold value used for the options Auto-Stop if Silence and 
Auto-Create Markers at Silence Points. It is used in conjunction with the 
Silence Duration Required setting, so that recording is stopped or a marker 
is added if the input level stays below the threshold value for the specified 
duration.

Recording Programming – Start

Determines the time at which recording starts when the option Auto-Start at 
Specific Time is activated.

Recording Programming – On Tomorrow

If this option is activated, you can specify a time on the next day (starting 
midnight).

Recording Programming – Duration

Determines the length of the recording if Auto-Stop after Specific Duration 
is activated.

Split Argument – File Size

If this option is activated, a new file is created when the recorded file reaches 
the size specified in the corresponding value field.

Split Argument – File Duration

If this option is activated, a new file is created when the recorded file reaches 
the length specified in the corresponding value field.



Recording
Recording Dialog

399

Pause Memory

This is a safety buffer when you are using the Pause button. When you 
resume recording, this buffer is used to restore the last short section of audio 
before you deactivated the Pause button. This way, you can resume 
recording even if you deactivated the Pause button a bit too late.

Meter Display

Level/Spectrum

Specifies which meter to display.

Settings

Opens the Level/Pan Meter Settings dialog, where you can customize the 
meter settings.

Reset

Resets the peak values.

Monitor

If this option is activated, the audio input is also sent to the output ports (not 
available if Windows MME drivers are used).

Mix with Playback

If this option is activated and the same audio ports are selected for monitoring 
and for playback (in the VST Audio Connections tab), the signals are mixed. 
If this is not activated, the monitoring signal has priority.

This allows you to toggle between the auditioning of the recorded signal and 
the playback signal, and to have full control over the monitor outputs.

Marker

Allows you to set markers during the recording.

Next Marker Name

Edit the name of the next marker to insert.

Solo

Reduces/Increases the size of the window and hides/shows all other 
WaveLab Pro windows.
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Meter Display

In the lower part of the Recording dialog, you find a meter display. This is useful for 
checking the input level and the frequency spectrum of the input signal.

The meters in the Recording dialog are miniature versions of the Level Meter and 
Spectrometer windows. Activate the meters by activating the Monitor 
checkbox.This is done automatically if Activate Monitoring when Opening Record 
Window is activated on the Options tab in the Recording dialog.

To reset the meters, click the Reset button.

Level Meter

In the Level Meter, horizontal bars show the peak level (outer bars) and average 
loudness (VU, inner bars) of each channel. Values are also shown numerically. 
When you click the Settings button, the Level/Pan Meter Settings dialog opens.

Spectrometer

The Spectrometer shows a bar diagram, providing a continuous graphical 
representation of the frequency spectrum. From the Settings pop-up menu you can 
choose whether to restrict to high audio levels, or to include medium or low audio 
levels.

Disk Capacity Indicator

This indicator at the bottom of the Recording dialog indicates the approximate 
amount of available disk space on the hard disk specified in the File to Create 
section, or the hard disk that you have selected for temporary files.

NOTE

When there is less than 30 seconds of available hard disk space left, the disk 
capacity indication is displayed in red.

Recording in the Audio Montage Window

You can record audio as clips in the audio montage.
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Recording from the Cursor Position

PROCEDURE

1. In the Audio Montage window, click at the position where you want the 
recorded clip to start.

2. To the left of the track, open the Track pop-up menu.

3. Select Record at Cursor.

4. In the Recording dialog, make your settings.

5. Click Record.

Recording During Playback

PROCEDURE

1. In the Audio Montage window, start playback.

2. Select Track > Record at Cursor.

3. In the Recording dialog, make your settings.

4. Click Record.

NOTE

If you first go into Pause mode and then activate recording, you get a pre-roll time 
according to the pause buffer, allowing you to capture the audio just before you start 
recording.

Playing Back During Recording

When you record in a multitrack environment, it is often necessary to have the 
existing track play back during recording, performing an overdub.

For this to be possible in the audio montage, Stop Playback when Monitoring or 
Recording must be deactivated on the Options tab of the Recording dialog.



402

Master Section

The Master Section is the final block in the signal path before the audio is sent to 
the audio hardware, to an audio file, or to the audio meters. This is where you adjust 
the master levels, add effects, resample, and apply dithering.

The settings and effects in the Master Section are taken into account in the 
following cases:

• When playing back an audio file in the wave window.

• When playing back an audio montage. Note that the Master Section effects 
are global for all clips and tracks in an audio montage.

• When using the Render function.

• When using the Audio Input plug-in.

• When writing a CD from an audio montage.

By default, the Master Section is active. You can turn it off for each file individually 
by deactivating the Bypass Master Section button at the bottom of the 
wave/montage window.

To turn the Master Section off globally, deactivate the Bypass Master Section 
button at the top left of the Master Section.

Master Section Window

In this window, you can apply effect plug-ins, adjust the master level, apply 
dithering, and render the audio file or audio montage.

• To open the Master Section window, select Tool Windows > Master 
Section.
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The Master Section consists of the following panes:

• Effects

• Resampling

• Master Level

• Final Effects/Dithering

• Playback Processing

• Speaker Configuration

Signal Path

The panes in the Master Section window correspond to the processing blocks of 
the Master Section.

The signal passes through these blocks from top to bottom:
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In the Master Section, the signal passes all plug-ins, even if some plug-ins are 
soloed. However, the sound is not affected by this because the muted plug-ins are 
bypassed from the playback process stream.

The Master Section meters monitor the signal directly after a particular slot if 
Monitoring Point is activated for this slot.

Master Section Tools

The tools and options at the top of the Master Section window allow you to make 
various settings before rendering the file, make bypass settings, and decide 
whether the playback signal passes the Master Section.
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Bypass Master Section

If this option is deactivated, the Master Section is ignored during playback. 
However, rendering to file is still possible. If playback is activated when you 
change this option, it stops and restarts.

Presets

Lets you save and recall Master Section presets. The Presets menu offers 
additional options to save and load default banks and effects.

Smart Bypass

Opens the Smart Bypass dialog, where you can make special bypass 
settings.

Reset Master Section

Removes all active effects from the slots and sets the master output to 0 dB.

Settings

Opens the Settings pop-up menu, where you can make settings for the 
Master Section.

Settings Pop-up Menu

Hide Plug-in Windows when Master Section is not Visible

If this option is activated, plug-in windows are hidden when the Master 
Section is not visible.

Show Plug-in Controls in the Plug-in Window

If this option is activated, the plug-in controls are displayed in plug-in 
windows.

Use Plug-in Chain Window

Shows all open plug-ins in the plug-in window as tabs, which allows you to 
quickly switch between the plug-ins.

Plug-in Windows Move with Master Section

If this option is activated, the plug-in windows are also moved when you move 
the floating Master Section.

Restore Last Configuration at Next Start-Up

If this option is activated, the plug-in configuration and fader positions in the 
Master Section are restored at the next WaveLab Pro start.

Section Visibility

Allows you to show or hide the Master Section sections.

Monitor 16 bit Dithering

Allows you to hear what the effect of the dither plug-in sounds like during 
playback. You can try different dither plug-ins, to find out which one has the 
best dither effect on the audio.
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Rearrange

Rearranges the Master Section according to the sample rate and channel 
configuration of the active audio file. The internal bus of the Master Section 
and any active plug-ins are configured accordingly.

This operation is performed automatically before playback or rendering. It is 
sometimes helpful to manually rearrange the Master Section, because some 
plug-ins do not accept a mono or stereo signal as input, or a given sample 
rate. In that case, clicking the button informs you about any problems, before 
playback or rendering.

This operation has no effect if playback is already in progress or if there is no 
active audio file.

RELATED LINKS

Final Effects/Dithering Pane on page 416

Effects Pane

This pane in the Master Section allows you to add up to 12 effect plug-ins in series, 
and manage them.

Fold/Unfold Pane

Expands or collapses the pane.

Bypass All Effects

Bypasses any effect processing during playback and optionally when 
rendering.

Add Effect

Allows you to add an effect to an empty effect slot.

Channel Processing

Allows you to specify how a VST plug-in processes the stereo stream. You 
can process all channels or only the left, right, mid, or side channel. This 
allows any VST plug-in to become mid/side capable.

Monitoring Point

Lets the Master Level meter monitor the signal directly after this plug-in.

Effect plug-in name

Once you have added a plug-in to a slot, you can click the plug-in name to 
open and close the corresponding plug-in window.
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Presets pop-up menu

Lets you save and recall preset settings. The Presets pop-up menu offers 
additional options to save and load default banks and effects.

Effect Options pop-up menu

Allows you to load another effect to the effect slot. Furthermore, the following 
options are available:

• Remove Plug-in removes the effect from the slot.

• Shift All Plug-ins Down/Shift All Plug-ins Up allows you to move the 
effects to another position.

• If Active is activated, the effect is active. If Active is deactivated, the 
effect is excluded from playback and rendering.

• If Lock is activated, the effect slot is locked. The plug-in in the slot 
remains as is when a Master Section preset is loaded, or when Reset 
Master Section is used.

Solo (Bypass)

Soloes the plug-in.

Bypass Processing

Bypasses the plug-in during playback and optionally during rendering. The 
signal is still processed by the plug-in, but is not injected in the audible 
stream.

Supported Effect Plug-in Formats

WaveLab Pro supports different plug-in standards. WaveLab Pro-specific plug-ins, 
VST 2 plug-ins  and VST 3 plug-ins.

WaveLab Pro-specific Plug-ins

Some specific plug-ins are included in WaveLab Pro, for example, the Audio Input 
and External Gear plug-ins. These are only available if you are using an ASIO driver.

VST Plug-ins

Steinberg’s VST plug-in format is supported by a lot of programs and plug-in 
manufacturers. You find a number of VST plug-ins included with WaveLab Pro. 
Other plug-ins can be purchased separately from Steinberg or other manufacturers.

Setting Up Effects

The number of available effects depends on the number and format of the plug-ins 
that you have installed.
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• To select an effect plug-in for a slot, click the slot, and select an effect from 
the pop-up menu. When you have selected an effect, it is automatically 
activated, and its control panel opens.

• To turn off an effect, right-click the slot, and deactivate Active. To activate the 
effect, activate Active again.

• To remove an effect plug-in, right-click the slot and select Remove Plug-in 
from the pop-up menu.

• To show/hide a plug-in window, click the effect slot.

• To solo an effect, click its Solo (Bypass) button. This allows you to check the 
sound of that effect only. You can also bypass effects via their control panels.

• To change the order of the slots, that is, the order in which the signal passes 
through the effects, click a slot, and drag it to a new position.

Master Section Plug-in Window

In the plug-in windows of the Master Section, you can make settings for a Master 
Section effect plug-in.

• To show/hide a plug-in window, click the effect slot.

Plug-in Chain

If Use Plug-in Chain Window is activated on the Settings pop-up menu of 
the Master Section, the effects of the active audio file are displayed in a 
plug-in chain at the top of the plug-in window.

You can right-click a plug-in tab or an empty tab to select a new plug-in for 
the slot.

Bypass Processing

If this option is activated, this plug-in is bypassed during playback, and 
optionally for a rendering operation. To deactivate an effect when rendering, 
right-click an effect slot, and deactivate Active in the Effects pane of the 
Master Section.

Bypass Modes

Right-click Bypass Processing to open the Bypass Modes pop-up menu. 
Here, you can select Bypass Effect or Bypass Source Signal.
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Channel Processing

Allows you to specify how a VST plug-in processes the stereo stream. You 
can process all channels or only the left, right, mid, or side channel. This 
allows any VST plug-in to become mid/side capable.

Solo (Bypass)

Soloes the plug-in.

Render in Place

Processes the audio in place. Bypassed plug-ins are excluded and the 
rendered audio is crossfaded at boundaries.

Monitoring Point

If this option is activated, the Master Level meters monitor the signal directly 
after this plug-in.

Switch Effect On/Off

If you deactivate a plug-in, it is excluded from both playback and rendering.

Presets

Opens a menu to save/load presets for this plug-in.

Effect Plug-in Presets

With WaveLab Pro comes a number of factory presets for the included effect 
plug-ins. You can use them as they are or as a starting point for your own settings.

Third-party plug-ins can provide their own factory presets. To access the presets 
for an effect, click the Presets button in its control panel window or the Presets 
button for its effect slot. The available functions depend on the type of plug-in.

Presets for VST 2 Plug-ins

VST 2 plug-ins have their own preset handling.

When you click the Presets button for this type of effect, a pop-up menu with the 
following options opens:

Load/Save Bank

Loads and saves complete sets of presets. The file format is compatible with 
Cubase.

Load/Save Default Bank

Loads the default set of presets or saves the current set of presets as the 
default bank.
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Load/Save Effect

Loads or saves a preset. This is also compatible with Cubase.

Edit Name of Current Program

Allows you to define a name for the preset.

Preset List

Allows you to select one of the loaded presets.

Channel Processing

In the Master Section, in plug-in windows, and in the Effects window, you can 
specify for each plug-in which channels to process. This allows you to use each 
plug-in in mid/side mode, for example.

You can process all channels or only the left, right, mid, or side channel. When you 
select one channel, the other channel is bypassed.

To use a different plug-ins for each channel, use one effect slot for each channel.

Insert

Stereo

All channels are processed by the plug-in.

Left

Only the left channel is processed by the plug-in.

Right

Only the right channel is processed by the plug-in.

Mid

Only the mid channel is processed by the plug-in.

Side

Only the side channel is processed by the plug-in.

Send (Return to Stereo)

Left

Only the left channel of the plug-in is processed. The left wet signal of the 
plug-in is mixed to the left/right dry signal.

Right

Only the right channel of the plug-in is processed. The right wet signal of the 
plug-in is mixed to the left/right dry signal.
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Mid

Only the mid channel of the plug-in is processed. The mid wet signal of the 
plug-in is mixed to the mid/side dry signal.

Side

Only the side channel of the plug-in is processed. The side wet signal of the 
plug-in is mixed to the mid/side dry signal.

Setting Up the Channel Processing

You can set up which channel to process in the Master Section, in plug-in 
windows, and in the Effects window.

Channel Processing in the Master Section

In the Master Section, on the Effects pane, click Channel Processing, and select 
which channel you want to process.

Channel Processing in Plug-in Windows

In a plug-in window, click Channel Processing and select which channel you want 
to process.
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Channel Processing in the Effects Window

In the Effects window, click in the Channel Processing column for a plug-in and 
select which channel you want to process.

Resampling Pane

This pane in the Master Section allows you to resample the signal. With the 
Resampling plug-in, you can check the peaks before the master gain and meters, 
and before limiting and dithering.

You can select one of the common sample rate values or create custom sample rate 
values via the Customize Sample Rate Menu dialog.

Fold/Unfold Pane

Expands or collapses the pane.

Off

Deactivates the resampling effect.

Use Preferred Sample Rate

If this option is activated, resampling matches the sample rate that is specified 
as the preferred sample rate on the VST Audio Connections tab.

NOTE

The sample rate is used for playback only. This allows you to play back sample 
rates that your audio device does not support.

Monitoring Point

Lets the Master Level meter monitor the signal directly after this plug-in.
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Sample Rate menu

Allows you to select a sample rate. You can select one of the common sample 
rates or click Customize to open the Customize Sample Rate Menu dialog, 
where you can specify custom sample rates. The selected sample rate is used 
for playback and rendering.

RELATED LINKS

VST Audio Connections Tab on page 13
Customize Sample Rate Menu on page 413

Customize Sample Rate Menu

The Customize Sample Rate Menu dialog allows you to customize the available 
sample rate values for the sample rate pop-up menu of the Resampling pane. You 
can add common sample rate values to the menu or create custom sample rates.

• To open the Customize Sample Rate Menu dialog, open the Resampling 
pane in the Master Section window, click the sample rate, and select 
Customize.

Add Common Sample Rate to Menu

Adds the selected sample rate to the sample rate pop-up menu.

Remove Sample Rate from Menu

Removes the selected sample rate from the sample rate pop-up menu.

Add Custom Sample Rate

Opens the Custom Sample Rate dialog, where you can specify custom 
sample rate values.

Master Level Pane

This pane in the Master Section allows you to control the master level of the active 
audio file.
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Faders

The faders in the Master Level pane govern the final output level. Use the faders to 
optimize the level of the signal that is sent to the audio hardware.

NOTE

It is important to avoid clipping, especially when mastering. Clipping is indicated by 
the clip indicators of the Master Section.

• To lock the faders, activate Lock Faders below the fader section.

Locked faders cannot be changed with the mouse. Other editing methods, for 
example via remote control or shortcut, are still possible.

Meters

The Master Section meters show the signal level of the signal before dithering or 
any other plug-in that you have applied post-master fader.

Use these meters to get an overview of the signal levels. The numeric fields above 
the faders show the peak levels for each channel. The peak indicators turn red 
whenever the signal clips. If this happens, you should do the following:

• Lower the faders.

• Right-click the clip indicators and select Reset Peaks to reset the clip 
indicators.

• Play back the section again until no clipping occurs.

NOTE

For critical level metering, we recommend using the Level Meter. It is more precise, 
and it is applied after the whole Master Section (after dithering) and therefore 
shows the actual signal level that is sent to the audio hardware.
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Mixing Stereo Channels into Mono Channels and Multichannel into Stereo

The options on the Audio Channel Monitoring pop-up menu allow you to transform 
the left and right channels of a stereo track into two mono channels or surround 
channels to stereo channels. The output level is automatically reduced by -6 dB to 
avoid clipping. This is useful for checking the mono compatibility of stereo mixes or 
stereo compatibility of surround mixes. You can also render the channels into a 
mono file.

Default Channels

The default channels.

Mix to Mono

Mixes the stereo channels into mono channels.

Mix to Mono (L-R)

Mixes the stereo channels into mono channels and removes the right channel 
from the left channel. If both channels are the same, you hear silence. This 
allows you to check if the audio is true mono.

Left Channel Only

Mixes the left stereo channel into two mono channels.

Right Channel Only

Mixes the right stereo channel into two mono channels.

Mid Channel Only

Mixes the mid stereo channel into two mono channels.

Side Channel Only

Mixes the side stereo channel into two mono channels.

Mix to Stereo

If you have a surround setup with more than two channels, you can mix the 
surround channels to stereo.

NOTE

If another option than Default Channels is selected on the Audio Channel 
Monitoring pop-up menu, the indicator for the Master Level pane is lit, even if the 
master level is not adjusted. This helps you avoid accidentally using audio channel 
monitoring.

Unlink Faders Button

Determines whether you can adjust the faders individually or together.

If Unlink Faders is deactivated, moving one fader also moves the other by the same 
amount. Activating Unlink Faders allows you to correct improper stereo balancing 
by adjusting the level of the channels individually.
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If you offset the faders with Unlink Faders activated and then deactivate Unlink 
Faders, you can adjust the overall level without changing the level offset between 
the channels.

Fader offsets are not preserved at the end of the range of movement or once the 
mouse button is released.

True Peak Analyzer Button

If True Peak Analyzer is activated, the analog reconstructed peaks (true peaks) are 
displayed in the Master Level meter. If this button is deactivated, the sample values 
(digital peaks) are displayed.

Final Effects/Dithering Pane

This pane in the Master Section allows you to add final effects and dithering to the 
signal before it is sent to the audio hardware or saved as a file on disk.

Fold/Unfold Pane

Expands or collapses the pane.

Bypass All Effects

Bypasses the effects in the Final Effects/Dithering pane.

Monitoring Point

Lets the Master Level meter monitor the signal directly after this plug-in.

Presets pop-up menu

Lets you save and recall preset settings. The Presets pop-up menu offers 
additional options to save and load default banks and effects.

Effect Options pop-up menu

Allows you to load another effect to the effect slot. Furthermore, the following 
options are available:

• Remove Plug-in removes the effect from the slot.

• Shift All Plug-ins Down/Shift All Plug-ins Up allows you to move the 
effects to another position.

• If Active is activated, the effect is active. If Active is deactivated, the 
effect is excluded from playback and rendering.

• If Lock is activated, the effect slot is locked. The plug-in in the slot 
remains as is when a Master Section preset is loaded, or when Reset 
Master Section is used.
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Bypass Processing

Bypasses the plug-in during playback and optionally during rendering. The 
signal is still processed by the plug-in, but is not injected in the audible 
stream.

Dithering

Dithering is the technique of adding small quantities of noise to a signal to reduce 
the audibility of low level distortion in a digital recording. A small amount of random 
noise is added to the analog signal before the sampling stage, reducing the effect 
of quantization errors.

By adding a special kind of noise at an extremely low level, the quantization errors 
are minimized. The added noise can be perceived as a very low-level quiescent hiss 
added to the recording. However, this is hardly noticeable and preferred to the 
distortion that occurs otherwise. The Noise Shaping options allow you to filter this 
noise to a frequency area less sensitive to the human ear.

In WaveLab Pro, dithering is applied when reducing the number of bits in a 
recording, for example, when moving from 24 to 16 bits, and when applying 
processing. You can choose between WaveLab Pro’s internal dithering algorithm, 
Izotope’s MBIT+ algorithm, or any external dithering plug-in.

NOTE

Dithering should always be applied after the output bus fader stage, and after any 
kind of audio process.

RELATED LINKS

Internal Dithering on page 817

Dithering Plug-ins

WaveLab Pro comes with two dithering plug-ins: Internal dithering and the MBIT+ 
dithering. However, you can also add other dithering plug-ins.

• To select and activate a dithering plug-in in the Master Section, click the 
plug-in slot in the Final Effects/Dithering pane, and select one of the options 
from the pop-up menu.

• To deactivate the dithering plug-in, open the Final Effects/Dithering pop-up 
menu, and select Remove Plug-in.

RELATED LINKS

Internal Dithering on page 817

Adding Other Plug-ins to the Final Effects/Dithering Pane

If you want to use another dithering plug-in than the internal or UV22HR dithering, 
you can add it to the Final Effects/Dithering pane.
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NOTE

The meters in the Master Section monitor the signal before the Final 
Effects/Dithering pane. To avoid clipping, check the level/pan meter and adjust 
the output level of the plug-in, if available.

PROCEDURE

1. Select File > Preferences > Plug-ins.

2. Select the Organize tab.

3. Locate the plug-in that you want to add to the Final Effects/Dithering pane 
in the list, and activate the checkbox in the Final column for the plug-in.

RESULT 

The plug-in is available via the pop-up menu in the Final Effects/Dithering pane, 
and can be inserted after the Master Level faders. The plug-in is still available for 
selection as a regular pre-master effect if the corresponding entry in the Effect 
column in the Plug-ins Preferences is activated.

When to Apply Dithering

The basic rule is that you should apply dithering when converting an audio file to a 
lower resolution. For example, preparing a 24-bit file for mastering to CD, that uses 
16-bit format.

However, even if you are playing back or rendering a 16-bit or 24-bit file to the same 
resolution, you need to apply dithering if you are using any real-time processing in 
WaveLab Pro. The reason for this is that WaveLab Pro works with an internal 
resolution of 32 bit (floating point) for supreme audio quality. This means that as 
soon as you perform any kind of processing, the audio data is treated at this high 
resolution instead of the original 16 bit or 24 bit, thus making dithering necessary.

Examples of real-time processing include level adjustments, effects, mixing of two 
or more clips in an audio montage, etc. The only time when a 16-bit file is played 
back at 16-bit resolution is if you play it without any fades or effects, and with the 
Master Level faders set to 0.00 (no level adjustment – master level indicator turned 
off).

NOTE

To check whether you need to apply dithering, use the Bit Meter to see the actual 
resolution of your audio signals.

RELATED LINKS

Bit Meter on page 479

Testing the Quality of the Dithering Plug-ins

In the Master Section, you can compare the quality of different dithering plug-ins, 
by making the quantization noise and the dithering signal more audible.
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• To activate this option, click Settings  at the top of the Master Section, and 
activate Monitor 16 Bit Dithering.

Now, when you activate a dither plug-in and play back an audio section, you can 
hear what the effect of the dither plug-in sounds like. You can try out different 
dithering plug-ins, to find out which one has the best effect on the audio.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

Make sure to deactivate Monitor 16 Bit Dithering when you are done testing the 
dithering quality.

NOTE

Only dither to 16 bit, otherwise the result does not have any meaning.

Playback Processing Pane

This pane in the Master Section contains the Encoder Checker that allows you to 
compare audio encoders. You can also add your own plug-ins to the Playback 
Processing slots.

NOTE

The plug-ins in the Playback Processing pane are only part of the playback 
processing. It is not applied when rendering files or CDs.

Fold/Unfold Pane

Expands or collapses the pane.

Bypass All Effects

Bypasses the effects in the Playback Processing pane.

Monitoring Point

Lets the Master Level meter monitor the signal directly after this plug-in.

Effect Options pop-up menu

Allows you to add an effect to the effect slot. You can load your own plug-ins 
or use the included Encoder Checker. Furthermore, the following options are 
available:

• Remove Plug-in removes the effect from the slot.

• Shift All Plug-ins Down/Shift All Plug-ins Up allows you to move the 
effects to another position.

• If Active is activated, the effect is active. If Active is deactivated, the 
effect is excluded from playback and rendering.
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• If Lock is activated, the effect slot is locked. The plug-in in the slot 
remains as is when a Master Section preset is loaded, or when Reset 
Master Section is used.

Presets pop-up menu

Lets you save and recall preset settings. The Presets pop-up menu offers 
additional options to save and load default banks and effects.

Bypass Processing

Bypasses the plug-in during playback and optionally during rendering. The 
signal is still processed by the plug-in, but is not injected in the audible 
stream.

RELATED LINKS

Plug-ins Preferences on page 672

Encoder Checker

The Encoder Checker plug-in allows you to compare the quality between different 
audio encoders. It is applied in the Playback Processing pane of the Master 
Section.

With the Encoder Checker you can find the best settings for your encoders and 
test the effect of other plug-ins on the compression. The Encoder Checker is only 
used for playback and is bypassed during audio file rendering.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

The Encoder Checker does not support multichannel audio montages.

NOTE

The more encoders are selected in the Encoder Checker dialog, the more CPU 
power is used. Also, the more audio compression is applied to the audio file, the 
higher the latency. The latency is determined by the encoder with the highest 
latency.

Checking the Quality of Encoded Audio Files

PROCEDURE

1. Open the audio file that you want to check in different encoding qualities.

2. In the Master Section, right-click the effect slot in the Playback Processing 
pane, and select Steinberg > Encoder Checker.

3. In the Encoder Checker, click in the first numbered field and select a factory 
preset or select Edit to specify a custom audio file format.

4. Optional: Specify more audio file formats.

5. Play back the audio file.
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6. Click Original Sound and the number icons to compare the sound of the 
original audio with the sound of the encoders.
If the Encoder Checker window is active, you can also press the [1], [2], and [3] keys 
on your keyboard to switch between the encoders and click [.] to select the original 
sound.

NOTE

If you select or edit an encoder, the plug-in synchronizes the new encoder settings 
with the other active encoders and the original sound. This can result in short audio 
artifacts.

AFTER COMPLETING THIS TASK 

If you have found the best encoder, click Render to render the audio file to the 
selected audio file format. You can also click Batch Processor to open the Batch 
Processor window with an audio file format preset that corresponds to the selected 
encoder.

Checking the Quality of Encoded Audio Files Using the Blind Modes

To make sure that you only rely on your ears when checking the encoder quality, you 
can use the Blind modes to compare the encoders without knowing which encoder 
is playing.

PROCEDURE

1. Open the audio file that you want to check in different encoding qualities.

2. In the Master Section, right-click the effect slot in the Playback Processing 
pane, and select Steinberg > Encoder Checker.

3. In the Encoder Checker, click in the first field and select a factory preset or 
select Edit to specify a custom audio file format.

4. Optional: Specify more audio file formats.

5. Do one of the following:
• To compare only the encoders, activate Blind (Encoders). For this function, at 

least 2 encoders must be selected.

• To compare the encoders and the original sound, activate Blind (Encoders + 
Original Sound).

6. Play back the audio file.

7. Use the up/down or left/right arrow keys to switch between the encoders.

8. Use the + and - keys to rate the encoder that you are listening to.

9. Deactivate Blind mode.
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RESULT 

The encoder that you have heard last is highlighted and you can see the ratings of 
the encoders.

AFTER COMPLETING THIS TASK 

If you have found the best encoder for your needs, click Render to render the audio 
file to the selected audio file format.

Encoder Checker Dialog

In this dialog, you can compare the quality of different audio encoders.

• To open the Encoder Checker dialog, right-click the effect slot in the 
Playback Processing pane, and select Steinberg > Encoder Checker.

Display

Displays the spectrum (FFT) of the original sound (green) and of the selected 
encoder (red). This gives you a rough estimation of the effects that the 
encoder has on the audio spectrum.

Switch indicator LED

In the Blind modes, this LED lights up each time that a new encoder is 
selected via the arrow keys.

Blind (Encoders)

If this option is activated, the original sound is selected. When you use an 
arrow key, a random encoder is used. You can use the arrow keys to switch 
between the selected encoders without being able to see which encoder is 
selected.

You can use the + and - keys to rate the encoder that you are listening to. The 
rating results are displayed when you deactivate Blind mode.
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Blind (Encoders + Original Sound)

If this option is activated, a random encoder or the original sound is selected. 
You can use the arrow keys to switch between the selected encoders and the 
original sound without being able to see which one is selected.

You can use the + and - keys to rate the encoder that you are listening to. The 
rating results are displayed when you deactivate Blind mode.

Freeze Display

If this option is activated, the FFT display freezes.

Original Sound

Lets you hear the original audio file during playback.

Presets

Lets you select different audio encoders and switch between them during 
playback.

Rating

Shows the number of plus and minus marks that were set during the Blind 
modes.

Compression

The real-time estimation of the audio compression ratio with a 16-bit file size 
as reference.

Latencies

The first latency value indicates how long you have to wait until you hear the 
new encoder when you select another encoder. The second latency value 
indicates the delay when switching between encoders.

Batch Processor

Opens the Batch Processor window with an audio file format preset that 
corresponds to the audio file format that is being monitored.

Render

Opens the Render dialog with an audio file format preset that corresponds to 
the audio file format that is being monitored.

Speaker Configuration Pane

This pane of the Master Section allows you to select the speaker configurations. 
The speaker configurations are set up in the VST Audio Connections.

Fold/Unfold Pane

Expands or collapses the pane.
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Speaker Configuration

Lets you select eight different speaker configurations.

VST Audio Connections

Opens the VST Audio Connections, where you can set up the speakers for 
the speaker configuration buttons.

Speaker Gain

Lets you edit the gain of the speaker configuration. Positive gains are 
indicated by a red LED, and negative gains are indicated by an orange LED. 
When the gain is zero, the LED is dark green (off). The gain is not rendered to 
file.

RELATED LINKS

Speaker Configuration on page 127
VST Audio Connections Tab on page 13

Rendering

By rendering the effects using the Render function in the Master Section, they 
become a permanent part of a file. So instead of performing all processing in 
real-time during playback, you can save the audio output to a file on disk.

You can render to a single file format or to multiple audio file formats.

Writing the output of the Master Section to a file on disk allows you to apply 
Master Section processing to an audio file, or mix down an audio montage to an 
audio file. In case of a multichannel audio montage, several files can be created, one 
for each channel in the selected configuration.

There are several uses for rendering:

• Mix down a complete audio montage to an audio file.

• Process a file and save a file to a new audio file, including Master Section 
effects, dithering, and other settings. You can choose the format of the new 
audio file, which allows you to create an MP3 file and add effects at the same 
time, for example.

• Process one or more regions of an audio file in place or to new files.

Multiple File Format Rendering

You can render to multiple audio file formats simultaneously. To do so, you must first 
create file format presets for these formats.

You can also create multiple audio file format presets. These are a list of single file 
format presets.
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Rendering Files

You can render to a single file format or to multiple file formats.

PREREQUISITE 

Set up your audio file or audio montage. If you want to render to multiple file formats, 
create the necessary audio file format presets.

PROCEDURE

1. In the Master Section, make your settings.

2. On the bottom of the Master Section, click Render.

3. Do one of the following:
• To render a single file, click Single.

• To render multiple files, click Multi.

4. Make your rendering settings.

5. In the Result section, activate Named File.

6. Click the Format field and do one of the following:
• To render to one audio format, select Edit Single Format, and make your 

settings in the Audio File Format dialog.

• To render to multiple file formats, select Edit Multi Format, and in the Multi 
Audio File Format dialog, click Add , and select the file format presets that 
you want to render to.

7. Click OK.

8. When you have set up the rendering process, click Start.

RESULT 

The file is rendered. You can see the progress in the Tasks window.

NOTE

Several rendering operations can be performed at the same time when using 
different files.

RELATED LINKS

Audio File Format Dialog on page 155
Multi Audio File Format Dialog on page 426
Creating Single Audio File Format Presets on page 426
Creating Multiple Audio File Format Presets on page 426
Tasks Window on page 442
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Creating Single Audio File Format Presets

PROCEDURE

1. In the Audio File Format dialog, specify the audio file format.

2. Open the Presets pop-up menu and select Save As.

3. Enter a name for the preset and click Save.

RELATED LINKS

Audio File Format Dialog on page 155

Creating Multiple Audio File Format Presets

PREREQUISITE 

Create a preset for each audio file format that you want to add to the multi format 
preset.

PROCEDURE

1. In the Audio File Format dialog, click Multiple File Format.

2. Click Add  and select the preset that you want to use.

3. Add as many audio file format presets as you need.

4. Optional: To make changes to an existing preset, right-click it and select Edit.

5. Open the Presets pop-up menu and select Save As to save the multiple 
format as preset.

RELATED LINKS

Multi Audio File Format Dialog on page 426

Multi Audio File Format Dialog

In this dialog, you can select audio file format presets. These allow you to render an 
audio file or an audio montage to multiple file formats.

• To open the Multi Audio File Format dialog, select File > Export, and select 
Render > Single or Render > Multi. Then click in the Format field and select 
Edit Multi Format.

You can also open the Multi Audio File Format dialog via the Format tab in 
the Batch Processor window.
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Add

Opens a menu from which you can select a file format preset to add it to the 
preset list.

Remove

Removes the selected preset from the list.

Preset list

Shows the selected audio file format presets, an optional subfolder in which 
the files are rendered to, and an optional suffix for the rendered files. The 
Subfolder column allows you to sort the output files to different subfolders. 
The Suffix column helps to avoid name conflicts.

Multicore Rendering

If this option is activated, all audio files are generated at the same time, each 
with a different CPU core, if possible. This increases the rendering speed.

NOTE

It is recommended to deactivate the Multicore Rendering option if a batch 
processor is running that already uses multiple CPU cores.

Single File Format/Multiple File Format

Switches the view between the Audio File Format dialog and the Multi 
Audio File Format dialog.

In-Place Rendering

In the Audio Editor, you can process a section of an audio file or the whole audio 
file. This is a quick way to process several audio sections in an audio file, or test the 
effect of different plug-ins on an audio file.

You can select the Render in Place function in the following places:

• On the Render tab of the Audio Editor

• In the Master Section, in the context menu of the Render button

• In the command bar of a plug-in window
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When selecting Render in Place via the Render tab, you can make additional 
render settings on the Options pop-up menu. When selecting Render in Place via 
the Master Section or a plug-in window, the following render settings are always 
active:

• Fade in/out at boundaries

• Exclude bypassed plug-ins

NOTE

Once an audio section has been processed, there is no automatic bypass of 
plug-ins or the Master Section.

An example for using in-place rendering:

Let’s say that you are restoring a file and have 3 favorite plug-ins, for example, 3 
DeClicker plug-ins. Now you want to use the one that gives the best results.

1) Load all 3 plug-ins in the Master Section.

2) Select a region, solo plug-in #1, and play the region.

3) Solo plug-in #2, and play the region.

4) Solo plug-in #3, and play the region.

5) Solo the plug-in that you think sounded the best, and click Render in Place, 
or press [Alt]/[Option]-[A].

RELATED LINKS

Render Tab on page 149

Rendering an Audio Selection In-Place

You can render the plug-ins of a section of an audio file or the whole audio file.

PREREQUISITE 

In the Audio Editor, open the audio file that you want to render, and set up the 
Master Section.

PROCEDURE

1. Optional: If you only want to use some plug-ins of the Master Section, solo 
the plug-ins that you want to use.

2. In the wave window, select the audio section that you want to process.

3. Select the Render tab.

4. In the Source section, open the Source pop-up menu and select Selected 
Audio Range.

5. In the Result section, activate In Place.



Master Section
Rendering

429

6. In the Options section, open the pop-up menu and make render settings.

7. In the Render section, click Start.

RESULT 

The audio section or the audio file is processed.

Using the Master Section Settings in a Batch Process

You can open a Batch Processor that uses the same plug-in setup as the one that 
is used in the Master Section. This allows you to process more files in a batch, or 
add off-line processors to the audio processing chain.

PROCEDURE

1. At the bottom of the Master Section, right-click Render.

2. Select Create Batch Processor from Settings.

RESULT 

The Batch Processor window opens with the same plug-in setup as the one that 
was used in the Master Section.

AFTER COMPLETING THIS TASK 

Add more files to the batch process and/or make additional configurations in the 
plug-in chain.

RELATED LINKS

Batch Processing on page 586

Render Tab

This tab allows you to select which parts of an audio file to render, into which format, 
and what to do with the result.

• To open the Render tab, click Render at the bottom of the Master Section. 
If you want to render to a single file format, select Single. If you want to render 
to multiple file formats, select Multi.
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The following options are available for rendering audio files and audio montages.

Part

• Selected Audio Range processes and renders the selected audio 
range.

• Specific Region processes and renders an audio range that is 
specified using region markers. In the pop-up menu next to this option, 
select the region that you want to render. For example, a CD track.

• All Regions processes and renders each marked audio range to an 
independent file, or renders in place, according to the settings. By 
defining multiple isolated regions in an audio file, you can process them 
in place in one operation. In the pop-up menu next to this option, select 
the type of marked regions you want to render.

In Place

If this option is activated, the rendered audio range replaces the source audio 
range.

Unnamed File

If this option is activated, the file is named untitled.

Named File

If this option is activated, you can specify a name for the rendered file.

Name

Enter a name for the rendered file. Clicking the arrow icon opens a menu that 
offers you several automatic naming options.

Scheme

Allows you to automatically create file names according to custom variables, 
text snippets, or auto variables. For example, when rendering multiple 
sources, you can activate this option to add a numeric prefix to all rendered 
files.

Location

Select a folder for the rendered file.

Format

Opens the Multi Audio File Format dialog, where you can select the file 
format.

Bypass Master Section

If this option is activated, the plug-ins and gain of the Master Section are 
bypassed when rendering.
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Exclude Master Section Bypassed Plug-ins

If this option is activated, the plug-ins that are bypassed during playback are 
not used for rendering.

NOTE

This applies to the bypass states managed by WaveLab Pro, not any bypass 
state that is under the control of the plug-ins.

Fade In/Out at Boundaries

If this option is activated, a fade is performed at the audio range boundaries 
when a new file is created, or a crossfade with the audio neighborhood is 
created if the audio range is processed in place.

Crossfades allow a smooth transition between the processed and the 
non-processed parts. The crossfade time and shape are set in the Audio 
Files Preferences. If the fade time is longer than half the length of the 
processed file, it is not performed.

No Reverb Tail

If this option is activated, the audio tail produced by effects such as reverb is 
not included in the rendered file.

Some plug-ins do not provide a tail duration to WaveLab Pro. In this case, this 
option has no effect. For such plug-ins, you could add the Silence plug-in to 
add extra samples at the end of the file.

Copy Markers

If this option is activated, markers that are included in the range to process 
are copied to the rendered file.

Open Resulting Audio File

If this option is activated, the rendered files are opened in a new file group.

Bypass Master Section on Resulting Audio File

If this option is activated, playback of the resulting audio file bypasses the 
entire Master Section after rendering. This setting can be toggled by clicking 
on the button at the bottom right of the wave window or montage window.

NOTE

It is recommended to activate this option, because you do not want to monitor 
this new file through the effects again when the effects have been applied to 
a file.

Export to SoundCloud

If this option is activated, the rendered file is uploaded to SoundCloud, after 
the rendering process is finished.

Render Tab for Audio Files

The following options on the Render tab are exclusive to rendering audio files.
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Part

Whole File processes and renders the whole file.

In Place

If this option is activated, the rendered audio range replaces the source audio 
range.

Skip Exclusion Regions

If this option is activated, audio ranges that are marked as muted are skipped 
and not included in the result.

Render Tab for Audio Montages

The following options on the Render tab are exclusive to rendering audio montages.

Part

• Whole Montage processes and renders the whole audio montage.

• Union of Selected Clips processes and renders the audio range that 
starts from the first selected clip and ends with the last selected clip. 
Only the selected clips are included in the process.

• Selected CD Track processes and renders the selected CD track in 
the CD window.

• All Clip Groups processes and renders each clip group to an 
independent file. The group names are used for the output file names.

• All Selected Clips processes and renders each clip to an independent 
file. The clip names are used as output file names.

• CD Track Group processes and renders the selected CD track group.

• All CD Tracks in Group processes and renders all CD tracks in the 
selected CD track group.

Depending on the Part setting, different additional options are available.

Create Basic Audio CD

If this option is activated, a file of the whole audio montage, including clip 
effects and master effects, is created. Then a Basic Audio CD window opens.

Create CD Image and Cue Sheet

If this option is activated, the audio montage is exported as a CD image with 
an accompanying cue sheet, that is, a text file identifying the CD tracks in the 
image file. The cue sheet and the image file it describes can then be imported 
into any CD recording application that supports this function, including 
WaveLab Pro, and written onto a CD. The CD image is a wave file.

Create Audio Montage from Result

If this option is activated, the rendered audio file is imported in a new audio 
montage.
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Render Audio File, Do Not Change Audio Montage

If this option is activated, the rendered audio file is saved at the specified 
location and the audio montage is not changed.

Replace on Same Audio Montage Track

If this option is activated, the rendered audio file replaces the audio montage 
track.

Add to Next Empty Audio Montage Track

If this option is activated, the rendered audio file is added to the next empty 
audio montage track.

Add to New Audio Montage Track

If this option is activated, the rendered audio file is added to a new audio 
montage track.

Bypass Clip Plug-ins

If this option is activated, clip plug-ins are bypassed when rendering.

Bypass Volume/Pan Envelopes

If this option is activated, volume/pan envelopes are bypassed when 
rendering.

Replace Clips with Rendered Audio Files

If this option is activated, the rendered audio files replace the selected clips.

Include Pause before Track

If this option is activated and you render CD tracks, a pause is included before 
each CD track in the rendered file.

Include Pause after Track

If this option is activated and you render CD tracks, a pause is included after 
each CD track in the rendered file.

Render Multi Tab

The Multi tab in the Render tab allows you to render multiple audio files and audio 
montages at once.

• To open the Render tab for multiple file formats, click Render at the bottom 
of the Master Section. Then select Multi.
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The file list displays all open file groups and their included files. You can filter the file 
list to only display the active file group, and only audio files or audio montages.

In the file list, select the files that you want to render.

You can also select multiple file tabs and render the files via the Render tab.

RELATED LINKS

Check Tab/Uncheck Tab on page 67

Recording From an ASIO Input

You can record an audio file to disk from an ASIO input, while the audio is collected 
from the audio input. The audio from the ASIO input is rendered through the Master 
Section including its plug-ins and saved as a file, as when rendering normally.

This is another way to record. When you record normally, no plug-ins are used, but 
more options are possible.

Rendering the ASIO Input to File

PREREQUISITE 

In the VST Audio Connections, set up the input and output channels of the ASIO 
plug-in.

PROCEDURE

1. In the Master Section, in the Effects pane, add the Audio Input plug-in to 
the first effect slot.

2. In the lower part of the Master Section, click Render.

3. Make your settings.

4. Click Start.

RESULT 

The audio file is recorded to disk from the ASIO input, until you click the Stop button 
on the transport bar.
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RELATED LINKS

VST Audio Connections Tab on page 13

Smart Bypass

Smart bypass allows you to compare the original signal to the processed signal with 
a level correction applied to it. This function is particularly useful when you are 
making final level adjustments to a recording, for example, during mastering.

Smart bypass compares the signal at the input of the Master Section to the signal 
at the output of the Master Section, and adjusts the level accordingly.

The main reason for smart bypass is that processing audio often changes the level 
or loudness of the signal. When comparing the processed signal with the original 
signal, your ears are sensitive to this loudness change. If you need to compare the 
sound of the effect independently from the loudness change, a level correction is 
required.

Using Smart Bypass

PROCEDURE

1. At the top of the Master Section, click Smart Bypass.

2. In the Smart Bypass dialog, select one of the play modes.
You can also use key commands to select a Play option. Press [A] for Original Audio, 
[B] for Processed Audio + Level Correction, and [C] for Processed Audio.

3. Select one of the Level Correction modes.

4. Depending on your selection, you have the following options:
• If you have selected Match Loudness (RMS) or Match Peaks, specify the time 

range that you want to analyze in the Analysis Time field, and proceed with 
step 5.

• If you have selected Custom Correction, specify a value, start playback, and 
proceed with step 7.

5. Play back the audio and wait for the analysis to complete.
Wait as long as the time specified in the Analysis Time field.

6. Click Update Gains.
Depending on the selected correction method, the level correction that is applied is 
shown below the corresponding button.

You can also press [U] to update the gains.

7. Switch between the three play mode options to compare the processed audio 
with level correction, the processed audio without level correction, and the 
original audio (unprocessed).
If you change the analysis time or start playback from another position you have to 
wait for the set time, and then click Update Gains again to update the analysis.
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Smart Bypass Dialog

The Smart Bypass dialog allows you to choose whether to bypass all the active 
effects in the Effects slots, including faders. This allows you to compensate for any 
level differences introduced by the Master Section.

• To open the Smart Bypass dialog, click Smart Bypass  at the top of the 
Master Section.

NOTE

This applies to playback only, not to file rendering.

Play – Original Audio

Monitors the unprocessed signal at the Master Section input.

Play – Processed Audio + Level Correction

Monitors the signal at the Master Section output plus the applied level 
correction. To be able to listen to the corrected level, click Update Gains first.

Play – Processed Audio

Monitors the unprocessed signal at the Master Section output without level 
correction.

Level Correction – Match Loudness (RMS)

If this option is activated, the output is adjusted so that the loudness of the 
processed signal corresponds to that of the original signal.

Level Correction – Match Peaks

If this option is activated, the output is adjusted so that the peak levels of the 
processed signal correspond to those of the original signal.

Level Correction – Custom Correction

Allows you to set a custom level compensation (no analysis).

Level Correction – Analysis Time

Determines how many samples are used to calculate the reference loudness.

Level Correction – Update Gains

Updates the volume analysis.
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Saving a Master Section Preset

You can save all settings that are made in the Master Section as a preset. This 
includes which processors are used, which settings are made for each one of them, 
and the dithering options.

PROCEDURE

1. Set up the Master Section.

2. Click Presets at the top of the Master Section, and select Save As.

3. Optional: In the Save Master Section Preset dialog, click the path name, 
enter a name, and click OK to create a new subfolder in the Master Section 
preset folder.

4. Enter a name for the preset in the Name field.

5. Select the options that you want save in the preset.

6. Optional: Activate Create Shortcut for Selecting the Preset, to assign a 
shortcut to open the preset, after you clicked Save.

7. Click Save.

Save Master Section Preset Dialog

In this dialog, you can save a Master Section setup as preset and define which 
parts of the current Master Section you want to include in the preset.

• To open the Save Master Section Preset dialog, click Presets at the top of 
the Master Section, and select Save As.
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Location

Opens the root folder of the preset in the File Explorer/Mac OS Finder. Here, 
you can create subfolders in which presets can be saved.

Presets list

Lists all existing presets.

Name

Lets you specify the name of the preset to save.

Create Shortcut for Selecting the Preset

If this option is activated and you click Save, the Shortcut Definitions dialog 
opens, where you can define a shortcut for applying this preset.

If a preset already has a shortcut, this option is grayed out. To change the 
existing shortcut, double-click the preset name in the presets list.

Save Effects Plug-ins

If this option is activated, the effect plug-ins are saved with the preset.

Save Resampling Settings

If this option is activated, the resampling settings are saved with the preset.

Save Master Level Settings

If this option is activated, the master level settings are saved with the preset.

Save Final Effects/Dithering Plug-in

If this option is activated, the final effects/dithering plug-in is saved with the 
preset.

Save Playback Processing Plug-in

If this option is activated, the playback processing plug-ins are saved with the 
preset.

Exclude Locked Plug-ins

If this option is activated, locked plug-ins are not saved as part of the Master 
Section preset.

Loading a Master Section Preset

You can load a previously saved Master Section preset, a temporarily saved 
Master Section preset, or import WaveLab Pro 4/5/6 presets.

Open the Presets pop-up menu at the top of the Master Section window.

• To load a preset that has been previously saved in the Presets\Master 
Section folder, select a preset from the Presets pop-up menu.

• To load a preset from any location, select Load Preset, select a preset, and 
click Open.
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• To load a temporarily saved preset, open the Restore submenu, and select a 
preset.

• To import a WaveLab Pro 4/5/6 preset, select Load WaveLab 4/5/6 Preset, 
select a preset, and click Open.

Saving a Master Section Preset in an Audio File or Audio 
Montage

You can save the current settings of the Master Section along with an audio file or 
inside an audio montage.

• To save the current settings of the Master Section along with an audio file, 
open the Master Section Preset Settings pop-up menu on the lower right 
of the wave window, and select Save Master Section Preset. In the Save 
Master Section Preset dialog, make your settings and click Save.

The preset is saved in companion files.

• To save the current settings of the Master Section as part of an audio 
montage, open the Master Section Preset Settings pop-up menu on the 
lower right of the montage window, and select Save Master Section Preset. 
In the Save Master Section Preset dialog, make your settings and click 
Save.

Loading a Master Section Preset to an Audio File or Audio 
Montage

You can apply the Master Section settings that have been saved along with an 
audio file or inside an audio montage to the project.

If the option Open Options Dialog when Selecting Preset is activated on the 
Presets menu of the Master Section, the Load Master Section Preset dialog 
opens when applying a Master Section preset. In this dialog, you can specify which 
parts of a saved Master Section preset to load when opening it.

• To load a Master Section preset that is saved along with the opened audio 
file, open the Master Section Preset Settings pop-up menu on the lower 
right of the wave window, and select Load Master Section Preset.

• To load a Master Section preset that is saved inside the opened audio 
montage, open the Master Section Preset Settings pop-up menu on the 
lower right of the montage window, and select Load Master Section Preset.

Load Master Section Preset Dialog

In this dialog, you can specify which parts of a saved Master Section preset to load 
when opening it.
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• To open the Load Master Section Preset dialog, click Presets at the top of 
the Master Section, and select Load Preset.

This dialog only opens if it is activated on the Presets menu of the Master Section. 
Open the Presets menu at the top of the Master Section, and activate Open 
Options Dialog when Selecting Preset.

Now, when restoring a temporarily saved preset or opening a saved preset a dialog 
with the following options opens:

Name

Displays the name of the preset.

Load/Replace Effect Plug-ins

If this option is activated, the active effect plug-ins are removed, and any new 
plug-ins are inserted from the top slot.

Insert Effect Plug-ins from Focused Slot (Keep Existing Plug-ins)

If this option is activated, the current effect plug-ins are kept, and any new 
plug-ins are inserted from the top slot.

Load/Replace Resampling Settings

If this option is activated, the current resampling settings are reset, and any 
new settings are loaded.

Load/Reset Master Level Settings

If this option is activated, the current Master Level settings are reset, and any 
new settings are loaded.

Load/Replace Final Effects/Dithering Plug-in

If this option is activated, the current final effects/dithering plug-in is removed, 
and the new plug-in is loaded.

Load/Replace Playback Processing Plug-in

If this option is activated, the current post-processing plug-in is removed, and 
the new plug-in is loaded.
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Open Plug-in Windows

If this option is activated, the plug-in window opens when you load a new 
Master Section preset.

Including a Master Section Preset When Rendering

You can include the Master Section preset that is saved with the audio montage in 
the rendering process of super clips’ audio montages.

This means that if this option is activated for an audio montage, anytime this audio 
montage is rendered so that its image is used in a parent montage, its associated 
Master Section preset is used in the rendering process.

• To include the Master Section preset when rendering a super clip, open the 
Master Section Preset Settings pop-up menu on the lower right of the 
montage window, and select Include Master Section Preset when 
Rendering as Super Clip.

Master Section Presets Pop-up Menu

This pop-up menu offers several options for saving, managing, and restoring 
Master Section presets.

• To open the Presets pop-up menu, click the presets pane at the top of the 
Master Section.

Save

Saves the changes you have made to an existing preset.

Save As

Opens a dialog where you can specify a name and a location for the preset.

Organize Presets

Opens the Preset folder of the Master Section, where you can rename or 
delete presets.

Define Shortcut for Current Preset

Opens the Shortcut Definitions dialog, where you can define key sequences 
and keywords.

Load Preset

Allows you to load a Master Section preset via the File Explorer/Mac OS 
Finder. For example, this is useful if you want to load a preset that is provided 
by another source and not located in your default root folder.
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Load WaveLab Pro 4/5/6 Preset

Allows you to load WaveLab Pro 4/5/6 presets via the File Explorer/Mac OS 
Finder.

Open Options Dialog when Selecting Preset

If this option is activated, a dialog opens that allows you to choose how to load 
the preset you select.

Store Temporarily

Lets you select one of the slots to temporarily save a preset.

Restore

Lets you restore a previously saved preset.

List of saved presets

Lists the presets that are saved in the Presets folder of the Master Section.

Monitoring Background Tasks

When rendering, you can monitor the process, and pause or cancel tasks.

You can adjust the priority with which tasks are processed, pause, or cancel them. 
This is useful if you have a number of lengthy processes underway and want to free 
up some processing power to focus on editing. You can either lower the priority of 
a task so that it does not use as much of the computer processor capacity, or pause 
the task.

To automatically open the Tasks window when a task starts, select the Options tab 
in the Global Preferences, and activate Make Tasks Monitor Visible When Task 
Starts.

A status bar below the wave window and the montage window shows the progress 
of the current rendering process, and lets you cancel and pause the rendering, 
without opening the Tasks window.

RELATED LINKS

Global Preferences on page 700

Tasks Window

This window allows you to view all background rendering processes that are in 
progress.

• To open the Tasks window, select Tool Windows > Tasks
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The list of background tasks shows the following information about the rendered file 
during the rendering process:

• Name

• Status

• Elapsed Time

• Remaining Time

• Progress in %

• Progress bar

With the Pause and Cancel buttons, you can pause and cancel the rendering 
process.

From the Tasks menu, you can select the following options:

Suspend

Pauses the selected task.

Suspend All

Pauses all tasks.

Resume

Resumes the selected paused task.

Resume All

Resumes all paused tasks.

Cancel

Cancels the selected task.

Lowest Priority

Runs the task at a the lowest speed to leave processing power to other tasks, 
and only when the mouse or keyboard are not in use.

Low Priority

Runs the task at a low speed to leave processing power to other tasks.

High Priority

Runs the tasks as fast as possible while giving you the possibility to continue 
working in WaveLab Pro.
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Dropouts

A dropout most likely occurs when your computer does not have the processing 
power to handle all used effect processors.

To avoid dropouts, try the following:

• Use fewer effects.

• Consider rendering the processing rather than running it in real-time. Then 
master from the processed file without applying effects. Dropouts never occur 
when rendering to a file.

• Do not process any files in the background.

• If neither of the above helps, check the audio card preference settings. You 
might need to adjust the audio buffer settings. If a dropout occurs during a 
real-time mastering process we recommend that you re-master. Stop 
playback, click the dropout indicator to reset it, and try again.
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Markers

Markers allow you to save and name specific positions in a file. Markers are useful 
for editing and playback.

For example, markers can be used for the following:

• Indicate cue points or absolute time locations.

• Highlight problem sections.

• Visually separate tracks.

• Set the wave cursor to a specific position.

• Select all audio between two positions.

• Define CD tracks.

• Loop sections in an audio file.

There is no limit to the amount of markers that you can have in a file.

The following marker types come in pairs: CD, loop, mute, region, error and 
correction. When you delete a marker of a marker pair, the other marker is also 
deleted.

Because you cannot have a CD track that starts but never ends, a loop end point 
without a start, etc., special rules exist for creating, deleting, and moving these types 
of markers. CD track markers must always be balanced. For example, if you delete 
a track start, the corresponding end marker is also deleted.

Loop, mute, correction, error, and region markers only have a functionality when 
balanced.

NOTE

The functions in the Markers window are the same for audio files and audio 
montages. However, the Markers window for audio montages offers additional 
options regarding clips.

Marker Types

The following marker types are available:

Generic markers

Allow you to locate positions and select all the audio between two points, for 
example. Generic markers can be created during recording.
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Temporary markers

Can be used for any purpose. Temporary markers are deleted when the 
corresponding file is closed.

Playback start markers

Define a playback start point.

CD track start and end markers

Denote where a CD track begins and ends. CD track start and end markers 
also serve for DVD-A discs. CD/DVD markers are used in pairs.

CD track splice markers

Are used when a CD track starts exactly where another ends. CD track splice 
markers also serve for DVD-A discs.

CD track index markers

Are used to create index points in CD tracks. CD track index markers also 
serve for DVD-A discs.

Region start and end markers

Define start and end points for generic regions. Region start and end markers 
can be created during recording and are used in pairs.

Loop start and end markers

Are used to define loop points and are required to access loop editing 
functions on the Process tab of the Audio Editor. Loop start and end markers 
are connected to the Loop mode when playing back audio. These markers are 
useful for editing and creating loops before transferring a sound to a sampler. 
Loop markers are used in pairs.

Exclusion start and end markers

Let you temporarily silence a section. Sections between exclusion regions are 
skipped if Skip Range is activated in the Play Audio Range pop-up menu on 
the transport bar. The Render dialog also allows you to exclude regions from 
being rendered. Exclusion markers are used in pairs.

Error start and end markers

Are used to highlight errors, such as clicks. Error start and end markers are 
saved in audio files if Save Error and Correction Markers is activated in the 
Audio Files Preferences, on the File tab. Error start and end markers can be 
placed manually, but their main use is in combination with the Error 
Correction tool.

Correction start and end markers

Are used to highlight corrections performed on regions previously marked as 
errors. Correction start and end markers are saved in audio files if Save Error 
and Correction Markers is activated in the Audio Files Preferences, on the 
File tab. The correction markers can be placed manually, but their main use is 
in combination with the Error Correction tool.
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Markers Window

In this window, you can create, edit, and use markers while working on an audio file 
or audio montage.

• To open the Markers window, open an audio file or audio montage and select 
Tool Windows > Markers.

Markers List

The Markers window contains a list of all markers of the active file along with their 
details and controls. You can create and edit markers from the markers list.

Marker numbers

Clicking the number of a marker scrolls the waveform to reveal the 
corresponding marker.

From Start with Pre-Roll ( )

Plays back the audio from the marker position with a pre-roll.

You can also press [Alt]/[Option] and click  to play back from the marker 
position with a short pre-roll.

From Start ( )

Plays back the audio from the marker position.

Marker type

Shows the marker type. To change the marker type, click the marker icon and 
select another marker type from the pop-up list.

Name

Shows the marker name. To change the name, double-click in the 
corresponding cell and enter a new name.

Time

Shows the marker position on the time ruler. To change the position, 
double-click in the corresponding cell and enter a new value.

Length

Shows the time between the marker start position and the corresponding end 
or splice marker.
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• To zoom in on the region between a start and end marker, click the 
corresponding cell in the Length column.

• To select the region between a start and end marker, double-click the 
corresponding cell in the Length column.

Lock

Allows you to lock markers. Locking markers prevents them from being 
accidentally dragged to a new position in the wave window or the montage 
window. To lock a marker, activate the corresponding checkbox.

Clip Reference (only available for markers in the Audio Montage window)

A marker can be attached to the left or right edge of a clip, and to its 
waveform. When you move a clip, the corresponding marker moves along. 
The clip reference column shows the name of the clip.

Offset (only available for markers in the Audio Montage window)

Shows the distance between the marker and the reference point.

Comment

Allows you to enter a comment. To enter a comment, double-click in a cell.

Functions Menu

Depending on whether the Audio Editor or the Audio Montage window is open, 
different options are available. The following options are available for audio files and 
audio montages:

Select All

Selects all markers in the markers list.

Select in Time Range

Selects the markers located in the selection range.

Deselect All

Deselects all markers.

Delete Selected Markers

Deletes all markers that are selected.

Select Markers to Delete

Opens the Delete Markers dialog, where you can select the markers to 
delete according to various criteria.

Copy

Opens a submenu with the following options:

• Copy All Markers copies all markers of the open audio file or audio 
montage to the clipboard. When pasting these markers, the marker 
positions will be relative to the file start.
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• Copy Markers in Selected Range copies all markers of the open audio 
file or audio montage that are located in the selected range to the 
clipboard. When pasting these markers, the marker positions will be 
relative to the first copied marker.

Paste Markers

Pastes the markers that were copied to the clipboard at the edit cursor 
position. Sample rate differences between the source and destination file are 
taken into account when pasting markers.

Convert Marker Types

Opens a dialog where you can convert markers to another type.

Move Multiple Markers

Opens the Move Multiple Markers dialog, where you can select which 
markers you want to move by a specified amount.

Default Marker Names

Opens the Default Marker Names dialog, where you can select default 
marker names for each marker type.

Batch Renaming

Opens the Batch Renaming dialog where you can rename several markers 
in one go.

Export Markers List as Text

Opens a dialog where you can export the markers list in various file formats, 
or as print out. You can decide which information about the markers to include 
in the exported file.

Generate Markers

Opens the Generate Markers dialog where you can specify a sequence of 
markers to create.

Lock Selected Marker

Locks the selected marker. If this option is activated, the marker cannot be 
moved or deleted.

Customize Command Bar

Opens a dialog where you can customize marker-related menus and 
shortcuts.

The following options of the Functions menu are only available for audio montages:

Import Markers from Active Clip's Audio File to Audio Montage

Automatically adds all markers of the clip’s source audio file to the audio 
montage. To visualize these markers before importing them, it is 
recommended to activate Source’s Ruler and Markers in one of the 
following ways:

• On the View tab of the Audio Montage window, in the Clip section, 
activate Ruler.
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• In the Clips window, select Functions, and activate Show/Hide Clip 
Ruler and Markers of Source File. You can also right-click the upper 
part of a clip, and activate this option in the pop-up menu.

Bind Selected Markers to Start of Active Clip

Makes the marker position relative to the start of the active clip. When the start 
of this clip moves, the marker moves, too.

Bind Selected Markers to End of Active Clip

Makes the marker position relative to the end of the active clip. When the end 
of this clip moves, the marker moves, too.

Bind Selected Markers to Audio Samples of Active Clip

Locks the selected marker in relation to the audio samples referenced by the 
active clip. The marker moves when the audio samples move relatively to the 
start of the montage.

Detach Selected Markers from Their Associated Clip

Makes the marker position relative to the start of the audio montage.

Automatically Attach New Marker to the Most Suitable Clip

Links all newly created markers to a clip when a reasonable pattern is 
detected. For example, an end marker at the end of a clip or slightly beyond, 
or any marker inside a clip. The marker type and its position relatively to the 
closest clip determine the type of bond.

Full Clip Attachment

Attaches markers to a clip so that they are copied or deleted when the clip is 
copied or deleted.

Customize Command Bar

Opens the Customize Commands dialog which contains options to hide or 
show specific command bar buttons.

Filter Menu

Use the Filter menu to determine which types of markers are displayed in the 
markers list and on the timeline.

Filtering Markers

The search field allows you to filter the markers list by names.

You can search for text in the Name and Comment columns. The search only 
happens in the sorted columns. The function Select All only selects the filtered 
items.

• In the toolbar of the Markers window, click in the search field, and enter the 
text that you want to search for. You can use wildcard characters. “*” 
substitutes for zero or more characters, and “?” substitutes for any character.
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• To switch the focus from the search field to the markers list, press [Down 
Arrow].

• To switch the focus from the markers list to the search field, press 
[Ctrl]/[Command]-[F].

• To view all markers again, cancel the search.

About Creating Markers

Markers can be created during playback or in stop mode. You can generate a 
sequence of markers or mark a selection range, for example.

You can create specific markers if you already know what you want to mark, or 
create generic markers.

Creating Markers

You can create markers in the wave window and montage window in stop mode or 
during playback.

PROCEDURE

1. Do one of the following:
• Start playback.

• In the wave/montage window, set the cursor to the position where you want to 
insert the marker.

2. Do one of the following:
• In the Audio Editor or Audio Montage window, select the Insert tab, and click 

a marker icon in the Markers section.

• Right-click the upper part of the time ruler, and select a marker from the context 
menu.

• Press [Insert]/[M]. This creates a generic marker.

• To create CD start/end markers for audio montages, open the CD window, and 
use the CD Wizard. This only works in stop mode.

Creating Markers at Selection Start and End

You can mark a selection for looping or review, for example.

PROCEDURE

1. In the wave window or the montage window, create a selection range.

2. Do one of the following:
• In the Audio Editor or the Audio Montage window, select the Insert tab and 

select a marker pair in the Markers section.
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• In the wave window, make a selection range, right-click it, and select one of the 
marker pairs.

• In the wave window or the montage window, create a selection range, 
right-click above the time ruler, and select one of the marker pairs.

Duplicating Markers

This is a quick way to create a marker from an existing marker.

PROCEDURE

• In the wave window or the montage window, hold down [Shift], click a marker, 
and drag.

Generating a Sequence of Markers

You can generate several markers at once in a specified time range. This allows you 
to create markers at every beat, or create markers as guidelines for inserting silence 
when you want to distribute demo sounds, for example.

PROCEDURE

1. To decide where you want to insert the generated markers, do one of the 
following:
• To generate markers in a specific time range, create a selection range in the 

wave window or the montage window.

• To generate markers from the cursor position to the end of the audio or 
generate a fixed number of markers from the cursor position, set the cursor 
position where you want the first marker to be created.

2. In the Markers window, select Functions > Generate Markers.

3. Select the type of marker and specify the gap between markers, and if you 
have selected a marker pair, the region length.

4. Optional: Activate Naming and select a naming scheme.

5. Select a numbering scheme.

6. Click OK to generate the markers.

Generate Markers Dialog

This dialog allows you to generate markers at regular intervals in a specified time 
range. You can fill a selected time range, the region between the cursor position and 
the end of the audio, or specify a fixed number of markers to be generated.

• To open the Generate Markers dialog, open the Markers window and select 
Functions > Generate Markers.
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Marker type

Specifies the type of marker to be generated.

Gap between Markers/Gap between Regions

Sets the time between two markers or two regions.

Region Length

Sets the length for the region to be generated.

Naming

Allows you to set up a naming scheme.

Depending on whether you have selected a single marker or a start/end 
marker, you can specify the naming scheme for a single marker, or one naming 
scheme for the start marker and one for the end marker.

If you select Custom, the Marker Naming dialog opens, where you can 
specify a custom naming scheme.

Naming Fields

Allows you to specify a base name for the markers, an optional separator 
between name and marker number, and the start value of the marker index.

The base name is also used as a basis for the Custom naming scheme.

Fill Selected Time Range

Generates markers in the selected time range.
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Start after Gap

If this option is activated, the first generated marker is inserted after the gap 
time specified at the top of the dialog.

Specific Number of Markers

If this option is activated, you can specify the number of markers that you want 
to generate.

Fill from Cursor to End

Generates markers between the edit cursor position and the end of the audio.

Fixed Number, Starting from Cursor

Generates a specified number of markers or regions, starting at the edit 
cursor position.

Allow Marker after Last Clip (audio montage only)

Determines whether markers can be generated beyond the end of the last 
clip, when Fixed Number, Starting from Cursor is activated.

Deleting Markers

Markers can be deleted in the wave window or the montage window, in the Markers 
window, and in the Delete Markers dialog.

Deleting Markers in the Wave/Montage Window

• In the wave/montage window, right-click a marker and select Delete.

• Drag and drop a marker icon upwards outside the time ruler.

Deleting Markers in the Markers Window

This is useful if your project has many markers or if the marker that you want to 
delete is not visible in the wave/montage window.

PROCEDURE

1. In the Markers window, select one or several markers.
You can also select Functions > Select All.

2. Click Delete Selected Markers , or select Functions > Delete Selected 
Markers.
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Deleting Markers by Type

This is useful to delete markers of a specific type in the whole wave/montage 
window or in a selection range.

PROCEDURE

1. Optional: If you only want to delete markers in a specific time range, create a 
selection range in the wave/montage window.

2. In the Markers window, select Functions > Select Markers to Delete.

3. Select the marker types that you want to delete.

4. Optional: Define conditions that have to be met for markers to be deleted.

5. In the Range section, select in which range you want to delete markers.
If you have selected an audio range and want to use it, activate In Selected Audio 
Range.

6. Click OK.

Delete Markers Dialog

In this dialog, you can define which markers to delete by selecting marker types and 
conditions.

• To open the Delete Markers dialog, open the Markers window and select 
Functions > Select Markers to Delete.

Marker types

Allows you to select the marker types to delete.

Conditions

Allows you to select a condition that has to be met for markers to be deleted. 
For example, Marker Name Must Contain This Text.
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Select All

Selects/deselects all marker types.

Range – All

Select this if you want to delete all markers.

Range – In Selected Audio Range

Select this if you want to delete all markers in the selected time range.

Range – Skip Locked Markers

If this option is activated, locked markers are not deleted.

Moving Markers

You can adjust marker positions in the wave window and the montage window.

PROCEDURE

• In the wave/montage window, drag a marker to a new position on the time 
ruler.
If Snap to Magnets is activated, the marker snaps to the cursor position, or the 
beginning/end of a selection or waveform.

Moving Multiple Markers

You can move multiple markers simultaneously, keeping the relative distances 
between the markers.

PROCEDURE

1. Optional: If you only want to move markers in a specific time range, create a 
selection range in the wave window or the montage window.

2. In the Markers window, select Functions > Move Markers.

3. Specify the amount of time by which you want to move the markers.

4. Select the marker types that you want to move.

5. Optional: Define conditions with or without regular expressions.

6. Optional: If you have selected an audio range and want to use it, activate In 
Selected Audio Range.

7. Click OK.
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Move Multiple Markers Dialog

In this dialog, you can specify which markers you want to move by a specific amount.

• To open the Move Multiple Markers dialog, open the Markers window and 
select Functions > Move Multiple Markers.

Move Markers by This Amount

Defines the distance that the markers are moved.

Move These Marker Types

Allows you to select the marker types that are moved.

Conditions

Allows you to select a condition that has to be met for markers to be moved. 
For example, Marker Name Must Contain This Text.

Select All

Selects/deselects all marker types.

Range – All

Select this if you want to move all markers.

Range – In Selected Audio Range

Select this if you want to move all markers in the selected time range.

Range – Skip Locked Markers

If this option is activated, locked markers are not moved.
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Navigating to Markers

You can jump to the previous or next marker using the corresponding marker 
buttons.

• To jump to the previous/next marker, select the View tab, and, in the Cursor 
section, click Previous Marker/Next Marker.

• To set the wave cursor to a marker position, in the wave window or the 
montage window, double-click a marker triangle.

Hiding Markers of a Specific Type

For a better overview, you can hide marker types.

PROCEDURE

1. In the Markers window, select Filter.

2. Deactivate the marker type that you want to hide.
You can make the markers visible again by activating the corresponding marker type.

Converting Marker Types

You can convert markers of a specific type to another type.

Converting the Type of a Single Marker

PROCEDURE

1. In the Markers window, click the marker icon that you want to convert.

2. Select a new marker type from the list.

Converting All Markers of a Specific Type

You can convert loop markers to CD track markers, for example.

PROCEDURE

1. Optional: If you only want to convert markers in a specific time range, create 
a selection range in the wave window or the montage window.

2. In the Markers window, select Functions > Convert Marker Types.
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3. Use the From and To pop-up menus to specify the source and target marker 
types.

4. Optional: Specify a condition.

5. Select whether you want to convert all markers or only the markers in the 
selected range.

6. Click OK.

Convert Marker Types Dialog

In this dialog, you can convert marker types.

• To open the Convert Marker Types dialog, open the Markers window and 
select Functions > Convert Marker Types.

From

Specifies the source marker type.

To

Specifies the target marker type.

Conditions pop-up menu

Allows you to specify conditions for the conversion. Select an option and 
enter a text in the text field below.

Markers to Convert – All

Converts all markers.

Markers to Convert – In Selected Audio Range

Converts only markers of the selected audio range.
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Markers to Convert – Skip Locked Markers

Excludes locked markers from the conversion.

Renaming Markers

You can change the names of markers.

• To rename a marker in the wave window or the montage window, right-click 
a marker, select Rename, and enter a new name.

• To rename markers in the Markers window, double-click a marker name in the 
Name column, and enter a new name.

• To batch rename multiple markers according to specified settings, in the 
Markers window, select Functions > Batch Renaming.

• To edit the default names, in the Markers window, select Functions > 
Default Marker Names.

RELATED LINKS

Batch Renaming on page 632

Default Marker Names Dialog

In this dialog, you can specify the default marker names.

• To open the Default Marker Names dialog, open the Markers window and 
select Functions > Default Marker Names.

Marker type

Lets you select the type of marker for which you want to specify the default 
name.

Default Name for This Marker Type

Lets you specify the default name for the selected marker type.

Selecting Markers

There are several ways to select markers.
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• In the wave window or the montage window, click a marker.

• In the Markers window, click in a cell. The corresponding marker is selected.

• Use [Ctrl]/[Command] and [Shift] to select multiple markers.

The marker icon changes its background to indicate the selected marker.

Selecting the Audio Between Markers

You can select the audio between two adjacent markers or between any two 
markers. This allows you to select a section that has been marked.

• To select the audio between two adjacent markers, double-click between two 
adjacent markers in the wave window or the montage window.

• To select several regions between two adjacent markers, double-click 
between two adjacent markers, and after the second click, drag to select the 
adjacent regions.

• To select the audio between a region marker pair, hold down [Shift], and 
double-click a region marker.

• To extend the selection until the end of a marker region, in the wave/montage 
window, hold down [Shift], and double-click in the marker region that you 
want to select.

• To open the Markers window and display further information about a specific 
marker, hold down [Alt]/[Option], and double-click a marker.

Binding Markers to Clips in the Audio Montage

In the Audio Montage window, you can bind markers to clips. By doing this, the 
marker remains in the same position relative to the clip start/end, even if the clip is 
moved or resized in the audio montage.

You can find the options regarding binding clips and markers on the Functions 
menu of the Markers window, and when right-clicking a marker.

When a marker is bound to a clip element, its name is preceded by a blue character.

RELATED LINKS

Markers Window on page 447
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Exporting the Markers List as Text

You can export the markers list as text. The markers list contains the marker names, 
positions, region lengths, types, and comments.

PROCEDURE

1. Open the Markers window.

2. Select Functions > Export Markers List as Text.

3. Choose the information that you want to export, and the output format.

4. Click OK.

RESULT 

The markers list opens in the selected output format. When you select Print, the 
Print Preview window opens. The text file is saved in the specified folder for 
temporary files.

RELATED LINKS

Specifying Folders on page 104

Export Markers List as Text Dialog

This dialog allows you to export the markers list in various file formats, or as print 
out. You can decide which information about the markers to include in the exported 
file.

• To open the Export Markers List as Text dialog, open the Markers window 
and select Functions > Export Markers List as Text.

How Marker Information is Saved

WaveLab Pro uses MRK files as a way to save information that is independent of 
the file format. However, to make marker information exchangeable between 
applications, WaveLab Pro also saves some information in the Wave headers.
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This makes saving files quicker if only a marker setting was changed. However, this 
only applies if Write Markers in WAV File Header is deactivated in the Audio Files 
Preferences on the File tab. By default, MRK files are created and information are 
saved in the Wave headers.

• When you import a file for the first time, any loop points are imported and 
displayed as loop markers.

• When you save a file in the Wave format, the loop points are saved both as 
part of the actual file and in the MRK file.

• When you open a file that includes markers that were added in WaveLab Pro, 
and markers that were added in another application, all markers are displayed 
in WaveLab Pro.
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Metering

WaveLab Pro contains a variety of audio meters that you can use for monitoring and 
analyzing audio. Meters can be used to monitor audio during playback, rendering, 
and recording. Furthermore, you can use them to analyze audio sections when 
playback is stopped.

Metering Window

Audio meters can be used in the WaveLab window and in the Control Window.

There can only be one instance of each audio meter.

The axis of most audio meters can be rotated, to view the graphics horizontally or 
vertically. For some meters, you can also style and customize parameters via a 
settings dialog.

RELATED LINKS

Docking and Undocking Tool Windows and Meter Windows on page 55

Real-Time vs. Non-Real-Time

Metering can be used to measure audio in real-time, that is, while the audio is being 
played back, or in non-real-time, that is, in stop mode.

Metering Monitor Modes

You can choose which audio source to monitor and select a mode for displaying 
information in the meters.

The following metering modes are available on the Analyze tab in the Monitoring 
section of the Audio Editor.



Metering
Meter Settings

465

Playback

This is the standard metering mode, in which the meters reflect the audio that 
is played back. Metering occurs after the Master Section, which means that 
effects, dithering, and master faders are taken into account. You can monitor 
audio files, audio montages, audio CD track lists, etc.

Audio Input

In this mode, the meters reflect the audio input. Typically, this is the mode to 
use when recording. The Master Section settings are not taken into account.

Freeze Meters

This mode freezes the values for all open meters. The meters remain frozen 
until you select another monitor mode.

File Rendering

In this mode, you can monitor what is being written to disk during file 
rendering or when recording. Like Audio Selection, average and min/max 
peak values are calculated. After rendering, the meters freeze until you refresh 
or change monitor mode.

Edit Cursor (Audio Editor only)

In this mode, the meters are static, showing the levels and other values for the 
audio at the position of the edit cursor, in stop mode. This allows you to 
analyze a specific position in an audio file in non-real-time. The Master 
Section settings are not taken into account.

Audio Selection (Audio Editor only)

In this mode, the meters display the average values calculated for the selected 
range. The Master Section settings are not taken into account.

When you change the selection, you have to update the meter displays by 
clicking Update Selection Analysis.

Update Selection Analysis (Audio Editor only)

Analyzes the audio selection again and updates the meters.

Meter Settings

You can set up most meters in the corresponding settings dialogs. For example, you 
can adjust the behavior, scale, and color of the meters.

• To open the settings dialog for a meter, select Functions > Settings.

• To check the results after changing the settings without closing the settings 
dialog, click Apply.

• To close the settings dialog and discard any changes that you have made, 
even if you have clicked the Apply button before, click Cancel.
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Multichannel Metering

WaveLab Pro features 8 audio channels that can be routed to inputs and outputs 
on a multi i/o audio card. The audio montage supports various surround channel 
configurations using up to 8 channels.

WaveLab Pro can display multiple meters. When working with multiple channels in 
an audio montage, each channel has its own meter. This applies to all meters (up to 
8 real-time FFTs, 8 level meters, 4 pan meters, 4 phase scopes, etc.). If a surround 
configuration is selected, each meter indicates the corresponding surround channel 
(Lf, Rf, LFE, etc.).

When working with more than two channels, it is recommended to use floating 
meter windows, because they can be resized more easily.

Resetting the Meters

You can reset the display of some meters, for example, the Level Meter.

PROCEDURE

• In the meter window, click Reset , or select Functions > Reset.

RESULT 

All values and numerical indicators of the meter are reset.

Using Presets in the Meter Windows

You can save the settings that you have made for a meter window as a preset. By 
assigning presets to preset buttons, you can quickly switch between different level 
scales and display modes, for example.

• To save your settings as a preset, select Functions > Settings, click Presets 
, and select Save As.

• To assign a preset to one of the preset buttons, select Functions > Settings, 
click Presets , and from the Assign to Preset Button submenu, select a 
preset button.

• To apply a preset, select it from the Functions menu, or click the 
corresponding preset button.

Preset buttons 1-5
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Level Meter

The Level Meter displays the peak and average loudness/decibel levels of your 
audio file, and the balance between the left and right channels in a stereo file.

• To open the Level Meter, select Meters > Level Meter.

Level Meters

The upper part of the window shows the peak level and the average loudness in the 
following way:

• The peak level meters display the peak levels of each channel, graphically and 
numerically.

• The VU meters measure the average loudness (RMS) of each channel. These 
meters have a built-in inertia, evening out loudness variations over a 
user-defined time span. If you are monitoring playback or the audio input, you 
can see two vertical lines following each VU meter bar. These lines indicate 
the average of the most recent minimum RMS values (left line) and the 
average of the most recent maximum RMS values (right line). To the left, the 
difference between the minimum and maximum average values is displayed. 
This gives you an overview of the dynamic range of the audio material.

• If you are monitoring real-time audio (playback or input), the maximum peak 
and loudness values are displayed to the right of the meter bars. The numbers 
in brackets to the right of the maximum peak values indicate the number of 
times that clipping occurs (0 dB signal peaks). Values between 1 and 2 are 
acceptable, but if you get a larger number, you should lower the master level 
to avoid digital distortion.

• Recording levels should be set so that they only rarely clip. If the master level 
is set too high, the sound quality and frequency response are compromised 
at high recording levels, with unwanted clipping effects. If the level is set too 
low, noise levels can be high relative to the main sound being recorded.

Pan Meters

The lower part of the window shows the difference in level between the left and right 
channel of a stereo audio file.

• The upper pan meters show the peak level difference between the channels. 
The level bars can go to the left or right, indicating which channel is loudest.
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• The lower pan meters show the average difference in loudness between the 
channels. This gives you a visual indication of whether a stereo recording is 
properly centered, for example.

• If you are monitoring real-time audio (playback or input), the maximum balance 
difference values (peak and loudness) for each channel are displayed 
numerically to the left and right of the meter bars.

Level/Pan Meter Settings

In the Level/Pan Meter Settings dialog, you can adjust the behavior, scale, and 
color of the meters.

• To open the Level/Pan Meter Settings dialog, open the Level Meter 
window, and select Functions > Settings.

Peak Meter Section

Peaks pop-up menu

On this pop-up menu, select Digital Peaks if you want WaveLab Pro to use 
sample values and True Peaks if you want WaveLab Pro to use analog 
reconstructed values.

Ballistics – Release Rate

Determines how fast the peak level meter falls after a peak.

Ballistics – Peak Hold Time

Determines how long a peak value is displayed. The peak can be displayed as 
a line or a number. If the meter's height is too narrow, only the line is displayed.

Top/Middle/Low Zone

The color buttons allow you to select colors for the low, middle, and top zones 
of the level meter. You can define the range for the top and middle zones by 
changing the corresponding values.

Cursor Mode – Unit

If this option is activated, you can specify which unit is used to display the 
peak value.

Show Value of Single Sample

If this option is activated, the value of the single sample is displayed at the 
cursor position. If this option is deactivated, several samples are scanned 
around the cursor to determine the peak value. Generally, this is best 
activated when you have zoomed in on the waveform to see the details.

VU Meter (Loudness) Section

VU Meter (Loudness)

Activates/Deactivates the VU meter.
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Modes pop-up menu

On this pop-up menu, you can choose between the standard mode and three 
K-System modes. The settings for K-System modes are shown in the Zones 
section.

Ballistics – Resolution

Sets the time that is used to determine the loudness. The smaller this value, 
the more the VU meter behaves like the peak meter.

Ballistics – Range Inertia

Sets the time that is used to determine the recent minimum and maximum 
value lines, and therefore determines how quickly these respond to changes 
in loudness.

Top Zone/Middle Zone/Low Zone

The color buttons allow you to select colors for the low, middle, and top zones 
of the VU level meter. You can define the range for the top and middle zones 
by changing the corresponding values.

Cursor Mode – Samples to Scan

Determines how many samples are scanned when calculating the VU meter 
value in Monitor Edit Cursor Position mode.

Panning Meter Section

Panning Meter

Shows/Hides the panning meter in the Level Meter window.

Range

Determines the dB range of the panning meter.

Peak and Loudness Left/Right, Global Colors

Lets you specify the colors for the different elements.

Global Colors Section

In this section, you select colors for the meter background, marks (scale units), and 
grid lines.

Global Range (Peak and VU Meter) Section

In this section, you specify the minimum and maximum values of the displayed level 
range.

K-System VU Meter Modes

K-System integrates standardized metering, monitor calibration, and level practices.
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In WaveLab Pro, you can choose between three metering modes which all set the 
0 dB VU point below the standard level meter. To fully utilize the K-System, you have 
to calibrate your monitor level so that 0 VU equals 83 dB.

You should use a pink noise reference signal and a SPL level meter. Use C 
weighting (slow response), and adjust your playback level so that your noise meter 
indicates 83 dB SPL per channel or 86 dB SPL when played on the two channels 
simultaneously.

The K-System has three meter operating modes (selectable from the VU-Meter 
pop-up in the Level/Pan Meter Settings dialog). These are intended for different 
uses:

• K-System 20: This places 0 VU 20 dB lower than standard VU mode, and is 
intended for music with a very wide dynamic range, e.g. classical music.

• K-System 14: This places 0 VU 14 dB lower than standard VU mode, and is 
intended for music with a slightly more compressed dynamic range. Use this 
for pop, R&B, and rock music.

• K-System 12: This places 0 VU 12 dB lower than standard VU mode, and is 
intended for broadcast applications.

Loudness Meter

The Loudness Meter is an audio meter for monitoring loudness, according to the 
EBU R-128 standard.

• To open the Loudness Meter, select Meters > Loudness Meter.

1) Momentary loudness bar

Displays the loudness of a 400 milliseconds slice that is evaluated every 100 
milliseconds.

2) Short-term loudness bar

Displays the loudness of a 3 seconds slice that is evaluated every second.

3) Integrated loudness bar

Displays the average loudness. This bar is evolving over time, because it 
makes an average of the loudness by measuring 400 millisecond slices every 
100 milliseconds.
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4) Target loudness

The purple vertical line corresponds to the target loudness defined in the 
Loudness Meter Settings dialog. The purple shadow around it corresponds 
to the acceptable deviation.

5) EBU R-128 Loudness Range (LRA)

This loudness range displays the difference between the estimates of the 
10th and the 95th percentiles of the loudness distribution. The lower 
percentile of 10 % can, for example, prevent the fade out of a music track from 
dominating the loudness range. The upper percentile of 95 % ensures that an 
unusually loud sound, such as a gunshot in a movie, is not responsible for a 
large loudness range.

The EBU R-128 loudness range, the dynamics range of the short-term 
loudness, and the dynamics range of the momentary loudness help to decide 
if dynamic compression is necessary, by giving instant feedback about the 
dynamics (too low, good, too much).

6) Dynamics range of the short-term loudness

This loudness range monitors the recent minimum/maximum loudness 
measurements to provide a hint about the short-term dynamics.

7) Dynamics range of the momentary loudness

This loudness range monitors the recent minimum/maximum loudness 
measurements to provide a hint about the momentary dynamics.

8) Loudness curve

This curve shows where the loudness is distributed in a song. The audio 
signal is divided into small blocks, and the loudness of each block is 
computed. The curve informs about how often audio events with a given 
loudness appear in the file in comparison to all other events. If the curve has 
a peak, the given loudness often appears in the song.

The curve is always normalized. The peak shows which loudness is the most 
represented in a song. The curve is related to the LRA as the LRA starts at the 
left part of the curve and ends at the right part, with a 10 %/95 % tolerance.

9) Gate LED

The Gate LED lights up when audio is discarded from measurement. The EBU 
standard discards audio below a specific level, relative to the average 
loudness.

10) Numerical values of the bars

This section shows the numerical values of the bars. The values in brackets 
are the loudness ranges.

11) True Peak LED

The True Peak LED is based on a true peak analysis and lights up when 
clipping is detected.

RELATED LINKS

EBU Loudness Standard R-128 on page 45



Metering
Loudness Meter

472

Loudness Meter Settings

In the Loudness Meter Settings dialog, you can set up the appearance of the 
Loudness Meter window.

• To open the Loudness Meter Settings dialog, open the Loudness Meter 
window, and select Functions > Settings.

Short-term Loudness/Momentary Loudness

Top Zone/Middle Zone/Low Zone

Here, you can specify the colors for the top, middle, and low zones of the 
meter.

From

Allows you to specify the starting point for the middle and top zones.

Show Maximum Values

If this option is activated, the maximum short-term and momentary values are 
displayed instead of the loudness range values.

Loudness Range

If this option is activated, a moving rectangle is displayed, which symbolizes 
the short-term loudness range/momentary loudness.

Ballistics

Determines the inertia of the loudness range for the short-term 
loudness/momentary loudness, that is, how fast the range edges meet each 
other after a new minimum or maximum loudness is reported.

Integrated Loudness

Target Loudness

Allows you to specify the ideal loudness to match. The EBU R-128 standard 
is -23 LUFS.

Acceptable Deviation

Allows you to specify the loudness range that is considered to be an 
acceptable deviation from the target loudness.

Outside the Acceptable Deviation

Allows you to specify a color for the range that is outside the acceptable 
deviation.
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Loudness Range

Range Color

Lets you specify the range colors if the range size is above the associated 
value (Too Much), exactly as the associated value (Good), or below the 
associated value (Not Enough).

Below/From

A loudness range that you consider to be not enough (Below) and too much 
(From).

Transition

Lets you specify how fast the color changes from Good to Too Much, and 
from Good to Not Enough. 0 % means that the color changes abruptly when 
a threshold is reached. 100 % means that the color changes gradually.

Additional Settings

Background/Marks/Grid/Curve

Lets you set the colors for the meter background, marks, grid lines, and the 
loudness distribution curve of the Loudness Meter.

Peak Hold Time

Determines how long the peak LED remains lit after a true peak.

Show Loudness Histogram

If this option is activated, a loudness histogram is displayed in the Loudness 
Meter.

Scale

In this section, you can specify the low and high end of the displayed level range.

The EBU +9 scale and the EBU +18 scale are EBU recommendations. Both of 
these scales are centered around 0 LU, which represents -23 LUFS, the 
recommended EBU loudness.

Phasescope

The Phasescope indicates the phase and amplitude relationship between two 
stereo channels.

• To open the Phasescope, select Meters > Phasescope.
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Reading the Phasescope

The Phasescope works as follows:

• A vertical line indicates a perfect mono signal (the left and right channels are 
the same).

• A horizontal line indicates that the left channel is the same as the right, but 
with an inverse phase.

• A fairly round shape indicates a well balanced stereo signal. If the shape leans 
to one side, there is more energy in the corresponding channel.

• A perfect circle indicates a sine wave on one channel, and the same sine wave 
shifted by 45° on the other.

• Generally, the more you can see a thread, the more bass is in the signal, and 
the more spray-like the display, the more high frequencies are in the signal.

Phase Correlation Meter

The phase correlation meter at the bottom of the display works as follows:

• The green line shows the current phase correlation, and the two red lines 
show the recent minimum and maximum values.

• With a mono signal, the meter shows +1, indicating that both channels are 
perfectly in phase.

• If the meter shows –1, the two channels are the same, but one is inverted.

• Generally, for a good mix, the meter should show a value between 0 and +1.

The phase correlation meter is also available in Analyze Audio Selection mode, 
showing an average value for the selected range.

Phasescope Settings

In the Phasescope Settings dialog, you can adjust the behavior, scale, and color 
of the meters.

• To open the Phasescope Settings dialog, open the Phasescope window, 
and select Functions > Settings.
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Background

Click this to change the background color.

Coil Display

Allows you to adjust the color for the grid and phase coil display.

Auto-Size (Maximize)

If this option is activated, the display is optimized to fit in the window.

Correlation Display

This is where you select colors for the elements in the phase correlation meter 
display, and adjust the peak hold time for the maximum and the minimum 
indicator.

Number of Samples to Display

This setting affects the length of the phase coil and the density of the display. 
For audio with high sample rates, you might want to raise this value.

Spectroscope

The Spectroscope shows a graphical representation of the frequency spectrum, 
analyzed into 60 separate frequency bands, represented as vertical bars.

• To open the Spectroscope, select Meters > Spectroscope.

Peak levels are shown as a horizontal lines above the corresponding bands, 
indicating recent peak/maximum values. The Spectroscope offers a quick 
spectrum overview. For a more detailed analysis of the audio spectrum, use the 
Spectrometer.

On the Functions menu, you can specify whether only high audio levels are 
displayed, or whether medium and low levels are also shown.

Spectrometer

The Spectrometer uses FFT (Fast Fourier Transform) techniques to display a 
frequency graph, providing a precise and detailed real-time frequency analysis.
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• To open the Spectrometer, select Meters > Spectrometer.

The current frequency spectrum is shown as a linear graph. Spectrum peaks are 
shown as short horizontal lines.

Zooming

In the Spectrometer window, you can zoom in on a frequency area.

• To zoom in on a frequency area, click and drag a rectangle in the spectrum. 
The display is zoomed in so that the selected frequency range fills the window.

• To return to full-scale display, select Functions > Zoom out Fully, or 
double-click in the spectrum.

Spectrometer Snapshots

You can take snapshots of the current spectrum, to check the effects of adding EQ, 
for example.

The snapshots are displayed on the spectrum graph. Up to five snapshots can be 
displayed. The sixth snapshot replaces the earliest snapshot.

• To take a snapshot, select Functions > Add Snapshot.

• To erase the last snapshot, select Functions > Erase Last Snapshot.
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Exporting FFT Data as ASCII Text

FFT (Fast Fourier Transform) analysis is a method to convert a waveform from the 
time domain to the frequency domain. You can export the displayed FFT data as a 
text file.

PROCEDURE

1. In the Audio Editor, select the Analysis tab.

2. In the Monitoring section, activate Edit Cursor or Audio Selection.

3. In the Spectrometer window, select Functions > Export FFT Data as 
ASCII.

4. Specify a file name and location.

5. Click Save.

RESULT 

The resulting text file can be imported into Microsoft Excel, or other applications that 
allow graph plotting from text files.

Spectrometer Settings

In the Spectrometer Settings dialog, you can adjust the behavior and display of 
the meters, and assign up to five sets of spectrometer settings to the preset 
buttons.

• To open the Spectrometer Settings dialog, open the Spectrometer 
window, and select Functions > Settings.

Process Tab

Analysis Block Size

The higher this value, the higher the accuracy in the frequency domain, that is, 
the spectrum is divided into more bands. At the same time, the time 
localization is reduced. This means that the higher the value, the less easy to 
know where a given frequency starts and ends in time.

NOTE

Raising the block size value also requires more CPU power and introduces a 
higher latency. Therefore, high values should only be used for off-line 
monitoring.
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Analysis Overlapping

To get more accurate results, the program can analyze overlapping blocks. 
This setting determines the amount of overlap between these blocks – the 
higher the value, the more accurate the results.

NOTE

Raising this value is very CPU intensive. A setting of 50 % requires twice the 
amount of CPU power, a setting of 75 % requires four times the CPU power, 
etc.

Smoothing Window

Allows you to choose which method to use for pre-processing the samples in 
order to optimize the spectrum display.

Display Tab

Frequency Ruler

Determines the frequency range to be shown, at full-scale display. The lowest 
frequency to be shown depends on the Analysis Block Size setting and the 
highest actual frequency depends on the sample rate.

Logarithmic Scale

When this is activated, each octave occupies the same horizontal space in the 
display. If you need more resolution in the high frequency range, you may want 
to turn this off.

Level Ruler

Determines the range of the vertical level ruler, in dB or as a percentage value.

Normalize Display to 0 dB

If this option is activated, the level display is offset, so that the highest point 
on the curve is displayed as 0 dB. This is only possible in non-real-time mode.

Optimize Scale

Optimizes the level scale so that only the relevant level range is shown. This 
is only possible in non-real-time mode.

Display Type

Allows you to toggle the display between curve and bar graph.

Peak Hold Time

Determines for how long the peak level graph remains displayed when the 
levels drop.

Colors

This is where you select colors for the curves, grid, background, etc.
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Bit Meter

The Bit Meter shows how many bits are used.

• To open the Bit Meter, select Meters > Bit-Meter.

While you may expect the maximum number of bits to be the same as the resolution 
of the audio file, this is not necessarily the case.

As soon as you perform any kind of real-time processing on an audio file, the audio 
data is treated at a much higher resolution (32-bit floating point), to allow for pristine 
audio quality. The only time when a 16-bit file is played back at 16-bit resolution is, 
for example, if you play it without any fades or effects, and with the master faders 
set to 0.00.

How to Read the Bit Meter

• The inner meters show how many bits are used.

• The outer meters show how many bits were recently in use.

• The Over segment indicates clipping.

• If the Below segment is lit, there are more than 24 bits. The Bit Meter shows 
the 24 higher bits, and the Below segment indicates the existence of extra, 
lower bits.

• If the Inter segment is lit, this indicates that the audio data cannot be correctly 
expressed on a regular 24-bit scale. For example, this is the case when 
floating point values in between bits are present, which is typically the case if 
you apply effects, etc.

When to Use the Bit Meter

The Bit Meter is useful in the following situations:

• To check whether dithering is necessary. If you are playing back or mixing 
down to 16 bits, and the Bit Meter shows that more than 16 bits are used, you 
should apply dithering.
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• To see the actual resolution of an audio file. For example, even though a file is 
in 24-bit format, only 16 bits may be used. Or, a 32-bit file may only use 
24 bits, in which case, the Below segment would not be lit.

• To see whether a plug-in that is set to zero still affects your signal, or whether 
a plug-in uses 16-bit internal processing.

Bit Meter Settings

In the Bit Meter Settings dialog, you can adjust the behavior and display of the Bit 
Meter.

• To open the Bit Meter Settings dialog, open the Bit Meter window, and 
select Functions > Settings.

Colors

You can adjust the colors of the meter segments, grids, background, etc. by 
clicking the corresponding color buttons.

Bit Hold Time

Determines for how long peak values are held by the outer meters.

Bit Display

Determines how the bits are displayed. In Intuitive Mode, the absolute value 
of the signal is shown. The bar graph goes higher with higher signal levels, 
similar to a common level meter.

In True Mode, the meter shows the direct mapping of the bits. However, 
because the actual values may be negative, there is no intuitive relationship 
with the level. This mode is useful if you want to check the full range, because 
all bits are displayed, regardless of the audio signal level.

Oscilloscope

The Oscilloscope offers a highly magnified view of the waveform around the 
playback cursor position.

• To open the Oscilloscope, select Meters > Oscilloscope.
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If you are analyzing stereo audio, the Oscilloscope normally shows the separate 
levels of the two channels. However, if you activate Show Sum and Subtraction 
on the Functions menu, the upper half of the Oscilloscope shows the mix of the 
two channels and the lower half shows the subtraction.

Oscilloscope Settings

In the Oscilloscope Settings dialog, you can adjust the display colors, and 
activate/deactivate Auto-Zoom. When Auto-Zoom is activated, the display is 
optimized so that the highest level reaches the top of the display at all times and 
even small signals are visible.

• To open the Oscilloscope Settings dialog, open the Oscilloscope window, 
and select Functions > Settings.

Wavescope

The Wavescope meter displays a real-time waveform drawing of the audio signal 
being monitored. It can be useful when recording or rendering a file if Monitor File 
Rendering mode is active.

• To open the Wavescope, select Meters > Wavescope.

Wavescope Settings

In the Wavescope Settings dialog, you can make various color settings for the 
background, grid, and waveform display, and set the waveform rendering speed and 
vertical zoom.

• To open the Wavescope Settings dialog, open the Wavescope window, and 
select Functions > Settings.

Colors

Lets you select colors for the waveform graphics.

Waveform Rendering Speed

Determines how much the waveform display is compressed.
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Level Zoom

Determines the level zoom. Set a high value if the waveform has a low 
amplitude.

Clear Waveform when Reaching Right of Pane

If this option is activated, the waveform display is cleared each time the cursor 
reaches the right end of the display. If this option is deactivated, the new 
waveform overwrites the previous waveform.
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Basic Audio CD

In WaveLab Pro, you can write Basic Audio CDs that are compatible with the Red 
Book standard.

In the Basic Audio CD window, you create your audio CD by adding audio files to 
a list of tracks. Each track contains a reference to the external audio file. This means 
that you can save your Basic Audio CD layout as its own session and continue 
editing individual tracks, for example.

A Basic Audio CD project contains the information about the CD track start position 
and the length of the referenced audio file. If the CD markers of an audio file are 
deleted, the audio file is removed from the Basic Audio CD project.

Once you have set up your CD layout, you can check the CD for conformity to the 
Red Book standard, write the CD, or export it to the Audio Montage window for 
further editing. You can also consolidate the audio files in the CD into a single audio 
file containing track markers.

A Basic Audio CD can also be used as a generic playlist. It allows you to assemble 
lists of files or sections of files with adjustable pauses in between.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

Writing Basic Audio CDs offers only basic functionality. For professional CD 
creation you should use the Audio Montage window.

RELATED LINKS

About the CD Window on page 357

Basic Audio CD Window

In this window, all tracks of the Basic Audio CD are listed. Here you can assemble 
and write Basic Audio CDs that are compatible with the Red Book standard.

• To open a new Basic Audio CD file, select File > New and click Basic Audio 
CD.

• To open a saved Basic Audio CD file, select File > Open and click Basic 
Audio CD. Select the Basic Audio CD file that you want to open and click 
Open.
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Track List

The track list shows information about the CD tracks. Apart from the entries in the 
Name column, you cannot edit the information shown in this window. The following 
informations are available for each track:

• Name

• Start position

• Length

• ISRC code

• Comment (not saved on the CD)

To show the markers and pauses of a track, click the arrow icon in front of the track.

The total time of the CD is displayed at the bottom of the window.

Playback Buttons

The playback buttons in the Start column allow you to play back the corresponding 
track.

From Start with Pre-Roll ( )

Playback from start with a pre-roll.

You can also press [Alt]/[Option] and click  to play back from the start with 
a short pre-roll.

From Start ( )

Playback from start.
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Edit Tab

Add Tracks

Allows you to select the audio files that you want to add to the Basic Audio 
CD.

Delete

Deletes the selected track from the Basic Audio CD.

Edit Audio

Displays the audio of the selected track in the wave window.

Options

Opens the Basic Audio CD Options dialog.

Write Audio CD or DDP

Opens a dialog from which you can write a CD or DDP.

Check CD Conformity

Verifies that the structure of the Basic Audio CD is correct according to the 
Red Book standard.

Clone Fully

Creates a single audio file that contains all the audio material used by the 
Basic Audio CD, as well as a new Basic Audio CD file. The new Basic Audio 
CD is independent from the audio files and markers that are referenced by the 
active Basic Audio CD.

Save Each CD Track as an Audio File

Opens a dialog where you can specify a location to save each track as 
separate audio file.

Create Audio File from All CD Tracks

Creates an audio file that recreates the structure of the Basic Audio CD and 
opens it in the wave window, without writing any audio sample to disk.

Convert to Audio Montage

Creates an audio montage with the same structure of CD tracks as the Basic 
Audio CD.

Basic Audio CD Options Dialog

In this dialog, you can specify an UPC/EAN code for the CD, add silence before 
and after tracks, specify pauses, and decide whether to play back the audio through 
the Master Section.

• To open the Basic Audio CD Options dialog, open a Basic Audio CD file, 
and on the Edit tab, click Options.
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UPC/EAN Code

Here you can specify an optional UPC/EAN code for the CD.

Adjust Gaps between Markers and Sound (as CD Frames)

If this option is activated, WaveLab Pro performs small adjustments to the 
spacing before and after the CD track markers. This is useful to ensure that a 
low-quality CD player does not miss the start of tracks or cut them off before 
their actual end, for example. You can specify the silence length for the 
following options:

• Silence after First Track Start Marker

• Silence after Track Start Marker

• Silence before Each Track End Marker

• Silence before Last Track End Marker

Default Pause

Allows you to add silence before the first track of the CD. Usually, the pause 
needs to be longer for the first track than for the other tracks, to ensure that a 
low-quality CD player does not miss the start of the first track, for example.

Reset Pause of All Tracks

If this option is activated, the pauses of all tracks are reset to the default value 
when you close the dialog.

Play through Master Section

If this option is activated, playback of the Basic Audio CD passes the Master 
Section.

NOTE

You cannot use this option when writing a Basic Audio CD.

Save as Default Settings

If this option is activated, the settings made in this dialog are used for newly 
created Basic Audio CDs.

CD Markers

A track in the Basic Audio CD window is defined by CD track start and end markers 
or CD track splice markers.

• CD track splice markers indicate the end of one track and the start of the next. 
If you insert a start marker after another start marker, the second marker is 
automatically converted into a splice marker.

• If you delete the CD markers defining a track, the track is deleted from the 
Basic Audio CD list.
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• If you edit the marker position of a CD track, the change is reflected in the 
track in the Basic Audio CD.

• When you create a CD track start marker, a CD track end marker is 
automatically created at the start of the next track or at the end of the audio 
file, whichever comes first.

• If you try to move CD track markers beyond the end of the corresponding file, 
to a position inside another track, etc., the marker is automatically moved to 
the closest valid position.

• The name of a CD track equals the name of the CD track start marker. Editing 
the marker name also changes the CD Track name, and vice versa.

Preparing a Basic Audio CD

You can add any type of file to a Basic Audio CD. However, when writing the files 
to CD, the files must meet specific specifications.

• 44100 Hz (44.1 kHz)

• Mono, dual mono, or stereo.

• 8, 16, 20, or 24-bit resolution. During the writing process, files are converted 
to 16-bit stereo.

A track can only be used once in a Basic Audio CD.

Creating a Basic Audio CD

PROCEDURE

1. Select File > New and click Basic Audio CD.

2. Add tracks to the Basic Audio CD project using the following methods:
• In the Basic Audio CD window, on the Edit tab, click Add Tracks, and select 

the audio files that you want to add.

• Drag audio files from the file browser of your computer to the Basic Audio CD 
window.

• Drag a selection of an audio file from the wave window to the Basic Audio CD 
window.

If a file contains CD start and sub-index markers, these are used to define the track 
in the list.

If a file does not contain markers, a dialog asks you if you want to use the file start and 
end as boundaries for the track.

3. Select File > Save, specify a name and location, and click Save.

RESULT 

The audio files are added to the Basic Audio CD project.
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Saving a Basic Audio CD

PREREQUISITE 

Set up your Basic Audio CD.

PROCEDURE

1. In the Basic Audio CD window, click the Save button, or select File > Save.

2. In the Save Basic Audio CD dialog, specify a file name and location.

3. Optional: Activate one of the following options:
• Open standard file selector before this dialog

• Save copy

4. Click Save.

Opening a Basic Audio CD Project

PROCEDURE

1. Select File > Open.

2. Select Basic Audio CD.

3. Select Browse.

4. Select a Basic Audio CD file and click Open.

RESULT 

All audio files that are referenced by the Basic Audio CD are opened in 
WaveLab Pro. However, they do not appear in the wave windows.

Deleting CD Tracks from a Basic Audio CD

You can delete a CD track from a Basic Audio CD project by deleting its CD track 
markers or by deleting it from the Basic Audio CD list.

• In the wave window, right-click the CD track start or end marker of the CD 
track that you want to delete, and select Delete.

• In the Basic Audio CD window, select a track, and on the Edit tab, click 
Delete.
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Adjusting Pauses in CD Tracks

You can change the length of the pause that is played before the beginning of a 
track in the Basic Audio CD.

PROCEDURE

1. In the Basic Audio CD window, click the arrow icon next to a track to unfold it.

2. Double-click the Length column of the Pause row, enter a value, and press 
[Return].

Opening CD Tracks for Editing

You can open the tracks of a Basic Audio CD in a wave window to edit the audio 
or open the tracks as a clip in an audio montage.

• To open an entire CD track, double-click it in the Length column. A wave 
window opens and the entire CD track is selected.

• To open an entire CD track and position the cursor at track start or end, click 
the arrow icon to unfold the CD track, and double-click the Length column of 
the Track Start or Track End rows.

• To insert a CD track into an open audio file, drag the CD track on the open 
audio file in the wave window.

• To open a CD track as a clip in an audio montage, drag the CD track into the 
audio montage and select one of the insert options.

Playing Back Files in the Track List

There are several ways to play back files in the track list of a Basic Audio CD.

• In the Start column, click the time information of the track that you want to play 
back.

What you hear during playback is identical to the audio that is played back 
from the actual CD. All pauses and other adjustments are taken into account.

If you have audio files in the list that do not have the correct sample rate 
(44.1 kHz), they can still be played back. However, when you activate 
playback, all files play back at the same rate. The inherent rate of the selected 
file is used for all files.

• Select a track, and click Play on the transport bar. Press Stop to stop 
playback.
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• To play back from the marker position, click the right play icon of a track in the 
Start column. To play back from the marker position with a pre-roll, click the 
left play icon.

Playing Back Files in the Track List Through the Master Section

Playing back files through the Master Section takes all the settings and effects in 
the Master Section into account.

PROCEDURE

1. In the Basic Audio CD window, on the Edit tab, click Options.

2. Activate Play through Master Section, and click OK.

Saving Basic Audio CD Tracks as Separate Files

You can save tracks of a Basic Audio CD as separate audio files on your hard disk. 
This is useful for archiving, for example.

PROCEDURE

1. Set up a Basic Audio CD.

2. In the Basic Audio CD window, on the Edit tab, click Save Each CD Track 
as an Audio File.

3. Specify a location and the output format.

4. Click OK.

RESULT 

The tracks in the list are saved as separate audio files in the specified folder.
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Saving Basic Audio CD Tracks as One File

You can save tracks of a Basic Audio CD as a single audio file on your hard disk.

PREREQUISITE 

Set up a Basic Audio CD. A track must be at least 4 seconds long.

PROCEDURE

1. In the Basic Audio CD window, on the Edit tab, click Clone Fully.

2. Specify a location.

3. Click OK.

RESULT 

The tracks in the list are saved as a single audio file in the specified folder.
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DVD-Audio

In WaveLab Pro, you can author a DVD-Audio from a collection of audio montages 
and write it to DVD-Audio.

You can add your audio montages to the DVD-Audio window, check the 
DVD-Audio layout for conformity, and write a DVD-Audio disk.

Compared to a Basic Audio CD, the DVD-Audio has the following advantages:

• More disk space

• Higher audio quality with up to 192 kHz and 24 bit

• Surround support

• Picture slide show support

The contents of a DVD-Audio project are saved in a folder named AUDIO_TS 
(Audio Title Set), which includes all audio, still picture, text, and visual menu data.

The AUDIO_TS contents are created when you render a DVD-Audio project. These 
data files are readable by the DVD-Audio player, but cannot be opened or edited in 
WaveLab Pro.

You can use DVD+R, DVD-R, DVD+RW, DVD-RW, DVD-RAM for writing 
DVD-Audio compatible discs.

NOTE

Throughout WaveLab Pro, where “CD” is mentioned (for example, in messages or 
marker names), this usually also applies for DVD-Audio.

Structure of a DVD-Audio Project

You structure your DVD-Audio projects in groups.

• An album can contain up to 9 groups. In WaveLab Pro, a group corresponds 
to an audio montage. A group is similar to a CD and can be represented by 
an audio montage.

• Each group can contain up to 99 tracks. Tracks are defined by CD track start 
and end markers in the audio montage.
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DVD-Audio Formats

A DVD-Audio project can contain audio in a variety of resolutions.

The sample rates can be 48 kHz, 96 kHz, 192 kHz, 44.1 kHz, 88.2 kHz, or 176 kHz 
and the bit-depths can be 16 or 24.

You can use other bit resolutions for audio files in a montage, but they are saved on 
the DVD-Audio disc as either 16-bit or 24-bit audio samples, regardless of the 
original resolution. The sample rate of the DVD is specified on the Info tab of the 
corresponding audio montage.

DVD-Audio Format Considerations

There are two main considerations when planning a DVD-Audio project: the total 
size of the album and the highest allowable data rate for a group.

A single album cannot contain more data than 4.7 GB (using a standard single layer 
DVD).

Highest Allowable Data Rate for a Group

The data rate is the data bandwidth that is necessary to reproduce a given number 
of channels at a specific bit resolution and sample frequency. The DVD-Audio 
specification allows for a maximum data rate of 9.6 Mbps when using an 
uncompressed PCM audio format.

To keep a DVD-Audio project within the allowable data rate limit, use the following 
list as a guide.

6 Channels

Maximum bit resolution/sample rate: Up to 16 bit/96 kHz or 24 bit/48 kHz

4 Channels

Maximum bit resolution/sample rate: Up to 24 bit/96 kHz

2 Channels

Maximum bit resolution/sample rate: Up to 24 bit/192 kHz

DVD-Audio Window

In this window, you can author DVD-Audio and write it to DVD.

• To open a new DVD-Audio file, select File > New and click Create 
DVD-Audio.
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• To open a saved DVD-Audio file, select File > Open and click DVD-Audio. 
Select the DVD-Audio file that you want to open and click Open.

DVD-Audio List

The columns in the DVD-Audio window show information about the audio 
montages in the project. Apart from the entries in the Group Name column, you 
cannot edit any of the information shown in this window.

Group Name

If you double-click the name, you can enter a new name for the group. By 
default, the name of the audio montage is used as the group name. The group 
name is shown in the DVD menu display.

File

The name of the audio montage. If you double-click the audio montage name, 
the corresponding audio montage opens.

Titles

The number of titles in the audio montage.

Time

The total time of all titles.

Bits

The bit depth of the samples in the audio montage as they will be saved on 
the final DVD.

Rate

The sample rate of the audio montage.

Channel

The number of audio channels used in the audio montage.

Size

The total size of the audio montage.
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Edit Tab

Add Audio Montages

Opens the file browser where you can select the audio montages that you 
want to add to the DVD-Audio.

Remove

Removes the selected audio montage from the DVD-Audio.

Open Audio Montage

Opens the montage window of the selected audio montage.

Options

Opens the DVD-Audio Options dialog.

Check Conformity

Verifies that the structure of the DVD-Audio conforms to the standard.

Write DVD-Audio

Opens a dialog from which you can write a DVD.

DVD-Audio Options Dialog

In this dialog, you can make various settings for the DVD-Audio.

• To open the DVD-Audio Options dialog, open a DVD-Audio file, select the 
Edit tab, and click Options.

Disc Identification

Volume ID and Number of Volumes allow you to specify disc information. 
For example, if you have a project that has 3 DVD discs, you can specify 3 
volumes, and specify the ID for the volumes 1, 2, and 3.

Album Name allows you to type in the name of the album. This name is also 
used as the DVD volume name.

Provider Information allows you to type in information about the DVD-Audio 
provider.

Options

If Generate Menus is activated, a basic menu displaying the 
album/group/tracks structure is automatically generated. This menu appears 
when playing back the DVD-Audio in a DVD player.

If Include Still Picture Tracks is activated, pictures placed on audio montage 
picture tracks are included on the DVD, and are displayed by a compatible 
DVD player.

If Auto Play is activated, DVD playback starts automatically when the DVD is 
inserted into a compatible DVD player.
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TV System

Specifies whether the DVD-Audio disc should conform to the NTSC or 
PAL/SECAM video standard.

Default Still Picture

If this option is activated, you can define a default still picture that is displayed 
when the DVD-Audio is played back.

Still Picture Effects

Lets you define effect transitions between pictures. Choose a mode and a 
duration of the transition for start and end of playback. Not all DVD players 
support this feature.

TV Systems

If you want to use still pictures, you need to specify whether the DVD-Audio disc 
should conform to the NTSC or PAL/SECAM video standard.

This is important because the NTSC (used in North America and Asia) and 
PAL/SECAM (used in Western Europe, Australia/France, and Eastern Europe) use 
different resolutions.

Preparing a DVD-Audio

Creating a DVD-Audio

PROCEDURE

1. Select File > New and click Create DVD-Audio.

2. Add tracks to the DVD-Audio project using the following methods:
• In the DVD-Audio window, on the Edit tab, click Add Audio Montages, and 

select the audio montages that you want to add.

• Drag audio montages from the file browser of your operating system to the 
DVD-Audio window.

• Drag an audio montage tab to the DVD-Audio window.

3. Select File > Save, specify a name and location, and click Save.

RESULT 

The audio montages are added to the DVD-Audio project.
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Saving a DVD-Audio

PREREQUISITE 

Set up your DVD-Audio.

PROCEDURE

1. In the DVD-Audio window, click Save As, or select File > Save As.

2. In the Save DVD-Audio dialog, specify a file name and location.

3. Click Save.

Opening a DVD-Audio Project

PROCEDURE

1. Select File > Open and click DVD-Audio.

2. Select Browse.

3. Select a DVD-Audio file and click Open.

RESULT 

All audio montages that are referenced by the DVD-Audio file are opened in 
WaveLab Pro. However, they do not appear in the montage window.

Setting an Audio Montage to DVD-Audio Mode

To be able to write an audio montage to DVD-Audio, the mode of the audio montage 
must be DVD-Audio compatible.

PROCEDURE

1. In the Audio Montage window, click the File tab.

2. Click Info.

3. Open the Mode menu and select Multichannel (DVD-Audio Compatible).

4. Click File > Save to save the changes.
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Removing Audio Montages from a DVD-Audio

When removing audio montages from a DVD-Audio, the audio montage references 
are removed from the DVD-Audio, but the audio montage files are not deleted.

PROCEDURE

1. In the DVD-Audio window, select an audio montage.

2. On the Edit tab, click Remove.

Opening Audio Montages for Editing

There are several ways to open an audio montage of a DVD-Audio project for 
editing in the Audio Montage window.

• Double-click the audio montage in DVD-Audio window.

• Select an audio montage from the list, select the Edit tab, click Open Audio 
Montage.

• Drag an audio montage from the DVD-Audio window to an open audio 
montage, or the Audio Montage window area.

Checking the DVD-Audio Conformity

Before rendering the DVD-Audio project, you can use the Check Conformity 
function to make sure that the settings conform to the DVD-Audio standard. This is 
also done automatically before writing to disk.

PROCEDURE

1. In the DVD-Audio window, select the Edit tab.

2. Click Check Conformity.

RESULT 

All audio montages that are part of the DVD-Audio project are checked for their 
conformity. Afterwards, a message opens stating the result of the conformity check.
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Writing Operations

This chapter describes the CD/DVD writing processes in WaveLab Pro. This 
chapter assumes that the preparations have been completed, and that you are 
ready to run the actual writing process. Refer to the chapters Basic Audio CD, 
DVD-Audio, and CD window for a description of the preparations before following 
the instructions in this chapter.

RELATED LINKS

Basic Audio CD on page 483
DVD-Audio on page 492
About the CD Window on page 357

Write Audio CD or DDP Dialog

In this dialog, you can write your audio CD project and audio montage to audio CD 
or DDP image.

• If you want to write audio files to an audio CD or a DDP image, open the Basic 
Audio CD window, select the Edit tab, and click Write Audio CD or DDP.

• If you want to write audio montages to an audio CD or a DDP image, open the 
CD window, and select Functions > Write Audio CD or DDP.

The following options are the same for writing both audio files and audio montages 
to audio CD or DDP image.
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Device

Allows you to select the disc writer that you want to use or select DDP Image 
to write a set of DDP files on the hard drive.

NOTE

On the Mac, insert a medium in the drive after opening WaveLab Pro. 
Otherwise, the drive is under the control of the operating system and is not 
available for WaveLab Pro.

Refresh

Scans the system for connected optical devices. This is done automatically 
when this dialog opens. Click the refresh icon after you insert a new blank 
medium to update the Speed menu.

NOTE

On the Mac, insert a medium in the drive after opening WaveLab Pro. 
Otherwise, the drive is under the control of the operating system and is not 
available for WaveLab Pro.

Eject Optical Medium

Ejects the optical medium present in the selected drive.

Device Information

Opens the Device Information dialog that shows information about the 
selected device.

Erase Optical Media

Erases the optical medium present in the selected drive, provided it is a 
rewritable media.

If DDP Image is selected, clicking the button erases the existing DDP files.

Bypass Master Section

If this option is activated, the audio signal is not processed through the 
Master Section before being written to the medium. For writing a Basic Audio 
CD, this option is always activated.

Destination Folder (DDP image must be selected)

Allows you to specify the destination path. If you type a non-existing path, it is 
automatically created.

Write Table of Contents and Customer Information (DDP image must be 
selected)

If this option is activated, a file called IDENT.TXT is written in the DDP folder. 
It contains a table of contents of the tracks and some customer information. 
This file is not officially part of the DDP specification, but it can be used by the 
recipient of the DDP image to identify the files.
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Speed

Allows you to select the writing speed. The highest speed depends on the 
capabilities of your writing device and of the medium present in the device.

Copies

Allows you to define the number of copies that you want to write.

Test Only, Do Not Write

If this option is activated, clicking OK initiates a simulation of writing the CD. 
If this test is passed, the real write operation will succeed. If the test fails, try 
again at a lower writing speed.

Render to Temporary File before Writing (only available for writing audio 
montages)

If this option is activated, a disk image is created before writing, which 
eliminates the risk of buffer underruns. This is useful if your project uses many 
audio plug-ins while writing. It is activated automatically when writing multiple 
copies. While this option makes the writing operation longer, it allows you to 
select an higher writing speed.

CD-Extra Compatible (New Session Possible)

If this option is activated, the resulting audio CD is compatible with the 
CD-Extra format.

Eject after Completion

If this option is activated, the medium is ejected after the writing operation.

Erase Optical Media Dialog

In this dialog, you can quickly or fully erase an optical disc before writing.

• To open the Erase Optical Media dialog, open the Write Audio CD or DDP 
dialog and click the eraser icon.

Quick Erase

Erases the table of contents of the disc.

Full Erase

Erases all parts of the disc.
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Force Erasing Even If a Disk Appears to Be Blank

If this option is activated, the disc is erased, even if it is declared as blank. Use 
this option to make sure that discs that were partially or minimally erased are 
fully erased.

About Writing Audio Files

You can write the audio files of a Basic Audio CD project to an audio CD or a DDP 
image.

Writing Audio Files to an Audio CD

PREREQUISITE 

Set up a Basic Audio CD project.

NOTE

On the Mac, insert a media in the drive after opening WaveLab Pro. Otherwise, the 
drive is under the control of the operating system and is not available for 
WaveLab Pro.

PROCEDURE

1. Optional: In the Basic Audio CD window, select the Edit tab, and click Check 
CD Conformity to check that all settings conform to the Red Book standard.

2. Insert an empty CD into your drive.

3. In the Basic Audio CD window, on the Edit tab, click Write Audio CD or 
DDP.

4. From the Device pop-up menu, select the writing device that you want to use.

5. Select the writing speed from the Speed pop-up menu.

6. Optional: Activate one or several of the following options:
• Activate Test Only, Do Not Write if you want to test if the writing operation is 

successful.

• Activate CD-Extra Compatible (New Session Possible) if you want the 
resulting audio CD to be compatible with the CD-Extra format.

• Activate Eject after Completion if you want the disc to be automatically 
ejected after the writing operation.

7. Click OK to start the writing operation.

RELATED LINKS

Write Audio CD or DDP Dialog on page 499
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Writing Audio Files to DDP Image

There might be situations when you want to freeze an entire Basic Audio CD, 
without actually writing a CD. This is done by saving it as a DDP image.

PREREQUISITE 

Set up a Basic Audio CD project.

PROCEDURE

1. Optional: In the Basic Audio CD window, select the Edit tab, and click Check 
CD Conformity to check that all settings conform to the Red Book standard.

2. In the Basic Audio CD window, on the Edit tab, click Write Audio CD or 
DDP.

3. From the Device pop-up menu, select DDP Image.

4. Specify the destination folder.

5. Optional: Activate Write Table of Contents and Customer Information to 
create a text file, containing information about the DDP file.

6. Click OK to start the writing operation.

RELATED LINKS

Write Audio CD or DDP Dialog on page 499

Writing an Audio CD from a DDP Image

You can write a CD from a DDP image that you have previously created with 
WaveLab Pro or another application.

PROCEDURE

1. Select File > Tools > Write Audio CD from DDP Image.

2. In the Write Audio CD from DDP Image dialog, open the Device pop-up 
menu, and select the writing device that you want to use.

3. Select the writing speed from the Speed pop-up menu.

4. Select the DDP image folder.

5. Optional: Activate one or several of the following options:
• Activate Test Only, Do Not Write if you want to test if the writing operation 

would be successful.

• Activate Eject after Completion if you want the disc to be automatically 
ejected after the writing operation.

6. Click OK to start the writing operation.
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Write Audio CD From DDP Image Dialog

This dialog allows you to write a CD from a DDP image that you have previously 
created with WaveLab Pro or another application.

• To open the Write Audio CD from DDP Image dialog, select File > Tools > 
Write Audio CD from DDP Image.

Device

Here, select the disc writer that you want to use.

NOTE

On the Mac, insert a medium in the drive after opening WaveLab Pro. 
Otherwise, the drive is under the control of the operating system and is not 
available for WaveLab Pro.

Refresh

Scans the system for connected optical devices. This is done automatically 
when this dialog opens. Click the update icon after you insert a new blank 
media to update the Speed menu.

NOTE

On the Mac, insert a medium in the drive after opening WaveLab Pro. 
Otherwise, the drive is under the control of the operating system and is not 
available for WaveLab Pro.

Eject Optical Medium

Ejects the optical medium present in the selected drive.

Device Information

Opens the Device Information dialog that shows information about the 
selected device.

Erase Optical Disc

Erases the optical disc present in the selected drive, provided it is a rewritable 
media. If DDP Image is selected, clicking the button erases the existing DDP 
files.
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Speed

Allows you to select the writing speed. The highest speed depends on the 
capabilities of your writing device and of the medium present in the device.

Test Only, Do Not Write

If this option is activated, clicking OK initiates a simulation of writing the CD. 
If this test is passed, the real write operation will succeed. If the test fails, try 
again at a lower writing speed.

Eject after Completion

If this option is activated, the medium is ejected after the writing operation.

DDP Image Folder

Lets you specify the source path of the DDP image.

About Writing Audio Montages

You can write audio montages to an audio CD or a DDP image.

Writing an Audio Montage to an Audio CD

PREREQUISITE 

Set up your audio montage and make your CD writing settings in the Global 
Preferences.

NOTE

On the Mac, insert a media in the drive after opening WaveLab Pro. Otherwise, the 
drive is under the control of the operating system and is not available for 
WaveLab Pro.

PROCEDURE

1. Optional: In the CD window, select Functions > Check CD Conformity to 
check that all settings conform to the Red Book standard.

2. Insert an empty CD into your drive.

3. In the CD window, select Functions > Write Audio CD or DDP.

4. From the Device pop-up menu, select the writing device that you want to use.

5. If you want to bypass the Master Section, activate Bypass Master Section.

6. Select the writing speed from the Speed pop-up menu.

7. Select the number of copies that you want to write.
When you want to write more than one copy, it is recommended to activate Render 
to Temporary File before Writing.

8. Optional: Activate one or several of the following options:
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• Activate Test Only, Do Not Write if you want to test if the writing operation 
would be successful.

• Activate Render to Temporary File before Writing if your audio montage uses 
many plug-ins. This way, the audio data is sent to the CD writer fast enough.

• Activate CD-Extra Compatible (New Session Possible) if you want the 
resulting audio CD to be compatible with the CD-Extra format.

• Activate Eject after Completion if you want the disc to be automatically 
ejected after the writing operation.

9. Click OK.

RESULT 

The writing operation starts.

RELATED LINKS

Write Audio CD or DDP Dialog on page 499

Writing an Audio Montage to a DDP Image

PREREQUISITE 

Set up your audio montage, and make your CD writing settings in the Global 
Preferences.

PROCEDURE

1. Optional: In the CD window, select Functions > Check CD Conformity to 
check that all settings conform to the Red Book standard.

2. In the CD window, select Functions > Write Audio CD or DDP.

3. From the Device pop-up menu, select DDP Image.

4. If you want to bypass the Master Section, activate Bypass Master Section.

5. Specify the destination folder.

6. Optional: Activate Write Table of Contents and Customer Information to 
create a text file, containing information about the DDP file.

7. Click OK to start the writing operation.

RELATED LINKS

Write Audio CD or DDP Dialog on page 499
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Writing Audio Montages With Any Sample Rate

You can write audio montages to CD/DDP even if they are not at 44.1 kHz. To be 
able to do this, set up the Resampler plug-in in the Master Section. This 
procedure is not automated so that you can customize the resampling quality, 
limiting, and dithering.

PREREQUISITE 

Set up your audio montage.

PROCEDURE

1. In the Master Section, add the Resampler plug-in to an Effects slot.

2. In the Resampler, set the Sample Rate to 44.1 kHz.

3. Optional: Add a Peak Limiter and a Dithering plug-in at the end of the 
Master Section.

4. Write the audio montage as you would write any other audio montage.

RELATED LINKS

Writing an Audio Montage to an Audio CD on page 505
Writing an Audio Montage to a DDP Image on page 506

Checking the Transition Between Tracks

You can set up a pre-roll time before tracks start and then play back all tracks. This 
way you can check the transition between tracks.

PREREQUISITE 

Set up your audio montage.

PROCEDURE

1. In the CD window, select Options > Edit Playback Times.

2. Make your settings, and click OK.

3. In the CD window, select Functions > Play All CD-Track Starts.

RESULT 

Each track start point and end point is played back according to the values set in 
the Edit Playback Times dialog.

CD-Text

CD-Text is an extension of the Red Book Compact Disc standard and allows you 
to save text information such as title, songwriter, composer, and disc ID on an audio 
CD.
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The text data is then displayed by CD players that support the CD-Text format. The 
CD-Text can also be included in the audio CD report.

CD-Text Editor Dialog

In this dialog, you can specify information such as track title, performer, and 
songwriter, that is written onto the CD as CD-Text.

You can add information about the disc itself and each individual track. This 
information is entered in the text fields that scroll horizontally. There is one pane of 
fields for the disc itself and a pane for each track.

• To open the CD-Text Editor dialog, in the CD window, select the track for 
which you want to edit the CD-Text, and select Functions > Edit CD-Text.

Copy CD Track Marker Name

Copies the name of the CD track marker to this field.

Copy CD Track Start Marker Name to All CD Track Titles

Copies the name of each CD track start marker to the title field of each CD 
track.

Copy Text to All Following Tracks

Copies the text to all tracks that are located after the current one.

Scrollbar

Allows you to navigate across all CD-Texts. The first position corresponds to 
the whole CD, other positions to individual tracks.

Language

Here, select how characters should be encoded on the CD.

NOTE

If a character is not CD-Text compatible, it is displayed as a ? character.
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Restrict to ASCII

To ensure the maximum compatibility with CD players, it is recommended to 
restrict the characters to ASCII when using the Western European option. If 
this option is activated, and you type a non-compatible character, a ? 
character is displayed.

Enable CD-Text Writing

If this option is activated, the CD-Text is written onto the CD.

Import

Allows you to import a text file that contains CD-Text.

Importing CD-Text

You can import CD-Text that has been written in a standard CSV text file in UTF-8 
format.

• To import CD-Text, click Import in the CD-Text Editor dialog and select the 
text file that you want to import.

Importing CD-Text replaces the content of the CD-Text Editor dialog.

You can specify the CSV delimiter in the Global Preferences on the Formats tab. 
The CSV file must only contain the text and between 1 and 7 fields per line. The text 
must be in the following order:

1) Title

2) Performer

3) Songwriter

4) Composer

5) Arranger

6) Message

7) Disc ID

RELATED LINKS

Formats Tab on page 703

Audio CD Reports

An audio CD report is a detailed report about the active audio CD. This report 
includes a full track listing with ISRC codes, track times, and CD-Text.

The audio CD report can be output in HTML, Adobe PDF, XML, simple text format, 
CSV format, or printed out. You can choose the details of what is displayed and 
include your custom logo. You can send the audio CD report to your client, an 
album artwork designer, or to the CD replication house when presenting them with 
a master CD, for example.

There are two types of variables:
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• Factory variables provide automatically generated information about a project, 
such as number of tracks, track times, track names, etc., based on the actual 
contents of the project.

• User defined variables contain personal data such as company name and 
copyright information, etc.

Along with the variables, the audio CD report can also include any CD-Text that you 
have specified, for example, composers or performers.

Generating an Audio CD Report

An audio CD report should be generated when an audio montage is fully prepared 
and ready for CD writing.

PROCEDURE

1. Open the audio montage that you want to create a report for.

NOTE

The audio montage must be in stereo mode.

2. Select Tool Windows > CD.

3. In the CD window, select Functions > Generate Audio CD Report.

4. On the Rich Text tab, in the Output format section, specify one of the 
following output formats:
• HTML

• Adobe PDF

• Print

• XML

• CSV

5. Make your settings.

6. Optional: On the Raw Text tab, select a cue sheet template or enter cue 
sheet information.

7. Optional: If you want to save the audio CD report to a specific location, 
activate Specify File Name and Location, and specify a file name and 
location.

8. Click Apply.

Audio CD Report Dialog

In this dialog, you can generate an audio CD report and specify which information 
to include in this report.

• To open the Audio CD Report dialog, in the CD window, select Functions > 
Generate Audio CD Report.



Writing Operations
About Writing Audio Montages

511

Global Options

The following option is available on the Rich Text tab and the Raw Text tab.

Specify File Name and Location

Lets you specify a name and location for the report. The file is created when 
you click Apply.

Rich Text Tab

CD Tracks

Allows you to select whether you want to create an audio CD report for all 
tracks or for a specific track group.

Font/Font Size

Determines the font and font size to use in the report.

Header Image

Lets you select an image to be inserted at the top of the report.

Center Image

Centers the image horizontally. If deactivated, the image is placed on the left.

Header

Adds general information at the start of the report.

Custom Text

Lets you enter text to be inserted at the top of the report. To insert custom 
variables, right-click the text field.

Extra Lines

Lets you select which of the following information you want to add to the 
header:

• Date

• Audio Montage Name

• UPC/EAN Code

• Number of Tracks

• Disc Duration

Skip Lines with Empty Values

If this option is activated, a line is not added to the report if the line contains 
an empty variable.
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Ignore CD Pre-Gap

If this option is activated, the default 2 second gap at the start of a red-book 
CD is ignored.

ISRC

Adds a column to the report to display the ISRC code.

Pre-Emphasis Status

Adds a column to the report to display the track pre-emphasis status.

Copy Status

Adds a column to the report to display the copy status of the track.

Time Details

Adds a description of the pause, track start, and possible sub-indexes to the 
report.

Pause

If this option is activated, the pause information is included in the report.

Sub-Indexes

If this option is activated, track sub-indexes are described in the report.

Sub-Indexes Relative to Track

Sets the sub-index values to be relative to the start of the corresponding track. 
If deactivated, they are relative to the start of the CD.

Start Time (in Audio Montage)

Adds a column to the report to display the event times from the start of the 
audio montage.

Start Time (on CD)

Adds a column to the report to display the event times from the start of the 
CD.

CD-Text

If this option is activated, the CD-Text is included in the report. You can 
specify which CD-Text information you want to include in the report.

Output Format

Lets you select the output format for the report.

• HTML generates an HTML file with a UTF-8 character format.

• Adobe PDF generates a PDF file.

• Print generates a preview of the report, allowing you to print the report. 
If no printer is connected, the preview is empty.

• XML generates an XML file that includes the CD information.
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• CSV generates a CSV file that can be imported in a spreadsheet. The 
CSV file can only save the main properties of the CD report. You can 
set the type CSV delimiter in the Global Preferences dialog on the 
Formats tab.

Value Format

Opens the Value Formats dialog, where you can edit the format of the 
auto-generated values. These variables are part of any presets saved for this 
dialog.

Raw Text Tab

Template

Lets you select a template for the report layout. When selecting Custom, you 
can also create your own cue sheet template.

Cue sheet field

Lets you write a cue sheet.

Copy to Clipboard

Copies the text to the clipboard.

Cue Sheet Templates

A cue sheet is an alternate form of the CD report, based on raw UTF-8 text, and can 
be customized in several ways. Creating a cue sheet requires an understanding of 
computers and some knowledge about programming, because it makes use of the 
commands and variables concept.

Cue sheets are organized in the following way: There are a number of codes, 
commands, and variables, which you place in a text file – the template. If you ask the 
program to generate a cue sheet, it creates the text file based on the codes it finds 
in the template.
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If the program encounters a variable, it replaces this with some information about 
the CD. For example, there is a variable called “NUM_TRACKS”. When the program 
finds this, it replaces it with the actual number of tracks in the CD.

Commands, on the other hand, are instructions for the program to do something. 
For example, the command “TIMECODE SEPARATOR =” followed by a few 
special characters, instructs the program what characters should be inserted 
between time code values, so that you can get time code values printed out in the 
format 00:00:00.00, “00 00 00 00”, or anything else you prefer.

The following codes can be entered for specific purposes:

$

A variable. The text that follows right after the “$” is the command name, for 
example, “$TITLE”. A variable can occur anywhere on a line, and there can be 
any number of variables on a line.

#

A command. The text that follows after the “#” is the command name, for 
example, “#FOR EACH TRACK”. There can only be one command per line 
and there should not be anything else on that line.

;

If a line starts with a semi-colon “;”, the line is interpreted as a comment. 
Nothing on such a line is used in the cue sheet. This is useful for making notes, 
for example.

All other text characters can be entered on their own lines or among the variables, 
and are used as they are. For example, if you type “Title: $TITLE” and the title you 
have entered is “My Greatest Hits!”, the text “Title: My Greatest Hits” appears in 
the cue sheet.

To find out more about the available commands and how they are used, you can 
open the included templates and study them. The following variables are available:

Track Number

T0

As decimal number “1” or “22”

T1

Blank Justified Two Digit Number “1” or “22”

T2

Zero Justified Two Digit Number “01” or “22”

Track Index

I0

As decimal number “1” or “22”
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I1

Blank Justified Two Digit Number “1” or “22”

I2

Zero Justified Two Digit Number “01” or “22”

Copy Protection Status

C1

“x” or “ ”

C2

“Y” or “N”

Emphasis Status

E1

“x” or “ ”

E2

“Y” or “N”

Absolute Time of Index

TIME_IA_0

As decimal number

TIME_IA_1

Blank justified 7 digit decimal number

TIME_IA_2

Time as “hh:mm:ss:ff”

TIME_IA_3

Time as “hh:mm:ss:ff” blank justified, leading zero not displayed

TIME_IA_4

Time as “hh:mm:ss:ff” compressed if there are no hours, none are displayed

TIME_IA_5

Time as “mm:ss:ff” no hours displayed

TIME_IA_6

Time as “mm:ss:ff” blank justified, leading zero not shown, no hours displayed

TIME_IA_7

Time as “mm:ss:ff” no minutes displayed if not required, no hours displayed
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TIME_IA_8

Time format as “1h 2mn 3s 4f”

TIME_IA_9

Time format as “1h 2mn 3s”

Index Time Relative to Start of CD

TIME_IR_0

As decimal number

TIME_IR_1

Blank justified 7 digit decimal number

TIME_IR_2

Time as “hh:mm:ss:ff”

TIME_IR_3

Time as “hh:mm:ss:ff” blank justified, leading zero not displayed

TIME_IR_4

Time as “hh:mm:ss:ff” compressed if there are no hours, none are displayed

TIME_IR_5

Time as “mm:ss:ff” no hours displayed

TIME_IR_6

Time as “mm:ss:ff” blank justified, leading zero not shown, no hours displayed

TIME_IR_7

Time as “mm:ss:ff” no minutes displayed if not required, no hours displayed

TIME_IR_8

Time format as “1h 2mn 3s 4f”

TIME_IR_9

Time format as “1h 2mn 3s”

Index Time Relative to Start of Track

TIME_IT_0

As decimal number

TIME_IT_1

Blank justified 7 digit decimal number

TIME_IT_2

Time as “hh:mm:ss:ff”
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TIME_IT_3

Time as “hh:mm:ss:ff” blank justified, leading zero not displayed

TIME_IT_4

Time as “hh:mm:ss:ff” compressed if there are no hours, none are displayed

TIME_IT_5

Time as “mm:ss:ff” no hours displayed

TIME_IT_6

Time as “mm:ss:ff” blank justified, leading zero not shown, no hours displayed

TIME_IT_7

Time as “mm:ss:ff” no minutes displayed if not required, no hours displayed

TIME_IT_8

Time format as “1h 2mn 3s 4f”

TIME_IT_9

Time format as “1h 2mn 3s”

Pause Length

TIME_PA_0

As decimal number

TIME_PA_1

Blank justified 7 digit decimal number

TIME_PA_2

Time as “hh:mm:ss:ff”

TIME_PA_3

Time as “hh:mm:ss:ff” blank justified, leading zero not displayed

TIME_PA_4

Time as “hh:mm:ss:ff” compressed if there are no hours, none are displayed

TIME_PA_5

Time as “mm:ss:ff” no hours displayed

TIME_PA_6

Time as “mm:ss:ff” blank justified, leading zero not shown, no hours displayed

TIME_PA_7

Time as “mm:ss:ff” no minutes displayed if not required, no hours displayed

TIME_PA_8

Time format as “1h 2mn 3s 4f”
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TIME_PA_9

Time format as “1h 2mn 3s”

Track Length

TIME_TR_0

As decimal number

TIME_TR_1

Blank justified 7 digit decimal number

TIME_TR_2

Time as “hh:mm:ss:ff”

TIME_TR_3

Time as “hh:mm:ss:ff” blank justified, leading zero not displayed

TIME_TR_4

Time as “hh:mm:ss:ff” compressed if there are no hours, none are displayed

TIME_TR_5

Time as “mm:ss:ff” no hours displayed

TIME_TR_6

Time as “mm:ss:ff” blank justified, leading zero not shown, no hours displayed

TIME_TR_7

Time as “mm:ss:ff” no minutes displayed if not required, no hours displayed

TIME_TR_8

Time format as “1h 2mn 3s 4f”

TIME_TR_9

Time format as “1h 2mn 3s”

CD Length

TIME_CD_0

As decimal number

TIME_CD_1

Blank justified 7 digit decimal number

TIME_CD_2

Time as “hh:mm:ss:ff”

TIME_CD_3

Time as “hh:mm:ss:ff” blank justified, leading zero not displayed
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TIME_CD_4

Time as “hh:mm:ss:ff” compressed if there are no hours, none are displayed

TIME_CD_5

Time as “mm:ss:ff” no hours displayed

TIME_CD_6

Time as “mm:ss:ff” blank justified, leading zero not shown, no hours displayed

TIME_CD_7

Time as “mm:ss:ff” no minutes displayed if not required, no hours displayed

TIME_CD_8

Time format as “1h 2mn 3s 4f”

TIME_CD_9

Time format as “1h 2mn 3s”

Various

NUM_TRACKS

Total number of tracks as decimal number

UPC

UPC/EAN code

ISRC

ISRC code

FILE

File name (no path)

PFILE

File name (with path)

TRACK_NAME

Track name

TRACK_COMMENT

Track comment

Creating a Cue Sheet Template

You can create a cue sheet template and load it each time you want to create an 
audio CD report.

PROCEDURE

1. Open an audio montage that contains CD tracks.
The audio montage must be in stereo mode.
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2. Select Tool Windows > CD.

3. In the CD window, select Functions > Generate Audio CD Report.

4. Select the Raw Text tab.

5. In the Template section, select Custom to start with an empty cue sheet, or 
select one of the available cue sheets to modify them.

6. Enter the cue sheet information.

7. Activate Specify File Name and Location, and specify a file name and 
location.

8. Click Apply to save the cue sheet template.

Write DVD-Audio Function

Before writing an audio montage to DVD-Audio, the contents of the DVD-Audio 
project must be rendered to an AUDIO_TS folder. This folder is automatically added 
to a Data CD/DVD project, from which you can start the actual writing operation.

DVD-Audio Creation Dialog

This dialog allows you to make settings for the DVD-Audio creation.

• To open the DVD-Audio Creation dialog, in the DVD-Audio window, set up 
the DVD-Audio project and click Write DVD-Audio.

Test Only

If this option is activated, all data is checked and rendered in memory to know 
if the DVD-Audio project is complete and ready for rendering. When the test 
is finished, a report opens.

Render Each Audio Montage with Its Own Plug-in Set

If this option is activated, each audio montage is rendered with its own Master 
Section effects.

Use Current Master Section Settings for All Audio Montages

If this option is activated, all audio montages are rendered using the selected 
Master Section settings.

Ignore

If this option is activated, the audio montages are rendered without any 
Master Section effects.

Output Folder

Lets you select the destination folder for the rendered files.
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Rendering the DVD-Audio

To be able to write the DVD-Audio project to disc or ISO image, you must render 
the DVD-Audio project first.

PREREQUISITE 

Set up the DVD-Audio project.

If you want to use the Master Section plug-ins when rendering the project, set up 
the Master Section to your liking.

PROCEDURE

1. In the DVD-Audio window, select the Edit tab.

2. In the Burn section, click Write DVD-Audio.

3. In the Master Section plug-ins section, select one of the following options:
• Render Each Audio Montage with Its Own Plug-in Set

• Use Current Master Section Settings for All Audio Montages

• Ignore

4. Specify an output folder.

5. Click OK.

RESULT 

The Write Data CD/DVD dialog opens, allowing you to write your DVD-Audio 
project.

Write Data CD/DVD Dialog When Writing DVD-Audio

In this dialog, you can write your DVD-Audio project to a CD/DVD or an ISO file.

• To open the Write Data CD/DVD dialog, set up the DVD-Audio project in the 
DVD-Audio window and click Write DVD-Audio. After the rendering 
operation is finished, the Write Data CD/DVD dialog opens.
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Device

Lets you select the disc writer that you want to use, or select ISO Image to 
write a file on the hard drive. You can use an ISO image to create an optical 
medium that you want to write to disc in the future.

NOTE

On the Mac, insert a medium in the drive after opening WaveLab Pro. 
Otherwise, the drive is under the control of the operating system and is not 
available for WaveLab Pro.

Refresh

Scans the system for connected optical devices. This is done automatically 
when this dialog opens. Click the update icon after you insert a new blank 
media, to update the speed menu.

NOTE

On the Mac, insert a medium in the drive after opening WaveLab Pro. 
Otherwise, the drive is under the control of the operating system and is not 
available for WaveLab Pro.

Eject Optical Medium

Ejects the optical medium present in the selected drive.

Device Information

Opens the Device Information dialog that shows information about the 
selected device.

Erase Optical Disc

Erases the optical disc present in the selected drive, provided it is a rewritable 
media. If ISO Image is selected, clicking the button erases the existing ISO 
file.

ISO File Name

If ISO Image is selected on the Device menu, specify the file name and file 
location of the ISO file in the text field.

Speed

Allows you to select the writing speed. The highest speed depends both on 
the capabilities of your writing device and of the medium present in the device.

Test Only, Do Not Write

If this option is activated, clicking OK initiates a simulation of writing the CD. 
If this test is passed, the real write operation will succeed. If the test fails, try 
again at a lower writing speed.

Verify After Write

If this option is activated, the data on the medium is automatically verified after 
the writing process.
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Eject Before Verifying

If this option is activated, the disc is ejected and retracted before the 
verification process, to force the drive out of the write state. This is only 
possible if the disc can be retracted automatically.

Eject After Completion

If this option is activated, the medium is ejected after the writing operation.

Writing a DVD-Audio Project to a Data CD/DVD

After rendering the DVD-Audio project, you can write it to a Data-CD/DVD.

PREREQUISITE 

You have set up and rendered a DVD-Audio project.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

On the Mac, insert a media in the drive after opening WaveLab Pro. Otherwise, the 
drive is under the control of the operating system and not available for 
WaveLab Pro.

PROCEDURE

1. Insert an empty DVD into your drive.

2. In the DVD-Audio window, select the Edit tab.

3. In the Burn section, click Check Conformity to check that all settings are 
compatible with the Red Book standard.

4. Click Write DVD-Audio.

5. In the Master Section plug-ins section, select one of the following options:
• Render Each Audio Montage with Its Own Plug-in Set

• Use Current Master Section Settings for All Audio Montages

• Ignore

6. Specify an output folder.

7. Click OK.

8. In the Write Data CD/DVD dialog, open the Device pop-up menu, and select 
the disc writing device that you want to use.

9. Select the writing speed from the Speed pop-up menu.

10. Optional: Activate one or several of the following options:
• Activate Test Only, Do Not Write if you want to test if the writing operation 

would be successful.

• Activate Verify After Write if you want the file to be verified after the writing 
operation.
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• Activate Eject Before Verifying and/or Eject After Completion if you want the 
disc to be automatically ejected at the corresponding situations.

11. Click OK to start the writing operation.

Writing a DVD-Audio Project to an ISO Image

If you want to save an entire DVD-Audio project without actually writing a DVD, you 
can save the project as an ISO image.

PREREQUISITE 

Set up and render a DVD-Audio project.

PROCEDURE

1. In the DVD-Audio window, select the Edit tab.

2. In the Burn section, click Check Conformity to check if all settings are 
compatible with the Red Book standard.

3. Click Write DVD-Audio.

4. In the Master Section plug-ins section, select one of the following options:
• Render Each Audio Montage with Its Own Plug-in Set

• Use Current Master Section Settings for All Audio Montages

• Ignore

5. Specify an output folder.

6. Click OK.

7. In the Write Data CD/DVD dialog, open the Device pop-up menu and select 
ISO Image.

8. Specify an ISO file name and location.

9. Click OK to start the writing operation.

10. When the operation is finished, click OK.

Data CD/DVD Projects

A data CD/DVD project can be used to compile and write a data-only CD, DVD, 
Blu-ray, or to write to ISO image. You can enter a name for your disc and change 
the disc file structure before writing your data to a CD, DVD, Blu-ray, or ISO image.
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Creating a Data CD/DVD Project

A data CD/DVD project can be used to compile and write a data-only CD, DVD, 
Blu-ray, or to write to ISO image.

PROCEDURE

1. Select File > Tools > Data CD/DVD.

2. Add files to the project, using one of the following methods:
• Drag the files from the WaveLab Pro File Browser window or from the File 

Explorer/Mac OS Finder into the Data CD/DVD window.

• Drag an audio file or audio montage tab into the Data CD/DVD window.

• Right-click a file tab, and select Add to > Data CD/DVD.

3. Optional: Click New Folder , specify a folder name, and arrange the files 
by dragging.

Writing a Data CD/DVD Project

PREREQUISITE 

Open the Data CD/DVD dialog, and add the files that you want to write to a data 
CD/DVD.

PROCEDURE

1. Click Write Data CD/DVD .

2. Select a writing device.
• If you select ISO Image, specify a file name and file location.

• If you select a CD/DVD writer, specify the writing speed and make further 
settings.

3. Click OK.

Data CD/DVD Dialog

In this dialog, you can create a data CD/DVD project, and write it to a CD, DVD, 
Blu-ray, or an ISO image.

• To open the Data CD/DVD dialog, select File > Tools > Data CD/DVD.
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Media

Allows you to select the media type you want to write. If the media size that 
you want to use is not listed, select the media type that offers the size closest 
to your requirements.

Volume Name

Allows you to specify the volume name of the CD/DVD.

Open File Explorer/Mac OS Finder

Opens the File Explorer/Mac OS Finder to show the location of the selected 
file.

Remove Selected Files and Folders

Removes the selected files and folders from the CD/DVD project.

New Folder

Creates a folder. You can also create sub-folders.

Write Data CD/DVD

Opens the Write Data CD/DVD dialog from which you can write the media.

Data CD/DVD list

Shows the contents of the CD/DVD project, and the size creation date, and 
number of files.

Available space on media

Indicates how much space is used on the media. The Total Size of the data 
CD/DVD project is shown below the data CD/DVD list.

Reset

Removes all files from the data CD/DVD project.

Write Data CD/DVD Dialog

In this dialog, you can write a data CD/DVD project to a CD/DVD or an ISO file.
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• To open the Write Data CD/DVD dialog, open the Data CD/DVD dialog and 
click Write Data CD/DVD.

Device

Allows you to select the disc writer that you want to use or select ISO Image 
to write a file on the hard drive. Writing an ISO image creates a copy of a 
future optical medium.

NOTE

On the Mac, open WaveLab Pro without a media in the drive. Otherwise, the 
drive is under the control of the operating system and is not available for 
WaveLab Pro.

Refresh

Scans the system for connected optical devices. This is done automatically, 
when this dialog opens. Click the update icon after you insert a new blank 
media, to update the speed menu.

Eject Optical Medium

Ejects the optical medium present in the selected drive.

Device Information

Opens the Device Information dialog that shows information about the 
selected device.

Erase Optical Medium/ISO Image

Erases the optical medium present in the selected drive, provided it is a 
rewritable media. If ISO Image is selected, clicking the button deletes the 
existing ISO file.

ISO File Name

If ISO Image is selected in the Device menu, specify the file name and file 
location of the ISO file in the text field.

Speed

Allows you to select the writing speed. The highest speed depends on the 
capabilities of your writing device and of the medium present in the device.
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Test Only, Do Not Write

If this option is activated, clicking OK initiates a simulation of writing the CD. 
If this test is passed, the real write operation will succeed. If the test fails, try 
again at a lower writing speed.

Create CD-Extra Session

If this option is activated, the data is written in a new session, after the audio 
tracks. This creates a CD Extra, also known as Enhanced CD and CD Plus. 
For this to work, the CD in the drive must have audio tracks on it, written with 
the CD Extra option. Otherwise the operation fails.

Verify After Write

If this option is activated, the data on the medium is automatically verified after 
the writing process.

Eject Before Verifying

If this option is activated, the disc is ejected and retracted before the 
verification process, to force the drive out of the write state.

NOTE

This is only possible if the disc can be retracted automatically.

Eject After Completion

If this option is activated, the disc is ejected after the writing operation.

Audio CD Formats

This chapter provides you with background information on the CD format, to help 
you better understand how to create your own CDs.

Basic CD Formats

There are a number of different formats for the contents of a CD disc. For example, 
audio CDs, CD-ROMS, and CD-I. These are all slightly different.

The audio CD specification is called Red Book. It is this standard to which 
WaveLab Pro conforms.

NOTE

Red Book CD is not a real file format. All the audio on the CD is saved in one big 
file. This is different from hard disks, for example, where each file is saved 
separately. Keep in mind that all the audio is in fact one long stream of digital data.
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CD-Extra Support

CD-Extra is a format that allows for the writing of both audio and data on a single 
CD, just like Mixed Mode CDs. When writing an audio CD, you can prepare it for 
CD-Extra support (also known as Enhanced CD or CD Plus).

The difference is that when Mixed Mode CDs are written with the audio placed on 
the last tracks of the CD, for CDs in the CD-Extra format the audio is contained in 
the first tracks of the CD, and the data follows subsequently.

All features of the Red Book audio CD are possible with CD-Extra, unlike with Mixed 
Mode CDs. After an audio CD has been written with CD-Extra support, the data can 
be added to the CD in a separate session, by creating and writing a data CD 
project.

NOTE

Some computer CD drives may not recognize CDs in the CD-Extra format.

Types of Events on an Audio CD

There are three types of events that can be used to specify various sections of audio 
on the CD.

Track start

There can be up to 99 tracks on one CD. Each is identified by its start point 
only.

Track sub-index

On advanced CD players, a track can be divided into sub-indexes (sometimes 
called only indexes). These are used to identify important positions within a 
track. There can be 98 sub-indexes in each track. However, because it is 
difficult and time-consuming to search for and locate to a sub-index, many CD 
players ignore this information.

Pause

A pause is added before each track. Pauses can be of variable lengths. Some 
CD players indicate the pauses between tracks on their displays.

Frames, Positions, Small Frames, and Bits

The data on an audio CD is divided into frames.

A frame consists of 588 stereo samples. 75 frames make up one second of audio. 
This is because 75 x 588 = 44100, and because the sampling frequency of the CD 
format is 44100 Hz (samples per second), this equals one second of audio. When 
you specify positions on the CD, in WaveLab Pro, you do it in the format mm:ss:ff 
(minutes:seconds:frames). The frame values go from 0 to 74, because there are 75 
frames to a second.
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Technically, there is no way to specify something smaller than a frame on a CD. One 
effect of this is that if the sample length of a track on the CD does not equal a 
perfect number of frames, some blank audio must be added at the end. Another 
effect of this is that when you play the CD, you can never locate to anything closer 
than a frame. If you need some data in the middle of a frame, you still have to read 
the whole frame. Again, this is unlike a hard disk, where you can retrieve any byte 
on the disk, without reading the surrounding data.

But frames are not the smallest block of data on a CD. There is also something 
called “small frames”. A small frame is a container of 588 bits. 98 small frames 
together make up one regular frame. In each small frame there is only room for six 
stereo samples, which means that a lot of space is left for data other than the actual 
audio. There is information for encoding, laser synchronization, error correction, and 
the PQ data to identify the track boundaries. This PQ data is of major importance to 
anyone who wants to create their own CD, and handled effortless in WaveLab Pro.

PQ Codes Handling

The PQ codes convey information about track start, sub-indexes, and pauses.

However, when creating a CD there are a number of rules you must take into 
account. For example, there should be some silent frames before each track, 
sub-indexes should be slightly early, there should be pauses at the beginning and 
end of the entire CD, etc.

When creating CDs from an audio montage, these rules and settings are handled 
by the CD Wizard. If you do not change these settings, you will get default values 
that ensure your CD will work properly. However, you can still adjust the PQ codes 
to your liking. We recommend to leave the settings as they are.

WaveLab Pro only exposes intuitive CD markers and automatically generates the 
corresponding PQ codes to be written to CD.

ISRC Codes

International Standard Recording Code (ISRC) is an identification that is only used 
on CDs intended for commercial distribution. WaveLab Pro allows you to specify an 
ISRC code for each audio track. These codes are provided by your publisher or 
clients.

The ISRC code is structured as follows:

• Country Code (2 ASCII characters)

• Owner Code (3 ASCII characters or digits)

• Recording Year (2 digits or ASCII characters)

• Serial Number (5 digits or ASCII characters)

The groups of characters are often presented with hyphens to make them easier to 
read, but hyphens are not part of the code.
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Importing ISRC Codes

You can import ISRC codes that has been written in a standard text file. The ISRC 
text file must have one ISRC code per line.

• To import ISRC codes, select Functions > Import ISRC Codes from Text 
File in the CD window, select the text file that you want to import, and click 
Open.

UPC/EAN Codes

UPC/EAN code – the Universal Product Code/European Article Number, is a 
catalog number for an item (such as a CD) intended for commercial distribution. On 
a CD, the code is also called the Media Catalog Number and there is one such code 
per disc. These codes are provided by your publisher or clients.

UPC is a 12-digit barcode widely used in the USA and Canada. EAN-13 is a 
13-digit barcoding standard (12 + a checksum digit) defined by the GS1 standards 
organization. EAN is now renamed as International Article Number, but the 
abbreviation has been retained.

Pre-Emphasis

CD pre-emphasis refers to process designed to increase, within a band of 
frequencies, the magnitude of some (usually higher) frequencies compared to the 
magnitude of other (usually lower) frequencies in order to improve the overall 
signal-to-noise ratio by lowering the frequencies during reproduction.

Pre-emphasis is commonly used in telecommunications, digital audio recording, 
record cutting and in FM broadcasting transmissions. The presence of 
pre-emphasis on a track is sometimes indicated by a checkmark in the 
Pre-Emphasis  column on the Import Audio CD dialog.

Disc-At-Once – Writing CD-Rs for Duplication Into Real CDs

WaveLab Pro only writes audio CDs in Disc-at-Once mode.

• If you want to create a CD-R to use as a master for a real CD production, you 
must write the CD-R in Disc-At-Once mode. In this mode, the entire disc is 
written in one pass. There are other ways of writing a CD, namely 
Track-At-Once and Multi-Session. If you use these writing formats, the link 
blocks created to link the various recording passes together will be 
recognized as uncorrectable errors when you try to master from the CD-R. 
These links can also result in clicks when playing back the CD.

• Disc-At-Once mode provides more flexibility when specifying pause lengths 
between tracks.

• Disc-At-Once is the only mode that supports sub-indexes.
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Writing On The Fly vs. CD Images

WaveLab Pro writes a CD on the fly, that is, it does not create a CD image before 
writing. This method makes writing CDs/DVDs faster and requires less disc space. 
However, you can also create an image prior to writing a CD/DVD.
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Spectrum Editing

Spectrum editing allows you to edit and process individual frequency ranges 
instead of the full frequency spectrum.

There are two main operational modes:

• Surgery mode is intended for audio restoration purposes applied to short 
time ranges.

• Master Section mode allows you to process an individual frequency range via 
the Master Section.

Both modes operate on a spectrum region, which is set using the Spectrum 
Selection tool. The region selection defines a time and a specific frequency range. 
This allows you to edit and process audio both in the time domain and in a specific 
frequency domain.

Spectrum editing can consist of many different types of processing. Although it is 
developed for audio restoration, it can also be used for artistic or special effects.

You can perform spectrum editing on the left and right channels or on the mid and 
side channels of a stereo file.

Spectrum editing comprises the following steps:

• Defining the region that you want to edit.

• Editing the region in the Spectrum Editor by applying filter operations, by 
copying regions, or by sending it to the Master Section to apply effects.

Spectrum editing can only be performed when the Spectrum Selection tool is 
selected.

Spectrum Display

The spectrum display in the wave window shows the frequency spectrum in relation 
to time.

• To see the spectrum view of the audio file in the Audio Editor, click 
Spectrum below the waveform display.

• To see the spectrum view of the audio file and activate the spectrum editing 
mode, select the Edit tab in the Audio Editor, and select the Spectrum 
Selection tool in the Tool section.
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• To switch between the spectrum view for the left/right channels and the 
mid/side channels, click the LR/MS button at the bottom left of the spectrum 
view.

Each vertical line represents the frequency spectrum at a particular time position.

• Low frequencies are shown at the bottom of the display, and high frequencies 
at the top.

• In the Spectrogram Options dialog, you can define how to represent the 
spectrum. It can be represented in color or in black and white. In color mode, 
frequencies with loud volume intensities are shown in red, and soft 
frequencies in dark purple.

• The vertical ruler on the left shows the frequency range in Hz.

• The status bar shows the time/frequency position of the mouse cursor.

• Right-clicking in the spectrum display opens a context menu with options for 
editing the spectrum.

• If you point the mouse cursor at a defined region, a tooltip displays the 
frequency range and the time range for the current region.

RELATED LINKS

Spectrogram Options on page 131

Surgical Processing

Surgical processing can be used to process short regions of up to 30 seconds 
offline. This type of processing can be used to reduce, remove, or replace unwanted 
sound artifacts in the audio material with great precision.

For example, you can replace a part of a live recording that contains an unwanted 
noise such as a mobile phone ring tone, with a copy of a similar region of the 
spectrum that contains a clean signal.

NOTE

In general, the spectral copy/paste combination gives the best results if the source 
and destination regions are properly chosen.
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If you are working with the Spectrum Editor, you first have to define a 
time/frequency region. Once a region has been set, you can use the surgical 
processing functions. Filtering operations allow you to filter the selected region in 
various ways. Copy operations allow you to copy the spectrum region and apply it 
to another region.

Filtering Individual Frequencies

Filtering individual frequencies is useful for audio restoration purposes.

PREREQUISITE 

Select the Spectrum Selection tool and define the region to process. The selected 
region must not exceed 30 seconds.

PROCEDURE

1. In the Spectrum Editor window, click Surgery.

2. In the Processing of the Selection section, select a processing type.

3. In the Filter Settings section, make the filter settings that you want to use.

4. Set up the Crossfade Time of Processed Audio parameter.

5. Click Apply.

Spectrum Editing by Copying Regions

Spectrum editing by copying regions is useful for removing unwanted sounds in the 
audio material. You first define a source region and a target region. Then you copy 
the audio from the source region to the target region.

PREREQUISITE 

Select the Spectrum Selection tool to switch the wave window to spectrum 
editing. In the Spectrum Editor window, click Surgery.

PROCEDURE

1. In the Audio Editor, use the Spectrum Selection tool to select the region 
that you want to use as source region.

2. In the Spectrum Editor window, click Define Selection as Source.
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3. Click the source region to select it, then press [Shift] to preserve the 
frequency range or [Ctrl]/[Command]-[Shift] to preserve the time range, and 
click and drag the selection to the region that you want to edit.

4. Select the region that you want to use as target region.

5. In the Spectrum Editor window, click Define Selection as Target.

6. In the Copy Audio from One Region to Another section, open the pop-up 
menu and select one of the options.
• Selecting Copy Exactly copies the defined source region exactly.

• Selecting Copy Ambience copies an average of the frequencies of the source 
region, blurring the original dynamics and pitches, and making the copied 
region appear less identifiable.

7. In the Filter Settings section, set a high Steepness value, or activate the 
Infinite option.

8. Click Copy Source to Target.

9. Play back the audio file to hear the result.
The crossfade times and the filter settings have an effect here, because the audio is 
copied and crossfaded both in the time domain and in the frequency domain.

Rules and Tips for Spectrum Editing by Copy Operations

Copy operations in the Spectrum Editor are intended for audio restoration 
purposes. You define a source region and a destination region, then you copy audio 
from the source region to the destination region.

• The source and the target region must have the same length and the same 
frequency range.

• The regions must be part of the same audio file.

• Setting the source region just before or after the sound to remove can 
produce very accurate results, as this region probably contains a similar 
frequency spectrum as the target region containing the artifact.

• When copying between different frequency regions, pitch shifting occurs. 
Using the Move Upwards 1 Octave and Move Downwards 1 Octave 
options may produce better results.

• In the low to low-mid frequency range, the masking or removal of unwanted 
artifacts is difficult to achieve without audible interruptions. Finding a limited 
frequency area is important to not interrupt the flow of the audio when 
removing artifacts.

Master Section Processing

Master Section mode allows you to process an individual frequency range via the 
Master Section.
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The selected or non-selected regions of the spectrum can be processed differently. 
You can also use a number of filters (bandpass/low-pass/high-pass) to further 
refine the range of frequencies to be affected by any Master Section effects.

The signal is split so that one part (selected spectrum or non-selected spectrum) is 
sent to the plug-ins, while the other part can be mixed with this processed signal, 
after the Master Section output.

The arrows show the three possible routing options for the spectrum region 
selection. The non-selected spectrum has the same options, although it cannot use 
the same routing destination as the region selection.

The following operations can be performed:

Process separately via the Master Section plug-ins

The non-selected spectrum can either be bypassed or sent to the Master 
Section.

Bypass

This mutes the audio outside the selected spectral region. The non-selected 
spectrum can either be routed to the Master Section input or the Master 
Section output.

Send to Master Section output

The non-selected spectrum can be bypassed or sent to the Master Section 
input. In the latter case, it is mixed with the selected spectrum region at the 
Master Section output.
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Applying Master Section Processing

PROCEDURE

1. In the Audio Editor, select the Spectrum Selection tool and define a region.

2. In the Spectrum Editor window, activate Master Section.

3. In the Filter Settings section, select a Filter and specify a Steepness.

4. Specify a crossfade time for the processed audio.

5. In the Routing of Selected Spectral Region and Routing of Non-Selected 
Spectral Region section, select how to process the selected and 
non-selected region.

6. Click Render to apply the settings.

Defining a Region for Spectrum Editing

All spectrum editing functions are applied to a selected region, or from a selection 
region if Master Section processing is used. A region that is set in the Spectrum 
Editor contains a time range and a frequency range.

PREREQUISITE 

Zoom in on the time range where you want to perform spectrum editing.

PROCEDURE

1. In the Audio Editor, select the Edit tab.

2. In the Tools section, click Spectrum Selection .

3. Click in the spectrum display and drag a rectangle around the region that you 
want to edit.
When defining a region in a stereo file, a corresponding region is automatically 
created in the other channel.

4. Optional: Click and drag the defined region to move it.
Pressing [Shift] restricts to horizontal movement, to ensure that the frequency range 
is retained. Pressing [Ctrl]/[Command]-[Shift] restricts to vertical movement, to 
ensure that the selected time range is retained.

5. Optional: Move the cursor over a region edge, and click and drag to resize the 
defined region.

AFTER COMPLETING THIS TASK 

Process the selected region in the Spectrum Editor window.
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Processing Frequency Ranges via the Master Section

The Spectrum Editor allows for frequency-selective processing via the Master 
Section.

PREREQUISITE 

Select the Spectrum Selection tool, and define the region to process. The 
selected region must be longer than one second.

You can route the frequency spectrum of the selected region to the Master Section 
where it is processed separately from the non-selected frequency spectrum, or vice 
versa. At the Master Section output, the processed region is mixed with the 
non-processed signal.

PROCEDURE

1. In the Spectrum Editor window, click Master Section.

2. In the Filter Settings section, select a filter type from the Filter pop-up menu.

3. Set the Steepness value and the Crossfade Time of Processed Audio 
value.
The Crossfade Time of Processed Audio value is needed for rendering.

4. In the Routing of Selected Spectral Region and Routing of Non-Selected 
Spectral Region sections, make settings to define where to route the 
selected frequency range and the non-selected frequency range.

5. Open the Master Section and set up the plug-ins that you want to apply to 
the selected/non-selected frequency range.
Do not use any plug-ins that change the number of samples.

6. Click Render to apply the Master Section settings to the selected region.

Spectrum Editor Window

The Spectrum Editor is an audio restoration and processing tool set that provides 
high quality linear-phase filters to process a frequency range selection.

• To open the Spectrum Editor window, select Edit in the Audio Editor, and 
click Spectrum Selection .

The Spectrum Editor window provides two modes:

• Surgery mode is intended for audio restoration purposes applied to short 
time ranges.

• Master Section mode allows you to process an individual frequency range via 
the Master Section.
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Filter and Crossfade Settings

The filter and crossfade settings are available in Surgery mode and in Master 
Section mode. The following options are available:

Bandpass Filter

Attenuates all frequencies outside the region equally.

Low-Pass Filter

Attenuates high frequencies in the region more strongly.

High-Pass Filter

Attenuates low frequencies in the region more strongly.

Steepness

Determines how quickly frequencies are attenuated. Steepness is expressed 
in dB per octave, with higher numbers indicating a steeper filter. The 
Steepness parameter creates a crossfade in the frequency domain between 
the processed and the unprocessed section. If the value is low, the selected 
region contains much of the unprocessed signal near the frequency edges.

Infinite

Sets the filter steepness to an infinite number of dB per octave.

Crossfade Time of Processed Audio

Sets the duration of the crossfade between the processed and the 
unprocessed signal.

Settings

Opens the Spectrum Settings dialog, where you can activate the following 
options:

• If Show Pop-Up Window About Regions is activated, a pop-up 
window in the spectrum view gives you information about the selected 
region.

• If Maintain Independent Settings for Each File is activated, 
Spectrum Editor settings are independent for each audio file.

Pin

If this option is activated, the Spectrum Editor window remains open when 
the Spectrum Selection tool is not selected. Otherwise, the window is 
closed as soon as the Time Selection tool is selected, and none of the 
opened audio files is associated with the Spectrum Editor.

Spectrum Editor Window – Surgery Mode

The Surgery mode of the Spectrum Editor allows you to process short regions of 
up to 30 seconds offline.
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• To activate Surgery mode, open the Spectrum Editor window and click 
Surgery.

Selection Options

Edit

Opens the Audio Range dialog that allows you to define a selection.

Deselect Channel with Cursor

When you edit a stereo file, this option deselects the channel where the 
cursor is located.

Change Channel

When you have defined a region in only one channel in a stereo file, this option 
moves the selection to the other channel.

Zoom

Zooms in on the selected region.

Select a Single Channel

Normally, when you edit a stereo file and make a selection on one channel, the 
selection is automatically applied to the other channel. Activating this option 
allows you to unlink the channels, and edit a single channel.

Select until Top/Select until Bottom

Extends the selection to the top/bottom of the frequency axis.

Select until Start of File/Select until End of File

Extends the selection to the beginning/end of the audio file.

Select Entire File Length

Extends the selection to the entire file.

Move Backwards

Moves the selection to the left so that it ends at its previous start position on 
the time axis.
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Move Forwards

Moves the selection to the right so that it starts at its previous end position on 
the time axis.

Move Upwards

Moves the selection upwards on the frequency axis so that its lower edge is 
placed at its previous upper edge.

Move Downwards

Moves the selection downwards on the frequency axis so that its upper edge 
is placed at its previous lower edge.

Move Upwards 1 Octave/Move Downwards 1 Octave

Moves the selection upwards/downwards by one octave on the frequency 
axis.

Define Selection as Source

Defines the current selection as source region for copy operations.

Define Source at Cursor

Copies the selection rectangle to the current cursor position, and defines it 
as source region for copy operations. This ensures that the selection to copy 
and the selected region that you want to edit have the same size.

Define Selection as Target

Defines the current selection as the target region for copy operations.

Define Target at Cursor

Copies the selection rectangle to the current cursor position, and defines it 
as target region for copy operations. This ensures that the selection to copy 
and the selected region that you want to edit have the same size.

Clear All

Clears all selections.

Copy Operations

Copy Exactly

Copies the defined source region exactly.

Copy Ambience

Copies an average of the frequencies of the source region, blurring the 
original dynamics and pitches, and making the copied region appear less 
identifiable. Depending on the audio material, this may avoid a repetition 
effect.

Copy from Cursor to Replace Selection

Copies a region of the size of the current selection starting at the cursor, and 
replaces the selection by it.
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Copy from Cursor to Replace Target

Copies a region of the size of the defined target region starting at the cursor, 
and replaces the target region by it.

Copy Source to Target

Copies the defined source region to the defined target region.

Copy Source to Cursor

Copies the defined source region to the current cursor position.

Processing Options

Crossfade times and filter settings are taken account for these options.

Gain

Determines the level of the filter processing. Negative gain settings attenuate 
the level, positive gain settings boost the level.

Damp

Attenuates or boosts the level of the selected region according to the set 
gain.

Blur Peaks

Attenuates or boosts the level of the frequencies with the highest level in the 
selection according to the set gain. If the gain is set to a negative value, these 
frequencies are blurred. This is useful for removing acoustic feedback, for 
example.

Dispersion

Blurs the dynamics and pitches of the selected region without changing the 
frequency content.

Fade Out

Gradually filters out the frequencies in the region along the time axis, creating 
a fade out.

Fade In

Gradually lets pass frequencies in the region along the time axis, creating a 
fade in.

Fade Out then Fade In

Lets the frequencies fade out and fade in again.

Fade In then Fade Out

Lets the frequencies fade in and fade out again.

Apply

Applies the selected processing mode.
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Spectrum Editor Window – Master Section Mode

The Master Section mode of the Spectrum Editor allows you to process the 
selected spectral region through the Master Section.

• To activate the Master Section mode, open the Spectrum Editor window 
and click Master Section.

Master Section Mode Options

In Master Section mode, you can decide whether you want to send the selected 
region or the non-selected region to the Master Section for processing. The 
options are the same for both the selected region and the non-selected region.

Bypass

Mutes the selected/non-selected region.

Send to Master Section Input

Sends the selected/non-selected region to the Master Section, allowing you 
to apply plug-ins to it.

Send to Master Section Output (Pre-Master)

Sends the selected/non-selected region to the Master Section output 
without plug-in processing. Only the post-master plug-in is applied.

Render

Processes the selected/non-selected region according to the settings in the 
Spectrum Editor.

Spectrum Settings Dialog

In this dialog, you can make settings for the spectrum editing.

• To open the Spectrum Settings dialog, open the Spectrum Editor window 
and click Settings.
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Show Pop-Up Window About Regions

If this option is activated, a pop-up window displays details when you position 
the mouse cursor over a region or adjust a region.

Maintain Independent Settings for Each File

If this option is activated, the settings are saved when you switch to another 
audio file and restored when you switch back to the original file.
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Auto Split

The auto split function allows you to automatically split audio files or clips in an audio 
montage according to specific rules.

Auto split can create new audio files or audio montage clips referencing the original 
files. The new audio files or clips can be automatically named and/or numbered.

Auto Split in Audio Files

You can use the auto split function, for example, to cut a recorded audio file into 
single takes, to cut a drum loop into its individual drum hit samples, to output 
individual tracks from an album master file, or to silence the regions between audio 
information in an instrumental take.

You can use auto split to split audio files at the following positions:

• Markers

• Regions containing silences

• Beats using beat detection

• Specific intervals

• Specific regions derived from a text file

Auto Split Dialog in the Audio Editor

In this dialog, you can set up auto split rules for audio files.

• To open the Auto Split dialog for an audio file, select File > Tools, and select 
Auto Split.

You can also select the Process tab in the Audio Editor, and click Auto Split.
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The Auto Split dialog contains a series of pages, with different parameters and 
options depending on the selected auto split method.

On the first page, you specify which files to process. You have the following options:

• The audio file in the active window.

• All audio files are in a specified folder.

• The audio files derived from a file list.

On the second page, you select the type of splitting that you want to perform. The 
following types are available:

Split According to Markers

Splits the files at specific marker positions. If you select this option, you can 
specify the marker type that will be used for the splitting on the next page.

Split at Specific Intervals

Splits the files at specific time intervals. If you select this option, you can 
specify the time interval, that is, the duration of each region, on the next page.

Split at Silences

Splits the files so that all non-silent sections become separate regions. If you 
select this option, you can specify the minimum region duration, the minimum 
duration of a silent section, and the signal level that should be considered as 
silence on the next page.

Split at Beats

Detects beats in the audio material and splits the files at each beat. If you 
select this option, you can specify the sensitivity of the beat detection, the 
minimum beat level to create a split point, and the minimum region duration 
on the next page.

Cut Head and Tail

Removes sections from the start and/or end of the files, silent sections, or 
specified sections.
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Learn Regions from a Text File

Splits an audio file according to a description of regions that is saved in a text 
file.

Convert Stereo Files to Two Mono Files

Splits stereo files into two mono files.

The third page of the dialog varies according to the selected split method. The 
following pages of the dialog are common to all types of auto split, except that some 
options are grayed out in the dialogs if they are not applicable.

On the fourth page, you specify what to do with the regions that are created by auto 
split. You can save the regions as separate files or create clips and add these to a 
new or an existing audio montage. You can also create markers at the split points 
instead of splitting the files.

On the fifth page, you can insert silence at the start and/or end of the files, or 
automatically assign root key note numbers to the files.

On the last page, you specify how to name the files, clips, or markers that are 
created by auto split. Options include name as source file name plus a key name or 
number, or name as specified in a text file. To open a saved naming scheme file, 
click Open, select the text file that you want to open, and click Open.

The Finish button is available from all pages. If you are sure about your settings, you 
can click Finish without having to go to all pages. For example, when you are using 
a preset and you know that you do not want to make changes on the last pages, you 
can click Finish earlier.

Learn Regions From Text File

You can split an audio file according to a description of regions that is saved in a 
text file.
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Each region must be described by a name, a start position, and an end position (or 
region length). The text file must be placed in the same folder as the audio file, with 
the same name, and with the extension that you specify in the WaveLab Pro dialog 
(for example, “txt” or “xml”).

You can use four tags to specify the regions.

• Region name

• Start

• End

• Length

These tags can be customized in the Auto Split dialog. The text file must specify 
either the End or the Length parameter.

Each parameter must be located on a separate text line.

The time values must be in samples or in timecode format.

• Hours:minutes:seconds:samples

You can use three text formats.

• “Tag”=“Value”: The tag comes first, then “=”, then the value.

• “Tag” Tabulation “Value”: The tag comes first, then a tabulation, then the 
value.

• XML style: The tag comes first, surrounded by < and >, then the value, then 
the tag surrounded by </ and >.

Text files must be in UTF-8 format.

Example for Using Auto Split for Audio Files

You can split a long recording into samples. This is useful if you are working with a 
sampler, for example, HALion.

PROCEDURE

1. Open an audio file in the Audio Editor.

2. Select the Process tab.

3. In the Split section, click Auto Split.

4. In the Auto Split dialog, select Audio File in Active Window and click Next.

5. Select Split at Silences and click Next.

6. Set up the page according to the audio file and click Next.
Adjust the first setting according to the length of the shortest recorded note, the 
second setting according to the shortest period of silence between two notes, and 
the third setting according to the level of the silence between the notes.

7. Select Save as Separate Files, specify the format and location for the new 
files, and click Next.
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8. On the Options page, activate Assign Key, select Detect Pitch, and click 
Next.
This way, the correct key is assigned to each sample. If you activate Quantize to 
Nearest Semitone, WaveLab Pro sets the key according to the closest semitone. If 
not, the Detune setting in the sample may also be adjusted, according to any pitch 
deviations.

9. Select the naming option As Audio File Name + Key and click Finish.

RESULT 

The file is split according to your settings, and new files are created in the specified 
location.

Auto Split in Audio Montages

You can use the auto split function to split the active clip. You can use the auto split 
function in many situations, for example, to cut a single clip of a recording into 
separate takes, to cut a drum loop into its individual drum hit samples, to output 
individual tracks from an album master file, or to silence the regions between audio 
information in an instrumental take.

During the analysis, only the audio files of the audio montage are taken into account. 
Envelopes and effects are ignored.

You can use auto split to split the active clip at the following positions:

• Markers

• Specific intervals

• Between silences

• Beats

Auto Split Dialog in the Audio Montage Window

In this dialog, you can set up auto split rules for audio montages.

• To open the Auto Split dialog for an audio montage, open the Audio 
Montage window, select the Process tab, and click Auto Split.
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The Auto Split dialog contains a series of pages, with different parameters and 
options depending on the selected auto split method.

On the first page, you select the target for the auto split.

On the second page, you select the type of splitting. The following types are 
available:

Split According to Markers

Splits the files at specific marker positions. If you select this option, you can 
specify the marker type that will be used for the splitting on the next page.

Split at Specific Intervals

Splits the files at specific time intervals. If you select this option, you can 
specify the time interval, that is, the duration of each region, on the next page.

Split at Silences

Splits the files so that all non-silent sections become separate regions. If you 
select this option, you can specify the minimum region duration, the minimum 
duration of a silent section, and the signal level that should be considered as 
silence on the next page.

Split at Beats

Detects beats in the audio material and splits the files at each beat. If you 
select this option, you can specify the sensitivity of the beat detection, the 
minimum beat level to create a split point, and the minimum region duration 
on the next page.

Cut Head and Tail

Removes sections from the start and/or end of the files, silent section or 
specified sections.

The third page of the dialog varies according to the selected split method. The 
following pages of the dialog are common to all types of auto split, except that some 
options are grayed out if they are not applicable.

On the fourth page, you specify what to do with the regions that are created by auto 
split. You can split the regions or remove silent parts. You can also create markers 
at the split points instead of splitting the files.
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On the last page, you specify how to name the clips that are created by auto split. 
Options include name as marker names, name as clip name, or name as specified 
in a text file. To save this text file, select Save, enter a name and location, and select 
Save. To open a saved naming scheme file, click Open, select the text file that you 
want to open, and click Open.

The Finish button is available from all pages. If you are sure about your settings, you 
can click Finish without having to go to all pages. For example, when you are using 
a preset and you know that you do not want to make changes on the last pages, you 
can click Finish earlier.
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Loops

This chapter describes various operations that are related to looping. Looping is 
used to simulate the infinite or at least very long sustain of many instrumental 
sounds. WaveLab Pro has tools for creating smooth loops, even for the most 
complex types of sounds.

Basic Looping

Looping a sound allows you to repeat a section of the sample indefinitely in order 
to create a sustain of unlimited length. Instrumental sounds in samplers rely on 
looping organ sounds, for example.

In WaveLab Pro, loops are defined by loop markers. Loop markers are added, 
moved, and edited just as any other type of marker.

To ensure that you find a good loop point, note the following:

• A long loop usually sounds the most natural. However, if the sound does not 
have a stable section in the middle (an even sustain part), it might be hard to 
find a good long loop.

For example, a piano note which decays continuously is hard to loop because 
the start point of the loop is louder than the end point. A flute is much simpler, 
because the sound in the sustain section is very stable.

• A loop should start shortly after the attack, that is, when the sound has 
stabilized to a sustaining note.

• If you set up a long loop, it should end as late as possible but before the sound 
starts decaying to silence.

• Short loops are difficult to position within the sound. Try to position them near 
the end.

NOTE

More information about looping in general, and the exact capabilities of your 
sampler in particular can be found in the manual of the sampler.
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Creating a Basic Loop

PROCEDURE

1. In the Audio Editor, select the audio section that you want to loop.

2. Right-click above the ruler and select Create Loop from Selection.

3. On the transport bar, activate Loop.

4. Play back the loop and adjust the position of the markers to change the loop.

AFTER COMPLETING THIS TASK 

Creating a loop this way does not necessarily lead to good loops, because clicks 
or abrupt changes in timbre at the turning point can occur.

We suggest that you use this method for setting up the basic length of the loop and 
then use the Loop Tweaker and Loop Tone Uniformizer for optimizing.

Refining Loops

The Loop Tweaker tool allows you to refine a region of audio for seamless looping. 
Use the Loop Tweaker to tweak an existing loop selection so that it loops perfectly 
or use it to create a loop from material which is not perfectly suited to create a loop.

You can automatically detect loop points by scanning the area between two loop 
markers. You can specify parameters that determine how accurate the program 
should be when suggesting loop points.

If the automatic search for loop points is not successful, you can process the 
waveform to allow for smoother loops by crossfading areas of the waveform close 
to the loop start and end points.

To use the Loop Tweaker, you must first define a loop using a pair of loop markers.

Loop Points Adjustment Tab

Use the Loop Points Adjustments tab in the Loop Tweaker dialog to manually 
refine a loop selection by dragging the waveform to the left/right or by using the 
automatic search buttons to find the nearest suitable loop point. The aim is to align 
the waveforms so that they meet at a zero-crossing point where the waveforms 
match as closely as possible. When you adjust your loop start and end points in the 
dialog, the start and end loop markers in the main waveform window adjust 
accordingly. Note that this movement may not be visible depending on how much 
you move the markers and on the zoom factor that you have selected.

It may be helpful to activate Loop on the transport bar during playback so that you 
can hear the difference when you adjust the loop markers. If you are not using a 
crossfade or post-crossfade, you do not have to click Apply when tweaking loop 
points. You can also leave this dialog open and manually adjust the position of the 
markers in the main waveform windows.
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Crossfade Tab

This tab allows you to apply a crossfade between the audio at the end of a loop and 
the audio at the beginning of the loop. This can be useful to smooth the transition 
between the end of a loop and its beginning, especially when you use material that 
is not perfectly suited to create a loop. Use the envelope drag points or value sliders 
to adjust the crossfade envelope. Click Apply to create the crossfade.

Post-Crossfade Tab

This tab allows you to apply a cross fade at the end of the loop by mixing a copy of 
the loop back into the audio. Use the envelope drag points or value sliders to adjust 
the crossfade envelope. Click Apply to create the post crossfade.

Post-crossfading means crossfading the loop back into the audio after the end of 
the loop so that there is not glitch when playback continues after the loop. This is 
done by mixing a copy of the loop back into the audio.

Refining Loops

You can refine loops using the Loop Tweaker tool.

PREREQUISITE 

Set up a basic loop.

PROCEDURE

1. In the Audio Editor, select the loop that you want to refine by clicking 
between its loop start and loop end marker.

2. Select the Process tab.

3. In the Loop section, click Tweaker.

4. In the Loop Tweaker dialog, refine your loop.

5. Click Apply.

Moving Loop Points Manually

If your loop still has glitches or bumps at the transition points, you can use the Loop 
Tweaker tool to move the points in small steps to remove the glitch.

This is similar to moving the loop points in the wave display, but with a visual 
feedback to facilitate finding good loop points.

There are two ways of moving the loop points manually on the Loop Points 
Adjustment tab in the Loop Tweaker dialog:

• Drag the waveform to the left and right.

• Use the green arrows below the waveform to nudge the audio to the left and 
right. Each click moves the loop point by a single sample.
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The following applies when moving the loop points manually:

• To move the end point to a later or earlier position, move the left part of the 
display.

• To move the start point to a later or earlier position, move the right part of the 
display.

• To move the start and end points simultaneously, activate Link Start and End 
Points. This way, when adjusting a loop point, the length of the loop stays the 
same, but the entire loop is moved.

• You can also adjust the loop markers in the wave window.

Automatically Detecting Good Loop Points

The Loop Tweaker tool can automatically search for good loop points.

PROCEDURE

1. In the Audio Editor, select the loop that you want to refine by clicking 
between its loop start and loop end marker.

2. Select the Process tab.

3. In the Loop section, click Tweaker.

4. In the Loop Tweaker dialog, on the Loop Points Adjustment tab, make sure 
that Link Start and End Points is deactivated.

5. In the Automatic Search section, specify the Aimed Correspondence and 
the Search Accuracy.

6. Click the yellow arrow buttons to start the automatic search for a good loop 
point.
WaveLab Pro scans from the current point forwards or backwards, until it finds a 
point that matches. You can stop at any time by clicking the right mouse button. The 
program then jumps back to the best found match.

7. Check the loop by playing it back.

8. Optional: If you think there might be a better loop point, continue with the 
search.
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Temporarily Saving Loop Points

Temporarily saving and restoring loop points allows you to compare different loop 
settings.

PREREQUISITE 

Set up a basic loop and open the Loop Tweaker tool.

NOTE

• There are five slots for temporarily saving loop points for each wave window 
and montage window. If you have several sets of loops in your file, you must 
be careful to not recall the wrong set.

• Only loop positions are temporarily saved.

PROCEDURE

1. On the Loop Points Adjustment tab, in the Temporary Memories section, 
click M.

2. Select one of the five memory slots.

Crossfades in Loops

Crossfading is useful to create smooth transitions between the end of a loop and 
its beginning, especially when using material that is not perfectly suited to create a 
loop.

Sometimes it is impossible to find a loop that does not cause any glitches. This is 
especially true for stereo material, where you might be able to find a perfect 
candidate for only one channel.

In this case crossfading smears the material around the end loop point so that it 
loops perfectly. This is achieved by mixing material from before the loop start with 
material that is located before the loop end.

NOTE

This technique alters the waveform and therefore changes the sound.

Creating a Crossfade

PROCEDURE

1. In the Audio Editor, create as good a loop as you can.

2. Select the Process tab.

3. In the Loop section, click Tweaker.
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4. In the Loop Tweaker dialog, decide if you want to create a crossfade or a 
post-crossfade:
• If you want to create a crossfade, click the Crossfade tab.

• If you want to create a post-crossfade, click the Post-Crossfade tab.

5. Make sure that Crossfade Audio at End of Loop with Audio before Loop 
(Crossfade tab) or Crossfade Audio after Loop with Audio of Loop Start 
(Post-Crossfade tab) is activated.

6. Specify the length for the crossfade either by dragging the length handle or 
by adjusting the Length value below the graph.

7. Specify the crossfade shape by dragging the shape handle or by adjusting the 
Shape (from Equal Gain to Equal Power) value.

8. Click Apply.
The sound is processed. Each time that you click Apply, the previous loop process is 
automatically undone. This allows you to try out different settings quickly.

NOTE

Do not move the loop points after you have performed a crossfade. The waveform has 
been processed specifically for the current loop settings.

AFTER COMPLETING THIS TASK 

• You can check the crossfade visually by opening the Loop Points 
Adjustment tab and activating Display Processed Audio. If this is activated, 
the display shows a preview of the crossfaded waveform. If this option is 
deactivated, the display shows the original waveform. Switching back and 
forth allows you to compare the two.

Post-Crossfades

Post-crossfading means crossfading the loop back into the audio after the end of 
the loop so that there is not glitch when playback continues after the loop. This is 
done by mixing a copy of the loop back into the audio.

The post-crossfade can be set up on the Post-Crossfade tab of the Loop Tweaker 
dialog.

The post-crossfade analyzes the part of the waveform that occurs just after the loop 
start and processes a specific area that begins at the end of the loop. The length 
parameter adjusts the size of this area. Everything else is identical with regular 
crossfading.

Loop Tweaker

This dialog allows you to adjust the loop start and end points, and crossfade the 
loop boundaries. The loop start and end points are specified with the loop start and 
end markers.
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If more than one loop marker pair is available in the audio file, click in the area 
between a loop marker pair to tweak the corresponding start and end points.

• To open the Loop Tweaker dialog, open the Audio Editor, select the 
Process tab, and in the Loop section, select Tweaker.

Loop Points Adjustment Tab

The top of this dialog shows the beginning and the end of the waveform between 
the loop markers. The bottom of this dialog offers the following options:

Loop End – Inner Arrows

Move the loop end points to the left/right.

Loop End – Outer Arrows

Invokes an automatic search for the nearest good loop point to the left/right 
of the loop end point and moves the end point to that position.

Loop Start – Inner Arrows

Moves the loop start points to the left/right.

Loop Start – Outer Arrows

Invokes an automatic search for the nearest good loop point to the left/right 
of the loop start point, and moves the start point to that position.

Stereo Merge

If this option is activated for a stereo file, the two waveforms are overlaid, 
otherwise they are shown in two separate sections.



Loops
Refining Loops

560

Overlap

If this option is activated, the waveforms of both halves are continued in the 
other half. This shows how the waveform looks like right before and after the 
loop.

Display Processed Audio

If this option is activated, the display shows a preview of the waveform after 
crossfading. If this option is deactivated, you see what the waveform looks like 
without crossfading. This option only makes sense after you have applied a 
crossfade.

Automatic Vertical Zooming

If this option is activated, the vertical magnification is adjusted so that the 
waveform always fills the entire display vertically.

Zoom

Sets the zoom factor.

Current Correspondence

Indicates how well the waveforms near the loop points match one another. 
The left value estimates the similarity across several wave cycles, while the 
right value estimates the similarity of the few samples near the loop points. 
The higher the values, the better the match.

Aimed Correspondence (0-1000)

Sets up the automatic search for good loop points. This defines how well the 
found section must resemble the section to which it is compared, in order to 
be considered a match. The higher the value, the more precise the 
resemblance must be. A value of 1000 requires a 100 % perfect match.

Search Accuracy

Determines how many samples should be taken into account by the auto-find 
analysis. Higher values result in greater accuracy, but also in longer 
processing times.

Link Start and End Points

If this option is activated, both the start and end points move simultaneously 
when you adjust the loop points manually. That is, the loop length stays exactly 
the same and the entire loop moves.

Temporary Memories

Allows you to save up to five different sets of loop points which you can later 
recall. This allows you to try out different loop settings. To save a set, click this 
button, then on one of the buttons 1-5.
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Crossfade Tab

Crossfade Audio at End of Loop with Audio before Loop

To enable crossfading, activate this checkbox. The crossfade is applied when 
you click Apply.

Length

Determines the length of the crossfade. Generally, you want the crossfade to 
be as short as possible, with an acceptable result.

NOTE

• Using a long crossfade smoothens the loop. However, more of the 
waveform is processed, which changes its character.

• A shorter crossfade affects the sound less, but the loop is not as smooth.

Shape (from Equal Gain to Equal Power)

Determines the shape of the crossfade. Use low values for simple sounds and 
high values for complex sounds.
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Post-Crossfade Tab

Crossfade Audio after Loop with Audio of Loop Start

To enable crossfading, activate this checkbox. The crossfade is applied when 
you click Apply.

Length

Determines the length of the crossfade. Generally, you want the 
post-crossfade to be as short as possible, with an acceptable result.

NOTE

• Using a long post-crossfade smoothens the loop. However, more of the 
waveform is processed, which changes its character.

• A shorter post-crossfade affects the sound less, but the loop is not as 
smooth.

Shape (from Equal Gain to Equal Power)

Determines the shape of the post-crossfade. Use low values for simple 
sounds and high values for complex sounds.

Looping Audio Which Is Not Very Well Suited for 
Looping

Sounds that constantly decay in level or continuously change in timbre are difficult 
to loop. The Loop Tone Uniformizer allows you to create loops from these kind of 
sounds.
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The Loop Tone Uniformizer applies processing to the sound that evens out 
changes in level and timbral characteristics in order for a sound to loop properly. 
For example, this is useful for creating looped samples for a softsynth or hardware 
sampler.

The Loop Tone Uniformizer includes a crossfade option allowing you to fade in 
the original sound into the processed sections when playback approaches the loop 
start.

To use the Loop Tone Uniformizer, you must have created a loop by setting a pair 
of loop markers. The original length of the loop is not changed.

Looping Seemingly Unloopable Audio

PROCEDURE

1. In the Audio Editor, set up a basic loop.

2. Select the Process tab.

3. In the Loop section, click Tone Uniformizer.

4. In the Loop Tone Uniformizer dialog, make sure that either Slice Mixing 
and/or Chorus Smoothing is activated and make the settings.

5. Optional: Select the Pre-Crossfade tab, and set up a crossfade.

6. Click Apply.
The sound is processed. Each time that you click Apply, a new loop is defined. This 
allows you to try out different settings quickly.

NOTE

Do not move the loop points after you have performed a crossfade. The waveform has 
been processed specifically for the current loop settings.

AFTER COMPLETING THIS TASK 

After using the Loop Tone Uniformizer, the transition between the end of the loop 
and the end of the file might not sound very natural. This can be fixed by creating a 
post-crossfade using the Loop Tweaker.

Loop Tone Uniformizer

This dialog allows you to create sounds that loop from audio which is not very well 
suited for looping. These are normally sounds that constantly decay in level or 
continuously change in timbre.

• To open the Loop Tone Uniformizer dialog, open the Audio Editor, select 
the Process tab, and in the Loop section, select Tone Uniformizer.
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Uniformizers Tab

This tab allows you to specify the methods that are used to even out the sound that 
you want to loop.

Slice Mixing

Cuts the loop in slices, which are then mixed together to uniformize the sound.

For slice mixing, you need to determine the number of slices. Only 
experimentation can tell how many slices are needed, but generally, the more 
slices you have, the more natural the sound. However, the program puts a 
restriction on the number of slices, so that each one is never shorter than 
20 ms.

For example, if you specify eight slices, the loop is cut up into eight sections 
of equal length. These sections are then overlapped and mixed together as 
one sound which is repeated eight times. This new piece of audio replaces all 
audio inside the loop so that no harmonic cancellation due to phase offsets 
occurs.

Slice Mixing – Number of Slices

The more slices you use, the more the sound changes.

Chorus Smoothing

This processor uses a phase vocoding method to filter the harmonics. This 
method is recommended for looping ensemble and choir sounds and can 
drastically change the timbre.

Chorus Smoothing – Timbre

Governs the amount by which the timbral characteristics of the sample should 
be evened out. The higher the value, the more pronounced the effect.

Chorus Smoothing – Chorusing

Determines the depth of the chorus effect.

Chorus Smoothing – Enhance Warmth

Creates a smoother, warmer sounding effect.

Chorus Smoothing – Stereo Expansion

Increases the width of the sample in the stereo sound image.



Loops
Sample Attributes

565

Pre-Crossfade Tab

This tab allows you to crossfade the end of the loop with the start of the newly 
processed section so that the transition into the looped section is smoother during 
playback. Use the envelope drag points or value sliders to adjust the crossfade.

You need to use this feature because the Loop Tone Uniformizer changes the 
timbre only inside the loop. This means that the transition into the loop is not as 
smooth as expected unless you apply crossfading.

Crossfade Audio before Loop with Audio of End of Loop

Enables crossfading, which is applied when you click Apply.

Length

Determines the length of the crossfade. Generally, you want the 
post-crossfade to be as short as possible, with an acceptable result:

NOTE

• A long crossfade produces a smoother loop. However, more of the 
waveform is processed, which changes its character.

• A shorter crossfade affects the sound less, but the loop is not as smooth.

Shape (from Equal Gain to Equal Power)

Determines the shape of the crossfade. Use low values for simple sounds and 
high values for complex sounds.

Sample Attributes

Sample attributes allow you to define settings for an audio sample before loading it 
into a hardware or software sampler.
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Sample attributes do not process the sample, they just provide the file properties 
that the receiving sampler can use. This includes information about the pitch of the 
sample, which can be detected automatically, the key range that the sample should 
span, and the velocity range to occupy. For WAV and AIFF files, this information is 
saved in the header of the file. By default, there are no sample attributes in an audio 
file.

NOTE

Depending on your sampler and the protocol that you use for communicating, the 
sample attributes may not be supported.

Editing Sample Attributes

PROCEDURE

1. Open the Audio Editor.

2. Select Tool Windows > Sample Attributes.

3. In the Sample Attributes window, click Create.

4. Optional: If you want to automatically detect the pitch of an audio selection, 
select an audio range, and select Detect from Audio Selection.

5. Specify the sample attributes.

6. Save the audio file to save the sample attributes settings in the audio file.
The sample attribute is only saved in WAV and AIFF files.

Sample Attributes Window

In this window, you can create sample attributes for an audio sample.

• To open the Sample Attributes window, open the Audio Editor and select 
Tool Windows > Sample Attributes.

Create/Remove

Creates/Removes sample attributes for the active audio file.

Tune – Key

Specifies which key plays back the sound at its basic pitch.



Loops
Sample Attributes

567

Tune – Detune

Specifies whether the sample should be played back at a slightly different 
pitch. The range is ±50 % of a semitone, which translates into a quarter tone 
in each direction.

Detect from Audio Selection

Detects the pitch from an audio selection. Make sure that the audio selection 
contains a clearly defined pitch.

Key Range – High/Low

Specifies the key range for the sample if the sample is part of a multi-sample 
key map.

Velocity Range – High/Low

Specifies the velocity range for the sample if the sample is part of a 
multi-sample key map with velocity-switchable samples.
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Generating Signals

In WaveLab Pro, you can generate synthesized sounds and DTMF or MF tones.

Signal Generator

The Signal Generator allows you to generate complex synthesized sounds in mono 
or stereo.

You can layer different waveform generators together and if outputting a stereo file, 
adjust different settings for both the left and right channels.

Use the Signal Generator for the following:

• Testing the specifications of audio equipment

• Measurements of various kinds, including calibrating tape recorders

• Testing signal processing methods

• Educational purposes

The Signal Generator is based on a waveform generator that can generate a large 
number of basic waveforms, such as sine, saw, pulse, and various types of noise.

The Signal Generator has a multitude of settings for character (Source tab), 
frequency (Frequency tab), and amplitude (Level tab).

You can combine up to 64 Signal Generators into layers and make separate 
settings for the left and right channel.

NOTE

The Signal Generator is not intended for synthesizing musical sounds.

Signal Generator Dialog

This dialog allows you to generate complex synthesized sounds in mono or stereo.

• To open the Signal Generator dialog, select File > Tools > Signal 
Generator.
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Audio Properties

Opens the Audio Properties dialog in which you can select sample rate, bit 
resolution, etc.

Global Gain

Adjusts the global level of all combined layers.

Number of Layers

Determines the number of layers, for example, the number of independent 
signals to be combined.

All Channels/Left Channel/Right Channel

Determines whether the settings on the tab are applied to the left or right 
channel of the selected layer, or to both channels. This option is only available 
for stereo files.

Copy

Copies all settings of the current layer.

Paste

Pastes the settings to the selected layer.

NOTE

Clicking Paste replaces the source, frequency, and level settings on all tabs, 
not just on the selected one.

Generate

Applies the settings.
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Source Tab

Waveform

Use this pop-up menu to select a waveform for the selected layer.

Width

If you select one of the pulse waveforms, you can set this parameter to the 
width of the pulse, specified as a percentage or a number of samples.

Angle (0-359°)

Sets the phase of the signal for the selected layer.

Adjust Signal Length to End on a Cycle Boundary

If this option is activated, the generated waveform ends with a complete cycle, 
regardless of the phase setting.

Frequency Tab

Envelope Section

In this section, you can set up the frequency envelope of the selected layer. 
The envelope consists of four frequency values and three duration values in 
between the frequency values.

If you want to set a static frequency (no envelope curve), make sure that all 
time values are set to 0, and set the frequency with the Median Freq. 2 
parameter.

Vibrato Section

In this section, you can add a vibrato to the frequency of the selected layer. 
You can select a waveform for the vibrato, set the frequency, and adjust the 
intensity.
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Change Frequency at Cycle Boundaries

If this option is activated, the vibrato is not continuously applied from 
sample-to-sample, but recomputed after each cycle.

Linear Frequency Variations

If this option is activated, the frequency varies linearly.

Level Tab

Envelope

In this section, you can set up the amplitude envelope of the selected layer. 
The envelope consists of three level values and three duration values in 
between the level values. In addition, the Silence Before and Silence After 
parameters allow you to include a period of silence before or after the signal 
of the selected layer.

NOTE

The Overall Gain parameter determines the overall level of the layer.

Tremolo

In this section, you can add a tremolo (continuous level variation) to the 
selected layer. You can select a waveform for the tremolo, set the frequency, 
and adjust the intensity.

Change Level at Cycle Boundaries

If this option is activated, the tremolo is not continuously applied from 
sample-to-sample, but recomputed after each cycle.

DC Offset

Allows you to add a DC offset to the signal of the selected layer.

Overall Gain

Allows you to set an overall level for the selected layer.
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Generating an Audio Signal

PROCEDURE

1. Select File > Tools > Signal Generator.

2. In the Signal Generator dialog, click the audio properties.

3. In the Audio Properties dialog, set up the channels, sample rate, and bit 
resolution.

4. Choose how many layers of signal generators you want to use by setting the 
Number of Layers parameter.

5. Set the Global Gain.

6. For each layer, edit the settings on the Source, Frequency, and Level tabs.

7. If you have selected stereo channels, you can make changes for both or just 
one of the channels by selecting All Channels, Left Channel, or Right 
Channel.

8. Once all settings are made, click Generate.
The file is generated and opens in a new window.

DTMF Generator

With the DTMF Generator you can generate DTMF (Dual Tone Multi Frequency) or 
MF tones as used by analog telephone systems.

These tones are created by combining two sine waves with variable frequencies. 
Push button telephones generate these two sine waves at different frequencies 
depending on the number that you press. These dial pulses are then decoded by 
the telephone exchange to identify which letters or numbers you pressed.

DTMF Generator Dialog

This dialog allows you to generate DTMF or MF tones.

• To open the DTMF Generator dialog, select File > Tools > DTMF 
Generator.
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Dial String

Lets you enter the numbers that you want to convert into DTMF tones. The 
characters that you can use for DTMF are 0123456789ABCD*#,) and for MF 
0123456789ABC*#,.

DTMF

DTMF is the most commonly used standard. DTMF strings are limited to 16 
characters.

MF

MF uses a different frequency than DTMF. MF strings are limited to 15 
characters.

Leading Silence

Determines the length of the silent region before the first tone.

Tone

Sets the length of each tone.

Inter-Tone

Adjusts the time interval between the tones.

Pause

Determines the length of any pauses in the dial string. A pause is entered by 
typing a comma character in the dial string.

Trailing Silence

Determines the length of the silent region after the last tone.
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Overall

Controls the level of the tone’s mix.

High Frequencies Gain

The DTMF signal consists of a mix between two tones. One high frequency 
tone and one low frequency tone. You can either choose to let the two tones 
have the same amplitude by leaving this at zero, or you can raise the high 
frequency tone by up to 12 dB. On some telephone lines, the high frequency 
tones are set 2 dB higher than the low ones.

Fade In/Fade Out Tones

If this option is activated, the generated tones will fade in and out.

Time

Lets you set the time of the fades if the corresponding option is activated.

Audio Properties

Opens the Audio Properties dialog in which you can select sample rate, bit 
resolution, etc.

Generating DTMF Files

PROCEDURE

1. Select File > Tools > DTMF Generator.

2. In the DTMF Generator dialog, enter a dial string in the text field at the top of 
the dialog.
The characters that you can use are shown above the text field.

3. Select the standard to use.

4. Make the settings for Durations and Amplitude.

5. Click the audio properties to select a bit resolution and a sample rate.

The Audio Properties dialog opens where you can edit settings for the audio file.

6. Click Generate.
The file is generated and opens up in a new window.
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Importing Audio CD Tracks

You can read audio tracks from regular CDs and save them as a digital copy in any 
audio format on your hard disk.

Although WaveLab Pro supports a large number of CD drives, there are some 
restrictions you need to be aware of:

• There are a number of different protocols for retrieving audio from a 
CD-ROM/CD-R drive. WaveLab Pro supports as many of these methods as 
possible, but there are no guarantees that it works with any particular drive. 
This applies for CD-Text and ISRC.

• Observe and respect any copyright notices on the CDs from which you are 
importing tracks.

When importing tracks, they are named “Track XX” by default, where XX is a 
number starting at 01. The numbering scheme can be changed.

NOTE

• Importing audio CD tracks is technically more complicated than reading files 
from a CD-ROM or hard disk, because audio sectors can be hard to detect. 
Some CDs which do not conform completely to the CD standard may cause 
problems, especially when they are copy protected.

• If you import a CD track with Emphasis, and later want to use this on a CD of 
your own, remember to activate Emphasis for that track in the audio montage 
or Basic Audio CD window.

Import Audio CD Dialog

In this dialog, you can import one or more tracks from an audio CD.

• To open the Import Audio CD dialog, select File > Import, and click Audio 
CD.
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Functions Menu

CD Info

Displays the CD length and the UPC/EAN code, if available.

Extract ISRC Codes

Reads the ISRC codes and displays them in the track list. Depending on your 
CD drive, this can take a while.

Examine CD-Text

Opens the CD-Text dialog where you can view the CD-Text. Not all CD drives 
support CD-Text.

Extract CD-Text

Extracts the CD-Text and displays a summary in the track list.

Rename Tracks Menu

Name

Renames the tracks according to the selected renaming scheme.

Search Track Names on the Internet (FreeDb)

Searches track names from an Internet database. If the album is found, the CD 
track list is updated.

Submit Track Names to the Internet (FreeDb)

Submits the information about the audio CD to the FreeDb database of CD 
information.
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Convert Menu

Convert All Tracks to Audio Montage

Extracts all audio CD tracks and uses them to create an audio montage.

Convert Selected Tracks to Audio Montage

Extracts the selected audio CD tracks and uses them to create an audio 
montage.

Convert All Tracks to Basic Audio CD

Extracts all audio CD tracks and uses them to create a Basic Audio CD.

Convert Selected Tracks to Basic Audio CD

Extracts the selected audio CD tracks and uses them to create a Basic Audio 
CD.

Actions Tab

Source

Select the CD drive from which you want to import audio CD tracks.

Speed

Allows you to set the writing speed. The highest speed depends on your 
writing device and on of the media present in the device.

Refresh

If you insert a CD while the Import Audio CD dialog is open, you need to click 
this button to show the contents of that CD in the list.

Eject Optical Medium

Ejects the medium from the selected drive.

Track List

Shows the tracks on the CD.

Range – Start/Length

If you want to import only a section of a track, use the Start and Length fields 
to define a start point and length.

Output – Location

Allows you to set the output location.

Output – File Format

Allows you to set the output file format.

Select All

Selects all CD tracks in the track list.

Play

Plays back the selected CD track.
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Options Tab

Trim Silence

If this option is activated, silence between imported tracks is removed. Only 
digital silence is removed, that is, samples with a zero level.

Automatically Refresh on CD Change

If this option is activated, WaveLab Pro checks for the presence of a new CD 
in the drive several times a second. If a new CD is found, the track list display 
is refreshed.

Automatically Extract ISRC Codes

If this option is activated, ISRC codes are automatically extracted when a CD 
is inserted.

Automatically Extract CD-Text

If this option is activated, CD-Text is automatically extracted when a CD is 
inserted.

Automatically Search Track Names on the Internet

If this option is activated, track names are automatically searched on the 
Internet when a CD is inserted.

Grab Pause before First Track (If Available)

If this option is activated, when a section of audio is located before the first 
track, it is extracted together with the first track. This way, you can import 
hidden bonus tracks.

Use a Japanese CD-Text Decoder

If this option is activated, CD-Text is interpreted as Japanese the next time it 
is extracted.

Create Peak File

If this option is activated, a peak file is created together with the rendered files.

Show Times with CD Frame Units

If this option is activated, times are shown in CD frame units. There are 75 CD 
frames per second.

Play through Master Section

If this button is activated, the Master Section is ignored. If the button is 
deactivated, the audio is played through the Master Section.

Convert Titles and CD-Text to Meta-Data

If this option is activated when importing tracks into an audio format 
supporting meta-data (for example, MP3 and WMA), the titles of the tracks 
and the CD-Text are automatically added to the file header.
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Ultra-Safe Mode (Slow)

If this option is activated, each CD track is read several times until the same 
result is found (checksums are used). Specify the number of times that a track 
must be read with the same result before it is saved to disk.

Real Audio Before and After Tracks

You can ensure that tracks are imported in their entirety by defining how much 
audio should be read before and after each CD track.

Importing Audio CD Tracks

PROCEDURE

1. Insert a CD into the CD-ROM/CD-R device.

2. Select File > Import.

3. Click Import Audio CD.

4. In the Import Audio CD dialog, in the Source section, select the drive from 
which you want to read, and specify the read speed.

5. Optional: Rename the files and adjust the numbering scheme.
The tracks must have unique names if you want to import them all.

6. Optional: On the Options tab, in the Read Audio Before and After Tracks 
section, define how much audio should be read before and after each CD 
track.

7. In the track list, select the tracks that you want to import.

8. Optional: If you have only selected one file, in the Range section, you can 
define a Start and Length, to import just a part of the track.

9. In the Output section, click the folder icon, and select an output location.
You can also drag one or more CD tracks onto an audio montage track.

10. In the Output section, click the file format field, and select a file format for the 
imported audio files.

11. Click Save.

RESULT 

The tracks are imported to the specified location.
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Searching Track Names on the Internet

You can search for information about your CDs using the FreeDb database of CD 
information.

PREREQUISITE 

You must be connected to the Internet to use the FreeDb function.

PROCEDURE

1. Insert a CD into the CD-ROM/CD-R device.

2. Select File > Import.

3. Click Import Audio CD.

4. In the Import Audio CD dialog, select Rename Tracks > Search Track 
Names on the Internet (FreeDb).

Submitting Track Names to the Internet

You can submit information about an audio CD to the FreeDb database of CD 
information.

PREREQUISITE 

You must be connected to the Internet to use the FreeDb function.

PROCEDURE

1. Insert a CD into the CD-ROM/CD-R device.

2. Select File > Import.

3. Click Import Audio CD.

4. In the Import Audio CD dialog, rename each track.

5. Select Rename Tracks > Submit Track Names to the Internet (FreeDb).

6. In the Submit CD Information dialog, fill out the text fields and enter an 
E-Mail address.

NOTE

An E-Mail address is required to report submission errors. It will not be saved.

The FreeDb database does not offer the possibility to enter different artists or genres 
for individual tracks. If the artists differ from track to track, you can write the track title 
in the following way:

Title/Artist

7. Click OK.
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Ultra-Safe Mode

Sometimes, a small bit of a CD track is not properly retrieved which results in 
unpleasant clicks and pops in the audio. This depends on the quality of your CD 
drive. To solve this issue, you can activate the Ultra-Safe Mode in the Import 
Audio CD dialog options.

If this option is activated, you can specify how many times each CD track must be 
read with the same result, before it is saved to disk.

Converting Audio CD Tracks to an Audio Montage

PROCEDURE

1. Insert a CD into the CD-ROM/CD-R device.

2. Select File > Import.

3. Click Import Audio CD.

4. Optional: In the Import Audio CD dialog, on the Options tab, select which 
information you want to extract from the Audio CD when converting.

5. Decide whether to convert only selected tracks or all tracks.
• To convert only selected tracks, select Convert > Convert Selected Tracks 

to Audio Montage.

• To convert all tracks, select Convert > Convert All Tracks to Audio Montage.

RESULT 

When the conversion is finished, the imported files open in the Audio Montage 
window.

Converting Audio CD Tracks to a Basic Audio CD

PROCEDURE

1. Insert a CD into the CD-ROM/CD-R device.

2. Select File > Import.

3. Click Import Audio CD.

4. Optional: In the Import Audio CD dialog, on the Options tab, make your 
settings.

5. Decide whether to convert only selected tracks or all tracks.
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• To convert only selected tracks, select Convert > Convert Selected Tracks 
to Basic Audio CD.

• To convert all tracks, select Convert > Convert All Tracks to Basic Audio 
CD.

RESULT 

When the conversion is finished, the imported files are added to the Basic Audio 
CD window.
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WaveLab Exchange

You can use WaveLab Pro as an external editor for Cubase and vice versa.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

• WaveLab Exchange is only available for Cubase Pro 8.5.10 or higher and 
Cubase Artist 8.5.10 or higher.

• WaveLab Exchange supports the file formats Wave and Wave 64.

WaveLab Pro as External Editor for Cubase

You can open Cubase events in WaveLab Pro. This allows you to use the editing 
capabilities of WaveLab Pro and apply them to Cubase events.

For example, the following editing options are exclusively available in WaveLab Pro:

• Audio error correction

• Audio spectrum editing

• Independent channel editing and processing

• Mid/Side editing and processing

• Loudness normalization (EBU R-128 recommendation)

• Analysis meters, global analysis (EBU R-128 recommendation), and 3D 
frequency analysis

• Sonnox restoration toolkit (DeBuzzer, DeClicker, DeNoiser)

• MasterRig
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Editing Cubase Audio Events in WaveLab Pro

PREREQUISITE 

Open your Cubase project in Cubase.

PROCEDURE

1. In the Cubase Project window, select the audio event that you want to edit in 
WaveLab Pro.
You can also select only a part of the audio event with the Object Selection tool.

2. Select Audio > Edit in WaveLab.

3. In WaveLab Pro, edit the audio event.

4. When you have finished the editing, click Trigger Cubase Update on the 
command bar.

RESULT 

The changes to the audio event are applied to the Cubase project.

Cubase as External Editor for WaveLab Pro

When you are working on an audio file or clip in WaveLab Pro, you can open the 
project of the audio file in Cubase. This allows you to correct issues that you have 
identified during mixing and correct these issues in the audio file in Cubase.

When you then export the audio file in Cubase, and you use the same file name, the 
audio file or clip is automatically updated in WaveLab Pro.

Preparing the Cubase Project for WaveLab Exchange

PROCEDURE

1. In Cubase, open the project that you want to prepare for WaveLab Exchange.

2. Select File > Export > Audio Mixdown.

3. In the Export Audio Mixdown dialog, specify a file name and path.

4. In the File Format pop-up menu, select Wave File or Wave 64 File.

5. Activate Insert iXML Chunk.

6. Click Export.
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Editing the Audio File in Cubase

PREREQUISITE 

The Cubase project is prepared for WaveLab Exchange.

PROCEDURE

1. In WaveLab Pro, open the audio file in the Audio Editor.
A yellow line above the file tab indicates that the file has been rendered in Cubase.

2. Select the Edit tab.

3. In the Source section, click Edit Project.
The Cubase project that contains the audio file opens.

4. In Cubase, edit the audio file.

5. Select File > Export > Audio Mixdown.

6. In the Export Audio Mixdown dialog, activate Insert iXML Chunk.

IMPORTANT

Do not change the file name and path.

7. Click Export.

RELATED LINKS

Preparing the Cubase Project for WaveLab Exchange on page 584
Tab Colors on page 93
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Batch Processing

Batch processing in WaveLab Pro allows you to process any number of audio files 
or audio montage files with Master Section plug-ins and presets, offline effects, 
and other plug-ins that are unique to batch processing.

Each file is processed and then saved to a folder of your choice. You can change 
the file format, rename the file according to a set of rules, and run an external 
application when the batch is finished. You can process as many files as you want 
taking advantage of multi-processing on multi-core processors.

When you save batch processor files you can run batches repeatedly, if required. 
For example, you may have a folder of 24-bit audio files which you want to normalize, 
add a fade out to, and dither down to 16 bit 44.1 kHz. You could save this as a batch 
processor file, and re-run the batch each time that you update the original files. This 
procedure can be simplified using batch templates.

Advantages of the WaveLab Pro Batch Processor

While processing multipass plug-ins, other plug-ins of the plug-in chain are only 
gone through when necessary and file writing is reduced to a single writing process. 
This results in an improved performance of the batch processing. The following 
graphic shows the advanced uses of the multipass plug-ins of the batch processor.
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Batch Processing Meta-Data

You can batch process meta-data. For this you can set up the Meta-Data dialog in 
the Batch Processor window, and apply this meta-data to the files of the batch 
process.

RELATED LINKS

Meta-Data in the Batch Processor Window on page 181

Batch Processor Window

This window allows you to process any number of audio files or audio montages 
with Master Section plug-ins and presets, offline effects, and other plug-ins.
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Edit Tab

Execution

Start

Runs the batch process.

Pause

Interrupts the process to reduce the CPU load. You can continue the process 
by clicking Pause again.

Cancel

Cancels the running process.

Run All

Runs sequentially all open batches. That is, a batch process starts when the 
previous one ends. An error does not prevent a new batch process from 
starting. If you stop the active process, the global process stops.
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Preview

Preview Processing

Allows you to preview the effect of the batch processor on any file of a batch. 
The preview includes all effects and the file format.

Reset Status

All Files

Sets the files with the status “Done” or “Error” to “To do”.

All Selected Files

Sets all selected files with the status “Done” or “Error” to “To do”.

Files with an Error

Sets the files with the status “Error” to “To do”.

Insert

Audio Files

Allows you to select the audio file that you want to add to the batch process.

Audio Montages

Allows you to select the audio montage that you want to add to the batch 
process.

Files from Folder

Opens the Add Files from Folder dialog, where you can add files of a 
specific type from a folder to the batch process.

Add Master Section Preset

Adds the Master Section plug-ins to the batch process.

Remove

All Files

Removes all files from the list that are not being processed.

Selected Files

Removes the selected files from the list that are not being processed.

All but Selected

Removes all files from the list that are not selected and not being processed.

Successfully Processed Files

Removes all files with the status “Success” from the list.
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Files with Errors

Removes all files with the status “Error” from the list.

XML

XML Audio Description

Opens the XML Audio Description dialog, in which you can instruct 
WaveLab Pro how to understand the structure of the XML file that you want 
to read.

Audio Plug-in Chain

Here, you can add plug-ins that the audio signal traverses, from top to bottom.

You set up the list by dragging plug-ins from the plug-ins section.

• To remove a plug-in from the list, select it and press [Delete], or right-click a 
plug-in and select Remove.

• To edit a plug-in, double click it, or right-click a plug-in and select Edit.

Red, green, and blue arrows on the right of the audio plug-in chain visualize the 
audio signal path when plug-ins have been added to the list.

You can prevent a plug-in from processing by deactivating it.

Files to Process

Here, you specify which files to process. You can add files to the list via drag and 
drop or use the insert options on the Edit tab.

Options on Context Menu

You can right-click a file, to access a context menu with the following options:

Reset Status

Sets the status of the selected files to “unprocessed”.

Remove

Removes the selected files from the list.

Open in WaveLab Pro

Opens the selected file in WaveLab Pro.

Reveal in File Explorer/Finder

Opens the folder of the selected file in the File Explorer/Mac OS Finder.
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Open with Default Application

Opens the selected file with the default application, for example, a media 
player.

Preview Processing

Allows you to preview the effect of the batch processor on the selected file. 
The preview includes all effects and the file format.

Insert Audio Files

Opens a submenu that allows you to select the audio files that you want to 
insert in the file list.

Insert Audio Montages

Opens a submenu that allows you to select the audio montages that you want 
to insert in the file list.

Options Above the File List

The following options are available above the files list:

Folder

Lets you select the folder that you want to add to the batch process.

Each time you start the batch process, the selected folder is scanned and the 
audio files that are found in the folder are processed.

 To disable this option, clear the path name.

NOTE

If you want to use XML files in the folder mode, you must select XML 
Descriptors in the File Types to Process menu.

Include Subfolders

If this option is activated, the subfolders of the selected folder are also 
scanned. The audio files inside these subfolders are added to the batch 
process.

Refresh

Refreshes the selected folder and, if Include Subfolders is activated, its 
subfolders. All audio files inside the folders are added to the batch process.

File Types to Process

Lets you specify which file types should be added to the batch process. You 
can also select that all file types should be added to the batch process.

Options Below the File List

The following options are available below the files list:
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Accept Dual Mono Files

If this option is activated, you can add dual mono files to your batch process.

Preview Duration

Determines the length of the preview duration.

Output Tab

On this tab, you can specify the output location for the files that you want to 
process.

Destination folder type

Define a type of destination folder. The following types are available:

• Temporary (Can Be Undone)
Writes the processed audio in a temporary file. For this, the source file 
must already be open in the Audio Editor.

• As Source Path
The file is rendered in its own folder.

• Subfolder of Source Path
The file is rendered in a customizable subfolder of its own folder.

• Subfolder “Output” in Source Path
The file is rendered inside the Output subfolder of the Watch Folder. 
This subfolder is created automatically by WaveLab Pro.

• Explicit Path
The file is rendered in a destination folder that you must specify.

• Explicit Path + Source Folder
As previous option, but the folder name of the source file is added to the 
path.

• Explicit Path + Source Folder (2 Levels)
As previous option, but the folder name of the source file, and its parent, 
are added to the path.

• Explicit Path + Source Folder (3 Levels)
As previous option, with one more added element of the source path.

• No Audio Output
Processing takes place while no file is written to the disk.
When using Watch Folders, this option only makes sense if you use the 
Audio Analyzer plug-in to produce a text file from the source audio file, 
without rendering a new audio file. The text file is always written in the 
Output subfolder of the Watch Folder.

NOTE

For Watch Folders, the destination folder can also be determined by an XML 
file that contains this information.
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Path

Specify the folder into which the files are rendered.

Rename Files

If this option is activated, the source file names are processed through a 
renaming preset, to produce new names for the rendered files.

Renaming Field

Allows you to open the Rename Files dialog, where you can set up a 
renaming scheme.

Name Scheme

Allows you to define naming schemes for the audio files or audio montages 
that you want to render. You can save naming schemes as presets.

RELATED LINKS

Naming Schemes on page 101

Format Tab

On this tab, you can specify the file format for the files that you want to process and 
specify how to handle meta-data.

File Format

Allows you to open the Audio File Format dialog for single file formats or 
multiple file formats.

Batch Meta-Data

Lets you select one of the following options for handling the batch meta-data:

• Ignore the batch meta-data and preserve the meta-data in the audio file.

• Merge the batch meta-data with the meta-data found in the audio file.

• Replace the meta-data of the audio file with the batch meta-data.

These options only have effect if Inherit From Source File is activated in the 
Audio File Format dialog.

For Audio Montages, Render CD Images and Cue Sheets

If this option is activated, audio montages are rendered as CD images 
together with cue sheets.

Options Tab

On this tab, you can make additional settings for the batch process.

Create Peak Files

If this option is activated, peak files are created for each rendered file.
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No Reverb Tail

If this option is activated, a fade is performed at the audio range bounds when 
a new file is created, or a crossfade with the audio neighborhood is created if 
the audio range is processed in place.

Crossfades allow a smooth transition between the processed and the 
non-processed parts. The crossfade time and shape are set in the Audio 
Files Preferences. If the fade time is longer than half the length of the 
processed file, it is not performed.

Copy Markers

If this option is activated, markers that are included in the range to process 
are copied to the rendered file.

On Success, Run External Tool

Allows you to select an external tool to run after the batch process is finished. 
For example, you could email, upload, or archive the resulting files. To be able 
to select tools, you need to specify them in the Configure External Tools 
dialog.

This option has no effect when using Watch Folders.

XML Tab

On this tab, you can make settings to generate XML files containing information 
about the audio files.

Process

Lets you select whether the output XML file should be generated from scratch 
(Generate XML/HTML File) or can use the input XML files as reference 
(Transform Input XML File). If you do not want to use an XML process, select 
the No XML Process option.

Presets

Lets you save and restore setting presets.

XSLT File

The path of the XSLT file that is used to generate the XML file.

Optional Parameters

The list of the parameters to send to the XSLT process. You can type new 
parameters into the text field or click the pen icon to open the Parameters for 
XSLT Processing dialog and enter the new parameters there.

Execution Tab

On this tab, you can make additional settings for the batch process.
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Auto Start When Dropping Files

If this option is activated, the processing starts automatically when dragging 
a file into the list.

Auto Remove Converted Files

If this option is activated, a file is removed from the list once it is successfully 
processed.

Stop on Error

If this option is activated, the global process stops if an error is encountered. 
If it is deactivated, the file associated with the error is marked in red, and the 
next file is processed.

This option has no effect when using Watch Folders.

Include File List When Saving

If this option is activated, the list of files (with their status) is saved with the 
batch processor document.

Usage of Processor Cores

Allows you to select how many cores are to be used simultaneously. The 
contents of this pop-up menu depend on your computer hardware.

When a File is to Be Overwritten

Specify the behavior when a file is to be overwritten. The following options are 
available:

• Overwrite without Question

• Stop and Ask

• Report as Error

• Skip and Mark as Done

• Auto-Rename

This option has no effect when using Watch Folders.

Comment Tab

On this tab, you can enter a comment for the active batch process document.

Batch Plug-ins Window

The Plug-ins window for batch processes allows you to select plug-ins and Master 
Section presets for the batch process. A plug-in or preset can be dragged into the 
audio plug-in chain of the active batch processor document. You can also 
double-click a plug-in to add it at the end of the chain.

• To open the Plug-ins window, open a batch process file and select Tool 
Windows > Batch Plug-ins.
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From the following categories, you can select plug-ins or Master Section presets:

Master Section Presets

This is the list of Master Section presets.

Master Section Plug-ins

This is the list of all plug-ins available in the Master Section.

Monopass Plug-ins

This is the list of monopass plug-ins. Monopass means that the audio signal 
needs to pass through the plug-in only once to be processed. These plug-ins 
are not available in the Master Section.

Multipass Plug-ins

This is the list of multipass plug-ins. Multipass means that the audio needs to 
be analyzed at least once before it is modified. These plug-ins are not 
available in the Master Section. Some are unique to the Batch Processor.

Metapass Plug-ins

This is the list of metapass plug-ins. Metapass means that the audio is 
analyzed once, and is processed after all other files have been analyzed, to 
take all analyses into account. These plug-ins are not available in the Master 
Section and are unique to the Batch Processor.

Off-Line Processors

There are several different types of plug-ins that can be applied to a batch process.

The following types of batch processing plug-ins are available:

• Monopass plug-ins only require one pass when processing. A monopass 
plug-in effect processes the signal and then outputs it to any subsequent 
plug-in.
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• Multipass plug-ins require two or more passes (one or more analysis passes 
followed by a process pass) before processing the audio. Some are unique 
to the Batch Processor window while others are also found as offline 
processors in the Audio Editor.

• Metapass plug-ins are unique to the Batch Processor window and require 
at least one analysis pass on all audio files before audio is processed. After 
analyzing the audio, a metapass plug-in takes into account all other plug-ins 
in the effects chain before processing the audio.

Master Section Presets

These presets are updated each time that you save a new preset in the Master 
Section. The presets also contain the Master Section gain settings.

Master Section Plug-ins

These plug-ins are all the plug-ins available from the Master Section, sorted in the 
same manner.

Metapass Plug-ins

A metapass plug-in analyzes all files in the batch, collects the results, and 
processes the files by varying amounts. The result of the analysis of one file can 
affect how other files are processed.

A typical example of a metapass plug-in is the Loudness Meta Normalizer, which 
can process a number of files so that they all get the loudness of the loudest file in 
the batch.

Metapass plug-ins can be freely combined with other types of processors. For 
example, you can use both the Loudness Meta Normalizer and a regular 
Normalizer in the same batch. You may also combine metapass plug-ins with 
multipass plug-ins.

A metapass plug-in requires two processing passes. During the first pass all the 
files in the batch are analyzed and during the second pass they are all processed.

This is different from other multipass plug-ins, where each file is 
analyzed/processed twice or more times if required.

Avoid Clipping When Increasing the Signal Level

Processors often increase the signal level. If you are not careful, your file may be 
distorted when it exits the batch. To prevent this, you can use the Only if Clipping 
option of the Level Normalizer multipass plug-in.
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It is no problem for the signal to be amplified above 0 dB (full level) within the audio 
stream, because WaveLab Pro uses 32-bit internal processing. There is a lot of 
extra headroom and the signal will not be clipped. However, when a signal that 
exceeds 0 dB is converted to a 16-bit file at the output of the Batch Processor, 
clipping occurs.

To remedy this, you can insert the Normalizer effect at the end of the signal chain. 
The Normalizer raises or lowers the levels as required so that the signal peaks 
exactly at the specified value just before it is converted to a file. This is useful to do 
even when Only if Clipping is not activated.

If you only want the Normalizer to be applied to avoid clipping, activate Only if 
Clipping. When this is activated, the signal output may be low, but the audio does 
not clip due to amplification within any of the processors.

This allows you to use the Normalizer as a completely distortion-free limiter.

If you reduce the bit depth, add the dithering plug-in after the Normalizer plug-in.

Working with the Batch Processor

Creating a Batch Process File

Batch process files allow you to set up a batch process.

PROCEDURE

1. Select File > New.
If you have specified a template to be the default template, clicking New opens a new 
template with the settings of the default template.

2. Click Batch Processor.

3. Do one of the following:
• To open an empty batch process file, select Create Empty.

• To create a batch process file that contains all files that are open in 
WaveLab Pro, select From Current File.

• To create a batch process from a template, select Templates and click the 
template that you want to use.
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Saving a Batch Process File

PREREQUISITE 

Set up your batch process.

PROCEDURE

1. Do one of the following:
• To save a batch process file that has never been saved before, select File > 

Save As.

• To save a batch process file that has been saved before, click Save, or select 
File > Save.

2. Specify a file name and location.

3. Optional: Activate Include File List.

4. Click Save.

Save Batch Processor Dialog

In this dialog, you can specify the name and location of the batch processor file that 
you want to save.

• To open the Save Batch Processor dialog, click the Save As button, or 
select File > Save As.

Name

The name of the file to write.

Location

The location where you want to save the file.

Include File List

If this option is activated, the file list is also saved, including the status of each 
file.

Save

Saves the file.

Save Copy

Allows you to save a copy of the open batch processor file. The batch process 
continues to refer to the source file. Click the arrow at the bottom right of the 
Save button to access the Save Copy option.

Adding Files to a Batch Process

You can add audio files and audio montages to a batch process.
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Adding Audio Files to a Batch Process

PREREQUISITE 

Create a new batch process file or open an existing file.

PROCEDURE

1. In the Batch Processor window, select the Edit tab.

2. In the Insert section, click Audio Files.

3. Select Browse.

4. Browse to the location of the audio file that you want to add, and select it.

5. Click Open.

RESULT 

The audio file is added to the batch process.

NOTE

You can also add audio files by right-clicking the Files to Process window, and 
selecting Insert Audio Files > File Group > Select All, or selecting one of the 
open audio files from the list.

Adding Audio Montages to a Batch Process

PREREQUISITE 

Create a new batch process file or open an existing file.

PROCEDURE

1. In the Batch Processor window, select the Edit tab.

2. In the Insert section, click Audio Montages.

3. Select Browse.

4. Browse to the location of the audio montage that you want to add, and select 
it.

5. Click Open.

RESULT 

The audio montage is added to the batch process.

NOTE

You can also add audio montages by right-clicking the Files to Process window, 
and selecting Insert Audio Montages > File Group > Select All, or selecting one 
of the open audio montages from the list.
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Adding Files from a Folder to a Batch Process

You can add all files that are included in a folder to a batch process.

PREREQUISITE 

Create a new batch process file or open an existing file.

PROCEDURE

1. In the Batch Processor window, select the Edit tab.

2. In the Insert section, click Files from Folder.

3. In the Add Files from Folder dialog, specify the folder location.

4. Optional: Activate Include Subfolders if you want to include files located in 
subfolders.

5. Specify the file type.

6. Click OK.

RESULT 

All files are added to the list of files to process.

Adding Files from a Default Folder to a Batch Process

You can specify a default folder in which you put the files that you want to batch 
process. Each time that you start the batch process, the selected folder is scanned 
and the audio files that are found in the folder are added to the file list and 
processed.

PREREQUISITE 

Create a new batch process file or open an existing file.

PROCEDURE

1. In the Folder field, specify the source folder.

2. If you want to include the files that are located in the subfolders, activate 
Include Subfolders.

3. From the File Types to Process pop-up menu, select which audio file types 
you want to include.

4. To start the batch process, select the Edit tab and click Start.
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Custom Plug-in Chain vs. Associated Master Section Preset

You can batch process files using a common custom plug-in chain or batch 
process each file with its own associated Master Section preset. You can also 
choose to use no plug-in at all for the batch process and only use the other features 
of the Batch Processor window, for example, the file format conversion or 
meta-data processing.

Adding Plug-ins to a Batch Process

You can create a custom plug-in chain and include it in the batch process.

PREREQUISITE 

Create a new batch process file or open an existing file.

PROCEDURE

1. Open the batch processing pop-up menu and select Custom Plug-in Chain.

2. In the Plug-in window, do one of the following:
• Select the plug-in or the Master Section preset that you want to use, and drag 

it to the Custom Plug-in Chain.

• Double-click a plug-in or a Master Section preset to add it at the end of the 
plug-in chain.

Audio Signal Path

The audio signal path of a batch process is indicated by red, green, and blue arrows 
in the audio plug-in chain list.

• A red arrow indicates that the signal is processed, then sent to the next 
plug-in.

• A green arrow indicates that the signal is analyzed at this stage of the audio 
chain, but is not yet modified and therefore not sent to the next plug-in. When 
the audio stream comes to an end, it is restarted. Next time the signal reaches 
this plug-in, it is modified, and sent to the next plug-in. Some plug-ins need 
several analyses before passing to the next plug-in.

• A blue arrow indicates that the signal has been fully processed at this stage 
and is written to disk.

• A vertical separator line indicates that a meta-pass happens. This means that 
the files are read and processed again one after the other.
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NOTE

Some multipass plug-ins request more than one analysis pass, or send the signal 
further in the chain without ordering the audio stream to restart. This behavior 
depends on the plug-in settings and on the audio material and cannot be 
influenced.

Removing Files and Plug-ins from the Batch Process

PROCEDURE

• In the Custom Plug-in Chain or Files to Process list, right-click the item that 
you want to remove, and select Remove, or select the item and press 
[Delete].

Changing the Order of the Plug-ins in the Batch Process

PREREQUISITE 

Create a new batch process file or open an existing file.

PROCEDURE

• Select a plug-in or Master Section preset from the audio plug-in chain list, 
and drag it to another position.

Previewing the Effect of the Batch Process

You can preview the effect of the batch processor on any file of a batch. The 
preview includes all effects and the file format.

PREREQUISITE 

Set up your batch process.

PROCEDURE

1. In the lower right corner of the Batch Processor window, set up the Preview 
Duration.
The preview duration can be between 2 seconds and 59 seconds.

2. Right-click the file that you want to preview and select Preview Processing.

Processing Open Files

If you are processing a file that is already open there are things to consider.
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• If the new file will have the same name and is saved in the same location, the 
file will not be saved because it is already open.

• If the new file will have the same name and is saved in the same location, and 
the number of channels changes in the file (mono becomes stereo or vice 
versa), a new document is created, which is opened in an untitled window.

Selecting an Output Format for the Batch Process

You can render to a single audio format or to multiple audio formats.

PREREQUISITE 

Create a new batch process file or open an existing file.

PROCEDURE

1. In the Batch Processor window, select the Format tab.

2. Click the File Format field.

3. Select Edit Single Format or Edit Multi Format.

4. In the Audio File Format dialog, make the settings, and click OK.

Setting Up a File Location for the Batch Process

PREREQUISITE 

Create a new batch process file or open an existing file.

PROCEDURE

1. In the Batch Processor window, select the Output tab.

2. Set the type of destination folder and the folder in which the audio files are 
rendered.

Specifying an Overwriting Strategy

PREREQUISITE 

Create a new batch process file or open an existing file.

PROCEDURE

1. Select the Execution tab.

2. From the When a File Is to Be Overwritten pop-up menu, select one of the 
following overwriting strategies:
• Overwrite without Question

• Stop and Ask
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• Report as Error

• Skip and Mark as Done

• Auto-Rename

Naming Rendered Audio Files

With the renaming function of the Batch Processor window, you can generate new 
names for the rendered files according to custom rules.

PREREQUISITE 

Open a batch processor file.

PROCEDURE

1. In the Batch Processor window, select the Output tab.

2. Activate Renaming, and click the renaming field.

3. Make your settings, and click OK.

Running and Stopping the Batch Process

Once all settings are made, you can start the batch process. You can pause and 
cancel the processing procedure at any time.

• To start the batch process, select the Edit tab and click Start.

• To pause the batch process, select the Edit tab and click Pause. You can 
continue the batch processing by clicking Pause again.

• To cancel the batch process, select the Edit tab and click Cancel.

Batch Processing Status Icons

The icons next to the file number indicate the status of the files in the Files to 
Process list.

Green circle

Indicates that the file is ready to be processed.

Cogwheel icon

Indicates that the file is being processed. The Batch Processor window 
cannot be closed if any files have this status.

Yellow dot

Indicates that the process is done partially. For example, the files have been 
analyzed (analysis pass), but not yet processed (modifying pass).
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Green dot

Indicates that the file has been successfully processed. In order to process 
the file again, you need to reset its status.

Red dot

Indicates that an error occurred.

Resetting the Status of Batch Processed Files

To apply the batch process again on already processed files, you need to reset the 
status of these files.

• To reset the status of one or several files in the File to Process list, select one 
or several files, right-click them, and select Reset Status.

• To reset the status of all files in the Files to Process list, select the Edit tab 
and, in the Reset Status section, click All Files.

• To reset the status of all files with an error in the Files to Process list, select 
the Edit tab and, in the Reset Status section, click Files with an Error.

Multitasking During the Batch Process

You can select how many CPU cores of your computer should be used 
simultaneously. The available number of cores depends on your computer 
hardware.

Each task uses one core, therefore the multitasking setting represents the maximum 
number of tasks that can be run in parallel. It is not always recommended to use the 
highest settings for the following reasons:

• If you want to continue working with your computer during batch processing, 
you need to spare power.

• The disk is slower.

• Graphics performance and user interface responsiveness are reduced.

• If your processor uses hyper-threading, half of the cores are virtual and do not 
bring as much power as real cores.

If many large files are written, using multitasking is not always recommended, 
because the files can become more fragmented on your disk. The resulting files 
might be slower to read, unless you are using SSD drives.

NOTE

The number of cores to be used can be changed at any time. Tasks that are already 
running are continued or paused, depending on the new setting.
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Selecting Processor Cores for the Batch Process

PROCEDURE

1. In the Batch Processor window, select the Execution tab.

2. Open the Usage of Processor Cores pop-up menu and select the number 
of processor cores that you want to use.

Watch Folders

Watch Folders can be used to automate batch processing tasks. By copying files 
into a Watch Folder a predefined batch processor is automatically applied to these 
files.

In the batch processor, you can use all audio processing functions that 
WaveLab Pro offers. For example, processing with VST plug-in chains, R-128 
loudness normalizing, audio analysis reports, MP3 conversions, etc.

NOTE

To fully take advantage of the Watch Folder feature, you must be acquainted with 
the Batch Processor window in WaveLab Pro.

Any kind of File Explorer/Mac OS Finder folder can be defined as Watch Folder. 
You can drag or copy files into the folder, or save audio files into a Watch Folder 
from any application. Watch Folders can process both audio files and audio 
montages.

You can set up multiple Watch Folders, each corresponding to a different audio 
process.

WaveLab Pro processes any files that are copied into Watch Folders, even if it is 
not the active application.

The procedure to set up a Watch Folder is to set up a batch processor, create a 
Watch Folder, associate the Watch Folder with the batch processor, and then 
activate the Watch Folder. When you now drag files into this folder, they are 
processed automatically.

The files that you drag into the Watch Folder can be located in folders with 
subfolders. The processed files in the output folder will have the same folder 
structure as the source files.

You can also drag XML files into the Watch Folder that specify the audio files that 
you want to process.

RELATED LINKS

Batch Processing on page 586
XML Files in Batch Processing on page 622
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Setting Up a Batch Processor for Watch Folders

You can associate any existing batch processor configuration with your Watch 
Folders or set up a new batch processor configuration for your Watch Folders.

A Watch Folder can be associated with multiple batch processor tasks. For 
example, copying a file into a Watch Folder could automatically produce an 96 kbps 
MP3 file, a 192 kbps MP3 file, an OGG file, and a normalized WAVE file.

• To edit the batch processor, double-click a batch processor in the Watch 
Folder window.

• To edit the output folder of a batch processor, double-click the Output 
Folder column of a batch processor in the Watch Folder window.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

Plug-ins that show a validation dialog on startup cannot be used.

RELATED LINKS

Working with the Batch Processor on page 598
Multitasking During the Batch Process on page 606

Watch Folders Window

In this window, you can set up and edit the Watch Folder configuration.

• To open the Watch Folder window, open the Batch Processor window and 
select Tool Windows > Watch Folder.

NOTE

The configurations that you make in the Watch Folder window are automatically 
saved as you edit.

Watch Folder List

The Watch Folder list shows the selected Watch Folder and its associated batch 
processors.

• To edit a Watch Folder, double-click the folder in the list.

• To exclude batch processors from being triggered, deselect the 
corresponding checkbox in the Watch Folders window.
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Functions Menu

Add Watch Folder Task

Opens the Add Watch Folder Task dialog, where you can assign a new 
Watch Folder to a batch processor.

Remove Watch Folder Task

Removes the selected watch folder task.

Settings

Opens the Watch Folder Settings dialog, where you can make additional 
settings for the Watch Folder.

Verify Configuration

Verifies that the Watch Folder configuration is valid and ready to be activated. 
This check is automatically performed when you activate the Watch Folder.

Start

Activates the Watch Folder. If you drag files into an active Watch Folder, the 
associated batch processors are applied.

Pause

Pauses the Watch Folders.

Stop

Stops the Watch Folders. All tasks that are running are canceled.

Multi Computer Processing

Allows you to activate the Watch Folders as master instance or slave 
instance.

Presets Menu

Save As

Allows you to save the active Watch Folder configuration as a preset.

Presets List

Lets you select a Watch Folder configuration preset.

Defining a Watch Folder

PREREQUISITE 

Set up a batch processor.

PROCEDURE

1. In the Batch Processor window, do one of the following:
• In the Watch Folders window, select Functions > Add Watch Folder Task.

• In the Watch Folders window, click the + icon.
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• Drag a folder that you want to make a Watch Folder or a batch processor file 
into the Watch Folders window. This opens the Watch Folder Task dialog and 
sets the corresponding folder or batch processor file as default.

2. In the Add Watch Folder Task dialog, do the following:
• Specify the path of the folder that you want to use as a Watch Folder.

• Specify the file types that you want to process.

• Specify the path of the batch processor that you want to trigger in the selected 
Watch Folder.

If a batch processor is already open in the Batch Processor window, it will be 
proposed by default in the Batch Processor File field.

3. Click OK.
The Watch Folder setup is added to the Watch Folders list.

4. In the Watch Folders window, select Functions > Settings and make 
additional settings for the Watch Folders.

5. To validate the Watch Folder setup, select Functions > Verify 
Configuration.

6. Optional: Assign another batch processor to the Watch Folder.

AFTER COMPLETING THIS TASK 

When you are done creating a Watch Folder configuration, you must activate it.

RELATED LINKS

XML Files in Batch Processing on page 622
Watch Folder Settings Dialog on page 616

Add Watch Folder Task Dialog

In this dialog, you can specify the Watch Folder location, its associated batch 
processor file, and the file types that should be processed.

• To open the Add Watch Folder Task dialog, open the Watch Folders 
window, and select Functions > Add Watch Folder Task or click the + icon.

Watch Folder Location

Allows you to specify the Watch Folder location.
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File Types to Process

Allows you to select the file types that are associated with the Watch Folder. 
Only files with the corresponding file format are added to the batch process.

Batch Processor File

Allows you to specify the batch processor file that you want associate with the 
Watch Folder.

You can click the icon  at the right of the text field to see a list of all open 
batch processors and a list of all recently used batch processors.

Activating the Watch Folder Configuration

Once you have set up a Watch Folder configuration, you can activate it.

PREREQUISITE 

Set up a batch processor and create one or more Watch Folders.

PROCEDURE

1. In the Watch Folders window, select Functions > Start.

2. In the Watch Folder Activation dialog, make your settings, and click Activate.

RESULT 

The Watch Folder configuration is active. Once you drag a file into a Watch Folder, 
the associated batch processors are triggered.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

To apply the changes that you have made for an active Watch Folder configuration, 
you must stop and restart the Watch Folders.

AFTER COMPLETING THIS TASK 

Via the system tray icon you can access information about the activated Watch 
Folder, and pause or stop the processing.

Processing Watch Folders in the Background

WaveLab Pro’s Watch Folder feature can be used as a background task. For this, 
an additional instance of WaveLab Pro is opened in the background. The two 
instances can run simultaneously.

The GUI mode is mainly used for setting up the Watch Folder and test the 
functionality. Once everything has been set up, you can activate the Watch Folder 
configuration using the WaveLab Pro background instance.
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The background instance can be used once you have set up the Watch Folder. 
When you drag files into your Watch Folder, the WaveLab Pro background 
instance processes the files. You can have the background instance launched 
automatically with the operating system.

You can use the Multi Computer Processing option to run a WaveLab Pro 
background instance on a different computer to increase the processing speed.

NOTE

Once a background instance is opened, it is independent from the instance that you 
work with.

RELATED LINKS

Watch Folder Activation Dialog on page 614
Multi Computer Processing on page 612

Automatically Starting a Background Instance on Startup

You can start a WaveLab Pro background instance automatically with the operating 
system.

• To activate or deactivate the automatic startup function, open the Watch 
Folder Activation dialog, and select Activate Watch Folders at Computer 
Startup.

You can also deactivate the automatic startup function outside WaveLab Pro.

• On Windows, remove the WatchFolders.lnk file from the following location: 

C:\Users\[UserName]\AppData\Roaming\Microsoft\Windows
\Start Menu\Programs\Startup

• On Mac, remove the WaveLab Pro entry from the login items list.

System preferences/Users & groups/Login items

RELATED LINKS

Activating the Watch Folder Configuration on page 611

Multi Computer Processing

You can use several computers that are located in the same network to process the 
same Watch Folders. For example, if there are 10 computers and 800 files to 
process, each computer processes 80 files. This increases the processing speed.

If the Watch Folder is located on a shared network path, the processing tasks are 
distributed between the computers. One instance of WaveLab Pro is the “master” 
version that distributes the files between the other computers that are in “slave” 
mode. This allows for much faster processing of the files.

The Watch Folder configuration of the master instance is used and shared with the 
slave instances.
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The multi computer processing option uses the background instance mode for each 
computer in the setup.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

• All computers in the network must be either Windows or Mac.

• All computers in the network must be set to the same language.

• Each computer must be set up with the plug-ins that are used by the batch 
processors.

• The paths specified in the Watch Folder configuration must be specified in a 
universal form.

On Windows, this must be in the following form: \\ServerName\volume

On Mac, this must be in the following form: /ServerName/volume

• If a task depends on specific settings (for example, the XML settings), these 
settings must be set on each computer. You can use the Synchronization 
Settings option in the WaveLab Pro global preferences to synchronize the 
computers.

Activating a Multi Computer Processing Watch Folder

PREREQUISITE 

Set up a batch processor and create one or more Watch Folders.

PROCEDURE

1. In the Watch Folders window, do one of the following:
• To activate a master instance, select Functions > Multi Computer 

Processing > Start as Master.

• To activate a slave instance, select Functions > Multi Computer Processing 
> Start as Slave.

NOTE

When you are setting up a new multi computer processing, you must first start the 
master instance.

2. Specify the network setting path.

3. Decide whether to activate the Watch Folders at computer startup.

4. Click Activate.

RESULT 

The Watch Folder starts in master or slave mode.
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Watch Folder Activation Dialog

In this dialog, you can set up the Watch Folder mode for the Watch Folders that you 
are activating.

Depending on whether you are activating a standard Watch Folder or use the multi 
computer processing mode, the Watch Folder Activation dialog has different 
options.

Standard Watch Folder Activation Dialog

In this dialog, you can specify whether the Watch Folder runs in GUI mode or as a 
background application.

In the Batch Processor window, in the Watch Folders window, set up a Watch 
Folder task, and select Functions > Start.

Start in This WaveLab Session

If this option is activated, the active WaveLab Pro instance is used for 
processing files in the Watch Folders. When files are copied into a Watch 
Folder, the corresponding batch processor file is activated. This allows you to 
see the progress of the processing from within WaveLab Pro.

This mode is useful for setting up the Watch Folder configuration.

Start as Background Application

If this option is activated, a new WaveLab Pro instance is launched in the 
background. This instance is used for processing the Watch Folders.

Priority

When using a WaveLab Pro background instance for processing files in the 
Watch Folders, this can slow down other programs when files are processed. 
You can set the priority with which the background instance uses the 
resources of the computer.

The following priorities are available:

• Normal: Causes the WaveLab Pro background instance to run with the 
same priority as all other programs.

• Low: Causes a WaveLab Pro background instance to run with a lower 
priority. Processing is slower, leaving more power to other applications.
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• Lowest: Causes a WaveLab Pro background instance to run with the 
lowest priority. Processing is slower, leaving more power to other 
applications than the Low option.

Activate Watch Folder at Computer Startup

If this option is activated, a background instance of WaveLab Pro 
automatically launches when the computer starts. This instance is used for 
processing files in the Watch Folders.

Watch Folder Activation Dialog for a Master or Slave Instance

In these dialogs, you can set up the multi computer processing. This allows you to 
distribute the processing of the batch processor files over several computers in the 
network.

Network Setting Path

When using multi computer processing, the Watch Folder configuration must 
be shared among all computers and the network path must be accessible for 
all computers in the network.

Activate Watch Folder at Computer Startup

If this option is activated, a background instance of WaveLab Pro 
automatically launches when the computer starts. This instance is used for 
processing files in the Watch Folders.
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Using the Watch Folder

Once you have set up the Watch Folder configuration, you can start to process files.

PREREQUISITE 

Set up one or several batch processor files, associate them with one or more Watch 
Folders, and activate the Watch Folder configuration.

PROCEDURE

• Drag, copy, or save audio files into your Watch Folders.
You can also drag entire folders into the Watch Folder.

NOTE

If you drag an empty folder into the Watch Folder, it is automatically deleted.

NOTE

If you have set up the Scheduled Folder option, place the files into the Scheduled 
subfolder inside the Watch Folder. Otherwise, they are processed immediately.

RESULT 

The files are processed according to your settings.

Saving a Watch Folder Configuration as Preset

You can save the Watch Folder settings and list as a preset. However, the preset 
does not include the batch processor files, which are independent files.

PROCEDURE

1. Set up a Watch Folder configuration.

2. In the Watch Folders window, select Presets > Save As.

3. In the Save Preset As dialog, do one of the following:
• To save the preset in the default folder, enter a name and click Save.

• To save the preset in a custom subfolder of the default folder, click the folder 
icon, enter a name for the subfolder, and click OK. Then select the subfolder, 
enter a name for the preset and click Save.

Watch Folder Settings Dialog

In this dialog, you can make settings for the Watch Folders.

• To open the Watch Folder Settings dialog, in the Watch Folders window, 
select Functions > Settings.
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Main Tab

After Processing Input File

After an input file is successfully processed, it has to be removed from its 
folder. The following options are available:

• Move Input File to the “Sources” Subfolder
If this option is activated, processed files are moved to a folder called 
Sources, inside the Watch Folder. The original folder structure is 
preserved.

NOTE

When using an XML file to describe the files to process, an audio file can be 
located anywhere outside the Watch Folder. In that case, the Move It to 
Source Subfolder option has no effect.

• Delete Input File
If this option is activated, processed files are deleted from the Watch 
Folder.

If an Input File Cannot Be Processed

If an input file cannot be successfully processed, it has to be removed from its 
folder. The following options are available:

• Move Input File to the “Errors” Subfolder
If this option is activated and a file cannot be successfully processed, it 
is moved to a folder called Errors, inside the Watch Folder. The 
original folder structure is preserved.

• Delete Input File
If this option is activated and a file cannot be successfully processed, it 
is deleted from the Watch Folder.

Scheduled Folder

You can specify a time range for the processing of Watch Folders. This allows 
you to automatically process files over night or during lunch break, for 
example.

To do so, create a folder named Scheduled inside the Watch Folder, 
activate the Scheduled Folder option, and specify the time range.

Files that reside copied outside the Scheduled subfolder are processed 
immediately.

Notification after Processing

If this option is activated, a system tray notification pops up when the files 
have been processed successfully. Clicking this notification opens the folder 
where the last file was rendered.

Add Readme File to Each Watch Folder

If this option is activated, a file called “readme.html” is added to the root folder 
of each Watch Folder. The readme file contains information about the settings 
of the Watch Folder.
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Advanced Tab

Timing

• Poll Period
This is the period during which WaveLab Pro scans Watch Folders. The 
shorter the time, the sooner the files that are copied into the Watch 
Folder are processed.

• Delay before Processing Starts
A file must be fully written to the Watch Folder before processing can 
start. Therefore, WaveLab Pro monitors how the file size increases and 
the time stamp of the file. Once these indicators are stable, 
WaveLab Pro waits for the specified time before starting the batch 
processors.
If the files are written by another application, for example, a Cubase 
mixdown, a value of 2 seconds is recommended. If the audio files are 
copied or moved from the File Explorer/Mac OS Finder, you can use a 
smaller value.

• Wait for Companion File
If an audio file is copied into the Watch Folder along with a marker file 
(.mrk), the processing should only start when both files are present in 
the Watch Folder. The delay value specifies how long WaveLab Pro 
waits for a marker file.
If you never process audio files with marker files, you can set this value 
to 0.
WaveLab Pro also waits for both mono audio files of a dual mono file if 
this is activated in the batch processor. The Wait for Companion File 
option is independent from the dual mono file capability, which relies on 
file naming analysis that you can set up in the Audio Files Preferences.

Log File

You can create a log file that is continuously updated with messages about 
the batch processing inside the Watch Folders. The log file helps you locate 
errors in the Watch Folder configuration.

• File Path
Here, you can specify the name and the location of the log file.
If you use Watch Folders in a distributing network environment, one 
independent log file is created on each computer.

• Clear Log File when Activating Watch Folders
If this option is activated, the log file is cleared each time Watch Folders 
are activated. This option is always activated if the log file has a markup 
format.

• Only Report Errors
If this option is activated, only error messages are written to the log.
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• Format
Lets you select whether the log file is a raw text file or a markup file (XML 
or HTML).
For markup files, an end tag is added only when the Watch Folders are 
deactivated. In case of a distributing computing environment, this tag is 
added by the master computer.

RELATED LINKS

XML Files in Batch Processing on page 622
Dual Mono Files on page 168

System Tray Icon

If Watch Folders are active, a system tray icon is displayed that gives information 
about the progress and errors, and offers several options regarding the active 
Watch Folder.

To open the context menu, click the system tray icon.

System tray icon on Windows.

Explore Watch Folder

Lets you open the active Watch Folders in the File Explorer/Mac OS Finder.

Info

Opens a pop-up message about the number of successfully processed files 
and the number of error messages.

Open Log File

Opens the log file for the Watch Folders.

Start WaveLab Pro

If the system tray icon corresponds to a background instance of 
WaveLab Pro, this option opens a new WaveLab Pro instance.

If there is already a visible instance of WaveLab Pro, it is put to the front.

Start

Activates the Watch Folders. If this option is not available, the Watch Folders 
are already activated.
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Pause

If this option is activated, WaveLab Pro stops watching folders. If files are 
being processed, their processing is paused. It will continue as soon as 
Pause is deactivated.

Stop

If this option is activated, WaveLab Pro stops watching folders and cancels 
any batch processing that is taking place.

Quit

Quits WaveLab Pro and cancels any batch processing that is active. This 
option is only available if WaveLab Pro is running in the background.

System Tray Status Icons

The system tray icon changes according to the status of the Watch Folder.

Active

Indicates that the Watch Folder is active.

Processing

Indicates that the Watch Folder is processing.

Pause

Indicates that the Watch Folder is paused.

Stop

Indicates that the Watch Folder is stopped.

Error

Indicates that an error occurred during processing. However, processing is 
not stopped.

Folder Structure

There are different types of subfolders that WaveLab Pro automatically creates 
inside a Watch Folder.

Output, Sources, Errors, Scheduled, and $TEMP$ are reserved for 
WaveLab Pro. You cannot create a subfolder with one of these names.

Output

When you create a new batch process, this is the folder where processed 
files are written by default. You can change the output folder in the Output 
tab of each batch processor.

Sources

This is the folder where processed files are moved when they are successfully 
processed. For this, the corresponding option must be activated in the Watch 
Folder settings.
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Errors

This is the folder where files that could not be processed are moved. For this, 
the corresponding option must be activated in the Watch Folder settings.

Scheduled

If you want to process some files only at a specific time, this is the folder 
where you must place the files. These files are only processed at the time that 
is specified in the Watch Folder settings.

$TEMP$

This is a temporary folder that is created and deleted by WaveLab Pro during 
processing.

Controlling the WaveLab Background Application via 
Command Line Parameters

You can control the WaveLab Pro background instance via command line 
parameters.

The following options are available:

--serviceLaunch

This command launches a WaveLab Pro background instance. It must be 
followed by one of the following options:

• alone: Causes a WaveLab Pro background instance to be launched for 
use in a single computer system.

• master: Causes a WaveLab Pro background instance to be launched 
in Master Mode for a multi computer system.

• slave: Causes a WaveLab Pro background instance to be launched in 
Slave Mode for a multi computer system.

For these commands, a background WaveLab Pro instance is launched in 
stop mode by default. This command can be followed by the commands 
--serviceCommand start and --servicePriority, for example.

--serviceLaunch alone --serviceCommand start 
--servicePriority low

--serviceAuto

This command causes a WaveLab Pro background instance to be launched 
in the mode that was active when you last selected Activate Watch Folders 
at Computer Startup from the Watch Folder Activation dialog.

For such an instance, the Watch Folders are automatically activated.

--serviceCommand

This command starts, pauses, or stops the WaveLab Pro background 
instance. It must be followed by one of the following options:

• start: Starts the WaveLab Pro background instance.
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• pause: Pauses the WaveLab Pro background instance.

• stop: Stops the WaveLab Pro background instance.

--servicePriority

This command defines the priority with which the WaveLab Pro background 
instance is using the processing power of the computer. It must be followed 
by one of the following options:

• normal

• low

• lowest

--serviceSettingPath

This command specifies the network path used to synchronize the 
configuration between the computers when you are running WaveLab Pro in 
master and slave mode. For example:

--serviceSettingPath "\\server\volume\test"

An example to start a master instance:

--serviceLaunch master --serviceCommand start 
--serviceSettingPath "\\server\volume\test"

An example to start a slave instance:

--serviceLaunch slave --serviceCommand start 
--serviceSettingPath "\\server\volume\test"

--serviceStatus

This command instructs WaveLab Pro to write the status of the Watch Folder 
to a file. This command must be followed by a file name and WaveLab Pro 
must run as a background instance.

The status file gives information about whether WaveLab Pro is running, 
paused, or stopped, the number of error messages, and success messages.

This command is useful to check the status of the Watch Folder system.

--serviceStatus "d:\tests\status.txt"

XML Files in Batch Processing

WaveLab Pro can read information from XML files, such as audio file location and 
meta-data. WaveLab Pro can also write information to XML or HTML files, such as 
custom data, meta-data, and audio analysis.

This is useful for handling and tagging huge amounts of audio files. Also, the batch 
input to WaveLab Pro and the batch output from WaveLab Pro can be controlled 
externally with XML files.

The input XML files must not be formatted in a restricted way. You can instruct 
WaveLab Pro to understand the structure of your XML files.
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XML Input

You can add an XML file to a batch processor to pass information to WaveLab Pro.

There are three types of elements that WaveLab Pro can identify.

Input file path and file name

To instruct WaveLab Pro where to find the audio file that you want to process. 
This information is mandatory.

Output file path

To instruct WaveLab Pro where to render the audio file. This information is 
optional.

If this information is available, it has priority over the output path settings that 
you make for the batch process on the Output tab.

Meta-data

To transmit meta-data that WaveLab Pro can add to the audio files that you 
want to process. This information is optional.

Instructing WaveLab to Understand your XML Files

You must instruct WaveLab Pro to understand you XML files, in order to make use 
of the XML input function.

PROCEDURE

1. In the Batch Processor window, select the Edit tab.

2. In the XML section, click XML Audio Description.

3. In the XML Audio Description dialog, specify the input location.

4. Optional: Specify more elements.
If you have selected User Variable (to Import Meta-Data), specify a user variable.

5. Specify a tag and, if necessary, an attribute name and value.

NOTE

You can only specify one attribute per tag. If your XML file has other attributes, these 
are ignored by WaveLab Pro.

6. If necessary, specify the enclosing element tag and its attribute name and 
value.

7. Optional: To save the settings as preset, click the presets field, select Save 
As, enter a name, and click OK.

8. Click OK.

RESULT 

WaveLab Pro can understand the structure of your XML file. You can now add the 
XML file to your batch process.
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XML Audio Description Dialog

In this dialog, you can instruct WaveLab Pro how to understand the structure of the 
XML file that you want to read.

• To open the XML Audio Description dialog, open the Batch Processor 
window, and in the XML section on the Edit tab, click XML Audio 
Description.

Element

Lets you select the element that you want WaveLab Pro to identify in the XML 
file. You can specify the file location of the input file and the file location of the 
output file. The following input and output elements are available:

• Input Folder/Output Folder
The input folder is the folder where the audio file is located. The output 
folder is the folder where you want to save the file. These paths can be 
relative to the path of the XML file.
If no input/output folder is found, the file path of the XML file is used 
instead.

• Input File Name/Output File Name
The file name of the input/output file. For example, Piano.wav.

• Input File Path/Output File Path
The complete input/output path including the file name. For example, 
C:\AudioFiles\Piano.wav.

For the input, you must specify either the Input File Path or the Input Folder 
+ Input File Name. If the audio file is located in the same folder as the XML 
file, it is sufficient to specify only the File Name.

If you do not make any output settings, the settings of the batch processor are 
used.

User Variable

Lets you specify custom variables that you want WaveLab Pro to identify in 
the XML file. This option is available if you have selected User Variable on the 
Element menu.
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The custom variables are shared throughout WaveLab Pro. To edit the 
variables, select File > Preferences > Variables.

Identification – Tag

Lets you specify the XML tag that describes the element to identify.

Identification – Attribute Name and Value

If this option is activated, you can specify an XML attribute and its value for 
the tag to identify an element. In the text field, you must write the name and 
value in the following style:

attr=”value”

Enclosing Element

If this option is activated, the element must be further identified by a parent 
tag.

Enclosing Element – Tag

Lets you specify the XML tag of the enclosing element.

Enclosing Element – Attribute Name and Value

If this option is activated, you can specify an XML attribute and its value for 
the tag of the enclosing element to identify an element. In the text field, you 
must write the name and value in the following style:

attr=”value”

Preview

Shows a preview of the structure that WaveLab Pro expects in the XML file.

RELATED LINKS

Variables and Text Snippets on page 676

XML Output

After a batch process, WaveLab Pro can automatically produce an XML or HTML 
file that describes the processed audio files. This file can contain the type of 
processing, the embedded meta-data, and the audio analysis result, for example.

An XSLT file must be specified to instruct WaveLab Pro how to generate the 
XML/HTML file. The XSLT file must use the UTF-8 character set.

You can generate the XML/HTML file from scratch or generate an XML file that is 
based on an existing XML file. The structure of the existing input XML file must be 
specified in the XML Audio Description dialog. The input XML file can contain the 
location of the audio files that you want to process and information that you want to 
find in the XML/HTML output file, for example.

Once the XML/HTML files are generated, you can import them to a database or a 
podcast, for example.

RELATED LINKS

Instructing WaveLab to Understand your XML Files on page 623
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XML Tab on page 594

XSLT Files

WaveLab Pro needs an XSLT file to create an XML output file or transform an XML 
or HTML document to another XML document.

XSLT is a language for transforming XML documents into other XML documents, or 
generating XML documents from scratch. The WaveLab Pro XSLT processor is 
compatible with the XSLT 2.0 standard. However, not all features are supported, for 
example, xsl:output.

The XSLT file in WaveLab Pro determines whether the generated output file will be 
in XML or in HTML format. WaveLab Pro provides XSLT example files to generate 
XML or HTML files that describe the processed audio files.

• To use the XSLT example files, select the XML tab, open the Presets pop-up 
menu, and select Factory Presets > HTML Example or Factory Presets > 
XML Example.

In order for the example to work properly, the processed audio file must 
contain information for the ID3v2 meta-data fields Title and Genre.

Parameters for XSLT Processing

You can specify which parameters will be included in an XML or HTML output file 
that you can generate with the batch process. For example, you can include 
meta-data and the results of an audio analysis in such an output file.

To transmit parameters to the XSLT script, define them in the Parameters for XSLT 
Processing dialog.

NOTE

ID3v2 meta-data can have custom fields (“TXXX”) that WaveLab Pro cannot list 
automatically on the menu. However, you can enter them manually.

Including Audio Analyzer Results in the XML or HTML Output File

You can include the audio analysis results of the Audio Analyzer batch processor 
monopass plug-in in the XML or HTML output file.

PROCEDURE

1. Open the Audio Analyzer monopass plug-in.

2. In the Audio Analyzer dialog, activate the Send Analysis Results to XML 
Processor option.

3. Open the Parameters for XSLT Processing dialog and select the 
parameters of the audio analysis that you want to include in the output XML.
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Parameters for XSLT Processing Dialog

In this dialog, you can edit the parameters that you want to find in the XML or HTML 
file that you can generate with the batch process.

• To open the Parameters for XSLT Processing dialog, in the Batch 
Processor window, select the XML tab, and click the pen icon.

Create Parameter

Creates a new parameter.

Remove Parameter

Removes the selected parameter.

Parameter List

In the left column, you can specify a parameter name that is known by your 
XSLT file. In the right column, you can specify the value for the parameter.

The parameter values can be custom variable codes, custom variable values, 
auto variable codes, auto variable values, and text snippets. To see a list of all 
available parameters, click the arrow icon.

RELATED LINKS

Variables and Text Snippets on page 676

Generating an XML or HTML File From Scratch

PREREQUISITE 

• Set up your batch process.

• Set up an XSLT file.

PROCEDURE

1. In the Batch Processor window, select the XML tab.

2. On the output pop-up menu, select Generate XML/HTML File.

3. In the XSLT file field, specify the path to your XSLT file.
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4. Optional: In the Optional Parameters field, click the pen icon and specify 
additional parameters.

5. On the Edit tab, click Start to start the batch process.

RESULT 

The audio files are processed and an XML/HTML file is generated with the 
information that are specified by the XSLT script.

The XML/HTML file is saved in the same location and with the same name 
(extension .xml or .html) as the rendered audio file. If No Output is activated, 
the XML/HTML file is saved in the Output subfolder of the Watch Folder.

Generating an XML File Based on an Existing Input XML File

PREREQUISITE 

• Set up your batch process.

• Set up an XSLT file.

• Instruct WaveLab Pro how to understand the input XML file.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

The input XML file must be valid to the structure that is specified in the XML Audio 
Description dialog.

PROCEDURE

1. In the Batch Processor window, select the XML tab.

2. On the output pop-up menu, select Transform Input XML File.

3. In the XSLT file field, specify the path to your XSLT file.

4. Optional: In the Optional Parameters field, click the pen icon and specify 
additional parameters.

5. Add the input XML file to the batch process.
The audio files that are specified in the input XML file are displayed in the batch 
processor list.

IMPORTANT

Do not manually add audio files to the batch process. The location of the audio files 
that you want to process is taken from the input XML file.

6. On the Edit tab, click Start to start the batch process.

RESULT 

The audio files are processed and an output XML file is generated with the 
information that are specified by the XSLT script.
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The XML file is saved in the same location and with the same name (extension 
.xml) as the rendered audio file. If No Output is activated, the XML file is saved in 
the same location as the source file.

RELATED LINKS

Instructing WaveLab to Understand your XML Files on page 623
XML Audio Description Dialog on page 624
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Batch Conversion

You can convert multiple files simultaneously to another format. If no processing is 
needed, this can be done using the Batch Conversion dialog.

Batch Conversion Dialog

This dialog allows you to convert the file format of a group of audio files.

• To open the Batch Conversion dialog, select File > Tools > Batch 
Conversion.

Add File

Opens a dialog, where you can select files to add to the list.

Remove Selected Files

Removes the selected item from the list.

List of files to convert

Shows the files to convert.
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Output Tab

Folder

Allows you to specify the folder in which the converted files are saved.

File Format

Allows you to open the Audio File Format dialog, where you can set the file 
format.

Options Tab

Auto Start When Dropping Files

If this option is activated, the conversion starts automatically when you drag a 
file into the list.

Auto Remove Converted Files

If this option is activated, a file is removed from the list once it is successfully 
converted. Otherwise, it remains in the list with a green mark indicating its 
status.

Stop on Error

If this option is activated, the global process stops if an error is encountered. 
If this option is deactivated, the file associated with the error is marked in red, 
and the next file is processed.

Multitasking Tab

Usage of Processor Cores

Allows you to select how many cores to use simultaneously. The contents of 
this menu depend on your computer hardware.

Batch Converting Files

PROCEDURE

1. Select File > Tools > Batch Conversion.

2. Click the plus icon to add files, or drag the files into the Files to Convert list.

3. On the Output tab, select a file location and a file format.

4. Optional: Make further settings on the Options and Multitasking tabs.

5. Click Start to begin converting the files.
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Batch Renaming

With the batch renaming functions, you can batch rename multiple files, markers, 
and clips. You can convert, remove, format, import, and insert text. This allows you 
to batch rename file names according to user specified rules.

You can use simple options to match text, or you can build your own regular 
expressions. Batch renaming can be useful with large projects, for example, to apply 
easily identifiable names to all referenced files, clips, and markers belonging to the 
project.

You can use batch renaming for the following operations:

• Rename files

• Rename clips in an audio montage

• Rename markers in audio files and audio montages

Batch Renaming Dialogs

The Batch Renaming dialogs for files, clips, and markers share most features, with 
some differences.

The Batch Renaming dialog has 3 pages.

1) The first page defines which files, clips, or markers are renamed. It is different 
for all renaming operations.

2) The second page defines how the renaming is performed. It is identical for all 
renaming operations.

3) The third page shows you a preview of the resulting names.

Batch Renaming Files

You can batch rename multiple files according to specified settings.

PROCEDURE

1. Select File > Tools > Batch Renaming.

2. In the Batch Renaming dialog, select the files that you want to rename and 
click Next.
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3. Define the batch rename operation and click Next.

4. Verify that the renaming is performed as intended, then click Finish.

RELATED LINKS

Batch Renaming Dialog for Files on page 633
Renaming Operation Categories and Types on page 637
Previewing and Performing All Renaming Operations on page 645

Batch Renaming Dialog for Files

In this dialog, you can batch rename individual files. Any open files that reference 
these files are updated automatically.

• To open the Batch Renaming dialog, select File > Tools > Batch 
Renaming.

On the first page of this dialog, you can define which files to rename, by using the 
following options:

Rename Files in This Folder

Allows you to specify the folder that contains the files to rename.

Scan Subfolders

If this option is activated, files are also searched in subfolders.

Only Rename Files with This Extension

If this option is activated, only files with the extension specified in the text field 
below are renamed.
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Only Rename Files with Specific Names

If this option is activated, only files that correspond to a specific name are 
renamed. You can type in a text string in the text field below, and select one 
of the following options from the menu:

• Name must contain this text

• Name must NOT contain this text

• Name must contain this text (with wild cards)

• Name must NOT contain this text (with wild cards)

• Name must contain this regular expression

• Name must NOT contain this regular expression

Skip Read-Only Files

If this option is activated, files that are read-only are not renamed.

Set New Extension

If this option is activated, the extension of files is replaced with the extension 
specified below.

Batch Renaming Markers

You can batch rename multiple markers in audio files or audio montages according 
to specified settings.

PROCEDURE

1. Optional: If you only want to rename markers in a specific time range, create 
a selection range in the wave window or the montage window.

2. Open the Markers window, and select Functions > Batch Renaming.

3. In the Batch Renaming dialog, on the Target page, make your settings, and 
click Next.
If you have made an audio selection and want to use it, activate All Markers in Audio 
Selection.

4. Define the batch rename operation, and click Next.

5. Verify in the preview list that the renaming is performed as intended, and click 
Finish.

RELATED LINKS

Batch Renaming Dialog for Markers on page 635
Renaming Operation Categories and Types on page 637
Previewing and Performing All Renaming Operations on page 645
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Batch Renaming Dialog for Markers

In this dialog, you can batch rename markers of any type.

• To open the Batch Renaming dialog for markers, open the Markers window 
and select Functions > Batch Renaming.

All Markers

If this option is activated, all markers in the selected file are renamed.

All Markers in Audio Selection

If this option is activated, all markers in the selected audio range are renamed.

Types to Rename

Only the markers of the type selected here are renamed.

Only Markers With Specific Names

If this option is activated, only markers that correspond to a specific name are 
renamed. You can type in a text string in the text field below, and select one 
of the following options from the menu:

• Name must be empty

• Name must contain this text

• Name must NOT contain this text

• Name must contain this text (with wild cards)

• Name must NOT contain this text (with wild cards)

• Name must contain this regular expression

• Name must NOT contain this regular expression

Skip Locked Markers

If this option is activated, markers that are locked are not renamed.
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Batch Renaming Clips

You can batch rename multiple clips according to specified settings.

PROCEDURE

1. In the Clips window, select Functions > Batch Renaming.

2. In the Batch Renaming dialog, select the clips that you want to rename and 
click Next.

3. Define the batch rename operation and click Next.

4. Check in the preview list if the renaming is as intended, then click Finish.

RELATED LINKS

Batch Renaming Dialog for Clips on page 636
Renaming Operation Categories and Types on page 637
Previewing and Performing All Renaming Operations on page 645

Batch Renaming Dialog for Clips

In this dialog, you can batch rename audio montage clips.

• To open the Batch Renaming dialog for clips, open the Clips window and 
select Functions > Batch Renaming.

On the first page of this dialog, you can define which clips to rename, by using the 
following options:

All Clips

If this option is activated, all clips are renamed.
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All Clips on Selected Track

If this option is activated, all clips on the selected track are renamed.

All Selected Clips

If this option is activated, all selected clips are renamed.

Only Clips With Specific Names

If this option is activated, only clips that correspond to a specific name are 
renamed. You can type in a text string in the text field below, and select one 
of the following options from the menu:

• Name must be empty

• Name must contain this text

• Name must NOT contain this text

• Name must contain this text (with wild cards)

• Name must NOT contain this text (with wild cards)

• Name must contain this regular expression

• Name must NOT contain this regular expression

Skip Locked Clips

If this option is activated, clips that are locked are not renamed.

RELATED LINKS

Clips Window on page 287

Renaming Operation Categories and Types

On the second page of the Batch Renaming dialog, you set up the renaming 
operation that you want to perform for clips, files, or markers.

The Category pop-up menu lists the renaming operation categories. The Type 
pop-up menu lists the various types of renaming operations. When you select a 
type, the related controls are displayed. The types depend on the selected category.

Remove

All

Removes all characters from the selected range.

Spaces

Removes all spaces from the selected range.

Spaces at Start/End

Removes all spaces at start and end of the selected range.
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Duplicate

Replaces two consecutive identical characters by one. Specify the character 
to remove in the Character field.

Specific Characters

Removes all instances of one or more characters. Specify the characters to 
remove in the Character field.

Surrounded Text

Removes all instances of one or more characters. In the Left Character field, 
specify the characters from which on the text is removed. In the Right 
Character field, specify the last character to remove.

Then specify in the Occurrence pop-up menu which character to remove if 
several are found.

Convert

To Lower Case

Sets all characters in the selected range to lower case.

To Upper Case

Sets all characters in the selected range to upper case.

Capitalize

Sets the first character to upper case, and the rest to lower case. On the 
menu, you can specify whether only the first word or all words should be 
capitalized.

Initials to Upper Case

Sets only isolated letters to upper case. For example, u.s.a to U.S.A.

Specific Character to Text

Replaces each instance of a specific character with a custom string. In the 
Character to Replace field, enter the character you want to replace. In the 
Replacement field, enter the replacement string.

Pad Number with Zeros

Pads a number present in the selected range with zeros at the left side. On 
the menu below, specify how many digits the number should consist of.

Invert Character Order

Inverts the order of the characters in the selected range.

Replace with New Text

Replaces the selected range by a specific text string. In the text field below, 
enter this string.
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Insert

Nothing

Inserts nothing.

Counter

Inserts a number at the selected position, and updates its value with each 
insertion. Set up the counter with the additional options.

Specific Text

Inserts a string at the selected position. In the text field below, enter the text 
to be inserted.

Part of Original Name

Inserts a part of the original name (before the first operation was performed) 
at the selected position. In the text field below, enter the regular expressions. 
Clicking on the bulb icon opens a menu with shortcuts for several regular 
expressions.

Pair of Characters around Text

Inserts specific characters before and after the selected range. In the Left 
Character field, specify the characters to insert before the selected range. In 
the Right Character field, specify the characters to insert after the selected 
range.

Spaces around Text

Inserts a space before and after the selected range.

Space after Specific Characters

Inserts a space after specific characters. In the field below, enter the 
characters that should be followed by a space.

Space before Each Capitalized Word

Inserts a space before each word starting with an upper case letter. For 
example, this changes “MyNicePiano” to “My Nice Piano”.

If Only Capitalize First Word is activated, only the first word is capitalized.

Today’s Date/Time

Inserts the current date and time.

Universal Unique Identifier

Inserts a unique identifier. This is useful for recordings, for example.

Random Word

Inserts a random pronounceable word.
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Import and Insert External Data

This category allows you to insert information taken from a file or current context. 
This is mostly audio-oriented as some features analyze the audio file headers. The 
available options differ depending on the selected Batch Renaming dialog.

Sample Rate

Inserts the sample rate of the file. In the fields below, enter a prefix and suffix, 
and select how to format the imported data.

Number of Channels

Inserts the number of channels of the file. In the fields below, enter a prefix and 
suffix, and select how to format the imported data.

Sample Bit Resolution

Inserts the bit resolution of the file. In the fields below, enter a prefix and suffix, 
and select how to format the imported data.

Bit Rate

Inserts the bit rate of the file if the file is encoded. In the fields below, enter a 
prefix and suffix, and select how to format the imported data.

Variable/Constant Bit Rate

Inserts the tag VBR or CBR if the file is encoded. In the fields below, enter a 
prefix and suffix.

File Length

Inserts the length of the file. In the fields below, enter a prefix and suffix.

File Extension

Inserts the extension of the file. In the fields below, enter a prefix and suffix.

Date/Time

Inserts the date/time of the file at the selected position. In the Format field 
below, enter a date.

Folder Name

Inserts the name of the folder containing the file. In the fields below, enter a 
prefix and suffix.

Folder Name (2 Positions Up)

Inserts the name of the folder located two positions higher up in the hierarchy. 
In the fields below, enter a prefix and suffix.

Folder Name (3 Positions Up)

Inserts the name of the folder located three positions higher up in the 
hierarchy. In the fields below, enter a prefix and suffix.

Sample: MIDI Note

Inserts the sample note of the file, if available. In the fields below, enter a prefix 
and suffix, and select how to format the imported data.
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Sample: Detune

Inserts the detune information for the sample, if available. In the fields below, 
enter a prefix and suffix.

Sample: Key Range

Inserts the key range of the sample, if available. In the fields below, enter a 
prefix, suffix, and separator, and select how to format the imported data.

Sample: Velocity Range

Inserts the velocity range of the sample, if available. In the fields below, enter 
a prefix, suffix, and separator, and select how to format the imported data.

Meta-Data: Title

Inserts the title if this information is present in the meta-data of the file. In the 
fields below, enter a prefix and suffix.

Meta-Data: Artist

Inserts the artist if this information is present in the meta-data of the file. In the 
fields below, enter a prefix and suffix.

Meta-Data: Genre

Inserts the genre if this information is present in the meta-data of the file. In 
the fields below, enter a prefix and suffix.

Meta-Data: Album

Inserts the album if this information is present in the meta-data of the file. In 
the fields below, enter a prefix and suffix.

Meta-Data: BWF description

Inserts the corresponding meta-data. You can insert the title, artist, genre, 
album, and BWF description.

Timeline Position

Inserts the position of the file in the timeline. In the fields below, enter a prefix 
and suffix.

Line [x] from Text File

Inserts the specified line from a text file to the specified renaming operation. 
In the field below, specify the location of the text file (UTF-8) from which the 
strings should be collected.

Find and Replace from Table

This category allows you to define a table of words and to associate each word with 
a replacement. This feature is useful to reformat a text according to a new style. For 
example, it can be used to map a series of numbers to a series of tags, to change a 
numerical sequence like “000 – 127” to “C-2 – G8” (MIDI notes).

Find Anywhere in Text

Replaces the words in the table with their specified replacement if they can 
be found anywhere in the selected range.
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Find Exact Text

Replaces a word of the table with its specified replacement if it is identical to 
the word in the selected range.

In the table below these types, you can define a list of strings to find, and define a 
replacement for each one. Double-click the cells to edit the list. If a file cell is empty, 
it is ignored.

If Case Sensitive Search is activated, the search takes the letter cases into 
account. If Keep Letter Case is activated, the case of the replacement text is 
adapted to the case of the found text.

List of Renaming Operations

In this section on the Operation page of the Batch Renaming dialog, you can 
create, delete, and arrange renaming operations.

Add Renaming Operation

Adds a new renaming operation at the end of the list.

Remove Selected Renaming Operation

Removes the selected renaming operation from the list.

Arrow Up/Down

Moves the selected renaming operation one position up/down.

Renaming Operations

Lists all renaming operations that are performed on the original name. The 
operations are performed one after the other.

Preview Section

In this section on the Operation page of the Batch Renaming dialog, you can 
preview the result of the selected renaming operation.

When you enter a name in the Original field, the change is automatically reflected 
in the Output Format field. This preview is continuously updated.
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If the preview cannot display missing data, an “X” is shown instead.

Range Parameters

The range parameters on the Operation page of the Batch Renaming dialog allow 
you to specify where in the name the operation is performed.

• To access the range parameters, click Advanced Editing at the bottom of the 
Batch Renaming dialog.

Range to Process

All

If this option is activated, the whole name is processed by the operation.

Regular Expression

Select this option if you want only a part of the name to be processed by the 
operation. In this case, you need to define a regular expression. Clicking on 
the bulb icon opens a menu with shortcuts for several regular expressions.

From/To

If this option is activated, you can set the start and end position of the range 
independently in the From and To sections.

From

Start

If this option is activated, the position is the beginning of the source name.
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Character Position

If this option is activated, the position is a fixed offset from the beginning of 
the of the source name.

Start of Regular Expression

Select this option if you want the position to be the one of the sub-strings 
found by the regular expression applied on the source name.

After Regular Expression

Select this option if you want the position to be the one right after the 
sub-string found by the regular expression applied on the source name.

End of Previous Operation

If this option is activated, the position corresponds to the end of the change 
performed by the previous operation.

End

If this option is activated, the position is the end of the source name.

To

End

If this option is activated, the position is the end of the source name.

Position from End

If this option is activated, the position is a fixed offset before the end of the 
source name.

Number of Characters

If this option is activated, the end position is given by the start position plus a 
number of characters.

Before Start of Regular Expression

Select this option if you want the position to be just before the sub-string 
found by the regular expression applied on the source name.

End of Regular Expression

Select this option if you want the position to be the end of the sub-string 
found by the regular expression applied on the source name.

Comment

Comment

Allows you to add a comment to the batch renaming operation.
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Previewing and Performing All Renaming Operations

On the last page of the Batch Renaming dialog, you can see how all the selected 
file, clip, or marker names are changed before you start the batch renaming. Note 
that if the name contains a random item, this item name will most likely be different 
in the preview.

PREREQUISITE 

You made your settings on the first two pages of the dialog.

PROCEDURE

1. In the list, check if the changes are as you intended.

2. Click Finish.

Regular Expressions

A regular expression is a formula composed of characters that have special 
meanings (called operators). Other characters are plain letters and numbers that 
are searched for. The search engine browses the target text one character at a time 
and stops as soon as it finds a sequence of characters that matches the regular 
expression.

At various places in WaveLab Pro, you can use regular expressions to build 
complex text matching operations into your conversion and renaming processes. A 
regular expression is a set of text symbols that describe a method to find a specific 
text string within a large body of text, and then apply a specific operation to this text 
string. Regular expressions are available to perform powerful string search/replace 
operations, for example, in batch renaming or batch processing.

Throughout WaveLab Pro, wherever you see the bulb icon , there is a field where 
you can create your own regular expressions. A menu containing shortcuts to build 
up the basic syntax of an expression is also available.

Common Regular Expressions

There are various versions of regular expressions. WaveLab Pro uses a version that 
represents a good compromise between power and ease-of-use.
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The term “expression” refers to a single character, a character class, or a 
sub-expression enclosed with () or {}. Searches for regular expressions are not case 
sensitive.

Regular Expressions Pop-up Menu

Menu Item Operator Description

Any Character . Symbolizes any character.

Character in Range [ ] A bracketed text is treated as a single 
character, for example: [AEW13] means A or 
E or W or 1 or 3. A hyphen within the brackets 
specifies a range of characters. For example, 
[F-I] means F or G or H or I, and [A-Z0-9] 
matches all letters and all digits.

Character Not in 
Range

[^] A circumflex located at the first position in a 
bracket is a complement operator. It describes 
a situation where all characters match except 
those included in the bracket. For example, 
[^E] means any character except E.

0 or 1 Match (1 if 
Possible)

? Matches 0 or 1 time the preceding 
expression. 1 repeat if possible is grabbed, 
then the rest of the regular expression 
continues to be evaluated.

0 or 1 Match (0 if 
Possible)

?? Matches 0 or 1 time the preceding 
expression. 0 repeat if possible (the NEXT 
step in the regular expression is also 
evaluated and has priority).

0 or More Matches 
(as Many as 
Possible)

* Matches 0 or more times the preceding 
expression. As many repeats as possible are 
grabbed, then the rest of the regular 
expression continues to be evaluated.

0 or More Matches 
(as Few as Possible)

*? Matches 0 or more times the preceding 
expression. As few repeats as possible are 
grabbed (the NEXT step in the regular 
expression is also evaluated and has priority).

1 or More Matches 
(as Many as 
Possible)

+ Matches 1 or more times the preceding 
expression. As many repeats as possible are 
grabbed, then the rest of the regular 
expression continues to be evaluated.

1 or More Matches 
(as Few as Possible)

+? Matches 1 or more times the preceding 
expression. As few repeats as possible are 
grabbed (the next step in the regular 
expression is also evaluated and has priority).

Or | OR operator. Use this to separate two 
expressions and to match expression #1 or 
expression #2. For example, Piano|Drum 
matches all texts that contain Piano or Drum.
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Special Characters Submenu

On this submenu, all special characters for regular expressions are available.

Shortcuts Submenu

Not ! Negation operator: the expression following ! 
must not match the text. For example, a!b 
matches any “a” not followed by “b”.

Generic Group () Grouping operator. Useful to form a 
sub-expression.

Capture {} Capture operator. By default, the found text 
corresponds to the entire regular expression. 
But it is possible to limit a part of the regular 
expression with { }, and if a part is matched, 
this will be the retained part. For instance the 
regular expression “ab{cd}ef” that is applied 
on “abcdef” will return “cd”.

Beginning of Text ^ Use the circumflex sign to specify that the text 
must be located at the start of the browsed 
text. Any match not located at the start of the 
browsed text is ignored.

End of Text $ Use this sign to specify that the text must be 
located at the end of the text. Any match not 
located at the end of the text is ignored.

Menu Item Operator Description

Menu Item Operator Description

Any Digit (0-9) /d Symbolizes any digit, as [0-9].

Any Non-Digit (not 
0-9)

/D Symbolizes any non-digit, as [^0-9].

Any Letter (a-z or 
A-Z)

/l Symbolizes any letter, as [a-z].

Any Non-Letter (not 
a-z, not A-Z)

/L Symbolizes any non-letter, as [^a-z].

Any Alphabetic (a-z, 
or A-Z, or 0-9)

/w Symbolizes any alphabetic character, as 
[0-9a-z].

Any Non-Alphabetic 
(not a-z, not A-Z, not 
0-9)

/W Symbolizes any non-alphabetic character, as 
[^0-9a-z].

Number /u Symbolizes a number (without a sign).

Number (with 
Possible +- Before)

/i Symbolizes a number which can be preceded 
by a + or - sign.

Quoted String /q Symbolizes quoted text.
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Presets Submenu

Simple Word /z Symbolizes a simple word (a sequence of 
letters surrounded by non-letters, for example, 
spaces).

Menu Item Operator Description

Menu Item Operator Description

1st Word /z Searches for the first word (separated by a 
space).

2nd Word /z/L+{/z} Searches for the second word (separated by 
a space).

3rd Word /z/L+/z/L+{/z} Searches for the third word (separated by a 
space).

Last Word {/z}/L*$ Searches for the last word (separated by a 
space).

1st Expression in 
Parentheses

.*?{/(.*?/)} Searches for the first string enclosed in 
parentheses.

2nd Expression in 
Parentheses

.*?/(.*?{/(.*?/)} Searches for the second string enclosed in 
parentheses.

3rd Expression in 
Parentheses

.*?/(.*?/(.*?{/(.*?/)} Searches for the third string enclosed in 
parentheses.

Last Expression in 
Parentheses

.*{/(.*?/)}.*$ Searches for the last string enclosed in 
parentheses.

1st Expression in 
Brackets

.*?{/[.*?/]} Searches for the first string enclosed in 
brackets.

2nd Expression in 
Brackets

.*?/[.*?{/[.*?/]} Searches for the second string enclosed in 
brackets.

3rd Expression in 
Brackets

.*?/[.*?/[.*?{/[.*?/]} Searches for the third string enclosed in 
brackets.

Last Expression in 
Brackets

.*{/[.*?/]}.*$ Searches for the last string enclosed in 
brackets.
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Podcasts

Podcasting is a method of distributing multimedia files over the Internet, for 
example, for playback on mobile devices and personal computers.

A podcast can be downloaded automatically, using software that is capable of 
reading RSS feeds. RSS (Really Simple Syndication) is a standard for distributing 
news and other information via the Internet. An RSS news feed sends short 
messages on a specific topic from a specific web site. In order to read the 
messages, the user employs a program that has the ability to monitor multiple feeds 
and automatically download new messages on a regular basis. This can be special 
feed readers or an Internet browser, for example.

A podcast is an RSS feed including data content, such as audio or video files. This 
can be a show of which new episodes are released regularly. The file formats .mp4a, 
.mp3, and .ogg are commonly used for podcasts.

Podcast Editor

The Podcast Editor is divided into two panes. The upper pane shows the 
information for the feed or an episode, depending on the item that is selected in the 
list below. This is where you can add files, Internet links, or textual information to the 
podcast feed and its episodes. The lower pane shows an item list of the basic feed 
and all episodes that are included in the podcast.
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Episode Section

In the Episode section, you can create, delete, and move individual podcast 
episodes.

New

Adds a new untitled episode.

Duplicate

Adds a new episode, copying all the information from the existing episode to 
the new one.

Delete

Deletes the selected episode. Alternatively, you can exclude an Episode from 
the podcast by deactivating the Enabled box.

Cut/Copy/Paste

Cuts, copies, and pastes the selected episode.

Move Up/Move Down

Moves the selected episode one position up or down in the list. Alternatively, 
use drag and drop.
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FTP Section

In the FTP section, you can define where your podcast is going to be uploaded via 
FTP.

Update All Items

Uploads/updates the XML podcast file on the FTP server. It also uploads all 
associated media files, but only if they are not yet available on the FTP server. 
This is the most common function to upload and update your podcast.

Update Selected Item

Uploads/updates the XML podcast file on the FTP server. It also uploads the 
media file of the selected item in the list, but only if it is not yet available on the 
FTP server.

Upload/Replace All Items

This is the same as above, but it always uploads/replaces all of the media files 
belonging to the item. This is useful if you have changed the audio data, for 
example.

Upload/Replace Selected Items

This is the same as above, but it always uploads/replaces the media file of the 
selected item in the list. This is useful if you have changed the audio data, for 
example.

FTP Settings

Opens the FTP Settings dialog, which allows you to edit the FTP settings that 
are related to this podcast.

Podcast Section

View Published Podcast

Opens your podcast (via the URL that is specified in your FTP site settings) 
using your default browser.

View XML Source Code

Opens an XML editor to display the source code of the podcast.

Global Options

Edit the automatic picture resizing, set a time offset with Greenwich Mean 
Time, and specify the path of the HTML editor.

Main Tab

On the Main tab, you can assign parameters to your podcast. The available 
parameters change, depending on whether you select a feed or an episode. Field 
labels in bold letters mark fields that are mandatory to fill.

Title

Sets the title of the feed, for example, the topic of your podcast.
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Description

Gives space for a further description of the feed content.

Import HTML File (only available for episodes)

Lets you browse for an HTML document that replaces the description.

Internet Link (URL)

The main link of the feed that the user sees. Use this to direct people to a web 
site that is related to your feed. Clicking the world icon opens the specified 
URL in your default Internet browser.

Audio File (only available for episodes)

This sets the path to the audio file that you want to add to the episode. The 
audio file can be of any file type that is supported by the media reader of your 
browser. An MP3 file provides best compatibility. Click the icon to list the 
audio files that are already open in WaveLab Pro. Select one for your episode.

Alternatively, you can drag the list icon of an audio file into the audio file pane. 
Click the play icon to open the specified file in the default media player or 
viewer of your system, for previewing or checking purposes.

Picture (only available for feeds)

According to the RSS standard, this picture may not be larger than 144 x 400 
pixels, so the picture is automatically resized. Clicking the picture icon  
opens the specified picture in your default image viewer of your system.

Publication Date and Time

Sets the publication date and time of the feed or episode. Clicking the Now 
button transfers current date and time of your system.

As Most Recent Episode (only available for feeds)

If this option is activated, the date and time of the most recent episode are 
automatically matched.

Extra Tab

On the Extra tab, you can assign parameters to your podcast. The available 
parameters change, depending on whether you select a feed or an episode.

The following parameters are available for a feed:

• Webmaster (Email Address)

• Editor (Email Address)

• Copyright

• Category

• Related Domain (URL)

• Language

• Frequency of Updates
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• Skip Hours (0 to 23, Comma Separated)

• Time to Live (Number of Minutes)

The following parameters are available for an episode:

• Author (Email Address)

• Comments (URL)

• Category

• Related Domain (URL)

• Title

• Original Domain (URL)

iTunes Tab

On the iTunes tab, you can activate the iTunes extension that allows you to specify 
additional feed and episode information. The available parameters change, 
depending on whether you select a feed or an episode.

The following parameters are available for a feed:

• Subtitle

• Summary

• Categories

• Keywords (Comma Separated)

• Author

• Owner Name

• Picture

• New URL of Feed

• Hide in iTunes

• Explicit Material

The following parameters are available for an episode:

• Subtitle

• Summary

• Keywords (comma separated)

• Author

• Duration

• Hide in iTunes

• Explicit material
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Global Podcast Options

Some additional options are valid for all Podcast Editor tabs.

• To open the Global Podcast Options dialog, open the Podcast Editor, 
select the Edit tab, and click Global Options.

Automatic Picture Resizing (Not for iTunes)

Defines what to do if specified pictures exceed the maximum size allowed by 
the RSS standard. If pictures need resizing, the original images on your hard 
disk is not modified.

Time Offset with GMT (Greenwich Mean Time)

The displayed dates and times are local. If your system is properly set up, 
WaveLab Pro automatically adjusts the time offset in relation to GMT. 
However, if you want to have time and date relative to a different time zone, 
adjust the value with this option.

HTML Editor

Sets the path to the external HTML editor that is launched when you click the 
pen  button in the Import HTML File section.

Creating a Podcast

There are several ways to create a new podcast feed or episode.

• To create a new podcast, select File > New and click Create Podcast.

• To add a new untitled episode to a podcast, in the Podcast Editor, select the 
Edit tab, and click New.

• To add an audio file to the selected episode, select the Main tab, click in the 
Audio File field, and select Select File Using Standard Selector. Select the 
audio file in the file browser and click Open.

You can also drag an audio file from the File Browser window to the Audio 
File field.

• To duplicate the selected episode, select the Edit tab, and click Duplicate. 
This adds a new episode, and copies all information from the existing episode 
to the new one.
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Setting Up a FTP for Podcast Publishing

To be able to upload a podcast to your FTP server, you must enter the FTP server 
details first.

PROCEDURE

1. In the Podcast Editor, select the Edit tab.

2. In the Podcast section, click FTP Settings.

3. In the FTP Settings dialog, enter the following details:
• The log-in details for your FTP server.

• The relative path and file name of the podcast (extension .xml).

• Your web site address including the path to the feed.

4. Click OK.

Publishing a Podcast

You can upload a podcast from within WaveLab Pro to your FTP server.

PREREQUISITE 

Set up your FTP settings within WaveLab Pro.

PROCEDURE

1. In the Podcast Editor, select the Edit tab.

2. In the FTP section, select one of the following options:
• Update All Items

• Update Selected Item

• Upload/Replace All Items

• Upload/Replace Selected Items

3. In the FTP Settings dialog, check if the FTP settings are correct, and click 
OK.

RESULT 

The podcast is uploaded to your FTP site.

FTP Settings Dialog

In the FTP Settings dialog, you can manage all required information for the podcast 
upload process.
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• To open the FTP Settings dialog, open the Podcast Editor, select the Edit 
tab, and click FTP Settings.

Host

The host name or IP address of the FTP server.

User Name

The login name to your FTP server.

Password

The password to the login.

Use Passive Mode

Keep this activated and only change this if you experience problems with the 
FTP connection.

Feed File Name (with Path)

The podcast file name that is displayed on your FTP server (extension .xml), 
including the relative path. File name and path are part of the final public 
Internet address of the podcast, so you may want to avoid long names.

Associated Web Site (URL)

Your own web site address including the path to the feed.

FTP Settings Example

• Your FTP host address is “ftp.MyPage.com”, your public web site address is 
“www.MyPage.com”.

• The feed file name setting is “podcasts/fantastic-cast.xml”, the associated 
web site setting is “www.MyPage.com/podcasts”.
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• The media files of the podcast will be uploaded to the FTP server at 
“ftp.MyPage.com/podcasts”.

• The podcast file itself and the Internet address to be distributed will be found 
at “www.MyPage.com/podcasts/fantastic-cast.xml”.

Each podcast saves its own complete FTP site information. It is also possible to 
save and recall FTP site presets using the Preset functions at the bottom of the 
dialog.

Checking the Podcast

After creating and publishing a podcast, you can check if the upload was 
successful.

• To visualize the contents of the feed XML file in your default XML editor, open 
the Podcast Editor, select the Edit tab, and click View XML Source Code.

• To open your default Internet browser and receive the podcast that you have 
just published from the Internet, open the Podcast Editor, select the Edit tab, 
and click View Published Podcast.
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Customizing

Customizing means making settings so that the program behaves and looks the way 
that you want it to.

Workspace Layout

Workspace layouts are used for creating various work displays for different 
situations.

You can create a workspace layout that always appears when you launch 
WaveLab Pro. Optionally, the snapshots and the files that you had opened 
automatically reopen.

You can save a workspace layout to recall your favorite layout for a specific editing 
task. Because workspaces can be complex, it is useful to have layouts with a 
reduced number of visible tool windows to perform a given task.

Working with Workspace Layouts

Depending on your computer setup or the kind of project that you are working on, 
you may want to use different window layouts. You can select layout presets or 
create your own layouts.

You can save the placement of the workspace frame and all its tool windows and/or 
the layout of tabbed data windows.

• To select a layout preset, select Workspace > Layout and select a layout 
preset.

• To save the current layout as a preset, select Workspace > Layout > Save 
As. In the Workspace Layout dialog, specify the folder where you want to 
save the preset, enter a name, and click Save.

• To save the current layout as default, select Workspace > Layout > Save 
Current Layout As Default.

• To restore the default layout, select Workspace > Layout > Restore Default 
Layout.

• To organize the layout preset folder, select Workspace > Layout > Organize 
Preset Files.
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The File Explorer/Mac OS Finder opens. You can then create folders and 
subfolders and organize layout presets in them. The folder structure will be 
reflected as submenus on the Layout menu.

Workspace Layout Dialog

This dialog allows you to save the window layout of the active workspace as a 
preset.

• To open the Workspace Layout dialog, select Workspace > Layout > Save 
As.

Path name

Opens the root folder of the preset in the File Explorer/Mac OS Finder. Here, 
you can create subfolders in which presets can be saved.

Presets list

Lists all existing presets.

Name

Lets you specify the name for the preset.

Create Shortcut for Selecting the Preset

If this option is activated and you click Save, the Shortcut Definitions dialog 
opens, which allows you to define a shortcut to apply to this preset.

If a preset already has an assigned shortcut, this option is grayed out. To 
change the existing shortcut, double-click the preset name in the presets list.

Starting WaveLab Pro With a Workspace Layout Preset

You can start WaveLab Pro with a specific workspace layout by entering a preset 
name in the command line.

The format of the command line is “--layout presetName”.
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If the preset is saved inside a folder in the layout preset, you must specify the relative 
path. If the preset name contains spaces, put the name in quotes. For example, 
--layout “My Folder/presetName”.

EXAMPLE

An example of setting up the command line.

1) Set up a workspace layout and save it as Layout 1.

2) Start WaveLab Pro with the command line --layout “Layout 1“.

Customizing the Wave Window and the Montage 
Window

You can set up the wave/montage window by adjusting colors of waveforms, 
background, cursor lines, etc., and changing the look of the ruler and other window 
details.

Customizing can be done in the following ways:

• By changing the default style.

• By assigning different styles, according to specific conditions. For example, a 
specific file type or a specific file name.

Assigning Custom Colors to the Wave Window or the Montage 
Window

PROCEDURE

1. Depending on whether you want to customize the colors of the wave window 
or the montage window, do the following:
• For the wave window, select File > Preferences > Audio Files and select the 

Style tab.

• For the montage window, select File > Preferences > Audio Montages and 
select the Style tab.

2. Select the part that you want to color from the Parts list.

3. Specify a color using the color picker or the RGB fields.

Assigning Custom Colors According to Conditions

You can apply different color schemes automatically to different clips, according to 
their names or the properties of their audio files.
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IMPORTANTIMPORTANTIMPORTANTIMPORTANT

If you redefine colors, be careful not to choose colors that cause other elements to 
disappear.

PROCEDURE

1. Depending on whether you want to customize the colors of the wave window 
or the montage window, do one of the following:
• For the wave window, select File > Preferences > Audio Files and select the 

Style tab.

• For the montage window, select File > Preferences > Audio Montages and 
select the Style tab.

2. Do one of the following:
• In the Audio Files Preferences, select one of the Conditional options from the 

pop-up menu at the top of the dialog.

• In the Audio Montages Preferences, in the Parts list, select one of the 
Custom entries.

3. Specify a color using the color picker or the RGB fields.

4. In the This Style Is Used If These Conditions Apply section, specify the 
conditions.

5. Click OK.

Copying Color Settings

You can copy the color settings of one part, or all parts of a custom color schema.

• To copy a color setting, select the part from which you want to copy the color, 
and select Copy Color. Then select the part to which you want to copy the 
color, and select Paste.

• To copy all color settings of a custom color setting, drag the name of a custom 
color setting onto another custom color name, and click OK.

Customizing Shortcuts

In WaveLab Pro, you can control many functions via shortcuts to speed up your 
workflow. You can edit existing shortcuts, and create new shortcuts.

Most shortcuts are restricted to a specific editor, which means that you can reuse 
the same shortcut combination in different editors. The exception is the Master 
Section where all shortcuts are global to the application.

The shortcuts in the Navigation (Numeric Pad) and View and Navigation sections 
on the Shortcuts tab are dedicated to navigating through WaveLab Pro.
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Shortcuts that cannot be edited are grayed out. The shortcuts that you created are 
displayed in blue in the editor.

You can create new shortcuts in the following ways:

• By specifying a key sequence of up to four keys that must be pressed in a 
specific order to invoke the operation.

• By specifying a MIDI command. You need a MIDI controller device connected 
to your computer for this to work.

• By specifying keywords.

RELATED LINKS

Shortcuts Tab on page 665

Keywords

Keywords are custom words that are assigned to a function in the Customize 
Commands dialog or to a preset in the Shortcut Definitions dialog. When you 
enter the keyword in the File Search and Keyword field, the corresponding 
function is triggered.

EXAMPLE

For example, if you want to have a quick way to normalize audio to -1 dB, proceed 
as follows:

1) In the Audio Editor, select the Process tab.

2) In the Normalizing section, click Level.

3) In the Level Normalizer dialog, set the Peak Level to -1 dB.

4) Click the Presets field, and select Save As.

5) In the Save Preset As dialog, enter a name for the preset, and activate Create 
Shortcut for Applying the Preset.

6) Click Save.

7) In the Shortcut Definitions dialog, enter norm_1 as a Keyword, and click 
OK.

8) Now, to trigger the preset, enter .norm_1 in the File Search and Keyword 
field, and press [Return].
The dot in front of the keyword instructs WaveLab Pro to interpret the text as 
a keyword. Without the dot, the File Search and Keyword field is used for 
finding file tabs.

RELATED LINKS

Shortcuts Tab on page 665
Shortcut Definitions Dialog on page 666
Searching for Open Files on page 76
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Indexed Key Commands

Indexed key commands allow you to quickly jump to specific locations in your 
project, for example, to a specific marker or Master Section slot.

The available indexed key commands are listed on the Shortcuts tab, in the 
Navigation (Numeric Pad) section.

• To trigger an index key command, type the number of the item that you want 
to jump to and press the corresponding key on your keyboard.

EXAMPLE

If you want to jump to the 5th marker in your file window, press [5] on your keyboard 
and then press [M].

If you want to jump to the 10th file tab, press [10] on your keyboard and then press 
[F].

RELATED LINKS

Shortcuts Tab on page 665

Editing Shortcuts

You can see the list of all shortcuts in the Shortcuts tab, and edit and assign 
shortcuts on the Shortcut Definitions dialog.

The Shortcuts tab provides a different command set for each menu or dialog.

• To open the Shortcut Definitions dialog, select File > Preferences > 
Shortcuts, select a command, and click Edit Shortcut.

• You can enter a keyword which you can later use to activate a command by 
typing it into the File Search and Keywords field in the command bar.

• You can assign a command to be triggered by an external MIDI controller. For 
example, this can be useful for issuing transport commands from your midi 
keyboard. You can specify a sequence of up to three midi events. The MIDI 
shortcut is displayed in the MIDI Trigger column.

• You can define one key shortcut, and/or one MIDI shortcut, and/or one 
keyword per command. Each shortcut can be a sequence of up to four 
keystrokes or three MIDI events. A keyword can be of any length.
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• To reset some or all types of shortcuts to their factory default use the Reset 
button.

Defining Key Sequences

You can define key sequences for a keyboard and for a MIDI controller.

PREREQUISITE 

If you want to define a key sequence for a MIDI controller, make sure that your MIDI 
controller is connected to your computer, and selected on the Remote Devices 
tab.

On a Mac, commands for the main menus must consist of a single key command.

When using multiple key stroke commands, make sure that the key commands do 
not interfere with each other. For example, when you have one shortcut [Shift]+L, M 
and define another to be [Shift]+L, this second shortcut has no effect.

PROCEDURE

1. Select File > Preferences > Shortcuts.

2. In the commands list, select the command for which you want to define a key 
sequence, and click Edit Shortcut, or double-click the Key Sequence 
column of the corresponding command.

3. In the Shortcut Definitions dialog, click in the Key Stroke fields and press 
the buttons that you want to use as the key sequence.

4. Click OK.

RESULT 

When you now press the keys/buttons specified in the dialog, the corresponding 
operation is performed. The key strokes must be executed one after the other.

RELATED LINKS

Remote Devices Tab on page 16

Selecting a MIDI Controller for Defining MIDI Commands

Before you can use MIDI commands, you have to select a MIDI controller.

PROCEDURE

1. Select File > Preferences > Remote Devices.

2. On the Device Editing tab, select MIDI Shortcuts for Menus from the 
pop-up menu at the top.

3. Select Active, to activate the selected device.

4. From the In-Port pop-up menu, select a MIDI input port.
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Generating a List of All Shortcuts

You can generate an HTML file or print out a list that contains all shortcuts.

PREREQUISITE 

If you want to print out the list, make sure a printer is connected to your system.

PROCEDURE

1. Select File > Preferences > Shortcuts.

2. Click Summary, and select one of the following options:
• To open the Print Preview dialog, from which you can print out the list of all 

shortcuts, select Print Preview. For Print Preview to be available, a printer 
must be connected.

• To open the list of all shortcuts in the HTML file format in the standard browser, 
select HTML Report.

Shortcuts Tab

This tab allows you to customize your own shortcuts for WaveLab Pro. It shows a 
list of the assigned shortcuts for WaveLab Pro commands and menu options.

• To open the Shortcuts tab, select File > Preferences > Shortcuts.

Search pop-up menu

Allows you to select the part of the commands list in which the search is 
performed.
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Search field

Allows you to search for a command.

Use Wildcards

If this option is activated, the wildcard characters “*” and “?” can be used.

“*” substitutes zero or more characters, and “?” substitutes any character.

For example, if Search Keyboard Shortcut is selected, type “*” to display all 
commands that are already associated with a shortcut.

Expand/Collapse

Expands/Collapses the folder tree.

Commands list

Shows all commands and their shortcuts.

Reset

Resets the commands to the factory settings.

Summary

Opens a menu from which you can generate a list of all commands and their 
shortcuts, either in HTML or as a print out.

Edit Shortcut

Opens the Shortcut Definitions dialog where you can edit the shortcuts for 
the selected command.

Shortcut Definitions Dialog

This dialog allows you to define your own customized shortcuts for a particular 
function.

• To open the Shortcut Definitions dialog, select File > Preferences > 
Shortcuts, select a command, and click Edit Shortcut.
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Key Sequence

1st Key Stroke

Lets you select the first key of a sequence that can consist of up to four keys. 
Set the focus to the key stroke field, then press the key combination. If nothing 
is displayed, a key is not allowed in this context.

2nd/3rd/4th Key Stroke (optional)

Lets you select additional keys that must be used to execute the command. 
The command is only executed if this key event happens after the first one.

Clear

Erases all key event fields.

Keyword

Lets you type in a keyword that invokes the command.

MIDI Event Sequence

This section is only available if a MIDI input port is specified in the main preferences 
in WaveLab Pro.

1st Event

Lets you select the first MIDI event of a sequence that can consist of up to 
four MIDI events. Set the focus to the event field, then trigger the MIDI event 
from your MIDI controller.
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2nd/3rd Event (optional)

Lets you select additional MIDI events that must be triggered to execute the 
command. The command is only executed if this MIDI event happens after the 
first one.

Clear

Erases all MIDI event fields.

Customizing Command Bars

You can hide or show individual command bar buttons. This way you can customize 
command bars by removing unwanted commands.

PROCEDURE

1. In a tool window, open the menu and select Customize Command Bar.

2. To show a specific command on the command bar, activate the checkbox in 
the Bar column for the corresponding command.

3. Click OK.

Plug-in Organization

WaveLab Pro comes with various plug-ins, and additional plug-ins can be added. 
To retain an overview over the plug-ins that are relevant to your project, you can 
organize your plug-ins in groups.

On the Organize tab of the Plug-ins Preferences, you can specify how your 
plug-ins appear on menus in the program. In the plug-ins list, you find subfolders 
representing groups of plug-ins.

Initially, plug-ins are categorized by vendor, category, favorite plug-ins, and recently 
used plug-ins.

If the 32-bit and 64-bit versions of WaveLab Pro are used on the same system, their 
settings are shared. An exception to this rule are the following options in the 
Plug-ins Preferences:

• Additional VST Plug-in Folders

• Ignore Plug-ins Located in the following Subfolders

This is because 32-bit plug-ins cannot be used in WaveLab Pro 64 bit and vice 
versa.

RELATED LINKS

Plug-ins Preferences on page 672
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Deactivating Plug-ins

 
 

PROCEDURE

1. Select File > Preferences > Plug-ins.

2. Select the Organize tab.

3. In the plug-ins list, navigate to the plug-in that you want to deactivate.

4. Deactivate the checkbox in for the plug-in. When selecting multiple plug-ins,
you can deactivate all of them with a single click.
• To deactivate the plug-in on the plug-in selection menus, deactivate the

checkbox in the Effect column.

• To deactivate the plug-in on the Final Effects/Dithering panel of the Master
Section, deactivate the checkbox in the Final column.

• To deactivate the plug-in on the Playback-Processing panel of the Master
Section, deactivate the checkbox in the Play column.

• To deactivate a clip plug-in when a clip is not streamed, deactivate the
checkbox in the Dyn column.

This allows you to save DSP power when using hardware plug-ins.

Adding Plug-ins to the Favorites Menu

You can add plug-ins that you are using regularly to the Favorites menu of the 
plug-in selection menu.

PROCEDURE

1. Select File > Preferences > Plug-ins.

2. Select the Organize tab.

3. In the plug-ins list, navigate to the plug-in that you want to add to the favorites.

4. Activate the checkbox for the corresponding plug-in in the Favorites
column.

NOTE

If the Favorites menu is empty, it does not appear in plug-in selection menus.
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Customizing Plug-in Groups

You can customize the appearance and sorting of plug-ins on the Organize tab of 
the Plug-ins Preferences.

• To update the tree, click the Show Changes button.

• To create a custom category for a plug-in, click the Custom Category column 
for the corresponding plug-in, and enter a new category name. 
[Alt]/[Option]-click to delete the category. Use the character “|” to create 
subcategories, for example, “Folder-1|Folder-2”. If you select multiple 
plug-ins, the category name is applied to all selected plug-ins.

• To rename a custom category, click the category name in the Custom 
Category column, and select Rename Category from the pop-up menu. In 
the Rename Category dialog, enter the name of the category that you want 
to rename in the Find field, and the name that you want to replace it with in 
the Replace with field. Then click Replace All.

• The category labels that are used to create the hierarchy are supplied by the 
plug-in manufacturers. To change the category name, navigate to the 
Category Renaming table, click in the Original column, and select the 
category that you want to rename. Then click in the Modified column, and 
enter a new name.

• To change the sorting of plug-in groups, select whether to sort by category 
or by vendor in the sorting menu of the Customize section. If a plug-in does 
not publish a vendor name or category, the name of the enclosing plug-in 
folder on disc is used as vendor name or category if it is not the VST plug-in 
root folder.

• To group all plug-ins that start with the same prefix in one submenu, activate 
Create Submenus Based on Prefixes, and specify the number of plug-ins 
that must start with the same prefix. Only if this number is reached, a submenu 
is created.

• To group plug-ins in a single submenu if their number is below a specified 
value, activate Compress Hierarchy, and specify the threshold. A tree is 
flattened to a single submenu if the number is below the threshold. This 
prevents too small submenus.

• To activate the Recently Used category, activate Submenu with Recently 
Used Plug-ins, and specify the maximum number of recently used plug-ins 
that should be displayed in this category.

• You can make the Recently Used category global to all places or individual 
for each context, for example, for the Master Section, audio montage track, 
or audio montage clip. To make the Recently Used category individual for 
each context, activate Independent Recently Used Plug-ins Menus.
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Adding Additional VST Plug-ins

You can specify folders where additional VST plug-ins can be found. This is useful 
if you are using third-party VST plug-ins that you do not want to save in the standard 
VST folder.

PROCEDURE

1. Select File > Preferences > Plug-ins.

2. Select the General tab.

3. In the Additional VST Plug-in Folder (WaveLab Specific) section, click the 
folder icon, and navigate to the folder that contains the VST plug-ins that you 
want to add.

Excluding Plug-ins

You can specify a list of plug-ins that WaveLab Pro does not open.

PROCEDURE

1. Select File > Preferences > Plug-ins.

2. Select the General tab.

3. In the Do Not Load the Following Plug-ins section, type in the name of the 
plug-in that you do not want to open:
• Enter the exact file name, without path and without file extension.

• Enter one name per line.

• If you put “*” in front of the name, any plug-in that contains the name is ignored.
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Replacing Missing Plug-ins

When you open an audio montage and some plug-ins for tracks or clips are missing, 
you can select plug-ins to replace the missing plug-ins.

PROCEDURE

1. In the Missing Plug-ins dialog, click the Replacement column, and select a 
replacement for the plug-in displayed in the Original column.

2. If you want to use the new plug-in from now on, activate Save Replacements 
as Default.

3. Click OK.

Plug-ins Preferences

On this tab, you can access a number of options for managing your VST plug-ins.

You can specify where WaveLab Pro should search for your VST plug-ins and 
which ones it should ignore. It also allows you to choose how your VST plug-in 
controls respond to mouse actions and how frequently graphics are updated.

If you use your own file structure to organize and save VST plug-ins, this dialog 
allows you to gain full control over which plug-ins are loaded and which are ignored. 
This is useful if you want to deactivate a particular plug-in or if you want to ignore 
plug-ins that you never want to use with WaveLab Pro.

• To open the plug-in preferences, select File > Preferences > Plug-ins.
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General Tab

Search Standard VST Plug-in Shared Folders

If this option is activated, WaveLab Pro searches for VST plug-ins in the 
default VST plug-in folders.

Information About the Searched Folders 

Click on the info icon to see in which folders WaveLab Pro searched for 
plug-ins when it was launched. If you cannot find a plug-in in WaveLab Pro, 
this helps you to determine whether you have specified the correct folder, for 
example.

Additional VST Plug-in Folders (WaveLab Pro Specific)

Lets you specify additional folders where VST plug-ins can be found.

Ignore Plug-ins Located in the following Subfolders (Separate Folder Names 
with a Semicolon)

Lets you specify folder names that WaveLab Pro skips when searching for 
VST plug-ins.
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Do Not Load the following Plug-ins

Lets you specify plug-ins that WaveLab Pro does not open. Enter the file 
names, without path and without file extension. Write each plug-in on a new 
line.

If you put the character * in front of the name, any plug-in that contains the 
name is ignored.

Force Plug-in Detection at Next Launch

Analyzes the plug-ins when launching WaveLab Pro the next time. To reduce 
the start time of WaveLab Pro, the plug-ins are not analyzed every time 
WaveLab Pro is started. However, WaveLab Pro keeps a list of plug-ins and 
updates this automatically when a date or size change is detected.

Keep Plug-ins in Memory until WaveLab Pro Quits

If this option is activated, the plug-ins are kept in memory even when they are 
no longer used. This results in a faster reopening of plug-ins. However, if you 
use many plug-ins, too much memory could be used after a specific time, 
which slows down the application.

Faster Graphics Refreshing (Consumes More Computer Power)

Refreshes the graphics of VST plug-ins more quickly.

VST Plug-in Knobs

Lets you set the mode for using knobs in plug-ins. You can set the mode to 
Circular, Circular Mode (Relative Movement), and Linear.

Organize Tab
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Plug-ins list

Displays the hierarchy of the plug-ins in WaveLab Pro. Here, you can specify 
whether a plug-in is available on the plug-in selection menus and/or the Final 
Effects/Dithering panel and Playback-Processing panel of the Master 
Section.

You can add plug-ins to the Favorites list, create shortcuts for plug-ins, 
specify custom categories, and decide whether to use the generic user 
interface or the plug-in specific user interface.

Expand/Collapse

Expands/collapses the folder tree.

Search field

Allows you to filter the plug-ins list for names.

• Click in the search field, and enter the text that you want to search for.

• To switch the focus from the search field to the plug-ins list, press 
[Down Arrow].

• To switch the focus from the plug-ins list to the search field, press 
[Ctrl]/[Command]-[F].

Only Show New Plug-ins

If this option is activated, only the recently detected plug-ins are displayed.

Remove “New” Status

Resets the “new” status of the recently detected plug-ins.

Show Changes

Refreshes the plug-in tree according to the current settings.

Sorting

Determines how the plug-ins are sorted. The other parameters act on that 
hierarchy.

Compress Hierarchy

Merges all items into a single submenu if a submenu and all its submenus 
contain less than a specific number of plug-ins (Threshold).

The Threshold value determines the minimum number of items that are 
needed to compress the hierarchy.

Create Submenus Based on Prefixes

Creates a submenu that is labeled as the prefix if several items in a submenu 
start with the same prefix.

The Threshold value determines the minimum number of items that must start 
with the same prefix that are needed to create submenus that are labeled as 
the prefix.

Merge Single Submenus

Merges submenus that contain another submenu with only a single item in it.
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Category Renaming

The category labels used to create the hierarchy are supplied by the plug-in 
manufacturers. In this section, you can change the category name. This can 
also be useful to merge two categories into one, by renaming these two 
categories with the same name.

Submenu with Recently Used Plug-ins

If this option is activated, the Recently Used submenu is shown.

The Maximum Size value determines the maximum number of plug-ins on the 
Recently Used submenu.

The Independent Recently Used Plug-ins Menu option determines whether 
the Recently Used submenu is global to all places where plug-ins can be 
selected, or if it is local to each context.

Ignored Plug-ins

Opens the Ignored Plug-ins dialog, where you can plug-ins which were not 
loaded. This dialog lets you instruct WaveLab Pro to rescan these plug-ins at 
the next launch. This is faster than a full rescan.

Number of Plug-ins

Shows the number of plug-ins that are available in WaveLab Pro.

Variables and Text Snippets

You can define and use custom variables and text snippets, or use auto variables in 
various places in WaveLab Pro, for example, in the Meta-Data dialog.

Custom variables can be used to replace codes with a specified text in meta-data 
saved within audio files. For example, you can define the variable %proj% to be 
replaced by the name of the current project. A custom variable can also contain 
references to other variables. For example, %comment% can be defined as 
“%proj% started on @Date1@”.

Variable codes are replaced with the variable values when the file is written. For 
example, when the meta-data is saved inside an audio file.

Auto variables are automatically set by WaveLab Pro. For example, the current date, 
the sample rate, or the bit resolution.

Text snippets can be used to define words that you are using regularly when filling 
in text fields. These can be inserted into a text field via the Text Snippets menu.
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Some auto-variables depend on the context. For example:

• CD Text variables are only used when rendering an audio montage.

• Auto-variables that relate to CD tracks are only used when rendering CD 
tracks from an audio montage. To render CD tracks, activate one of the 
following options in the Render dialog: Selected CD Track, One Region 
(CD Track markers), or Regions (track markers).

If a variable is used in a wrong context, it is replaced with a blank.

Defining Variables and Text Snippets

You can create new variables and text snippets, and define values for them.

PROCEDURE

1. Select File > Preferences > Variables.

2. Do one of the following:
• On the Custom Variables tab, click the plus icon to add a new variable, or 

double-click an existing variable that you want to modify.

• On the Text Snippets tab, click the plus icon to add a new definition, or 
double-click an existing definition that you want to modify.

3. For custom variables, enter the name, code, and value for the variable. For text 
snippets, enter the text.

NOTE

Variable codes are case sensitive. It is recommended to select the codes from the 
menus.
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Applying Variables and Text Snippets

You can apply custom variables, auto variables, and text snippets at various places 
in WaveLab Pro.

PREREQUISITE 

Define custom variables and text snippets.

PROCEDURE

1. In a value field, click the arrow icon. If several fields are selected, right-click to 
access the pop-up menu.

2. From the menu, select a custom variable, an auto variable, or a text snippet.

The variable or text snippet is added to the value field.

Variables and Text Snippets Dialog

This dialog allows you to define custom variables, see the auto variables, and define 
text snippets that are local to the project that you are working on.

• To open the Variables and Text Snippets dialog, select File > Preferences 
> Variables.
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Plus icon

Adds a new custom variable/text snippet.

Minus icon

Removes the selected custom variable/text snippet.

Scripting

WaveLab Pro contains a powerful scripting language to help advanced users 
create their own scripts to automate tasks. Using basic scripts can be useful for 
automating repetitive editing tasks such as trimming and cropping a file at specific 
times, for example.

You can write scripts that perform other basic editing commands, apply offline 
processing, place markers, and display information about the active file. You can 
script commands to edit the active audio file or the active audio montage. If you have 
some experience of programming with modern scripting languages you should have 
no problem writing utility scripts for WaveLab Pro.

The WaveLab Pro scripting language is based on ECMAScript, with the addition of 
WaveLab Pro specific commands. If you are familiar with Javascript, JScript, or 
Actionscript the code syntax will be familiar to you as they are all based on 
ECMAScript, too.

To begin exploring the WaveLab Pro specific functions that are available, see the 
WaveLab Pro scripting language chapter. For a broader look at the complete 
subset of commands that are available, see ECMAScript Reference.

On Windows, there is an additional scripting interface to control WaveLab Pro from 
external applications using VBScript or JScript. The documentation of this interface 
can be found in the folder following folder:

WaveLab 9\Tools\Windows Scripting\

This chapter is about scripts that are executed from within WaveLab Pro.
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Writing and Executing a Script

PROCEDURE

1. Select File > New.

2. Click Create Script.

3. In the Script Editor, type your script or copy and paste it from an external text 
editor.

4. To run the script, select the Edit tab, and click Execute Script.

NOTE

Only one script can be executed at a time.

RESULT 

The script runs if there are no syntax errors. Any errors appear in a dialog box to help 
you debug them.

NOTE

There are several free utility text editors that are context sensitive. This means that 
they can color and highlight parts of your code to make it more readable. If you use 
one of these for writing and editing your scripts, choose Javascript as the editing 
language and/or save the file with a .js (Javascript) extension.

Script Editor

The Script Editor allows you to write and execute scripts in WaveLab Pro.

• To open a new script file, select File > New and click Script.

• To open a saved script file, select File > Open and click Script. Select the 
script file and click Open.
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Execute Script

Executes the script.

Using the Log Window When Scripting

It is a good idea to begin scripting by writing some simple scripts that output some 
text to the Log window.

The goal of the following example is to output a simple text message to the Log 
window.

PROCEDURE

1. Select Tool Windows > Log.

2. Copy and paste the following script into the Script Editor.
//output the number of samples in the active wave as text in the log window.

logWindow.printInfo("This file has " + activeWave.size() + " samples");

NOTE

Any lines of a script that begin with two forward slashes // are comments, and are 
ignored when the script is executed.

3. Execute the script.

RESULT 

In the Log window, the number of samples used in the active file is displayed.
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WaveLab Pro Scripting Language

The scripting language of WaveLab Pro varies slightly between editors. This 
chapter briefly introduces the commands that are available in each editor and those 
that are global.

Global Commands

These commands are available in all scripting contexts.

logWindow

Object representing the Log window, where you can output messages to. If 
the Log window is not open, all functions are ignored.

printInfo(messageString)

Outputs an informal message to the Log window. The message argument 
must be typed as a string. For example, between inverted commas:

logWindow.printInfo("start");

printWarning(messageString)

Outputs a warning message to the Log window.

printError(messageString)

Outputs an error message to the Log window.

clear()

Clears the Log window. For example:

logWindow.clear();

Audio Editor

activeWave

Object representing the active audio file. Many functions make use of presets 
as an argument. For example, the normalize() function accepts a preset as 
an argument:

activeWave.normalize("myPreset");

The advantage is that you do not need to specify many parameters in your 
scripts, instead you can use the corresponding dialog to define the settings 
of a particular function, and then save them as a preset file. Because each 
type of preset is unique, you do not need to specify a full path name to the 
preset. Only specifying the preset name is enough, there is no need for its file 
extension. Because presets can also be saved in a subfolder, you can use a 
relative path name if necessary.

For example, if you want to normalize a file using a preset that you have 
defined in the Level Normalizer dialog and saved in a subfolder as a preset, 
the script looks like this:

activeWave.normalize("mySubFolder/myPreset");
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All audio processing functions operate on the selected audio range. If there is 
no selection, the whole file range is processed if this option is activated in the 
Audio Files Preferences. If the cursor or selection is in one channel only, only 
that channel is processed. In other words, it operates exactly the same as if 
you were applying a process from within a dialog.

If the preset is a factory preset, you must specify this using the prefix 
%factory%/. For example:

activeWave.normalize("%factory%/EBU R-128 
Recommendation")

All positions and sizes are measured in sample units. If you want to specify a 
time range in another unit you need to convert it from samples:

var twoSeconds = 2 * activeWave.sampleRate();

size()

Returns the number of samples in the audio file.

sampleRate()

Returns the sample rate of the audio file.

numChannels()

Outputs the number of channels of the audio file.

cursorPosition()

Outputs the current cursor position in samples.

setCursorPosition(pos)

Sets the cursor position to a specific sample location.

selectionStart()

Outputs the index of the first selected sample, or -1 if there is no selection.

selectionSize()

Outputs the number of selected samples.

select(presetName)

Loads the audio range preset and applies its setting to the active audio file.

select(start, size)

Selects a number of samples, starting from a specific position.

setCursorChannel(channel)

Sets the cursor position to a new channel. Use leftCh, rightCh, or allCh 
as arguments.

addMarker(type, name, comment)

Adds a marker at the cursor position. Possible values for type are:

• generic

• temporary
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• cdTrackStart

• cdTrackEnd

• cdTrackFrontier

• cdTrackIndex

• loopStart

• loopEnd

• muteStart

• muteEnd

• playbackStarter

• regionStart

• regionEnd

• errorStart

• errorEnd

• correctionStart

• correctionEnd

For example:

activeWave.addMarker(generic, "SomeName", 
"SomeComment");

findNextMarkerPosition(posStartSearch, type)

Searches for the next marker of the specified type, from a set position. 
Returns the marker position if any is found, or -1.

normalize(presetName)

Loads the normalize preset and applies its settings to an audio range.

normalizeLoudness(presetName)

Loads the loudness normalizer preset and applies its settings to an audio 
range.

normalizePan(presetName)

Loads the pan normalizer preset and applies its settings to an audio range.

silence(presetName)

Loads the silence preset and applies its settings to an audio range.

timeStretch(presetName)

Loads the time stretch preset and applies its settings to an audio range.

pitchCorrection(presetName)

Loads the pitch correction preset and applies its settings to an audio range.
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pitchQuantize(presetName)

Loads the pitch quantize preset and applies its settings to an audio range.

changeLevel(dbValue)

Changes the level of the selected audio range.

fadeIn(shape) and fadeOut(shape)

Applies a fade to the selected audio range. The shape can be one of the 
following:

• linear

• sinus

• squareRoot

• sinusoid

• log

• exp

• expp

For example:

activeWave.fadeIn(squareRoot);

levelEnvelope(presetName)

Loads the envelope shape and applies its settings to an audio range.

morph(presetName)

Loads an effect morphing preset and applies its settings to an audio range.

invertPhase()

Inverts the phase of the samples in the audio range.

reverse()

Reverses the order of the samples in the audio range.

cut()

Cuts the selected audio range.

copy()

Copies the selected audio range.

paste()

Pastes audio from the clipboard to the current cursor position.

trim()

Trims the selected audio range.

remove()

Deletes the selected audio range.
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removeSmooth()

Deletes the selected audio range and crossfades the resulting regions.

mute()

Mutes the selected audio range.

swapChannels()

Swaps stereo channels.

undo()

Undoes the last command.

removeDcOffset()

Removes the DC offset in an audio range.

readSamples(channelIndex, from, numSamples)

Reads a number of samples from a specific cursor position, on a set channel:

• Use 0 for the left channel

• Use 1 for the right channel

This returns the result in an array. For example:

buf = activeWave.readSamples(0, 20, 100); // read 100 
samples on left channel, from sample index 20

for (i = 0; i < 100; i++)

{

logWindow.printInfo(buf[i]);

}

Audio Montage Window

size()

Outputs the number of samples in the audio montage.

sampleRate()

Outputs the sample rate of the audio montage.

numChannels()

Outputs the number of output channels of the audio montage.

numTracks()

Outputs the number of tracks of the audio montage.

cursorPosition()

Outputs the current cursor position (in samples).

setCursorPosition(pos)

Sets the cursor position to a specific sample location.
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selectionStart()

Outputs the index of the first selected sample, or -1 if there is no selection.

selectionSize()

Outputs the number of selected samples.

select(presetName)

Loads the audio range preset and applies its settings to the active audio 
montage.

select(start, size)

Selects a number of samples, starting from a specific position.

setSelectedTrack(index)

Sets the selected track.

addMarker(type, name, comment)

Add a marker at the cursor position. Possible values for type are:

• generic

• temporary

• cdTrackStart

• cdTrackEnd

• cdTrackFrontier

• cdTrackIndex

• loopStart

• loopEnd

• muteStart

• muteEnd

• playbackStarter

• regionStart

• regionEnd

• errorStart

• errorEnd

• correctionStart

• correctionEnd

For example:

activeWave.addMarker(generic, "SomeName", 
"SomeComment");
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findNextMarkerPosition(posStartSearch, type)

Searches for the next marker of the specified type, from a set position. 
Returns the marker position if any is found, or -1.

insertMonoTrack(where)

Adds a mono audio track at index 'where'.

insertStereoTrack(where)

Adds a stereo audio track at index 'where'.

insertClip(iTrack, timePosition, fileName, autoShift)

Creates a clip from 'fileName', inserts it in track 'iTrack', on the timeline at the 
position 'timePosition', and shifts other clips to make room, according to the 
following autoShift parameters:

• autoShiftNo

• autoShiftTrack

• autoShiftGlobal

This function returns the ID of first created clip, or 0.

clipWithName(name)

Outputs the ID of the first clip with name 'name', or 0.

clipWithFile(name)

Outputs the ID of the first clip that refers to 'fileName', or 0.

firstClip()

Outputs the first audio montage clip ID, or 0 if the audio montage is empty.

nextClip(clipId)

Outputs the ID of the clip saved after 'clipId', or 0. Clips are not sorted in any 
special order. Using both firstClip and nextClip allows to access all audio 
montage clips.

clipName(clipId)

Outputs the name of the clip identified by 'clipId'.

clipPosition(clipId)

Outputs the timeline position of the clip identified by 'clipId'.

clipSize(clipId)

Outputs the size of the clip identified by 'clipId'.

setClipName(clipId, name)

Rename the clip identified by 'clipId'.

setTrackName(index, name)

Rename the track identified by 'index'.
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moveClip(clipId, newPos)

Move the clip identified by 'clipId' on the timeline.

resizeClip(clipId, qlonglong newSize)

Resize the clip identified by 'clipId'. The size is limited by the audio file that is 
referenced by the clip.

setClipDefaultFadeIn(clipId)

Sets the default fade in shape and time for the clip identified by 'clipId'.

setClipDefaultFadeOut(clipId)

Sets the default fade out shape and time for the clip identified by 'clipId'.

undo()

Undoes the last command.

ECMAScript Reference

The scripting language of WaveLab Pro is based on the ECMAScript scripting 
language, as defined in standard ECMA-262. Microsoft's JScript, Netscape's 
JavaScript, and Adobe's Actionscript are also based on the ECMAScript standard.

If you are not familiar with the ECMAScript language, there is a large amount of 
teaching and reference material available online.

This reference page contains a list of all ECMAScript objects, functions and 
properties that are supported by the WaveLab Pro scripting system. These are 
available in any scripting context but are not WaveLab Pro specific.

Some basic scripting examples are included below, so that you can see the 
scripting syntax in context. These scripts will work if you copy, paste, and execute 
them in a script window.

Supported ECMAScript Subset

Global Objects

Values

• NaN

• Infinity

• undefined

• Math
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Functions

• eval(x)

• parseInt(string, radix)

• parseFloat(string)

• isNaN(number)

• isFinite(number)

• decodeURI(encodedURI)

• decodeURIComponent(encodedURIComponent)

• encodeURI(uri)

• encodeURIComponent(uriComponent)

Objects

• Object

• Function

• Array

• String

• Boolean

• Number

• Date

• RegExp

• Error

Examples

//Test if a value is not a number

var isNumber = isNaN("this is a string");

//Print the result in the log window

logWindow.printInfo(isNumber); //Traces "true" because it is a String

//Convert a string to a number

var numStr = "2.345";

var num = parseFloat(numStr);

//Print the result in the log window

logWindow.printInfo(num);

//Encode a string into an Internet valid ASCII String
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var str = "a sentence with spaces";

var encodedStr = encodeURI(str);

logWindow.printInfo(encodedStr);

Function Objects

Prototypes

• toString()

• toLocaleString()

• valueOf()

• hasOwnProperty(V)

• isPrototypeOf(V)

• propertyIsEnumerable(V)

Functions

• toString()

• apply(thisArg, argArray)

• call(thisArg [, arg1 [, arg2, ...]])

Examples

//Create a new custom marker Object

function customMarker(name, comment, timeSecs)

{

this.name=name;

this.comment=comment;

this.timeSecs=timeSecs;

}

//Create a new instance of the custom marker

var myMarker=new customMarker("A custom marker", "My custom marker 
comments",5);

//Use prototype function to add a new property to it

customMarker.prototype.samples = null;

myMarker.samples = activeWave.sampleRate() * myMarker.timeSecs;

//Trace the results in the log window
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logWindow.printInfo(myMarker.name);

logWindow.printInfo(myMarker.samples);

Array Objects

Functions

• toString()

• toLocaleString()

• concat([item1 [, item2 [, ...]]])

• join(separator)

• pop()

• push([item1 [, item2 [, ...]]])

• reverse()

• shift()

• slice(start, end)

• sort(comparefn)

• splice(start, deleteCount[, item1 [, item2 [, ...]]])

• unshift([item1 [, item2 [, ...]]])

Examples

//Create an empty array

var a = new Array();

//Add some items to it

a.push("first array item");

a.push("next array item", "last array item");

//Print them out in the Log window

logWindow.printInfo(a.toString());

//Call the Array's reverse function

a.reverse();

//View the results in the Log window

logWindow.printInfo(a.toString());
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String Objects

Functions

• toString()

• valueOf()

• charAt(pos)

• charCodeAt(pos)

• concat([string1 [, string2 [, ...]]])

• indexOf(searchString ,position)

• lastIndexOf(searchString, position)

• localeCompare(that)

• match(regexp)

• replace(searchValue, replaceValue)

• search(regexp)

• slice(start, end)

• split(separator, limit)

• substring(start, end)

• toLowerCase()

• toLocaleLowerCase()

• toUpperCase()

• toLocaleUpperCase()

Examples

//Create a string variable

var str = new String("WaveLab is a powerful editing tool");

//Make it all upper case

var capsStr = str.toUpperCase();

//View the results in the Log window

logWindow.printInfo(capsStr);
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Boolean Objects

Functions

• toString()

• valueOf()

For example

//Test if an equation is true or false

var isTrue = (1 + 1 == 3);

//Convert the Boolean to a String and trace in the Log window

logWindow.printInfo(isTrue.toString());

Number Objects

Functions

• toString(radix)

• toLocaleString()

• toFixed(fractionDigits)

• toExponential(fractionDigits)

• toPrecision(precision)

Examples

//Convert a number into exponential notation

var num = new Number(13.3714);

//Show the result in the Log window

logWindow.printInfo(num.toExponential());

Math Objects

Values

• E

• LN10

• LN2

• LOG2E
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• LOG10E

• PI

• SQRT1_2

• SQRT2

Functions

• abs(x)

• acos(x)

• asin(x)

• atan(x)

• atan2(y, x)

• ceil(x)

• cos(x)

• exp(x)

• floor(x)

• log(x)

• max([value1 [, value2 [, ...]]])

• min([value1 [, value2 [, ...]]])

• pow(x, y)

• random()

• round(x)

• sin(x)

• sqrt(x)

• tan(x)

Examples

//Get a random number from 0 to 1

var r = Math.random();

//Print it out in the log window

logWindow.printInfo(r);

//Trace out Pi in the log window

logWindow.printInfo(Math.PI);
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Date Objects

Functions

• toString()

• toDateString()

• toTimeString()

• toLocaleString()

• toLocaleDateString()

• toLocaleTimeString()

• valueOf()

• getTime()

• getFullYear()

• getUTCFullYear()

• getMonth()

• getUTCMonth()

• getDate()

• getUTCDate()

• getDay()

• getUTCDay()

• getHours()

• getUTCHours()

• getMinutes()

• getUTCMinutes()

• getSeconds()

• getUTCSeconds()

• getMilliseconds()

• getUTCMilliseconds()

• getTimeZoneOffset()

• setTime(time)

• setMilliseconds(ms)

• setUTCMilliseconds(ms)

• setSeconds(sec [, ms])

• setUTCSeconds(sec [, ms])
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• setMinutes(min [, sec [, ms]])

• setUTCMinutes(min [, sec [, ms]])

• setHours(hour [, min [, sec [, ms]]])

• setUTCHours(hour [, min [, sec [, ms]]])

• setDate(date)

• setUTCDate(date)

• setMonth(month [, date])

• setUTCMonth(month [, date])

• setFullYear(year [, month [, date]])

• setUTCFullYear(year [, month [, date]])

• toUTCString()

Examples

//Create a new date object

var d = new Date();

//Print it out in the log window

logWindow.printInfo(d);

//Get just the hours

logWindow.printInfo(d.getHours());

RegExp Objects

Functions

• exec(string)

• test(string)

• toString()

Examples

//Create a new regular expression defining a 5 digit number

var reg = new RegExp(/^\d{5}$/);

//Test a string with it to see if it contains a 5 digit number

var isFiveDigit = reg.test("12345");

//Trace the result to the log window

logWindow.printInfo(isFiveDigit);
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Errors Objects

Values

• name

• message

Functions

• toString()

Types of native errors available

• EvalError

• RangeError

• ReferenceError

• SyntaxError

• TypeError

• URIError

Basic Scripting Example

Below is a basic scripting example which uses some WaveLab Pro scripting 
functions to perform some simple operations on an audio file in the Audio Editor.

The script first displays information about the audio file, fades in the start and fades 
out the end of the file, and then adds ten markers at 1 second intervals. Examine it 
line by line and read the comments for each operation to see how it works.

/* To run this script:

- open an audio file that is at least 10 seconds long

- open the Log window

- copy and paste this script into the Script Editor

- in the Script Editor, on the Edit tab, click Execute Script */

//clear the log window

logWindow.clear();

//show some information about the active wave file in the log window

logWindow.printInfo("This wave file has " + activeWave.size() + " samples");

logWindow.printInfo("Its sample rate is " + activeWave.sampleRate());

logWindow.printInfo("It has " +activeWave.numChannels() + " channels");
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//Work out how long the file is in seconds and round to a whole number

var lengthSecs = activeWave.size() / activeWave.sampleRate();

logWindow.printInfo("This wave file is " + lengthSecs + " seconds long");

//Select the first 10 seconds of the file

activeWave.select(0, 10 * activeWave.sampleRate());

//Trim the file to 10 seconds

activeWave.trim();

//select the first two seconds of the file and fade it in

activeWave.select(0, 2 * activeWave.sampleRate()); //sample rate multiplied 
by two = 2 seconds

activeWave.fadeIn(linear);

//select the last two seconds of the file and fade it out

activeWave.select(activeWave.size() - (2 * activeWave.sampleRate()), 
activeWave.size());

activeWave.fadeOut(linear);

//loop through 10 times and add a marker each second

for (i = 1; i <= 10; i++)

{

//work out next cursor time

var nextCursorPosition = i * activeWave.sampleRate();

//set cursor position forwards by a second

activeWave.setCursorPosition(nextCursorPosition);

//add a generic marker at the next cursor position and give it a name and comment

activeWave.addMarker(generic, "Marker "+i, "A comment for marker "+i);

//write some information about the new marker

var cursorTimeSecs = nextCursorPosition/activeWave.sampleRate();

logWindow.printInfo("created a new marker at " + cursorTimeSecs + " 
seconds");

}
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Configuring the Software

You can configure WaveLab Pro according to your needs.

NOTE

The settings that you make in the preferences are applied when you switch to 
another WaveLab Pro window.

Global Preferences

Global preferences are preferences that apply throughout WaveLab Pro. Before 
you start working with WaveLab Pro, it is recommended to edit these preferences 
to configure WaveLab Pro according to your needs.

• To open the global preferences, select File > Preferences > Global.

General Tab

This tab allows you to change the location of settings files and the user interface 
language. You must restart the application for changes to take effect.

General

Language

Allows you to select the user interface language.

Setting Location

Common for All Users

Shares the preferences settings with all users on this computer.

Independent for Each User

Lets each user on this computer make their own preferences settings.

Application Folder (Portable Installation)

Saves settings in the application directory. Use this option to install the 
application on a portable device.



Configuring the Software
Global Preferences

701

Specific Folder

Allows you to save the settings in a specified folder.

Open Setting Folder

Opens the folder that is used to save settings. This way you know where the 
settings are saved and you can back up the settings.

Synchronization Settings

Master Folder

Lets you specify where the preference settings are saved.

Synchronize at Every Launch

If this option is activated, the settings are synchronized whenever 
WaveLab Pro is launched.

Synchronize at Next Launch

If this option is activated, the settings are synchronized the next time that 
WaveLab Pro is launched.

Preferences Handling

Determines how to synchronize the preferences, that is, all settings except the 
presets. You can either ignore or mirror the preferences.

Preset Handling

Determines how to synchronize the presets that are saved in the master 
folder. The following options are available:

• If Ignore Presets is activated, the presets are not synchronized.

• If Mirror Presets is activated, the presets are restored from the master 
folder, regardless of their time stamp. Any additional local presets are 
deleted.

• If Import New Presets is activated, the presets in the master folder that 
are unavailable on the computer are imported.

• If Update Old Presets is activated, existing presets are overwritten if a 
newer version is found in the master folder.

Ignore the following Preset Folders (Separate Them with a Semicolon)

Lets you specify which preset folders you want to ignore when synchronizing 
the settings. For example, to ignore the VST Audio Connections settings, add 
"VST Audio Connections" to the field.

Update Master

If you click this button, the settings that were used when launching 
WaveLab Pro are used to update the master folder.

NOTE

This procedure should only be run by the system administrator if multiple 
WaveLab Pro workstations are used.
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Display Tab

This tab allows you to change many aspects of the user interface that apply across 
the whole application. These options provide information and usability functions but 
can be deactivated to streamline the interface.

Theme

Theme

Allows you to switch between the WaveLab Pro color schemes.

Workspace

Show Tab If There Is a Single File Window

If this option is activated, the tabs are always visible, even if there is only one 
active file.

Display Active File Path in Title Bar

Displays the file path of the active file in the title bar of the workspace.

When Closing the Active Tab

Determines the behavior of the program when closing the active tab.

Tool Windows

Show Title for Single Tool Windows

Allows you to show or hide the title bar for single tool windows.

Animate Slide-Out Windows

If this option is activated, slide-out windows open with an animation.

Window Transparency

Sets the degree of transparency for windows that have this option activated.

Miscellaneous Options

Use the System File Selector to Open Files

If this option is activated, the standard file selector opens when you select the 
Save As option.

Open Quick File Selector When Saving Files

If this option is activated and you save a file via the save shortcut, a dialog 
opens instead of the File tab.
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Undo/Redo Does Not Scroll/Zoom Audio

If this option is activated, the undo and redo functions for audio files and audio 
montages do not restore the snapshot that was active when the operation 
was performed.

Show WaveLab Pro Logo on Startup

Determines whether the WaveLab Pro logo is displayed during initialization.

Show Tooltips

If this option is activated, tooltips are displayed when you move the mouse 
cursor over markers or command bar buttons.

Hide Top Level Windows When the Application Is Not Active (Windows only)

If this option is activated, all floating windows are automatically hidden when 
another application becomes active. If this option is deactivated, floating 
windows remain on top of other application windows.

History

Maximum Number of Items in Recent File Menus

Sets the maximum number of files that are listed in recent file menus.

Maximum Number of Items in Recent Files Tab

Sets the maximum number of files that are listed in the Recent Files tab.

Maximum Number of Items in the Recent Folders Menu

Sets the maximum number of files that are listed in the Recent Folder menus.

Audio Tab

Resample Conversion Quality

Allows you to specify the resample conversion quality.

Default Fade/Crossfade

Allows you to specify the default duration and shape of the fades or 
crossfades that WaveLab Pro creates automatically during specific 
processes.

Formats Tab

This tab allows you to adjust settings for some of the audio formats and units that 
WaveLab Pro uses.
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Formats

Use AES17 Standard for RMS Values

Determines how RMS values are reported.

• If this option is activated, the displayed level for a full scale sine audio 
file is 0 dB. This follows the AES17 standard.

• If this option is deactivated, the displayed level for a full scale sine audio 
file is -3 dB.

Pitch of A3 (Used in Frequency To Note Conversions)

Sets the reference pitch in WaveLab Pro. The frequency-to-note conversions 
take this pitch into account.

MIDI Note Display

The options in this section allow you to choose whether to display the different key 
values in WaveLab Pro with the pitch or the MIDI note number of the key. In musical 
notation, keys are denoted according to their pitch. For example, C3 means the note 
C in the third octave.

Each key corresponds to a MIDI note number from 0 to 127. For example, key C3 
corresponds to the MIDI note number 48. MIDI note numbers make it possible for 
samplers to automatically map samples to the correct keys.

Numeric Style

Determines the format for MIDI notes that are displayed as numbers.

Middle C (Note #60)

Determines the key convention for the MIDI note range (0-127).

Display

Determines how MIDI notes are displayed throughout the application.

CSV Delimiter

CSV Delimiter

Several areas of WaveLab Pro allow you to export information in the CSV text 
format. This option lets you set the delimiter character that a third-party 
software requires to import CSV files.

CD Writing Tab

This tab allows you to set a number of parameters for CD writing and for the 
creation of DDP images.



Configuring the Software
Global Preferences

705

CD Writing

Use Burnproof

Fixes possible buffer underrun errors automatically, provided that the CD 
writer supports this technology.

Allow Disc Overflow

Allows WaveLab Pro to attempt writing more data (max. 2 minutes) than the 
official capacity of the disc.

Maximum Audio CD Size

Allows you to specify the maximum length for a CD. A warning message will 
appear if the project exceeds this length. The standard maximum length is 74 
minutes.

DDP Creation

DDP Creation – Format 1.0/Format 2.0

Determines which format to create when producing DDP files for an audio 
project.

Write Checksum File (CRC-32)

If this option is activated, a file called CHECKSUM.CHK is added to the DDP 
files that are created on the hard drive. The checksum contains the CRC32 
checksums of the created DDP files.

Write Checksum File (MD5)

If this option is activated, a file called CHECKSUM.MD5 is added to the DDP 
files that are created on the hard drive. The checksum file contains the MD5 
checksums of the created DDP files.

Write Log File

If this option is activated, a text file called gear.log is added to the DDP files 
that are created on the hard drive. The log file logs all operations.

Warn If Files Already Exist

If this option is activated, a warning message is displayed if files are about to 
be overwritten in the specified destination folder.

Options Tab

This tab allows you to control application-wide start-up options. You can also reset 
the default message boxes.

Make Tasks Monitor Visible When Task Starts

If this option is activated, the Tasks window opens when a background task 
starts.
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Play a Sound When a Long Task Completes

Allows you to select a sound that is played when a task finishes.

Minimum Duration

Specifies how long a task must be for a sound to be triggered when the task 
is finished. If the task duration is shorter, no sound is triggered.

Path and Name of the Audio File

Lets you select which audio file is played. On Windows operating systems, 
the file format must be WAV, and on Mac OS operating systems, the file 
format can be WAV or AIFF.

Only Play the Sound for Blocking Tasks

If this option is activated, the sound only plays if tasks prevent you from 
working elsewhere in WaveLab Pro. For example, background tasks do not 
trigger a sound when they are completed.

Alternative External File Browser

Allows you to specify an alternative external file browser that opens when you 
use the Reveal Folder in File Explorer/Mac OS Finder or Reveal Files in 
File Explorer/Mac OS Finder options in WaveLab Pro.

If the application needs a special command line formatting, you can specify it 
in the Command Line field. Use %1 as a placeholder for the file or folder to 
which you want to browse.

Interval for Zoom Key Command

Allows you to specify how much the waveform zoom factor changes each time 
that the zoom shortcuts are triggered. Higher values allow you to zoom in and 
out more quickly but with bigger steps.

Reset Default Answers

Resets all message box options to their default settings. For example, all “Do 
not show again” options are deactivated.

Audio Files Preferences

This dialog allows you to define settings for editing in the Audio Editor. However, 
these settings also effect other parts of WaveLab Pro. You can choose defaults for 
editing and playback, adjust the visual appearance of the waveform displays, and 
determine how WaveLab Pro works with audio and peak files.

• To open the Audio Files Preferences tab, select File > Preferences > 
Audio Files.
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Editing Tab

Display

Save View Settings in Companion File

If this option is activated, zoom settings, ruler settings, and optionally the 
Master Section preset that is associated with the audio file are saved in a 
companion file. if the audio file is reopened, these settings are used. Deleting 
a companion file does not alter the audio contents.

Save in an Independent Folder

If this option is activated, the companion file is not saved in the same folder as 
the related audio file but in a folder that you can specify.

Edit

Opens the Folders dialog that allows you to specify where to save the 
companion files.

Show Overview when Opening new Audio Files

If this option is activated and you open an audio file, the overview is also 
displayed. If this option is deactivated, only the main view is displayed.

Show Overview when Opening new Audio Files in Multiple Tab Groups

If this option is activated and 2 or more tab groups are available, the overview 
is also displayed in the wave window when you open an audio file. If this 
option is deactivated, only the main view is displayed.

Overview: Passive Range Indicator Also Covers the Waveform

If this option is activated, the range indicator that is displayed in the time ruler 
of the overview also covers the waveform area. Unlike the time ruler indicator, 
the range indicator is passive and cannot be modified.

Analog Waveform Emulation at Sample Level Zooming

If this option is activated and a waveform is zoomed at the sample level in the 
timeline, an analog emulation of the waveform is displayed.

Auto-Zoom for Overviews

If this option is activated and you open an audio file, the zoom of the overview 
is set to display the whole file.

Display File Extension on Tabs

If this option is activated, tabs display file names with their extension. For 
example, “piano.mp3” instead of “piano”.

Number of Seconds to Display on Opening

Lets you specify the time range to display when opening an audio file for the 
first time. WaveLab Pro converts this time range to the appropriate zoom 
factor.
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Whole Audio File

If this option is activated, the horizontal zoom is set to display the whole file.

Editing

Select All Channels with the Mouse

If this option is activated and you select a range with the mouse in a stereo 
file, both channels are selected. To select the channels individually, press 
[Shift] while selecting. To switch from one channel selection to the other, 
press [Tab].

Process Whole File If There is No Selection

If this option is activated and a process is to be applied to an audio file, the 
whole file is processed if no audio is selected. In the same situation, if the 
option is deactivated, a warning appears.

Playback Scrubbing

Restrict to Play Tool

If this option is activated, this function only works if the Play Tool is used.

Sensitivity

Lets you set the micro audio loop duration that is performed when you move 
the mouse cursor over the time ruler.

Snap Selection to Zero-Crossing

Do Not Snap at High Zoom Factors

If this option is activated, snapping does not occur if the waveform is 
displayed at a high zoom factor.

Scan Range

Lets you define how far WaveLab Pro searches a zero-crossing point in the 
left and right direction.

File Tab

Warn When Opening a File with a Malformed Header

If this option is activated, a message opens when you open a file with a 
corrupt header. This might be a damaged file, or a file that is not properly 
formatted by another application.

If this option is deactivated, WaveLab Pro tries to open the file, but you are 
not informed about possible issues.
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Support RF64 File Format

If this option is activated, WaveLab Pro creates WAV files that can be larger 
than 2 GB.

NOTE

This file format is not supported by all applications.

Default Sample Rate for Files without Header

Lets you specify the sample rate of audio files that do not have a header 
describing this property.

Create Optimized Audio File Headers

If this option is activated, WaveLab Pro increases the WAV file headers to a 
value that improves disk access. Although this is a standard procedure, some 
applications cannot open these files correctly.

Save Audio Files in the Background

If this option is activated, WaveLab Pro saves audio files in the background 
so that you can continue working.

Write Markers in WAV File Header (Riff Format/BWF Format)

If this option is activated, markers are written in WAV file headers. Thus, the 
markers are always available even if you open the files in another application.

Write Markers in Separate File

If this option is activated, markers are written in a separate file (extension 
.mrk) that is saved in the same folder as the audio file. This allows marker 
support in file formats where markers are usually not supported.

Save Error and Correction Markers

If this option is activated, error and correction markers are saved with the 
other markers.

Create Peak Files in an Independent Folder

If this option is activated, peak files are not saved in the same folder as the 
related audio file. To specify the folder location, click Edit.

Create Peak Files When Writing Audio Files

If this option is activated, WaveLab Pro writes peak files while rendering audio 
files.

Delete Peak Files When Closing Audio Files

If this option is activated, peak files are deleted after use. This saves disk 
space but means that audio files take longer to open.

Allow Opening of Dual Mono Files

Allows recognizing multiple selected mono files as stereo files according to 
their name, and edit them as one stereo file.
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Name Creation/Name Interpretation

You can define a name creation pattern and up to 7 name interpretation 
patterns for different naming schemes.

• Name creation pattern (only 1) is used by WaveLab Pro to add the 
specified suffix to audio files when creating dual mono files. The default 
suffix is “-L” and “-R”.

• Name interpretation patterns (up to 7) are used by WaveLab Pro to 
identify the original channel of mono files through an analysis of their 
name.

Left Channel ID/Right Channel ID

These IDs are the character sequences that are used to identify the left and 
right channel files in their name. For example, “_l” for the left channel and “_r” 
for the right channel.

Suffix

In this mode, the channel ID string must be located at the end of the file name.

Advanced

In this mode, the channel ID string can be located anywhere in the file name 
and not only as a suffix. For this purpose, a name pattern must be defined. This 
name pattern must have a {capture} section.

The default suffixes for recognizing dual mono files are as follows:

• -L/-R

• _L/_R

• .L/.R

This mode is only available for input patterns.

Style Tab

This tab allows you to specify custom colors for parts of the wave window.

Styles

Lets you select the default style and conditional styles.

Parts

Shows parts that can be colorized. Click a part to edit the color.

Hide (for specific parts only)

Hides the selected part.

Dotted Line (for specific parts only)

Changes the line to a dotted line.

Transparency (for specific parts only)

Lets you edit the degree of transparency of the selected element.
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Element Size (for specific parts only)

Lets you edit the size of the selected element.

Change Both Channels

Allows you to make separate color settings for the left and the right side of a 
stereo file. If this option is activated, settings for the left side of a file are 
automatically mirrored on the right side, and vice versa.

Change Both Main View and Overview

Allows you to make separate color settings for the main view and the 
overview. If this option is activated, settings for the main view are automatically 
mirrored on the overview, and vice versa.

Color Picker

Lets you select the color for the selected part. Click the surrounding circle to 
select the hue. Click in the triangle to adjust the saturation and lightness.

Red/Green/Blue

Lets you specify the red, green, and blue components of the RGB color 
spectrum.

Copy Color

Copies the current color to the clipboard.

Paste

Pastes the color from the clipboard.

This Style Is Used If These Conditions Apply

Lets you define conditions under which a specific color style is applied.

File Extension Is Any Of

If this option is activated, the color style is applied to files with the specified 
extension. Separate extensions with a “;” character.

Name Contains Any of These Keywords

If this option is activated, the color style is applied to files with specific 
keywords in their name. Separate keywords with a “;” character.

Sample Rate Is in the Range

If this option is activated, the color style is applied to files that have a sample 
rate within the specified range.

Bit Resolution Is in the Range

If this option is activated, the color style is applied to files that have a bit 
resolution within the specified range.

Number of Channels Is

If this option is activated, the color style is applied to files that have the 
specified number of channels.
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Color Elements in the Audio Editor

You can assign custom colors to various elements of the Audio Editor. Depending 
on the selected element, additional settings can be made for transparency, 
appearance, or whether a line should be dotted, for example.

Left/Right Channel

Waveform

The waveform color.

Waveform (Selected)

The waveform color of the selected part of the waveform.

Waveform Outline

The outline color of the waveform.

Waveform Outline (Selected)

The outline color of the selected part of the waveform.

Background Top

The color of the background top.

Background Top (Selected)

The color of the selected part of the background top.

Background Bottom

The color of the background bottom.

Background Bottom (Selected)

The color of the selected part of the background bottom.

Waveform Main Axis

The color of the waveform main axis and its style.

Waveform 50 % Axis

The color of the waveform 50 % axis and its style.

Waveform Elements

Channel Separator

The color of the channel separator line.

Cursor (Edit)

The color of the edit cursor, its width, and transparency.

Cursor (Edit, No Focus)

The color of the edit cursor for a file that does not have the focus.
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Cursor (Play)

The color of the cursor during playback.

Marker Line

The color of the marker lines and an optional transparency.

End of File Indicator

The color of the end of the file indicator.

Time Ruler Style

The color of the time ruler and its style.

Time Ruler Font

The color of the font on the time ruler and the font size.

Level Ruler Style

The color of the level ruler, its style, and transparency.

Level Ruler Font

The color of the font on the level ruler and the font size.

Audio Montages Preferences

This dialog allows you to set up general parameters for all audio montages or for the 
active audio montage only.

• To open the Audio Montages Preferences dialog, select File > 
Preferences > Audio Montages.

Active Audio Montage Tab

The settings made on this tab apply only to the active audio montage.

Default Gap

Sets the default gap for clips. This setting is used for separating clips, for 
example, when you insert several clips at the same time.

DVD-Audio Resolution

Defines the DVD-Audio resolution for writing the audio montage to 
DVD-Audio. You can select 16 bit (smaller file size) or 24 bit (best quality).

Folder for Audio Files

Sets the path, which is relative to the audio montage folder, to the folder 
where audio files are implicitly created. For example, if you enter Data in the 
text field, a folder named Data is created in the audio montage folder. Files in 
this folder are not deleted when you close the audio montage.

If no folder is defined, the audio montage folder is used.
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Reset Plug-ins When Starting Playback

If this option is activated, all active effect plug-ins are instructed to release all 
samples in their memory when you start playback.

Use this option if you experience clicks or noises when the playback position 
reaches the start of a clip that contains effects (typically reverb or delay). 
Otherwise, leave this option deactivated because it could lead to a delayed 
response upon playback start.

It is recommended that you deactivate this option, unless you experience 
shortage of memory that is caused by too many plug-ins.

Reset Plug-ins before Rendering

If this option is activated before rendering, all active plug-ins are reloaded.

Use this option if you experience clicks or noises in rendered audio files.

Auto Save Master Section Preset

Automatically saves the current Master Section preset along with the audio 
montage when saving the audio montage. This is recommended if you work 
on one audio montage at a time.

All Audio Montages Tab

The settings made on this tab apply to all audio montages.

Maximum Number of Backups

Specifies how many previous versions are kept.

Auto Save

Automatically saves the audio montage in intervals which you can specify in 
the time field below.

Clear After Each Saving

Clears the memory that is used by the operation history each time the audio 
montage is manually saved. Any operations that were performed before 
saving can no longer be undone.

Group Similar Operations

Groups similar successive operations into one undo operation to save 
memory on your hard disk.

For example, if you need several steps to move a clip until you find the right 
position, you can undo each step as usual. However, as soon as you perform 
another operation, all the previous steps are considered as one entry in the 
undo history.

When Closing Unmodified Montages

Defines the actions that are performed when closing an unmodified audio 
montage. An audio montage is only tagged as modified if the audio-related 
data has been modified. The following options can be selected:
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• Save and Update Time Stamp: The audio montage is saved to 
remember its current state, for example, selection and zoom, and the 
time stamp of its file is updated.

• Save and Retain Time Stamp: The audio montage is saved to 
remember its current state, and the time stamp of its original file is 
retained.

• Do Not Save: The audio montage is not saved and therefore not 
preserved for the next launch of WaveLab Pro.

Display Indications of Possible Actions

Displays hints in the status bar of the audio montage about what you can do 
at the current mouse position in the montage window.

Display Envelope Tooltip While Editing

Displays a tooltip when you click and drag an envelope element. The tooltip 
indicates the value of the performed editing.

Auto Activate Clip when Selecting Audio Range

If this option is activated and you select an audio range, the corresponding 
clip becomes the active clip.

Auto Select the Active Clip

If this option is activated, you can click anywhere on a clip to select it. If this 
option is deactivated, the clip is only selected when you click in the bottom 
clip area.

Basic Amplitudes for Nudging – Time/Gain

Defines the amount with which elements are adjusted when you modify them 
with the nudge commands. This is used for nudging the position of objects or 
edges and for nudging volume gains.

CD Cue Sheets – Write Audio File Names without Path

If this option is activated, audio files are referenced without a path when 
generating CD cue sheets.

When an Audio File Is Replaced in a Clip

When you replace the audio file in a clip, the clip is resized accordingly.

This applies in the following situations:

• When replacing the audio file of a clip

• When replacing an audio file in an audio montage

• When rendering a super clip

• When re-rendering a sequencer project whose file is used by one or 
more clips

Markers that are attached to the clips are automatically shifted.

The following options determine what happens when you replace the audio 
file in a clip.
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• If Synchronize Clip Length with Audio File is activated, the clip length 
is set to the length of the new audio file.

• If Shift Clips on the Right is activated, the clips on the right of the clip 
retain their relative position.

NOTE

This only applies to clips that represent the whole audio file. If a clip is only a 
limited view of a larger audio file, these options have no effect.

Clip Time Ruler – Time is Relative to Clip Start

If this option is activated and Show/Hide Clip Ruler and Markers of Source 
File is activated in the wave window, the clip ruler time at the start of a clip is 
set to zero. If this option is deactivated, the clip ruler time is relative to the time 
of the audio file source.

Style Tab

This tab allows you to specify custom colors to clips and parts of a clip in the 
montage window.

Parts

Shows parts that can be colorized. Click a part to edit the color.

Checkbox

Allows you to select multiple parts to colorize multiple parts at the same time.

Undo

Undoes the last change.

Redo

Allows you to redo changes that were undone.

Hide

Hides the selected part.

Change Both Channels

It is possible to make separate color settings for the left and the right side of 
stereo clips. If this option is activated, settings for the left side of a clip are 
automatically mirrored on the right side, and vice versa.

Color Picker

Lets you select the color for the selected part. Click the surrounding circle to 
select the hue. Click in the triangle to adjust the saturation and brightness.

Red/Green/Blue

Lets you specify the red, green, and blue components of the RGB color 
spectrum.
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Copy Color

Copies the current color to the clipboard.

Paste

Pastes the color from the clipboard.

This Style Is Used If These Conditions Apply

Lets you define conditions under which a specific color style is applied.

File Extension Is Any Of

If this option is activated, the color style is applied to clips referencing a file 
with the specified extension. Separate extensions with a “;” character.

Name Contains Any of These Keywords

If this option is activated, the color style is applied to clips with specific 
keywords in their name. Separate keywords with a “;” character.

Sample Rate Is in the Range

If this option is activated, the color style is applied to clips referencing a file 
that has a sample rate within the specified range.

Bit Resolution Is in the Range

If this option is activated, the color style is applied to clips referencing a file 
that has a bit resolution within the specified range.

Number of Channels Is

If this option is activated, the color style is applied to clips that have the 
specified number of channels.

Color Elements in the Audio Montage

You can assign custom colors to various elements of the montage window.

Clip Colors

The following clip types are available:

Crossfade Region

Allows you to set the background color for overlapping clip sections.

Default

The default colors, used for clips for which you have not selected any specific 
color.

Mid/Side

The colors used for mid/side clips.

Locked

The colors used for fully locked clips.
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Muted

The colors used for muted clips.

Custom

These options correspond to the items on the color submenus. You can set 
up conditions in the This Style Is Used If These Conditions Apply section 
for when these should be automatically applied.

The following color elements are available:

Background Top/Bottom (Normal/Selected/Selected Range)

The background colors of the clip for selected and unselected clips and the 
selection range. The resulting display backgrounds are gradient fades from 
the top colors to the bottom colors.

Waveform (Normal/Selected/Selected Range)

The waveform color for selected and unselected clips and the selection 
range.

Waveform Outline (Normal/Selected/Selected Range)

The color of the waveform outline for selected and unselected clips and the 
selection range.

Edge

The left and right edge of the clip.

Edge (Selected)

The left and right edge of a selected clip.

Edge (Selected Range)

The left and right edge of a selected clip if within a selection range.

Axis (Level Zero)

The color of the horizontal dotted line in the middle of a clip, indicating the zero 
level.

Axis (Half Level)

The color of the horizontal dotted lines halfway up and down from the middle 
of a clip, indicating 50 % level.

Channel Separator (Stereo Clip)

The line dividing the two sides in a stereo clip.

Clip Name

The name label of the clip.

Active Clip Name

The name label of the active clip.

Active Clip Name Background

The name label background of the active clip.
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Miscellaneous

Background Top/Bottom

The background colors of the track view for areas without a clip.

Background (Selected Range) Top/Bottom

The background colors in selected ranges.

Cursor (Edit)/Cursor (Edit, No Focus)/Cursor (Playback)

The color of the corresponding cursor.

Marker Line

The color of the marker lines in the audio montage.

Cue Point Line/End Cue Point Line

The color of the vertical dotted cue point lines and end cue point lines.

Marker Line (Source File)

The color of marker lines from the source montage window. The marker lines 
are displayed if Show/Hide Clip Ruler and Markers of Source File is 
activated on the Functions menu of the Clips window.

Time Ruler (Source File)

The color of the source ruler. The source ruler is displayed if Show/Hide Clip 
Ruler and Markers of Source File is activated on the Functions menu of the 
Clips window.

Time Grid Lines

The color of the time grid if activated in the menu of the time ruler.

Settings Management

You can make some reference settings available to other WaveLab Pro 
installations. These settings can then be used by other WaveLab Pro workstations 
to keep the settings synchronized on several computers.

PROCEDURE

1. Select File > Preferences > Global.

2. Select the General tab.

3. In the Setting Location section, specify where to save the settings.
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Multi-User Settings

If you use multiple WaveLab Pro stations in your studio or in your school, for 
administration, etc., you can set up one WaveLab Pro station to be the master 
station. The shared preferences and presets of this station can then be used by 
other slave stations.

These settings can be saved on the local network, for example.

If the administrator updates these settings, the different WaveLab Pro stations can 
synchronize with the master settings. You can also use this feature for individual 
computers to back up a reference setting and revert to this if necessary.

The settings in the General tab of the Global Preferences dialog are not 
synchronized. These are saved for each user in the startup.ini (Windows) or 
startup.plist (Mac).

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

Settings cannot be synchronized between PC and Mac.

Setting Up a Multi-User Setup

You can use the settings that you have made on a master WaveLab Pro station for 
other slave WaveLab Pro stations.

PROCEDURE

1. Set up a WaveLab Pro station with all settings and presets that you want to 
use on other WaveLab Pro stations.

2. Assign read-only access to the settings folder of the master WaveLab Pro 
station.

3. Open WaveLab Pro on another station for which you want to use the master 
settings.

4. Select File > Preferences > Global.

5. Select the General tab.

6. In the Synchronization Settings section, set up the Master Folder, specify 
when the settings should be synchronized, and specify whether to include the 
preferences and/or presets.

7. Close WaveLab Pro.

8. Copy the startup.ini (Windows) or startup.plist (Mac) of the slave 
WaveLab Pro station to the settings folder of the other slave WaveLab Pro 
stations.

RESULT 

All slave WaveLab Pro stations use the settings of the master WaveLab Pro station.
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External Tools

You can configure external tools to work with WaveLab Pro. You can pass 
command line arguments on to the external tools so that they can process the 
current file/folder on which you are working, or the settings folder of WaveLab Pro.

This function is useful if you want to edit an audio file in another application, or if you 
want to compress all your audio files into a backup ZIP file, for example.

Once you have defined an external tool, you can run it by selecting it from the 
External Tools pop-up menus in the Audio Editor and Batch Processor window.

NOTE

An external tool only works within the editor in which it is defined. Thus, each editor 
type can have its own external toolkit.

RELATED LINKS

Configuring External Tools on page 721
Configure External Tools Dialog on page 722

Configuring External Tools

To be able to select external tools from the Tools menu, you must configure them.

PROCEDURE

1. In the Audio Editor or the Batch Processor window, open the Configure 
External Tools dialog.

2. In the Configure External Tools dialog, click the plus icon to create a new 
tool definition.

3. Specify a title, the path to the external tool that you want to run, arguments, 
an initial folder, and a comment.

4. Optional: Add more tool definitions by clicking the plus icon again.

RESULT 

The external tool is configured and can be selected from the Tools menu.

Once an external tool has been configured, you can assign a shortcut to it.

RELATED LINKS

Configure External Tools Dialog on page 722
Customizing Shortcuts on page 661
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Running an External Tool After a Batch Process

You can specify external tools to run after a batch process is completed. For 
example, you can run a tool to zip the output files or an FTP tool to upload the files 
to the Internet.

PREREQUISITE 

Configure the external tool that you want to run after the batch process.

PROCEDURE

1. In the Batch Processor window, select the Options tab.

2. From the On Success, Run External Tool pop-up menu, select the external 
tool that you want to run after the batch process.

RELATED LINKS

Configuring External Tools on page 721
Configure External Tools Dialog on page 722

Configure External Tools Dialog

In this dialog, you can configure external tools to work with WaveLab Pro. For 
example, you can run a tool to zip the output files or an FTP tool to upload the files 
to the Internet.

• To open the Configure External Tools dialog for audio files, select the 
Process tab in the Audio Editor, click External Tools in the Other section, 
and select Configure External Tools.

• To open the Configure External Tools dialog for batch processes, select the 
Options tab in the Batch Processor window, open the On Success, Run 
External Tool pop-up menu, and select Configure External Tools.

List of external tools

The list of all external tools that are defined, in the order as they appear in the 
Tools menu.

Create item

Creates a new tool definition.

Delete item

Deletes the selected tool definition from the list.

Move selected item one position up/down

Moves the selected tool definition one position up/down.

Title

The title for the tool definition.
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Application

The full path and file name of the application to run.

Arguments text field

The list of arguments to pass on to the application. Normally, there is at least 
one argument, for example, the active file name in WaveLab Pro. The required 
arguments depend on the application to run. Refer to the related 
documentation.

The arguments must be separated from one another by a space character. If 
an argument contains space characters, it must be enclosed in quotes.

Predefined arguments can be selected via the menu button next to this text 
field.

Arguments button

Opens a menu with a list of predefined arguments. These are placeholders 
that are replaced by actual values at runtime.

For example, if you select from the menu Active File Name with Its Path, the 
following text is inserted: $(FilePathAndName). At runtime, this symbol could 
be replaced by C:/Music/Piano.wav, presuming that this is the active file in 
WaveLab Pro.

Initial Folder

Specify the reference path that might be needed by the application. This path 
depends on the application. This setting is optional.

Comment

Allows you to add comments.

Before Execution – Warn If Active File Has Unsaved Changes (Audio Editor 
only)

If this option is activated, WaveLab Pro warns you if the active file has 
unsaved changes before running the external tool.

Before Execution – Close Active File (Audio Editor only)

If this option is activated, WaveLab Pro closes the active file before running 
the external tool. This is useful if the tool is meant to modify the active file.

Before Execution – Stop Playback (Audio Editor only)

If this option is activated, WaveLab Pro stops playing back the file before 
running the external tool. This is useful if the tool is meant to play back the file.

RELATED LINKS

External Tools on page 721
Configuring External Tools on page 721
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Plug-in Reference

Steinberg created Virtual Studio Technology (VST) to allow effect plug-ins to be 
integrated with audio editors, such as WaveLab Pro. VST uses Digital Signal 
Processing (DSP) to closely simulate the effects of familiar recording studio 
hardware in software.

A vast number of plug-ins are available, from freeware to high-end commercial 
products.

The order of processing is significant. You can change the order in which effects 
are processed by moving the effect icons by dragging them between slots. 
WaveLab Pro provides slots for up to ten plug-ins.

Most plug-ins provide a custom GUI, often displaying controls similar to the physical 
switches and knobs of audio hardware. Other plug-ins rely on the host application 
for their UI.

Built-in Plug-ins

These plug-ins use the plug-in format of WaveLab Pro, and cannot be used with 
other applications.

• WaveLab Pro specific plug-ins can only be used in the Master Section and 
in batch processes. However, some WaveLab Pro effects are also included 
as VST plug-ins, available as track or clip effects in audio montages.

• You can specify which plug-ins should be available on the Effects pane and 
the Final Effects/Dithering pane of the Master Section by using the Plug-in 
Settings dialog.

• Only specific built-in plug-ins can be used as master effects when a 
multichannel configuration is used in the audio montage. All channels in the 
Master Section are affected equally.

Resampler

This plug-in is a professional sample rate converter providing exceptional 
transparency and preservation of the frequency content. It is only available in the 
Master Section.
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NOTE

This plug-in is very CPU consuming, especially in high quality modes.

Output Sample Rate

Defines the output sample rate while the input sample rate is determined by 
the sample rate of the active audio file or audio montage.

Quality

Defines the quality of the algorithm that is used (Preview (Fast), Standard, 
High, Ultra (Slow)). In Preview mode the CPU load is much lower than in 
Ultra mode but the sound quality of the resulting audio is also lower.

Ducker

This plug-in lets you control (modulate) the volume of clips placed on a track with 
the signal of one or more clips placed on the next adjacent track below it. The 
Ducker plug-in can only be used as a clip effect in the audio montage.

It uses the Route to options that can be found on the Track menu. You can use 
mono or stereo tracks for both the modulating and the upper track.

Threshold

Sets the loudness threshold that triggers the Ducker. Clips on the modulator 
track with levels above the threshold will cause the level of a clip on the upper 
track to be lowered.

Damping

Sets the amount of level reduction that is applied to the clip on the upper 
track.

Fall Time

Sets the time it takes for the level to change from 0 dB to the set damping 
level.
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Hold Time

When the modulating signal falls below the set threshold, this setting 
determines how long the level will stay reduced before it starts rising to normal 
level again.

Rise Time

Sets the time after which the reduced level rises to the normal level when the 
modulating signal falls below the set threshold (after the Hold Time).

Mix Mode

If this is activated, the Ducker outputs a mix of the two tracks. This is only 
useful if the Route to Upper Track Only option has been activated for the 
modulating track. Then this feature can be used for processing several clips 
through the same plug-in chain if more plug-ins have been assigned after the 
Ducker on the upper track.

Note that the mixed output is controlled by the upper track. If this is not playing 
a clip, both of the tracks will be silent.

Leveler

This plug-in is useful for correcting an imbalance or adjusting levels between stereo 
channels, or for mixing down to mono.

Volume Left/Volume Right (-48 dB to 12 dB)

Governs how much of the signal is included in the left and/or right channel of 
the output bus.

Stereo Link

If this option is activated, Volume Right delivers the gain that is set for 
Volume Left.

Mix to Mono

If this option is activated, a mono mix of the stereo channels is delivered to the 
output bus.

Leveler Multi

This plug-in takes multichannel input and applies a fader equally to all channels.
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Volume (-48 dB to 12 dB)

Governs how much gain is applied to the signal before it is routed to the 
output bus.

MasterRig

MasterRig allows you to master audio material in an intuitive and creative way. It 
offers high-class sound quality, accuracy, flexibility, and control.

Main Layout

Module Chain

The module chain contains the mastering modules. You can add up to 8 modules.

The following settings are available for each module:

Bypass

Bypasses the module. This allows you to compare the sound of the 
unprocessed signal to that of the processed signal.

Solo

Solos the module. Only one module can be soloed at a time.

Remove

Removes the module from the module chain.

Scenes

You can save up to 4 MasterRig configurations as scenes. This allows you to 
compare different parameter settings and module combinations.
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• To copy the settings of a scene to another scene, click Copy Scene, and then 
click the scene button of the scene where you want to paste the settings.

A copy of a scene is indicated by a (c) behind the scene name.

• To reset the settings of the selected scene, click Reset Scene.

• To rename a scene, double-click the scene name and type in another name.

Spectrum Display

The spectrum display in the upper half of the panel is where you set the width of the 
frequency bands. The vertical value scale to the left shows the gain level of each 
frequency band. The horizontal scale shows the frequency range.

• To define the frequency range of the different frequency bands, use the 
handles at the sides of each frequency band.

• To attenuate or boost the output level of each frequency band by ±15 dB, use 
the handles on top of each frequency band.
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Settings

Parameter Linking

Links the parameters of the same type in all bands in a module. This allows 
you to edit parameter values of all bands in a module simultaneously. Two link 
modes are available: Absolute and Relative.

• If Absolute Mode is activated and you edit a parameter value in one 
band, the corresponding parameter values in the other bands are set to 
the same value.

• If Relative Mode is activated and you edit a parameter value in one 
band, the corresponding parameter values in the other bands keep their 
relation.

Auto Listen for Filters

If this option is activated and you edit a parameter of a module, the 
corresponding filter or band is soloed. This allows you to locate unwanted 
frequencies in your audio and helps you to focus on a particular band or filter. 
Once you stop editing the parameter, Solo is deactivated.

Global Settings

Allows you to make global settings for MasterRig.

Undo/Redo

Undoes/Redoes the last operation. The undo/redo history is deleted when 
you select another scene.

Input/Output Meter

The input/output meter provides a combined peak level, with peak-hold functionality 
and RMS meter. Between the meters for input and output is the gain reduction 
meter for the Limiter.
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The maximum values for input/output peak level, RMS, and gain reduction are 
displayed above the meter display. To reset all maximum values, click any of the 
values.

Side-Chain Settings

The Compressor module and the Dynamic EQ module support side-chain. You 
can set up the side-chain routing for each band separately.

• To open the side-chain panel, click the SC button at the bottom left of each 
band section.

Active

Activates the internal side-chain filter. The input signal can then be shaped 
according to the filter parameters.

SC FREQ

Sets the frequency of the side-chain filter.

Auto (Dynamic EQ only)

Deactivates the SC Frequency knob of the side-chain panel. Instead, the 
settings of the Frequency knob are used.

Listen

Allows you to solo the side-chain filter.

SC Q

Sets the resonance or width of the filter.

Modules

Modules allow you to create a mastering chain. Some modules can be used only 
once and some in two instances in the module chain. You can rearrange modules 
in the module chain to change the processing order.

• To add a module to the module chain, click Add Module in the modules 
section and click a module.

• To remove a module, click the corresponding Remove button.
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• To bypass a module, click the corresponding Bypass button.

• To solo a module, click the corresponding Solo button.

• To change the order of the modules, drag a module to another position in the 
module chain.

Global Settings

• To open the Global Settings, click Global Settings  above the spectrum 
display.

Spectrum Display

Show Spectrum

Activates/Deactivates the spectrum display.

Smooth

Determines the reaction time of the spectrum display. Lower values result in 
faster reaction times.

Peak Hold

Freezes the peak values of the spectrum display.

Slope

Tilts the spectrum display around the 1 kHz pivot.

Two Channels

If this option is activated, the spectrum of the left and right channels are 
displayed separately.

EQ Curve

Show Curve

Shows/Hides the EQ curve in the spectrum display.

Filled

If this option is activated, the EQ curve is filled.

RMS

AES17 (+3 dB)

If this option is activated, the RMS value is raised by 3 dB to follow the AES17 
standard.



Plug-in Reference
Built-in Plug-ins

732

Limiter

The Limiter module makes sure that the output level never exceeds a set output 
level, to avoid clipping in following devices.

Band Settings

On/Off

Activates/Deactivates the corresponding section.

Balance
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Mid/Side

Allow you to set the gain for the mid and side signal.

Solo Mid Signal/Solo Side Signal

Allow you to solo the mid or side signal.

Transients

If the Transients section is activated, you can set the following parameters:

ATT

Sets the gain of the attack phase of the signal for the corresponding band.

REL

Sets the gain of the release phase of the signal for the corresponding band.

Gain

Sets the output level for the corresponding band.

Harmonics

If the Harmonics section is activated, the Limiter module starts limiting the signal 
softly. At the same time, harmonics are generated, adding a warm, tube-like 
characteristic to the audio material.

2nd HARM/3rd HARM

Allow you to control the second and third harmonic independently.
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Drive

Allows you to adjust the amount of gain boost for the signal to raise the 
amount of soft-clipping.

Brickwall

Due to its fast attack time, Brickwall Limiter can reduce even short audio level 
peaks without creating audible artifacts. The limiting amount is displayed between 
the input and the output meter.

Release

Sets the time after which the gain returns to the original level when the signal 
drops below the threshold. If Auto Release is activated, the plug-in 
automatically finds the best release setting for the audio material.

Oversample

If this option is activated, Brickwall Limiter detects and limits signal levels 
between two samples to prevent distortion when converting digital signals 
into analog signals.

Stereo Link

If this option is activated, Brickwall Limiter uses the channel with the highest 
level to analyze the input signal. If the button is deactivated, each channel is 
analyzed separately.

Output

Sets the output level.

Maximizer

Maximizer raises the loudness of audio material without the risk of clipping. The 
limiting amount is displayed between the input and the output meter.
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Optimize

Determines the loudness of the signal.

Output

Sets the output level.

Compressor

The Compressor module allows a signal to be split into four frequency bands. You 
can specify the level, bandwidth, and compressor characteristics for each band.

You can add two Compressor modules to the module chain, Compressor A and 
Compressor B.
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Band Settings

On/Off

Activates/Deactivates the corresponding section.

Soloing Frequency Bands

To solo a frequency band, activate the S button in each section. Only one 
band can be soloed at a time.

Channel Settings

Allow you to switch between left/right, stereo, and mid/side processing. In 
Left/Right or Mid/Side processing mode, you can make different settings for 
the two channels.

Add/Remove Band

Allow you to add and remove bands.

Standard

Allows you to create smooth compression effects.

THRESH (-60 to 0 dB)

Signal levels above the set threshold trigger the compressor.

ATT (0.1 to 100 ms)

Determines how fast the compressor responds. If the attack time is long, more 
of the initial part of the signal passes through unprocessed.
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REL (10 to 1000 ms)

Sets the time after which the gain returns to its original level. If Auto Release 
is activated, the plug-in automatically finds a suitable release setting for the 
audio.

Ratio

Sets the amount of gain reduction applied to signal above the set threshold.

Mix

Sets the level balance between the dry signal and the wet signal.

Compressor curve display

Graphically illustrates the compressor curve that is shaped according to the 
Threshold and Ratio parameter settings.

Output

Sets the output gain.

Side-Chain

Opens the Side-Chain settings.

Tube

This versatile compressor with integrated tube-simulation allows you to produce 
smooth and warm compression effects.

Input

In combination with the Output setting, this parameter determines the 
compression amount. The higher the input gain setting and the lower the 
output gain setting, the more compression is applied.

ATT (0.1 to 100 ms)

Determines how fast the compressor responds. If the attack time is long, more 
of the initial part of the signal passes through unprocessed.

REL (10 to 1000 ms)

Sets the time after which the gain returns to its original level. If Auto Release 
is activated, the plug-in automatically finds the best release setting for the 
audio.
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Drive

Controls the amount of tube saturation.

Mix

Sets the level balance between the dry signal and the wet signal.

Output

Sets the output gain.

Side-Chain

Opens the Side-Chain settings.

Vintage

Vintage Compressor is modeled after vintage type compressors.

Input

In combination with the Output setting, this parameter determines the 
compression amount. The higher the input gain setting and the lower the 
output gain setting, the more compression is applied.

ATT (0.1 to 100 ms)

Determines how fast the compressor responds. If the attack time is long, more 
of the initial part of the signal passes through unprocessed.

REL (10 to 1000 ms)

Sets the time after which the gain returns to its original level. If Auto Release 
is activated, the plug-in automatically finds the best release setting for the 
audio material.

Ratio

Sets the amount of gain reduction that is applied to signals above the set 
threshold.

Attack Mode (Punch)

If this option is activated, the early attack phase of the signal is preserved, 
retaining the original punch in the audio material, even with short Attack 
settings.
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Mix

Sets the level balance between the dry signal and the wet signal.

Output

Sets the output gain.

Side-Chain

Opens the Side-Chain settings.

Maximizer

Optimize

Determines the loudness of the signal.

Mix

Sets the level balance between the dry signal and the wet signal.

Output

Sets the output gain.

Equalizer

The Equalizer module is a high-quality 8-band parametric stereo equalizer with 8 
fully parametric mid-range bands. The low and high bands can act as either shelving 
filter, as peak filter (band-pass), or as cut filter (low-pass/high-pass, band 1 and 8 
only).

You can add two Equalizer modules to the module chain, Equalizer A and 
Equalizer B.
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Band Settings

On/Off

Activates/Deactivates the corresponding section.

Channel Settings

Allow you to switch between left/right, stereo, and mid/side processing. In 
Left/Right or Mid/Side processing mode, you can make different settings for 
the two channels.

Equalizer Section
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Type

You can choose between the EQ types Low Shelf, Peak, High Shelf, and 
Notch. For band 1 and 8, you can also select the types Cut 12, Cut 24, and 
Cut 48.

• Low Shelf boosts or attenuates frequencies below the cutoff frequency 
by the specified amount.

• High Shelf boosts or attenuates frequencies above the cutoff 
frequency by the specified amount.

• Peak boosts or attenuates frequencies at the set frequency value with 
a bell shaped filter.

• Notch boosts or attenuates frequencies at the set frequency value with 
a very narrow filter.

• Cut attenuates frequencies below (band 1) or above (band 8) the set 
frequency. You can choose between different slopes: 12 dB, 24 dB, or 
48 dB per octave.

FREQ (20 to 20000 Hz)

Sets the frequency of the corresponding band.

Q

Controls the width of the corresponding band.

Gain (-15 to +15 dB)

Sets the amount of attenuation/boost for the corresponding band.

Dynamic EQ

Dynamic EQ allows you to adjust frequencies and lets you determine when and 
how the EQ is applied depending on the dynamics of the audio material.

You can add two Dynamic EQ modules to the module chain, Dynamic EQ A and 
Dynamic EQ B.
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Band Settings

On/Off

Activates/Deactivates the corresponding section.

Channel Settings

Allow you to switch between left/right, stereo, and mid/side processing. In 
Left/Right or Mid/Side processing mode, you can make different settings for 
the two channels.

Equalizer Section



Plug-in Reference
Built-in Plug-ins

743

Type pop-up menu

Allows you to select the EQ types.

• Low Shelf boosts or attenuates frequencies below the cutoff frequency 
by the specified amount.

• Peak boosts or attenuates frequencies at the set frequency value with 
a bell shaped filter.

• High Shelf boosts or attenuates frequencies above the cutoff 
frequency by the specified amount.

FREQ (20 to 20000 Hz)

Sets the frequency of the corresponding band.

Q

Controls the width of the corresponding band.

Gain (-15 to +15 dB)

Sets the amount of attenuation/boost for the corresponding band.

TRESH (-50 to 0 dB)

Determines the threshold level. Only signal levels above the threshold are 
processed.

ATT (0.1 to 100 ms)

Determines how fast Dynamic EQ responds to signals above the threshold. 
If the attack time is long, more of the early part of the signal passes through 
unprocessed.

REL (10 to 1000 ms)

Sets the time after which Dynamic EQ returns to its original level when the 
signal drops below the threshold.

Ratio

The higher the level of the input signal is above the threshold, the more 
filtering occurs. Low ratio values mean that the filter starts to boost or 
attenuate smoothly above the threshold. High ratio values mean that the filter 
starts to work almost immediately.

Side-Chain

Opens the Side-Chain settings.

RELATED LINKS

Side-Chain Settings on page 730



Plug-in Reference
Built-in Plug-ins

744

Saturator

The Saturator module allows you to simulate the sound of analog tubes, and the 
saturation and compression effect when recording on analog tape machines.

You can add two Saturator modules to the module chain, Saturator A and 
Saturator B.

Band Settings

On/Off

Activates/Deactivates the corresponding section.

Soloing Frequency Bands

To solo a frequency band, activate the S button in each section. Only one 
band can be soloed at a time.

Channel Settings

Allow you to switch between left/right, stereo, and mid/side processing. In 
Left/Right or Mid/Side processing mode, you can make different settings for 
the two channels.

Add/Remove Band

Allow you to add and remove bands.
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Saturator Section

Tape/Tube

Allows you to switch between tube saturation and tape saturation.

• Tube saturation simulates the saturation of analog tube compressors.

• Tape saturation simulates the saturation and compression effect of 
analog tape machine recordings.

Drive

Controls the amount of saturation.

Mix

Sets the level balance between the dry signal and the wet signal.

Output

Sets the output gain.

Imager

The Imager module allows you to expand or reduce the stereo width of your audio 
in up to four bands. This way you can independently adjust the stereo image in 
defined frequency domains.



Plug-in Reference
Built-in Plug-ins

746

Band Settings

On/Off

Activates/Deactivates the corresponding section.

Soloing Frequency Bands

To solo a frequency band, activate the S button in each section. Only one 
band can be soloed at a time.

Add/Remove Band

Allow you to add and remove bands.



Plug-in Reference
Built-in Plug-ins

747

Imager Section

Width

Allows you to control the stereo width per band.

Pan

Allows you to pan the signal left/right.

Output

Sets the output level for each band.

Peak Master

This is a basic plug-in that minimizes peaks in your audio file, allowing a louder mix 
without clipping. It is useful in taming dynamic instruments.

It is primarily used as a brickwall limiter. For example, you can limit audio peaks 
without altering the rest of the audio signal. In this case, set Input Gain to 0 dB and 
Out Ceiling to 0 dB, to achieve a clip-free audio signal. When used in this way, 
Peak Master is an excellent plug-in to succeed a resampler plug-in, and to proceed 
a dithering plug-in.

Input Gain

Values range from -12 dB to 24 dB.

Out Ceiling

This is the maximum level of the output signal. Values range from -18 dB to 
0 dB.
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Softness

This governs the speed at which the signal becomes unaffected after limiting 
has been triggered on some samples. Values range from -5 to +5.

Silence

This plug-in provides a simple way of inserting a precise period of silence at the 
start or at the end of an audio file. Use this plug-in to add silence at the end of a file, 
so that the tail of a reverb plug-in does not cut immediately at the end of the file.

Start

Use the slider to insert from 0 to 60,000 ms of silence at the start of the file.

End

Use the slider to insert from 0 to 60,000 ms of silence at the end of the file.

Stereo Expander

This plug-in is a stereo width enhancer that makes a stereo signal sound wider. It 
gives better results from real stereo material, as opposed to mono channels panned 
to different positions in the stereo image.

Width

Higher values result in a greater stereo width. Usually, you set Width to values 
between 0 % and 20 %. Higher values can be used for special effects.

Steinberg VST 3 Plug-ins

In WaveLab Pro there is no limitation to the use of VST plug-ins. They can be used 
wherever plug-ins can be inserted.

• You can specify which VST plug-ins should be available in the Effects pane 
and Final Processing/Dithering pane of the Master Section by using the 
Plug-in Settings dialog.
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• VST plug-ins have their own preset handling. You can save or load effect 
programs (presets).

AutoPan

This plug-in is a simple auto-pan effect. It can use different waveforms to modulate 
the left-right stereo position (pan), using manual modulation speed settings.

Rate

Sets the auto-pan speed.

Sync

Activates/Deactivates tempo sync.

Width

Sets the depth of the auto-pan effect, that is, how far out to the left/right 
speaker the sound should move.

Waveform Shape selector

Allows you to select the modulation waveform. Sine produces a smooth 
sweep. Triangle creates a ramp, that is, a sweep from one speaker to the 
other and then a quick jump back.

Brickwall Limiter

Brickwall Limiter ensures that the output level never exceeds a set limit.
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Due to its fast attack time, Brickwall Limiter can reduce even short audio level peaks 
without creating audible artifacts. However, this plug-in creates a latency of 1ms. 
Brickwall Limiter features separate meters for input, output, and the amount of 
limiting. Position this plug-in at the end of the signal chain, before dithering.

Threshold (-20 to 0 dB)

Determines the level where the limiter kicks in. Only signal levels above the 
set threshold are processed.

Release

Sets the time after which the gain returns to the original level when the signal 
drops below the threshold. If the Auto button is activated, the plug-in 
automatically finds the best release setting for the audio material.

Link

If this button is activated, Brickwall Limiter uses the channel with the highest 
level to analyze the input signal. If the button is deactivated, each channel is 
analyzed separately.

Detect Intersample Clipping

If this option is activated, Brickwall Limiter detects and limits signal levels 
between two samples to prevent distortion when converting digital signals 
into analog signals.

NOTE

Brickwall Limiter is designed for the reduction of occasional peaks in the signal. If 
the Gain Reduction meter indicates constant limiting, try raising the threshold or 
lowering the overall level of the input signal.

Channel Extractor

This plug-in allows you to only keep the left or the right channel of a stereo stream.

Channel

Lets you select whether to keep the left or the right channel of the stereo 
stream.

Chorus

This plug-in is a single-stage chorus effect. It works by doubling the audio that is 
sent into it with a slightly detuned version.
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Rate

If tempo sync is deactivated, this sets the sweep rate.

Sync

Activates/Deactivates tempo sync.

Width

Sets the depth of the chorus effect. Higher settings produce a more 
pronounced effect.

Spatial

Sets the stereo width of the effect. Turn clockwise for a wider stereo effect.

Mix

Sets the level balance between the dry signal and the wet signal. If the effect 
is used as a send effect, set this parameter to the maximum value as you can 
control the dry/effect balance with the send.

Waveform Shape selector

Allows you to select the modulation waveform, altering the character of the 
chorus sweep. A sine and a triangle waveform are available.

Delay

Affects the frequency range of the modulation sweep by adjusting the initial 
delay time.

Filter Lo/Hi

Allow you to roll off low and high frequencies of the effect signal.

NOTE

If side-chaining is supported, the modulation can also be controlled from another 
signal source via the side-chain input. If the side-chain signal exceeds the threshold, 
the modulation is controlled by the side-chain signal’s envelope. For a description 
of how to set up side-chain routing, see the Operation Manual.
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Compressor

This plug-in reduces the dynamic range of the audio, making softer sounds louder 
or louder sounds softer, or both.

Compressor features a separate display that graphically illustrates the compressor 
curve shaped according to the Threshold and Ratio parameter settings. 
Compressor also features a Gain Reduction meter that shows the amount of gain 
reduction in dB, Soft knee/Hard knee compression modes, and a 
program-dependent auto feature for the Release parameter.

Threshold (-60 to 0 dB)

Determines the level where the compressor kicks in. Only signal levels above 
the set threshold are processed.

Ratio

Sets the amount of gain reduction applied to signals above the set threshold. 
A ratio of 3:1 means that for every 3 dB the input level increases, the output 
level increases by 1 dB.

Soft Knee

If this button is deactivated, signals above the threshold are compressed 
instantly according to the set ratio (hard knee). If Soft Knee is activated, the 
onset of compression is more gradual, producing a less drastic result.

Make-up (0 to 24 dB or Auto mode)

Compensates for output gain loss, caused by compression. If the Auto button 
is activated, the knob becomes dark and the output is automatically adjusted 
for gain loss.

Attack (0.1 to 100 ms)

Determines how fast the compressor responds to signals above the set 
threshold. If the attack time is long, more of the early part of the signal passes 
through unprocessed.

Hold (0 to 5000 ms)

Sets the time the applied compression affects the signal after exceeding the 
threshold. Short hold times are useful for DJ-style ducking, while longer hold 
times are required for music ducking, for example, when working on a 
documentary film.
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Release (10 to 1000 ms or Auto mode)

Sets the time after which the gain returns to its original level when the signal 
drops below the threshold. If the Auto button is activated, the plug-in 
automatically finds the best release setting for the audio material.

Analysis (Pure Peak to Pure RMS)

Determines whether the input signal is analyzed according to peak or RMS 
values, or a mixture of both. A value of 0 is pure peak and 100 pure RMS. RMS 
mode operates using the average power of the audio signal as a basis, 
whereas Peak mode operates more on peak levels. As a general guideline, 
RMS mode works better on material with few transients such as vocals, and 
Peak mode works better for percussive material with a lot of transient peaks.

Live

If this button is activated, the look-ahead feature of the effect is deactivated. 
Look-ahead produces more accurate processing, but adds a specific amount 
of latency as a trade-off. If Live mode is activated, there is no latency, which 
is better for live processing.

CurveEQ

Voxengo CurveEQ is a spline equalizer for professional music and audio production 
applications. CurveEQ shows the filter response you are designing by means of a 
spline, that is, a smooth curvy line. This way you can see how the EQ alters the 
sound.

CurveEQ implements spectrum matching technology that allows you to transfer the 
spectral shape of one recording to another. In other words, you can copy the 
frequency balance of existing time-proven mixes so that other mixes can be 
improved. CurveEQ’s filters can be switched between linear-phase and 
minimum-phase modes. CurveEQ also features a customizable spectrum analyzer. 
Furthermore, you can display, save, and load static spectrum plots for comparison 
and matching purposes.
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Main Layout

Title Bar

Plug-in instance name

This text box allows you to name the current plug-in instance.

Bypass

Use this button to compare the sound of the unprocessed signal to that of the 
processed signal. The Bypass button does not reduce the plug-in’s CPU load 
when switched on.

General Control Bar

Presets selector

Allows you to store and restore custom settings.

Undo

Allows you to undo changes.
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History

Opens a change log that lists up to 32 changes in the order you have made 
them.

Parameter changes are logged with the group name in parentheses, for 
example, Gain (Ls) change.

Redo

Allows you to redo changes that were undone.

A/B

By pressing the A/B button, you can switch between two plug-in states (A 
and B).

A>B (B>A)

Copies the current plug-in state to the other state (A or B). This is useful to 
copy programs between Session Bank slots.

Reset

This is the master reset button. It resets the plug-in to its default state. The 
default state can be chosen in the Preset Manager window.

Routing selector

The Routing button opens the Channel Routing Window, where you can 
change several routing options. The pop-up menu provides access to 
common routing options.

Save CSV

Allows you to save the selected EQ curve in a comma-separated text file. The 
EQ curve is stored as series of frequency/gain pairs, one per line, in the 
following form:

20.00,3.00

400.00,2.51

1000.00,1.45 # comment

5000.00,3.40

20000.00,1.05

Each pair defines the position of a single control point on the CurveEQ’s 
control surface. Write decimal points as a period, not as a comma. Comments 
can be added at any position, starting with a hash character.

Load CSV

Allows you to load a previously saved CSV file or any externally generated EQ 
curve specification, such as room correction or RIAA phono correction. 
Frequencies defined in the file should lie between 20 and 20000 Hz.

Settings

Allows you to change general settings.
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EQ Top Control Bar

Equalizer dB gain range

Lets you change the maximum boost/decrease of frequencies per band.

MIN-Phase

Enables minimum-phase filtering instead of linear-phase filtering. 
Minimum-phase filtering sounds better at steeper EQ slopes because it lacks 
pre-ringing artifacts present in linear-phase filters. Furthermore, it does not 
add a considerable processing latency.

Static & Match

Opens the Static Spectrums Editor where you can display static spectrums 
and perform spectrum matching. Spectrum matching allows you to match the 
spectrum shape of a sound recording to that of another sound recording.

Mode selector

Allows you to select a mode for spectrum matching.

Edit

Opens the Spectrum Mode Editor.

Main EQ Control Surface

The heart of CurveEQ is the equalizer control surface with a built-in real-time 
spectrum analyzer.

• To add a control point, double-click the curve.

• To delete a control point, double-click it.

The picture above shows the equalizer control surface with control points that can 
be dragged to adjust the filter’s gain and frequency.
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The readouts show the mouse cursor position within the display, the musical note 
and detune in cents that correspond to the frequency position, and the mouse 
cursor position within the spectrum power range.

If two or three curves are displayed, a white curve shows the summary frequency 
response of all enabled filters.

While dragging a control point with the mouse, you can adjust the filter’s bandwidth 
by additionally holding the right mouse button or pressing . Alternatively,  

use the mouse wheel to adjust the filter’s bandwidth.

• To enable the gain adjustment only, press  while dragging a point.

• To enable frequency adjustment only, press -

• To set a control point to 0 dB, press , and double-click it.

Equalizer – Group Editing

You can perform editing operations on a group of control points.

• To select several control points, click inside the equalizer control surface and 
drag a rectangle over the control points that you want to select.

• To select all control points at once, right-click the control surface.

• To deselect any selected points, click in the control surface.

• To add control points to the current selection, press and click the control 
points that you want to add.

• To remove control points from the selection, hold  and click the control point 
that you want to remove.

For group editing, the following controls are available:

Up/down arrow button

Allows you to change the relationship of the selected control points.

Inv

Inverts the gain of the selected control points.

Reset

Resets the current filter to its default state.
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Equalizer - Spectrum

The equalizer control surface can display the Fourier spectrum analysis plot. The 
spectrum analysis and the display of parameters can be selected via the Mode 
selector. The Spectrum Mode Editor can be used to customize these parameters 
further. You can also click the control surface anywhere to reset the spectrum 
analysis display.

A red vertical line is displayed if the visible frequency range is wide. This line shows 
the maximum frequency of the input signal and depends on the input sample rate.

By default, Voxengo plug-ins use a slope value of 4.5 dB per octave for the 
spectrum display. This setting can be changed in the Spectrum Mode Editor 
window.

To zoom in on the spectrum’s peak values, -click and drag a selection rectangle.

If the spectrum does not fit the display, adjust the visible spectrum range in the 
Spectrum Mode Editor.

Equalizer - Narrow-Band Sweeping

To highlight the resonances in the sound, you can enable the narrow-band 
sweeping function by pressing  and dragging in the control surface with the mouse. 
As a result of this action, the curve of the band-pass filter only passes the selected 
frequency range. You can adjust the bandwidth of the filter with the mouse wheel.

The band-pass filter’s curve is applied on top of the existing equalizer curve. This 
means that the curve you see when engaging the narrow-band sweeping is 
composed of the existing equalizer curve and band-pass filter’s own equalizer 
curve.

Zooming

• To zoom into the spectrum display, press  and drag the control surface.

• To zoom out of the spectrum display, press  and double-click the 
surface.

Scrollbar

The horizontal and vertical scrolling controls feature zooming functionality. The 
scrollbars are found at the sides of the equalizer control surface.

The diamond-shaped button between a horizontal and vertical scrollbar can be 
used to control the positions of both scrollbars at once in a single X-Y coordinate 
space.

You can double-click scrollbars and diamond-shaped buttons to quickly switch 
between the zoomed and non-zoomed views of the control surface.
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EQ Bottom Control Bar

Hide Points

Hides the control points, which allows you to evaluate the EQ curve more 
precisely.

Freeform

Enables freeform mode, in which you can draw the EQ curve manually by 
drawing on the control surface with the left mouse button.

Note that switching to freeform mode and back can be destructive and some 
EQ curve features can be lost.

Curve 1/2/3

You can define up to 3 equalizer curves for every channel group. This is useful 
if you are using spectrum matching. For example, you can apply a matching 
EQ curve generated automatically and at the same time apply any additional 
EQ curve that you draw manually.

Note that CurveEQ has a lower resolution at the frequencies below 200 Hz. 
At these frequencies, the EQ curve does not always follow the control point 
positions.

Underlay

Allows you to select another EQ curve from any other channel group that is 
displayed as an underlay.

Up/down arrow button

Allows you to scale the gain of the EQ curve.

Inv

Inverts the current EQ curve.

Copy To

Copies the envelope to the same envelope in another group.

Reset

Resets the current EQ curve to its default state.

Group Bar and Hint Line
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Group 1/2/3/4

These buttons represent the channel groups. You can select the channel 
group whose parameters are being edited or monitored. Only groups that are 
assigned to the internal channels in the Channel Routing window are shown.

Solo

Allows you to solo the output of the selected group. The state of the Solo 
button is not saved between project sessions and is not restored when the 
project is reloaded.

Copy To

Allows you to copy parameter settings defined for the selected channel group 
to another channel group.

Reset

Resets the parameters of the active group.

NOTE

Note that the group bar is not visible if the Min Infrastructure option in the Settings 
window is activated. In that case, you can use the Routing selector to select a 
channel group.

Channel Group List

CurveEQ shows a list of input channels that are routed to the selected channel 
group. This list is connected to the Channel Routing window and displays routing 
settings defined by it. Internal channel names (A, B, C, etc.) that accept the 
corresponding input channel are displayed in a superscript style. These internal 
channel names are also displayed on the level meters. If more than one input 
channel is routed to the same internal channel, the sum is displayed in the form 
“(IN1+IN2)”.

When the internal channel is assigned to a mid/side group, its input channels are 
written in parentheses with the “m” (mid) or “s” (side) prefix. For example, “s(IN1 & 
IN2)” means “side part of the mid/side pair consisting of IN1 and IN2 input 
channels”.

Hint Line

This interface element displays hint messages and can also display other 
informational messages. The hint line can be disabled in the Settings window.

Level Meter

The level meter shows several bars that correspond to the channels (A, B, etc.) of 
the selected channel group. The level meter displays all available channels if the 
Show All Channel Meters button is activated in the Channel Routing window.
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Level meters can show a small horizontal white bar that represents the peak level. 
In output level meters, such as peak level, it can turn red. This means that the output 
level has entered the area above the 0 dBFS signal level and clipping can occur if 
the plug-in is inserted at the final position in the signal chain of the host application. 
If the plug-in is inserted in an intermediate position, that is, before other plug-ins, 
clipping does not necessarily occur.

Level meter ballistics and peak level hold time can be defined for all instances of the 
plug-in in the Settings window.

Output level meters usually feature a Out/In display, showing the difference in RMS 
level between the input and output signals of the plug-in.

Spectrum Matching

With CurveEQ you can match the sound of any audio track to another, whether it is 
your to-die-for guitar into or your favorite kick drum sample.

All spectrum related functions are located in the Static & Match display.

NOTE

Spectrum matching uses parameters specified in the Spectrum Mode Editor. Only 
spectrums present in static spectrum slots can be used for matching. The usual 
realtime primary and secondary spectrums are not used for matching, unless taken 
as snapshots by means of the Take or Take 2nd buttons.

When you perform spectrum matching it is suggested to set the Type selector in 
the Spectrum Mode Editor to Avg, so that average spectrum is used for matching. 
You must run the averaging for several seconds until the visible spectrum becomes 
smooth enough. After achieving the required spectrum shape on the screen you can 
click the Take (or Take 2nd) button in the static spectrum slot to store this 
spectrum for matching purposes.

You need at least two spectrum snapshots in two slots for matching. The spectrum 
that you want to equalize and the reference spectrum should be marked with the 
Apply To and Reference switches. You can define more than one Apply To or 
Reference spectrum. In that case the mean value of the spectrums is used.
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The Points parameter specifies how many measuring points to use for matching. 
The more points you use the more precise the match will be. However, in many 
cases more precise match does not mean a better sounding match. It is suggested 
to try several values to determine which one sounds best.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

The EQ curve present on the screen affects the spectrum averaging process, so the 
EQ curve should be flat when spectrum data is being collected.

NOTE

The static spectrum’s gain shift has no effect on the matching process.

Spectrum Mode Editor

Spectrum matching options are placed in the Spectrum Mode Editor, which can be 
opened by clicking the Edit button on the EQ top control bar.

Spectrum Disable

Disables the spectrum analysis function of the plug-in.

Filled Display

Enables additional semi-transparent filling of the spectrum display.

2nd Spectrum

Enables the secondary spectrum curve, which is displayed in a darker color.
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Type selector

Allows you to select a spectrum analysis type. The RT Avg mode applies 
realtime spectrum averaging analysis. This type of analysis produces an 
RMS-averaged spectrum over the period specified by the AVG Time 
parameter. The analysis type Max produces a cumulative maximum power 
spectrum. The Avg type produces a cumulative average power spectrum. The 
RT Max mode produces a realtime maximum spectrum with spectrum 
fall-down. For better spectrum maximum estimate, use a higher Overlap 
setting. If you need an infinite peak hold, use the Max analysis type.

Block Size

Specifies the block size of the FFT (fast Fourier transform) spectrum analyzer. 
Higher block sizes provide more resolution in the lower frequency range, but 
decrease time coherence (time precision) in the higher frequency range; the 
higher frequency information becomes over-averaged. Also, at higher block 
size settings the spectrum is refreshed less frequently. This can be 
compensated by increasing the Overlap parameter.

When working at increasingly higher sample rates, you need to increase the 
block size value, because the setting is used over the full spectral bandwidth. 
Therefore, at higher sample rates the analyzer’s resolution in the visible 
frequency range will be lower for the given block size.

If you want to measure the frequency of a low-frequency sound such as a 
drum or bass guitar precisely, use a higher Block Size value along with a 
higher Overlap value.

In order to avoid clicks and glitches in playback when using high Block Size 
values, you need to increase the audio buffer size in your host application.

2nd Type

If 2nd Spectrum is activated, you can use this pop-up menu to select an 
analysis type for the secondary spectrum. For example, by setting the 2nd 
Type to RT Max and Type to RT Avg, you can see the average and maximum 
spectrums simultaneously.

Note that the secondary spectrum uses the same Block Size and Avg Time 
values as the primary spectrum.

Overlap

Controls the overlap between the adjacent FFT spectrum analysis windows. 
Higher overlap values allow spectrum to be updated more frequently at the 
expense of a higher CPU load.

AVG Time

Specifies the average (fall-down) time used when the RT Avg or RT Max 
analysis is active. This value specifies after how many milliseconds the 
spectrum level falls down by 20 dB.

Smoothing

Lets you select the smoothing function’s resolution. Smoothing produces a 
drop of 6 dB per octave when stationary sine wave signals are used. For 
example, even if the signal consists of 2 sine waves (1 kHz and 2 kHz) of equal 
peak amplitude, the 2 kHz sine wave looks like it is 6 dB quieter. This happens 
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because the fast Fourier transform produces a narrower spectrum for 
high-frequency stationary signals in comparison to low-frequency stationary 
signals. This drop does not appear when non-stationary (musical) signals are 
analyzed.

Freq Low/Freq High

Specify the visible frequency range of the spectrum view.

Range Low/Range High

Specify the accessible spectrum power range.

Slope

Allows you to adjust slope in the spectrum analyzer display around 1 kHz. 
Skewing the spectrum can be useful because higher frequencies usually have 
weaker power in comparison to the lower frequencies. By choosing an 
appropriate spectrum slope, you can compensate for this fact.

Static Spectrums Editor

CurveEQ features a static spectrum display that can be controlled via the Static 
Spectrums Editor.

You can select the display name of the spectrum slot, its color, and the shift in dB 
of the static spectrum. The static spectrum can be shown or hidden using the 
visibility checkbox. The shift in dB can be used for a more convenient placing of the 
static spectrum on the screen and it does not affect the shape of the spectrum.

Take/Take 2nd

These buttons take a snapshot of the primary or secondary spectrum. The 
static spectrum snapshots are taken using the spectrum parameters specified 
in the Spectrum Mode Editor.

Before taking a spectrum, choose a spectrum analysis type via the Spectrum 
Mode Editor, usually Avg or Max, and analyze long enough so that the 
spectrum becomes general enough. When analyzing a song, it is 
recommended to store separate spectrums for verse, chorus, and bridge 
parts, as they can have distinctively differing spectral balance.
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If no snapshot is taken after pressing a Take button, no spectrum is available. 
You either have to configure the spectrum mode or start the audio playback 
first.

Load/Save

You can save the spectrum in a static spectrum slot as a spectrum file with 
the extension .csf (compressed spectrum file).

X

Removes the spectrum in the selected slot.

Preset Manager

You can use the main preset manager to save and load plug-in state presets.

Presets in the main preset manager are shared among all instances of the same 
Voxengo plug-in. All presets within the main preset manager are stored in user 
preset banks. Beside user preset banks two special banks exist: the Session Bank 
and Factory ROM bank.

The Session Bank contains programs rather than presets. Each program in the 
Session Bank contains its own undo/redo change log. The Session Bank lists 
programs that mirror programs of the host application. When you activate a 
program in the Session Bank, the program in the host application switches.

The Factory ROM bank contains presets that cannot be changed. The Factory ROM 
bank is loaded into the Session Bank every time a new instance of the plug-in is 
created in the host application.

The main preset manager contains the following control buttons:

+/-

Allow you to add and remove a bank or preset. Right-clicking the plus button 
(+) inserts the preset at the current list position rather than at the end of the 
list.

Load/Save

Allow you to save and load the bank or preset to and from a file.
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U

Updates the selected preset with the current plug-in state.

Set as Default

Makes the selected preset the default preset. The default preset is loaded 
every time a new plug-in instance is created in the host application or when 
the master Reset button is pressed. If you want to restore the original default 
preset, select the “Default” preset in the Factory ROM bank and click the “Set 
as Default” button.

Activate

Loads the selected preset. You can also double-click a preset name.

NOTE

Voxengo plug-ins use a proprietary format to store presets and preset banks. Add 
a meaningful prefix to bank and preset file names so that you do not mix up presets 
created in different Voxengo plug-ins. Voxengo plug-in preset files have the 
extension .cpf, preset bank files the extension .cbf.

To rename a preset or bank, select it and after a small delay click the item again.

Channel Routing Window

In the Channel Routing window, the following options are available:

Routing Presets

Opens a window that contains presets for the Channel Routing window, 
including channel labels.

Show all Channel Meters

Enables displaying of all channel meters and statistics counters regardless of 
the selected channel group. When this option is deactivated, only meters 
belonging to the selected channel group are shown.
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Activating this option is useful when you are using dual-mono or mid-side 
processing. This option allows you to see channel meters for left and right, or 
mid and side channels together.

Input and Output Routing

Allow you to route external plug-in inputs to internal plug-in channels and vice 
versa, and to route internal plug-in channels to external plug-in outputs. The 
plug-in has a pre-defined number of internal channels, but the number of input 
and output channels can vary depending on the host application’s track or 
bus on which the plug-in is inserted.

Note that if the input routing selector is red, the selector refers to a 
non-existent input channel. You can correct this by selecting an existing 
channel. External side-chain inputs are denoted by parenthesized labels, for 
example, (IN3), (IN4).

Mid/Side Pairs

Allow you to assign internal channels to mid/side pairs for encoding and 
decoding. The mid/side encoding is a wide-spread technique that allows you 
to process the middle (center) and side (spatial) information in stereo signals 
independently of each other, thus offering a great deal of control over that 
signal’s stereophony.

Mid/side encoding works with paired channels only and thus requires two 
channels to be assigned to the same mid/side pair. An input signal is mid/side 
encoded before it is processed by the plug-in, and decoded afterwards 
before it is routed to an output of the plug-in.

Group Assignments

The plug-in allows you to assign its internal audio channels to logical channel 
groups. Each group is affected by its own set of parameter values (EQ shape, 
gain factor, etc.). The current channel group is selected via the channel group 
selector.

Individual audio channels can be assigned to different channel groups. For 
example, you can make separate EQ settings for channel 1 and for channel 2 
by assigning channel 1 to group 1 and channel 2 to group 2.

In a surround setup you can assign left and right channels to group 1 and 
surround channels to group 2, and apply different EQ shapes to the groups.

Each plug-in audio channel can be assigned to a single channel group only. 
Channel grouping also affects channel-linking in case of dynamics 
processing and other processes that estimate signal loudness envelope: 
channels assigned to the same group are linked during processing and signal 
loudness estimation.

IN Channel Labels

Opens the label assignment window where you change the display names for 
the input channels.

You can also import channel labels from the host application by pressing the 
“Import labels from host” button. However, not all host applications provide 
distinctive input channel names.
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Group Names

Opens the group names where you can change the display names for the 
groups.

CurveEQ Settings

In the CurveEQ Settings window the following parameters are available:

Color scheme

The icons show possible color schemes. To change the color scheme, click 
an icon.

UI scale

Adjusts the size of the plug-in panel. Note that changing this setting requires 
a restart of the host application.

Show hints

If activated, hint messages appear at the bottom of the plug-in panel.

Min Infrastructure

Activate this to hide part of the plug-in interface in favor of showing a larger 
EQ control surface.

Level meter settings – Density mode

Activates the density metering mode. In this mode you can see levels at which 
a signal stays often. By examining the range of levels at which a signal stays, 
you can draw conclusions about the effective dynamic range of the material.

Note that the signal level estimation is affected by the meter’s integration and 
release times. In this mode, the display of the signal level is also affected by 
the Peak Level hold time setting.
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Level meter settings – Integration time

Affects the level integration time of all level meters. The value reflects the time 
it takes for a signal level to fall down by 20 dB, or raise up from one steady 
level to another steady level.

Note that this setting does not affect the peak level on the level meters, but 
affects the visible difference between the peak and RMS levels when a 
musical signal is measured.

Level meter settings – Release Time

Changes the level meter’s release time. This is the time it takes for a signal to 
fall down by 20 dB.

Level meter settings – Peak level hold time

Adjusts the time that a registered peak level with a width of 1 sample stays 
unchanged on the level meter.

Global Plug-in Settings

The global plug-in settings can be accessed via the Settings window. The following 
parameters are available:

Mouse Wheel Precision

Affects the precision of the mouse wheel. The higher the precision, the finer 
the value changes using the mouse wheel.

SHIFT Key Precision

Affects the precision when using  and dragging a control with the mouse.

Drag Precision

Affects how quickly knobs and readouts react to mouse movements.

Visual settings

You can customize the look of the plug-in with the following settings:
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• Flat Panels – When enabled, all buttons and panels of the plug-in look 
flat, without a gradient fill.

• Spotlight – Enables a wide light area that looks like a spotlight.

• Textures – Adds texture to the plug-in panel.

• Shadows – Enables shadows on graphical elements.

• Flat Level Meters – Enables the flat, non-blocky look of the level meters.

Show Knob Labels

Enables numeric labels that appear when you point the mouse at a knob.

Tablet Mode

When activated, you can control the plug-in with a pen tablet.

Show Virtual Keyboard

When this is activated, a virtual computer keyboard is shown when you enter 
values. The virtual computer keyboard is useful if the host application blocks 
some keys from reaching the plug-in’s user interface.

Radial Knob Mode

When this is activated, you can click on the corona to set the parameter value 
immediately.

Control Surface Crosshair

Displays a crosshair cursor in the control surface area.

Anti-Denormal Noise

Enables insertion of anti-denormalization noise on the plug-in inputs. This 
noise has an RMS value of -220 dB – well below the audible dynamic range. 
If you are using the plug-in in a host application that applies such noise 
automatically, you can deactivate this option to save CPU power. Without 
anti-denormalization noise the filters of the plug-in can overload the CPU 
when silence is processed.

Remember Window Positions

When this is activated, the relative position of the plug-in windows is 
remembered after reopening the plug-in.

Show All Filter Shapes

When this is activated, all active filters are shown together with the shape of 
the selected filter.

Do Not Show Latency Changes

Disables the Latency Changed warning message completely.
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Standard Control Elements in Detail

Knob

Knobs can be controlled as follows:

• If Radial Knob Mode is activated, you can drag the corona of a knob to adjust 
the value of the corresponding parameter. During dragging, you can move the 
mouse cursor away from the knob to increase value adjustment precision.

• Drag the center of a knob to adjust the value of the parameter with up and 
down mouse movements, linearly. If you press the left and right mouse buttons 
together while dragging the center, you enter high-precision adjustment 
mode. You can also enter this mode by holding down  when dragging. The 
dragging precision can be adjusted in the global settings window.

• Turn the mouse wheel to adjust the parameter.

• Double-click a knob to reset it to the default state.

When you point the mouse at a knob, an additional ring shows approximate 
parameter values at different knob positions. These values are also referred to as 
knob labels. Thousands are suffixed with an asterisk (2*). This ring can be disabled 
in the global settings window.

Keyboard Value Entry

Most readout values such as gain or frequency can be clicked to enter a new value.

Value List Selector

This type of control allows you to choose a value or an option from the list. You can 
click the selector button to display the value list. You can also use the mouse’s 
forward and backward buttons or the mouse wheel to scroll through the values of a 
list without opening it.

To reset a value list to its default value, right-click the selector.

Slider

Sliders can be dragged with the left mouse button. If you press the left and right 
mouse buttons together while dragging the slider, you enter high-precision 
adjustment mode. You can also enter this mode by holding down  when dragging.

Location of CurveEQ Files

CurveEQ creates settings files, including presets. All CurveEQ settings and presets 
are available to the specific user of the computer only.

On Windows systems, the files reside in the following folder: \Users\<user 
name>\ Application Data\Voxengo\Audio Plug-ins\.
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On Mac OS X systems, the files reside in the following folder: /Users/<user 
name>/Library/Preferences/ Voxengo/Audio Plug-ins/.

You can safely remove, copy and replace these files, including the whole 
Voxengo\Audio Plug-ins\ subfolder.

DeEsser

This effect reduces excessive sibilance, primarily for vocal recordings. It is a special 
type of compressor that is tuned to be sensitive to the frequencies produced by the 
s-sound.

Close proximity microphone placement and equalizing can lead to situations where 
the overall sound is just right, but there is a problem with sibilants.

Reduction

Controls the intensity of the de-essing effect.

Threshold

If the Auto option is deactivated, you can use this control to set a threshold 
for the incoming signal level above which the plug-in starts to reduce the 
sibilants.

Release (1 to 1000 ms)

Sets the time after which the de-essing effect returns to zero when the signal 
drops below the threshold.
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Auto

Automatically and continually chooses an optimum threshold setting 
independent of the input signal. The Auto option does not work for low-level 
signals (< -30 db peak level). To reduce the sibilants in such a file, set the 
threshold manually.

Level meters

Indicate the dB values of the input (IN) and output (OUT) signals as well as 
the value by which the level of the sibilant (or s-frequency) is reduced (GR). 
The gain reduction meter shows values between 0 dB (no reduction) and 
-20 dB (the s-frequency level is lowered by 20 dB).

Distortion

Distortion adds crunch to your tracks.

Boost

Increases the distortion amount.

Feedback

Feeds part of the output signal back to the effect input. Higher settings 
increase the distortion effect.

Tone

Lets you select a frequency range to which to apply the distortion effect.

Spatial

Changes the distortion characteristics of the left and right channels, thus 
creating a stereo effect.

Output

Sets the output level.

DualFilter

This plug-in filters out specific frequencies while allowing others to pass through.
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Position

Sets the filter cutoff frequency. If you set this to a negative value, DualFilter 
acts as a low-pass filter. Positive values cause DualFilter to act as a high-pass 
filter.

Resonance

Sets the sound characteristic of the filter. With higher values, a ringing sound 
is heard.

EnvelopeShaper

This plug-in can be used to attenuate or boost the gain of the attack and release 
phase of audio material.

You can use the knobs or drag the breakpoints in the graphical display to change 
parameter values. Be careful with levels when boosting the gain and if needed 
reduce the output level to avoid clipping.

Attack (-20 to 20 dB)

Sets the gain of the attack phase of the signal.

Length (5 to 200 ms)

Sets the length of the attack phase.

Release (-20 to 20 dB)

Sets the gain of the release phase of the signal.
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Output

Sets the output level.

Expander

Expander reduces the output level in relation to the input level for signals below the 
set threshold. This is useful if you want to enhance the dynamic range or reduce the 
noise in quiet passages.

You can either use the knobs or drag the breakpoints in the graphical display to 
change the Threshold and the Ratio parameter values.

Threshold (-60 to 0 dB)

Determines the level where the expansion kicks in. Only signal levels below 
the set threshold are processed.

Ratio

Sets the amount of gain boost applied to signals below the threshold.

Soft Knee

If this button is deactivated, signals below the threshold are expanded 
instantly according to the set ratio (hard knee). If Soft Knee is activated, the 
onset of expansion is more gradual, producing less drastic results.

Fall (0.1 to 100 ms)

Determines how fast the expander responds to signals below the set 
threshold. If the fall time is long, more of the early part of the signal passes 
through unprocessed.

Hold (0 to 2000 ms)

Sets the time the applied expansion affects the signal below the threshold.

Rise (10 to 1000 ms or Auto mode)

Sets the time after which the gain returns to its original level when the signal 
exceeds the threshold. If the Auto button is activated, the plug-in 
automatically finds the best rise setting for the audio material.
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Analysis (Pure Peak to Pure RMS)

Determines whether the input signal is analyzed according to peak or RMS 
values, or a mixture of both. A value of 0 is pure peak and 100 pure RMS. RMS 
mode operates using the average power of the audio signal as a basis, 
whereas Peak mode operates more on peak levels. As a general guideline, 
RMS mode works better on material with few transients such as vocals, and 
Peak mode works better for percussive material with a lot of transient peaks.

Live

If this button is activated, the look-ahead feature of the effect is deactivated. 
Look-ahead produces more accurate processing, but adds a specific amount 
of latency as a trade-off. If Live mode is activated, there is no latency, which 
is better for live processing.

Gate

Gating, or noise gating, silences audio signals below a set threshold. As soon as 
the signal level exceeds the threshold, the gate opens to let the signal through.

Threshold (-60 to 0 dB)

Determines the level where the gate is activated. Signal levels above the set 
threshold trigger the gate to open, and signal levels below the set threshold 
close the gate.

State LED

Indicates whether the gate is open (LED lights up in green), closed (LED 
lights up in red) or in an intermediate state (LED lights up in yellow).

Filter buttons (LP, BP, and HP)

If the Side-Chain button is activated, you can use these buttons to set the 
filter type to low-pass, band-pass, or high-pass.

Side-Chain

Activates the internal side-chain filter. The input signal can then be shaped 
according to the filter parameters. Internal side-chaining is useful for tailoring 
how the gate operates.



Plug-in Reference
Steinberg VST 3 Plug-ins

777

Center (50 to 20000 Hz)

If the Side-Chain button is activated, this sets the center frequency of the 
filter.

Q-Factor

If the Side-Chain button is activated, this sets the resonance or width of the 
filter.

Monitor

Allows you to monitor the filtered signal.

Attack (0.1 to 1000 ms)

Sets the time after which the gate opens when it is triggered.

NOTE

Deactivate the Live button to make sure that the gate is already open when a 
signal above the threshold is played back.

Hold (0 to 2000 ms)

Determines how long the gate remains open after the signal drops below the 
threshold level.

Release (10 to 1000 ms or Auto mode)

Sets the time after which the gate closes (after the set Hold time). If the Auto 
button is activated, Gate automatically finds the best release setting for the 
audio material.

Analysis (Pure Peak to Pure RMS)

Determines whether the input signal is analyzed according to peak or RMS 
values, or a mixture of both. A value of 0 is pure peak and 100 pure RMS. RMS 
mode operates using the average power of the audio signal as a basis, 
whereas Peak mode operates more on peak levels. As a general guideline, 
RMS mode works better on material with few transients such as vocals, and 
Peak mode works better for percussive material with a lot of transient peaks.

Live

If this button is activated, the look-ahead feature of the effect is deactivated. 
Look-ahead produces more accurate processing, but adds a specific amount 
of latency as a trade-off. If Live mode is activated, there is no latency, which 
is better for live processing.

GEQ-10/GEQ-30

These graphic equalizers are identical, except for the number of available frequency 
bands (10 and 30).
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Each band can be attenuated or boosted by up to 12 dB, allowing for fine control 
of the frequency response. In addition, there are several preset modes available that 
can add color to the sound of GEQ-10/GEQ-30.

You can draw response curves in the main display by clicking and dragging with the 
mouse. You have to click one of the sliders before you drag across the display.

At the bottom of the window, the individual frequency bands are shown in Hz. At the 
top of the display, the amount of attenuation/boost is shown in dB.

Output

Sets the overall gain of the equalizer.

Flatten

Resets all the frequency bands to 0 dB.

Range

Allows you to adjust how much a set curve cuts or boosts the signal.

Invert

Inverts the current response curve.

Mode pop-up menu

This pop-up menu allows you to set the filter mode that determines how the 
various frequency band controls interact to create the response curve.

EQ Modes

The Mode pop-up menu in the lower right corner allows you to select an EQ mode, 
which add color or character to the equalized output in various ways.

True Response

Applies serial filters with an accurate frequency response.

Digi Standard

In this mode, the resonance of the last band depends on the sample rate.

Classic

Applies a classic parallel filter structure where the response does not follow 
the set gain values accurately.
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VariableQ

Applies parallel filters where the resonance depends on the amount of gain.

ConstQ u

Applies parallel filters where the resonance of the first and last bands 
depends on the sample rate.

ConstQ s

Applies parallel filters where the resonance is raised when boosting the gain 
and vice versa.

Resonant

Applies serial filters where a gain increase of one band lowers the gain in 
adjacent bands.

Limiter

This plug-in is designed to ensure that the output level never exceeds a set output 
level, to avoid clipping in following devices.

Limiter can adjust and optimize the Release parameter automatically according to 
the audio material, or it can be set manually. Limiter also features separate meters 
for the input, output and the amount of limiting (middle meters).

Input (-24 to 24 dB)

Sets the input gain.

Output (-24 to 6 dB)

Sets the maximum output level.

Release (0.1 to 1000 ms or Auto mode)

Sets the time after which the gain returns to its original level. If the Auto button 
is activated, the plug-in automatically finds the best release setting for the 
audio material.

L/R -> M/S, M/S -> L/R

This plug-in allows you to convert a stereo signal into a M/S signal and vice versa.
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The L/R -> M/S tool converts a L/R signal that is divided into a left and a right signal 
into a M/S signal that is divided into a mid signal (L+R) and side signals (L-R).

The M/S -> L/R tool reconverts the M/S signal into a L/R signal.

Maximizer

This plug-in raises the loudness of audio material without the risk of clipping.

Output (-24 to 6 dB)

Sets the maximum output level.

Optimize

Determines the loudness of the signal.

Soft Clip

If this button is activated, Maximizer starts limiting or clipping the signal softly. 
At the same time, harmonics are generated, adding a warm, tube-like 
characteristic to the audio material.

Mix6to2

This plug-in lets you quickly mix down your surround mix format to stereo. You can 
control the levels of up to six surround channels and decide for each channel up to 
which level it is included in the resulting mix.

NOTE

This plug-in does not simulate a surround mix or add any psycho-acoustical artifacts 
to the resulting output – it is simply a mixer. The plug-in is only available in the 
Master Section and if a surround audio montage is active.
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Surround Channels

Volume

Govern how much of the signal is included in the left and/or right channel of 
the output bus.

Link

Link the volume faders.

Invert

Invert the phase of the left and right channel of the surround bus.

Output Bus

Volume

Set the volume of the of the mixed output.

Link

Links the Output faders.

Normalize

If this option is activated, the mixed output is normalized. For example, the 
output level is automatically adjusted so that the loudest signal is as loud as 
possible without clipping.

Mix8to2

This plug-in lets you quickly mix down your surround mix format to stereo. You can 
control the levels of up to eight surround channels and decide for each channel up 
to which level it is included in the resulting mix.
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This plug-in does not simulate a surround mix or add any psycho-acoustical artifacts 
to the resulting output – it is simply a mixer. The plug-in is only available in the 
Master Section and if a 8 channel audio montage is active.

Surround Channels

Volume

Govern how much of the signal is included in the left and/or right channel of 
the output bus.

Link

Link the volume faders.

Invert

Invert the phase of the left and right channel of the surround bus.

Output Bus

Volume

Set the volume of the of the mixed output.

Link

Links the Output faders.

Normalize

If this option is activated, the mixed output is normalized. For example, the 
output level is automatically adjusted so that the loudest signal is as loud as 
possible without clipping.

MonoDelay

This is a mono delay effect that can either be tempo-based or use freely specified 
delay time settings.
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Delay

If tempo sync is activated, this sets the base note value for the delay. If tempo 
sync is deactivated, the delay time can be set freely in milliseconds.

Sync

Activates/Deactivates tempo sync.

Feedback

Sets the number of repeats for the delay.

Filter Lo

Affects the feedback loop of the effect signal and allows you to roll off low 
frequencies. The button below the knob activates/deactivates the filter.

Filter Hi

Affects the feedback loop of the effect signal and allows you to roll off high 
frequencies. The button below the knob activates/deactivates the filter.

Mix

Sets the level balance between the dry signal and the wet signal. If the effect 
is used as a send effect, set this parameter to the maximum value as you can 
control the dry/effect balance with the send.

MonoToStereo

This effect turns a mono signal into a pseudo-stereo signal. The plug-in can be used 
on a mono file or a stereo file with equal channels.

Width

Controls the width or depth of the stereo enhancement. Turn clockwise to 
increase the enhancement.
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Delay

Increases the amount of differences between the left and right channels to 
further increase the stereo effect.

Color

Generates additional differences between the channels to increase the stereo 
enhancement.

Mono

Switches the output to mono, to check for possible unwanted coloring of the 
sound which sometimes can occur when creating an artificial stereo image.

MultibandCompressor

MultibandCompressor allows a signal to be split into four frequency bands. You can 
specify the level, bandwidth, and compressor characteristics for each band.
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Frequency Band Editor

The frequency band editor in the upper half of the panel is where you set the width 
of the frequency bands as well as their level after compression. The vertical value 
scale to the left shows the gain level of each frequency band. The horizontal scale 
shows the available frequency range.

• To define the frequency range of the different frequency bands, use the 
handles at the sides of each frequency band.

• To attenuate or boost the gain of the frequency bands by ±15 dB after 
compression, use the handles at the top of each frequency band.

Live

If this button is activated, the look-ahead feature of the effect is deactivated. 
Look-ahead produces more accurate processing, but adds a specific amount 
of latency as a trade-off. If Live mode is activated, there is no latency, which 
is better for live processing.

Bypassing Frequency Bands

To bypass each frequency band, activate the Bypass Band button  in each 
section.

Soloing Frequency Bands

To solo a frequency band, activate the S button in each section. Only one 
band can be soloed at a time.

Output (-24 to 24 dB)

Sets the output level.

Compressor Section

You can specify the Threshold and Ratio by moving breakpoints or using the 
corresponding knobs. The threshold is marked by the first breakpoint where the line 
deviates from the straight diagonal.

Threshold (-60 to 0 dB)

Determines the level where the compressor kicks in. Only signal levels above 
the set threshold are processed.

Ratio

Sets the amount of gain reduction applied to signals above the set threshold. 
A ratio of 3:1 means that for every 3 dB the input level increases, the output 
level increases by 1 dB.

Attack (0.1 to 100 ms)

Determines how fast the compressor responds to signals above the set 
threshold. If the attack time is long, more of the early part of the signal passes 
through unprocessed.
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Release (10 to 1000 ms or Auto mode)

Sets the time after which the gain returns to its original level when the signal 
drops below the threshold. If the Auto button is activated, the plug-in 
automatically finds the best release setting for the audio material.

MultibandEnvelopeShaper

This plug-in allows a signal to be split into four frequency bands. You can attenuate 
or boost the gain of the attack and release phase of audio material for each band.

Frequency Band Editor

The frequency band editor in the upper half of the panel is where you set the width 
of the frequency bands as well as their level. The vertical value scale to the left 
shows the gain level of each frequency band. The horizontal scale shows the 
available frequency range.

• To define the frequency range of the different frequency bands, use the 
handles at the sides of each frequency band.

• To attenuate or boost the gain of the frequency band, use the handles at the 
top of each frequency band.
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Live

If this button is activated, the look-ahead feature of the effect is deactivated. 
Look-ahead produces more accurate processing, but adds a specific amount 
of latency as a trade-off. If Live mode is activated, there is no latency, which 
is better for live processing.

Bypassing Frequency Bands

To bypass each frequency band, activate the Bypass Band button  in each 
section.

Soloing Frequency Bands

To solo a frequency band, activate the S button in each section. Only one 
band can be soloed at a time.

Output (-24 to 24 dB)

Sets the output level.

Shaper Section

You can specify the Attack, Length, and Release by moving breakpoints or using 
the corresponding knobs. Be careful with levels when boosting the gain. You can 
reduce the output level to avoid clipping.

Attack (-20 to 20 dB)

Sets the gain of the attack phase of the signal.

Length (5 to 200 ms)

Sets the length of the attack phase.

Release (-20 to 20 dB)

Sets the gain of the release phase of the signal.

Sensitivity (-40 to -10 dB)

Sets the sensitivity of the detection.

Output

Sets the output level.

MultibandExpander

This plug-in allows a signal to be split into four frequency bands. You can reduce 
the output level in relation to the input level for signals below the set threshold for 
each band. This is useful if you want to enhance the dynamic range or reduce the 
noise in quiet passages.



Plug-in Reference
Steinberg VST 3 Plug-ins

788

Frequency Band Editor

The frequency band editor in the upper half of the panel is where you set the width 
of the frequency bands as well as their level after expansion. The vertical value scale 
to the left shows the gain level of each frequency band. The horizontal scale shows 
the available frequency range.

• To define the frequency range of the different frequency bands, use the 
handles at the sides.

• To attenuate or boost the gain of the frequency band after expansion, use the 
handles on top of each frequency band.

Live

If this button is activated, the look-ahead feature of the effect is deactivated. 
Look-ahead produces more accurate processing, but adds a specific amount 
of latency as a trade-off. If Live mode is activated, there is no latency, which 
is better for live processing.

Bypassing Frequency Bands

To bypass each frequency band, activate the Bypass Band button  in each 
section.
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Soloing Frequency Bands

To solo a frequency band, activate the S button in each section. Only one 
band can be soloed at a time.

Output (-24 to 24 dB)

Sets the output level.

Expander Section

You can specify the Threshold and Ratio by moving breakpoints or using the 
corresponding knobs. The first breakpoint from which the line deviates from the 
straight diagonal is the threshold point.

Threshold (-60 to 0 dB)

Determines the level where the expansion kicks in. Only signal levels below 
the set threshold are processed.

Ratio

Sets the amount of gain boost applied to signals below the threshold.

Maximum Reduction

Sets the maximum amount by which the level is reduced when the signal falls 
below the set threshold.

Fall (0.1 to 100 ms)

Determines how fast the expander responds to signals below the set 
threshold. If the fall time is long, more of the early part of the signal passes 
through unprocessed.

Hold (0 to 2000 ms)

Sets the time the applied expansion affects the signal below the threshold.

Rise (10 to 1000 ms or Auto mode)

Sets the time after which the gain returns to its original level when the signal 
exceeds the threshold. If the Auto button is activated, the plug-in 
automatically finds the best rise setting for the audio material.

Output

Sets the output level.

Side-Chain Section
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Frequency

If the Side-Chain button is activated, this sets the frequency of the side-chain 
filter.

Q-Factor

If the Side-Chain button is activated, this sets the resonance or width of the 
filter.

Side-Chain

Activates the internal side-chain filter. The input signal can then be shaped 
according to the filter parameters. Internal side-chaining is useful for tailoring 
how the gate operates.

Side-Chain

Activates the internal side-chain filter. The side-chain signal can then be 
shaped according to the filter parameters. Side-chaining is useful for tailoring 
how MultibandExpander operates.

Monitor

Allows you to monitor the filtered signal.

Octaver

This plug-in can generate two additional voices that track the pitch of the input 
signal one octave and two octaves below the original pitch. Octaver is best used 
with monophonic signals.

Direct

Sets the level balance between the dry signal and the wet signal. A value of 0 
means that only the generated and transposed signal is heard. By raising this 
value, more of the original signal is heard.

Octave 1

Adjusts the level of the generated signal one octave below the original pitch. 
A setting of 0 means that the voice is muted.

Octave 2

Adjusts the level of the generated signal two octaves below the original pitch. 
A setting of 0 means that the voice is muted.
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PingPongDelay

This is a stereo delay effect that alternates each delay repeat between the left and 
right channels. 

Delay

If tempo sync is activated, this sets the base note value for the delay. If tempo 
sync is deactivated, the delay time can be set freely in milliseconds.

Sync

Activates/Deactivates tempo sync.

Feedback

Sets the number of repeats for the delay.

Filter Lo

Affects the feedback loop of the effect signal and allows you to roll off low 
frequencies. The button below the knob activates/deactivates the filter.

Filter Hi

Affects the feedback loop of the effect signal and allows you to roll off high 
frequencies. The button below the knob activates/deactivates the filter.

Spatial

Sets the stereo width for the left/right repeats. Turn clockwise for a more 
pronounced stereo ping-pong effect.

Mix

Sets the level balance between the dry signal and the wet signal. If the effect 
is used as a send effect, set this parameter to the maximum value as you can 
control the dry/effect balance with the send.

PostFilter

This effect allows quick and easy filtering of unwanted frequencies, creating room 
for the important sounds in your mix.
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The PostFilter plug-in combines a low-cut filter, a notch filter, and a high-cut filter. 
You can make settings by dragging the curve points in the graphical display, or by 
adjusting the controls below the display section.

Level meter

Shows the output level, giving you an indication of how the filtering affects the 
overall level of the edited audio.

Low Cut Freq (20 Hz to 1 kHz, or Off)

Allows you to eliminate low-frequency noise. The filter is inactive if the curve 
point is located all the way to the left. You can set the frequency either in Hz 
or as a note value. If you enter a note value, the frequency is automatically 
changed to Hz. For example, a note value of A3 sets the frequency to 440 Hz. 
When you enter a note value, you can also enter a cent offset. For example, 
enter A5 -23 or C4 +49.

NOTE

Ensure that you enter a space between the note and the cent offset. Only in 
this case, the cent offsets are taken into account.

Low Cut Slope

Allows you to choose a slope value for the low-cut filter.

Low Cut Preview

Use this button between the Low Cut Freq button and the graphical display 
to switch the filter to a complementary high-cut filter. This deactivates any 
other filters, allowing you to listen only to the frequencies that you want to filter 
out.
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Notch Freq

Sets the frequency of the notch filter. You can set the frequency either in Hz 
or as a note value. If you enter a note value, the frequency is automatically 
changed to Hz. For example, a note value of A3 sets the frequency to 440 Hz. 
When you enter a note value, you can also enter a cent offset. For example, 
enter A5 -23 or C4 +49.

NOTE

Ensure that you enter a space between the note and the cent offset. Only in 
this case, the cent offsets are taken into account.

Notch Gain

Adjusts the gain of the selected frequency. Use positive values to identify the 
frequencies that you want to filter out.

Notch Gain Invert

This button inverts the gain value of the notch filter. Use this button to filter out 
unwanted noise. When looking for the frequency to omit, it sometimes helps 
to boost it first (set the notch filter to positive gain). After you have found 
frequency of the noise, you can use the Invert button to cancel it out.

Notch Q-Factor

Sets the width of the notch filter.

Notch Preview

Use the Preview button between the notch filter buttons and the graphical 
display to create a band-pass filter with the peak filter's frequency and Q. This 
deactivates any other filters, allowing you to listen only to the frequencies you 
want to filter out.

Notches buttons (1, 2, 4, 8)

These buttons add additional notch filters to filter out harmonics.

High Cut Freq (3 Hz to 20 kHz, or Off)

This high-cut filter allows you to remove high-frequency noise. The filter is 
inactive if the curve point is located all the way to the right. You can set the 
frequency either in Hz or as a note value. If you enter a note value, the 
frequency is automatically changed to Hz. For example, a note value of A3 
sets the frequency to 440 Hz. When you enter a note value, you can also enter 
a cent offset. For example, enter A5 -23 or C4 +49.

NOTE

Ensure that you enter a space between the note and the cent offset. Only in 
this case, the cent offsets are taken into account.

High Cut Slope

Allows you to choose a slope value for the high-cut filter.
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High Cut Preview

This button between the High Cut Freq button and the graphical display 
allows you to switch the filter to a complementary low-cut filter. This 
deactivates any other filters, allowing you to listen only to the frequencies you 
want to filter out.

RoomWorks

RoomWorks is a highly adjustable reverb plug-in for creating realistic room 
ambience and reverb effects in stereo and surround formats. The CPU usage is 
adjustable to fit the needs of any system. From short room reflections to 
cavern-sized reverb, this plug-in delivers high quality reverberation.

Input Filters

Lo Freq

Determines the frequency at which the low-shelving filter takes effect. Both 
the high and low settings filter the input signal prior to reverb processing.

Hi Freq

Determines the frequency at which the high-shelving filter takes effect. Both 
the high and low settings filter the input signal prior to reverb processing.

Lo Gain

Sets the amount of boost or attenuation for the low-shelving filter.

Hi Gain

Sets the amount of boost or attenuation for the high-shelving filter.

Reverb Character

Pre-Delay

Determines how much time passes before the reverb is applied. This allows 
you to simulate larger rooms by increasing the time it takes for the first 
reflections to reach the listener.
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Reverb Time

Allows you to set the reverb time in seconds.

Size

Alters the delay times of the early reflections to simulate larger or smaller 
spaces.

Diffusion

Affects the character of the reverb tail. Higher values lead to more diffusion 
and a smoother sound, while lower values lead to a clearer sound.

Width

Controls the width of the stereo image. At a setting of 0 %, the output of the 
reverb is mono, at 100 % it is stereo.

Variation

Clicking this button generates a new version of the same reverb program 
using altered reflection patterns. This is helpful if some sounds are causing 
odd ringing or undesirable results. Creating a new variation often solves these 
issues. There are 1000 possible variations.

Hold

Activating this button freezes the reverb buffer in an infinite loop. You can 
create some interesting pad sounds using this feature.

Damping

Lo Freq

Determines the frequency below which low-frequency damping occurs.

Hi Freq

Determines the frequency above which high-frequency damping occurs.

Lo Level

Affects the decay time of the low frequencies. Normal room reverb decays 
quicker in the high- and low-frequency range than in the mid-range. Lowering 
the level percentage causes low frequencies to decay quicker. Values above 
100 % cause low frequencies to decay more slowly than the mid-range 
frequencies.

Hi Level

Affects the decay time of the high frequencies. Normal room reverb decays 
quicker in the high- and low-frequency range than in the mid-range. Lowering 
the level percentage causes high frequencies to decay quicker. Values above 
100 % cause high frequencies to decay more slowly than the mid-range 
frequencies.
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Envelope

Amount

Determines how much the envelope attack and release controls affect the 
reverb itself. Lower values have a more subtle effect while higher values lead 
to a more drastic sound.

Attack

The envelope settings in RoomWorks control how the reverb follows the 
dynamics of the input signal in a fashion similar to a noise gate or downward 
expander. Attack determines how long it takes for the reverb to reach full 
volume after a signal peak (in milliseconds). This is similar to a pre-delay, but 
the reverb is ramping up instead of starting all at once.

Release

Determines how long after a signal peak the reverb can be heard before being 
cut off, similar to a release time of a gate.

Output

Mix

Sets the level balance between the dry signal and the wet signal. If 
RoomWorks is used as an insert effect for an FX channel, you most likely want 
to set this to 100 % or use the wet only button.

Wet only

This button deactivates the Mix parameter, setting the effect to 100 % wet or 
affected signal. This button should normally be activated if RoomWorks is 
used as a send effect for an FX channel or a group channel.

Efficiency

Determines how much processing power is used for RoomWorks. The lower 
the value, the more CPU resources are used, and the higher the quality of the 
reverb. Interesting effects can be created with very high Efficiency settings 
(>90 %).

Export

Determines if during audio export RoomWorks uses the maximum CPU power 
for the highest quality reverb. During export, you may want to keep a higher 
efficiency setting to achieve a specific effect. If you want the highest quality 
reverb during export, make sure this button is activated.

Output meter

Indicates the level of the output signal.
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RoomWorks SE

RoomWorks SE is a smaller version of the RoomWorks plug-in. This plug-in 
delivers high quality reverberation, but has fewer parameters and is less CPU 
demanding than the full version.

Pre-Delay

Determines how much time passes before the reverb is applied. This allows 
you to simulate larger rooms by increasing the time it takes for the first 
reflections to reach the listener.

Reverb Time

Allows you to set the reverb time in seconds.

Diffusion

Affects the character of the reverb tail. Higher values lead to more diffusion 
and a smoother sound, while lower values lead to a clearer sound.

Hi Level

Affects the decay time of the high frequencies. Normal room reverb decays 
quicker in the high- and low-frequency range than in the mid-range. Lowering 
the level percentage causes high frequencies to decay quicker. Values above 
100 % cause high frequencies to decay more slowly than the mid-range 
frequencies.

Lo Level

Affects the decay time of the low frequencies. Normal room reverb decays 
quicker in the high- and low-frequency range than in the mid-range. Lowering 
the level percentage causes low frequencies to decay quicker. Values above 
100 % cause low frequencies to decay more slowly than the mid-range 
frequencies.

Mix

Sets the level balance between the dry signal and the wet signal. When using 
RoomWorks SE inserted in an FX channel, you most likely want to set this to 
100 %.

StereoDelay

StereoDelay has two independent delay lines with freely specified delay time 
settings.
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Delay

If tempo sync is activated, this sets the base note value for the delay. If tempo 
sync is deactivated, the delay time can be set freely in milliseconds.

Feedback

Set the number of repeats for each delay.

Filter Lo

Affects the feedback loop of the effect signal and allows you to roll off low 
frequencies. The button below the knob activates/deactivates the filter.

Filter Hi

Affects the feedback loop of the effect signal and allows you to roll off high 
frequencies. The button below the knob activates/deactivates the filter.

Pan

Set the stereo position for each delay.

Mix

Sets the level balance between the dry signal and the wet signal. If the effect 
is used as a send effect, set this parameter to the maximum value as you can 
control the dry/effect balance with the send.

StereoEnhancer

This plug-in expands the stereo width of (stereo) audio material. It cannot be used 
with mono files.

Width

Controls the width or depth of the stereo enhancement. Turn clockwise to 
increase the enhancement.



Plug-in Reference
Steinberg VST 3 Plug-ins

799

Delay

Increases the amount of differences between the left and right channels to 
further increase the stereo effect.

Color

Generates additional differences between the channels to increase the stereo 
enhancement.

Mono

Switches the output to mono, to check for possible unwanted coloring of the 
sound which sometimes can occur when enhancing the stereo image.

Stereo Tools

Stereo Tools allows you to pan or position both the left and right channels 
independently of one another. You can use it for stereo files that you do not want to 
convert to mono or for fixing a problem with the stereo file, for example.

Invert Left Phase/Invert Right Phase

Inverts the polarity of an audio channel. You can use it for removing the center 
information or for fixing a channel that has been inverted, for example.

Swap Stereo Channels

Swaps the left and right channels.

Transform

Determines the conversion method:

• Nothing: No conversion of the signal.

• Left/Right -> Mid/Side: Converts a stereo signal into a mid/side 
signal.

• Mid/Side -> Left/Right: Converts a mid/side signal into a stereo 
signal.

Left/Mid Gain (dB)

Sets the gain of the left stereo signal or the mid signal of the M/S signal.
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Right/Side Gain (dB)

Sets the gain of the right stereo signal or of the side signals of the M/S signal.

Left/Mid Panning (%)

Pans the left stereo signal or the mid signal of the M/S signal.

Right/Side Panning (%)

Pans the right stereo signal or the side signals of the M/S signal.

StudioChorus

StudioChorus is a two-stage chorus effect that adds short delays to the signal and 
modulates the pitch of the delayed signals to produce a doubling effect. The two 
separate stages of chorus modulation are independent and are processed serially 
(cascaded).

Rate

If tempo sync is deactivated, this sets the sweep rate.

Width

Sets the depth of the chorus effect. Higher settings produce a more 
pronounced effect.

Spatial

Sets the stereo width of the effect. Turn clockwise for a wider stereo effect.

Mix

Sets the level balance between the dry signal and the wet signal. If the effect 
is used as a send effect, set this parameter to the maximum value as you can 
control the dry/effect balance with the send.

Waveform Shape selector

Allows you to select the modulation waveform, altering the character of the 
chorus sweep. A sine and a triangle waveform are available.

Delay

Affects the frequency range of the modulation sweep by adjusting the initial 
delay time.
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Filter Lo/Hi

Allow you to roll off low and high frequencies of the effect signal.

NOTE

If side-chaining is supported, the modulation can also be controlled from another 
signal source via the side-chain input. If the side-chain signal exceeds the threshold, 
the modulation is controlled by the side-chain signal’s envelope. For a description 
of how to set up side-chain routing, see the Operation Manual.

StudioEQ

Studio EQ is a high-quality 4-band parametric stereo equalizer with two fully 
parametric mid-range bands. The low and high bands can act as either shelving 
filters (three types), or as peak filter (band-pass), or as cut filter 
(low-pass/high-pass).

Gain (-20 to +24 dB)

Sets the amount of attenuation/boost for the corresponding band.

Inv

Inverts the gain value of the filter. Use this button to filter out unwanted noise. 
When looking for the frequency to omit, it sometimes helps to boost it in the 
first place (set the filter to positive gain). After you have found the frequency 
of the noise, you can use the Inv button to cancel it out.
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Freq (20 to 20000 Hz)

Sets the frequency of the corresponding band. You can set the frequency 
either in Hz or as a note value. If you enter a note value, the frequency is 
automatically changed to Hz. For example, a note value of A3 sets the 
frequency to 440 Hz. When you enter a note value, you can also enter a cent 
offset. For example, enter A5 -23 or C4 +49.

NOTE

Ensure that you enter a space between the note and the cent offset. Only in 
this case, the cent offsets are taken into account.

Q-Factor

Controls the width, or resonance, of the corresponding band.

Filter mode

For the low and high band, you can choose between three types of shelving 
filters, a peak filter (band-pass), and a cut filter (lowpass/high-pass). If Cut 
mode is selected, the Gain parameter is fixed.

• Shelf I adds resonance in the opposite gain direction slightly above the 
set frequency.

• Shelf II adds resonance in the gain direction at the set frequency.

• Shelf III is a combination of Shelf I and II.

Output (-24 to +24 dB)

This knob on the top right of the plug-in panel allows you to adjust the overall 
output level.

Auto Gain

If this button is activated, the gain is automatically adjusted, keeping the 
output level constant regardless of the EQ settings.

Spectrum

Shows the spectrum before and after filtering.

Reset

Resets the EQ settings.

TestGenerator

This utility plug-in allows you to generate an audio signal, which can be recorded as 
an audio file.
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The resulting file can then be used for a number of purposes:

• Testing the specifications of audio equipment

• Measurements of various kinds, such as calibrating tape recorders

• Testing signal processing methods

• Educational purposes

The TestGenerator is based on a waveform generator which can generate a number 
of basic waveforms such as sine and saw as well as various types of noise. 
Furthermore, you can set the frequency and amplitude of the generated signal. As 
soon as you add the TestGenerator as an effect on an audio track and activate it, a 
signal is generated. You can then activate recording as usual to record an audio file 
according to the signal specifications.

Waveforms and noise section

Allows you to set the basis for the signal generated by the waveform 
generator. You can choose between four basic waveforms (sine, triangle, 
square, and sawtooth) and three types of noise (white, pink, and brownian).

Frequency section

Allows you to set the frequency of the generated signal. You can set the 
frequency either in Hz or as a note value. If you enter a note value, the 
frequency is automatically changed to Hz. For example, a note value of A3 
sets the frequency to 440 Hz. When you enter a note value, you can also enter 
a cent offset. For example, enter A5 -23 or C4 +49.

NOTE

Ensure that you enter a space between the note and the cent offset. Only in 
this case, the cent offsets are taken into account.

Gain section

Allows you to set the amplitude of the signal. The higher the value, the 
stronger the signal. You can select one of the preset values, or use the slider 
to set a value between -81 and 0 dB.
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Tube Compressor

This versatile compressor with integrated tube-simulation allows you to achieve 
smooth and warm compression effects. The VU meter shows the amount of gain 
reduction. Tube Compressor features an internal side-chain section that lets you 
filter the trigger signal.

Drive (1.0 to 6.0)

Controls the amount of tube saturation.

Input

Determines the compression amount. The higher the input gain, the more 
compression is applied.

Limit

Increases the ratio of the compressor for a limiting effect.

Output (-12 to 12 dB)

Sets the output gain.

Attack (0.1 to 100 ms)

Determines how fast the compressor responds. If the attack time is long, more 
of the initial part of the signal passes through unprocessed.

Release (10 to 1000 ms or Auto mode)

Sets the time after which the gain returns to its original level. If the Auto button 
is activated, the plug-in automatically finds the best release setting for the 
audio material.

Mix

Adjusts the mix between dry signal and wet signal preserving the transients 
of the input signal.

In/Out Meters

Show the highest peaks of all available input and output channels.

VU Meter

Shows the amount of gain reduction.
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Side-Chain

Activates the internal side-chain filter. The input signal can then be shaped 
according to the filter parameters. Internal side-chaining is useful for tailoring 
how the gate operates.

Filter buttons (LP, BP, and HP)

If the Side-Chain button is activated, you can use these buttons to set the 
filter type to low-pass, band-pass, or high-pass.

Side-chain section

Center (50 to 20000 Hz)

If the Side-Chain button is activated, this sets the center frequency of the 
filter.

Q-Factor

If the Side-Chain button is activated, this sets the resonance or width of the 
filter.

Monitor

Allows you to monitor the filtered signal.

VintageCompressor

VintageCompressor is modeled after vintage type compressors.

This compressor features separate controls for Input and Output gain, Attack, and 
Release. In addition, there is a Punch mode which preserves the attack phase of 
the signal and a program-dependent Auto feature for the Release parameter.

Input

Determines the compression amount. The higher the input gain, the more 
compression is applied.

Output (-48 to 24 dB)

Sets the output gain.

Attack (0.1 to 100 ms)

Determines how fast the compressor responds. If the attack time is long, more 
of the initial part of the signal passes through unprocessed.
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Punch

If this is activated, the early attack phase of the signal is preserved, retaining 
the original punch in the audio material, even with short Attack settings.

Release (10 to 1000 ms or Auto mode)

Sets the time after which the gain returns to its original level. If the Auto button 
is activated, the plug-in automatically finds the best release setting for the 
audio material.

VU Meter

Shows the amount of gain reduction.

In/Out Meters

Show the highest peaks of all available input and output channels.

VSTDynamics

VSTDynamics is an advanced dynamics processor. It combines three separate 
processors: Gate, Compressor, and Limiter, covering a variety of dynamic 
processing functions.

The window is divided into three sections, containing controls and meters for each 
processor. Activate the individual processors using the buttons Gate, 
Compressor, and Limiter at the bottom of the plug-in panel.

Gate Section

Gating, or noise gating, is a method of dynamic processing that silences audio 
signals below a set threshold. As soon as the signal level exceeds the threshold, the 
gate opens to let the signal through. The Gate trigger input can also be filtered 
using an internal side-chain signal.

The following parameters are available:

Threshold (-60 to 0 dB)

Determines the level where the gate is activated. Signal levels above the set 
threshold trigger the gate to open, and signal levels below the set threshold 
close the gate.
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State LED

Indicates whether the gate is open (LED lights up in green), closed (LED 
lights up in red) or in an intermediate state (LED lights up in yellow).

Side-Chain

Activates the internal side-chain filter. The input signal can then be shaped 
according to the filter parameters. Internal side-chaining is useful for tailoring 
how the gate operates.

Filter buttons (LP, BP, and HP)

If the Side-Chain button is activated, you can use these buttons to set the 
filter type to low-pass, band-pass, or high-pass.

Center (50 to 20000 Hz)

If the Side-Chain button is activated, this sets the center frequency of the 
filter.

Q-Factor

If the Side-Chain button is activated, this sets the resonance or width of the 
filter.

Monitor

Allows you to monitor the filtered signal.

Attack (0.1 to 100 ms)

Determines how fast the compressor responds to signals above the set 
threshold. If the attack time is long, more of the early part of the signal passes 
through unprocessed.

Hold (0 to 2000 ms)

Determines how long the gate remains open after the signal drops below the 
threshold level.

Release (10 to 1000 ms or Auto mode)

Sets the time after which the gate closes after the set Hold time. If the Auto 
button is activated, the plug-in automatically finds the best release setting for 
the audio material.

Range

Adjusts the attenuation of the gate when it is shut. If Range is set to minus 
infinite , the gate is completely shut. The higher the value, the higher the 
level of the signal that passes through the shut gate.

Input Gain Meter

Shows the input gain.

Compressor Section

The compressor reduces the dynamic range of the audio, making softer sounds 
louder or louder sounds softer, or both. The compressor features a separate display 
that graphically illustrates the compressor curve shaped according to your settings.
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Threshold (-60 to 0 dB)

Determines the level where the compressor kicks in. Only signal levels above 
the set threshold are processed.

Ratio

Sets the amount of gain reduction applied to signals above the set threshold. 
A ratio of 3:1 means that for every 3 dB the input level increases, the output 
level increases by 1 dB.

Make-up (0 to 24 dB or Auto mode)

Compensates for output gain loss, caused by compression. If the Auto button 
is activated, the knob becomes dark and the output is automatically adjusted 
for gain loss.

Attack (0.1 to 100 ms)

Determines how fast the compressor responds to signals above the set 
threshold. If the attack time is long, more of the early part of the signal (attack) 
passes through unprocessed.

Release (10 to 1000 ms or Auto mode)

Sets the time after which the gain returns to its original level when the signal 
drops below the threshold. If the Auto button is activated, the plug-in 
automatically finds the best release setting for the audio material.

Graphical display

Use the graphical display to graphically set the threshold and ratio values. To 
the left and right of the graphical display, you find two meters that show the 
amount of gain reduction in dB.

Limiter Section

The limiter ensures that the output level never exceeds a set threshold, to avoid 
clipping in following devices. Conventional limiters usually require very accurate 
setting up of the attack and release parameters to prevent the output level from 
going beyond the set threshold level. The limiter adjusts and optimizes these 
parameters automatically according to the audio material.

Output (-24 to 6 dB)

Sets the maximum output level.

Soft Clip

If this button is activated, the signal is limited when the signal level exceeds 
-6 dB. At the same time, harmonics are generated, adding a warm, tube-like 
characteristic to the audio material.

Release (10 to 1000 ms or Auto mode)

Sets the time after which the gain returns to its original level. If the Auto button 
is activated, the plug-in automatically finds the best release setting for the 
audio material.
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Meters

The three meters show the input gain (IN), the gain reduction (GR) and the 
output gain (OUT).

Module Configuration Button

Using the Module Configuration button in the bottom right corner of the plug-in 
panel, you can set the signal flow order for the three processors. Changing the 
order of the processors can produce different results, and the available options 
allow you to quickly compare what works best for a given situation. Simply click the 
Module Configuration button to change to a different configuration. There are 
three routing options:

• C-G-L (Compressor-Gate-Limit)

• G-C-L (Gate-Compressor-Limit)

• C-L-G (Compressor-Limit-Gate)

Sonnox Restoration Toolkit

The Sonnox Restoration Toolkit consists of the De-Clicker, De-Noiser, and 
De-Buzzer tools. The tools are for restoring old material, removing clicks, pops, 
buzzes, and background noise that can occur in new recordings.

Sonnox DeBuzzer

Sonnox DeBuzzer allows you to remove hum and buzz noises from audio material.

Sonnox Menu Options button

Opens a menu where you can select the following options:

• Duration of the input/output meter clip lights hold (indefinitely, 2 s, 5 s)
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• Knob behavior

• Information about the version number and build date

Input Level meter

This meter is designed to give exactly 1 dB per LED for the top 18 dB of 
dynamic range, and 2 dB per LED thereafter. This gives a clear and intuitive 
impression of the working headroom.

Trim Input Level

Allows you to adjust the input signal level by up to ±12 dB.

Frequency Knob and touch pad (Hz)

The DeBuzzer has an active frequency range for the buzz fundamental of 
between 20 and 440 Hz. In Auto mode, this knob sets the frequency from 
which the buzz detection circuit starts to hunt for buzz components. In Freeze 
mode, this knob sets the exact frequency of the buzz fundamental. The knob 
is graduated around the circumference, and clicking on any labeled 
graduation sets the frequency to that graduation.

Fine Adjust button

Enables fine tuning of the buzz frequency control. The graduations around the 
circumference of the frequency knob re-draw to a finer scale, and scrolling the 
touch pad enables very quick fine tuning of a hunt frequency. Scrolling past 
an end-stop continues to scroll the frequency and the marked graduations 
re-draw appropriately.

Fine Adjust mode forces Freeze, so that the selected frequency can be 
specified exactly, without the Auto circuitry hunting for a stronger 
fundamental. If entering Fine Adjust mode from Auto, the Freeze button 
flashes and the plug-in reverts to Auto when Fine Adjust mode is exited.

Tone On button

Enables an audible tone generator, which can be used to aid location of the 
buzz fundamental. While the Tone button is on, a touch pad opens above the 
button and becomes a Tone level control. It defaults to -18 dB, and has a 
range of -6 dB to -96 dB.

Sensitivity knob and touch pad (%)

Controls the sensitivity of the buzz detection circuit. Fully sensitive might allow 
the detection circuit to lock to inaudible and possibly undesirable frequencies. 
Stronger buzzes, which typically would be removed first, require a less 
sensitive setting.

Hum/Buzz Mode button

Control switches between Hum mode and Buzz mode. In Hum mode the 
bandwidth limit for harmonic removal is 0 to 800 Hz. In Buzz mode the 
bandwidth limit for harmonic removal is 0 to 4000 Hz. Hum mode is less 
damaging, and should be used when possible.



Plug-in Reference
Sonnox Restoration Toolkit

811

Enable button

Enables the buzz removal processing. It allows glitch-less comparisons with 
and without the buzz removal. When Enable is deactivated, the buzz 
detection circuit is still enabled and the Detect display still shows the degree 
of buzz detection.

Reduction display

Indicates the level of audio that is being removed from the signal.

Attenuation knob and touch pad (dB)

Determine the level of attenuation that the buzz removal circuit apply, up to a 
maximum of 96 dB. Generally this should be set so that the buzz is just 
inaudible. Excessive use of attenuation can degrade the signal unnecessarily.

Auto button

Enables Auto mode for the buzz detection circuit. In this mode the buzz 
detection is continually calculated and a slow drift in the buzz fundamental 
frequency automatically follows. This mode is useful for material with a 
time-varying buzz component. In this mode the removal filters follow the 
detected frequency.

Freeze button

Enables Freeze mode for the buzz detection circuit. In this mode the buzz 
fundamental is fixed to the frequency shown in the touch pad window. This 
mode is useful for material with fluctuating buzz level, but with a constant buzz 
frequency. In this instance, Auto mode would suffer when the buzz level drops 
and would typically re-hunt for a different buzz fundamental. In this mode the 
removal filters follow the nominal frequency.

Detect display

Indicates the degree of detection that the buzz detection circuit has achieved.

Output Level meter (dB)

This meter is designed to give exactly 1 dB per LED for the top 18 dB of 
dynamic range, and 2 dB per LED thereafter. There is a peak-hold feature that 
holds the highest peak, helping to give a better impression of the working 
dynamic range.

Trim Output Level

Allows you to reduce the output level by up to 12 dB. Dithering is applied after 
output gain control, so it may be necessary to reduce this value by a small 
amount to avoid clipping.

Using the Sonnox DeBuzzer

• Find the nominal frequency. Start with Sensitivity and Attenuation controls 
at the default positions (90 % and -48 dB).

• If you know the rough frequency of the nominal, select that frequency using 
either the knob or by typing into the touch pad.
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• In Auto mode, allow the detector time to drift towards the actual fundamental. 
The Detect display indicates confidence of hum detection. Auto mode should 
be used if the fundamental drifts over time.

• Freeze mode should be used to select a specific frequency that might be 
variable in strength. Fine Adjust (which forces Freeze mode) can be used to 
increase the resolution of selecting the fundamental.

• If you are still having difficulty finding the fundamental, use the Tone control.

• The Hum mode removes harmonics up to 800 Hz. If you can hear harmonics 
that are higher in frequency, select Buzz mode, which removes harmonics up 
to 4000 Hz. If there are no harmonics above 800 Hz, be sure to use Hum 
mode to preserve as much original audio as possible.

• In order to cause as little damage to the audio as possible, back off the 
attenuation until you can just hear the buzz, then increase it until the buzz is 
inaudible.

• Then reduce the sensitivity until the buzz is inaudible.

Sonnox DeClicker

Sonnox DeClicker allows you to remove clicks from audio material.

Sonnox Menu Options Button

Opens a menu where you can select the following options:

• Duration of the input/output meter clip lights hold (indefinitely, 2s, 5s)

• Information about the version number and build date

Input Level Meter

Gives exactly 1 dB per LED for the top 18 dB of dynamic range, and 2 dB per 
LED thereafter. This gives a clear and intuitive impression of the working 
headroom.
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Trim Input Level

Allows you to adjust the input signal level by up to ±12 dB.

Sensitivity Fader and Touch Pad (%) (DePop, DeClick, DeCrackle)

Controls the sensitivity of the detection circuits. Fully sensitive might allow the 
detection circuit to react to low level signals and possibly mis-classify 
programme as pops or clicks. Stronger pops and clicks require a less 
sensitive setting.

In Button (DePop, DeClick, DeCrackle)

Enables the pop, click or crackle removal processing. When In is deactivated, 
the pop, click, or crackle detection circuit is still enabled and the detect 
display still shows the degree of event detection.

Detect Meter Display (DePop, DeClick, DeCrackle)

Combines two indications. The main rising column indicates the sum of the 
energy of events that have been detected. With the In button de-selected (i.e. 
the repair circuit disabled), this column is colored orange/red. With the repair 
circuit active the column is colored blue. The bottom segment of the meter is 
an indication of each individual detected event.

Output Level Meter (dB)

Gives exactly 1 dB per LED for the top 18 dB of dynamic range, and 2 dB per 
LED thereafter. There is a peak-hold feature that holds the highest peak, 
helping to give a better impression of the working dynamic range.

Trim Output Level

Allows you to reduce the output level by up to 12 dB. Dithering is applied after 
output gain control, so it can be necessary to reduce this value by a small 
amount to avoid clipping.

Using the Sonnox DeClicker

• We recommend repair the larger and more energetic events first.

• If there are large displacement events in the programme material, enable the 
DePop section and raise the sensitivity fader until the largest events are 
detected and repaired.

• For clicks, enable that section and raise the sensitivity fader until they are 
detected and repaired.

• Finally, if there is crackle left, enable that section and raise its fader to remove 
the crackle.

• There is necessarily some degree of overlap in the detection circuits of clicks 
and crackle. Decreasing the DeClick sensitivity can increase the apparent 
detection of crackle and increasing the DeClick sensitivity can indicate less 
crackle. Best results are likely if the two controls are balanced.



Plug-in Reference
Sonnox Restoration Toolkit

814

Sonnox DeNoiser

Sonnox DeNoiser removes wide-band noise from audio material.

Sonnox Menu Options button

Opens a menu where you can select the following options:

• Duration of the input/output meter clip lights hold (indefinitely, 2 s, 5 s)

• Knob behavior

• Information about the version number and build date

Graphical display

Shows the real-time frequency/gain curve of the program material. It is 
graduated from 0 to 20 kHz and from 0 to -144 dB. The yellow line is the 
calculated noise spectrum level, and in Adapt mode continually follows the 
noise in real time. Everything below this contour is assumed to be noise, and 
everything above the line is program signal.

Input Level meter

This meter is designed to give exactly 1 dB per LED for the top 18 dB of 
dynamic range, and 2 dB per LED thereafter. This gives a clear and intuitive 
impression of the working headroom.

Trim Input Level

Allows you to adjust the input signal level by up to ±12 dB.

Sensitivity fader and Trim touch pad (dB)

The sensitivity fader defaults to 0.0 dB, which is the midpoint of its travel. It 
adjusts the sensitivity of the noise detection circuit, and the visible effect of 
this is to move the yellow noise contour line up and down. The sensitivity level 
can be changed by up to ±18 dB.

To reduce the sensitivity and make the DeNoiser less reactive to the noise 
component, move the fader down. The noise contour displaces downwards, 
showing less noise component in the detection circuit. If the sensitivity is set 
too low, little noise reduction occurs.
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To increase the sensitivity and make the DeNoiser more reactive to the noise 
component, move the fader up. The noise contour displaces upwards, 
showing more noise component in the detection circuit. The default setting is 
for the noise contour to lie just below the peaks of the signal. Making the 
detection circuit more sensitive to noise decreases the signal component, 
possibly pushing the contour up towards the peaks of the signal. In this case, 
it is likely that processing artifacts are heard, as the noise removal circuit acts 
on the signal component as well as the noise component.

Adapt button

Enables Adapt mode for the noise detection circuit. In this mode the noise 
fingerprint is continually calculated and updated. This mode is useful for 
material with a time-varying noise component.

Freeze button

Enables Freeze mode for the noise detection circuit. In this mode the noise 
fingerprint is calculated. This mode is useful for material with a constant noise 
component, and would typically be sampled when the signal is absent and 
only the noise component is present.

In button

Enables the noise removal processing. It allows glitch-less comparisons with 
and without the noise reduction. When In is deactivated, the noise detection 
circuit is still enabled and the graphical display still shows the real-time 
frequency display and the noise contour line.

HF Limit knob and touch pad (Hz)

Displays and controls the frequency beyond which the attenuation is applied 
nondynamically. Scrolling the frequency down from the default of 22 kHz 
shows a red region in the frequency display that has a fixed attenuation. To 
the left of the HF Limit line the noise removal circuit behaves as normal. To the 
right the signal is attenuated by a fixed amount set by the attenuation fader. 
This mode is useful for band-limited program material.

A good example is a low bitrate encoded signal, which might be band limited 
to 12 kHz. Due to the sharp discontinuity, the noise removal circuit can 
introduce audible artifacts around the band limit, and setting the HF Limit 
frequency slightly lower than the band limit removes those artifacts.

Attenuation fader and touch pad (dB)

Determine the level of attenuation that the noise removal circuit applies in the 
range 0 to -18 dB. Generally this should be set so that the noise reduction is 
pleasing. Excessive use of attenuation can degrade the signal unnecessarily.

Output Level meter (dB)

This meter is designed to give exactly 1 dB per LED for the top 18 dB of 
dynamic range, and 2 dB per LED thereafter. There is a peak-hold feature that 
holds the highest peak, helping to give a better impression of the working 
dynamic range.
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Trim Output Level

Allows you to reduce the output level by up to 12 dB. Dithering is applied after 
output gain control, so it can be necessary to reduce this value by a small 
amount to avoid clipping.

Using the Sonnox DeNoiser

• Start with Sensitivity and Attenuation controls at the default positions 
(0.0 dB and -4.5 dB).

• Select Adapt mode if the noise varies in time. Select Freeze for a defined and 
static noise fingerprint.

• Adjust the Sensitivity to find the correct balance between being too low (not 
enough noise is removed) and too high (too much signal is removed).

• Adjust the Attenuation to find the most pleasing audio. Too much attenuation 
can impair the audio, either by reducing brightness or by introducing low-level 
distortion.

You might be working with bandwidth-limited material, possibly as a result of 
sample rate conversion or lossy compression (for example, limited at around 
10 kHz). If you experience distortion around the limit try reducing the HF Limit 
control. Adjust until it lies just to the lower frequency side of the limit (around 9.5 kHz 
in our example).

Legacy Plug-ins

Under Windows, a set of plug-ins is provided for compatibility with audio projects 
that referenced these effects when using earlier versions of WaveLab Pro. An audio 
montage which referenced these plug-ins would otherwise require cumbersome 
user intervention to open, for example.

Their use with new audio projects is not recommended and they are not 
documented.

Dithering Plug-ins

Dithering plug-ins add small quantities of noise to a signal to reduce the audibility 
of low level distortion in a digital recording. A small amount of random noise is 
added to the analog signal before the sampling stage, reducing the effect of 
quantization errors.
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Internal Dithering

This is a built-in plug-in that provides a simple way of adding a small amount of noise 
to the rendered signal to improve the apparent signal-to-noise ratio of the output.

The following parameters are available when selecting Internal Dithering.

Noise Type

Sets the noise type for adding to the signal.

• In No Noise mode, no dithering is applied.

• The Noise Type 1 mode is the most all-round method.

• The Noise Type 2 mode emphasizes higher frequencies more than 
Noise Type 1.

Noise Shaping

Increases the apparent signal to noise ratio by altering the spectrum of the 
low-level audio signal which results from lowering the number of bits. The 
higher the number you select here, the more the noise is moved out of the 
ear’s mid-range.

Bit Resolution

Allows you to specify the intended bit resolution for the final audio, after 
dithering, regardless of whether you want to render the settings or play back 
in real-time.

Dithering changes the sample resolution, but not the sample size. For 
example, when dithering 24 bit to 16 bit, the file will still be 24 bit in size, 
although only 16 bits of information will have significance. When rendering to 
a 16-bit file, specify the file resolution to avoid wasting space.

MBIT+™ Dithering

This plug-in allows you to convert and dither to 24, 20, 16, 12, or 8 bits. This is 
useful for mastering a track for a CD (16-bit) from a 24-bit source, for example.

The MBIT+™ dither algorithm reduces quantization distortion with minimal 
perceived noise and produces smooth and quiet conversions.
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Bit Quantization

Sets the bit depth to which you are dithering. MBIT+™ produces 32-bit 
floating-point output, but all low-order bits will be zero and should be 
truncated.

Type

Sets the type of dithering. MBIT+™ contains two traditional dithering types 
and a proprietary MBIT+™ dithering type.

• Type 1 is a traditional dither based on a rectangular probability 
distribution function (PDF).

• Type 2 is a traditional dither based on a triangular PDF.

• MBIT+™ offers superior results when used with all types of source 
material.

Dither Amount

When using MBIT+™ dither, this controls the amount of dithering. The None 
and Low settings can leave some non-linear quantization distortion or dither 
noise modulation, while higher settings completely eliminate the non-linear 
distortion at the expense of a slightly increased noise floor. The Normal 
setting is suffice for most cases.

When using Type 1 or Type 2 dither, this controls the number of bits used to 
perform dithering. In most cases, 1 bit is suffice, but over-dithering with 2 bits 
can be useful in same cases.

Noise Shaping

When using MBIT+™ dither, this controls the amount of noise shaping. The 
choices range from no noise shaping to very aggressive noise shaping, 
providing approximately 14 dB of audible noise suppression, at the expense 
of a higher noise floor.

When using Type 1 or Type 2 dither, this controls the noise shaping. Dithering 
noise can be shaped in order to make it less audible. Simple noise shaping 
performs simple high-pass filtering on the noise. Clear noise shaping 
aggressively moves the noise toward the Nyquist frequency. Psych 5 is a 
5th-order filter designed to move noise away from audible bands, and Psych 
9 is a 9th-order filter with similar characteristics.
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Auto-Blanking

If this option is activated, MBIT+™ mutes dither output when the input is 
completely silent for at least 0.7 seconds.

Minimize Peaks

If this option is activated, spurious peaks in the noise-shaped dither are 
suppressed.

Harmonics Suppression

If this option is activated, the truncation rules are slightly altered, moving the 
harmonic quantization distortion away from overtones of audible frequencies. 
This option does not create any random dithering noise floor. Instead it works 
more like truncation, but with better tonal quality in the resulting signal. This 
option is applicable only in the modes without dithering noise and without 
aggressive noise shaping.

Copyright © 2013 iZotope, Inc. All rights reserved.

UV22HR

This is an advanced version of Apogee's renowned UV22 dithering algorithm, 
capable of dithering to 8, 16, 20, or 24 bits.

8, 16, 20, 24 bit

These buttons allow you to select the intended bit resolution for the final 
audio. As when using the internal dithering, it is important to set this to the 
correct resolution.

Hi

Applies a normal dither gain.

Lo

Applies a lower level of dither noise.

Auto black

If this option is activated, the dither noise is gated during silent passages.



Plug-in Reference
ASIO Plug-ins

820

ASIO Plug-ins

External Gear

This Master Section plug-in allows you to process audio files using external 
hardware processors. One or more ASIO outputs are used to send the audio signal 
to your processor, and corresponding ASIO inputs are used to return the signal 
from the external processor.

By default, this plug-in is located in the ASIO submenu of the Master Section 
effects. An ASIO driver must be used, and only one instance of this plug-in is 
allowed in the Master Section plug-in chain.

External Gear Plug-in

In the Effects pane of the Master Section window, select the External Gear 
plug-in from the ASIO submenu.

Num. Outputs

Here you can set the number of outputs to use. Normally this is the same as 
the number of inputs (the As Inputs option). However, you can use a mono 
out/stereo in configuration in which case you set this parameter to 2 with the 
slider.

Latency

External gear may introduce latency. WaveLab Pro can automatically 
compensate for this if you select Auto (only active during rendering), or you 
can set this latency compensation yourself (in milliseconds). The latency 
introduced by the ASIO driver is automatically taken into account by 
WaveLab Pro.

Send Level

Allows you to adjust the send level. This should normally be set to 0 dB. If 
necessary, adjust the input level on the external effect.

Using External Gear

PROCEDURE

1. Select File > Preferences > VST Audio Connections.

2. Set the Audio Device to ASIO.
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3. Select the ASIO Plug-ins tab.

4. Select the channels to be used for device output (to gear) and device input 
(from gear), and click OK.
These should be different I/O channels than the ones you use for playback and 
recording. The available outputs in this plug-in equals the number of inputs (up to 8).

5. In the Effects pane of the Master Section window, select the External Gear 
plug-in from the ASIO submenu.
The External Gear plug-in window opens.

6. Make your settings.

AFTER COMPLETING THIS TASK 

Now you can process a signal through the external processor, just as if it was a 
software plug-in effect. If you render a file using the External Gear plug-in, playback 
is not available during the rendering.

Audio Input

This is a special Master Section plug-in that allows you to render a signal coming 
in to the inputs of a sound card together with any Master Section effects. This 
signal can be anything your sound card accepts, such as a feed from a mixer, a 
recorder, or a microphone.

By default, this plug-in is located in the ASIO submenu of the Master Section 
effects. An ASIO driver must be used, and only one instance of this plug-in is 
allowed in the Master Section plug-in chain.

When the Audio Input plug-in is loaded, wave playback is not possible.

Setting Up the Audio Input Plug-in

PROCEDURE

1. Select File > Preferences > VST Audio Connections.

2. Set the Audio Device to ASIO.

3. Select the ASIO Plug-ins tab.

4. Select the channels to be used for device input, and optionally name them.

5. In the top effect slot of the Effects pane of the Master Section window, 
select the Audio Input plug-in from the ASIO submenu.

6. In the Audio Input plug-in window, set the number of inputs and the sample 
rate.
You have to match the number of inputs in the VST Audio Connections tab to the 
number of inputs selected here.

7. Start playback.
The cursor does not move, but the Play button is lit and you can now monitor the input 
source. Pressing Stop ends input monitoring.
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8. If you change the settings in the control panel, click Stop, and restart playback 
to apply them.

9. In the Master Section, click Render.

10. Select a name, an audio format, and a location for the file to be rendered.

11. Click Start.
Recording/rendering starts, recording the external input from the output of the 
Master Section, including all real-time processing. You can monitor the recording as 
it happens.

12. Click Stop to stop the recording/rendering.

Batch Processing Plug-ins

In the Batch Processor window, you can add a sequence of plug-ins that can be 
used to process a batch of audio files. These plug-ins can be standard plug-ins 
available from the Master Section, offline processes available in the Audio Editor, 
and plug-ins that are only available within batch processing.

Audio Analyzer

This plug-in allows you to generate text files with statistics about the audio files in a 
batch process.

This monopass plug-in is exclusive to the Batch Processor window.

If you want to analyze files without writing anything, select No Output in the Output 
tab of the Batch Processor window.
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Information to Report

In this section you specify which information to include in the output. The following 
information can be included:

• Sample rate

• Number of channels

• Real bit resolution

• Number of samples/duration

• Digital peaks

• True peaks

• Integrated loudness

• Loudness range

• Short-term loudness (maximum)

• Short-term loudness (minimum)

• Momentary loudness (maximum)

• Momentary loudness (minimum)

• Loudness balance

• DC Offset

Output

In this section you set up the output of the Audio Analyzer. The following options are 
available:

Send Analysis Results to XML Processor

If this option is activated, the analysis results are passed as parameters to the 
XML or HTML output of the batch processor.

Create One Report per Audio File

If this option is activated, one report is created for each audio file in the batch 
process. The audio file name is used as the report file name.

Merge Results into Global Report

If this option is activated, the results of the analysis are merged into a global 
report. The audio file name is used as the report file name.

Open Global Report at End of Batch Process

If this option is activated, a global report opens after the batch process.

File Name Suffix

Lets you specify a file name suffix. This is necessary when you are using this 
plug-in multiple times in a batch process, for example, to see the stats before 
and after specific plug-ins.
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Use different suffixes for each instance of the Audio Analyzer plug-in used in 
the processing chain.

Output format

Lets you select the output format. The following formats are available:

• Pure text

• HTML

• Adobe PDF

• Open Office

• Spreadsheet

• XML

Audio Injector

This plug-in allows you to insert an audio file at the beginning and/or end of the 
audio file being processed. The inserted file can also be cross faded with the 
original audio file, if required.

This monopass plug-in is exclusive to the Batch Processor window.

Audio File to Inject at the Start (<= 60 sec)

Specifies the audio file to be added before the main audio file.

Audio File to Inject at the End (<= 60 sec)

Specifies the audio file to be added after the main audio file.

Perform Crossfade

Allows you to select a crossfade time and shape for the crossfade between 
the main audio file and the injected audio file.

DC Remover

This plug-in allows you to remove any DC Offset from an audio file.

It is useful to apply this plug-in first in a batch before other plug-ins to avoid further 
processing a file containing any DC Offset. For example, an audio file that has a DC 
offset is not at its loudest possible volume when normalized, because the offset 
consumes headroom.
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This multipass plug-in is available in the Batch Processor window and as an offline 
processor in the Audio Editor.

Fade In/Fade Out

This plug-in allows you to fade the beginning (Fade In) or the end (Fade Out) of a 
batch audio file. You can choose the length and shape of the fade, its duration, and 
the gain you want it to start/end at.

The fade plug-ins are exclusive to the Batch Processor window. Fade In is a 
monopass plug-in and Fade Out is a multipass plug-in.

Shape

Determines the shape of the fade.

Duration

Determines the duration of the fade.

Start Gain/End Gain

Determines the gain with which the fade starts. It ends with 0 dB.

Instructor

Instructor is a special utility plug-in that allows you to instruct the next plug-in in the 
batch with information about the audio it needs to process. This is useful for 
situations where you want to use monopass plug-ins that require an analysis stage 
that is not available at this point.

In effect, the Instructor plug-in turns a monopass plug-in into a dual pass one. Some 
monopass plug-ins, such as DeNoiser or DeBuzzer, need to learn about the audio 
they are to process before they can begin processing correctly. The Instructor 
plug-in can help in this situation, because it can teach the next plug-in in the audio 
chain about the audio it is about to process.

The Instructor plug-in must be used as a pair:

1) The first instance replicates the start of the audio stream. This means the next 
plug-in in the chain receives the start of the audio stream twice.

2) The second instance of the plug-in comes after the plug-in being instructed. 
It cuts out the extra audio injected by the first instance of the Instructor 
plug-in.
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For example, this means that the DeNoiser plug-in has time to sufficiently analyze 
the audio stream before the second stream start is injected. The “badly” processed 
first part of the stream is skipped by the second instance of the Instructor plug-in.

You can set the Instructor plug-in to replicate up to 20 seconds of audio.

NOTE

Do not set a value that is longer than the shortest file in the batch, otherwise a short 
file is over truncated by the second instance of the plug-in.

This monopass plug-in is exclusive to the Batch Processor window.

Replicate Stream Start

Injects the start of the audio stream twice into the next plug-ins. This action 
must be selected for the first instance of the Instructor plug-in.

Reverse Stream

If this option is activated, the start of the stream is injected first in reverse 
sample order, then in normal sample order. This changes nothing from the 
spectrum analysis point of view, but it improves the transition between the 
repeated streams.

Trim Stream Start

Skips the start of the audio stream. This action must be selected for the 
second instance of the Instructor plug-in.

Duration

Specifies how much audio to replicate or skip.

Loudness Meta Normalizer

This plug-in allows you to normalize a batch of files to the same loudness, while 
taking the EBU R-128 loudness measurement and a true peak analysis into 
account.

The purpose of this plug-in is to achieve the same loudness in all files (the highest 
loudness found, if possible), while being certain that no file clips. For each file, a 
specific gain is computed by the plug-in once all files have been analyzed and prior 
to actually applying any gain to achieve the common loudness. If it is not possible 
to match the highest found loudness, the level of the file with the highest loudness 
is reduced, so that other files can get the same loudness. Because no peak 
compression is used, the dynamics is preserved and no distortion is introduced.
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This metapass plug-in is exclusive to the Batch Processor window.

Match Loudness

Select what loudness the clip should get. The following options are available:

• Match loudest audio file

• Match maximum achievable loudness

• Match specific loudness

Loudness

Determines the specific loudness to match. For example, -23 LUFS if you 
want to follow the EBU R-128 recommendation for broadcast.

Reference

Select whether WaveLab Pro should use as reference the loudness of the 
entire clip (EBU R-128 recommendation), the average loudest 3 second 
audio section (Top of Loudness Range), or the loudest 3 seconds audio 
section (Maximum Short-Term Loudness).

Peaks

Select whether WaveLab Pro should refer to sample values (digital peaks) or 
to analog reconstructed values (true peaks).

Loudness Restorer

Loudness Restorer captures the loudness at a specific point in the audio chain and 
restores that loudness at another point. For this reason, the Loudness Restorer 
must be inserted in pairs into the signal chain: one plug-in for capturing and one 
plug-in for restoring.
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This multipass plug-in is exclusive to the Batch Processor window.

Mode - Capture

The first instance in the plug-in pair must be set to this mode. This makes the 
plug-in read the signal at this position in the audio chain.

Mode - Restore Peak Level/Restore Loudness (EBU R-128 Weighted)

The second instance in the plug-in pair must be set to one of these modes. 
Select one of these options if you want to use peak levels as a basis for 
determining what is considered equal level. Restore Loudness (EBU R-128 
Weighted) produces a more natural result than Restore Peak Level.

Reference menu

Select whether WaveLab Pro should use as reference the loudness of the 
entire file (EBU R-128 recommendation), the average loudest 3 second audio 
section (Top of Loudness Range), or the loudest 3 seconds audio section 
(Maximum Short-Term Loudness).

Peak menu

Select whether WaveLab Pro should use sample values (Digital Peaks) or 
analog reconstructed values (True Peaks).

Limit to 0 dB

If this option is activated, the restoration process will never result in levels 
above 0 dB.

Meta Leveler

This plug-in allows you to change the level of a batch of files consistently.

The core purpose of this plug-in is to apply the same gain to all files, while being 
certain that a specific peak level never exceeds in any file. The unique gain that you 
want to apply is (possibly) reduced by the plug-in, once all files in the batch have 
been analyzed, and prior to actually applying the gain across the batch.

This metapass plug-in is exclusive to the Batch Processor window.

Gain

Applies the specified gain to each file. The actual gain can be lower and even 
negative, to not exceed the value specified in the Maximum Peak field.
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Maximum Peak

Specifies the maximum peak level that any audio file should get at the end of 
the process.

Peaks

Select whether WaveLab Pro should refer to sample values (digital peaks) or 
to analog reconstructed values (true peaks).

Level Normalizer

This multipass plug-in allows you to raise or lower levels so that the signal peaks 
exactly at the specified value just before it is converted to a file.

Peak Level

Specify the highest level of any audio sample.

Stereo Link

Applies the gain to both channels.

Mix to Mono

Mixes the left and right channels. The resulting mono file gets the specified 
peak level. This ensure a clip-less mix.

Only if Clipping

Only applies a gain change if the audio file is beyond the reference peak level 
at some point. If not, the signal is untouched.

Resizer

This plug-in allows you to specify the duration of all audio files in the batch, and to 
choose whether to insert silence after the end of the chosen duration.
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This monopass plug-in is exclusive to the Batch Processor window.

Stereo -> Mono

This plug-in allows you to mix a stereo signal down to a mono signal while being 
certain not to clip while mixing channels because of the multipass approach. You 
can choose to use the same peak level that the stereo file contains, or set the gain 
to be applied and/or the maximum level to be reached in the resulting mono file.

This multipass plug-in is exclusive to the Batch Processor window.

Keep Same Peak Level as Stereo File

If this option is activated, the peak level of the resulting mono file is the same 
as the peak level of the original stereo file.

Gain

Specifies the increase or decrease in peak level for the resulting mono file, in 
relation to the original stereo file.

Maximum Level of Mono Signal

Specifies the peak level that the resulting mono file must not exceed. This 
ensure that the output file never clips. This way, the result never exceeds 0 dB, 
regardless of the specified Gain value.

Trimmer

This plug-in allows you to remove a specified duration (from 0 ms to 60 s) of audio 
from the head and/or tail of an audio file.
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This monopass plug-in is exclusive to the Batch Processor window.
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