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Dorico 4.1
27 May 2022

Improvements
Articulations
Articulations on split stems. A new option Articulations on the notehead side for
split stems has been added to the Horizontal Position group of the Articulations
page in Engraving Options.

This allows you to specify whether articulations should be shown only on the main
stem when split stems for altered unisons are present (the default value in new
projects) or should be shown on all stems (the default value in existing projects).
When set to Show only on main stem, when on the stem side, articulations on
stemless notes will now only appear on the main stem as well.
Articulations inside the staff. If staccatissimos are allowed inside the staff, and
articulations of duration are positioned inside slur endpoints, then staccatissimos
are now always positioned inside slur endpoints, regardless of their staff position.

Audio export
Reverb tail. Changes to the Reverb tail (s) value in the Export Audio dialog are now
correctly saved in application preferences.
Broadcast WAV. When the Broadcast WAV option is activated in the Export Audio
dialog, the correct initial timecode value is now encoded in the exported audio file.

Barlines
Reset Appearance. Edit ▶ Reset Appearance now works for time signatures and
special barlines.
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Start repeat barlines at the start of the system. It is now possible to specify that no
barline should appear at the end of the previous system using the Barline at end of
system property for start repeat barlines.

Brackets and braces
Orff instruments. When the Orchestral bracketing approach is chosen, Dorico now
ignores the Orff instruments family when determining how pitched and unpitched
percussion instruments should be bracketed together. Because the Orff
instruments family includes both pitched and unpitched instruments, it can
produce unexpected default bracketing in standard orchestral ensembles, so it is
now ignored.

Capos for fretted instruments
Note input with fretted instrument transposition. When Write ▶ Input Pitch ▶
Written Pitch is active and Edit ▶ Transposing Pitch is set, the value of In staff
notation, written C4 sounds as in the Edit Strings and Tunings dialog is now taken
into consideration during note input.

Chord diagrams
Editing chord diagrams in Engrave mode. It is now possible to edit an existing chord
diagram by double-clicking it in Engrave mode in Dorico Elements (and Dorico for
iPad, with subscription or lifetime unlock).

Chord symbols
Chord symbols between staves of a grand staff instrument. The option Position of
chord symbols on grand staff instruments that allows you to specify whether
chord symbols should appear above the top staff or between the staves of a grand
staff instrument has been moved from Engraving Options and can now be found on
the Chord Symbols and Diagrams page of Layout Options. As such, this option can
now be set independently in each layout if necessary.

Comments
Exporting comments. When exporting comments, the flow number is now
appended after the flow title to help identify to which flows the comments belong.
In addition, the name of the layout from which comments are exported is now
included in the filename used for the exported comments, to avoid multiple exports
from the same project unexpectedly overwriting each other.
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Cues
Horizontal lines. A new option Horizontal lines has been added to the Included
Notations section of the Cues page of Engraving Options, allowing you to specify
whether horizontal lines should be included in cues; a corresponding Show
horizontal lines property has been added to the Cues section of the Properties
panel, allowing this to be overridden for individual cues.

Engrave mode
Nudging bar number ranges. It is now possible to nudge the bar count and range of
bar numbers on a multi-bar rest in Engrave mode using Alt+↑/↓/←/→.
Nudging lyrics. Vertical adjustment of lyrics in Engrave mode with Alt+↑/↓ now
nudges in increments of 1/4 space, while horizontal adjustment with Alt+←/→
moves by 1/8 space.

Instruments
Improved default score order. Side drum is now ordered above bass drum in both the
Orchestral and Band instrument score orders, and the placement of the Woodwind
sketch instrument has now been corrected in both default score orders.
In addition, the order of the bass drum and clash cymbal instruments have been
swapped in the Concert Band template.

Key Editor
The Key Editor has undergone substantial further improvements in Dorico 4.1. In
addition to the reintroduction of the dynamics editor, all of the other editors have
also received significant attention – read on for the details. Even more
improvements are coming in the next Dorico 4 update.
Dynamics editor. The dynamics editor can now be chosen in the Expression and CC
section of the Key Editor, allowing you once more to tweak the playback effect of
written dynamics that are shown in the music, and to add your own non-printing
dynamics. These dynamics are automatically translated into the appropriate
playback data according to the expression map in use, and it is typically advisable to
use the dynamics editor rather than, say, manipulating MIDI CC1 directly in the
continuous controller editor.
Regions in the dynamics editor that correspond to dynamics that are printed in the
music have a green background, to differentiate them from regions of freehand
points added with the draw (or pencil) and line tools, which have a blue background.
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It is now possible to move dynamics left and right in the dynamics editor; click and
drag the first, larger handle in the green region to move the dynamic. All other
dynamics in the same group will also move by the same amount. The range of the
group that will be moved is indicated by a blue line at the top of the editor,
extending to the end of the last dynamic in the group.
The corresponding printed dynamics in the music will be moved too. Note,
however, that you cannot change both the position and the dynamic level of a green
region corresponding to a printed dynamic in the same operation. These edits must
be performed separately.
Freehand regions drawn with the draw tool, shaded blue, can be moved freely: they
will merge with each other, and if you draw or drag a blue region onto a green
region, the corresponding printed dynamic in Write mode will still appear, but its
playback effect will be overridden by the freehand range you have drawn.
Green regions corresponding to printed dynamics in the score cannot be dragged
such that they overlap any other region, either green or blue.
MIDI continuous controller editor. The resolution of the MIDI continuous controller
editor has been significantly increased, so freehand points can now be positioned
much closer to each other.
When drawing new data into or moving existing points in the MIDI continuous
controller editor, if appropriate the new or moved data will be merged with any
existing region at that position, ensuring that no gap exists at the boundary
between the existing and new data.
Editing multiple selected points in the MIDI continuous controller editor has been
greatly improved, providing much greater freedom in the kinds of edits that are
possible: in particular, a selected continuous range of points can be dragged to any
position; a single point can be dragged up to the adjacent point on either side; and a
discontiguous selection can be dragged by the distance to the closest adjacent point
to either side.
The hit testing for points in the MIDI continuous controller editor has been
improved, so the expected point is always selected, and clicking on the background
in the MIDI continuous controller and velocity editors now correctly clears the
selection.
Modifiers for dragging. You can now add modifier keys when clicking and dragging
selected points in the continuous controller, tempo and dynamics editors:
§

Hold Shift when dragging selected points to constrain the positions and
change only the values when dragging vertically, or to constrain the values
and change only the positions when dragging horizontally.
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§

Hold Alt when dragging selected points to copy them instead of moving
them.

Velocity editor. It is now possible to edit the velocities of individual notes in chords.
Velocity bars are now stacked in order of velocity, with the highest velocity at the
back and the lowest velocity at the front; if you select a velocity bar, then it will
always be drawn on top of all other velocity bars at that position.
With the select tool active, clicking in the velocity editor when no velocity bar is
already selected will select the frontmost velocity bar at that position. You can then
click and drag up and down anywhere in the horizontal space occupied by the
velocity bar to change its value; as such, to select another velocity bar at the same
position when a velocity bar is already selected, either use Ctrl+click (Windows) or
Command-click (Mac) to add or remove from the selection, or click on a blank part
of the editor background to clear the current selection before selecting the desired
velocity bar.
Marquee selections now also allow you to select individual velocity bars without
selecting all notes in that rhythmic region.
With the line or pencil tools active, as you drag across a series of velocity bars, if no
velocity bars are selected at that position, the resulting edit will apply to all notes at
that position, but if one or more velocity bars is selected at that position, the
resulting edit will only apply to the selected notes at that position.
The performance of the pencil and line tools have also been improved, so changing
velocities by drawing freehand across a range of notes and chords now feels much
more responsive.
Finally, the vertical bars in the velocity editor now have a border, to make it easier to
differentiate multiple notes at the same position.
Tempo editor. It is now possible to set the vertical range of the tempo editor in the
Key Editor by specifying the maximum tempo value that can be displayed: simply
set Range max. to the desired maximum value; this choice is saved in the current
project.
Pitch bend editor. The pitch bend editor now shows a horizontal guide line in the
vertical center of the editor, showing the mid-point (value 0); points will snap to this
line as they are dragged towards this value. To prevent points from snapping, hold
Ctrl (Windows) or Command (Mac) while dragging.

Key signatures
Accidental placement. The default placement of accidentals in flat key signatures for
the mezzo-soprano clef has been improved.
Dorico 4 Version History
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Library Manager
Export Library. A new Library ▶ Export Library command has been added that
allows you to export all library collections and options from the current project into
a .doricolib file that can later be imported, in whole or in part, into another project
via the Library Manager.
Comparing against the user library. When comparing the current project’s library to
the user library, the factory library values are now shown for values that are not set
in the user library, giving a more accurate picture of the effect of importing settings
from the user library.

Lyrics
Lyrics and paragraph styles. Lyrics are now drawn using paragraph styles, rather
than font styles; you will find five new paragraph styles –Lyrics, Lyrics (Chorus),
Lyrics (Chorus Translation), Lyrics (Translation) and Lyrics (Verse Numbers) – in
Library ▶ Paragraph Styles, and the old font styles no longer appear in Library ▶
Font Styles.
When opening an existing project, Dorico will update the new lyrics paragraph
styles to match as closely as possible the appearance of the corresponding font
styles.
When you open a project last saved in Dorico 4.1 in an earlier version, you will find
that the basic parameters of the lyrics paragraph styles have been applied to the
font styles, so lyrics will appear in at least the correct font family, style and size in
the earlier version, but any advanced paragraph style properties (such as squashing
or stretching the text) will not appear.
The precise positioning of lyrics in existing projects cannot be maintained in Dorico
4.1: for most projects you should notice no visible difference, but the change to
drawing lyrics using rich rather than plain text results in unavoidable changes in
metrics and measurements. The impact is that lines of lyrics may appear slightly
further away from the staff than before, and because the widths for individual lyrics
now include the side bearings of the first and last character in each lyric, they are
slightly wider than before.
If you have performed very detailed editing of lyric placement and spacing in your
existing projects and do not want to carefully proof-read and potentially re-edit
them, you are recommended to maintain Dorico 4.0.31 on your computer alongside
Dorico 4.1, and use the older version for those existing projects.
Because lyrics are now drawn with paragraph styles, they can have a different size
in full score and part layouts if desired.
Dorico 4 Version History
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Edit Single Lyric. A new Edit ▶ Notations ▶ Lyrics ▶ Edit Single Lyric dialog has been
added, allowing you to edit the rich text content of an individual selected lyric. This
allows you to change the style and formatting of individual characters within the
lyric, including changing the font if necessary. If you change the font family or point
size of an individual lyric, it will very likely no longer be aligned vertically with
neighboring lyrics in the same line. You can use the baseline shift property in the
Edit Single Lyric dialog to mitigate this if necessary.
Overriding the paragraph style for a lyric. A new Paragraph style property has been
added to the Lyrics group in the Properties panel, allowing you to override the
paragraph style used for an individual lyric. This is helpful if you want to make an
adjustment to, say, all the lyrics on a system, to choose a paragraph style with a
slightly different size or Text stretch value.
Reset Appearance. Any formatting changes made to a lyric in Edit Single Lyric can
be reset using Edit ▶ Reset Appearance.
When you change the content of a lyric via the popover, e.g. to correct a typo or
change the word altogether, any existing rich text formatting added via the Edit
Single Lyric dialog will similarly be removed.
Hanging punctuation. A new option Punctuation at the start or end of lyrics has
been added to the Spacing section of the Lyrics page of Engraving Options, allowing
you to specify whether hanging punctuation (at the start or end of each lyric
syllable) should be considered when determining the alignment of each lyric
syllable relative to the note to which it belongs; in new projects, hanging
punctuation will be ignored, but to preserve the appearance of existing projects, the
option is set to Consider when positioning by default.
Elision slurs. A new option Scale factor for gap between elided syllables has been
added to the Spacing section of the Lyrics page of Engraving Options: in new
projects this is set to 0.5, which reduces the space occupied by the elision slur and
the gap between adjacent lyrics; it remains set to 1.0 in existing projects to preserve
their current appearance.

Note input and editing
Lock Duration. A new option Jump over rests to next note only if closer than n
quarters (crotchets) has been added to the Note Input and Editing page of
Preferences. When using Lock Duration to repitch existing music, this allows you to
specify that Dorico should exit Lock Duration when you come to a large gap in the
voice, rather than jumping ahead by potentially dozens or even hundreds of bars.

Dorico 4 Version History

10

Steinberg Media Technologies GmbH

Percussion
Playback of diddles. The playback of diddles (measured single-note tremolos) for
unpitched percussion instruments has been improved: only for percussion kits,
Dorico now considers only the actual number of tremolo strokes on the stem,
instead of adding together the number of beam lines and tremolo strokes, to
determine whether the tremolo meets the threshold Minimum number of strokes
for playback of unmeasured tremolos on the Timing page of Playback Options. In
practice this means that a single tremolo stroke written on a note of any duration
will always play as a measured tremolo.

Playback
New effects plug-ins. Dorico 4.1 includes two new built-in VST effect plug-ins:
Frequency and Multiband Compressor.
Frequency is a high-quality equalizer with 8 fully parametric bands. The bands can
act as shelving filter, as peak or notch filter (band-pass), or as cut filter (lowpass/high-pass).
Multiband Compressor allows a signal to be split into four frequency bands. You can
specify the level, bandwidth, and compressor characteristics for each band.
Editing velocity via Properties. A new Velocity property has been added to the Notes
and Rests group in the Properties panel, allowing you to edit the MIDI velocity of a
selected note.
Abutting notes with 100% duration. If the option Play as % of written duration for
Default notes on the Timing page of Playback Options is set to 100%, a new option
Shorten note if followed by abutting note of same pitch appears, allowing you to
specify whether the first of two abutting notes of the same pitch should be
shortened by a single MIDI tick, to ensure that the note off message for the first note
is processed before the note on message for the second note.
Resetting port and channel when choosing a new plug-in. When you choose a new
VST instrument or MIDI device in the Routing section of the track inspector in Play
mode, the Port and Channel controls are now automatically reset to 1.
Updated audio engine. The audio engine and its related components have been
updated to the latest versions, providing some bug fixes and stability
improvements.
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Print mode
Printing selected flows. A new option Flows has been added in the Job Type section
of the right-hand options panel in Print mode. Click Choose to select which flows
should be printed, as a quick way of setting up a page range for printing:

If your layouts allow multiple flows to appear on the same page, please note that
only complete pages will be printed, so if you ask Dorico to print the third flow, and
the third flow begins on the same page on which the second flow ends, that
complete page will be printed. The choice of flows is saved in the project, so it will be
preserved the next time you print the project.

Project files
Cloud-aware project handling. When the open project file is located in a cloudenabled directory – for example, iCloud Drive, Dropbox, or OneDrive – and the
project file is updated as a result of synchronizing changes made on another device,
Dorico will now show you a prompt informing you that the project has changed,
allowing you to choose whether to save your current version under a new name, or
overwrite the updated version, or, if the project has no unsaved changes, reload the
updated version.
Exporting flows. A new option Omit empty flows and layouts when exporting
flows has been added to the Files section of the General page of Preferences. If you
are exporting individual flows from a larger project and want to maintain the same
instrumentation and layouts for the exported file, even if some instruments may
not be playing in the flows you export, deactivate this option.
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Staff labels
Periods after abbreviated instrument names. The Period (full stop) after
abbreviated instrument names option on the Staff Labels page of Engraving
Options is now also applied to staff labels that use the short player name instead of
the short instrument name.
Player names for percussion grids. It is now possible to use the player name instead
of the instrument name for players holding percussion kits when using the grid
presentation type.

User interface
Custom colors. A new Colors page has been added to the Preferences dialog. The
existing options for the setting the page and background colors that were
previously in the View section of the General page have been moved to this page.
Additionally, a new option Invert colors for music (white on black) has been added
to the new Colors page of Preferences; activate this to show the music in white on a
dark background, the color of which can be customized.

A new Voice Colors section has been added to the new Colors page of Preferences,
allowing you to customize the colors used for the first eight voices on each
instrument.

Finally, a new Other Colors section has been added to the Colors page of
Preferences, allowing you to customize the colors used for items that display in the
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score, including the caret and rhythmic grid, the shadow note, selections, out of
range notes, and the playhead:

Properties panel. It is now possible to click on the text label to the right of the slide
switch to activate or deactivate a property in the Properties panel.
List view in the Hub. The project name and path shown in the list view in the Open
Recent page of the Hub are now elided if necessary.
Adding a new tab. If you invoke Window ▶ New Tab when the tab bar is not visible,
Dorico first shows the tab bar and then creates a new tab.
Colors in Play mode. The colors used in the Key Editor and in Play mode have been
updated to make them more vibrant.
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Issues resolved
Component

Issue

Bar rests

Updating the Bar rest design in long time signatures option on the Rests page of Notation
Options now always correctly updates the score immediately.

Barlines

Under some circumstances, changing the barline at the end of the previous system using the
Barline at end of system property for start repeat barlines would not cause an immediate
redraw; this has now been fixed.

Barlines

It is now always possible to restore the default final barline at the end of a flow, either via the
panel or via the popover.

Beaming

With certain values for Shortened stem length for 16th (semiquaver) and shorter on the
Notes page of Engraving Options, it was possible for flat 32nd note beams to be incorrectly
positioned with respect to staff lines; this has now been fixed.

Beams

The option Flat beams with inner note closer to the beam than outer notes in the Advanced
Options section of the Slants section of the Beams page of Engraving Options now only takes
effect for eighth note (quaver) beams.

Chord diagrams

It is no longer possible to specify zero chord diagrams per row in the frame showing chord
diagrams used in the flow; this prevents Dorico from crashing.

Chord diagrams

Fingerings now correctly chord diagrams shown at the start of the flow if Show fingerings in
chord diagrams at start of flow is activated on the Chord Symbols and Diagrams page of
Layout Options.

Chord symbols

Creating a chord symbol region via the Shift+Q popover can now be correctly undone.

Chord symbols

Choosing either of the appearances that specify the use of a comma for the option Separating
added notes and alterations in the Alterations section of the Chord Symbols page of
Engraving Options now works correctly.

Chord symbols

Background erasure rectangles for chord symbols no longer sometimes remain on staves
where chord symbols are no longer drawn.

Chord symbols

When changing the default music font to Petaluma, small accidentals as shown in alterations
in chord symbols are now the correct size by default.

Chord symbols

Under some circumstances, changing the custom player order for a layout could cause chord
symbols supposedly set to appear above the top staff to appear in the wrong place; this has
now been fixed.
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Component

Issue

Chord symbols

A problem whereby chord symbols in galley view could unexpectedly move progressively
further away from the staff when editing later notes has been fixed.

Clefs

Entering an invalid string such as sub-f into the Shift+C popover no longer causes Dorico to
crash.

Comments

The Add Comment command is now only enabled when something is selected.

Comments

The Export Comments button in the action bar in the Comments panel is now always
correctly enabled if at least one comment exists.

Cues

Hidden cues that start or end in the middle of a bar no longer sometimes leave behind padding
rests.

Cues

The Instrument pitch or transposition option for cue labels on the Cues page of Engraving
Options is now always correctly respected.

Engrave mode

Glissando lines can once again be nudged in Engrave mode.

Harp pedaling

Harp pedal changes hidden by way of the Hidden property or having Show harp pedaling
deactivated on the Players page of Layout Options no longer prevent otherwise empty staves
from being hidden.

Jump bar

Setup ▶ Propagate Part Formatting can now be invoked via the jump bar regardless of
whether a layout is selected in the Layouts panel in Setup mode.

Key Editor

It is no longer possible to drag a velocity bar in the velocity editor to a value of zero.

Key Editor

When saving the project, the selected instrument in the Key Editor is no longer unexpectedly
reset.

Library Manager

Under some circumstances, Dorico could crash when importing library items in the Library
Manager; these problems should no longer occur.

Library Manager

The Library Manager no longer lists internal-only font styles.

Localization

It is now possible to use the Input Method Editor (IME) in the instrument picker.

MIDI import

When importing a MIDI file into an existing flow, the time and key signatures in the MIDI file
will now be imported if the destination flow has no existing time or key signature at the start.

MIDI import

When importing a MIDI file into an existing project in versions of Dorico that limit the total
number of players, Dorico once again now only imports sufficient tracks to avoid exceeding
the player limit.
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Component

Issue

Mixer

Under some circumstances, opening multiple projects and activating and deactivating them
for projects could result in the VU meters in the lower zone Mixer not updating correctly; this
has now been fixed.

Music symbols

The relative position of imported graphics in user-defined music symbols has now been
corrected, and matches the appearance of Dorico 3.5 and earlier versions.

MusicXML import

MusicXML 4.0 files that contain the new swing element now import without reporting the file
as invalid.

Note input and

When editing notes that span tuplet boundaries, Dorico will scale any properties that force the

editing

note to be split with ties at specific positions so that the ties are retained if possible.

Note input and

When pasting material, Dorico no longer incorrectly selects any notes that were not part of

editing

the pasted material but were affected (e.g. truncated) by the pasted material.

Note input and

Edit ▶ Select to End of Flow no longer incorrectly includes time and key signatures if the

editing

selection was invoked on the top staff in the system.

Note input and

Dorico no longer considers the duration of an entire dynamic group of which a single dynamic

editing

is selected when determining the extent for multi-paste.

Note input and

Under some circumstances, including explicit rests that have no specific duration in the

editing

selection and then changing their duration (for example, using Double Note Durations) could
result in the notes ending up at incorrect rhythmic positions; this has now been fixed.

Note input and

When pasting, Dorico now once more retains the voice of the source material by default.

editing
Note input and

The speed of Edit ▶ Select All has been greatly improved.

editing
Note input and

Under some circumstances, changing the transposition of the current layout when

editing

condensing is active could cause rhythm slashes to be incorrectly transposed; this has now
been fixed.

Note input and

Deleting multiple notes within a tuplet when the global scope for Insert mode is being used no

editing

longer sometimes causes the remaining notes in that voice to be incorrectly deleted.

Note input and

A problem whereby swapping voices could unexpectedly fail to remove a tuplet if another

editing

item, such as a slur, overlaps the range to be swapped has been fixed.

Note spacing

When adding or removing time via step-time input in Insert mode, Dorico now shifts note
spacing adjustments where possible, instead of removing them.
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Component

Issue

Percussion

When opening existing projects, Dorico now removes any spurious Starts voice/Ends voice
properties that were set on percussion kits in versions prior to 4.0, ensuring that all expected
rests appear when the project is opened in the current version.

Playback

When a trill is followed by a slashed grace note of the trilled-to pitch, Dorico now ensures that
the final note generated for the playback of the trill itself is the trilled-from pitch, to avoid a
repeated pitch.

Playback

If the current expression map specifies playback techniques for trills or unmeasured tremolos
as add-on switches, Dorico no longer incorrectly also plays the trill using generated notes.

Playback

Add-on switches no longer prevent any transposition (if any) specified in the base switch from
being applied during playback and auditioning.

Playback

When multiple instruments are routed to the same endpoint (the same port/channel of the
same VST instrument or MIDI device), editing the music on one of those instruments would
then cause the other instruments routed to the endpoint to become silent until the project is
reloaded; this has now been corrected.

Playback

Deactivating a project for playback while it is playing back now correctly stops playback.

Playback

Dorico now sends 'all notes off' and controller reset messages when changing the endpoint for
an existing instrument, to ensure any note currently playing on the previous endpoint is
correctly stopped.

Playback

When MIDI controller values, key switch notes and regular notes are all intended to be output
at the same MIDI tick, Dorico now plays key switches first, then controllers, then finally the
regular notes.

Playback

When calculating playback technique regions for dynamics (e.g. for sfz dynamics assigned to a
specific playback technique in an expression map), Dorico now correctly uses the position of
the individual dynamic within its larger group, if any.

Playback

Dorico did not calculate the duration of grace notes and generated notes for tremolos for
tempos that use a beat unit other than a quarter note (crotchet); this has now been fixed.

Playback

When the project is not active for playback, it is no longer possible to attempt to load
instrument or effects plug-ins via the track inspector in Play mode or via the Mixer.

Playback

In some projects with extended passages of open meter, the playhead and time display readout in the Transport would sometimes stall before the next barline; this has now been fixed.

Playback templates

When matching instruments in the project to a playback template, Dorico once again
correctly uses the parent instrument type if no more specific entry for an instrument is found.

Print mode
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Component

Issue

Print mode

If the user’s saved page range is empty when switching to Print mode, Dorico now
automatically resets the page range to contain all pages.

Project files

Dorico no longer removes empty-handed players that are not assigned to any flows, or empty
player groups, when saving projects.

Project files

When opening existing projects, Dorico will automatically remove any duplicate font styles
that it finds.

Project templates

User-defined project templates now correctly take precedence over factory-supplied projects
with the same name.

Project templates

When you create a new project based on a user-defined project template via the File ▶ New
From Template submenu, Dorico no longer incorrectly changes the Show flow headings
option on the Page Setup page of Layout Options.

Real-time recording

When recording MIDI continuous controller data during real-time recording, the automation
data is now directed to the appropriate track if independent voice playback is enabled.

Real-time recording

When recording at the start of any flow after the first in a layout, Dorico no longer incorrectly
resets the sound used for auditioning to the sound used by the topmost instrument in the
layout.

Real-time recording

When determining the optimal enharmonic spelling for notes input via real-time recording,
Dorico now correctly considers any explicit key signature changes in the flow.

Staff labels

Horn in B now appears correctly as “Horn in B” when the options on the Language page of
Engraving Options are set to use German instrument names with English note names.

Tempo

Under some circumstances, a gradual tempo marking coinciding with a time signature
change and spanning a system break could fail to be aligned with the time signature; this has
now been corrected.

Text

When editing a paragraph style in Library ▶ Paragraph Styles, Dorico now correctly
remembers any edits that are made purely to whether or not a particular property has been
overridden from its parent style for all styles edited during a single session of the dialog.

Text

Dorico can now once again correctly apply stretch and compression to extended weights
(medium, semibold, etc.) of font families (macOS only).

Time signatures

When switching between time signatures above and inside the staff, Dorico no longer
sometimes incorrectly continues to draw cautionary time signatures above the system.

Tokens

In layouts where flows can start anywhere on the page, the {@flowPage@} token is now
calculated correctly.

Dorico 4 Version History

19

Steinberg Media Technologies GmbH

Component

Issue

Transformations

Under some circumstances, Dorico could crash when applying transformations from the
Write ▶ Transform submenu; this has now been fixed.

User interface

The redundant Register Now menu item in the Help menu has been removed.

User interface

If you have edited the name of a factory-supplied library item, Dorico now ensures that your
edited name appears throughout the application; in some places, the original name was
sometimes incorrectly shown.

User interface

Clicking an existing project in the Open Recent page of the Hub and then hitting Return to
open it now always opens the project you clicked.

User interface

The click areas for the spin boxes used to specify measurement values for staff spacing in
Engrave mode have been adjusted, and it is now possible to select a system handle nearby to
the spin box.

User interface

When reopening the Hub, for example after closing the last project, the first (most recently
opened) project on the Open Recent page is now automatically highlighted.

User interface

If you had selected an ensemble from the Choose page of the ensemble picker and then
switched to the Build page and specified some instruments, when you clicked Build, the
ensemble from the Choose page would have incorrectly been created; this has now been fixed.

User interface

The buttons to edit playing techniques in the Playing Techniques panel in Write mode are now
only enabled when a playing technique is selected.

User interface

The list of playing techniques in Library ▶ Playing Techniques now scrolls automatically to
bring the selected playing technique into view.

User interface

The placement of the checkboxes on the cards in the Layouts panel in Setup mode when the
vertical scrollbar appears has been improved.

User interface

Line styles that contain font characters in their bodies now appear correctly in the Lines panel
in Write mode when the dark theme is enabled.

User interface

The list of font styles that appears in the various music symbol editors in Dorico now show the
translated name for each font style rather than its internal name.

User interface

If one of the tools in Engrave mode that shows no panel is active when returning to Engrave
mode from Print mode, the toolbox is no longer incorrectly displayed halfway down the lefthand edge of the project window.

User interface

Hitting Space after choosing the type of editor in the Key Editor to start playback no longer
unexpectedly opens the combo box as well as starting Playback.
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Dorico 4.0.30
20 March 2022

Improvements
Play mode
Tempo editor. The tempo editor has been reinstated in Play mode. To edit tempo,
select the global Tempo track at the top of the track overview in Play mode, and
ensure the Key Editor is shown in the lower zone. In addition, if linked mode is
active, selecting a tempo item in Write mode will show the tempo editor in the Key
Editor, if it is visible.
Editing tempo is much the same as in Dorico 3.5: you can use the Draw and Line
tools to add immediate and gradual tempo changes respectively. Tempo changes
that you add in Play mode appear in Write mode as signposts, and can be shown for
printing via the Properties panel if need be.
MIDI pitch bend editor. The MIDI pitch bend editor has also been reinstated in Play
mode. It can be chosen from the menu in the Expression and CC section of the Key
Editor. The semantic pitch bend editor (which shows, for example, the pitch bends
produced by guitar bends) is not included in Dorico 4.0.30 but will return in a future
update, along with the remaining missing editors (dynamics and percussion).

Hub
List view. The Open Recent page of the Hub now supports a list view in addition to
the familiar grid view: simply choose your preferred view type using the buttons on
the right-hand side of the window.
Keyboard access. You can now use ↑/↓ to move through the grid or list of recent
projects, and hit Return or Enter to open the highlighted project.
Learn updates. When the Hub first appears after starting Dorico, the Learn button
will now show a red badge to indicate that new items have been added to the Videos
or Dorico blog feeds on the Learn page; when you click the Learn button, the badge
will disappear.

Barlines
Start repeat barlines at the start of the system. When you have a start repeat barline
that coincides with the start of a system, you may wish the barline at the end of the
previous system to be shown either as a normal barline or a double barline; an
Dorico 4 Version History
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option to control this has long been found in the Repeats section of the Barlines
page of Engraving Options. However, such an option always applies to the whole
project, which may or may not be appropriate.
Therefore, a new property Barline at end of system has been added to the Time
Signatures group in the Properties panel, which appears only when a start repeat
barline is selected; this allows you to specify what kind of barline should appear at
the end of the previous system.
The same property can also be used to override the barline shown when a change of
key signature and a start repeat barline coincide: by default, Dorico shows a double
barline to the left of the key change, then the start repeat barline. If you want to
show a different barline instead, activate Barline at end of system and choose the
desired barline type.

Chord diagrams
Fingerings at the end of the string. A new Chord diagram fingering font font style
has been added, now used to draw the fingering numbers at the ends of strings in
chord diagrams, allowing you to specify their font, style and size.

Cues
Properties. When selecting an item as part of a cue in Engrave mode, the Properties
panel now hides any global properties so that you cannot inadvertently change the
appearance of the source material by setting properties in another layout.
Reset Appearance and Reset Position. Similarly, when you have selected an item as
part of a cue in Engrave mode, Edit ▶ Reset Appearance and Reset Position will not
reset global properties.

Staff labels
Periods after abbreviated instrument names. There are different conventions for
whether or not an abbreviated word should be indicated by appending a period (full
stop): some publishers always indicate an abbreviation by appending a period, while
others only append a period when the last letter of the abbreviation is not the last
letter of the full word. Dorico has always followed this latter convention, until now.
A new option Period (full stop) after abbreviated instrument names has been
added to the Staff Labels page of Engraving Options, allowing you to specify
whether you want to see, for example, “Vln” or “Vln.” for abbreviated instrument
names.
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Issues resolved
Component

Issue

Bars and barlines

The location for adding bars in the Bars and Barlines panel is now set to End of flow by
default.

Flows

Under some circumstances, attempting to import a flow from a project containing emptyhanded players could fail, resulting in an empty flow being added to the project; this has now
been fixed.

Instrument filters

When the instrument filter overlay is not shown, it is now possible to select the items in the
area where it previously appeared (we mean it this time).

Library Manager

Closing a project or quitting Dorico with the Library Manager open now correctly closes the
Library Manager and the source project, if any, from which items and options are being
imported.

Library Manager

When opening the Library Manager and choosing the Layout Options category on the left, the
Layout drop-down now shows the correct layout name by default.

MusicXML import

Under some circumstances, when importing a MusicXML file with unmetered passages,
Dorico could crash trying to allocate an incorrect size to a bar; this has now been fixed.

Numbered bar

The value of the Show in final bar property for a numbered bar region now always takes

regions

precedence over the corresponding Engraving Option.

Percussion

Real-time recording into a custom or imported percussion kit now works correctly.

Percussion

The correct percussion sounds are now always played when auditioning notes in a percussion
kit.

Performance

A problem whereby network requests resulting in redirections could eventually exhaust a
Windows resource, resulting in a crash, has been resolved (Windows only).

Performance

The overall performance of Dorico when you have a very large number (hundreds) of VST
plug-ins installed is now significantly improved.

Playing techniques

Continuation lines for playing techniques now always draw on the correct staff following a
system break, regardless of whether the glyph or text is repeated at the start of the system.

Quick Look

Attempting to show a Quick Look preview for a project that does not contain one no longer
causes Quick Look to crash (macOS only).

Repeats

Changing the number of times a repeat ending should be played now correctly immediately
updates playback.
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Component

Issue

Slash regions

Under some circumstances, setting properties on a selected barline in the middle of a slash
region could cause slashes in the bar before the barline to disappear temporarily; this has now
been corrected.

Text

Under some circumstances, attempting to edit a system-attached text item in a layout
containing tablature could crash; this has now been fixed.

User interface

The color of scroll bar thumbs when running Dorico in its light theme has now been darkened.

Views

When opening an existing project with the tab bar showing, Dorico once more correctly
restores the last-saved view and zoom level in each tab.
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Dorico 4.0.20
7 March 2022

Improvements
Accidentals
Cautionary accidentals in the Modernist scheme. A new option Notes at the same
octave within the same bar for cautionary accidentals has been added to the
Modernist Options section of the Accidentals page of Notation Options.

Barlines
Barline joins on vocal staves. A new Barlines between vocal staves at the ends of
systems option has been added to the Barlines page of Engraving Options, making
it possible to join a group of vocal staves with a single barline at the end of the
system while maintaining breaks between staves at other barlines to accommodate
lyrics. This convention is used by some European publishers.

Beams
A new option Flat beams with inner note closer to the beam than outer notes has
been added to the disclosable Advanced Options section of the Slants section of the
Beams page of Engraving Options.
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This option allows you to disable stem shortening for flat beams where the inner
note is closer than the outer notes, which can produce a more consistent beam
placement in passages of repeated, alternating notes or chords.

Chord diagrams
Fingerings in chord used in flow. A new Show fingerings in chord diagrams at start
of flow option has been added to the Chord Diagrams section of the Chord Symbols
and Diagrams page of Layout Options.

Holds and pauses
Single-stroke caesura. A new single-stroke caesura has been added. It can be
created using the Holds and Pauses panel in Write mode, or by typing //single into
the Shift+H popover.

Jump bar
Additional commands. The jump bar now lists a wider range of commands: in
general, any command that appears in the Key Commands page of Preferences and
can have a shortcut assigned should now appear in the jump bar.
Fuzzy matching. The algorithm used to match your input to commands in the jump
bar has been adjusted, so that it is no longer necessary to type a precise substring
corresponding to the command’s name: you can alternatively type initials or
snippets of the command name, and Dorico will perform a fuzzy match to try to
return more useful results.

Key Editor
Quick tool selector. Right-clicking in the editor opens a quick tool selector (similar to
the tool buttons palette in Cubase) that allows you to change the current tool very
rapidly: hold the right mouse button to show the quick tool selector, move the
pointer over the tool you want to use, then release the right mouse button. You can
return to the select tool by simply right-clicking, as the selector will open at the
mouse pointer's current position, automatically choosing the select tool.
Selection behavior. The multi-select tool has been removed from Dorico for macOS
and Windows (though it is still present in Dorico for iPad), and its functionality has
been combined with the existing select tool. With the single tool:
§

Clicking a note, velocity bar or automation point will set the selection to the
clicked object

§

Clicking an empty space will clear the selection

§

Marquee selections can be made by dragging from an empty space, without
the need to use a keyboard modifier
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§

Ctrl+click (Windows) or Command-click (macOS) will add or remove a note,
velocity bar or automation point from the selection

§

Holding Ctrl (Windows) or Command (macOS) while clicking and dragging a
marquee will add to the current selection

§

Shift+click will add a range to the selection. This either adds all objects
before the start of the range, after the end or in the middle.

Zoom. It is now possible to change the horizontal zoom level of the Key Editor when
the mouse pointer is over any part of the main piano roll, velocity and continuous
controller editors by holding Ctrl (Windows) or Command (macOS) and using the
mouse wheel.
Velocity editor. When modifying the velocities of multiple selected notes in the
velocity editor, edits are applied as deltas on the current values, rather than first
snapping the values of all selected notes to a single value.

Library Manager
Synchronizing options and collections. It is now possible to synchronize all options
and all library collections using the new buttons in line with the corresponding
category headers in the left-hand list in the Library Manager.

Lyrics
Navigation in Engrave mode. Navigating between lyrics has been improved: in
Engrave mode, using ↑/↓ to move between lines of lyrics is more reliable, and in
both Write and Engrave modes, using ←/→ to move between adjacent lyrics in the
same line is likewise now more reliable.

Playback templates
NotePerformer. When applying the NotePerformer playback template, Dorico now
automatically sets Playback approach for trills to Generated only on the Trills page
of Playback Options.
This is especially useful if you are running Dorico Elements or Dorico SE, which do
not provide direct access to editing Playback Options.

Trills
Trill extension lines. A new option End position for trill extension line has been
added to the Ornaments page of Engraving Options, allowing you to specify that the
trill extension line should end immediately after the last notehead in a tie chain (as
recommended by Ted Ross), or should extend to just before the following note (as
recommended by Elaine Gould).
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Spotlight and Quick Look (macOS only)
Dorico now supports Spotlight system-wide search and Quick Look file preview on
macOS.
The fields in Project Info in Dorico projects, such as title, composer, lyricist and so
on, can be indexed by Spotlight.
Dorico projects last saved in Dorico 4 or Dorico for iPad include a PDF preview of the
last active layout, and this is what will be shown when activating Quick Look in the
Finder (by default, this is bound to the keyboard shortcut Space), and such projects
will also show a thumbnail in the Finder instead of the standard Dorico project icon.
Projects that have not yet been saved from Dorico 4 or Dorico for iPad do not
include suitable graphic previews, and so will not display a thumbnail in the Finder
or show a preview via Quick Look.
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Issues resolved
Component

Issue

Audio engine

Having certain older versions of Groove Agent SE installed could cause the audio engine to
crash on start-up; this has now been fixed.

Audio export

When exporting audio, Dorico no longer incorrectly considers the instruments selected in the
score when determining which instruments to export.

Bar numbers

When choosing to propagate layout options when using Propagate Part Formatting, the Bar
Numbers options are now included.

Barlines

Setting Barline at end of each system to Join all staves on the Barlines page of Notation
Options no longer causes all staves to be joined with a single barline every few bars in galley
view.

Beams

Dorico no longer crashes if you confirm the Custom Centered Beam dialog with no beamed
groups selected.

Chord diagrams

Under some circumstances, Dorico would refuse to allow you to delete a user-defined chord
diagram shape, even once it is no longer in use in the project; this has now been fixed.

Chord diagrams

When editing fingerings in the Edit Chord Diagram dialog, the editing fingerings now appear
in the expected place.

Chord symbols

Dorico no longer hangs or crashes when clicking Save as Default in the Project Default Chord
Symbol Appearances dialog.

Clefs

Typing g1 into the Shift+C popover now produces a French violin clef.

Cues

Deleting a cue now always ensures that any multi-bar rests at the end of the flow are correctly
updated.

Cues

When creating a cue on a percussion kit, Dorico now correctly creates a rhythmic cue even if a
slash region is selected.

Dynamics

When a messa di voce hairpin follows an immediate dynamic, the transition point from one
hairpin to the next is now handled correctly.

Engrave mode

Articulations on down-stem notes now move in the expected direction when nudged with
Alt+↑/↓ in Engrave mode.

Engrave mode

Crosshairs for selected items in Engrave mode no longer appear twice in layouts showing both
tablature and staff notation.
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Component

Issue

Engrave mode

Double-clicking a lyric in Engrave mode now once again correctly switches to Write mode and
edits the lyric, as expected.

Engrave mode

Horizontal lines can once again be nudged with Alt+↑/↓/←/→ in Engrave mode.

Engrave mode

Nudging an instrument change label that has been positioned after a cue (by way of the Show
instrument change label after cue, if cue precedes first note in new instrument option on
the Players page of Layout Options) no longer causes that instrument change label to
disappear.

Engrave mode

Nudging lyrics vertically with Alt+↑/↓ now moves them by the same distance as they moved
in Dorico 3.5 and earlier.

Figured bass

When using Figurato for figured bass instead of Bravura, the placement of brackets and
parentheses around figures and accidentals is now correct.

Fingering

When Allow left-hand fingerings inside the staff for fretted instruments is deactivated on
the Fingering page of Engraving Options, all existing fingerings are now immediately and
correctly updated.

Guitar bends

It is now possible to nudge the individual segments of guitar bends and hold lines that cross a
system break correctly in Engrave mode.

Instrument filters

When the instrument filter overlay is not shown, it is now possible to select the items in the
area where it previously appeared.

Instruments

Dorico no longer adds an unnecessary trailing or leading space in instrument change
warnings when using a custom prefix or suffix.

Instruments

Switching off the Show instrument change label at start of flow option on the Players page
of Layout Options now correctly updates the score display right away.

Instruments

The border padding values defined for the Instrument change paragraph style are now always
used if set to show a border.

Instruments

The default order of saxophone instruments in the Orchestral and Band instrument score
orders has been improved (thanks to Matt Ehler).

Instruments

Tubular bells in new projects are now correctly written at their strike pitch and sound one
octave lower than written in playback.

Jump bar

Under some circumstances, hitting J followed by Return to execute the last-used command in
the jump bar would not work; this has now been fixed.
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Component

Issue

Key Editor

Adding a new voice in Write mode now updates the display of per-voice tracks for
instruments with IRV enabled in the track overview in Play mode.

Key Editor

Drawing points for the first time into a particular MIDI controller lane for an instrument and
then undoing now always updates the display immediately.

Key Editor

Notes input in the piano roll now respect the octave transposition of the current instrument, if
any.

Key Editor

The display of playing techniques in both the playing technique lane itself and its tool tips has
been corrected: it no longer sometimes shows information for the previous playing technique,
and correctly takes repeats into account.

Key Editor

The line that shows the constant value of the final point in the continuous controller editor is
now always drawn in the correct position.

Key Editor

Under rare circumstances, it was possible for Dorico to hang or crash when selecting a point
corresponding to a dynamic in the dynamics editor in Play mode; although the dynamics
editor is not currently available in Dorico 4, this underlying problem has been resolved.

Library Manager

The header for a list of entities in a collection in the Library Manager was not always correctly
updated when changing the source library; this has now been fixed.

Library Manager

The Library Manager is now closed automatically when the last window belonging to the
project with which it is associated is closed.

Library Manager

The Library Manager now opens with the user library chosen for comparison by default, if
available.

Library Manager

Under some circumstances, clicking Apply to apply changes in the Library Manager with a
term entered into the filter line edit could cause Dorico to crash; this has now been fixed.

Library Manager

When clicking Apply in the Library Manager, the right-hand area now retains its current scroll
position, rather than returning to the top.

Library Manager

When clicking the button to open the file picker in the Library Manager, the picker now opens
on your Dorico Projects folder by default.

Localization

A problem whereby choosing to use English note names for instrument transpositions when
running Dorico in German could cause the note name B flat to appear as H flat has been
resolved.

Localization

If you have Keyboard language set to Auto on the Key Commands page of Preferences, the
default key commands will be reloaded when you change the application language while
Dorico is running.

Dorico 4 Version History

31

Steinberg Media Technologies GmbH

Component

Issue

Localization

The jump bar is now correctly updated when you change the application language while
Dorico is running.

Localization

The track inspector and VST rack on the left-hand side of Play mode are now wider, and
correctly accommodate translated strings in all supported languages.

Localization

When changing the application language via Preferences, all existing menus and sub-menus
are now immediately updated with the newly-chosen language.

Lyrics

A problem whereby having the Show verse number property overridden for multiple lyrics in
the same line could cause verse numbers to be unexpectedly hidden has been resolved.

MIDI import

When combining multiple tracks together during MIDI import, Dorico no longer sometimes
incorrectly applies a tuplet structure that has been calculated for another track to later
combined tracks.

MIDI import

When importing a tempo track into a flow after the first in a project, markers are now
imported at the correct positions, instead of being incorrectly offset by the total length of all
preceding flows.

MIDI import

When importing MIDI files, Dorico now ignores a time signature defined in the MIDI file if it is
the same as the immediately preceding one (as happens with MIDI files exported from iReal
Pro).

Mixer

Combining separate percussion instruments held by the same player into a kit now
immediately updates the Mixer.

Mixer

If the Mixer is shown before a project is activated for playback, the channels in the Mixer now
correctly update their VU meters; similarly, after changing the plug-in for an existing slot in
the VST instruments rack, the corresponding VU meters in the Mixer are now correctly
updated.

Mixer

When starting a new project, the appropriate default channel gain and pan values are now set,
so that the effective gain and pan settings match the initial state shown in the Mixer.

MusicXML import

MusicXML 4.0 files can now be opened in Dorico 4.0.20 without throwing any errors; however,
at this time Dorico does not support any of the new features added in MusicXML 4.0.

Note input

A problem whereby some notes in tuplets in unpitched percussion kits could be omitted when
copying and pasting has been resolved.

Note input

Activating chord input while using pitch before duration note input now clears any previously
chosen accidental, so that the next note added to the chord does not unexpectedly assume the
accidental of the previous note.
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Component

Issue

Note input

Copying music containing tuplets to the clipboard no longer sometimes causes additional
bars to appear at the end of the flow.

Note input

Dorico no longer crashes when attempting to create a playing technique with no items
selected.

Note input

Dorico no longer crashes when performing Select All in a project with multiple completely
empty percussion kits.

Note input

Edit ▶ Paste Special ▶ Paste Articulations now works as expected with grace notes.

Note input

If both dynamics and slurs are selected when you choose Edit ▶ Notations ▶ Dynamics ▶
Remove From Group, the operation is now aborted, to avoid unexpectedly removing the
selected slurs.

Note input

It is now possible to paste articulations into a different destination voice than the source voice
in which the articulations originally appeared.

Note input

It is once again possible to extend the duration of a flow by selecting an implicit rest at the end
of the flow and typing R.

Note input

It is once again possible to paste grace notes in chord mode.

Note input

Under some circumstances, pasting an item with no duration, such as a piece of text, could
cause a hang or crash; this has now been fixed.

Note input

When deleting music across multiple players in Insert mode, the correct range is now deleted
under all circumstances.

Page layout

Dorico no longer crashes when attempting to use Move Bar to Next/Previous System in an
open meter passage, or when a frame handle or note/staff spacing handle is selected.

Percussion

Changing the Overlapping notes in the same voice in a kit or grid presentation option on
the Percussion page of Notation Options now always updates the displayed music
immediately.

Percussion maps

Dorico now chooses an appropriate default filename for a percussion map when exported to a
library file from Library ▶ Percussion Maps.

Play mode

When changing layout, Dorico now correctly maintains a selection in the track overview in
Play mode.

Play mode
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Component

Issue

Playback templates

When setting up the playback data for an instrument, including when saving an endpoint
configuration, Dorico now uses the exact ID of the instrument type created in the project,
except in the case that the instrument type does not appear in the factory library (for example,
because it has been modified as part of the MusicXML or MIDI import process), in which case it
will instead use the ID of its parent or base instrument type.

Project files

Under some circumstances, opening, closing and then reopening the same project in quick
succession without allowing the sounds to load could cause Dorico to hang; this has now been
fixed.

Project templates

When starting a new project from a user-defined project template, Dorico no longer applies
the engraving options specified in the SMuFL metadata file associated with the chosen music
font.

Rehearsal marks

When using an absolute font size for the Rehearsal marks font font style, the padding and line
thickness for the rehearsal mark enclosure are now determined such that they will not vary if
the staff size of the staff on which rehearsal marks appear change over the course of the
layout.

Remote control

It is no longer incorrectly possible to execute commands via the remote control interface that
are not enabled in the application for the current state or mode.

Staff labels

Under some circumstances, Dorico would not extend the bracket for a player group label to all
of the staves in the group, if the outermost staves in the group belonged to condensed divisi
players; this has now been fixed.

Staff labels

Under some circumstances, player group labels did not always encompass all staves of multistaff instruments; this has now been fixed.

Staff spacing

Alt+←/→ now moves staves up and down when using the staff spacing tool in Engrave mode.

Tempo

The display of tempo values in the Properties panel and the Transport window and minitransport on the toolbar has been improved, so that tempos that are very, very close to integral
values are displayed as integral values, as expected.

Tempo

The relative positioning of metronome marks following longer tempos written in Petaluma
Script has now been improved.

Time signatures

Instruments in the Electronics family no longer cause large time signatures for instruments
between the brass and string sections to show multiple time signatures instead of one.

Transport

The upper limit for the tempo display and slider in the Transport has been increased to 500
quarters per minute.
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Component

Issue

Trills

Under rare circumstances, accumulating errors in the calculation of notes required to play
very long trills at slow tempos could cause trills to play unexpectedly at earlier points in the
project; this has now been fixed.

User interface

Certain augmented intervals were not correctly calculated in the Transpose dialog; this has
now been corrected.

User interface

Help ▶ Keyboard Shortcuts now works correctly once more.

User interface

In Dorico SE, it is once again possible to access the Expression Maps, Percussion Maps and
Playback Techniques dialogs in the Library menu.

User interface

It is no longer incorrectly possible to open multiple instances of the Preferences dialog.

User interface

It is now possible to open a file from the Hub by tapping it on touch-enabled Windows devices.

User interface

Long printer names no longer cause the width of the right zone in Print mode to change in an
unhelpful way.

User interface

The appearance of the Players in Dorico Project list on the right-hand side in the MIDI Import
Options dialog is now improved on high pixel density displays (Windows only).

User interface

The button to hide and show the left zone has been restored to the toolbox in Engrave mode.

User interface

The layout of the Edit Strings and Tunings dialog has been improved.

User interface

The pop-up buttons that appear when right-clicking or long-pressing the rhythm dot, Insert
mode etc. buttons in the notes toolbox now work more reliably.

User interface

The selected text colour in the Create Comment dialog when using the light theme has been
improved.

User interface

The width of the layout selector drop-down in the toolbar has been increased.

User interface

Under some circumstances, the size of the scroll area in which the score pages are drawn
would not update in response to pages being added or removed; this has now been fixed.

User interface

Various commands in Setup mode are now more appropriately enabled and disabled based on
whether a player, flow, or layout is selected.

Video

Dorico no longer crashes on start-up when a Blackmagic DeckLink Recorder card is
connected to your computer (Windows only).

Video

Remaining issues with the behaviour of the Video window when moving it to a second display
that is handled by a separate GPU have been addressed.
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Dorico 4.0.10
28 January 2022

Improvements
Key Editor
Dorico 4.0.10 includes several minor improvements to the keyboard and mouse
interaction with the new Key Editor, in both Write and Play modes. Further
improvements will follow in future updates.
Piano roll editor. It is now possible to drag out a marquee with the select or multiselect tools in the piano roll without having to click and hold the mouse button for a
moment: you can now simply click and drag. If the select tool is active, you still need
to hold Shift to trigger a marquee selection.
Automation editor. It is now possible to remove selected points from the selection in
the automation editor by holding Ctrl (Windows) or Command (Mac) and clicking
the selected point.
Velocity editor. The way the select and multi-select tools function in the velocity
editor have been adjusted as follows. With the select tool active:
§

Clicking a velocity bar selects that bar and clears an existing selection.

§

Clicking on the editor background clears the existing selection.

§

Clicking and dragging a velocity bar selects it and changes its value in the
same click-and-drag operation.

With the multi-select tool active:
§

Clicking a velocity bar either adds it to or removes it from the selection as
appropriate.

§

Dragging up and down will increase or decrease the velocities of the
selected bars; if you click on a previously unselected velocity bar when
starting the drag, that velocity bar will also become selected and its value
will likewise be edited.

§

Dragging left or right will trigger a marquee selection; all velocity bars
covered by the marquee will be selected at the end of the operation.

Zoom. You can now zoom the piano roll editor by hovering the mouse over the
vertical keyboard display, holding Ctrl (Windows) or Command (Mac) and scrolling
the mouse wheel.
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Similarly, it is now possible to change the horizontal zoom in both the track
overview and the Key Editor by hovering the mouse over the ruler, holding Ctrl
(Windows) or Command (Mac) and scrolling the mouse wheel.
Expression and CC. The Automation and CC label in the Key Editor has been revised
to Expression and CC to better reflect its actual functionality.

Note input and editing
Paste Articulations. Edit ▶ Paste Special ▶ Paste Articulations now includes slurs
and jazz articulations.

Library Manager
Importing all options or items in a category. The Library Manager now shows the
status of each overall set of options and library collections by way of a status
indicator in the list in the left-hand category list; these indicators can also be
clicked to sync the entire collection or set of options in the destination library with
the contents of the source library.
Font and paragraph styles. When displaying descriptions of font and paragraph
styles in the Library Manager, the styles are correctly resolved using their parent
styles, and any overridden values are denoted with asterisks.
Non-modal dialog. The Library Manager dialog is now non-modal, so it is possible to
keep it open while you edit the project.

Capos for fretted instruments
Chord symbols used at start of flow. A new option Capo chord symbols has been
added to the Chord Diagrams section of the Chord Symbols and Diagrams page of
Layout Options, allowing you to specify whether and how the capo definition
specified in Use capo with transposition should affect the chord symbols displayed
above the chord diagrams shown at the start of the flow.
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Issues resolved
Component

Issue

Accidentals

A number of small problems with the new options for note spelling in atonal key signatures in
Note Input Options have been fixed.

Audio engine

A problem that could cause periodic drop-outs in audio due to high-performance timers
required to update the user interface has been fixed (Windows only).

Audio engine

Dorico’s audio engine now automatically ignores the Eucon control component if it is found
on the system, to avoid a crash on start-up.

Audio engine

Under some circumstances, Dorico could crash when restoring saved audio engine data in
existing projects; this has now been fixed.

Audio engine

When running natively on Apple silicon Macs, the audio engine no longer incorrectly attempts
to scan Intel plug-ins on start-up.

Bar numbers

The default values for the new Engraving Options for bar number placement relative to clefs
are now set for existing projects such that they will not cause the placement of bar numbers to
change when opening the project for the first time in Dorico 4.

Bar repeats

Dorico now erases the background behind the bar count numbers for 2- and 4-bar repeats.

Chord symbols

Edit ▶ Notations ▶ Chord Symbols and Diagrams ▶ Generate Chord Symbols From Notes is
now correctly included in Dorico Elements.

Chord symbols

Using Edit ▶ Notations ▶ Chord Symbols and Diagrams ▶ Clear Chord Symbol Played Pitches
now takes effect immediately when playing back.

Chord symbols

When only one chord symbol is shown above a chord diagram when a capo is active, the chord
symbol now correctly follows the engraving option that determines whether it should be
Roman or italicised.

Chord symbols

When using Generate Chord Symbols from Notes, Dorico now correctly ignores your usual
preference for whether inversions should be detected when inputting chord symbols via the
MIDI keyboard.

Comments

Comments no longer appear in a darker colour when they have non-zero duration.

Condensing

A problem whereby items with duration, such as hairpins, caused unnecessary recalculation
when editing with condensing enabled has been fixed, providing a speed improvement when
editing condensed music (for example, hiding or editing player labels).

Engrave mode

When using Alt+up/down to nudge unbeamed stems in Engrave mode, the direction in which
the stem moves now visually matches the direction of the pressed arrow key when the stem
points down.

Dorico 4 Version History

38

Steinberg Media Technologies GmbH

Component

Issue

Figured bass

Under some circumstances, Dorico could crash when calculating the position of a tasto solo
indication in figured bass; this has now been fixed.

Figured bass

When the Figured bass font font style has been changed, the placement of parentheses and
brackets relative to the enlarged or reduced figures is now correct.

Glissando lines

When determining whether to apply the minimum space for a glissando line, Dorico now
correctly considers whether the starting note is tied.

Grace notes

It is once again possible to create grace notes within nested tuplets; this also fixes problems
with opening existing projects in Dorico 4.0 in which such grace notes would unexpectedly
not be displayed.

Hub

Files with certain characters in their names would not open properly when dragged and
dropped onto the Hub window; this has now been fixed.

Hub

It is now possible to open MIDI files with the extension .midi from the Open or Import File
button in the Hub window.

Hub

RAM usage in the Hub window has been significantly reduced.

Insert mode

Changing the duration of implicit rests with Insert mode active now once again works
correctly.

Insert mode

Dragging the Insert mode stop position now only affects the flow in which you are actively
dragging the line.

Insert mode

When removing time from the end of a dynamic group, Dorico now more intelligently handles
affected dynamics at the end of the group.

Instrument filters

Changing the active instrument filter preset in galley view no longer takes an unexpectedly
long time in a project where condensing is enabled.

Instrument filters

The instrument filter overlay now only appears in Write mode.

Instruments

It is now possible to add a trumpet in the ensemble picker using the abbreviation “trp”.

Instruments

The new Woodwind sketch instrument now correctly appears in the instrument picker as
expected.

Jump bar

It is now possible to launch the Preferences and Device Setup dialogs via the jump bar.

Jump bar

When the jump bar is visible, the up/down arrow keys will now always navigate the pop-up list
in the jump bar rather than passing those keypresses on to the project window, potentially
navigating or otherwise editing the music.
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Component

Issue

Key Editor

It is now possible to shorten a note at the initial rhythmic position of the flow in the Key Editor
if required.

Key Editor

Switching from Write mode with linked mode in the Key Editor enabled to Play mode no
longer causes the piano roll to become much more zoomed in.

Key Editor

When switching away from the Velocity editor back to the piano roll editor, if the transform
tool was active, it is now properly deactivated automatically.

Library Manager

It is now always possible to undo changes applied in the Library Manager immediately,
without needing to make a further edit.

Lyrics

Dorico no longer crashes when opening a project created in an earlier version where multiple
lines of lyrics are displayed and verse numbers are enabled, but verse numbers do not appear
for one or more lines of lyrics.

Lyrics

When lyric hyphens are set not to appear at the start of the system, Dorico now correctly
accounts for grace notes before the first rhythmic note at the start of the new system.

Lyrics

When pasting lyrics into a staff with tuplets with chord mode enabled, the lyrics are now
positioned correctly relative to the destination tuplets.

MIDI export

Pick-up (upbeat) bars are now once more correctly handled in MIDI export by creating an
appropriate time signature for each pick-up bar.

MIDI export

The notes generated for playback of the Chords track in Play mode are now included when
exporting MIDI.

MIDI import

Projects created in Dorico 4.0 by importing MIDI files could exhibit instability when
continuing to edit them later on, and could crash; the underlying problem has now been fixed,
and existing projects will be automatically repaired upon opening them in 4.0.10.

MIDI import

Setting custom start and end playing techniques for tracks when importing MIDI files now
works correctly.

Mixer

Editing the name of an instrument no longer incorrectly causes all channels in the Mixer to
have their names updated.

Mixer

The faders in the Mixer are now rate-limited, so they feel more responsive when adjusting
levels during playback.

Mixer

When closing a project with the Mixer window open, the Mixer window no longer sometimes
incorrectly appears completely blank.

Mixer

When reloading a VST plug-in into an existing slot, the connection of the FX send to the
Effects channel is no longer incorrectly lost.
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Component

Issue

Multi-bar rests

It is no longer incorrectly possible to set the H bar X offset property globally.

Music symbols

Music symbols with more than two components are once again drawn with each component
positioned correctly relative to each other.

MusicXML import

Deactivating the Articulation placement option on the MusicXML Import page of Preferences
now works as expected when importing MusicXML files.

MusicXML import

Under some circumstances, Dorico could crash when opening MusicXML files with particular
encodings for accented or extended characters; this has now been fixed.

Note input

A problem whereby note input into fretted instruments with capo definitions would result in
incorrect transposition has been resolved.

Note input

Auditioning notes in the Keyboard and Fretboard panels now uses the correct sound.

Note input

Creating a playing technique with more than one note on a percussion kit selected no longer
causes Dorico to crash.

Note input

Dorico no longer crashes if you mistakenly enter the single character = into the Shift+I
popover.

Note input

It is once again possible to increase the length of the flow by lengthening selected implicit
rests.

Note input

It is once again possible to transpose key signatures by an interval of an augmented unison.

Note input

Lengthening or shortening grace notes with Shift+Alt+←/→ now retains their selection.

Note input

Under some circumstances, Dorico could fail to bring the end of the flow into view when
inputting new notes that extend the flow length in galley view; this has now been fixed.

Note input

When navigating from one bar to the next in Write mode, it could under rare circumstances
be possible for Dorico to crash when navigating into a slash region; this is now fixed.

Note input

When recording in real-time, Dorico will now always use polyphonic voice separation when
recording into both staves of a grand staff instrument.

Note input

You can once again exit note input by hitting Return when the caret is visible but nothing is
selected.

Numbered bar

If the options dictate that the bar count should not appear on the first bar of a numbered bar

regions

region, this is now respected.

Numbered bar

Under some circumstances, the bar count shown for numbered bar region bar counts could

regions

collide with playing techniques shown above the staff; this has now been fixed.
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Component

Issue

Page layout

Move Bar to Next System and Move Bar to Previous System now work as expected when a
barline is selected.

Page layout

When using Move Bar to Previous System with a multi-bar rest selected, Dorico no longer
incorrectly moves the bar following the multi-bar rest to the previous system.

Play mode

Combo boxes in the track inspector no longer retain keyboard focus, so hitting Space to play
back after e.g. changing VST instrument no longer causes the menu to pop back open again.

Play mode

Play ▶ Navigate Forwards, Navigate Backwards and Navigate To Start have temporarily been
removed until they can be made to work correctly with the new Play mode.

Play mode

The pop-up for the VST instrument combo box in the VST Rack is now significantly wider.

Play mode

When enabling or disabling independent voice playback, the selection in the track overview is
now preserved.

Playback

Under some circumstances, Dorico could crash when calculating rhythmic feel in open time
signatures; this has now been fixed.

Project files

Dorico no longer applies the user’s default or factory options when starting a new project
based on a user-defined template; instead, the options saved in the template are used.

Project files

Dorico no longer crashes when importing flows into a project that has existing players, but no
flows.

Project files

Under some circumstances, Dorico could crash when opening projects that use custom
tonality systems where the specified temperament definition is not included in the project;
this has now been fixed.

Project files

When a project is not active for playback that has not yet been saved, Dorico no longer
incorrectly reports an error during auto-save.

Project files

When choosing File ▶ New or choosing a project from File ▶ New From Template, the user’s
saved choice for whether or not flow headings should be shown is now correctly respected.

Rhythmic slash

Setting properties on multiple selected rhythmic slash regions now works as expected across

regions

all selected regions, not only one of them.

Staff labels

Under certain circumstances, player group labels could be drawn incorrectly after changing
staff spacing in Engrave mode; this has now been fixed.

Staff labels

When clicking Reset to Factory in Engraving Options, instrument names are no longer reset
to defaults.
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Component

Issue

Staff labels

When erasing the background around player group labels relative to their brackets, the value
in Engraving Options for padding now only affects the amount of padding directly above and
below the label.

Steinberg Licensing

If Dorico has no license, it is now correctly possible to quit the application.

Tempo

The Metronome mark order property now correctly takes effect in all open layouts when set
or changed.

User interface

It is now always possible to position the insertion point in the line edit control in the
instrument and ensemble pickers.

User interface

It is once again possible to force Dorico Pro to run as Dorico Elements or Dorico SE by holding
down Alt or Ctrl (Windows) or Command (Mac) respectively at start-up.

User interface

It is once again possible to set the background gradient for Engrave mode in Preferences.

User interface

Pinch-zooming on a multi-touch trackpad and using Ctrl+mouse wheel to zoom in and out
with nothing selected now always zooms into the centre of the view, rather than unexpectedly
zooming towards the start or end of the layout.

User interface

Selected notes are now denoted by blue dots in the Keyboard panel.

User interface

The alignment of the icons in the mini Transport and Transport relative to their buttons have
been improved.

User interface

The contrast of the slide switch thumb against its background has been greatly improved
when running Dorico with the light theme.

User interface

The controls in the toolbar, Notations toolbox and lower zone toolbar now all correctly
respond to touch inputs on touch-enabled Windows devices.

User interface

The ensemble picker now appears correctly immediately to the right of the Players panel.

User interface

The focus ring indicating which list has the keyboard focus now appears in the instrument and
ensemble pickers once more.

User interface

The search filter for accidentals in the Edit Tonality System dialog now works with nonalphanumeric characters.

User interface

The Sort Layouts button in the Layouts panel in Setup mode now bears an indicator to show
that it can be long-pressed or right-clicked to show a menu of options.

User interface
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Component

Issue

User interface

Under some circumstances, the toolbox in Engrave mode could appear too narrow when
switching from another mode; this has now been fixed.

VST plug-ins

The controls to allow or blow specific VST2.x plug-ins on the VST Plug-ins page of Preferences
no longer incorrectly appear when running natively on Apple silicon Macs.

VST plug-ins

The Maximiser and Envelope Shaper effects plug-ins were inadvertently excluded from
Dorico 4.0; they are now restored.
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Dorico 4.0
5 January 2022

New features
Key Editor in Write mode
Dorico has always included a piano roll editor in Play mode, together with tools for
editing note velocities, MIDI continuous controllers, and so on. These tools, more
conventionally found in a digital audio workstation like Cubase, are increasingly
important to users of music notation and composition software like Dorico, as the
demands of sophisticated virtual instruments and sample libraries mean that a
wider range of musicians than ever before needs to be able to manipulate and
shape the virtual performance of their music.
Dorico 4 extends these tools beyond Play mode and into Write mode, allowing you
to work more fluently with the piano roll and MIDI editors directly alongside
standard music notation. These editors are now found in the lower zone in both Play
mode and Write mode, and together they are now known as the Key Editor.

Showing the Key Editor. In both Write mode and Play mode, you can show the Key
Editor by showing the lower zone, which you can do either by clicking in the
disclosure area along the bottom of the project window or using the key command
Ctrl+8 (Windows) or Command-8 (Mac). The lower zone now accommodates a
number of different panels in each mode, but in both Write and Play modes, the Key
Editor is the rightmost button in the panel selector at the left-hand side of the lower
zone toolbar. Click
Dorico 4 Version History
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In Play mode, you can also quickly show the Key Editor by double-clicking a track in
the track overview, which will show the lower zone if it is currently hidden, and
switch to the Key Editor.
Choosing what instrument to edit. The Key Editor allows you to edit the material of
one instrument at a time. In Play mode, you specify the instrument by selecting its
track in the track overview.
In Write mode, by default the Key Editor is in linked mode, indicated by the
button in the lower zone toolbar. When in linked mode, the instrument shown in
the Key Editor follows the selection you make in the music notation: the horizontal
zoom is adjusted to bring the music corresponding to the system where the current
selection begins, and the vertical position of the piano roll is adjusted to bring the
music into view. In this way, the same music that you can see in the notation is
shown in the piano roll, and the view is automatically updated as you move around
the layout.
You can manually deactivate linked mode by clicking the button in the lower zone
toolbar, or alternatively Dorico will automatically deactivate linked mode when you
directly manipulate the zoom level, vertical position of the piano roll, or manually
scroll the view in the piano roll. Once linked mode is deactivated, Dorico will not
automatically update the view in the piano roll, until you reactivate linked mode
once more.
Lower zone toolbar. To the right of the panel selector buttons, the lower zone toolbar
includes the following tools when the Key Editor is active:

1. 2. 3. 4. 5.

1.

6.

7.

8.

9.

10.

11.

Select tool. In Play mode, this tool has the key command S. Selects individual
notes in the piano roll, velocity bars in the velocity editor, or points in the MIDI
controller editor. When you click on multiple items in succession, the previous
item is deselected.

2.

Multi-select tool. Selects multiple items in the Key Editor. Click on multiple
items in succession to add them to the selection, or click a selected item a
second time to remove it from the selection again. To make a marquee
selection, click and hold the mouse button for a moment on a blank area of the
editor; an animated rectangle will appear after a moment to show that it is now
ready to make a marquee selection. Keep the mouse button held down and drag
out a rectangle to select all enclosed items.

3.

Draw tool. In Play mode, this tool has the key command D. In the piano roll, this
allows you to add new notes: simply clicking will add a note of the current
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rhythmic grid value; click and hold the mouse button for a moment and you can
drag out a note of any duration. In the velocity and MIDI controller editors, you
can sweep across a horizontal region to edit successive velocities, or draw in a
series of controller data points.
4. Line tool (velocity and controller editor only). In Play mode, this tool has the key
command L. The line tool allows you to edit successive velocities in a linear
fashion, increasing or decreasing them over time according to the angle of the
line you drag out between two points. In the MIDI controller editor, it creates a
line between two points, and Dorico will then generate appropriate controller
events over the course of the line to play back the changes over time.
5.

Multi-edit tool (velocity editor only). This tool allows you to perform
transformations on a range of velocities. Click and hold the mouse button, then
drag across a range of velocities to determine the range to be transformed. The
specific transformations that can be performed are described below.

6. Delete. Deletes the selected notes in the piano roll or velocity editors, or the
selected controller data points in the MIDI controller editor.
7.

Played duration / Written duration. Toggling the piano roll display between
showing played durations

and written durations

allows you to edit

either the playback data of notes without affecting the way they are shown in
the layout, or to edit the notated durations.
8. Rhythmic grid selector. The Key Editor has its own rhythmic grid setting shared
between Play and Write modes, independent of the rhythmic grid used by
editing the music notation directly.
9. Playback techniques. Hides or shows the playback techniques lane between the
piano roll and velocity editors, so you can see which playback techniques are
being used at any given moment; hover your mouse over an entry in the lane to
show a tool tip with more detailed information.
10. Linked mode (Write mode only). Determines whether the Key Editor follows the
selection you make in the music notation.
11. Voice selector. Determines the voice you are currently editing; notes in other
voices are shown in grey.
Switching between editors. When the Key Editor is first shown, the piano roll editor
is active by default. To activate the velocity or MIDI controller editors, click either in
the header area at the left-hand side, or click on any part of the editor itself. To
activate the piano roll editor again, similarly click either in the vertical piano
keyboard display at the left-hand side, or click on any part of the editor itself.
Currently, the velocity and MIDI controller editors are combined into a single area
(though we plan to make it possible to show multiple editors in addition to the piano
roll editor in a future release). The menu immediately below the Automation and
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CC heading allows you to choose between editing velocity and any MIDI controllers
for which data already exists.
If you have not yet added data for a particular MIDI controller, it will not yet appear
in the list: click the + button next to the Add Automation label to show a selector
from which you can choose the desired MIDI controller. The chosen MIDI controller
is now selected in the menu above, allowing you to add your own data.
Piano roll editor. If you are familiar with the piano roll editor in a DAW or sequencer,
you should feel at home with Dorico’s editor. One possibly unfamiliar aspect is that
you can edit either the written durations of notes, or only edit their played
durations without affecting the appearance of the notation. The notes themselves
appear different in each mode:

Written durations

Played durations

When editing played durations, the written duration is shown as a thin line
immediately below the editable part of the note, which represents the note as it will
be played back.
Select a single existing note with the select tool active, or use the multi-select tool
to select multiple notes. You can then, if the editor is set to edit written durations:
§

edit the pitch of the selected notes by dragging them up or down;

§

edit the rhythmic position of the selected notes by dragging them left or
right, and as you drag, the notes snap to rhythmic grid positions;

§

edit the written start position by dragging the left-pointing triangle at the
start of one of the selected notes;

§

edit the written end position by dragging the right-pointing triangle at the
end of one of the selected notes.

If you have the editor set to edit played durations, you can still edit the pitch by
dragging the notes up and down, but editing the starts or ends of the notes will edit
their playback onset and offset properties rather than affecting the notation.
To write new notes into the piano roll, activate the draw tool, then:
§

click to add a note of the pitch that corresponds to the key shown in the
vertical piano keyboard at the left-hand side, of the current rhythmic grid
value in duration;
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§

click and hold the mouse button for a moment, then drag to the right to
increase its duration; you can also drag up or down to edit the pitch of the
note before you release the mouse button.

One other unique feature of Dorico’s piano roll editor, and new in Dorico 4, is that it
displays any tuplets that apply to the current voice immediately below the ruler.
You can drag notes in and out of tuplets freely, and Dorico will correctly scale and
unscale them as required.
By default, the piano roll is linked to the selection in the music notation view in
Write mode, but if you drag, scroll or zoom the piano roll view, it will become
unlinked. You can re-enable the link at any time simply by clicking the link button
in the lower zone toolbar.
To change the zoom level of the piano roll, you can use the floating zoom control
that appears in the bottom right-hand corner of the Key Editor:

The arrows at the left- and right-hand sides of the zoom control determine whether
the slider will affect the horizontal or vertical zoom; click the arrows that represent
the direction you want to zoom in, then drag the slider.
Alternatively, you can drag up and down in the ruler at the top of the piano roll
editor to change the horizontal zoom, or in the vertical piano keyboard at the lefthand side to change the vertical zoom.
Velocity editor. To edit note velocities, activate the velocity editor by clicking
anywhere in the editor itself or in the header area on the left-hand side. You can
edit individual note velocities by using the select tool to select an individual note,
then click again and drag the top of the velocity bar to change its value. To edit the
velocity of an individual note in a chord, first select the note in the notation (in
Write mode) or in the piano roll. You can then click and drag the velocity bar to set
that individual note’s value.
To edit the velocities of multiple notes, you can use the draw tool to draw values
freehand over a range of notes or use the line tool to create a consistent increase or
decrease in velocity over the range. For more detailed editing, use the multi-edit
tool to select a range of notes: click the mouse button and hold for a moment to start
a marquee selection, then drag across the notes you want to edit.
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You can click and drag on any of the tools around the edge of the selection to
transform the velocities. Moving clockwise from the bottom left-hand corner:
§

Randomize. Drag up and down to randomize the selected values.

§

Delta. Drag up and down to increase or decrease all the selected values by a
fixed amount.

§

Tilt left. Drag up and down to tilt the values so that they gradually increase
from the start of the selection to the end.

§

Tilt right. Drag up and down to tilt the values so that they gradually decrease
from the start of the selection to the end.

§

Scale. Drag up and down to increase or decrease the selected values by a
scale factor, so larger values change more quickly than smaller ones.

Editing velocities with the histogram. A histogram is a chart where values are
grouped according to frequency distribution. Click the Histogram button to show
the velocities for the current instrument as a histogram; by default, All notes will be
shown, but you can alternatively show the notes only from the current Voice chosen
in the voice selector, or in the Selection.
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It is also possible to switch between showing the values as bars, as shown above, or
showing an area chart.
In a similar fashion to the multi-edit tool, the histogram editor provides a set of
tools at the corners of the values. Moving clockwise from the bottom center:
§

Scale. Increases or decreases all the values by a scale factor.

§

Compress or expand. Drag left to expand the values out to a wider range, so
the lowest values are lower and the highest values are higher, or drag right
to compress the values to a smaller range.

§

Lower limit. Allows you to increase the lower limit, i.e. to increase the value
shown as Min in the read-out at the top left corner of the histogram.

§

Delta. Allows you to add or remove a delta to all values, effectively shifting
all the values up or down by the same amount.

§

Upper limit. Allows you to decrease the upper limit, i.e. to decrease the value
shown as Max in the read-out at the top left corner of the histogram.

At the very bottom left corner of the histogram editor is the randomize tool, which
you can drag up and down to edit all the shown values by a random amount.
If you want to undo the edits you have made during the current session in which the
histogram editor is shown, click Reset in the histogram editor toolbar to return all
notes’ velocities to their prior values.
The histogram editor makes it easy to change the overall character of an
instrument’s music: you can push the overall velocity level higher or lower, expand
the range of velocities used to increase the dynamic contrast, or provide a small
degree of randomization to avoid repetitive use of the same samples at precisely
the same velocity levels throughout the music.
Further editors. Dorico 3.5 and earlier versions included a few other editors that are
not yet included in Dorico 4, including the dynamics editor and the tempo editor.
We are sorry that these editors are not included in the initial release of Dorico 4, but
they will return in new and improved form in a future free maintenance update. In
the meantime, we apologize for any inconvenience caused by their absence.

Revamped Play mode
Dorico 4 introduces a brand new user interface for Play mode, designed to
complement the changes that allow the Key Editor to be used in Write mode as well
as Play mode. If you have used Play mode in Dorico for iPad, then the new layout on
the desktop will look familiar.
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Interface changes since Dorico 3.5. The toolbox on the left-hand side has been
removed, with the tools moving into the toolbar in the lower zone, when the Key
Editor is shown.
The VST Instruments panel on the right-hand side has been removed, and is now
found on the left-hand side, where you can switch between showing the track
inspector and showing the VST and MIDI instruments in the rack.
The individual track headers for each instrument are now more minimal than
before, serving primarily as a means of selecting an instrument, which then
updates both the track inspector on the left and the Key Editor in the lower zone.
From the track header you can mute and solo the track, but otherwise all editing is
performed via the track inspector.
Track inspector. The controls that were previously in the track header for assigning
the endpoint (combination of plug-in, port, and channel) are now found in the
Routing section of the track inspector.
For pitched instruments (not for percussion kits), you can click Turn on IRV in the
Routing section to enable independent voice playback, which shows a separate
track for each voice in the track overview area. Select the track associated with each
voice to change the endpoint settings in the Routing section of the track inspector.
The Insert Effects and Channel sections in the track inspector mirror the relevant
sections of the new Mixer.
Track overview. The track overview shows all the tracks in the current flow and
layout. Select a track to edit its settings in the track inspector on the left-hand side,
or to edit its musical content in the Key Editor in the lower zone.
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To fit more tracks into the vertical height of the window, click

in the area above

the track headers to cycle between three different vertical sizes for the tracks in the
overview.
You can change the horizontal zoom of the track overview by clicking and dragging
vertically in the ruler at the top of the window. To position the playhead, simply click
in the ruler.
Global tracks. The Tempo, Chords, and Markers global tracks are shown above all of
the instrument tracks in the track overview. They can be hidden or shown using the
buttons above the track headers.
For the Tempo and Chords global tracks, you can use the Routing section of the
track inspector to change the endpoint for the metronome click and the playback of
chord symbols respectively.
You can add a new marker at the playhead position by clicking the + button in the
Markers global track header.
Lower zone. You can now open the lower zone in Play mode, where it can show
either the new Mixer or the Key Editor. Like the track inspector, the Key Editor in
the lower zone follows the selection in the track overview, so to view the piano roll
and velocity editors for a particular instrument, select it in the track overview.
The lower zone can be resized by grabbing the handle at the right-hand side of the
lower zone toolbar, or anywhere along the length of the toolbar where your mouse
pointer turns into resize arrows.
The tools formerly in the Play mode toolbox on the left of the window are now
shown in the lower zone toolbar, together with a new drop-down to allow you to
specify the voice to be edited; if multiple voices are present, the active voice is
shown in the accent color for the track, and other voices are shown in grey. A button
to show the playing technique lane is also found in the lower zone toolbar, and
when shown the playing technique lane appears in between the piano roll and
velocity editors.
Further editors. Play mode in Dorico 3.5 and earlier versions included a few other
editors that are not yet included in Dorico 4, including the tempo editor and the
drum editor. We are sorry that these editors are not included in the initial release of
Dorico 4, but they will return in new and improved form in a future free
maintenance update. In the meantime, we apologize for any inconvenience caused
by their absence.
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Revamped Mixer
The Mixer has been completely rebuilt from scratch in Dorico 4. It is functionally
identical to the Mixer in previous versions, but is now more performant, more
beautiful to look at, and available in more locations in the software. It can be shown
in its own window, as before, but it is also now embedded in the lower zone, and
accessible in Write, Engrave and Play modes.
Mixer window. To show the Mixer window, click

in the toolbar, or choose

Window ▶ Mixer, or use the key command F3.
The Mixer is split into two resizable sections, with the main fader controls in the
lower section, and the insert effects, EQ and effects send controls in the upper
section.
To add an insert effect, load it into one of the slots in the Inserts section for that
channel. Once an effect is loaded into one of the slots, hover the mouse pointer over
that effect to see the controls to bypass the effect or show its interface. To remove
the effect, choose the --- entry at the top of the list of available effects.
The EQ is enabled by clicking the circular indicator to the left of the EQ label in the
section header. Each band can then be enabled and disabled independently.
The effects send is enabled by default and can be disabled by clicking the circular
indicator to the left of the FX label in the section header. The fader specifies how
much signal should be sent to the Reverb channel, which has the REVerence
convolution reverb effect loaded by default.
The Mixer is now a regular window, so it is not forced in front of all windows
belonging to all applications, and it does not disappear on macOS when the
application loses focus; as a corollary, however, that means it can also disappear
behind the project window.
Lower zone Mixer. When shown in the lower zone, only the most commonly needed
sections of the Mixer are shown: main fader, pan, mute and solo controls.
Channel filters. Whether shown in the lower zone or as a separate window, you can
filter which channels are shown in the Mixer by using the filters shown in the lower
zone toolbar or in the Mixer window toolbar.
By default, the Mixer does not show unused channels, in other words those outputs
in the loaded VST plug-ins that do not have any instrument routed to them. This
minimizes the number of faders that you see in the Mixer.
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On-screen instruments
The lower zone in Write mode now includes three new, beautiful and useful onscreen instruments, which are designed to assist with note input and editing: the
Keyboard panel is ideal for inputting into any pitched instrument; the Fretboard
panel allows quick and easy specification of string and fret information for notes on
fretted instruments like guitar; and the Drum Pads make it quick and easy to input
for specific instruments in a percussion kit.

Keyboard panel. To show the Keyboard panel, first show the lower zone by clicking
in the disclosure area along the bottom of the project window or using the key
command Ctrl+8 (Windows) or Command-8 (Mac), then click

.

You can resize the lower zone to make the Keyboard panel larger or smaller, either
by dragging the resize handle

at the right-hand side of the lower zone toolbar, or

by dragging the top edge of the lower zone.
You can also change the width of the keys in the Keyboard panel by enlarging or
reducing the range of keys shown: the keyboard range selector immediately above
the large keys shows the keys currently visible in white, with those keys outside the
visible range shaded. You can click and drag the dark grey keys at the top and
bottom of the visible range left or right to increase or decrease the visible range,
thus changing the width of the visible keys. You can also change the visible range of
keys by clicking and dragging the white area between the two dark grey keys.
The Keyboard panel can be used both in step-time input and when recording in real
time by clicking the keys with the mouse, or, if you have a touch-enabled display
(for example, a Windows Surface computer or similar), by tapping them directly
with your fingers. If you do not have a touch-enabled display, you are unlikely to get
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satisfactory results when recording in real time clicking on the keys with the
mouse, but the option is there should you need it.
However, it can certainly be convenient to use the Keyboard panel for step-time
input: the lower zone toolbar contains the common note durations and
articulations, so most of the items you need for note entry are within easy reach
with the mouse. Similar to input with a MIDI keyboard, Dorico will choose an
appropriate enharmonic spelling for notes automatically, but if you want to adjust
the spelling of the note you have just input, use the appropriate Respell button.
Outside note input, the Keyboard panel depresses the keys corresponding to any
selected notes, which can be helpful to visualize a chord voicing or harmony. When
there is no selection, if you play on your MIDI keyboard, the corresponding keys on
the Keyboard panel will become pressed and released as you play.
Fretboard panel. To show the Fretboard panel, first show the lower zone by clicking
in the disclosure area along the bottom of the project window or using the key
command Ctrl+8 (Windows) or Command-8 (Mac), then click

.

The Fretboard panel can only be used with fretted instruments, and the display
updates as appropriate for the kind of instrument you choose, with the number of
frets and strings as specified in the Edit Strings and Tuning dialog. If you define a
full or partial capo (see Capos for fretted instruments below), the capo will also be
shown in the Fretboard panel and will effectively block off the frets below the capo
on the appropriate strings.
Like the Keyboard panel, the Fretboard can be used to input notes, though only in
step-time input. When the caret is visible, simply click the string at the fret position
where you want the note to be input. If you have a touch-enabled display (for
example, a Windows Surface computer or similar), you can also input by tapping
directly with your fingers.
Outside note input, the Fretboard panel shows the fret positions for the selected
note or chord. If the notes were input directly with the Fretboard, or have otherwise
have the string on which they should be played set explicitly, for example in
tablature, they will appear at the corresponding place on the Fretboard; if, however,
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the notes were input using alphabetic input or using a MIDI keyboard, Dorico will
automatically calculate the string and fret positions.
Drum pads. To show the Drum Pads panel, first show the lower zone by clicking in
the disclosure area along the bottom of the project window or using the key
command Ctrl+8 (Windows) or Command-8 (Mac), then click

.

The Drum Pads panel can only be used with unpitched percussion instruments and
kits. The display updates to show the appropriate combination of instruments and
playing techniques when you select a note, rest or other item on a percussion kit.
The arrangement of pads shown can be edited: click

and the outline around each

of the pads turns orange, indicating that they can now be dragged into a new
position. Click Add Space in the lower zone toolbar to add a spacer pad that allows
you to create gaps between pads if you choose. The arrangement of the pads is
saved for the instrument or kit in the current project.
You can use the drum pads to input notes both in step-time input and when
recording in real time. When recording in real time, clicking closer to the centre of
the pad will produce a higher velocity than clicking near the edge of the pad. If you
have a touch-enabled display, you can tap the pads directly with your fingers, and
tap multiple pads simultaneously.

Smart MIDI import
MIDI files provide the most common route to transfer data between music notation
software like Dorico and sequencers and digital audio workstations like Cubase.
One of the most common workflows involves taking a mock-up produced in a DAW
written for virtual instruments and transferring it to a scoring application for
orchestration, the process of translating the composer’s intentions currently
expressed in terms of the specific sound libraries and virtual instruments in use in
the DAW into notated music that can be performed by a live ensemble.
Mock-ups are often written in large-scale DAW templates, with many tracks
– certainly dozens, frequently hundreds, and sometimes thousands. Before the
orchestration process can begin in earnest, the first step is to understand the
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structure of the template, which can itself be a time-consuming process. The music
that is ultimately intended for a single or section player might be split across many
tracks, with different playing techniques and articulations played by each track;
some of the music may be doubled up with alternative or additional sounds to
provide a richer, lusher sound in the mock-up, but resulting in tracks that can be
omitted as they duplicate material already found in other tracks; the tracks may
have cryptic names that make sense to the composer, but which require
deciphering by the orchestrator.
Even after understanding the structure of the template, the job of distributing the
music from the large number of tracks in the MIDI file to the appropriate players in
the notated score is a serious logistical undertaking, manually copying and pasting
music from staves created by the import process into the staves that form part of
the final notated score.
And since composers often use the same large-scale template for multiple cues or
pieces within the same project, a good deal of this logistical work must be repeated
for every cue, with very little help in automating any of these steps.
Dorico 4 greatly streamlines this entire process: it introduces a new workflow for
transferring MIDI data into music notation, with a great deal of assistance that
mostly automates the time-consuming busy work that precedes the real job of
preparing the music for the recording session.
The new MIDI file import workflow in Dorico 4 allows you to quickly eliminate
empty tracks, map multiple tracks representing different articulations and playing
techniques onto a single instrument, or indeed map a single track representing
multiple instruments onto multiple instruments, filter out key switches, detect
grace notes, slurs, trills and tremolos automatically, and so on – and every decision
you make is then stored in Dorico’s track memory, so you need only make it once.
Next time you open a project with the same or similar tracks, Dorico automatically
configures things the way you did before.
Opening versus importing. If you want to create a new project from your MIDI file,
use File ▶ Open to open the MIDI file. This will allow Dorico to create all the required
players and instruments as determined by the process of mapping tracks in the
MIDI file onto players and instruments.
If, on the other hand, you already have a suitable template with the target players
and instruments created, use File ▶ Import ▶ MIDI to import the MIDI file into the
current project; you can still create any additional players and instruments
required as part of the import process.
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When importing into an existing project, you can choose to import into a new flow,
or to import the music into an existing flow. This is very helpful, as it makes some
advanced workflows possible: for example, if you receive an updated MIDI file from
a colleague but only some of the instruments have new music, you can re-import
the material belonging to those instruments, overwriting the previous version
while leaving the rest of the ensemble untouched; or if you discover that a single set
of quantization values don’t produce ideal results for all of the tracks in the MIDI
file, you could re-import the MIDI file into the existing flow using different
quantization options and importing the music only from a subset of tracks.
To choose whether the music should be imported into a new or existing flow, set the
Destination drop-down in the top right corner of the MIDI Import Options dialog
accordingly.
Basic versus advanced editing. When the MIDI Import Options dialog opens, by
default it shows the basic editor, which primarily consists of a table showing the
tracks in the MIDI file, with a few global options in the bar at the top of the dialog.
Here you can find the option to Use track memory. If you want Dorico to remember
the choices you make for the tracks in this MIDI file so that they will be
automatically applied the next time you open this MIDI file, or another MIDI file
with identically named tracks, activate this option.
Interpret as General MIDI determines whether Dorico should use the MIDI
program changes at the beginning of each track as hints for determining the
instruments. Similarly, it gives Dorico the hint that any track set to use channel 10
will contain unpitched percussion using the General MIDI drum set. If you are not
certain that your MIDI file conforms to General MIDI conventions, you should
deactivate this option.
As a rule of thumb, older MIDI files of popular works that you download from the
internet may well conform to General MIDI conventions, but newly created MIDI
files you receive from a sequencer or DAW probably do not.
If you are importing rather than opening the MIDI file, the Destination drop-down
allows you to specify whether the MIDI file should be imported into an existing flow,
or whether a new flow should be created. Re-use existing players tells Dorico
whether it should try to assign the tracks in the MIDI file to players and instruments
that already exist in the project, or whether it should create new players and
instruments for each track by default.
Once you have set these global options appropriately, you can review the tracks in
the MIDI file itself and determine which should be imported, and how they should
be mapped onto players and instruments in your project.
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Basic editing. When the basic editor is enabled, the dialog looks like this:

Immediately above the tracks table is a filter edit control, allowing you to type part
of a track name to show only those tracks that match the filter text. The toggle
buttons to the right of the filter edit control allow you to show either all tracks, or
only those that are enabled for import.
By default, all non-empty tracks are enabled for import. To disable a track for
import, deactivate its checkbox at the left of its row in the tracks table. To enable or
disable multiple tracks at once, make a multiple selection in the tracks table with
Shift+click or Ctrl+click (Windows) or Command-click (macOS) and click Enable
Selected or Disable Selected in the action bar at the bottom of the table.
The Instrument(s) in track column shows which instrument Dorico thinks is
represented by each track. If you want to change the assignment, simply doubleclick the shown instrument, which opens a simple dialog containing the standard
instrument picker, allowing you to choose the desired instrument. If the track
represents multiple instruments – for example, a single horns track needs to be
mapped onto multiple horn instruments in the resulting flow – you must use the
advanced editor, described below.
The Technique(s) column shows which playing technique, if any, is represented by
this track. If the track is the normal or natural playing technique for that
instrument, you don’t need to specify that: similarly, if the track contains a mixture
of normal and legato notes, you don’t need to specify the legato playing technique,
as Dorico will automatically create slurs as needed. You can double-click the cell in
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the table to activate a drop-down from which you can choose one of the preset
playing technique combinations; if you require a combination that is not shown,
you must use the advanced editor, described below.
The Max. sim. notes column tells you how many notes are played simultaneously
on each track, which is helpful when determining whether the track represents a
single instrument or multiple instruments.
Finally, Total no. of notes provides a count of the notes in each track. This allows
you to see at a glance which tracks in the MIDI file contain no notes at all, and which
it may therefore be unnecessary to import.
For simple cases, checking the tracks table as described above is sufficient: you can
now click OK to import the MIDI file. If you want to explore the deeper capabilities,
read on.
Import Options. To show additional options for MIDI import, expand the Import
Options section at the bottom of the dialog. You can scroll within the dialog if
necessary to see all these options:

Instruments section:
§

Use GM program changes to identify instruments specifies whether
Dorico should use the MIDI program changes on each track as a hint to
identify instruments; if this option is switched off, Dorico will use the track
name as the primary means of determining the instrument.

§

Interpret channel 10 as General MIDI percussion specifies whether any
tracks set to use channel 10 should be assumed to conform to the General
MIDI drum set standard.

§

Overwrite all track contents when importing into existing flow/player
determines whether existing music should be overwritten, or new music
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should be merged with the existing music. This option applies only when
importing a MIDI file into an existing flow.
Interpretation section:
§

Split point for grand staff instruments determines how music imported
onto grand staff instruments should be disposed between the two staves: if
Auto is chosen, Dorico will consider musical context and normal hand span
when determining whether notes should be assigned to each staff; if Fixed
is chosen, the value of Split at MIDI note number will be used.

§

Filter out key switches outside range allows you to specify the playable
range for the tracks in the MIDI file, omitting any notes that are required to
trigger specific articulations or playing techniques in the sound library or
virtual instrument used in the original sequence. Any notes lower than the
low note name and octave, and any notes higher than the high note name
and octave, will be omitted during import.

The options in the Notation section are the same as those found in the Recording
section of the Play page of Preferences, and the options in the Performance section
are the same as those found in the Quantization section – see Polyphonic MIDI
transcription below for further discussion of these options.
Players section:
§

Create player group for new players creates a player group to contain all
the players added as part of the import process: if you already have an
existing ensemble of players in your project, it can be helpful to group newly
added players together so that you can find them easily.

§

Create part layouts for new players specifies whether players added as
part of the import process should have part layouts created for them; if you
know you are going to remove these players later after moving their music
to existing instruments, it may be helpful not to see part layouts for these
temporary players in the interim.

Dorico remembers the state of all these options, so they will be set the same way for
each MIDI file that you import.
Advanced editing. For complex MIDI files, you may require greater control than
provided by the basic editor. Activating the Advanced editor toggle button shows
two additional sections, Track settings and Players in Dorico project, that together
provide detailed control over how each track is mapped to one or more players in
the resulting flow.

Dorico 4 Version History

62

Steinberg Media Technologies GmbH

The Track settings section updates based on the selection in the tracks table on the
left-hand side of the dialog. It shows the full details of how the track will be
interpreted during import:

The Instruments in track list at the top of the section shows the instruments
required by the track. If you have, for example, a Horns track that shows 4 under
Max. sim. notes, you may well want to specify four horn instruments in the
Instruments in track list, so that each individual horn line will end up in its own
instrument. When you select an instrument in the Instruments in track list, a
corresponding selection is made in the Players in Dorico project list to the right. If
the track requires more instruments than exist at present, new players will be
added to the Players in Dorico project list to accommodate the required
instruments. Players that are going to be added show + in their icon

to

differentiate them from players already present in the project.
Player type allows you to specify whether the players required for the instruments
in this track should be Single or Section players.
Transpose specifies the number of half-steps (semitones) by which the music in the
track should be transposed; some sample libraries and virtual instruments
transpose instruments by one or more octaves to bring them into a more useful
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playable range on a MIDI keyboard. To transpose by an octave, specify 12 to
transpose up or -12 to transpose down.
Playing tech. specifies the pair of playing techniques represented by this track.
When preparing templates in a sequencer or DAW, composers often create
multiple tracks for a single instrument, so that it’s easy to access different playing
techniques and articulations simply by moving notes to a different track, which is in
turn set to trigger a particular sound in the sample library or virtual instrument in
use. Dorico can combine multiple tracks, each representing a different playing
technique or articulation, into a single instrument. The first in the pair of playing
techniques specifies the playing technique that is used when music from this track
appears, and the second in the pair specifies the technique that is used when music
from this track ends.
For example, if music for a violin instrument is split across two tracks, one using the
normal or natural playing technique and the other using pizzicato, you would
choose Pizzicato/Arco for the pizzicato track. Dorico will then automatically create
the required pizz. playing technique at the start of the music notated from the
pizzicato track, and arco at the start of the music notated from the natural track.
If you need a combination of playing techniques that is not listed, you can choose
Custom from the Playing tech. drop-down, then set the Start and End playing
techniques using the dedicated menus immediately below.
Similarly, the Articulations section specifies which articulation is represented by
this track. If you choose, say, Staccato, then all notes from this track will be notated
staccato in the resulting flow.
Voice separation mode specifies how Dorico will handle chords, if the destination
for a track is a single instrument. If you have mapped a single track to multiple
instruments, Dorico will automatically distribute the notes to each of the
destination instruments, and this option will be disabled.
When mapping a track to a single instrument, Dorico will choose an appropriate
voice separation mode: for example, for a harp or piano it will choose 4 voice
keyboard (auto). However, you may wish to adjust this setting yourself, in which
case the options are:
§

1 voice will notate all music in the track in a single voice

§

2 voice (auto) is the most appropriate choice for a track that contains music
for two instruments but which you want to be notated on a single staff,
rather than assigning it to two instruments (which is recommended)
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§

2 voice (fixed split point) is suitable for grand staff instruments, and uses
the value of Split at MIDI note number in the Import Options section to
determine which notes should be distributed to the upper and lower staves

§

2 voice (explode) will create two voices throughout, and is appropriate for
notating a single staff

§

4 voice keyboard (auto) is the most appropriate choice for a track for a
grand staff instrument, and can automatically detect common keyboard
textures, such as bass and melody with inner chords; for more details, see
Polyphonic MIDI transcription below.

Percussion. When importing a drum set using General MIDI percussion, if the
incoming track uses instruments that are not already defined in the target
percussion kit, Dorico will now automatically add the missing instruments during
import, assigning noteheads and staff positions that can later by edited in the Edit
Percussion Kit dialog after the import is complete.

Polyphonic MIDI transcription
Dorico 4 includes a suite of significant improvements to the transcription of MIDI
music, whether it is recorded into Dorico in real time or imported via a MIDI file.
These improvements include the ability to automatically transcribe keyboard
textures with multiple moving parts cleanly into separate voices, transcription of
slurs, grace notes, trills, tremolos, and smarter transcription of pedal lines.
The result is that music entered into Dorico via MIDI import or real-time recording
is automatically transcribed much more cleanly, bringing you closer to your desired
final result much more quickly.
Transcription options. Dorico uses a common set of options for transcribing music
in real time and importing MIDI files, but they are shown in different locations: for
information about setting transcription options when importing MIDI, see Smart
MIDI import above.
To set the options for real time recording, go to the Play page of Preferences. The
options under Quantization determine the minimum note value Dorico will use
when interpreting your input, and you can specify whether tuplets and grace notes
should be detected, as well as specifying whether Dorico should Fill gaps, which
automatically extends durations to prevent short rests appearing between notes.
The options under Recording specify further specific behaviors for handling
particular notations during real time recording.
Slurs. Dorico now detects slurs when importing MIDI data and creates them
automatically for notes that overlap by a small amount. If you would prefer Dorico
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not to do this, switch off Detect slurs in the Import Options section of MIDI Import
Options, or in the Recording section of the Play page of Preferences.
Grace notes. Dorico now detects slashed grace notes (acciaccaturas) during MIDI
import and retains the original played durations and dynamics. To prevent Dorico
from doing this, click Quantize Options in MIDI Import Options, and in the dialog
that appears, switch off Detect grace notes. This option is also found in the
Quantization section of the Play page of Preferences.
Trills and tremolos. Dorico can now detect trills and tremolos during MIDI import
and real time recording, and replace the original MIDI performance of the trill or
tremolo with a notated trill or tremolo that will subsequently be performed using
Dorico’s automatic playback features. To prevent Dorico from doing this, switch off
Detect tremolos and Detect trills in the Import Options section of MIDI Import
Options, or in the Recording section of the Play page of Preferences.
Pedal lines. When creating pedal lines, Dorico now merges abutting pedal lines into
a single pedal line with retakes at the appropriate positions. When piano pedaling is
performed in real-time, the sustain pedal is usually suppressed after the notes that
should be sustained have been played, but it is conventional for the start of the
pedal line to be notated at the same rhythmic position as the notes that should be
sustained. The new option Snap pedal lines to previous beat enables Dorico to do
this by default.
If you would prefer Dorico not to create pedal lines at all, switch off Import CC64 as
pedal lines in the Import Options section of MIDI Import Options dialog, or in the
Recording section of the Play page of Preferences.
Key signatures. When importing MIDI files, by default Dorico will attempt to choose
the most appropriate key signature for the imported music if none is specified in
the MIDI file. Dorico will only create a single key signature at the start of the flow, so
this will work best with music with a strong tonal center and without modulation.
To disable this, deactivate Detect key signature if missing in the Import Options
section of the MIDI Import Options dialog.
Starting recording. Dorico now shows a helpful message if it is unable to start
recording because there is no valid location to record from.

Insert mode
Insert mode is one of Dorico’s most powerful and unique features, but in practice it
can be difficult to handle. Dorico 4 introduces several significant improvements to
Insert mode to make it even more powerful, but crucially also more practical: firstly,
you can specify a stop position beyond which edits will have no effect, so that you
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can be sure that there will be no unwanted changes later in the flow; and secondly,
it is now possible to specify the scope for Insert mode, allowing you to insert or
remove time not only in the current voice, but in the whole player, and the whole
ensemble.
Stop position. To set the stop position in a flow, either show the caret, or select a
note, rest or other item at the desired position, then choose Write ▶ Insert Mode
Scope ▶ Set Edit Stop Position, or type the shortcut Shift+Alt+I. Alternatively, if the
system track is visible, you can click the

“no entry” icon to set the stop position at

that barline.
The stop position appears as a translucent red line that spans all of the staves in the
flow. You can move the stop position to a new position by choosing Set Edit Stop
Position again, or by dragging it with the mouse: the top of the line has a handle that
you can click and drag. By default, the stop position snaps to barlines; hold the Alt
key to drag the stop position by the rhythmic grid value instead.
To remove the stop position altogether, you can drag it off the start or end of the
flow: when the stop position becomes dotted, when you release the mouse button,
the stop position will be removed.
When you perform an edit that crosses the stop position, such as copying and
pasting, repeating material, or pushing material along by entering new notes in
Insert mode, the edit will not allow any changes after the stop position.
In general, the stop position will not be moved automatically, but in a couple of
situations, such as when you are lengthening or shortening a bar in Insert mode,
Dorico will adjust the stop position automatically such that it still makes sense.
Insert mode scope. In a major expansion of the capabilities of Insert mode, you can
now choose the scope that will be affected by your Insert mode edits from the new
Write ▶ Insert Scope submenu, or cycle through the four options by typing Alt+I.
The four different scopes are:
§

Voice: familiar from previous versions of Dorico, only notes, rests, tuplets
and other items in the current voice are affected

§

Player: affects all voices belonging to the current player, and all non-voiceattached items, such as dynamics

§

Global: affects all players in the flow

§

Global Adjustment of Current Bar: affects all players in the flow, but if note
input is active, it additionally changes the length of the current bar rather
than pushing or pulling items across barlines.
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If the caret is shown, the appearance of the caret is modified according to the
chosen scope:
Voice

Player

Global

The current scope is also shown in the Notes toolbox on the left-hand side in Write
mode. You can additionally click and hold, or right-click, the Insert toolbox button
to choose the desired scope.
Percussion kits. When working with unpitched percussion kits set to be displayed
using the five-line staff or grid presentation types, Dorico automatically uses Player
scope when Insert mode is active. Using Player scope ensures that all the
instruments in the kit will be affected correctly, rather than only those that happen
to be notated in the same voice.
Global adjustment of the current bar. The ability to dynamically lengthen or shorten
the current bar is very useful when working with unmetered music, such as chant
or psalmody, or for special cases such as cadenzas. Depending on the situation, you
may or may not find it helpful for Dorico to insert a new time signature in the
affected bar. An option to control this, When inserting with Global Adjustment of
Current Bar, can be found on the new Insert Mode page of Note Input Options.

Melodic and rhythmic transformations
Dorico 4 introduces a powerful new suite of tools for transforming melodic and
rhythmic material. They can all be found in the Write ▶ Transform submenu, or
they can be invoked from the Shift+I popover.
Write ▶ Transform ▶ Pitches:
§

Invert Pitches changes the melodic contour such that a rising interval
becomes a falling one of the same size.

§

Reverse Pitches takes the pitches of a series of notes and reverse their
order, so that the first pitch becomes the last, the second becomes the
penultimate, and so on; this is also known as retrograde.
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§

Reverse and Invert Pitches performs what is also known as a retrograde
inversion, where the melodic contour is inverted the order of pitches is
reversed.

§

Rotate Pitches shifts the pitches by a specified number of notes in a circular
fashion; rotating a single note will, for example, take the pitch of the last
selected note and apply that pitch to the first selected note, with the pitch of
every subsequent note being shifted to the right by one note.

§

Map Pitches provides a specific mapping from one pitch to another, so that
all notes with a particular pitch will have their pitches changed to another
particular pitch.

§

Map Scale provides a mapping from one scale to another, adjusting the
pitches of all notes according to a source and destination scale.

§

Repeat Pitches applies the pitches of the first n selected notes in turn to
each of the remainder of the selected notes.

Write ▶ Transform ▶ Rhythm:
§

Reverse Rhythms reverses the order of the durations of the selected notes,
so the duration of the first note is applied to the final note, the duration of
the second note is applied to the penultimate note, and so on.

§

Rotate Rhythms shifts the durations by a specified number of notes in a
circular fashion.

Write ▶ Transform ▶ Both:
§

Reverse Pitches and Rhythms reverses the order of both the durations and
pitches of the selected notes.

§

Reverse and Invert Pitches and Reverse Rhythms reverses the order of
both the durations and pitches of the selected notes, additionally inverting
the pitches (such that a rising interval becomes a falling one of the same
size).

§

Rotate Pitches and Rhythms effectively shuffles the selected notes by a
specified number of notes in a circular fashion.

All these melodic and rhythmic transformations apply not only to notes, but also to
all other selected material, including playing techniques, lyrics, dynamics, slurs,
and so on. They can be applied not only to pitched material, but also to unpitched
material written for percussion instruments.
Inversion. Choosing Write ▶ Transform ▶ Pitches ▶ Invert Pitches shows the
following dialog:
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Invert using specifies the behavior of the inversion operation:
§

Outermost pitches retains the highest and lowest pitches in the selected
passage, and transposes the other notes chromatically within the range
described by those outermost pitches. It is not possible to choose the
Diatonic inversion type when retaining the outermost pitches.

§

Specific pitch allows you to specify the pitch around which the inversion
should take place using the controls that appear below. You can choose in
this case whether to perform a Diatonic or Chromatic inversion.

§

Root uses the root note of the key signature, or C in the case of an
open/atonal or no key signature, as the pitch around which the inversion
should take place. You can additionally choose whether to perform a
Diatonic or Chromatic inversion.

§

First note uses the pitch of the first selected note as the pivot point for the
inversion, and in case the first selected note is actually a chord, you can
furthermore choose whether to use the highest or lowest note of the chord
as the pivot point. You can additionally choose whether to perform a
Diatonic or Chromatic inversion.

The same dialog appears when you choose Write ▶ Transform ▶ Pitches ▶ Reverse
and Invert Pitches and Write ▶ Transform ▶ Pitches ▶ Reverse and Invert Pitches
and Reverse Rhythms, so that you can specify the inversion behavior in each case.
To specify the inversion transformation when using the Shift+I popover, type
inversion, invert, mirror or inv. In addition:
§

Add a note name and octave to specify the pitch around which the inversion
should pivot, e.g. invc4 will invert around middle C (C4), or invEb5 will invert
around E♭5.

§

You can also specify the pitch in terms of divisions of the octave: for
example, if you are using a 24-EDO tonality system, typing inv D1/24 4 will
invert around D quarter-sharp 4.

§

Add root instead of a note name to specify that the inversion should be
around the root of the key.
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§

Add diatonic or diat to specify diatonic inversion, or chromatic or chrom to
specify chromatic inversion.

§

To invert around the pitch of the first note, specify top or bottom to choose
between using the highest or lowest pitch if the first note is a chord.

Retrograde. Using the Shift+I popover you can reverse either or both the pitches and
rhythms of the selected music:
§

Type retrograde, ret, reverse or rev to perform a complete retrograde of
both pitches and rhythms of the selected notes.

§

To reverse only the pitches, add pitches or pt, e.g. rev pitches.

§

To reverse only the rhythms, add rhythms or rm, e.g. ret rm.

§

To invert the pitches as well as reverse them, add invert or inv, along with
any additional instructions for the inversion operation, as described above.

§

To specify that Dorico should additionally include items that are not in the
selected voice, but instead belong to the player as a whole, add player.

§

Conversely, to specify that only items in the same voice as the selected
notes should be affected, add voice.

Rotation. Choosing Write ▶ Transform ▶ Pitches ▶ Rotate Pitches, Write ▶
Transform ▶ Rhythm ▶ Rotate Rhythms, or Write ▶ Transform ▶ Both ▶ Rotate
Pitches and Rhythms shows the following dialog:

You can specify the Number of steps, and the Direction of rotation. Forwards
means that things are shifted to the right, so that the pitch or rhythm of the last note
becomes the pitch or rhythm of the first note; Backwards means that things are
shifted to the left, so that the pitch or rhythm of the first note becomes the pitch of
rhythm of the last note.
To specify rotation via the Shift+I popover:
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§

To rotate both rhythms and pitches, type rotate or rot.

§

To rotate only pitches, add pitches or pit, e.g. rot pit.

§

To rotate only rhythms, add rhythm, rhy, or rm, e.g. rot rhy.

§

To specify the number of steps, use a positive number to specify a number
of forwards steps, or use a negative number to specify a number of
backwards steps, e.g. rot pit 3 or rot rhy -2. If you prefer, you can also
specify backwards rotation using backwards, bw, or prev.

Pitch mapping. Choosing Write ▶ Transform ▶ Pitches ▶ Map Pitches shows the
following dialog:

You can specify one or more mappings for pitches: set the source pitch using the
controls next to Map pitch, and the destination pitch using the controls next to To.
Specify whether the destination pitch should be specifically higher or lower than
the source pitch, closest in pitch, or in a specific octave, then click Add Mapping. If
you want to remove a mapping that you have set up, select it in the list of defined
mappings, and click Delete Mapping. When you have set up all of the required
mappings, click OK to apply the transformation.
To specify pitch mapping via the Shift+I popover:
§

Type the source and destination pitches, separated by an equals sign, and
each pair of mapped pitches with a comma, e.g. c4 = b3, d#5 = f#

§

Use the note name on its own if you don’t want to specify a particular
octave, or add the octave number after the note name if you do.

Dorico 4 Version History

72

Steinberg Media Technologies GmbH

§

Add * (asterisk) after the note name and optional octave to specify that you
want notes enharmonically equivalent to the chosen source note to be
included.

§

Add up or down to specify that the destination pitch should by higher or
lower than the source pitch.

Scale mapping. Choosing Write ▶ Transform ▶ Pitches ▶ Map Scale shows the
following dialog:

Scale mapping works by mapping each selected note to a source scale, so that it
knows the equivalent scale degree for each note, and then mapping that source
scale to a destination scale, so that each note is assigned to the corresponding
degree of the destination scale, thus transforming the melodic contour.
Dorico provides 18 preset types of scales, but if you want to specify a custom scale as
either the source or destination, you can describe the scale by choosing the closest
available preset, then entering any differing pitches in the Source scale overrides
or Destination scale overrides edit controls.
By default, Dorico will perform the transformation using the scale root implied by
the prevailing key signature, but if you want to specify a different root note for
either the source or destination scales, you can do so using the Use source root and
Use destination root controls at the top of the dialog.
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Choose the Source scale pattern and Destination scale pattern, apply any
overrides to either scale, specify the Direction for notes to be snapped, and click OK
to apply the transformation.
You may also want to set one or more of the additional options at the bottom of the
dialog:
§

Snap all pitches to destination scale determines what Dorico should do
with non-scale tones in the selected music; if you activate this option, notes
outside the scale will be snapped to the nearest pitch in the destination
scale.

§

Treat enharmonic equivalents as matching source scale determines
whether notes that have the same sounding pitch as notes in the source
scale should be considered as matching the source scale, and as such
whether they should be mapped to the destination scale.

§

If Treat enharmonic equivalents as matching source scale is activated,
you can additionally activate Respell enharmonic equivalents to fit
destination scale, which will cause those notes to be respelled.

§

Keep relative offsets from source scale is subtle. When Dorico transforms
material from one scale to another, it begins by transposing all the music by
the interval between the roots of the source and destination scales. For
example, if you write B♭ in C major, and transform C major to D Aeolian, the
interval between the roots of the scales is a major second. The interval
between B♭ and B natural, the nearest scale tone, is a diminished unison, so
the B♭ could end up as a C ♭, but C natural is a more likely note in the
destination scale. If you would prefer to maintain the offsets between the
notes at the expense of less likely scale tones after transformation, activate
Keep relative offsets from source scale.

To specify scale mapping via the Shift+I popover, you type in the form source to
destination, where the source and destination scales should be written in the form
of the note name of the root followed by the kind of scale:
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§

Ionian or major: ion, maj, M

§

Harmonic minor: harm min, har m, hmc m

§

Melodic minor ascending: me min, mdc m

§

Dorian: dor, drn

§

Phrygian: phryg, phry, phr

§

Lydian: lyd

§

Lydian dominant: lyd dom

§

Mixolydian: mixlyd, mlyd, mixo, mix, ml
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§

Aeolian or natural minor: aeol min, aeo m, aln m, nat min

§

Locrian: loc

§

Super Locrian (altered scale): super loc, sup loc, spr loc

§

Major pentatonic: maj pent, M pent, maj 5tonic, M 5ton

§

Minor pentatonic: min pent, m pent, min 5tonic, m 5ton

§

Major blues: maj blue, M bls, maj bls

§

Minor blues: min blue, m bls, min bls

§

Half-whole diminished or octatonic: half whole, halfwhole, hw, half-tone,
half tone, halftone, htone, hton, half, ht, dimin, octa, dim, oct

§

Whole-half diminished or octatonic: whole half octa, wholehalf dim, wh
oct, whole-tone oct, whole tone dim, wholetone dimin, wtone oct, wton
dim, whole dim, wt dim, wt dimin

§

Whole tone: whole-tone, wholetone, wtone, wton, whole, wt

§

Locrian ♭♭7 or harmonic major mode 7: loc harm maj 7, loc har M 7, loc har
mode7

§

Super locrian ♭♭7 or harmonic minor mode 7: sup loc, spr loc, harm min
mode7, hm mod7

All the above popover terms are case-insensitive, apart from M and m, which
represent major and minor respectively. To map from C major to C minor, for
example, you could type c M to c m.
You can also specify alterations to any of the scales by including the degree to be
modified: for example, to raise the fourth degree of the major scale, you could type
maj #4.
To activate the Snap all pitches to destination scale option, include the word snap
in your popover input. You can also specify the direction in which Dorico should
move notes that have to be adjusted to match the new scale; by default, it will always
use the smallest interval, but if you want to enforce a specific direction, you can add
up, higher, down or lower to your input.
Finally, you can also use scale mapping to manipulate the spelling of notes without
applying a new scale, or to snap non-scale tones to a particular scale. To respell the
selected notes in a passage according to a particular scale, type (say) spell C maj. To
snap non-scale tones, type (say) snap F min. You can even combine these two
operations, so if you have managed to end up with, for example, both an F♭ and an A♭
in music nominally in C major, typing spell snap C maj will both respell the F♭ as E♮,
and snap the A♭ to A♮.
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Repeat pitches. The transformation to repeat pitches takes the specified number of
pitches from the beginning of the selection, and then repeats those pitches in
sequence across the remaining selected notes. Choosing Write ▶ Transform ▶
Pitches ▶ Repeat Pitches shows the following dialog:

Simply specify the Number of pitches to repeat and click OK to confirm the dialog.
To repeat pitches using the Shift+I popover, type repeat n pitches, or for short rep n
pit, where n is the number of pitches to be repeated.
Note Input Options. A new Musical Transformations page has been added to the
Note Input Options dialog. Detailed explanations for each of the options are
provided in the dialog itself, but it is worth dwelling on the first two options.
Some transformation operations can cause the overall duration of the selection to
change; by default, Dorico will clip any notes that exceed the original selected
duration, but if you prefer, you can specify that Dorico should instead not carry out
the transformation at all.
Similarly, in complex situations involving tuplets, it is possible for notes that were
not previously contained in a tuplet to be moved into one, or vice versa. By default,
Dorico will scale notes as necessary to allow them to enter or leave a tuplet, but if
you prefer, you can specify that the transformation should not be carried out.

Instrument filters
When working on layouts with many instruments, it can be useful to see just one or
a few staves that you want to focus on for a while. Dorico 4 introduces new
instrument filters for galley view that make it quick and easy to show a subset of the
instruments in the layout.
Instrument filter overlay. When you switch to galley view, by default Dorico will show
the instrument filter overlay in the top left corner of the view.

Dorico 4 Version History

76

Steinberg Media Technologies GmbH

If you don’t want to see the overlay, you can switch it off by deactivating View ▶
Instrument Filter Overlay.
The filter button at the left-hand side of the overlay activates or deactivates the
filter shown in the menu in the middle of the control. You can also activate or
deactivate the current filter by choosing Write ▶ Instrument Visibility ▶ Use
Instrument Filter.
The + button in the overlay is enabled when you have a selection in the music, and
allows you to create a new instrument filter by selecting items in one or more
instruments in the music. You can also use Write ▶ Instrument Visibility ▶ Create
Preset From Selection to perform the same action.
Finally, the … button at the right-hand side of the overlay opens the Manage
Instrument Filters dialog, which allows you to create, edit and delete instrument
filters. You can also access this dialog by choosing Write ▶ Instrument Visibility ▶
Edit Instrument Filter Presets.
Manage Instrument Filters dialog. The Manage Instrument Filters dialog looks like
this:

Instrument filters are specific to a particular layout in your project (since each
layout can, and usually does, contain different players and their respective
instruments), so the dialog reminds you of the layout for which you are managing
presets.
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The presets are shown in the large list that occupies most of the dialog. When you
select a preset, the Instruments in filter list on the right-hand side shows which
instruments are currently included, and allows you to add or remove instruments
from the filter by activating or deactivating the relevant checkbox.
Dorico generates names for each preset based on the short names of the
instruments included in the filter, but you can edit the names by clicking the pencil
icon at the left-hand side of each list entry. The name shown in bold in the first row
of the entry is the name that will appear in the instrument filter overlay, and in the
Write ▶ Instrument Visibility submenu.
The number at the right-hand side of the list entry indicates the index of the preset,
corresponding to the numbers that appear in the Key Commands page of
Preferences – see below. To change the index of a selected preset, use the arrows in
the action bar below the list to move it up or down in the list.
To quickly generate a useful set of presets, you can click the Add Presets from
Instrument Families button, which as its name suggests will create presets for each
instrument family represented in the layout.
Key commands for instrument filters. To make it quick and easy to recall instrument
filters, it is possible to define custom key commands for up to 10 presets. On the Key
Commands page of Preferences, expand the Edit category and you will find 10
commands from Instrument Filter Preset 1 through Instrument Filter Preset 10.
Remember that instrument filters are specific to a particular layout, so the key
command for (say) Instrument Filter Preset 1 will recall a completely different
preset in two different layouts within the same project, or in a different project.
Working with instrument filters. When an instrument filter is active, Dorico draws a
dashed line at the point in the system where one or more instruments is hidden.
You cannot select music belonging to instruments that are hidden by an instrument
filter, and nor can you paste into instruments hidden by an instrument filter.

User-defined project templates
Dorico 4 makes it possible to save any project as a template for future projects. This
allows you to create future projects for the same ensemble of players and
instruments, using your own preferred options, page templates, playback template,
and so on.
Save as Project Template. To save your current project as a project template, choose
File ▶ Save As Project Template, which shows a simple dialog in which you can
specify the category in which the template should appear and its name. If you save a
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template with the same name as an existing factory-supplied template in the same
category, your template will take precedence over the factory template.
You can choose whether to retain the existing flows in the project (so that they will
appear in a new project you create based on the template) and whether to retain the
current Project Info values in the template.
Using the project template. Any project templates you create will appear both in the
Create New page in the Hub, and in the File ▶ New From Project Template
submenu.
When you use the Create New page in the Hub to start a new project based on your
user-defined template, you can use options on the right-hand side to set various
defaults for the newly created project. The Page size, orientation and Rastral size
options are disabled, however, so that the new project always uses the values from
the template.
When you choose your user-defined project template from the File ▶ New From
Project Template submenu, none of these options in the Hub will be applied, and
the project will be created containing either an empty flow of a single quarter
(crotchet) in length, or whatever flow you chose to keep when you saved your
project as a template.
Deleting a template. You can delete a user-defined project template by clicking the
menu button

in the top right-hand corner of the template’s card in the Create

New page in the Hub and choosing Delete Project Template from the menu. You
will be prompted to confirm the deletion: if you proceed, the project template will be
deleted and will no longer appear in the application.

Revamped ensemble picker
Dorico 4 provides a new, efficient way to add multiple players to your project, and
save your own combinations of instruments for later recall, via the revamped
ensemble picker. As in previous versions, the ensemble picker can be opened by
choosing Setup ▶ Add Ensemble or by clicking the

button in the action bar in the

Players panel. New in Dorico 4, you can also now open it via the new default key
command Shift+E.
The ensemble builder has two modes of operation, Build and Choose, which are
accessed using the toggle buttons at the top of the picker.
Choosing an ensemble. To simply choose one of the preset ensembles, as in previous
versions of Dorico, click Choose. All the default ensembles appear, organized as
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before into categories, and any user-defined ensembles that you save in the Build
page will appear here too.
Building your own ensemble. To add any combination of instruments to your project,
you can use the new Build page. You can type full or abbreviated instrument names
– for example fl or flute – optionally prefixed with a number – for example 4 hn to
add four horns in F. Each instrument must be separated with a comma: for example,
you could type 2 fl, picc, 2 ob, 2 clar. If you omit the commas, Dorico will attempt to
parse the entire input text as an instruction for a single instrument.
As you type into the edit control at the top of the Build page, the instruments that
Dorico has detected from your input are shown in the list below, but if you delete
any of the existing text from the edit control, the corresponding instruments will be
removed from the list. To confirm to Dorico that the instruments shown so far
should definitely be added, hit Tab to commit the current instruments shown in the
list below, clearing the edit control and allowing you to type further instruments.
You can also use orchestral shorthand for woodwind and brass instruments, for
example 2picc.2.2.1 / 4.3.3.1 for two flutes, one piccolo, two clarinets, two oboes,
one bassoon, four horns, three trumpets, three trombones, and one tuba. The
woodwind shorthand describes the number of flutes (plus optional piccolo,
specified by adding picc after the number of flutes), clarinets, oboes and bassoons.
The brass shorthand describes the number of horns, trumpets, trombones and
tubas.
If you provide only one set of shorthand digits, Dorico will assume it is specifying
woodwind instruments. To specify only brass, prefix the shorthand with br, for
example br4221.
You do not have to separate the digits for each instrument with a period or any
other separator, though you can if you wish. Dorico expects there to be a maximum
of nine instruments in any section – you cannot add (say) 12 horns by typing
br12.3.3.1.
Finally, you can also type the name of any preset ensemble into the edit control on
the Build page to add those instruments to the list to be added to the project.
To toggle the type of player to be added between single and section players, simply
double-click the relevant row in the ensemble builder.
When you are happy with the players and instruments shown in the list in the Build
page, click Add to add them to the project.
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To save your own ensemble preset for future use, add the desired players and
instruments to the list, then click Save to specify the name and category for the new
preset ensemble. This preset will then be available in Setup mode in all projects, and
will appear in the Choose page of the ensemble picker in the specified category.

Automatic score order and soloists
When adding new players and instruments, Dorico now automatically sorts the
instruments according to the conventional orchestral score order. It is also possible
to designate a particular player as a soloist, which will move them to the traditional
position in the score order, namely above the strings, and automatically name and
bracket them appropriately.
Enabling automatic score order in existing projects. To avoid making unexpected or
unwanted changes to your existing projects, automatic score ordering is only
enabled by default in new projects you create in Dorico 4.
To enable automatic score ordering, click and hold or right-click the new Sort
Players button

in the action bar in the Players panel in Setup mode: a menu will

appear in which you can choose between None, which disables automatic score
ordering, and Orchestral, which specifies the standard orchestral instrument
order. This choice specifies the order that will be applied when you click Sort
Players or when adding new instruments, so having chosen Orchestral, if you then
click Sort Players, the standard orchestral score order will be applied.
Soloists. If you have a player that should be designated as a soloist in your project,
right-click that player in the Players panel, and choose Soloist from the context
menu.
This causes the instrument to move in the score order to the conventional position
for a soloist (for example, in a concerto), directly above the strings. In addition:
§

Any instruments held by that player will no longer be considered for
numbering with other similar instruments in the same player group

§

Provided the full and short names for the instrument are the same as the
default full and short names for the instrument, Dorico will prepend Solo to
the instrument name (and hence staff label), using the language chosen for
instrument names in Engraving Options.

§

Soloists will also not be bracketed with instruments in the same family if
they are adjacent, so if for example you have a solo violin directly above
Violin 1 (and both are the same player type, however unlikely that may be),
then soloist will not be bracketed with the strings.
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All these things are reversed if you choose Soloist again from the context menu to
say that a player should no longer be considered a soloist.
System items for soloists. You can choose whether system-attached items such as
tempos and rehearsal marks should appear above the first soloist staff by activating
the Soloist checkbox in the Show system objects above the first bracket for the
given instrument families list on the Players page of Layout Options.
Bracketing for soloists. If you have the Bracketed groups with only one instrument
option on the Brackets and Braces page of Layout Options set to Use bracket, then
the soloist will now get a bracket; if there are two or more soloists, then they will
now be joined by a bracket regardless of whether they are from the same
instrument family.
Layouts. By default, part layouts in the Layouts panel will also be sorted in the same
order as the players, but if you prefer, you can specify that layouts should instead be
sorted by layout number; click and hold on the Sort Layouts button to choose
between these two sorting approaches.
Single players. To disambiguate soloists, what were previously known as solo
players in earlier versions of Dorico are now called single players.

Library Manager O
In Dorico, the term library refers to the complete set of options in the five primary
options dialogs (Engraving Options, Layout Options, Notation Options, Note Input
Options and Playback Options) and all the collections of items whose appearance
and semantic meaning you can edit or define, including (but not limited to) font
styles, paragraph styles, playing techniques, notehead sets, music symbols,
expression and percussion maps, and so on.
To reinforce the concept of the library, Dorico 4 includes a new Library menu,
which brings together all the main options dialogs and all the dialogs in which you
can edit or define the items used in your project. Full details of these changes can be
found under User interface on page 123.
Dorico is almost endlessly configurable, with hundreds of user-selectable options
and the ability to customize the appearance of practically every item in your project.
Managing these options even within a single project is challenging and being able to
maintain a consistent appearance and set of options across multiple projects was
impractical in previous versions of the software.
Dorico 4 aims to change that, with the introduction of the new Library Manager. The
Library Manager allows you to examine the library of the current project in detail,
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and compare it with the library in another project, or the factory library (Dorico’s
default settings), or your user library (which is a combination of the factory library
and the changes you have made to it and then saved as defaults for use in future
projects).
It is then easy to import settings or items from the source library – either the library
from another project, or the factory library, or your user library – into the target
library, which is the library of the project you are currently editing. You can import
individual settings within individual classes of options, or you can import
everything from the source library. Everything is completely within your control.
Opening the Library Manager. To open the Library Manager, choose Library ▶
Library Manager. This dialog opens:

At the top of the right-hand side of the dialog, you can specify the source library:
you can drag and drop the Dorico project containing the source library into the drop
area; or you can click the document icon to show a file chooser to browse to the
Dorico project containing the source library. Alternatively, click Factory settings or
User library to choose the factory library or your user library.
Once you have specified the source library, you can see how the target library
differs from the source. On the left-hand side of the dialog, the library contents are
separated into two lists: Options, and Collections.
Filtering and searching. To quickly see only the differences between the source and
target libraries, use the provided filters: click Differences to see only those option
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values and collection items that differ between the source and target libraries, or
click Not in this project to see only collection items that exist only in the source
library and not in the target library.

At the right-hand side is a Search box, which searches within the currently selected
set of options or collection type.
Comparing and importing options. To compare a specific set of options in the source
library with the target library, first click the desired set of options in the left-hand
list. You can then navigate through the categories of options within that set on the
right-hand side. If all the options have identical values between the source and
target libraries, the category will show a checkmark

and the words All options

match. If one or more of the options have differing values, however, the category
will show an inequality sign

and the words Some options differ.

To set all the options in the target library to the values from the source library,
simply click the inequality sign. The inequality sign will be replaced by a leftpointing arrow

to indicate that the differing values have been updated.

If you change your mind and decide you do not wish to import those values after all,
simply click the left-pointing arrow again; when you hover your mouse over the
arrow, it will become a cross

that you can click to revert those changes.

If you prefer to examine individual option values within a category, expand the
section by clicking the disclosure arrow at the right-hand side. Each option in that
category is shown, with the value in the project’s library (the target) on the left and
the source library on the right. In the same way as with whole categories, you can
click the inequality sign between the target and source values to apply the source
library’s value to the target library.
Layout- and flow-specific options. Layout Options can have different values for each
layout in a project, while Notation Options can differ for each flow.
When you choose to examine Layout Options in the Library Manager, you can
specify for both the target library (the project currently being edited) and the source
library (the project or library from which you want to import options values and
collection items) which layout should be used to provide the values. It is generally
advisable to compare the options for similar layouts, for example full score layouts
with full score layouts, and part layouts with part layouts.
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Similarly, when you choose to examine Notation Options in the Library Manager,
you can choose which flow in the target library and the source library to compare.
Comparing and importing collections. As you examine the various collections of
items in the source and target libraries, bear in mind that any individual Dorico
project is unlikely to contain every item in every collection in the library: only those
items that are actually used in the project, or which have been edited or defined by
you, are included in the library. When you compare the libraries of two Dorico
projects, then, you should not expect to see every item in every collection shown in
the Library Manager; indeed, it is quite unlikely that the two libraries will even
contain the same items as each other within any given collection.
When you select a particular collection, Dorico will display the items that exist in
that collection in the respective libraries. All items have a detailed text description
that provides information about the properties of that item, and many items
provide a graphical preview when selected, so that you can compare the items in
the source and target libraries graphically.
Once you have decided to import an item, click the inequality sign
replaced by a left-pointing arrow

, which will be

to indicate that a new item will be imported or

an existing item updated. If you change your mind and decide you do not wish to
import an item after all, simply click the left-pointing arrow again; when you hover
your mouse over the arrow, it will become a cross

that you can click to revert the

change.
Dependent items. It is especially useful to be able to import collection items that are
not present at all in the target library, for example to bring in custom expression
maps, percussion maps, playing techniques and playback techniques that you have
defined in one project into another. When an item is not present at all in the target
library, and you choose to import it, it will be added, along with any other items that
the chosen item depends upon.
For example, a playing technique may depend on either a specific font style (if it is
shown as text), or on a particular music symbol, in which case it will depend on at
least one font style, and possibly more, or perhaps even a graphic file embedded in
the source project. When you choose to import that playing technique, the
dependent items are also imported. Exactly what happens to those dependent
items depends on the state of the target library:
§

Any collection items that already exist in the target library and which are
identical to those in the source library are not imported, provided all of their
dependencies similarly exist and are identical.

§

If any of those dependent items in the target library have different internal
identifiers to the entities in the source library (which they will if they have
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been user-defined), the parent items will be updated with the new target
library identifiers, so that they remain correctly linked together.
§

If any of the dependent items that are being imported from the source
library have the same name as an item already in the target library, each of
those items is given a new unique name upon import (for example, by
appending a number to the end of its name).

§

If any of the dependent items that are being imported have the same
internal identifier as any items already in the target library, each imported
item is given a new internal identifier, references to which are updated in
each parent item that requires that item.

In summary, to ensure that imported items have the same appearance and
behavior in the target library as they had in the source library, any dependent items
are imported without overwriting any corresponding items in the target library, to
avoid existing items that already use (say) a dependent font style changing
appearance after import.
Applying the changes. Any change you make in either the Options or Collections
sections will not be applied until you click the Apply button. If you need to import
options or collection items from multiple different source libraries within the same
session, you must click Apply before you select a new source library.

Jump bar
The jump bar is a new user interface element that allows you to quickly run
commands, and to efficiently navigate through your music by going to specific
flows, rehearsal marks, bars, or pages.
Showing the jump bar. The jump bar is invoked by hitting J and appears in the center
of the project window:

Jump bar modes. It has two modes: Command and Go To. By default, it opens in
command mode. You can switch between the two modes either by clicking the
buttons in the jump bar, or:
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§

On Windows, type Alt+C for command mode and Alt+G for go to mode.

§

On Mac, type Control-1 for command mode and Control-2 for go to mode.

The jump bar remembers which mode it was last in, so reopens in that mode. At the
start of each new session, the jump bar will always default to command mode.
Command mode. In command mode, when the jump bar first opens, the last-used
command is shown in the text field, and the text is selected. You can simply hit
Return to execute that command again, or you can type to choose another
command, or you can use ↑/↓ to open the pop-up below the text field to choose
from your most frequently used commands.
Each time you execute a command via the jump bar, Dorico updates its persistent
cache of the frequency with which you use each command, so as you use the jump
bar it will learn which commands you use most often.
The five most frequently used commands are shown in the pop-up by default, so
you can use the up/down keys to choose one of them. If the last command you
executed is not among the five most frequently used commands, it is nevertheless
also added to the pop-up so that it can be chosen by default.
Commands can only be chosen via the jump bar if they can be executed given the
current window mode, selection state, and so on. For example, if one of your five
most frequently used commands is, say, System Break, this won't appear unless
you are in Engrave mode and there is a valid selection.
If you want to execute an arbitrary command, you can type to search for one. All
valid commands that can be executed without special parameters being specified
will appear.
Dorico also helpfully adds special commands for each of the pages of each of the
five main multi-page options dialogs, so you can type e.g. bar numbers and you will
see separate entries for the Bar Numbers pages of Engraving Options, Layout
Options, and Notation Options.
Jump bar aliases. You can also set aliases for commands in the jump bar, which are
special sequences of characters that you can use to trigger a particular command as
quickly as possible. Let's say you want to create an alias of st for the View ▶ System
Track command. You would do this by typing system track=st into the jump bar.
The characters following the equals sign will be set as the alias for that command,
which allows you to then quickly execute that command by typing J (to show the
jump bar) st (to choose the alias) Return (to confirm the jump bar).
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Jump bar aliases appear in the jump bar’s pop-up, just to the left of the key
command for that command, if it has one. Aliases can also be edited on the Key
Commands page of Preferences: search for the command in the main tree view,
and any defined jump bar alias will appear in the Jump Bar Alias section in the
bottom right-hand corner, allowing you to update or delete the alias. You can also
set a new alias from here if you wish.
To set a new alias via the jump bar without executing the command, hold Alt when
you hit Return to confirm the jump bar: that will set the alias, but not execute the
command.
Go to mode. In go to mode, you can type the following:
§

f followed by a number, e.g. f3, to go to that flow (equivalent to clicking that
flow's card in the Flows panel in Setup mode)

§

fn to go to the next flow, or fp to go to the previous flow

§

b followed by a number, e.g. b24, to go to that bar in the current flow
(equivalent to Edit ▶ Go To ▶ Go To Bar)

§

f and b can be combined, e.g. f2b14, to go to a particular bar in a specific flow
in the layout

§

p followed by a number, e.g. p13, to go to that page (equivalent to Edit ▶ Go
To ▶ Go To Page)

§

r followed by a letter or a number, e.g. rc or r13, to go to that rehearsal mark
(equivalent to Edit ▶ Go To ▶ Go To Rehearsal Mark).

Beware that the current flow is the flow in which you either currently have items
selected, or it was the flow in which you most recently had items selected; it is not
necessarily the flow that is currently in the view.

Capos for fretted instruments
A capo is a device that is applied to the neck of a fretted instrument, typically a
guitar, that depresses some, but more typically all, of the strings at a particular fret,
thus raising their open pitch. Capos are normally used to make it possible to play in
a particular sounding key while using the same fingerings that would normally be
used when playing open, or in other words without a capo.
Dorico 4 introduces comprehensive support for capos for fretted instruments,
allowing you to define a full or partial capo for your instrument, and specify the
effect this should have on the staff notation, chord symbols and diagrams, and the
tablature itself.
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Defining a capo. Capos are defined in the Edit Strings and Tuning dialog. To open
the dialog, expand the card for the player holding the guitar or other fretted
instrument in the Players panel in Setup mode, then click the … menu button at the
right-hand side of the label for the instrument that is revealed in the expanded
card, and finally choose Edit Strings and Tuning. To define the capo, click Capo at
the bottom of the dialog, which shows the following simple dialog:

If you choose Full Capo, you need only specify the Fret at which the capo should be
placed; if you choose Partial Capo, you specify not only the Fret but also which
strings to which the capo should apply. When you confirm your choice, a graphical
representation of the capo appears on the neck in Edit Strings and Tuning.
You may want to show the notation transposed into the sounding key, in which case
set Transposition interval for staff notation to the desired value. Because a capo at
the, say, second fret might suggest a root of either F♯ or G♭, it is important to be able
to specify the interval in terms of a note name rather than simply applying a
transposition by a number of half-steps or semitones.
Having specified a transposition interval for staff notation, this will only take effect
if the new Use fretted instrument transposition for notation option is set for this
specific instrument in the Fretted Instruments section of the Players page of
Layout Options, and if the layout is currently shown at transposed pitch.
Chord symbols. Because chord symbols in Dorico are global by default and therefore
apply to all the instruments in the flow, the chord symbols shown above a given
player do not consider a capo defined for any particular instrument in your
ensemble. Instead, you can specify the transposition interval to be used for the
notional capo for each player if you wish.
To specify the transposition interval, right-click the player above whose staff the
capo chord symbols should appear in the Players panel in Setup mode, and from the
Chord Symbols submenu of the contextual menu, choose Capo Chord Symbol
Transposition for Player. This shows a dialog in which you can specify the interval
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by which the chord symbol should be transposed, in the same manner as in the Edit
Strings and Tuning dialog.
Once the capo transposition has been specified, there are several options for how
the chord symbols themselves should appear for the player, all of which can be
similarly chosen from the Chord Symbols submenu of the player’s contextual
menu:
§

Show Main Chord Symbol for Capo shows only the main chord symbol, and
does not show the transposed capo chord symbol

§

Show Transposed Chord Symbol for Capo shows only the transposed capo
chord symbol, and does not show the main chord symbol

§

Show Capo Chord Symbol Above Main shows both the capo and main
chord symbols, with the transposed chord symbol above the main chord
symbol

§

Show Capo Chord Symbol Below Main shows both the capo and main
chord symbols, with the transposed chord symbol below the main chord
symbol

When showing capo chord symbols together with main chord symbols, it can be
helpful to visually differentiate the two kinds of chord symbols, and Dorico can
either display capo chord symbols in italics, or in parentheses. To change this,
modify Capo chord symbol appearance in the new Capo section of the Chord
Symbols page of Engraving Options. You can also here change the vertical gap
between the capo and main chord symbols if necessary.
If you wish, you can also override whether the capo or main chord symbol is shown
for a selected item by activating the new Show only property in the Chord Symbols
group in the Properties panel and choosing either Capo Chord or Main Chord as
you prefer.
Chord diagrams. If a capo transposition is defined for a particular player and a
fretted instrument tuning is chosen from the Chord Diagrams submenu of the
player’s context menu in the Players panel in Setup mode, the chord diagram
shown for each chord symbol will take the capo into account.
If you have Show chord diagrams used at start of flow activated on the Chord
Symbols and Diagrams page of Layout Options, if you want to show chord diagrams
that take a specific capo transposition into account (because, for example, one of
the instruments in your ensemble has a capo defined), you must provide the
appropriate transposition here too, by setting Use capo with transposition to the
appropriate pitch.
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Fretboard panel. If the selected instrument has a full or partial capo defined, the
Fretboard panel in the lower zone in Write mode will display the capo. For more
information about the Fretboard panel, see On-screen instruments above.

Numbered bar regions
When preparing instrumental parts, it is usually very helpful to number bars of
repeated material to help the performer keep their place through the passage.
Dorico 4 makes this easy with the introduction of numbered bar regions, which
build on the functionality of the existing feature for bar repeat regions. For more
information about bar repeats, please refer to the Operation Manual.
Visibility of numbered bar regions. By default, numbered bar regions appear only in
part layouts, though you can create them in any kind of layout. It is recommended
to create numbered bar regions in part layouts, but if you would prefer to create
them in the full score layout, you will find it useful to activate Show bar count in
numbered bar regions in the Numbered Bar Regions section of the Players page of
Layout Options for the full score layout.
Creating a numbered bar region. To create a numbered bar region, select the bars
that should be numbered, then choose Write ▶ Create Numbered Bar Region, or
type Shift+R to open the repeats popover, and enter numbars (or number bars,
num, or nb) followed by Return to confirm the popover. Be aware that if numbered
bar regions are not set to be visible in the current layout, you will see only the
handles of the region, and even they will disappear once you change the selection.
Numbered bar region highlights. When numbered bars regions are visible, a
translucent blue highlight is shown in the bars contained in the region. To switch
this off, choose View ▶ Highlight Bar Repeat Regions. The same option controls the
display of the highlights for both numbered bar regions and bar repeat regions.
Extended or shortening the region. In Write mode, select any of the bar count
numbers shown in the region to select the whole region and show the circular
handles at the start and end of the range. Drag these handles to change the bars
included in the region. Alternatively, you can use Alt+←/→ to move the entire region
left or right a bar at a time, or Shift+Alt+←/→ to lengthen or shorten the region a bar
at a time.
Bar count. By default, Dorico will number every bar in the bar repeat region, and if
the region is longer than four bars, it will also indicate the total length of the region
by adding the range of the region to the bar count on the first bar: for example, for
an eight-bar region, the first bar will show 1(–8) by default.
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The default bar count frequency can be set using the options in the Numbered Bar
Regions section of the Bar Repeats page of Engraving Options. You can also specify
whether the bar count should be shown in parentheses, whether it should be shown
above or below the staff, and whether Dorico should align the numbers at the same
vertical position across the width of the system, or instead allow individual
numbers to move vertically to conserve vertical space.
Further options are provided for the appearance of the range on the first bar of the
region, and for additionally numbering the final bar in each system and the final bar
in the region if the chosen frequency would not otherwise cause a number to be
shown there.
You can override these defaults using the properties found in the Bar Repeat
Regions section of the Properties panel.
Engrave mode. You can adjust the position of individual bar count numbers in the
region by selecting them and either dragging them with the mouse, nudging them
with the arrow keys while holding Alt, or adjusting the value of the Number offset
property.
Appearance. The bar count is drawn using the Bar Repeat Count font style, which
you can edit in Library ▶ Font Styles. The same font style is shared between
numbered bar regions and bar repeat regions.

SuperVision
Dorico 4 now includes SuperVision, a professional tool suite for monitoring and
analyzing your audio. The plug-in comes with several different modules for level,
spectral, phase, or waveform analysis.
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You can insert SuperVision on any channel in the Mixer, but perhaps the most
useful place to insert it is in the Inserts section for the master stereo output, where
it will allow you to get an overview of the overall sound.
Please refer to the dedicated SuperVision documentation for more information.

VST Amp Rack and VST Bass Amp
Dorico 4 now includes two powerful new plug-ins for shaping guitar sounds. VST
Amp Rack and VST Bass Amp are powerful guitar amp simulators, each offering a
choice of amplifiers and speaker cabinets that can be combined with stomp box
effects.

To use either of these effects, use the Inserts section of the Mixer for the channel on
which you want the effect to appear, and choose either VST Amp Rack or VST Bass
Rack from the menu of effects.
Please refer to the dedicated VST Amp Rack and VST Bass Amp documentation for
more information.

Universal app on macOS
Dorico 4 is now a Universal app, which means that it runs natively on both Intelpowered Macs, and on the latest Apple silicon Macs, such as the M1 MacBook Pro,
iMac and Mac mini. If you have an Apple silicon Mac, Dorico will run as a native
application by default.
VST plug-ins. When running natively on Apple silicon, Dorico can only load VST
plug-ins that can run natively as well: it is not possible for Dorico running natively
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to load VST plug-ins running under Rosetta 2, the technology that allows software
built for Intel-powered Macs to run on Apple silicon Macs.
In addition, there is no support for VST 2 plug-ins on Apple silicon, so when running
natively on Apple silicon, only native VST 3 plug-ins will appear.
If you still rely on one or more VST 2 plug-ins, or if a VST 3 plug-in you rely on is not
yet available in Universal format, you can force Dorico to run under Rosetta, which
will allow VST 2 and Intel-native plug-ins to be loaded, though at the expense of
slower overall performance.
To force Dorico to run under Rosetta:
§

Quit the application if it is running.

§

Locate Dorico 4 in your Applications folder.

§

Select the icon and type Command-I to open the info panel.

§

Activate the Open using Rosetta checkbox.

When you next start Dorico, it will run under Rosetta.

Steinberg Licensing
Dorico 4 is the first product to use the new Steinberg Licensing system, replacing
the eLicenser system that has been used by all previous versions of Dorico, and
indeed by all of Steinberg’s software products.
Steinberg Licensing uses your registered Steinberg ID as the means to identify you
and determine your eligibility to run the software.
Running for the first time. When you run Dorico 4 for the first time, a separate
application called Steinberg Activation Manager will launch. You may be prompted
to sign in, in which case clicking Sign In will open your default web browser.
If you are not currently signed in, you will be prompted to enter your Steinberg ID
email address and password. If your browser is already signed in with your
Steinberg ID, you will not be asked to sign in again.
Once you are signed in, you will be prompted to authorize Steinberg Activation
Manager to use your credentials: depending on your browser, click Allow or Open
(and, if you wish, activate the option to remember this choice in future).
You will then be returned to Steinberg Activation Manager, which should report
that your software has been activated successfully. You can close Steinberg
Activation Manager and use Dorico as normal.
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How activation works. Once your license is activated on a computer, Dorico 4 no
longer needs to contact the Steinberg Licensing server for the purposes of
activation.
You must remain signed in with your Steinberg ID to keep running your software: if
you sign out of Steinberg Activation Manager, your Dorico 4 license will be
deactivated on that computer.
Activating on another computer. With the introduction of Steinberg Licensing, your
single-user Dorico 4 license allows you to use the software on up to three
computers, with the intention that the software is used only by you.
To activate Dorico 4 on another computer, simply install the software on the second
computer as normal. When you run the software, you will be prompted to sign into
Steinberg Activation Manager with your Steinberg ID. Provided you have not
already activated Dorico 4 on three computers, you will be told that activation has
been successful.
If you are told that Dorico 4 has already been activated on the maximum number of
computers, you will need to deactivate the software on one of the computers on
which it is currently activated. To do this, run Steinberg Activation Manager on that
computer, and click the Deactivate button corresponding to your Dorico 4 license.
If you do not currently have access to the computer on which you need to deactivate
your license, you can contact Steinberg support to ask them to deactivate the
license for you.
You can freely deactivate and reactivate Dorico on your computers without limits,
but the software can only be activated on three computers simultaneously.

Remote control support
Dorico 4 introduces a new remote control API that allows richer control from
external applications such as the Elgato Stream Deck or Metasystem’s Metagrid
apps for iOS and Android. This API allows software to connect to Dorico using
WebSockets, then to send commands, update properties, read the state of the
application, and so on.
If you are a software developer who would be interested in finding out more about
Dorico’s remote control API, please contact us.
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Improvements
Accidentals
Respelling accidentals. A good deal of additional flexibility has been added for
managing the spelling of accidentals between different layouts.
By default, when you change the spelling of a note in the full score layout, that
change will be applied to all part layouts in which that note appears; conversely,
when you change the spelling of a note in a part layout, that change is local to the
part and is not reflected in the score.
Dorico 4 introduces powerful new commands that allow you to reset the spelling,
either to the spelling used in the full score or to an automatically determined new
default spelling, or to propagate the spelling in one layout to all other layouts.
Four new commands have been added to the Write ▶ Respell submenu:
§ Propagate Note Spellings applies the spelling of the selected notes in the
current layout and applies it to all layouts where those notes appear; this is
useful if you have respelled notes in a part layout but now want to propagate
those changes to the full score.
§ Reset Note Spellings in Current Layout resets the spelling of the selected notes
in the current layout to the spelling used in the full score layout; this is useful if
you have respelled notes in a part layout but want to return to the default
spelling used in the full score.
§ Reset Note Spellings in All Layouts resets the spelling of the selected notes in all
layouts in which they appear to the spelling used in the full score layout.
§ Respell Notes Automatically allows you to recalculate the spelling of the
selected notes based on an analysis of the musical content. The following dialog
appears:
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The options Additional context at start and Additional context at end allow you to
specify how much of the music either before or after the notes you have selected to
consider when Dorico analyses the music to determine its tonal center.
The two options at the bottom of the dialog – Prefer accidentals used most in this
flow and Preserve accidentals on unchanged pitches – take effect only if your
project uses a tonality system in which multiple accidentals are defined that have
the same effect on the pitch of the note. When respelling notes in such a project,
Dorico can be told to prefer to use the accidental that is most often used throughout
the flow.
Spelling in atonal key signatures. When writing atonal music, it may be preferable to
spell accidentals as simply as possible, without considering what would in tonal
music be the harmonic and intervallic relationships between notes in the same
chord or successive notes. Dorico 4 introduces new options to determine how it
chooses enharmonic spellings when you are writing in an open or atonal key
signature. The following new options are found in the Note Spelling section on the
MIDI Input page of Note Input Options:
§

Note spelling for remote accidentals in atonal key signatures specifies
whether you should Allow remote accidentals, like F flat, B sharp, or any
double or triple accidental, or Disallow remote accidentals, in which case
such remote accidentals will not be chosen.

§

Preferred accidentals in atonal key signature specifies whether Dorico
should try to favour only flats, only sharps, or allow a mixture.

§

Exceptional cases when spelling chords in atonal key signatures specifies
how Dorico should handle the spelling of notes in chords, taking into
account your choices for the preceding two options. For example, if
Preferred accidentals in atonal key signature is set to Flats only, and you
input a dyad of G sharp and B natural, this would spell the G sharp as A flat
and leave the B natural unchanged, producing an interval of an augmented
second. In this situation, choosing Avoid remote spellings would spell the
dyad G sharp and B natural, while choosing Avoid contradiction of
accidental preference would spell the dyad A flat and C natural, in each
case producing a more legible minor third. Dorico will not make any
adjustments for exceptional cases if you choose No exceptions.

§

For notes in atonal key signatures that could be spelled using double or
triple accidentals allows you to specify that, depending on the other choices
made for these options, you may still nevertheless prefer Dorico not to use
double or triple accidentals, even if you have specified that it should, for
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example, prefer sharps. For example, if you input a G#m(maj7) chord,
having set Sharps only and Avoid remote spellings, the root note of the
chord would be spelled as G sharp when Allow double and triple
accidentals is chosen. When Disallow double and triple accidentals is
chosen, however, it will instead spell the chord on an A flat to eliminate the
F double-sharp, even though the alternative still contains a C flat as its third.
These options have no effect when you are writing in any other key signature,
whether it is a minor or major key signature, or a custom key signature.
Independent scale factor. It is now possible to scale accidentals independently of
notes. In Engrave mode, select the notehead to which the accidental belongs, then
activate the new Accidental scale property in the Notes and Rests group in the
Properties panel.
Gaps between accidentals and following notes. Additional control over the gap
between the rightmost flat and an unshortened ledger line when note is in a space
or on a line has been provided, with new options on the Accidentals page of
Engraving Options.
Accidentals for 24-EDO tonality system. In response to user feedback, Dorico now
employs the Stein-Zimmermann accidentals in its default 24-EDO tonality system,
rather than the accidentals with arrows recommended by Elaine Gould in Behind
Bars.

Articulations O
Pasting articulations independently of notes. A new Edit ▶ Paste Special ▶ Paste
Articulations command has been added. Copy a passage of notes to the clipboard,
then select the note from which you want the articulations to be pasted, then
choose the new command; the articulations in the copied passage will be pasted.

Audio export
FLAC support. It is now possible to export audio in FLAC format. FLAC is a lossless
compression format, so unlike MP3 there is no effect on the quality of the sound
itself. FLAC typically compresses by around 50% compared to WAV, but it is not
universally supported by all playback software. When exporting in FLAC format,
you can choose between exporting at 16- or 24-bit depth.
Bit depth. When exporting in WAV format, you can now specify the bit depth of the
exported audio, with a choice between 16-bit, 24-bit or 32-bit.
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Bar numbers
Bar number changes. Bar number changes can omit the primary number, so you can
easily make sequences such as 1, 2, 3, a, b, c, 4, which are sometimes required for
inserts in musical theatre scores.
Position relative to clef at start of system. New options have been added to the Bar
Numbers page of Engraving Options specifying the minimum distance above or
below treble G, treble G with 8 below and tenor C clefs bar numbers at the start of
the system should appear. This allows you to specify a smaller gap above or below
the staff for bar numbers shown at other positions along the system and still have
bar numbers avoid clefs at the start of the system.
Ranges of bar numbers on multi-bar rests. When Show ranges of bar numbers
under multi-bar rests and consolidated bar repeats is activated on the Bar
Numbers page of Layout Options, Dorico will now only show those bar number
ranges on the staves on which bar numbers would normally appear, rather than on
every staff on which the multi-bar rest appears.
Local versus global bar numbers. When Dorico draws bar numbers, it uses the bar
numbers calculated for the staff on which the bar numbers are drawn. This can be
useful in polymetric music where the bar numbering may vary between
instruments, but in cases where local time signatures have only been used to do
things like change default beam grouping for a passage, it can be less helpful.
A new Bar Numbers page has been added to Notation Options, with the new option
Bar number calculations, allowing you to choose whether the bar number
calculations for each flow should Use global bar count or Use local bar count.

Bar repeats
Numbering the final bar of a bar repeat region. A new option Appearance of bar
repeat count for the last bar in the region has been added to the Bar Repeats page
of Engraving Options, allowing you to specify that the last bar in a bar repeat region
should always be numbered, even if it would not normally be numbered according
to the chosen interval for bar numbering in the region.

Beaming
Centered beams. A centered beam, sometimes called a “kneed beam”, describes a
beam that is positioned between notes on the same staff, both above and below the
beam. By default, Dorico will only show a centered beam if the natural stem
directions of the notes in the beamed group specify that both up- and down-stems
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would be required if the notes were unbeamed; in practice, this means that only
beam groups that straddle the middle staff line can show centered beams.
To provide additional flexibility for centered beams, you can now select the notes in
a beamed group and choose Edit ▶ Notations ▶ Stem ▶ Custom Centered Beam,
which will show a simple dialog in which you can specify the desired stem direction
for each note. When you confirm the dialog, if the combination of stem directions
you have chosen should give rise to a centered beam, one will be created.
Notes on the middle line of the staff. When notes on the middle line of the staff are
given a default direction instead of a contextual direction (because Stem direction
for notes on the middle line of the staff is set to Use default direction), such notes
can govern the overall stem direction for a beamed group, which is sometimes
undesirable. A new option, Notes on the middle line of the staff in beamed
groups, has been added to the Stems section of the Notes page of Engraving
Options, allowing you to change this behavior: choose Ignore for stem direction,
and only the notes either side of the middle line of the staff will govern the overall
stem direction for the group.
Stem direction calculation for beamed groups. By default, Dorico considers the
number of notes or chords above or below the middle of the staff when determining
the stem direction for a beamed group of notes, and uses the note furthest from the
middle of the staff in the event of an equal number of notes above and below the
middle of the staff. If you prefer to consider only the note furthest from the middle
of the staff, you can now set the new Stem direction for beamed groups option in
the Stems section of the Notes page of Engraving Options to Consider only furthest
note from middle of staff.
Beam thickness. It is now possible to override the thickness of and separation
between beam lines in Engrave mode, using new Thickness and Separation
properties in the Beaming group in Properties.

Breaks
Moving bars between systems. A pair of new commands have been added that make
it quick and easy to change the casting-off of your music. In Engrave mode, you can
select a note or indeed any item in a bar, and then use either Engrave ▶ Format
Systems ▶ Move Bar to Previous System or Move Bar to Next System to move that
bar to the previous or next system, leaving all other systems in the layout
untouched. These menu items have the default key commands , (comma) and .
(period or full stop) for quick access.
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When you move a bar to the previous or next system, Dorico creates appropriate
breaks to ensure that the right bars are on each system. For example, if you have
two systems, the first with four bars and the second with three, and you decide that
the first system would look better with only three bars, you can select any item in
the last bar of the first system and type . to move that bar to the next system. Dorico
ensures there is a break at the start of the first system, then creates a new system
break at the start of the bar in which you made your selection, so that bar becomes
the first bar of the second system. It sets the Wait for next system break property
on the original first system to ensure that the first system keeps the three bars it
already had. By default, Dorico does not force the layout of the second system;
instead it simply ensures that it begins with the bar that you moved from the first
system.
If you have previously used Finale, these commands will be familiar to you. If you
have not used Finale, you may be finding the purpose of these commands a little
abstract. Rest assured that they are much easier to understand by experimentation
than by reading about them: open an existing project, switch to Engrave mode,
select something and type , or . to see for yourself what happens.
In Finale, however, the equivalent commands work a little differently: to continue
the example described above, Finale would force the contents of the second system
so that even after adding one or more bars from the first system, all of the bars that
were previously on the second system should remain there, which could make it
more cramped. If you would like Dorico to behave exactly like Finale in this regard,
you can do so: activate Lock source and destination systems when moving bars to
previous or next system on the Note Input and Editing page of Preferences. When
this option is enabled, Dorico will create a further system break at the end of the
second system, and set the Wait for next system break property on the new break
at the start of the second system, effectively locking the contents of both the first
and second systems.
Break locations. A new option, Snap system and frame breaks to barlines when
creating, has been added to the Note Input and Editing page of Preferences. This
option is switched on by default.
You can create a system or frame break at any rhythmic position, including in the
middle of a bar, but by default breaks will snap to barlines. When creating a single
system or frame break, the break will be created at the start of the bar in which the
earliest item is selected. When using Make Into System or Make Into Frame, the
first break will be created at the start of the bar in which the earliest item is
selected, and the second break will be created at the end of the bar in which the
latest item is selected.
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This makes it much quicker to create breaks and perform casting off in your
layouts, because you no longer need to worry about making a selection at a precise
rhythmic position before you create a break.
Retaining properties on breaks. Dorico now always maintains Wait for next
system/frame break properties, staff size overrides and hide empty staves
overrides for breaks at the same positions as new breaks being created as part of
Make Into System/Frame or Lock System/Frame operations. This prevents
unexpected changes in casting off if you return to the same passage to perform
more formatting.
Lock and Reset Layout. It is now possible to lock the formatting of the current layout,
inserting suitable system and frame breaks on every page, by choosing Engrave ▶
Format Music Frames ▶ Lock Layout. This is equivalent to selecting an item in each
frame in turn and clicking Lock Frame, but you do not have to select anything in
advance.
The converse operation is also now available: to remove all system formatting from
your layout by deleting all system and frame breaks, choose Engrave ▶ Format
Music Frames ▶ Reset Layout.

Chord diagrams
Fingering numbers. It is now possible to show fingerings on chord diagrams, either
as numbers within the dots, or at the ends of the strings. To show fingerings,
activate Show fingerings in chord diagrams on the Chord Symbols and Diagrams
page of Layout Options. Use Fingerings position to choose between showing the
fingerings Inside dot or At end of string.
Dorico will show default fingerings for all the chord shapes in the factory library,
but you can edit them if you choose, either for an individual chord diagram by
double-clicking it in Engrave mode, or for the whole project via Library ▶ Chord
Diagrams. Fingerings will only appear in the chord diagram editor if they are shown
in the current layout, so be sure to activate Show fingerings in chord diagrams
before you try to edit them.
To edit a fingering, double-click it in the Edit Chord Diagram dialog, then type the
finger number. If you type a finger number that is already used on another string,
Dorico will attempt to reallocate the other strings sensibly. If, however, you need to
reset to the default fingering, choose Edit ▶ Notations ▶ Chord Symbols and
Diagrams ▶ Reset Chord Diagram Finger Numbering.
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Chord symbols
Creating chord symbols from selected notes. Dorico can now create chord symbols
based on the harmonies described by a selection of notes. First, select the music
from which you would like to generate chord symbols, which can be any size of
selection from a single chord on a single instrument to an extended passage of
music spanning multiple instruments. Once you have made your selection, choose
Edit ▶ Notations ▶ Chord Symbols and Diagrams ▶ Generate Chord Symbols From
Selection. The following dialog appears:

§

Harmonic rhythm specifies the interval at which Dorico should create new
chord symbols, examining the selected music chunk by chunk. Dorico
automatically chooses a useful value for this option based on the music you
have selected.

§

Minimum duration of single notes following chords to include in analysis
allows you to exclude passing notes from the analysis. Set this option to the
shortest note value you typically want to be considered as part of the
analysis; any shorter note values will be ignored.

§

Minimum duration of chords eligible for chord symbols similarly allows
you to exclude transitory chords from the analysis. Set this to the shortest
note value you typically want to be considered as a distinct chord; any
chords with shorter note values will be ignored.
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§

Only use downbeats when creating chord symbols from notes at
multiple positions considers the metrical structure of the bars containing
the selected music, and if switched on, it will only consider the notes that
start on strong beats in its analysis.

§

Detect inversions specifies whether Dorico should consider inversions
when analyzing the music; you may want to set this to Never when selecting
music from multiple instruments. When you are working with music from a
single instrument, you may want to either Always consider inversions, or
help Dorico to identify the bass notes in the chord by specifying a specific
pitch below which it should consider notes as describing inversions.

§

Only create chord symbols from horizontal passages when unambiguous
is switched off by default; if you switch it on, it will limit Dorico to looking for
simpler chord symbols, particularly when notes at different rhythmic
positions are considered together as forming a single chord.

§

Try to detect and handle passing notes enables heuristics that try to
determine which notes in the selection are passing notes and therefore not
critical to the analysis of the prevailing harmony.

§

Use vamp detection enables heuristics that try to identify rhythmic
patterns and textures often used when vamping, which are then taken into
consideration during the analysis. The two following options, Minimum
length for chords in vamp and Maximum rhythmic separation between
chords in vamp, can be adjusted based on the specific rhythmic patterns
used in the selection to help guide Dorico’s vamp detection.

§

Allow creation of open fifths determines whether Dorico will detect open
fifths (i.e. dyads a fifth apart, with no kind of third between them).

§

Allow creation of major and minor thirds determines whether Dorico will
allow dyads that have no fifth or higher scale degrees to be interpreted as
major or minor triads for the purposes of analysis.

§

Ignore omitted fifths determines how Dorico should handle chords that
would typically include a fifth, but in which the fifth is omitted.

Once you are satisfied with the options, click OK and Dorico will create chord
symbols in the selected passage. All instruments from which music was selected
will show chord symbols.
Parenthesizing chord symbols. It is now possible to enclose a chord symbol in
parentheses by activating the new Parenthesized property in the Chord Symbols
group in the Properties panel. When inputting a chord symbol via the Shift+Q
popover, you can also surround the chord symbol with parentheses, e.g. (Cm7), and
the resulting chord symbol will be parenthesized.
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If you want to indicate that a sequence of chord symbols is optional or an
alternative set of changes, you can show only the opening (left) parenthesis for one
chord symbol, and then the closing (right) parenthesis for another chord symbol,
using the new Parenthesis to show property.
Depending on the size and shape of the chord symbol, you may want to change the
type of parenthesis used; different parenthesis characters are provided that are
used for chord symbols of different heights, and you can choose between these by
activating the new Parenthesis style property. Further fine-tuning of the size of the
parenthesis can be achieved by altering the Parenthesis scale property.
If a chord symbol already includes parentheses, for example surrounding
alterations, then surrounding the entire chord symbol with a larger set of
parentheses can appear fussy or cluttered; as such, a new Suppress parentheses
around alterations option has been added to the new Parentheses section of the
Chord Symbols page of Engraving Options. This allows you to choose whether the
parentheses around alterations in chord symbols should appear, and under what
circumstances.
The Parentheses section of the Chord Symbols page of Engraving Options also
includes options for the gap between the parentheses and the chord symbol, and
the scale factor for parentheses; by default, the parentheses are scaled slightly large
relative to the chord symbols themselves, so that they extend a little way above and
below the chord symbol, making them more conspicuous.
Placement. A new option, Position of chord symbols relative to single staff
instruments, has been added to the Position section of the Chord Symbols page of
Engraving Options. This option allows you to specify whether chord symbols should
appear above the staff (the default), or below the staff.
You can also change the placement of an individual chord symbol by activating the
new Placement property in the Chord Symbols group in the Properties panel.
Erase background. When chord symbols are shown between the two staves of a
grand staff instrument, or otherwise above a staff that is joined to the staff above by
a barline, it may not always be possible to avoid the chord symbol colliding with a
barline. A new Erase background property has been added to the Chord Symbols
group in Properties; when activated, barlines and staff lines will be covered. The
padding for the erasure is determined by a new option in the Design section of the
Chord Symbols page of Engraving Options.
Chord symbol visibility regions. It is now possible to create a chord symbol visibility
region by typing reg into the Shift+Q popover.
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Showing either chord symbols or diagrams. A new Show only property has been
added to the Chord Symbols group of the Properties panel, allowing you to specify
that either the chord symbol or chord diagram component should be hidden.
Chord symbols with altered bass notes. You can now override the default
arrangement for altered bass notes, as specified in the Altered Bass Notes section
of the Chord Symbols page of Engraving Options, by activating the new Compound
chord arrangement property in the Chord Symbols group of the Properties panel.
Disabling MIDI input for chord symbols. If you do not ever want to input chord
symbols using your MIDI keyboard, you can set the new Chord symbol input via
MIDI keyboard option on the MIDI Input page of Note Input Options to Disallow
MIDI input.
Clearing played pitches. When you input chord symbols using your MIDI keyboard,
Dorico remembers the voicing you used for the chord, and that voicing will be
reproduced when you subsequently play back the chord symbols via the Chords
track in Play mode. If you later decide that you would like to restore the default
voicing for a chord symbol, select it and choose Edit ▶ Notations ▶ Chord Symbols
and Diagrams ▶ Clear Chord Symbol Played Pitches.
Chord symbol region highlights. When View ▶ Highlight Chord Symbol Regions is
switched off, Dorico now also hides the purple bar drawn for making it possible to
select chord symbol regions.
Flat 10 alteration. It is now possible to create a ♭10 alteration: simply type b10 into
the Shift+Q popover. You may need to enclose it in parentheses, e.g. C(b10).

Clefs
Lead sheet style. A new option Clefs at start of systems following first system has
been added to the Clefs page in Notation Options, allowing you to hide clefs on
systems following the first. This is a convention sometimes followed in hand-copied
lead sheets, and a corresponding option has been added for key signatures.
Octave shifts. It is now possible to specify an octave shift for the clef to be created in
the Shift+C popover: for example, typing g+2 will create a treble G clef with an
Octave shift value of 2, or f-1 will create a bass F clef with an Octave shift value of -1.

Comments
Comments from all flows. The Comments panel in the right zone in Write mode now
shows comments from all flows assigned to the current layout, rather than only the
current flow, as in previous versions.
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Condensing O
Tempo signposts. Signposts for hidden tempo items above condensed staves can
now be selected in Write mode.

Cues O
Fermatas. It is now possible to specify whether fermatas should be included in cues,
both via a new option on the Cues page of Engraving Options, and on a per-cue
basis via the new Show fermatas property in the Cues group in the Properties
panel.
Cues on unpitched percussion. It is now possible to create a rhythmic cue from a
pitched instrument on an unpitched percussion instrument or kit.
Popover input. It is no longer necessary to hit Return twice to confirm input of the
Shift+U popover.
Cues at instrument changes. A new option Show instrument change label after
cue, if cue precedes first note in new instrument has been added to the Players
page of Layout Options allowing you to specify that when an instrument change
occurs at the same point as a cue, the label showing where the new instrument
starts playing should be positioned at the end of the cue, rather than at the start.
The new option is disabled in existing projects by default to avoid changing their
appearance unexpectedly, but enabled in new projects.

Dynamics
Dynamics in tight spacing. The behavior of dynamics in tight situations – either
when note spacing is very narrow, or when wide dynamics are covering short
rhythmic durations – has been improved.
The way Dorico allocates additional space for gradual dynamics has been improved,
and the way messa di voce hairpins are handled has been overhauled: if a messa di
voce hairpin needs to be shortened to accommodate an immediate dynamic or
barline at either end, the amount to be shortened is now distributed over both
segments of the hairpin, rather than only the second, which looks much better.
In the specific case that a messa di voce hairpin is written over a single note or
chord, and ends at a barline position, Dorico will now evenly distribute the two
segments of the hairpin to improve its appearance. Options to control this new
behavior can be found in the Advanced Options section of the Gradual Dynamics
section of the Dynamics page in Engraving Options.
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Engrave mode
Crosshairs. Most items that are positioned outside the staff now show a pair of
crosshairs in Engrave mode when they are selected and when they are dragged
with the mouse. Although the implementation is very simple – there are no rulers,
and no snapping of items as they are dragged – the crosshairs are nevertheless
helpful when positioning items manually in Engrave mode, allowing you to see the
horizontal and vertical alignment of items immediately.
The following types of items show crosshairs when selected or dragged in Engrave
mode:
§

Immediate and gradual dynamics

§

Staff- and system-attached text

§

Octave lines

§

Slurs

§

Guitar bends

§

Immediate and gradual tempo changes

§

Playing techniques

§

Rehearsal marks

§

Lyrics

§

Ornaments and trills

§

Pauses

§

Pedal lines

§

Arpeggio lines

§

Chord symbols

§

Repeat endings

§

Percussion legends

§

Repeat markers

§

Harp pedal changes

§

Horizontal and vertical lines

§

Figured bass

If you would prefer not to see crosshairs in Engrave mode, you can deactivate Show
When Selected or Show When Dragging in the new Engrave ▶ Crosshairs
submenu.
Switching to Engrave mode. By default, Dorico remembers which of the tools in the
toolbox was last active when you return to Engrave mode, but you might find it
helpful to always have the graphical editing tool active when you return to Engrave
mode. If so, activate the new option When switching to Engrave mode, activate the
Graphical Editing tool in the Window section of the General page of Preferences.
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Nudging frames and handles. You can now use all of the combinations of modifiers
with the arrow keys used for nudging in graphical editing mode when nudging
selected frames, vertical spacing handles, and note spacing handles to nudge by
different amounts.

Figured bass
Bracketing. Dorico 4 introduces comprehensive support for adding parentheses or
square brackets to figured bass in your score. Whole stacks of figures, individual
figures, or even individual accidentals can all be flexibly bracketed.
To specify brackets when inputting figures using the Shift+G popover, simply type
parentheses around the figures, figure or accidental that you want to be bracketed.
For example, typing (#643) will bracket the entire stack of figures; typing #6(4)3 will
bracket only the figure 4; and typing (#)643 will bracket only the sharp accidental to
the left of the figure 6.
You may want to show an opening bracket on one stack of figures, and then a
closing bracket on a later stack of figures, for example to denote that a passage of
figures has been added by the editor or could be played optionally. In this case,
bracket both stacks of figures as normal, then in Engrave mode, activate the Hide
single bracket property in the Figured Bass section of the Properties panel, then
specify whether it is the Start or End bracket that should be hidden.
By default, Dorico uses square brackets, but you can use round brackets (or
parentheses) instead: set Bracket style to Round brackets in the Design section of
the Figured Bass page of Engraving Options. In this section you will also find a
comprehensive set of options for the design, size and positioning of the brackets.
Tasto solo. It is now possible to add a tasto solo indication, telling the continuo
player that the following passage should be played without harmony, using the
Shift+G popover: simply enter tasto or ts into the popover. The wording and case of
the tasto solo indication is controlled by the new Tasto solo appearance option in
the Design section of the Figured Bass page of Engraving Options. To change the
font or size of the indication, edit the new Figured bass tasto solo paragraph style
in Library ▶ Paragraph Styles.
MusicXML import. When importing figured bass from MusicXML files, you can
activate the new Figured bass appearance option on the MusicXML Import page of
Preferences if you want to retain the precise appearances of figured bass as stated
in the MusicXML file. By default, Dorico will use the default appearance options as
specified in Engraving Options and default interpretation options as specified in
Note Input Options to determine how the figured should be imported.
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MusicXML export. Figured bass is now included when exporting MusicXML.

Filters
Quick filters. New quick filters for Repeat Markers and Repeat Endings have been
added to the Edit ▶ Filter submenu.

Fingering
Fingering shifts. It is now possible to specify fingering shifts directly in the Shift+F
popover by appending / after the finger number; for example, 3/.

Grace notes
Converting to and from rhythmic notes. It is now possible to convert the selected
notes to and from grace notes by clicking the grace note button in the Notes toolbox
when the caret is not visible. This is particularly useful when editing music that was
input using real-time recording, or was automatically transcribed from a MIDI file.
To convert one or more selected rhythmic notes into grace notes, simply type the
key command / or click the grace note button in the Notes toolbox. To choose
between slashed (acciaccatura) or unslashed (appoggiatura) grace notes, press and
hold, or right-click, the grace note button to open a pop-up menu from which you
can make the choice between the two types.
When converting rhythmic notes into grace notes, by default Dorico snaps slashed
grace notes rightwards, so that they abut the next rhythmic position, and snaps
unslashed grace notes leftwards, so that they precede the rhythmic position at
which the first selected rhythmic note was previously located. If you want to change
this behavior, you can adjust Direction of rhythmic movement when converting to
grace notes on the Note Input and Editing page of Preferences.
To convert one or more selected grace notes into rhythmic notes, the procedure is
the same: simply type / or click the grace note button in the Notes toolbox. The new
rhythmic notes will begin at the primary rhythmic position the grace notes
formerly preceded, overwriting the following notes. If you want to prevent the grace
notes from overwriting the following notes, ensure Insert mode is active before you
convert them.

Harp pedaling
Scale and color. Harp pedal change items now respond to the Scale, Custom scale
and Color properties in the Common group in the Properties panel.
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Hub
The Hub window has been redesigned for Dorico 4. It is now split into three pages,
Open Recent, Create New, and Learn.
Open Recent page. Recently opened projects are listed in the reverse order in which
you last opened them. Projects saved in Dorico 4 or Dorico for iPad show a
thumbnail of the first page of the last layout that was shown when the project was
open; projects last saved in an earlier version of Dorico, or files in other formats
(such as MIDI or MusicXML) will not show a thumbnail. Click the menu button in the
top right-hand corner of each project card to open a contextual menu from which
you can choose to remove the project from the Hub or open the folder where the
project is located.
Create New page. Template categories are listed on the left, and choosing one shows
the templates in that category in the grid in the middle of the page. New options on
the right-hand side allow you to make some initial choices about your project,
including specifying the title, composer, music and text fonts, starting key and time
signature, and (if specifying a time signature) an initial number of bars. Project will
use multiple flows determines whether flow headings should be shown by default.
All these initial decisions can of course be changed later.
Learn page. In addition to showing the latest videos from the Dorico YouTube
channel and the latest posts from the Dorico blog, the Learn page also includes a set
of hands-on tutorials that are designed to introduce important note input and
editing concepts to new users.

Instrument changes
Instrument change labels. If the Instrument change paragraph style is set to use a
border, instrument change labels are now shown with a border.

Instrument types
Sketch instruments. A new Sketch family of instruments has been added, containing
generic treble, bass and grand staff instruments, and grand staff instruments for
woodwind, brass and strings.
These can be useful when importing MIDI data from your DAW or sequencer if the
original project uses sectional sounds on a single track, since a grand staff sketch
instrument is easier to read than a single staff with notes on many ledger lines
either above or below.
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They can also be useful when building up an arrangement from scratch in Dorico,
using a section sound while experimenting with texture, before splitting the music
out onto individual instruments in the family.

Key signatures
Lead sheet style. A new option Key signatures at start of systems following first
system has been added to a new Key Signatures page in Notation Options, allowing
you to hide key signatures on systems following the first. This is a convention
sometimes followed in hand-copied lead sheets, and a corresponding option has
been added for clefs.
Filter for accidentals. The Edit Tonality System dialog now contains a field into
which you can type to filter accidentals, helpful in tonality systems with many
accidentals defined.

Layouts
Duplicate Layout. It is now possible to duplicate an existing layout in your project,
making an exact copy that retains all the edits you have made, including
adjustments to Layout Options, page templates, flow headings, properties, clef and
transposition overrides, vertical spacing adjustments, note spacing adjustments,
lyric vertical position adjustments, custom staff sizes, graphics frames, and so on.
To duplicate a layout, select it in the Layouts panel in Setup mode, then either rightclick and choose Duplicate Layout from the context menu, or choose Setup ▶
Duplicate Layout.
Propagate Part Formatting. The layout options related to page numbers are now
propagated to part layouts when using Propagate Part Formatting.
Sorting layouts. It is now possible to sort layouts either according to their layout
number (which can be edited by expanding each layout’s card) or by following the
instrument score order. Click and hold, or right-click, the Sort Layouts button in the
action bar at the bottom of the Layouts panel in Setup mode to choose whether to
sort by Layout Number or Instrument Score Order.
Counterpart Layout. Window ▶ Counterpart Layout now works correctly with a rest
selected, as well as with a note or other type of item. Relatedly, it is now possible to
use Window ▶ Counterpart Layout to switch back from a part layout to the full
score layout with nothing selected. (The converse is not possible, as without any
selection, Dorico cannot determine which part layout to switch to.)
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Lyrics
Lyric hyphens at the start of the system. When a word is split into multiple syllables
across a system break, with a new syllable on the note at the start of the new
system, some publishers will show a hyphen both at the end of the preceding
system and at the start of the new one, while others will show a hyphen only at the
end of the preceding system. This latter convention is now possible to achieve in
Dorico by setting the new Lyric hyphens before the first note of the system option
on the Lyrics page of Engraving Options to Do not show.
Retain properties when edited. When editing existing lyrics, any properties set on
those lyrics are now preserved.
Nudging lyric lines. It is now possible to adjust lyric baselines by a tiny amount in
Engrave mode using Ctrl+Shift+Alt+↑/↓.

Multi-bar rests
Hidden time signatures. Hidden time signatures no longer cause multi-bar rests to
be split.
Horizontal position of H-bars. Additional control over the width and position of Hbar symbols used for multi-bar rests has been added.
Two new options, Items before barline at the end of multi-bar rest and Items
after barline at the start of multi-bar rest, have been added to the Rests page of
Engraving Options, allowing you to specify whether items that appear to the left
(such as clefs) or right (such as time and key signatures) of barlines should be
considered when determining the position of H-bars. By default, both options are
set to Consider width of items, but if you would prefer H-bars to always be
centered between barlines regardless of the widths of any intruding items, choose
Ignore width of items.
Furthermore, you can also now adjust the horizontal position of a selected H-bar
using the new H-bar X offset property in the Multi-bar Rests group in the
Properties panel.

Music fonts
Music symbol substitution. When using a music font other than Bravura, any
symbols that are required by the music but not provided by the chosen font will now
automatically be drawn using Bravura. If you want to specify a different fallback
music font, you can do so by adding a font to the new Substitutions list for the
relevant font style in Library ▶ Music Fonts.
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User interface improvements. The list of fonts in Library ▶ Music Fonts is now sorted
alphabetically. It is now possible to confirm the choice in the Music Fonts dialog by
double-clicking an entry in the list.

MusicXML export
Partial beams. Partial beams are now correctly exported to MusicXML.

MusicXML import
Clefs. The “none” clef type in MusicXML files is now interpreted as a treble G clef, as
recommended.
Tablature import. When importing MusicXML files containing staff notation and
tablature written as separate parts, Dorico will try to determine whether the two
parts are separate representations of the same music and should be interpreted as
a single instrument showing both staff notation and tablature. You can control
whether and how Dorico does this by changing the new When notation and
tablature are both encoded as separate parts option in the Advanced Options
section at the bottom of the MusicXML Import page of Preferences.

Notation Options
Note grouping in irregular meter. New When splitting notes at beat subdivisions
option in the Time signatures with irregular meter section of the Note Grouping
page of Notation Options, allowing you to specify whether Dorico should split notes
at all subdivisions or only at subdivisions of different length.

Note input
Notes toolbox. The Notes toolbox in the left zone in Write mode includes several
new buttons. Several buttons – including those for Insert mode, adding or cycling
through voices, specifying rhythm dots, grace notes, and tuplets – now show a
menu if you click and hold the button for a moment.
Start Note Input. Click this to show or hide the caret; equivalent to typing Shift+N. If
there is no selection, Dorico will show the caret at the start of the bar closest to the
top left corner of the current view.
Insert for current voice. Equivalent to having Insert mode active in earlier versions
of Dorico: adds or removes time from the selected voice, or the voice set in the
caret. This button can be held down to show a menu allowing you to choose a
different Insert mode scope.
Insert for current instrument. Adds or removes time from all voices in the selected
instrument, and also includes items that are not in a particular voice but are
instead attached to the staff, such as dynamics and lyrics.
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Insert for all instruments. Adds or removes time from all instruments in the
ensemble. This shifts music forwards and backwards while retaining the existing
time signatures.
Insert for all instruments and extend current bar. Adds or removes time from all
instruments in the ensemble, but also increases or decreases the duration of the
current bar.
Add new voice. Primes the caret to start inputting in a new voice; equivalent to
typing Shift+V. This button can be held down to show a menu allowing you to
choose between adding a new slash voice, or cycling between the currently active
voices (equivalent to typing V on its own, without Shift).

The changes to the Notes toolbox are intended to make more of Dorico’s note input
tools more readily available using the mouse.
Notations toolbox. The Notations toolbox in the right zone in Write mode has been
revamped, and it now contains a pair of buttons at the top of the toolbox that allow
you to switch between showing panels and opening popovers:
Panels
Popovers

When Panels is active, clicking a button will show or hide the relevant panel in the
right zone; when Popovers is active, clicking a button will open the relevant
popover. The buttons shown in the toolbox differ, since not all panels have an
equivalent popover, and vice versa.
Starting note input. You can now start note input and real-time recording without
first making a selection: choosing Write ▶ Note Input (shortcut Shift+N) or Play ▶
Record (shortcut Ctrl+R on Windows, Command-R on Mac) will now show the caret
on or start recording in the first visible bar in the first visible staff in the current
view.
Changing the voice of existing notes. It has always been possible to change the voice
of existing notes using the commands in the Edit ▶ Notations ▶ Voices submenu,
but Dorico 4 introduces an additional, very natural method to do this, using the
same key commands that are used during step-time input: V to cycle between the
voices already present on the staff, or Shift+V to move the notes to a new voice.

Note spacing
Minimum gap after rhythm dot. A new Gap after last rhythm dot option has been
added to the Rhythm Dots section of the Notes page of Engraving Options, which
defines the amount of space Dorico should enforce following the rightmost column
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of rhythm dots, so that in tightly-spaced music it is no longer possible for the
leftmost note at the next rhythmic position to appear closer to the rhythm dot to its
left than that rhythm dot appears to the note to its left to which it actually belongs.
In existing projects, this option has a value of 0 spaces, to avoid changing the
appearance of those projects; the default in new projects is half a space.

Percussion
Rests. It is now possible to edit rests in music written for percussion kits when
displayed using the five-line staff and grid presentation types. As far as is possible,
rests now behave the same way in percussion kits as they do in pitched
instruments. It is possible to change the vertical position of rests in the staff using
the Rest pos. property, it is possible to hide them using Edit ▶ Remove Rests, and
you can also manually hide and show them using the Starts voice and Ends voice
properties.
Be aware that if you save a project in Dorico 4 that makes use of these new
capabilities for editing rests, those edits will not be predictably preserved if the
project is opened in Dorico 3.5 or an earlier version.
Inputting tuplets. The handling of tuplets during note input onto percussion kits has
been thoroughly overhauled, and now feels much more natural. Whenever you
create a tuplet in an unpitched percussion kit, the tuplet is added to all of the kit
components that share the same notated voice in the kit presentation type, so that
any notes you subsequently add to other instruments in the kit in the range of the
tuplet will be correctly notated.
Removing instruments from kits. A new command, Remove All Instruments From
Kit, has been added to the instrument context menu, accessed from an expanded
player card. This command removes all instruments from the kit, leaving the kit
empty, and showing each instrument that was previously included in the kit as an
individual instrument assigned to the player.

Playback
Project activation. When working with multiple projects at the same time, only one
project can be active for playback. In previous versions, Dorico has always activated
a project when one of its windows becomes active, and depending on the playback
template in use, you may experience a delay of multiple seconds (or longer, in the
case of very large and complex playback templates) before you can work in the
newly activated project.
In Dorico 4, however, the default behavior is now different: the first project you
open is automatically activated for playback, as before, but if you open a second
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project without closing the first, a dialog will appear asking you whether you want
to activate this project, deactivating the first.
If you choose not to activate the new project, then you will not be able to play back in
that project until you manually activate it by clicking the

button on the toolbar.

On the Play page of Preferences, you will find two new options that control the
project activation behavior when opening projects.
Transport window. The Transport window has been redesigned to share the same
look and feel as the mini Transport in the toolbar.

The Transport window now includes the Activate Project button, and it is now
possible to change the tempo value in fixed tempo mode in the Transport window
(previously this was only possible using the mini Transport in the toolbar).
Viewing items suppressed in playback. A new option, View ▶ Note and Rest Colors ▶
Suppressed Playback, has been added, which when activated causes any items that
have been muted by way of the Suppress playback property to be shown in gray, so
that they are easier to spot. This option is switched on by default.
Rhythmic feel. Notes that have manual offsets applied to their duration (in other
words, affecting their end position) can now have swing rhythmic feels applied, if
appropriate.
Metronome click. The default metronome click in new projects is now Click, rather
than Beep. You can change this on the Click page of Playback Options.
Ghost notes. A new option Bracketed noteheads (ghost notes) for unpitched
percussion has been added to the Dynamics page of Playback Options. This allows
you to specify the amount of reduction in dynamic level that arises from a ghost
note. This can also be overridden in the Playback Options Overrides section of the
Expression Maps dialog if needed. The reduction is expressed in terms of steps in
dynamic level; 1.0 is the difference between, say, and .
Repeats playback. If Dorico detects during project loading that the repeat structure
is malformed and will lead to infinite repeats, it automatically switches off the Play
repeats option on the Repeats page of Playback Options.
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Play button behavior. A new preference has been added to the Play page of
Preferences that determines whether the Play button in the mini transport on the
toolbar plays from the playhead position (the default behavior) or from the
selection.

Playback templates
Moving projects between iPad and Mac or Windows. If you edit the same project in
Dorico for iPad and in Dorico 4 for Mac or Windows, the playback configuration for
each platform will now be preserved, so that changes you make to sounds and
effects on one platform will not cause the saved configuration for the other
platform to be lost.
Warning about missing playback templates. The warning that appears when
opening a project that uses a playback template that is not present on your
computer can now be suppressed so it no longer appears.

Playing techniques
Pedal lines. All the commands in the Edit ▶ Notations ▶ Pedal Lines submenu that
make sense to be able to operate at multiple rhythmic positions within the span of a
pedal line – such as adding or removing retakes, or changing to a different pedal
level – now take effect at all selected rhythmic positions if multiple notes are
selected within the length of the pedal line. If the caret is visible, then the edit will
take effect at the location of the caret instead.
Popover input. It is no longer necessary to hit Return twice to confirm input of the
Shift+P popover. Furthermore, when creating a playing technique with an existing
playing technique selected (for example, by hitting Return and editing it in the
popover), the original playing technique is now replaced, rather than a new playing
technique appearing in addition to the original one.
Hiding empty staves. Hidden playing techniques no longer cause staves that would
otherwise be allowed to be hidden as empty staves to appear.

Print mode
Transposition warning. When determining whether you should be warned that the
part layout about to be printed is in concert rather than transposing pitch, Dorico
now considers whether the layout contains any transposing instruments, and will
only show the warning in the event that it does (so, for example, a part layout
containing a piano set to concert pitch will no longer trigger the warning to appear).
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Slurs
Collision avoidance. The property formerly called Disable auto curve adjustment is
now called Avoid collisions, and can be set to force Dorico to adjust the curve of the
slur to avoid collisions with items under its arc as well as to disable collision
avoidance.

Staff labels
Player group labels. Dorico can now display labels in the left margin corresponding
to player groups as defined in the Players panel in Setup mode. For example, you
may wish to identify two separate mixed voice choirs as “Choir 1” and “Choir 2” in
your ensemble, or identify an off-stage group of performers, or perhaps identify
groups that can play the same music in a piece written for a flexible ensemble.
Player group labels are rotated through 90 degrees, and are written vertically up the
page, positioned to the left of staff labels for individual instruments.
In new projects created in Dorico 4, player group labels will appear by default as
soon as you create a player group in the Players panel, but in existing projects they
do not appear by default to avoid changing the appearance of those projects. To
show player group labels in your layout, activate the new Show player group
names option in the Staff Labels section of the Staves and Systems page of Layout
Options.
To control the font, style and size of player group labels, you can edit the new Player
Group Labels paragraph style in Library ▶ Paragraph Styles. By default, player
group labels are drawn centered on a vertical bracket that spans the staves
belonging to the instruments included in the group; if you prefer not to show a
bracket, or to show the group label inside the bracket rather than centered on the
bracket, you can adjust the options in the new Player Group Labels section of the
Staff Labels page of Engraving Options.
If there is insufficient room to show the full group name, Dorico will show the
group’s short name instead. To edit the full and short names for a player group,
select the group (rather than any of the players contained within) in the Players
panel in Setup mode, right-click, and choose Rename Player Group from the
context menu.
Using player names as staff labels. It is sometimes required that the staff label in the
margin should reflect the player’s name and number, rather than the names and
numbers of the instruments held by that player; for example, in the case of
percussionists with multiple instruments, it may be preferable for the staff label to
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appear simply as “Percussion 2” rather than listing all of the instruments played by
that player.
To accommodate this, a new section, Show player name instead of instrument
names, has been added to the Staves and Systems page of Layout Options, allowing
you to specify which players in the layout should use their name as their staff label.
Players can now therefore have different full and short names. To edit a player’s
names, right-click the player in the Players panel in Setup mode and choose
Rename Player, which shows a simple dialog in which you can specify the full and
short names for the player.
Instrument name language. A new option Default language for instrument names
has been added to the General page of Preferences, allowing you to specify the
language that should be used for instrument names in new projects. This sets the
Instrument names language option on the Language page of Engraving Options.
When you change the language used for instrument names in Engraving Options,
the existing instrument names in the project are now automatically updated. If you
don’t want to change the names in your project, deactivate Reset instrument
names when changing language on the Language page.
Furthermore, Dorico is now much more consistent in the way it handles instrument
name languages: the instrument picker in Setup mode now always follows the
language chosen for the user interface of the application (either your operating
system’s language, or the language explicitly chosen on the General page of
Preferences); default player and layout names shown in Setup mode always follow
the Instrument names language defined in Engraving Options; and staff labels
likewise follow the Instrument names language option, including using this
language for the note names used to describe instrument transpositions.
To better handle instrument transpositions in languages other than English, new
options have been added to the Language page of Engraving Options, allowing you
to specify the case for note names, the approach to be taken for accidentals in
German, and whether the note C should be described as “Do” or “Ut” in French.
Instrument transposition in staff labels. Greater flexibility for how the transposition
of an instrument appears as part of its staff label has been introduced, thanks to
new options on the Staves and Systems page of Layout Options. In addition to the
existing Position of instrument pitch in full staff labels option, that allows you to
choose between “B♭ Clarinet 1” (Start) or “Clarinet in B♭ 1” (End), three further new
options have been added:
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Show on separate line

Clarinet 1
B♭

Show in parentheses

Clarinet (B♭) 1

Show instrument number before

Clarinet 1 in B♭

transposition

These options can be combined in various ways, and it should now be possible to
achieve any of the standard conventions for formatting instrument transpositions.
The {@staffLabelsFull@} token has also been updated to take the state of these
options into account, and produce a similar result to the current Layout Options.
Stacking player numbers for condensed staves. If the option Player numbers for
condensed players on the Staff Labels page of Engraving Options is set to Stack
horizontally, the option When stacking player numbers for condensed players
vertically no longer unexpectedly takes effect, i.e. the option to Ignore stem
allocation no longer causes the player numbers to be stacked vertically.
Furthermore, adjacent section players can now use vertically stacked labels if
desired.
Grouping for adjacent section players. A new Staff labels for identical adjacent
instruments held by section players option has been added to the Staff Labels
page of Engraving Options. Choose Group between staves to show a single
instrument name between the staves, and the individual player numbers on each
staff.
Vertical position for grouped solo instruments. In some jazz and big band scores, it is
customary to show the full instrument name only on the staff corresponding to the
first chair for that instrument. For example, Trumpet 1 would show both the
instrument name and its number, while Trumpet 2 would show only its number.
This convention is now easily achieved in Dorico, first by setting Staff labels for
identical adjacent instruments held by single players to Group between staves,
and then setting the new Position of instrument names for grouped staff labels to
Align instrument name with first staff. These options are both found on the Staff
Labels page of Engraving Options.

Tacets
Paragraph style. In previous versions of Dorico, the Tacets page of Engraving
Options contained options related entirely to the appearance of the tacet indication
that is shown: whether it should have a border; the thickness of the border; and the
padding to the left or right of the text within the border.
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Since all these properties are also part of the Tacet paragraph style used to
determine the font, style and size of the text, Dorico 4 now uses the properties for
border, thickness and padding defined in the Tacet paragraph style, allowing
greater flexibility (particularly for padding), and the Tacet page of Engraving
Options has now been removed.
When opening an existing project created in an earlier version of Dorico, the values
that were previously defined on the Tacets page of Engraving Options are used to
modify the Tacet paragraph style, so that the appearance of your existing project is
maintained as far as possible.

Tempo
Metronome mark order. A new option Order of metronome mark relative to tempo
instruction has been added to the Tempo page of Engraving Options, allowing you
to specify that the metronome mark should appear Before tempo instruction by
default, as it is preferred by some publishers.
You can also override this on a per-item basis using the new Metronome mark
order property in the Tempo group in the Properties panel.

Text
Adding music symbols. To make it quicker and easier to add musical symbols both to
Shift+X text items and to text frames, a new Insert Music Symbol dialog has been
added, accessible from the right-click context menu when editing text:

By default, the dialog shows a handful of useful characters, but it also remembers
each symbol you choose and shows this selection of Recently used characters when
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the dialog opens. These choices are remembered between sessions, so if you
habitually need the same symbols in multiple projects, they will always be available
by default.
You can otherwise search for a symbol by name, using its SMuFL name, or you can
browse through the symbols by SMuFL range, choosing the desired range from the
drop-down menu.
Once you have found the symbol you want to insert, simply select it and click OK or
hit Return to confirm the dialog.
Selection after editing. When you finish editing a text item after you have either
created or edited it, the text item will now remain selected.

Ties
Tie end and middle thickness. It is now possible to override the thickness of the ends
and middles of individual ties via the Properties panel.

Localization
Date and time formatting. When using tokens that show the current date or time, or
using the option to print the current date and time as an annotation, Dorico can
now show the date and time in the correct localized format. A new option Date and
time tokens language has been added to the Language page of Engraving Options
to determine which language will be used. If you are running Dorico in a language
other than English, this will be set automatically to the language in which you are
running Dorico when starting a new project.
Changing application language. When you choose a new application language on
the General page of Preferences, it is no longer necessary to quit and restart Dorico
for the change of language to take effect.

User interface
Library menu. A new Library menu has been added, available from all modes. This
new menu includes all five of the main options dialogs, in addition to the new
Library Manager dialog. It also contains all the dialogs that edit library items in your
project, in other words those items whose appearance you can customize.
The new menu draws together items that were previously found in other menus
(most often the Engrave menu), as follows:
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Menu item

Previous menu

Paragraph Styles…

Engrave

Character Styles…

Engrave

Chord Diagrams…

Engrave

Chord Symbols…

Not applicable

Music Symbols…

Engrave

Notehead Sets…

Engrave

Playing Techniques…

Engrave

Lines…

Engrave

Line Bodies…

Engrave

Line Annotations…

Engrave

Repeatable Symbols…

Engrave

Expression Maps…

Play

Percussion Maps…

Play

Playback Techniques…

Play

Engraving Options…

Engrave

Layout Options…

Setup

Notation Options…

Write

Note Input Options…

Write

Playback Options…

Play

Library Manager…

New in Dorico 4

Context menu. The menu that appears when you right-click (Windows) or Controlclick (Mac) has been improved, and now changes its contents based on the selected
items, so it is truly now a context menu. All the items in the context menu can be
found in the main menu bar, mostly in the Edit menu. Many of the notation-specific
submenus in the Edit menu have now been moved into a new Notations submenu
to reduce the overall length of the top-level Edit menu.
Keyboard access. It is now possible to choose between different options shown as
buttons with music examples on them in the various multi-page options dialogs,
such as Engraving Options and Notation Options. It is now possible to move the
focus to these sets of buttons with Tab or Shift+Tab, then use ←/→ to toggle the
buttons in the group. On macOS, this requires Use keyboard navigation to move
focus between controls to be activated in the Shortcuts tab of the Keyboard pane
of System Preferences.
Tab bar. A new preference has been added to the View section of the General page
of Preferences, controlling whether the tab bar should appear by default in new
projects, switched off by default.
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Hand tool. When the hand tool is active, you can now trigger a marquee selection
using only the mouse by clicking and holding the mouse pointer for a moment;
when you see an animated rectangle appear for a moment, dragging will now
create a marquee rather than dragging the score as it normally would.
Switching mode and view. When switching between page view and galley view, or
when switching between Write mode in galley view and Engrave mode in page
view, Dorico now does a much better job of keeping the selected items in view. If
there is nothing selected, Dorico will try to keep the bar that was closest to the
center of the view in view after changing view type.
Dorico also now retains information about the view type (galley or page view), zoom
level, and which page or bar was in view when you switch between different layouts
within the same tab, or when the tab bar is not shown at all.
Furthermore, a new Center Selection command has been added, which can be
assigned to a keyboard shortcut via the Key Commands page of Preferences and
which allows you to bring the selection into view. This can be useful not only after
switching view, but also simply after having scrolled to a different part of the
current layout.
In addition, a new Toggle View Type command has been added, which switches
back and forth between galley view and page view. You can assign a keyboard
shortcut to this if you wish, on the Key Commands page of Preferences.
Switching between windows or tabs. If you have opened multiple windows on the
same project, or if you have multiple tabs open within the same window, when you
switch from one window or tab to another, if you have one or more items selected,
you may want to bring the selection into view automatically: to do this, activate the
new When switching tab or window, bring selection into view option in the View
section of the General page of Preferences.
Overscroll. When you scroll through the pages of your layout, Dorico does not
permit you to drag very far beyond the first or last page of the layout. Some users
have found this frustrating, as they want to be able to position, say, the top left-hand
corner of the first page in the center of their workspace, but Dorico does not allow
this much overscroll.
To address this, a new Overscroll amount option has been added to the View
section of the General page of Preferences, allowing you to configure the amount of
overscroll that Dorico will allow when scrolling off the start or end of the layout. By
default, this is set to Small; if you set it to Large, you can drag the pages almost
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completely out of view, while Medium is, as you might expect, somewhere between
the other two.
Taskbar buttons on Windows. The buttons for Dorico project windows, dialogs, and
the VST audio engine are now all grouped together on Windows; previously, the
audio engine buttons (for plug-in windows, for example) were grouped separately.
Application icon. For the first time since its initial release in 2016, Dorico 4 now
sports a new application icon, part of a new unified set of application icons for
Steinberg software products.
Options dialogs. The buttons in each of the five main options dialogs for saving
defaults, removing saved defaults, resetting to the saved defaults and resetting to
the factory defaults have been reworked so that it is no longer necessary to hold a
modifier key to access all of their functions.
In the Layout Options dialog, the menu in the bottom left-hand corner of the dialog
for specifying the layout type to which the options to save and restore defaults
should apply has been removed. Dorico now determines which layout type the save
or restore defaults operation should apply to automatically, based on the layouts
selected in the Layouts panel on the right-hand side of the dialog.
Preferences dialog. A new Reset to Factory button has been added to the
Preferences dialog, allowing you to restore the factory defaults for application
preferences if necessary.
On the Play page, the options for enabling and disabling MIDI input devices and
determining the default quantization settings for real-time recording are now
embedded directly in the Preferences dialog, instead of requiring you to open
subsidiary dialogs.
Missing Fonts dialog. The Missing Fonts dialog, which can appear when opening a
project, has been improved such that the widths of the columns in the table in the
dialog can be resized, and the chosen sizes will be saved and recalled in future.
Endpoint Setup dialog. The Endpoint Setup dialog, which allows you to specify the
expression and percussion maps assigned to each channel in your playback
devices, has similarly been improved such that the widths of the columns in the
table in the dialog can be resized, and the chosen sizes will be saved and recalled in
future.
Transpose dialog. It is no longer possible to choose an interval of diminished unison
in the Write ▶ Transpose dialog; instead, to transpose from (say) C to C flat, you
transpose down by an augmented unison.

Dorico 4 Version History

126

Steinberg Media Technologies GmbH

Percussion Maps dialog. If you have unsaved changes to one or more percussion
maps, hitting Esc will now show a prompt giving you the chance to confirm that you
want to discard your changes and close the Percussion Maps dialog, rather than
closing the dialog right away.
Underline access key shortcut. The underline access key shortcut for the Write menu
has been changed from Alt+I to Alt+R (Windows only).
Renaming projects. If you rename a project in the Finder while it is open in Dorico,
the project’s name will automatically be updated in Dorico, so that subsequent save
operations continue to update the current project, rather than unexpectedly
causing it to be saved again under its old name (Mac only).
Project thumbnails. When you save your project, Dorico now saves two preview
images inside the project, based on the layout that is active at the time the project is
saved. One thumbnail consists of a PNG graphic of the first page of the project, and
is displayed in the Open Recent page of the Hub, while the other consists of a PDF
graphic of the entire layout, and is not currently displayed anywhere, but it is
planned to be used in the future to allow for Quick Look support on macOS.
Although it normally adds only a negligible amount of time to the save operation,
and increases the file size of the project by a similarly modest amount, you may find
that in very large and complex projects, saving thumbnails imposes a performance
penalty that you want to avoid. In such cases, you can deactivate the Generate
preview thumbnails when saving checkbox in File ▶ Project Info.
Regardless of the state of this checkbox, Dorico does not save thumbnails when
auto-saving: only when you explicitly invoke the Save or Save As command.

Installation
Improved installation process. It is recommended to use Steinberg Download
Assistant to download and install Dorico 4. When you run Steinberg Download
Assistant you will be prompted to sign in with your Steinberg ID. You should then
click Enter your Download Access Code in the top left-hand corner of the
Steinberg Download Assistant window, and enter the code that you received from
the Steinberg online shop or on the license redemption card in your Dorico 4
package.
Click My Products in the left-hand panel, where you should see the appropriate
Dorico 4 product listed. Click its icon to select this product. Finally, on the righthand side, you should see a button Install All at the top of the list of application
components. Click this, and all the required components will be downloaded and
installed with no further intervention.
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When you first run Dorico 4, Steinberg Activation Manager will be launched
automatically to activate your license. You may be prompted to sign in with your
Steinberg ID to complete the activation process.

System requirements
Minimum supported operating system versions. On macOS, Dorico now requires Mac
OS X 10.14 Mojave or later. Dorico 4 cannot even be installed on earlier versions of
macOS. Dorico 4 is supported on Mac OS X 10.14 Mojave, Mac OS X 10.15 Catalina,
macOS 11 Big Sur and macOS 12 Monterey.
On Windows, Dorico 4 is supported on 64-bit Windows 10 update 21H2 (or later),
and 64-bit Windows 11 update 21H2 (or later).

Dorico Elements
The feature set of Dorico Elements has been expanded in version 4, with the
following changes over previous versions:
Increased maximum player count. You can now create projects with up to 24 players
in Dorico Elements, making it possible to write for ensembles like big bands,
medium-sized orchestras, and small concert and wind bands.
Engrave mode with graphical editing. You can now adjust the fine graphical
placement of every item in your project with the inclusion of the graphical editing
tool in Dorico Elements.
Notation Options. Dorico Elements now includes the Notation Options dialog (in the
Library menu), providing access to all of the options for note, beam and rest
grouping, accidental duration, and barline handling, which were previously only
included in Dorico Pro.
Project Language. A new Library ▶ Project Language dialog allows you to change
the language used for staff labels at any time in your project.
Customizable chord symbols. A new Library ▶ Chord Symbols dialog provides access
to the options from the Chord Symbols page of Engraving Options in Dorico Pro,
making it easy to choose from any of the provided presets or adjust individual
aspects of chord symbols.
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Accidentals

Deleting a trill now correctly recalculates the accidentals for following notes in the bar.

Accidentals

Any text-based symbols added to the music symbols used for custom accidentals are now
correctly imported when importing a tonality system.

Accidentals

In transposing layouts where the key signature has been simplified, modifying the accidental
for a selected grace note could lead to the wrong accidental appearing; this has now been
fixed.

Accidentals

If you create a key signature in a project using a user-defined tonality system that is present in
your user library, Dorico now always ensures that the tonality system itself is added to the
project.

Audio export

Dorico no longer incorrectly sends MIDI controller messages that are destined for channels
that are not included when exporting audio for a particular layout.

Audio export

When exporting audio, Dorico now prepends the flow number before the name of the flow, so
that identically named flows don’t overwrite each other as they are exported.

Auto-save

Auto-save location is no longer incorrectly migrated when migrating settings from previous
version.

Auto-save

Under some circumstances, the combination of a short auto-save interval and a very longrunning operation could cause Dorico to hang indefinitely; this has now been fixed.

Barlines

Selecting multiple adjacent barlines and deleting them now works as expected.

Barlines

If a barline type other than the single barline is chosen as the default barline for the flow in
Notation Options, selecting a default barline in the flow now shows the appropriate barline
highlighted in the Create Barline section of the Bars and Barlines panel.

Bar repeats

Under some circumstances, the end handle for a bar repeat or numbered bar region could
draw before the start handle when selected in Write mode; this has now been fixed.

Beams

Fixed the incorrect option images and descriptions for Horizontal eighth note (quaver)
beams within the staff option for Ted Ross-style straddle-hang (but not sit) beams.

Bracketing

Under some circumstances, changing an instrument held by a player to one in a different
instrument family could cause the bracketing to be calculated incorrectly; this has now been
fixed.

Bracketing

A problem whereby the width of bracket line, rather than the distance of the bracket from the
systemic barline, was being used to determine the additional width for the horizontal lines for
sub-brackets set to reach the systemic barline has been fixed.
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Bracketing

It is now possible to create bracketing changes on condensed divisi staves.

Bracketing

Bracket and barline change signposts can now be selected when they are shown on a
condensed staff.

Chord diagrams

Changing the Show barre using slur option on the Chord Diagrams page of Engraving
Options now works as expected.

Chord diagrams

Chord diagrams saved by the user no longer prevent identical chord shapes from the default
library from appearing at other positions up the neck.

Chord diagrams

Chord diagrams with explicitly excluded strings can now be transposed up the neck of the
guitar as expected.

Chord diagrams

Edit ▶ Reset Appearance now works as expected on selected chord diagrams.

Chord diagrams

Under some circumstances, a barre slur shown in a chord diagram in the frame of used chord
diagrams at the start of the flow could be drawn incorrectly; this has now been fixed.

Chord diagrams

Chord symbols shown above chord diagrams in the grid of used chords at the start of the flow
now correctly take the complete height of the chord symbol into account, avoiding collisions.

Chord diagrams

Under some circumstances, Dorico could display multiple chord diagrams with the same
appearance when cycling through diagrams, which would prevent further cycling; this has
now been fixed.

Chord symbols

Saving multiple project default chord symbols no longer sometimes results in the font styles
used by chord symbols being duplicated in the project.

Chord symbols

Copying and pasting a chord symbol with an overridden appearance no longer causes the
pasted chord symbol not to draw.

Chord symbols

Under certain circumstances, editing the appearance of stacked alterations in the Project
Default Chord Symbol Appearance dialog could overwrite the edited appearance of other,
different stacked alterations; this has now been fixed.

Chord symbols

Local chord symbols now appear correctly if the Position of chord symbols on grand staff
instruments engraving option is set to Between staves.

Chord symbols

Editing chord symbols to change the size and position of components within the chord symbol
now works much more reliably.

Chord symbols

When removing time (via the Shift+B popover) from the middle of ongoing cues or chord
symbol visibility regions, those regions are now correctly reduced by the corresponding
amount.
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Comments

Under some circumstances, comments that had been created with a range of music selected
would show a range of bar numbers where the ending bar number is before the starting bar
number; this has now been fixed.

Condensing

Under rare circumstances, Dorico could crash when activating condensing in some specific
situations involving beamed stemlet rests; this has now been fixed.

Condensing

Mid-bar system breaks in condensed staves no longer sometimes cause bar rests on
condensed staves to be split incorrectly.

Condensing

In the unlikely event that a condensing group of section players contains more than 16 divisi
sections, Dorico no longer crashes when enabling condensing.

Condensing

Under rare circumstances, condensing voices containing chords could crash; this has now
been fixed.

Condensing

Under some circumstances, apparently equivalent slurs can limit the maximum condensing
result, preventing music from being notated in unison or on a shared stem; this has now been
fixed.

Cues

When splitting a flow in the middle of a cue, the cue will now be correctly split into two parts in
the existing and new flows.

Cues

When importing a flow into a new project, cues in the imported flow are now retained.

Cues

When cueing material from a divisi section, Dorico now calculates the label to show for the
cue from the prevailing divisi change, so it should be correct under more circumstances.

Cues

Stems are no longer slightly misaligned relative to noteheads in cues.

Dynamics

Immediate dynamics hidden by way of Hide intensity marking now show signposts in the
correct rhythmic position, and can be correctly deleted by selecting the signpost and hitting
Delete.

Dynamics

Deleting a dynamic from a group (e.g. the hairpin from the middle of p<f) now splits the group,
so that subsequently adding further dynamics doesn’t delete distant dynamics from the same
group.

Dynamics

When hiding a dynamic in the middle of a dynamic group, the signpost now appears at the
rhythmic position of the individual hidden dynamic, not at the position of the start of the
overall group.

Dynamics

Under some circumstances, pasting dynamics to multiple instruments could result in the
dynamics being pasted on the wrong staff; this has now been fixed.
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Dynamics

Dorico now always correctly adds a space between poco and più modifiers when added to a 
or  dynamic.

Dynamics

The behavior of Align Dynamics has been improved when aligning dynamics above the staff.

Dynamics

When removing time via the Shift+B popover from the middle of an existing group of
dynamics, Dorico now intelligently shortens or removes the appropriate dynamics.

Engrave mode

All items – including guitar bends, figured bass and lines – now show their handles in Engrave
mode if Engrave ▶ Show Handles ▶ Always is active.

Expression maps

Changing the name of an existing expression map in Expression Maps no longer causes that
expression map to be duplicated unexpectedly.

Expression maps

Options in the Playback Options Overrides section of the Expression Maps editor that can use
floating point values now correctly save and restore values between 0 and 1.

Expression maps

The Export Library button in Expression Maps now works correctly if it is the very first thing
you do in the dialog without first selecting an expression map.

Figured bass

Figured bass signposts on rests now update correctly when the note being using as the basis
for their figures changes pitch.

Figured bass

Figures containing octave doublings no longer sometimes draw duplicate intervals if the bass
note is modified.

Figured bass

Entering s (as equivalent to # for sharp) followed by one or more numbers into the Shift+G
popover is now parsed correctly.

Figured bass

Under some circumstances, ongoing hold lines for figured bass could disappear following a
system break; this has now been fixed.

Figured bass

Under some circumstances, dragging a figured bass resolution in Engrave mode would cause
the line itself to become invisible during dragging; this has now been fixed.

Figured bass

Under some circumstances, hold lines crossing a system break could stop before the note at
the correct rhythmic position; this has now been fixed.

Figured bass

Figured bass hold lines that continue after a suspension now draw correctly on the following
system if that is where the suspension resolution appears.

Figured bass

Figured bass hold lines that continue through one figure and end at another now end at the
correct position if the final figured bass is after a system break.
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Figured bass

Figured bass hold lines for a single figure are now positioned correctly in the event that
another set of figures on the same system has more rows.

Figured bass

Figured bass hold lines now correctly draw through figures at the end of the line if they match
the initial figure.

Figured bass

The Draw line through figures at end property now works correctly even for figures that are
not adjacent.

Figured bass

Sharpened thirds in figured bass now follow the Appearance of raised or lowered third
engraving option as expected when an additional seventh is included.

Figured bass

Dominant seventh chords are now correctly abbreviated as expected on staves with a
different bass note.

Figured bass

If a figured bass suspension and resolution are separated by a system break, the resolution’s
figure can now be set independently of the initial suspension figure.

Figured bass

Resolution figures no longer appear in the wrong position if on a different system to the initial
suspension figure.

Figured bass

The figured bass calculator no longer sometimes finds the wrong bass note in the presence of
multiple voices with conflicting rhythms.

Figured bass

Figured bass signposts on rests now correctly update when the earlier note to which they
relate changes pitch.

Figured bass

The Draw line through figures at end property now works as expected for lines that end at
system breaks.

Figured bass

Figured bass containing octave doublings no longer sometimes draw duplicate intervals when
the bass note is repitched.

Fingering

When inputting fingerings on a percussion kit, advancing the fingering popover through a
tuplet position could sometimes cause Dorico to crash; this has now been fixed.

Fingerings

Intra-staff fingerings no longer incorrectly appear in cues.

Flow headings

It is now possible to specify a much larger value for the top and bottom flow heading margins
in the Flow Heading Change dialog.

Flows

When importing a flow into an existing project, additional instruments held by the player but
not used in the incoming flow will now be correctly padded with rests.
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Glissando lines

Under some circumstances, making an unrelated edit like adding a slur could cause a crossstaff glissando line on another instrument to temporarily disappear in galley view; this has
now been fixed.

Glissandos

Creating a glissando between non-consecutive notes no longer sometimes causes a rhythmic
distortion between the note on which the glissando starts and the note immediately following.

Glissandos

Under some circumstances, a glissando line between a grace note and a rhythmic note would
not appear correctly; this has now been fixed.

Grace notes

Grace notes immediately preceding a key signature change could sometimes show the wrong
spelling in transposing layouts; this has now been fixed.

Graphics export

When exporting to SVG, dashes in octave lines could end up with the wrong size under some
circumstances; this has now been fixed.

Graphics export

Colored text no longer incorrectly appears in grey in a PDF that was exported using the Mono
option.

Graphics export

It is no longer necessary for a project to be activated for playback in order for the commands
to export and print graphics from the current layout to be operational.

Guitar tablature

Vibrato bar dips now display the correct value above the dip for intervals other than a halfstep (semitone).

Guitar tablature

In projects with many chords with more notes than the available number of strings in the
instrument, Dorico could take so long to open the project that it would appear to have hung;
this is now fixed.

Guitar techniques

Guitar techniques (hammer-on, pull-off, tapping, etc.) can now correctly be nudged by holding
Alt and using the arrow keys when in Engrave mode.

Harmonics

When showing a harmonic as a notehead above the fundamental, if fundamental notehead
has a specific accidental override, Dorico now uses the same accidental for the harmonic
notehead.

Harp pedaling

When Set local properties is set to Globally, changes to the appearance of harp pedal changes
now correctly apply to all layouts in which they appear.

Key signatures

Key signature cancellations that appear for instrument changes in transposition layouts are
now always relative to the current key signature, and not sometimes the initial key signature
at the start of the flow.

Key signatures

Custom tonality systems are now always correctly added to the project when you create a key
signature using that tonality system.
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Lines

The effect of the Repeat options Accelerating and Decelerating has now been inverted.

Lines

Barline-attached horizontal lines now attach properly to start repeat barlines at the start of
the system.

Lines

Dorico no longer incorrectly truncates the length of a line when pasting another line of the
same type within the duration of the longer line.

Lines

It is no longer incorrectly possible to delete line body or repeatable symbol library items that
are used by line items defined in the project library, which could previously lead to a crash.

Localization

When using a German keyboard layout, it was not always possible to type the curly brace
characters needed for text tokens; this has now been fixed.

Lyrics

It is now possible to adjust the vertical position of lyrics in divisi sections.

Lyrics

Dorico no longer crashes if you attempt to vertically nudge lyrics if you inadvertently also have
a beam selected.

Lyrics

Lyrics are now always nudged by the same distance as other items, regardless of the current
staff size.

Markers

When nudging markers using Alt+←/→, the video start time offset (if any) is now correctly
taken into account.

MIDI export

When Dorico exports MIDI, it now uses the active layout to determine which players and flows
to export. Choose a layout that contains the instruments and flows you want to export before
you export.

MIDI import

Quantization now correctly recognizes tuplets if they appear anywhere in the bar, not only in
the first half of the bar.

MIDI import

When importing drum set tracks from MIDI files, Dorico can now resolve the tuplets to be
used by up- and down-stem voices separately, leading to more legible results.

Music symbols

It is no longer incorrectly possible to delete the attachment between two components in a
composite music symbol by selecting one of the components and typing Delete.

Music symbols

A problem with scaling music symbols that would cause custom noteheads to become
misaligned from their stems and staff positions at different staff sizes has been fixed.

MusicXML import

Dorico no longer incorrectly shows a niente circle on a hairpin imported from MusicXML if the
wedge element explicitly defines that a niente marking should not be shown.

MusicXML import

When importing hairpins from MusicXML files, Dorico now correctly respects the value of the
niente attribute.
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MusicXML import

In projects created by opening a MusicXML file, part layouts you subsequently create after the
initial import now work correctly.

MusicXML import

When importing MusicXML files that contain grand staff instruments with notes crossing
between staves, it was sometimes impossible to navigate the caret onto one of the staves of
the grand staff instrument; this has now been fixed.

MusicXML import

Text items attached to drum or percussion parts in MusicXML files are now imported more
reliably.

MusicXML import

If notes or rests in a MusicXML file have zero duration, they no longer sometimes cause Dorico
to crash when importing.

MusicXML import

When importing tablature for fretted instruments with more or fewer than six strings, the
tablature would often end up with the wrong number of strings; this has now been fixed.

MusicXML import

When importing a MusicXML file that creates a custom tonality system, the custom tonality
system now appears correctly chosen in the Key Signatures panel in Write mode.

Note input

When Specify accidental, rhythm dot and articulations is set to After inputting note, Dorico
no longer incorrectly auditions the selected note instead of the shadow note in pitch before
duration input.

Note input

Changing the duration of a chord where notes have different durations now works properly.

Note input

Changing the duration of a grace note no longer causes it to become deselected.

Note input

Under some circumstances, Dorico could hang when connecting or disconnecting a MIDI
input device while the application is running; this has now been fixed.

Note input

When moving a note between instruments in a percussion kit using the five-line staff
presentation type, tuplets are now always correctly created on each instrument to ensure the
rhythm is preserved.

Note input

When you change the duration of a rest, it will now remain selected as expected.

Note input

The pitch before duration button in the Notes toolbox now correctly remains active if
activated by clicking it with the mouse rather than using its key command.

Note input

Under some circumstances, it was possible to edit the duration of a note that crosses a barline
in such a way that undoing the edit would not restore the original note grouping; this has now
been fixed.

Note input
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Note input

Edit ▶ Select More now correctly advances directly from selecting the current bar to the whole
flow in galley view.

Note input

Starting a new voice by adding a bar rest via the Shift+B popover now works as expected.

Note input

Dorico no longer resets the number of rhythm dots to zero when advancing the caret with
Space when Specify accidental, rhythm dot and articulations is set to After duration.

Note input

When the option to set rhythm dot, accidental and articulations after the note has been
created is set, double-clicking a dotted note no longer advances the caret to the end of the
note.

Note input

Selecting an implicit rest in a tuplet on a percussion kit now selects the appropriate duration
in the Notes panel in Write mode.

Note spacing

Changing the Voice column X offset property for a note will now correctly immediately
update the horizontal position of any playing technique at the same position.

Note spacing

Moving a bracketed note using the Voice column X property now updates the position of the
parentheses right away.

Note spacing

Changes to stem direction for cross-staff notes that cause the beam to be positioned above a
different staff now correctly always cause the note spacing to be updated.

Note spacing

Under some circumstances, note spacing could behave unstably in projects with multiple note
spacing changes; this has now been fixed.

Note spacing

Items on staves hidden via the Manual Staff Visibility dialog no longer sometimes incorrectly
affect rhythmic spacing on the visible staves.

Octave lines

Octave lines that start and end on grace notes now both draw and take effect correctly on the
notes under their span.

Octave lines

Changing the scale factor for the music symbols at the start of octave lines in Library ▶ Music
Symbols now works correctly.

Page layout

When using Make Into System/Frame or Lock System/Frame, Dorico now correctly preserves
the Wait for next system/frame break properties of any existing breaks at affected positions.

Page layout

If you lock the format of a system, frame or layout, the Staff label property for any existing
break that is affected by the operation is no longer incorrectly reset.

Page layout

Under some circumstances, all the staves belonging to instruments held by a player could
become hidden incorrectly, causing the system to simply not appear in the layout; this has
now been fixed.
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Page layout

The Manual Staff Visibility dialog now shows more appropriate names for condensed divisi
staves.

Page layout

Hiding of empty staves now always works correctly for instruments that are set to show chord
symbols in slash and chord symbol regions, even if Allow individual staves of grand staff
instruments to be hidden is switched on.

Page layout

When fixing the number of bars per system using the Casting Off options on the Staves and
Systems page of Layout Options, pick-up (upbeat) bars are now handled correctly.

Page layout

Choosing Engrave ▶ Staff Spacing ▶ Reset Selected Frame with no selection will no longer
incorrectly reset the staff spacing for the whole layout.

Pedal lines

If the Dashed segments property for a pedal line is set to End Segment, Dorico now correctly
only draws the very final segment dashed, rather than incorrectly drawing the final segment
on each system in which the pedal line appears dashed.

Pedal lines

Dorico now correctly respects changes made to scale and color in Library ▶ Music Symbols for
symbols used in pedal lines.

Percussion

When exporting a percussion kit, any notehead types or other music symbols referenced by
the kit are all now correctly exported.

Percussion

When copying and pasting pitched material to an unpitched percussion kit, any text items in
the selection are no longer incorrectly duplicated to every instrument in the kit.

Percussion

If you have multiple windows open for a project and make changes in the Edit Percussion Kit
dialog, such as removing an instrument from the kit, the dialog now always updates correctly.

Percussion

Editing or deleting an empty or hidden text item shown as a signpost on a percussion kit now
works as expected.

Percussion

For some complex percussion maps with many instruments mapped, you would sometimes
end up with two notes being input when playing a single key on your MIDI keyboard; this has
now been fixed.

Percussion

Editing the name, playing techniques or notehead of instruments in a percussion kit after
moving the instrument to a different staff position no longer causes the instrument to be
moved back to its original staff position.

Percussion legends

Percussion legends are now positioned inside instrument change labels, if they occur at the
same rhythmic position.

Percussion maps

Changing the name of an existing percussion map in Percussion Maps no longer causes that
percussion map to be duplicated unexpectedly.
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Percussion maps

When opening the Playing Technique Combinations dialog from Percussion Maps, the initial
choice in the Playing Technique Combinations dialog is now always correctly populated.

Performance

Adding the first note to an empty instrument in a long flow with many instruments is now
much faster than before.

Play mode

If you deactivate a VST instrument in the VST Instruments panel in Play mode, its state is now
correctly restored when reopening the project.

Play mode

Changing the selection no longer causes the state of the buttons for each instrument in the
VST Instruments panel in Play mode to become reset.

Play mode

When opening a project and cleaning up empty voices, Dorico will not remove a voice if it has
been routed to an endpoint and independent voice routing is enabled. This prevents voice
assignments from being removed unexpectedly in the event that you have set up routing for
e.g. divisi sections but have not yet written any notes written for one or more voices.

Play mode

Individual points added to the dynamics lane in Play mode now take effect in playback as
expected.

Playback

The duration of the individual notes generated for unmeasured tremolo playback no longer
incorrectly depends on the beat unit of the prevailing tempo.

Playback

Parenthesized noteheads are now only treated as ghost notes with reduced volume on
playback on unpitched percussion instruments.

Playback

The metronome click now plays back correctly at the velocity level specified in Playback
Options.

Playback

In some situations, projects with unmatched repeat barlines that would play back in an
infinite loop could cause Dorico to crash when reopening them; this has now been fixed.

Playback

Play ▶ Set Solo From Selection no longer incorrectly takes effect if you invoke the command
with no selection; previously this would incorrectly cause the metronome click to be soloed.

Playback

If a switch in an expression map is disabled, any Transpose value for that switch would
nevertheless have been incorrectly applied during this playback; this has now been fixed.

Playback

Dorico will no longer play back silently if the chosen sample rate for the only available audio
device is not available.

Playback

Dorico will no longer hang when playback moves from one flow to the next if something is
selected an earlier flow.
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Playback

The WordBuilder feature in EastWest's Symphonic Choirs and Hollywood Choirs libraries now
works correctly with Dorico’s audio engine.

Playback

When Dorico generates playback for chord symbols, the generated chords now respect the
standard note duration option on the Timing page of Playback Options.

Playback

When Dorico plays a two-note tremolo, it now ensures that they always consist of an even
number of notes, so abutting two-note tremolos join smoothly.

Playback

Two-note tremolos no longer incorrectly cause the unmeasured tremolo playing technique to
be triggered during playback.

Playback templates

When saving an endpoint configuration, custom playback techniques referenced by a
percussion map necessary for the endpoint configuration are now correctly included.

Playback templates

When importing a playback template, Dorico now only imports user-defined library items,
and does not overwrite factory library items, preventing unexpected side-effects like text
fonts changing.

Playback templates

When exporting expression maps as part of an endpoint configuration, all playback
techniques referenced by add-on switches are now correctly included in the exported file.

Playing techniques

Dorico no longer automatically adds a space at the end of a text-based playing technique
when adding a Suffix via the Properties panel.

Playing techniques

When reverting an editing playing technique back to its default or factory appearance,
controls on the Continuation tab of the Edit Playing Technique dialog are now correctly reset
if necessary.

Playing techniques

When dragging one of the repeated symbols of a playing technique that uses the Repeat the
signs continuation type in Engrave mode, the correct symbol is now always dragged.

Properties

When nothing is selected, the Common group in the Properties panel now always appears
empty.

Properties

Deactivating the switch for a property in the Properties panel and then undoing to reactivate
the property now restores the previous state in a single step.

Rehearsal marks

The calculation of the width of enclosed items, such as rehearsal marks, now correctly
considers the thickness of the line used to draw the enclosure, fixing some collisions in tight
situations.

Rehearsal marks

The whole line width for enclosures around items like rehearsal marks and boxed text is now
considered for the purposes of collision avoidance.
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Repeat endings

It is now possible to specify the position for a created repeat ending by selecting one or more
slashes in a slash region, without first splitting or deleting the slash region.

Repeat markers

When hiding or showing staves via the Manual Staff Visibility, any repeat markers that
coincide with the end of the flow now appear or disappear as required if the top or bottom staff
in the system changes.

Repeats

The Play n times property now enforces a maximum value of 50 repeats, and this now
matches the maximum number of repetitions Dorico will play before it will stop automatically.

Rhythm slashes

Under some circumstances, deleting bars could cause slash regions to be notated across the
wrong region; this has now been fixed.

Rhythmic feel

Dorico no longer incorrectly plays some tuplets swung when it shouldn’t.

Rhythmic feel

Swung eighths rhythmic feels no longer incorrectly affect the playback of quadruplet quarter
notes (crotchets).

Rhythmic feel

Slurs on grace notes no longer incorrectly prevent rhythmic notes in the following beat from
being swung if appropriate.

Slurs

Under some circumstances, slurs could tuck in beside staccato and staccatissimo
articulations on the notehead side; Dorico now ensures that slurs cannot end between the
articulation and the note.

Staff labels

When the option to show staff labels for voice instruments in upper case is chosen, Dorico
now handles extended and accented characters correctly.

Staff labels

Staff labels for user condensable groups containing different instruments (for example,
Trombone and Bass Trombone) are no longer sometimes grouped incorrectly.

Staff labels

When a single uncondensed instrument is adjacent to a condensed staff, a single grouped
staff label can now be shown between the staves as expected.

Staff labels

If the option for showing instrument transposition in the Edit Instrument Names dialog is set
to Always, this is now correctly also applied to abbreviated staff labels as well as full ones.

Staff labels

Changing the Default text paragraph style will now correctly update the staff labels in the
project right away, assuming you have not updated the Staff labels style such that it does not
inherit.

System dividers

System dividers are now always correctly centered between systems; previously they could be
misaligned if the height of the outermost staves on adjacent systems differed.

Tempo
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Tempo

Edit ▶ Reset Appearance now works as expected for properties on immediate and gradual
tempo markings.

Text

Clicking the star button in Paragraph Styles or Character Styles to save a paragraph or
character style as a default for future projects now works even if the style has not been
modified in that session.

Text

The asterisk that indicates whether a style has been modified in Paragraph Styles or
Character Styles now works correctly when changing the selection in the dialog.

Text

Text that has been colored – either via its paragraph style, or via an override in the text editor,
or via the Color property – now shows correctly as black when printing or exporting
monochrome graphics.

Text

The {@staffLabelsShort@} and {@staffLabelsFull@} tokens now show player numbers in
Roman or Arabic numerals, according to the relevant engraving options.

Text

When changing the default text font in Engrave ▶ Music Fonts, Dorico no longer allows
existing font and paragraph styles to be updated to use non-existent bold or italic styles of the
chosen font.

Text

Under rare circumstances, nudging right-aligned text could cause the text to move
unexpectedly away from the staff; this has now been fixed.

Text

When inputting text in an East Asian language, the initial size of the text editor is now correct
and it grows correctly as more text is entered.

Text

System text no longer incorrectly responds to the Edit ▶ Flip command.

Ties

All the controls on the Ties page of Engraving Options for the number of spaces by which ties
are allowed to move in tight situations now use the correct units.

Time signatures

When filtering for time signatures, Dorico now only selects time signatures themselves, not
barlines.

Time signatures

When deleting music at the end of a flow, if the new end position of the flow coincides with an
open time signature, that time signature is now deleted, to avoid the final empty bar drawing
incorrectly.

Time signatures

When showing large time signatures centered on bracketed groups, Dorico no longer
sometimes incorrectly leaves an erasure background behind on the first staff in the bracketed
group.
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Issue

Time signatures

When showing large time signatures centered on bracketed groups, Dorico no longer
sometimes incorrectly leaves an erasure background behind on the first staff in the bracketed
group.

Transport

Beat divisions for a wider range of simple and compound time signatures now appear
correctly in the playback counter in the Transport.

Transport

Enabling or disabling the metronome click in the mini Transport now correctly updates the
click button in the Transport window.

Tremolos

Adjusting the Tremolo Y property for a whole note with a single-stem tremolo now correctly
updates the position of the tremolo strokes right away.

Tremolos

The option Maximum length of tremolo lines for unbeamed notes now takes effect as
expected.

Tremolos

When calculating the durations of notes played for unmeasured tremolos, ensure that the
played duration is the same regardless of the beat unit currently in force.

Tuplets

When deleting notes with Backspace during note input, Dorico will now correctly delete both
inner and outer tuplets if the parent tuplet in a nest of tuplets becomes empty.

Tuplets

Deleting all the notes from a tuplet but without deleting the tuplet itself no longer sometimes
cause the remaining tuplet bracket and its containing rests to disappear incorrectly.

Tuplets

Tuplets beamed across a beat boundary and system break no longer always draw a bracket
even if the Bracket appearance property is overridden.

Tuplets

Under some circumstances, tuplets created in an irregular bar longer than the prevailing time
signature could be padded with rests incorrectly; this has now been fixed.

User interface

Filenames containing an ampersand now display correctly in the File ▶ Open Recent
submenu.

User interface

Commands to move the score by a page at a time (for example, those mapped to Home and
End by default) now work correctly even when the page fills the viewport precisely.

User interface

When switching to Play mode, Dorico now ensures the mouse cursor is updated to match the
active tool in the Play toolbox.

User interface

The various commands in the Print category in Key Commands for exporting and printing
layouts are now correctly available from all modes.
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User interface

In dialog pages with multiple Advanced Options sections, only the first section would be
automatically expanded when searching for terms found within the page; this has now been
fixed.

User interface

It is now possible to use Fit… zoom levels when editing page templates in Engrave mode.

User interface

If Window ▶ Hide/Restore Zones is active, using Ctrl+8 to show the lower zone now correctly
works at the first time of asking.

User interface

When toggling View ▶ Full Screen, if the project window was previously maximized, that state
is now correctly restored.

Vertical spacing

In the specific situation that a frame is precisely 100% full, Dorico would not perform vertical
justification due to an incorrect boundary check; this has now been fixed.

Vertical spacing

The light blue shaded areas that show the top and bottom music frame margins in music
frames in Engrave mode now correctly reflect the values defined in Layout Options.

Voices

Dorico will no longer prune voices with no notes when opening an existing project if the voice
is assigned to a staff using independent voice routing and has an endpoint assigned.

VST plug-ins

When a VST plug-in’s interface is shown, it is now always correctly brought in front of the
Dorico project window (Windows only).

VST plug-ins

If you deactivate a VST plug-in, this state is now correctly restored when you save and
subsequently reopen the project.
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Known issues and solutions
Frequently asked questions
Answers to frequently asked questions about Dorico can be found online in the
Dorico forum.

Knowledge base
For the latest information about issues and solutions you may encounter when
running Dorico, please consult the Knowledge Base.

Key commands to transpose notes by an octave (Windows only)
The Intel Graphics Adaptor drivers used by many Windows computers define a
default key command to flip the screen by 90, 180 and 270 degrees via a shortcut
Ctrl+Alt+↑/↓/←/→ arrows.
Ctrl+Alt+↑/↓ option conflicts with the key commands in Dorico note input for
transposing notes by an octave.
For information about how to disable the default Intel Graphics Adaptor key
command, consult the Knowledge Base.
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