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About
Congratulations and thank you for using Dorico.
This document lists all update changes, fixes and improvements as well as known
issues and solutions for Dorico.
Please note that the known issues and solutions section contains issues that might
concern specific Dorico versions only. Please make sure to read through this
section before contacting Steinberg support.
Enjoy using Dorico!
Your Steinberg team
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Dorico 1.0.30
February 2017
This version contains the following improvements and issue resolutions.

Improvements
Accidentals
Accidentals are now listed in the Accidentals section of the Key Signatures and
Accidentals panel in Write mode in order of ascending pitch delta (i.e. accidentals
that lower the pitch are listed before those that raise the pitch). (STEAM-5545)
Auto-backup
Dorico now makes a backup copy of your project each time you save it. By default,
backups are stored in a folder called Backup Projects inside your chosen save
location (which is, by default, a folder called Dorico Projects in your user
account’s documents folder). A subfolder inside the backup location is created for
each project, and each time you save, that version is timestamped and placed in
that location. To conserve disk space, Dorico will keep only five backups of each
project by default, with the oldest backup being deleted as each new backup is
created. You can change the number of backup projects saved by setting Number
of backups per project in the Files group of the General page of Preferences.
To open a backup project, simply open it in the usual way, either by choosing it
from the File ▸ Open dialog or by double-clicking it in Windows Explorer or the
Finder. Dorico will open the backup project as if it were a new, untitled project, so
that you can choose where to save it and what to call it. (STEAM-5639)
Bar numbers
A new option Position bar numbers at start of system after clef and key
signature has been added to the Bar Numbers page of Layout Options,
switched off by default. When switched on, if a bar number would appear at the
start of the system, it will be positioned immediately to the right of the preamble at
the start of the system, rather than aligned with the initial systemic barline.
(STEAM-5513)
Barlines
A new thick barline type has been added. It can be created from the Barlines
section of the Bars and Barlines panel in Write mode, or by typing thick into the
Shift+B popover. (STEAM-5493)
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Brackets and braces
Two new options have been added to the Brackets and Braces page of
Engraving Options: (STEAM-5504)
 Brace distance from systemic barline allows you to control the default
distance of the brace from the initial systemic barline.
 Brace distance from bracket allows you to control the default distance of the
brace from the thick bracket line, if the Secondary bracket appearance option
is set to Brace.
Clefs
The Shift+C popover for adding clefs now accepts French names for common
clefs: sol for treble G clef, fa for bass F clef, ut5 for baritone clef, ut4 for tenor clef,
ut3 for alto clef, ut2 for mezzo soprano clef, and ut1 for soprano clef. (STEAM4582)
Color
More items in the score can now have their colors changed via the Properties
panel: slurs, tuplet brackets, ornaments, arpeggios, playing techniques, and holds
and pauses. (STEAM-5477)
It is now possible to create forzando dynamics with higher intensities than  by

Dynamics

typing e.g. fffz into the Shift+D popover.
Grace notes

 The interpretation of grace notes during playback has been improved. An
unslashed grace note of an eighth (quaver) or longer in duration will by default
be interpreted as a so-called long appoggiatura (as described in Robert
Donington’s The Interpretation of Early Music), being played on the beat of the
rhythmic note it precedes, and taking half of its duration (or half of its undotted
duration, if the rhythmic note is dotted). An unslashed grace note of a 16th
(semiquaver) or shorter in duration will be interpreted as a so-called short
appoggiatura, being played on the beat of the rhythmic note it precedes, but
being played as short as possible. (STEAM-5448)
 A new group of options has been added to the Timing page of Playback
Options, allowing you to specify whether single unslashed grace notes should
be played back as a long appoggiatura, and the threshold for the written
duration of the grace note below which it should be played back as a short
appoggiatura. You can also specify the exact duration of a short appoggiatura,
expressed as a fraction of the duration of a quarter note (crotchet) played at
120 quarters per minute, i.e. 0.5 seconds. (STEAM-5451)
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 A new option Horizontal offset from stem has been added to the Grace
notes section of the Notes page of Engraving Options, allowing you to specify
the default horizontal offset of the grace note slash relative to the note stem.
(STEAM-5534)
Hub window
A new Tutorials tab has been added to the left-hand pane in the Hub window,
which provides a list of the latest videos added to the Dorico YouTube channel.
There are now many useful tutorial videos available to help you learn how to use
the software.
A new Videos button has also been added at the top of the Hub window, which
links directly to the Dorico YouTube channel.
Instruments
The following changes have been made to transposing woodwind and brass
instruments:
 All common (and some uncommon) horn transpositions are now provided, with
variants both with and without key signatures.
 Bass in B♭ and E♭ now have variants that show a bass clef either at transposed
pitch or at concert pitch.
 Sousaphone in B♭ and E♭ now have variants that show a treble clef at
transposed pitch.
 Variants of euphonium in B♭, baritone horn in B♭ and tenor trombone in B♭ that
show bass clef at concert pitch without an octave transposition have been
added.
 Piccolo in D♭, soprano flute, contrabass flute, tenor trumpet in E♭, bass trumpet
in C (also known as valve trombone), alphorn in F♯, cornett (or zink) in C and D
have all been added.
An organ instrument that uses only two staves (manuals only) and an SATB choir
set up for two staves have also been added. (STEAM-5702)
Lyrics
A new option Punctuation for verse numbers has been added to the Lyrics page
of Engraving Options, allowing you to specify whether verse numbers should be
appended with a period (full stop). (STEAM-5492)
Players
The option Uses custom player order on the Players page of Layout Options is
now fully functional, and allows you to change the order of players in one layout
from the order specified in the Players panel in Setup mode. (STEAM-3686)
Dorico Version History
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Popovers
Except for the Shift+K key signatures and Shift+T tempo popovers, all the
popovers in Write mode are now case insensitive. (STEAM-5532)
Printing
A new option Collate copies has been added to the right-hand panel in Print
mode, switched on by default. When switched on, Dorico will print all pages of
each copy of each layout to be printed in sequence; when switched off, Dorico will
print the desired number of copies of the first page, then the desired number of
copies of the second page, and so on. (STEAM-5491)
Project Info
The File ▸ Project Info dialog now defaults to showing you the information for the
current flow, rather than the entire project. If you select a flow in the Flows panel in
Setup mode, if you invoke the dialog either from the File menu or from the rightclick context menu, the dialog will open to the page for the first selected flow. If no
flows are selected in Setup mode, the dialog will instead open to the page for the
current flow you are editing, which is denoted by the flow whose name is shown in
the document title bar. (STEAM-5530)
Rests
Dorico automatically fills the gaps between notes with rests of the appropriate
duration. These are known as implicit rests, because they are implied by the gaps
between the notes. Rests that are explicitly entered during note input using Force
Duration, or rests that were explicitly created by way of importing a MusicXML file,
are known as explicit rests. Explicit rests cannot be suppressed using the Starts
voice and Ends voice properties. Dorico 1.0.30 introduces new tools for working
with rests.
First, a new command Edit ▸ Remove Rests has been added, which will set the
Starts voice and Ends voice properties appropriately such that any rests in the
selection are removed. If you see extra rests arising from secondary voices that you
would prefer did not appear, simply select them individually, or select a range of
bars containing rests that you would prefer did not appear, and choose Edit ▸
Remove Rests. (STEAM-5213)
Second, a new option View ▸ Note and Rest Colors ▸ Implicit Rests has been
added. When switched on, implicit rests will be colored gray in the score. Explicit
rests will continue to be shown in black when this option is switched on.
This option can be useful in diagnosing why, for example, a rest does not disappear
when you set the Starts voice or Ends voice property on a nearby note: once you
identify a rest as an explicit rest, you can delete it, and the implicit rest that
replaces it will respect the Starts voice or Ends voice property. (STEAM-5525)
Dorico Version History

Page 7

Steinberg Media Technologies GmbH

It is also now possible to suppress implicit rests before the first note in a voice by
setting Starts voice on the first note in that voice, which will suppress all rests
before that note to the start of the flow. You can also suppress implicit rests after
the last note in a voice by setting Ends voice on the last note in that voice, which
will suppress all rests after that voice. It is also possible to suppress implicit rests
in any gaps between different voices that might occur in the middle of a flow,
though this will require you to set Ends voice on the last note of the first voice, and
Starts voice on the first note of the second voice, if the gap between those notes
spans multiple barlines. (STEAM-5565)
Tempo
A new Circa appearance option has been added to the Absolute Changes group
on the Tempo page of Engraving Options, allowing you to choose whether a
metronome mark that shows an approximate tempo should show the equals sign
between the note value and the approximate indication. (STEAM-5495)
Text
A new option Position of text relative to other items has been added to the Text
page of Engraving Options, which is set to Avoid collisions in new projects. This
option allows Dorico to move text items vertically to avoid collisions with other
items. This will not be enabled by default in existing projects, since you may have
already moved text items to avoid collisions, but you can enable it if you want to.
(STEAM-5014)
Tremolos
A new group of options has been added to the Timing page of Playback Options
to control the playback of unmeasured tremolos. You can specify the minimum
number of tremolo strokes that will be interpreted as unmeasured in playback. This
considers both the number of tremolo strokes and the number of beam lines that
would be used for the note; for example, if the option is set to require three tremolo
strokes, an eighth note (quaver) with two tremolo strokes will be played as
unmeasured, because the eighth note’s single beam is included in the calculation.
You can also specify the default length of the notes in an unmeasured tremolo,
expressed as a fraction of the length of a quarter note (crotchet) played at 120
quarters per minute, i.e. 0.5 seconds in length. (STEAM-5435)
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Issues resolved
ID #

Issue
Audio export: A problem that would result in exported audio files being exported to the correct length but

STEAM-5226

ending up either mostly or completely silent if the project had been played back completely before
exporting audio has been resolved.

STEAM-5537

Accidentals: Attempting to add a new glyph to an accidental definition without a glyph selected in the list
of glyphs no longer causes a crash.
Accidentals: The accidentals in the Accidentals section of the Key Signatures and Accidentals panel

STEAM-5413

now stick on during note input in the same way as the accidentals in the notes panel on the left-hand side
of the window.
Arpeggio signs: The spacing of arpeggio signs relative to cross-staff notes has been improved. In

STEAM-5496 &
STEAM-5457

particular, if two cross-staff arpeggio signs exist at the same rhythmic position on different instruments,
each arpeggio sign will now be offset only by the width of the accidentals etc. on the instrument to which
the arpeggio sign applies, rather than the width of accidentals on all instruments that have arpeggio signs
at that rhythmic position.

STEAM-5490

STEAM-5485

STEAM-5475

STEAM-5112

STEAM-5617

STEAM-5695

STEAM-5573

STEAM-5518

STEAM-5503

STEAN-5685

STEAM-5494

STEAM-5567

STEAM-5500

Dorico Version History

Arpeggio signs: Arpeggio signs no longer move slightly to the left or right while dragging them in Engrave
mode.
Arpeggio signs: The length of cross-voice arpeggio signs is now correctly updated when the pitches of
the notes changes sufficiently that the highest or lowest note is now in a different voice.
Arpeggio signs: The length of cross-staff arpeggio signs now updates correctly after the distance
between staves changes.
Articulations: The appropriate properties are now displayed in the Articulations of duration group of the
Properties panel depending on whether a tenuto is present.
Audio export: Exporting to WAV will now always use the sample rate used by the current audio device;
exporting to MP3 will always export at 44.1kHz.
Bars: In rare circumstances, it was possible for deleting bars using the Shift+B popover to cause Dorico
to crash. This problem has been resolved.
Beams: Beam direction is no longer affected by the staff positions of rests within the beamed group,
unless stemlets are in use.
Dynamics: A problem that prevented immediate dynamics immediately following a gradual dynamic (a
crescendo or diminuendo) from playing back correctly has been resolved.
Dynamics: Typing e.g. f cresc. into the Shift+D dynamics popover will no longer discard the specified
gradual dynamic when popover is closed.
Dynamics: Typing sf or sfz into the popover will now set the rfz/sfz style property as appropriate, so the
dynamic will match the popover input.
Exporting graphics: A problem whereby graphics would not be correctly exported if the name of the layout
to be exported contained one or more characters that are illegal in filenames has been resolved.
Exporting graphics: PDFs exported with the Mono option set are now always correctly exported in a true
monochrome color space.
Layouts: Empty part layouts numbered higher than 10 are now correctly renamed when assigning players
to them.
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ID #
STEAM-5476

STEAM-5464

STEAM-5619

Issue
Layouts: Changes made to player groups in the Players panel are now reflected immediately in the open
layout, instead of incorrectly requiring the layout to be closed and opened again.
Lyrics: Attempting to start lyric input with the final barline selected will no longer cause a crash.
Lyrics: A problem whereby lyrics could sometimes be pasted out of order when copying and pasting
between flows or projects has been resolved.

STEAM-4954

Mixer: Mute/Solo buttons now work correctly in the Mixer, and new buttons have been added to clear all

STEAM-4994

Mute and Solo states.

STEAM-4993

STEAM-5285

Mixer: The state of the insert and send slots in the Mixer, including whether each is enabled or disabled, is
now correctly saved and restored when saving and reopening a project.
Mixer: The Mixer now correctly updates in response to changes in the project, for example adding or
removing players and instruments, without requiring that the window be closed and reopened.
Mixer: The responsiveness of the faders in the Mixer has been improved. It is no longer possible to move

STEAM-5621

the faders with a two-fingered swipe gesture, but it is still possible to use a sideways swipe gesture to
scroll the Mixer window.

STEAM-5610

STEAM-5482

STEAM-5635

STEAM-5602

STEAM-5728

STEAM-5481

STEAM-5577

Mixer: The Mixer is no longer forced to be on top of all other windows (Windows only).
Mixer: It is now possible to route signal from any instrument output to the global effects channel;
previously, this routing would only work for the default HALion Sonic SE 2 plug-in.
Multi-bar rests: Gradual tempo changes (such as rit./accel.) no longer cause multi-bar rests to break
incorrectly.
Multi-bar rests: Deleting music from a part layout in which two or more instruments are included and multibar rests are enabled no longer causes a crash under certain circumstances.
Note input: When selecting notes in instruments whose sounds require a transposition of one or more
octaves in playback (e.g. double bass, bass guitar), the correct octave transposition is now applied.
Note input: You can now correctly override the choice of octave for the first note of a chord when
inputting a chord using the computer keyboard in step input.
Note input: It is now possible to set key commands for double sharp and double flat accidentals that can
be used to specify those accidentals during note input.
Note input: The initial duration chosen when note input starts will only be taken from the selected note if a

STEAM-5600

single note is selected; if there are multiple notes and rests selected, or if the selected rest is longer than
a quarter note (crotchet) in duration, the initial duration chosen will be a quarter note (crotchet).

STEAM-5487

STEAM-5543

STEAM-5526

STEAM-5460

Dorico Version History

Note input: Switching on Lock Durations during note input now correctly switches off rests, tuplets, or
grace notes, if any of those tools were engaged.
Notation options: Some options from the Notation Options dialog were not correctly applied to new
flows or new projects after having been saved as defaults; this problem has now been resolved.
Ornaments: When selecting a mordent or turn and editing it by clicking another ornament type in the
Ornaments panel in Write mode, the correct button now shows as selected in the panel after the edit.
Playback: Dorico no longer crashes if it attempts to play notes lower than MIDI note 0.
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ID #
STEAM-5522

STEAM-5456

STEAM-5367

STEAM-5498

Issue
Playback: Starting playback in a large project is now considerably faster. This also reduces the time it
takes to open larger projects.
Playback: A problem that would cause the playback of legato (either triggered by slurs or the legato
playing technique) to be overridden, so that there is no audible legato effect, has been resolved.
Playback: The nat. playing technique now correctly resets all other active playing techniques.
Playback: Grace notes at the same position in multiple voices or instruments are now correctly played at
the same time.
Playback: Only those flows assigned to the current layout are played back, in the order in which they are

STEAM-5533

listed in the Flows panel in Setup mode, rather than relying on the presence of a full score layout (the
absence of which would previously have caused there to be no playback at all).

STEAM-5638

STEAM-5396

STEAM-5721

STEAM-5595

AD-281

STEAM-5750

Playback: Audio devices with ampersand characters in their names can now be chosen correctly in the
Device Setup dialog.
Playback: Keyswitch notes are now correctly cleared when playback stops, so that starting playback again
does not sometimes result in Dorico playing the wrong technique.
Playback: Keyswitch notes and MIDI controllers are now correctly chased when starting playback from the
middle of a flow.
Playback: When opening an existing project, the correct playback data for the current layout is now set up
immediately, and switching the Flow drop-down in Play mode correctly updates the event display.
Playback: A problem whereby Waves NX plug-ins would not load or correctly display their user interface
has been resolved.
Playback: Reverb send level is now correctly set post-fader rather than pre-fader.
Players: When changing between two instruments with different numbers of staves held by the same

STEAM-5647

player, if the option to allow one staff of a multi-staff instrument to be hidden if empty is enabled, Dorico
no longer shows both staves of the two-staff instrument unless both contain music.

STEAN-5616

STEAM-5549

STEAM-5711

STEAM-5640

STEAM-5615

STEAM-5716

STEAM-5656

Dorico Version History

Players: Certain edits to music at or near a transition between different instruments held by the same
player can no longer cause the following system to disappear temporarily.
Players: Changing the instrument held by a player no longer causes any arpeggio signs written for the
original instrument to be lost.
Players: Under rare circumstances it was possible for Dorico to crash when moving a player from one
group to another in Setup mode. This has now been resolved.
Printing: It is no longer necessary to switch on the View options checkbox in the Annotations section of
the print options panel to print colored objects in color.
Printing: Typing a page number into the To spin control to determine the page range and then hitting Tab
to move the focus to another control no longer causes a crash under some circumstances (Mac only).
Printing: Reopening a project that was last saved with Print mode active will now correctly show the print
preview immediately, without requiring you to switch to a different mode and back again.
Properties: A problem whereby selecting a bar containing a playing technique that is otherwise empty
could cause Dorico to crash has been resolved.

Page 11

Steinberg Media Technologies GmbH

ID #

Issue
Rests: Under some circumstances, bar rests that appear when notes that had been crossed to an

STEAM-5563

otherwise empty staff from the staff above or below could appear at the wrong vertical position. This has
now been resolved.

STEAM-5478

STEAM-4875

STEAM-5538

Rests: Deleting a tuplet containing rests now always correctly renotates the rests that remain.
Rests: Under some circumstances, removing the Starts voice property from the first note in a tuplet would
not cause any suppressed rests earlier in the tuplet to reappear right away. This has now been resolved.
Staff spacing: Edits to staff spacing are no longer incorrectly removed if the layout whose staff has been
edited has been viewed in galley view during the current editing session.
Text: A problem whereby double-clicking a text item to edit it would not work in certain circumstances
involving music in multiple frame chains has been resolved.

STEAM-5323

STEAM-5090

STEAM-5470

STEAM-5609

STEAM-5527

Time signatures: A problem whereby setting the Ends interchangeable property on a time signature
would not immediately cause the following bars to be redrawn correctly has been resolved.
Time signatures: Deleting and recreating a time signature change within an interchangeable range will
now have the correct effect on the time signatures that come after it.
Time signatures: Rests are now correctly grouped according to the instrument-specific time signature, if
one is present.
Transposing: Making a selection of music at the beginning of a flow that starts with a C major or A minor
key signature will now correctly allow that key signature to be transposed.
Tremolos: When selecting a tremolo with four strokes, the correct button now shows as selected in the
Tremolos panel in Write mode.
Tremolos: The playback of measured tremolos has been improved, such that the number of tremolo

STEAM-5564

strokes now determines the note value of the repeated notes (one stroke = eighth note, two strokes =
16th note, etc.), instead of simply dividing the written note value by two, four, etc.

STEAM-5510

Voices: When you use Edit ▸ Stem ▸ Swap Voice Order to swap the order of two voices, the resultant
Voice column index values now appear correctly in the Properties panel.
User interface: The keyboard focus is now always returned to the main document area after clicking any of

STEAM-5474

the buttons in the right-hand panels in Write mode, so that all key commands operate on the music as
expected without having to click into the music area again.

STEAM-5471

STEAM-3033

STEAM-4934

STEAM-5614

STEAM-5692

STEAM-5605
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User interface: A problem whereby the scrollbars in the right-hand panels in Write mode could either
appear the wrong height (Mac and Windows), or too wide (Windows only), has been resolved.
User interface: It is now possible to assign key commands to key combinations that normally act as dead
keys producing combining diacritics, such as Alt+E (Mac only).
User interface: The way scroll bars appear in Dorico’s panels has been revamped to ensure that they only
appear when necessary.
User interface: Changes to key commands now take effect immediately, even if no project window is
open.
User interface: Changing the selection of layouts in Layout Options without having made any changes to
any of the options no longer incorrectly prompts that there are unsaved changes.
User interface: When running in full screen, menus that pop up from buttons (e.g. in the status bar at the
bottom of the window) no longer appear too high, as if the Dock were visible (Mac only).
Page 12
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ID #
STEAM-5620

STEAM-5638

STEAM-5574
STEAM-5471
STEAM-5321
STEAM-5590

Issue
User interface: When attempting to open many projects at the same time, Dorico no longer sometimes
crashes.
User interface: Audio devices with an ampersand (&) in their name now appear correctly in the Device
Setup dialog.
Localisation: Dorico will now start correctly if your user account name uses Japanese or other CJK
Unicode characters (Windows only).
Localisation: Several issues related to assigning key commands using specific key combinations on
French, German, Italian, Japanese and Russian keyboards have been resolved.
Localisation: The key command Ctrl+A (Windows) or Command-A (Mac) was missing from the default
sets of key commands in languages other than English; this has now been resolved.

STEAM-5585

STEAM-5629

STEAM-5579

Dorico Version History

Performance: A problem whereby commands (e.g. notes input in quick succession) could be executed in
the wrong order or skipped has been resolved.
Performance: The speed of note input and editing in projects containing multiple flows has been
significantly increased.
Performance: The speed of note input and editing in flows that have a lot of trailing empty bars has been
significantly increased.
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Dorico 1.0.20
December 2016
This version contains the following improvements and issue resolutions.

Improvements
Performance improvements
Building on the improvements in Dorico 1.0.10, this update includes further
significant improvements to the performance and reliability of Print mode. For
example, selecting multiple layouts in Print mode is now considerably faster.
(STEAM-5386)
Arpeggio signs
A new Arpeggiation section has been added to the Ornaments panel in Write
mode, allowing the creation of arpeggio signs indicating upwards and downwards
arpeggiation, as well as a non arpeggio bracket line indicating that a chord should
not be arpeggiated.
To create an arpeggio sign on a chord in a single voice, select any notehead in the
chord, and either select the desired arpeggio sign from the Ornaments panel, or
type Shift+O to open the ornaments popover, in which you can type arp (or
arpeggio) for an upwards arpeggio, arpdown (or arpeggiodown) for a
downwards arpeggio, or nonarp (or nonarpeggio) for a non arpeggio sign. Dorico
will create the arpeggio line spanning all of the notes in the chord. Dorico will not
create an arpeggio sign if only a single note exists in the selected voice. Arpeggio
signs can also be created during note input in chord mode using the ornaments
popover.
To create an arpeggio sign that spans chords in multiple voices (e.g. across both
staves of a piano or harp instrument), select any notehead in the first voice, then
hold Ctrl (Windows) or Command (Mac) and select any notehead in the second
voice, then create the arpeggio sign either using the panel or the popover, as
described above.
Dorico will automatically adjust the length of the arpeggio sign as the pitches of the
notes in the voices to which the sign belongs change, or as notes are added to or
deleted from the chords, and will automatically delete the arpeggio sign when only
a single note remains at that rhythmic position in that voice.
By default, any grace notes at the same rhythmic position as an arpeggio sign will
be positioned to the left of the arpeggio sign. To make the arpeggio sign appear to

Dorico Version History
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the left of the grace notes, select the arpeggio sign and set the Arpeggio before
grace notes property in the Properties panel.
Downwards arpeggio signs have an arrowhead at the bottom of the line by default,
but upwards arpeggio signs have no arrowhead by default. Arpeggio signs can
alternatively show a Couperin-style swash at their top or bottom. To override an
individual arpeggio sign, select it and open the Properties panel, then set the Sign
end property. The length of arpeggio signs can also be adjusted on a case-bycase basis in Engrave mode.
Options controlling the default appearance of arpeggio signs have been added to
the new Arpeggio Signs page of Engraving Options.
Arpeggio signs do not yet have any effect in playback, but this is planned for a
future update.
Brackets and braces
A new option Additional vertical protrusion beyond top or bottom of staff has
been added to the Design group on the Brackets and Braces page of Engraving
Options, allowing the thick vertical line of the bracket to be lengthened slightly if
needed to ensure a good join with the chosen bracket tip glyphs in the current
music font. (STEAM-5408)
Instruments
A keyless timpani instrument type, i.e. a timpani that does not use a key signature
and instead shows accidentals for each note as required, has been added and can
be chosen from the instrument picker. (STEAM-5339)
Key commands
 It is now possible to change the default key commands for changing the pitch of
notes (Alt+up/down arrow to move by step, Shift+Alt+up/down arrow to move
by chromatic step, and Ctrl+Alt+up/down arrow to move by octave). These
commands can now be found in the NoteEdit category. (STEAM-5453)
 It is also now possible to assign key commands for Edit ▸ Stem ▸ Force Stem
Up, Force Stem Down and Remove Forced Stem. These commands can now
be found in the Edit category. (STEAM-5454)
Lyrics
A new Italic property has been added to the Lyrics group in the Properties panel,
allowing any non-italic lyric to be made italic if necessary, for example for
occasional words in a different language, or vocalizations interspersed within the
text. (STEAM-5404)
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Music fonts
Dorico now reads the JSON metadata files for SMuFL-compliant fonts from the
locations recommended by the SMuFL specification:
 Windows: C:\Program Files\Common Files\SMuFL\Fonts\
 Mac: /Library/Application Support/SMuFL/Fonts/
Dorico will load the JSON file if it is named fontname.json (e.g. Bravura.json) and
located inside a folder called fontname (e.g. Bravura) in the appropriate path for
the operating system.
If Dorico can load the JSON metadata file correctly, then the font will appear in the
list of available music fonts in Engrave ▸ Music Fonts. (STEAM-2290)
Note input
To create a time signature or key signature that applies only to the staff on which
the caret is currently located, enter the time signature or key signature into the
Shift+M or Shift+K popover as usual, and type Alt+Return (instead of Return
alone) to confirm the item to be created. (STEAM-5422)
Notes
A new option Stem direction for notes on the middle line of the staff has been
added to the Stems group on the Notes page of Engraving Options, allowing you
to choose whether Dorico should use musical context (i.e. the staff positions of
notes preceding and following the notes on the middle line of the staff) or a fixed
default to determine the stem direction of notes on the middle line of the staff.
(STEAM-5348)
Ornaments
A new option Horizontal gap between trill marking and trill extension line has
allowing you to determine the distance between the  sign and the extension line
been added to the Trills group on the Ornaments page of Engraving Options,

to its right.
Page layout

A new Rastral size menu has been added to the Space Size group on the Page
Setup page of Layout Options, allowing the specification of staff size according to
the rastral sizes used in traditional music engraving. The largest size is Size 0
(9.2mm or 0.36”), and the smallest size in Size 8 (3.7mm or 0.15”), and the default
staff size in a new project is now Size 3 (7mm or 0.28”). It is naturally still possible
to choose any custom size, as before, by editing the Space size value directly.
(STEAM-5353)
Two new options have been added to the Hide Empty Staves group on the
Vertical Spacing page of Layout Options:
Dorico Version History
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 Allow individual staves of multi-staff instruments to be hidden: When
switched on, Dorico will allow (say) the left-hand staff of a piano instrument to
be hidden on a system on which it has no music; when switched off, the piano
will only be hidden on a system if both staves can be hidden. (STEAM-5382)
 Players excluded from hide empty staves: This provides a list of all of the
players in the current layout, and allows you to specify a list of players that
should never be hidden, even if their staves are empty throughout a system.
(STEAM-4755)
Playback
 A new Playback Options dialog has been added to the Play menu. This dialog
contains options to determine how Dorico should interpret specific markings
during playback, such as the percentage by which the written duration of notes
should be extended under a slur or when encountering a legato playing
technique, by how much the dynamic should be increased when playing an
accent or marcato articulation, and so on. The dialog also includes an initial set
of options for beat stress (the amount by which the dynamic should be
increased on primary and secondary beats in the current meter) and for
humanization of dynamic level and note start position.
 Single- and multiple-note tremolos now play back. Measured single-note and all
multiple-note tremolos are played back directly by rendering additional note
events, while unmeasured single-note tremolos can be played back using
unmeasured tremolo samples if they are provided by the VST Expression Map in
use for the instrument. (STEAM-3904)
 Slurs and the legato playing technique are now played back by extending the
duration of all but the last note under a slur. (STEAM-5148)
 Grace notes now play back. Any number of slashed and unslashed grace notes
at present all play back immediately before the rhythmic note they precede,
stealing time from the preceding rhythmic note. Playback of a single unslashed
grace note, taking half the written duration of the rhythmic note that follows, and
stealing time from that following rhythmic note, will be added in a future update.
 A new option Show playhead when stopped has been added to the Play
group on the General page of Preferences. When switched on, the playhead
(vertical green line) will appear both during playback and when stopped; when
switched off, the playhead will appear only during playback. (STEAM-4718)
Preferences
The General page of Preferences has been organized into groups of related
options.
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Rests
A new option Bar rests in additional voices has been added to the new Rests in
additional voices group on the Rests page of Notation Options. In new projects,
this option is set to Omit bar rests, which means that when an additional voice
(typically a down-stem voice) stops, any subsequent bars in which that voice has
no notes or chords prior to its reappearance will not be padded with bar rests. This
reduces the number of occasions you would have to search backwards through
the music to set the Ends voice property on the last note in the voice, which might
be dozens or even hundreds of bars earlier.
If you would prefer that Dorico continue to pad all intervening bars with bar rests,
set the new option to Show bar rests, which will also be the value chosen in any
projects created in versions of Dorico earlier than 1.0.20.
Furthermore, when this new option is set to Omit bar rests, bar rests no longer
appear in bars where the only notes and chords present have been crossed from
another staff. (STEAM-5212, STEAM-4831)
In addition, a new option Allow dotted rests equal to the length of a compound
beat has been added to the Compound Time Signatures group on the Rests
page of Notation Options. When set to Allow dotted rests, a rest of a dotted
quarter (dotted crotchet) in 6/8 will be rendered as a single dotted quarter rest; if it
is set to Split at beat subdivisions, it will be rendered as a quarter (crotchet) rest
followed by an eighth (quaver) rest. (STEAM-5109)
Finally, it is now possible to create explicit bar rests during note input. Either click
the new Insert Bar Rest button in the Bars and Barlines panel in Write mode, or
type rest into the Shift+B popover. (STEAM-5036)
Templates
The Brass band template has been improved, with corrected staff labels for the
cornet and horn instruments, and appropriate clefs for the trombones. (STEAM5334)
Tempo
It is now possible to control the appearance of absolute and gradual tempo
changes independently in Engrave ▸ Font Styles. Absolute, relative and reset
tempo markings use the Immediate tempo text font style, while gradual tempo
changes used the Gradual tempo text font style. (STEAM-5387)
Views
When changing view type from galley view to page view, or vice versa, if there is a
selection, Dorico now attempts to center the selected item or items in the new
view. (STEAM-5025)
Dorico Version History
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Issues resolved
The following table lists all issues that have been resolved in this version:
ID #
STEAM-5344

STEAM-5269

Issue
Copy and paste: Notes within tuplets that have been created with Force Durations set now retain their
forced duration when pasted.
Copy and paste: Using R to repeat a selection no longer sometimes pastes items (such as dynamics) in
the wrong location.
Dynamics: Dynamics between the two staves of a keyboard instrument are now correctly centered. The

STEAM-5414

option Allow dynamics between braced staves to violate minimum distance by n spaces has been
removed from the Dynamics page of Engraving Options.

STEAM-5403

STEAM-5391

STEAM-5380

Holds and pauses: Caesuras at the end of a bar now cause multi-bar rests to break at the bar in which
they appear, rather than at the following bar.
Holds and pauses: Caesuras that precede a change of time signature or key signature no longer cause
the time or key signature to be spaced incorrectly relative to the barline.
Instrument changes: Items that apply to the whole system, such as tempo markings, rehearsal marks, etc.,
now appear correctly above the top staff when the top staff uses instrument changes.
Key signatures and accidentals: Setting a non-Western accidental on a note no longer incorrectly also

STEAM-5352

sets the same accidental on the note in transposing layouts; now, the accidental is only set in transposing
layouts if the relative offset between the concert and transposed pitch notes are identical.

STEAM-5341

Key signatures and accidentals: Notes with non-Western accidentals now behave correctly when
repitched, and do not continue to show the same accidental even if the offset of the pitch changes.
Key signatures and accidentals: The rule that every tonality system must have an accidental type that fulfils

STEAM-5162

the role of the natural (i.e. does not change the pitch) is now enforced, and it is no longer possible to
delete any built-in accidental type, or any accidental type that is in use in the project.

STEAM-5383

Key signatures and accidentals: Accidentals types that contain graphics now display correctly in the
Accidentals section of the Key signatures and accidentals panel in Write mode.
Key signatures and accidentals: The option Notes following a change of key signature that shows

STEAM-5347

cancellation naturals on the Accidentals page of Notation Options now works as expected. This option
only takes effect if Dorico will show cancellation naturals at a change of key, as determined by the two
options immediately above this one in the dialog.
Key signatures and accidentals: A problem whereby instruments that don’t show a key signature (e.g.

STEAM-5338

Horn in F) would under some circumstances not show the required accidentals on some notes in extreme
keys (i.e. key signatures of 7 sharps or flats) has been fixed.

STEAM-5264

STEAM-5192

Key signatures and accidentals: Cancellation naturals now appear if necessary at changes of key arising
from changing between instruments with different transpositions.
Key signatures and accidentals: Changes of key that occur in the middle of a bar now correctly take effect
on the notes that follow the key signature before the end of the bar.
Key signatures and accidentals: When importing MusicXML files that use other accidentals than the

STEAM-5274

standard 12-EDO or 24-EDO accidentals, Dorico now automatically creates an appropriate tonality
system in the resulting project.

STEAM-5426
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ID #
STEAM-5255

STEAM-5074

STEAM-5354

STEAM-5318

STEAM-3035

Issue
MusicXML import: Dorico no longer crashes when encountering a MusicXML file that specifies an invalid
number for slur elements.
MusicXML import: Dorico no longer fails to open compressed MusicXML (.mxl) files that contain internal
filenames that use extended Unicode characters.
Navigation: Using up/down arrow to navigate to the staff above/below from a selected bar rest no longer
sometimes skips over the next staff.
Navigation: Using Ctrl+up/down arrow to navigate to the system above/below now works correctly, for
any number of staves in the system.
Note input: Specifying that the next note to be input should explicitly be above or below the previous note
now works more reliably.
Note input: Moving the caret to the staff above/below with up/down arrow now correctly takes into

STEAM-5351

account whether the caret is at a tuplet position on the original staff, and moves to an appropriate position
on the destination staff.

STEAM-5430

Note input: When inputting notes into transposing instruments in a transposing layout, notes are no longer
sometimes input in successively higher octaves for no discernible reason.
Note spacing: Tempo markings are no longer considered when determining the width of multi-bar rests,

STEAM-5359

unless another tempo marking in a later bar would collide with a previous tempo marking, preventing some
multi-bar rests from being made much wider than necessary.

STEAM-5402

Notes: Augmentation dots are no longer hardwired to be drawn using Bravura, so if you choose to use
another music font via Engrave ▸ Music Fonts, you will see the appropriate glyph from the new font.
Notes: Pairs of opposing voices where notes in both the left- and right-hand columns show an accidental

STEAM-5163

on the same staff position, and where the note in the right-hand column closest to a note in the left-hand
column is at an adjacent staff position, are no longer offset by an unexpectedly large distance.
Notes: Syncopated patterns of the form short-dotted long (e.g. quarter-dotted half in 4/4) are now

STEAM-4989

notated according to the options set in Notation Options regardless of whether or not the dotted long
note is also tied out of the bar.
Page layout: Changing the master page set of a layout on the Page Setup page of Layout Options is

STEAM-5357

now reflected immediately in the display in the Master Pages section of the right-hand panel in Engrave
mode.

STEAM-5187

Page layout: Under rare circumstances, staff labels would sometimes fail to update after undoing an edit
that results in the point at which an instrument change occurs changing. This has now been resolved.

STEAM-5287

Playback: Dynamics are no longer ignored during playback if the flow begins with a rest.

STEAM-5394

Playback: Multiple dynamics on the same note are now played back more sensibly.

STEAM-5369

Playback: Accents now play back correctly when notes with accents alternate with notes without accents.

STEAM-5371

Playback: Playing techniques on the very first note of the flow now play back correctly.

AD-269
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ID #
AD-253

AD-260

STEAM-5401

STEAM-5356

STEAM-5385

STEAM-5399

STEAM-5370

STEAM-5406

STEAM-4963

STEAM-4971

STEAM-5358

STEAM-5434

STEAM-5177

STEAM-5395

STEAM-5381

STEAM-5263

Issue
Playback: A problem whereby the VST audio engine could crash when used on a computer with on-board
Realtek sound hardware has been fixed (Windows only).
Playback: When reopening a saved project that uses Kontakt, a burst of static is no longer sometimes
emitted as the project loads (Mac only).
Rests: It is now possible to set properties, including the staff position, of bar rests correctly once more.
Selections: Edit ▸ Select All now selects only the music in the current flow, not across all flows in the
project.
Slurs: Slurs are no longer temporarily incorrectly positioned if Edit ▸ Reset Appearance is invoked when
both the slur itself and the notes at either end of the slur are selected.
Staff spacing: Using Alt+click-drag to drag a staff containing one or more instrument changes now works
correctly.
Staff spacing: Copy Staff Spacing will now work even if the user has not made any adjustments to the
staff spacing on the source page.
Text: Pasting text terminated by a null character (e.g. from a text block in Finale) into Dorico will no longer
cause the project to become corrupted when saving.
Text: Changing the stretch for text in a text item or text frame now correctly changes the shape of the
characters themselves, rather than merely the distance between characters (Mac only).
Text: Changing the stretch for text in a text item or text frame now displays correctly on screen and is
reproduced correctly both when printing and when exporting PDF graphics (Windows only).
Text: Changing the point size of multiple selected paragraphs using the controls in the text editing
popover now works correctly, rather than changing the size of only the first selected paragraph.
Text: The size of the text editor is no longer incorrect when editing a text item belonging to a staff that
uses a non-default staff size.
Ties: When Tie endpoint positioning in chords is set to Outermost ties above/below noteheads,
others between, Dorico no longer sometimes incorrectly offsets the wrong tie in multi-voice contexts.
User interface: Message boxes spawned from one of Dorico’s options dialogs no longer cause the
options dialog itself to disappear behind the main project window (Windows only).
User interface: It is no longer possible under some circumstances to show more than one instance of the
Layout Options or Notation Options dialog for a given score simultaneously.
User interface: The color picker dialog no longer increases in height slightly with each invocation within a
session (Mac only).
User interface: It is no longer possible to click the various Save as Default buttons in the Layout Options

STEAM-5392

and Notation Options dialogs when more than one layout or flow respectively is selected; being able to
do this in earlier versions could result in the saved options data being incomplete or inconsistent.

STEAM-4527

STEAM-5393
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ID #
STEAM-5360
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Dorico will no longer crash on start-up if it is unable to create the user’s chosen default project save
folder.
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Dorico 1.0.10
November 2016
This version contains the following improvements and issue resolutions.

Improvements
This maintenance update introduces the following improvements:
Performance improvements
 The speed of note input, and undoing note input, has been substantially
increased.
 The speed of changing the pitch of a selection of notes using Alt+up/down
arrow has been substantially increased.
 The speed of adding and removing players in Setup mode has been
substantially increased.
 Unnecessary screen redraws during editing operations have been eliminated,
providing a substantial improvement in the speed of redraw during editing
operations.
 The speed of creating a new project from a template has been substantially
increased.
 The speed of entering and working within Print mode has been substantially
increased.
Articulations
A new group of options Slurs on the Articulations page of Engraving Options
allow you to determine whether articulations of force (accent, marcato) or
articulations of stress (stress, unstress) should be positioned inside or outside slur
endpoints.
A new option Position of tenuto relative to tied notes has been added to the
Ties group on the Articulations page of Engraving Options, allowing you to
choose whether tenuto articulations should be positioned on the first or last note of
a chain of tied notes by default. An additional property has also been added to
allow this default to be overridden for an individual tenuto.
Beams
A new option has been added to the Advanced Options section of the Slants
group on the Beams page of Engraving Options, allowing you to specify whether
beams containing repeated patterns of pitches should be allowed to have slants, or
should always be horizontal.
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Brackets and braces
A new option has been added to the Approach group on the Brackets and
Braces page of Engraving Options, allowing you to specify whether groups
consisting of a single staff should show a bracket.
Two new choices have been added to the Ensemble type option in the same
group: British brass band (which provides separate bracketing groups for
cornets; flugelhorn; tenor horns; baritone horns; trombone and bass trombone;
euphonium; and percussion), and Big band (which provides separate bracketing
groups for saxophones; trumpets; trombone and bass trombone; and rhythm
section).
Key signatures and accidentals
 Instruments with (no key) in their names (e.g. French horn, timpani, etc.) are
now correctly created with no key signatures, and instead show accidentals on
every note as necessary.
 An open or atonal key signature can now be created via the Shift+K popover by
typing open or atonal.
 It is now possible to change the enharmonic spelling of notes in part layouts
independently of the full score layout.
Licensing
When using a time-limited or trial license, Dorico will now report the time remaining
in the license at start-up, every 10 days, and every day during the final five days of
the license period.
Lyrics
New Minimum distance from other items option in the Vertical Position section
of the Lyrics page in Engraving Options provides a small amount of padding
between items protruding outside the staff and the closest edge of the innermost
line of lyrics.
New option to show or hide elision slurs on lyrics in Japanese and other East Asian
languages by default, in the East Asian Lyrics section of the Lyrics page in
Engraving Options. In addition, there is a new property to override this default
setting for an individual lyric.
Note input and editing
 A new scissors tool (shortcut U) has been added. Outside of note input, the
scissors tool will remove any ties in the selected notes and chords. Inside note
input, the scissors tool will cut any sounding notes in the voice indicated on the
caret that are sounding at the current caret position.
 A new option Play notes during note input and selection has been added to
the General page of Preferences.
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 New Write ▸ Input Pitch submenu allows you to choose between inputting in
Written Pitch or Sounding Pitch, which is useful when inputting into
transposing instruments or when copying instrumental parts.
Page layout
 The Edit ▸ Breaks and Edit ▸ Note Spacing menus have been removed, with
their functions moved to the Engrave menu, in recognition of the fact that
system and frame breaks can only be created in Engrave mode. New Edit ▸
Format Systems and Edit ▸ Format Music Frames submenus have been
added, containing not only System Break and Frame Break, but also Lock
Frame, Lock System, Make Into System, and Make Into Frame.
 The default key command for system break is now Shift+S, and for frame break
it is now Shift+F.
Playback
 A new option Suspend audio device in background has been added to the
General page of Preferences, switched off by default. When switched on, this
option releases the audio device when Dorico loses focus, unless it is playing
back at the time, in which case Dorico retains ownership of the audio devices
so that playback can continue.
 Basic playback of changes in playing techniques has now been implemented for
HALion Symphonic Orchestra, allowing playback of e.g. pizz. and arco
instructions.
 The Mixer window now labels each fader with the plug-in output channel and
the short instrument name, and each fader is also color-coded using the same
colors used in the track header for each instrument in Play mode.
 The playhead is now shown in Play mode, and it moves through the music
during playback.
Selections
 Navigating around the music with the arrow keys in Write mode has now been
substantially improved.
 Use Tab and Shift-Tab to select the next/previous barline in Write mode.
 It is possible to start navigation in Write mode without the mouse: simply press
any arrow key, which will select the first item closest to the top left corner of the
view.
 Extending the selection by holding Shift and using the arrow keys now works
more reliably; hold Ctrl (Windows) or Command (Mac) to extend the selection
by a bar at a time.
 Clicking within the staff but not on a note or other item now selects all of the
music in that bar on that staff; hold Shift and click on another item or a blank
part of the same or another to extend the selection.
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 New Edit ▸ Select to End of System and Edit ▸ Select to End of Flow menu
items, to quickly extend the selection on the selected staff or staves to the end
of the system or the end of the flow, respectively. In addition, Edit ▸ Select All
now works as expected.
 Holding Ctrl (Windows) or Command (Mac) while making a marquee selection
now adds to an existing selection; holding Ctrl+Alt (Windows) or
Command+Opt (Mac) while making a marquee selection now subtracts from
an existing selection.
 The middle mouse button can now be used instead of Shift to toggle between
the default action when clicking and dragging, i.e. between moving the view or
making a marquee selection.
 Dragging a marquee selection over a barline will no longer select the barline.
Time signatures
Hidden time signatures are now shown using signposts, which allows them to be
selected for copying and pasting, or for deletion. A new View ▸ Signposts ▸ Time
Signatures menu item allows you to choose whether or not signposts for hidden
time signatures should be displayed.
Transposing
A new Write ▸ Transpose dialog has been added, allowing the selected music or,
if there is no selection, the entire flow to be transposed. Transposition can be
specified either by quality of interval (e.g. major, minor, perfect, augmented,
diminished) or by number of divisions of the octave. The dialog will not allow illegal
transpositions that would result in notes that cannot be notated (e.g. sharper than a
triple sharp, or flatter than a triple sharp, or using a microtonal accidental that does
not exist in the current tonality system).
In addition, a new Write ▸ Add Notes Above or Below dialog has been added,
allowing the addition of notes of a given interval above or below the selected notes,
providing a quick way of building chords over an extended passage of music.
Tuplets
Tuplets now show signposts if the tuplet ratio number/string is hidden, which
allows them to be selected for copying and pasting, or for deletion. A new View ▸
Signposts ▸ Tuplets menu item allows you to choose whether or not signposts for
hidden tuplets should be displayed.
Vertical spacing
A new Staff Spacing section has been added to the left-hand panel in Engrave
mode, allowing you to edit the vertical spacing of the music when switched on.
Staves can be dragged with the mouse by clicking anywhere in the staff itself, or in
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the handle at the left-hand side of the system. The whole system can be dragged
by clicking in the colored stripe immediately above the top staff in the system.
Hold Alt while dragging a staff or system to also adjust the distance between all of
the staves and systems below the staff or system being dragged, when there is no
further room at the bottom of the music frame.
Use the up/down arrow keys to select the handles at the left-hand side of the
system; use Tab to cycle between selecting handles for systems and handles for
staves. Hold Shift and use up/down arrow to extend the selection to the handle
above/below.
Nudge the selected staff, staves and/or systems using Alt+up/down arrow, and
add Ctrl (Windows) or Command (Mac) to nudge in larger steps.
Use Alt+J/K to nudge the selected staff, staves and/or system such that the
distance between all of the staves and systems below the staves being nudged will
also change, once there is no further room at the bottom of the music frame.
When a staff or system has an overridden position, its handle or the colored stripe
will be colored red. To remove a specific override, select the relevant handle and
click Delete.
To specify an exact distance, click on the numeric read-out in the left-hand margin,
which allows the entry of a specific measurement, using the preferred units of
measurement as determined in Preferences.
To clear all overrides in the selected frame, choose Engrave ▸ Reset Staff
Spacing.
To copy the staff spacing from one page to other pages within the layout, click
Copy Staff Spacing in the Staff Spacing section of the left-hand panel. A dialog
appears in which you can choose the source page and range of destination pages.
The staff spacing will be copied if the destination page has the same number of
systems each containing the same number of staves as the source page.
If the layout of music within the music frame changes because the music is cast off
again, any staff spacing overrides for that passage of music will be removed.
Voices
 The option Gap between adjacent noteheads in different voices in the
Voices section of the Notes page of the Engraving Options dialog now
respects negative values, allowing notes a second apart in opposing voices to
be positioned more closely together.
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 New Edit ▸ Voice submenu, containing options to change the default stem
direction of the voice of the selected note, or if note input is active, to change
the default stem direction of the voice indicated on the caret.
VST Expression Maps
 A new dialog Play ▸ VST Expression Maps has been added, allowing you to
create and edit expression maps to determine how changes in playing
technique should be handled by the chosen virtual instrument.
 VST Expression Maps for Cubase can be imported into your project via Play ▸
VST Expression Maps.
 A new Endpoint Setup dialog has been added, accessed via each entry in the
VST Instruments panel in Play mode, allowing you to specify which expression
map is used by each channel on the chosen VST instrument.

Issues resolved
The following table lists all issues that have been resolved in this version:
ID #
STEAM-4712

STEAM-5129

STEAM-5040

STEAM-5003

STEAM-5094

STEAM-4997

STEAM-4981

STEAM-5050

STEAM-5099

STEAM-5119

Issue
Bars: Using the Shift+B popover to delete bars now also adjusts the position of any time signatures and
key signatures that are affected by the deletion of bars preceding them.
Beaming: The behaviour of Edit ▸ Beaming ▸ Beam Together has been improved such that any selection
that includes a tied note at its start or end will produce the expected beaming.
Beaming: A problem whereby rests under beams could be positioned incorrectly under some
circumstances has been fixed.
Brackets and braces: The options to show sub-brackets and to draw sub-brackets using braces on the
Brackets and Braces page of Engraving Options now work as expected.
Brackets and braces: Organ instruments with three staves now correctly show a brace spanning the
upper two manual staves, leaving the pedal staff unbracketed.
Brackets and braces: Groups of players created in the Players panel in Setup mode now have separate
brackets.
Brackets and braces: Staff labels now draw correctly even when partially out of the viewport.
Brackets and braces: Long staff labels are now automatically wrapped if they exceed half the width of the
music frame.
Brackets and braces: Instruments whose names have been overridden are no longer automatically
numbered.
Brackets and braces: Saving and reloading a project in which there are multiple groups of players no
longer incorrectly changes the order of players on reloading.
Copy and paste: Copying and pasting individual dynamics from within a larger group of dynamics will now

STEAM-4944

create new groups containing only the selected dynamics, rather than all of the dynamics from the original
groups.
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ID #
STEAM-4948

STEAM-5085

STEAM-5007

Issue
Copy and paste: Items of different types that are either specific to staves or voices are now mapped
consistently when pasting, so that they don't end up on different staves than expected.
Copy and paste: Attempting to paste an implicit rest followed by an explicit rest no longer causes a crash.
Copy and paste: When copying and pasting a selection that includes one or more empty instruments, the
destination passage will also offset the appropriate number of empty instruments.

STEAM-5027,

Copy and paste: It is now possible to copy from e.g. the right-hand staff of a piano instrument to the left-

STEAM-5041

hand staff, provided the source selection contains only material from a single staff.

STEAM-5030
STEAM-4837,
STEAM-4839

Copy and paste: When copying and pasting dynamics, the pasted dynamics are now correctly left
selected.
Copy and paste: Pasting material that includes dynamics or slurs into other staves at the same rhythmic
position now result in the pasted dynamics and slurs becoming linked to the dynamics and slurs on the
source staves.

STEAM-5086

Dynamics: Attempting to set the color of a selected hairpin in Engrave mode no longer causes a crash.

STEAM-4911

Holds and pauses: It is now possible to add a fermata to the final barline of a flow written in open meter.

STEAM-5181

STEAM-5145

STEAM-5116

STEAM-5171

Holds and pauses: A transitory spacing problem that could result in adding a caesura not resulting in
space being added immediately has been fixed.
Holds and pauses: Fermatas attached to barlines now always draw correctly in galley view.
Holds and pauses: Fermatas attached to barlines no longer sometimes cause a bar number at the start of
the system to move incorrectly.
Instrument changes: Instrument change warning labels now appear correctly when the new instrument
starts playing on the following system
Instrument changes: Instrument changes that occur near the start of the flow are now snapped to the start

STEAM-5167

of the flow if the first instrument held by the player doesn't play at all before the new instrument starts
playing.

STEAM-5160

STEAM-5131

STEAM-4672

STEAM-4985

STEAM-5095

STEAM-5057

Dorico Version History

Instrument changes: The light blue staff labels in galley view are now shown on each instrument, rather
than for each player, making it easier to identify which staff is for which instrument held by each player.
Key commands: Key commands shown in tool tips are now correctly updated when key commands are
edited.
Key commands: Setting a key command in the global context now correctly reports if there is a conflict
with the same key combination in another context.
Key signatures and accidentals: Attempting to create a new accidental type in the Edit Tonality System
dialog no longer causes a crash if an existing accidental is not already selected.
Key signatures and accidentals: The Edit Key Signature dialog now correctly uses the bass F clef rather
than the baritone F clef.
Key signatures and accidentals: Custom key signatures that use a newly-created accidental type are now
shown correctly in the Custom Key Signatures section of the Key Signatures panel in Write mode.
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ID #
STEAM-5194

STEAM-5136

Issue
Key signatures and accidentals: Custom key signatures now show the name supplied by the user as a
tool tip when hovering over their button in the Key Signatures panel.
Key signatures and accidentals: Custom key signatures now transpose correctly in layouts set to
transposing pitch rather than concert pitch.
Key signatures and accidentals: Repitching notes now works correctly in key signatures that have been

STEAM-5028

chosen because they show one fewer sharp or flat than the enharmonic equivalent for transposing
instruments.

STEAM-5070

STEAM-4986

STEAM-5130

STEAM-5001

STEAM-5107

STEAM-5065

STEAM-5093

STEAM-5237

STEAM-4812

STEAM-5138

STEAM-5002

STEAM-4760

STEAM-5072

STEAM-5078

STEAM-5172

STEAM-5188

Dorico Version History

Layout Options: Saving layout options as the defaults for future projects no longer causes new layouts to
have either the wrong players and flows or no players and flows at all to be attached to them by default.
Layout Options: The option Use optical spacing for beams between staves on the Note Spacing page
of Layout Options is now switched on by default in part layouts in new projects.
Layout Options: If the saved layout options refer to a non-default set of master pages that is not available
in the new project, Dorico no longer crashes when creating the project.
Lyrics: Lyrics assigned to different voices but with the same line number now have the same vertical
position.
Lyrics: Lyric extender lines and hyphens now stop correctly before the systemic barline at the end of the
system.
Multi-bar rests: Grace notes positioned before a barline now draw correctly if the bar to which they are
attached becomes consolidated into a multi-bar rest.
Multi-bar rests: Fermatas now correctly cause multi-bar rests to break.
MusicXML import: Key signatures in MusicXML files that specify a number of fifths but no mode now
import correctly.
Note input and editing: Using Space to advance a hairpin past a tuplet no longer engages sticky tuplet
input, causing subsequent music to be overwritten unexpectedly.
Note input and editing: It is now possible to create a tied note longer in duration than a maxima, or 64
quarter notes (crotchets).
Note input and editing: When using Lock to Duration, the caret now correctly advances to the end of the
last note in the voice whose notes are being repitched.
Note input and editing: It is now possible to play chords on your MIDI keyboard when inputting ties with T
or when Lock to Duration is active.
Note input and editing: The first note input via the mouse can now have an accidental and a rhythm dot if
chosen from the panel.
Note input and editing: Double-clicking to start note input in galley view now always shows the caret at
the correct location.
Note input and editing: MIDI step-time input now correctly compensates for the octave transposition of
the instrument (e.g. piccolo, double bass, guitar, tenor voice), if any.
Page layout: Graphics placed in graphics frames on master pages are now correctly saved and loaded
with the project.
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ID #
STEAM-5083

STEAM-5092

STEAM-4984

STEAM-4886

STEAM-4496

STEAM-4792

STEAM-4988

STEAM-4955

STEAM-4998

Issue
Page layout: A problem that prevented text frames from being deleted in some circumstances has been
fixed.
Page layout: Using the formatting commands (e.g. make into system/frame, lock system/frame) in one
layout no longer incorrectly removes formatting from other layouts.
Page layout: You can now remove overrides from all pages in the layout by clicking the Remove
Overrides button in the Pages section of the right-hand panel in Engrave mode with no pages selected.
Playback: Dorico will now load sounds into all 16 channels of each instance of HALion Sonic SE, rather
than leaving the final channel in each instance empty.
Playback: Dorico now compensates correctly for HALion patches that are transposed by one or more
octaves (e.g. double bass, bass guitar).
Playback: The playback of hairpins has been improved such that immediate dynamics at either or both
ends of the hairpin are now properly respected.
Playback: Attempting to open another project when the Mixer window is already open for the current
project no longer causes Dorico to hang.
Playback: The default voice count for HALion Sonic SE in new projects has been increased from 128 to
512.
Print mode: A problem whereby staff lines or other lines could appear the wrong thickness on the second
and subsequent pages of exported PDFs has been fixed.

STEAM-5098

Print mode: Exporting graphics files from multiple layouts in a single operation no longer causes a crash.

STEAM-5042

Print mode: The default dots per inch (dpi) value for exported graphics is now 150dpi instead of 72dpi.

STEAM-5097

STEAM-5125

STEAM-5219

STEAM-4834

Print mode: Exporting multiple graphics no longer prompts separately to overwrite any found files: you can
simply confirm that you want to overwrite all existing files at once.
Print mode: The Watermark text in the Annotations section of the print options panel will no longer be
cleared incorrectly in the event that multiple selected layouts have conflicting values.
Print mode: Attempting to overwrite a graphics file that is locked by the filesystem (e.g. because it is open
in another application) will no longer cause a crash.
Properties: It is no longer possible to set the values for dot diameter, dash length, and gaps between dots
and dashes for ties and slurs to zero.

STEAM-5063

Properties: Properties for X and Y offset for force and combined dynamics now appear correctly.

STEAM-4570

Rehearsal marks: Rehearsal marks are now correctly centered above double and repeat barlines.

STEAM-4570

STEAM-5035

Dorico Version History

Rehearsal marks: If the option to position rehearsal marks at the start of the system is chosen, the
rehearsal marks are now correctly left-aligned with the systemic barline.
Rests: Rests that have properties set on them, e.g. to force a specific duration or to set a particular staff
position, are now positioned in a manner consistent with other rests that don't have properties set.
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ID #
STEAM-5204,
STEAM-4848
STEAM-4979

STEAM-5143

STEAM-4953

STEAM-5015

STEAM-5142

STEAM-5061

STEAM-4975

STEAM-5055

STEAM-5043

STEAM-5044

Issue
Rests: It is now possible to select all individual rests in Engrave mode.
Selection: A problem whereby the marquee rectangle could be left behind if you hit Esc during a marquee
selection has been fixed.
Slurs: A problem that prevented slurs starting in one voice and ending in another from being created
correctly has been fixed.
Tempo: The Shift+T popover for tempo input is now much more flexible and will allow a much wider set of
terms to be input.
Text: Edit ▸ Reset Appearance now clears any changes of font, size, and other typographical control in a
selected text item.
Text: A problem whereby some Japanese fonts were truncated during text editing has been fixed (Mac
only).
Text: Creating a new text frame on a master page now sets the default paragraph style correctly.
Text: It is now possible to jump to the name of a specific font in the list of fonts in the text editor popover
by typing the first letter or two of its name.
Text: Text frames that are too full now correctly truncate the text within the frame, rather than allowing the
text to flow outside the frame.
Text: Copying and pasting text into Dorico from another application no longer causes the formatting of the
text in the frame to be messed up.
Text: It is now possible to use the Unicode Hex Input input method to input extended Unicode characters
into the text editor within Dorico (Mac only).
Text: Paragraph styles in newly-created projects now inherit many of their settings from the Default Text
paragraph style, making it possible to quickly change the main text font in use in your project by editing the
Default Text paragraph style.

STEAM-5154

Time signatures: Newly-created time signatures now correctly show that they are selected after creation.
User interface: The Layout Options, Notation Options, and Engraving Options dialogs now remember

STEAM-5207

which page you were last looking at when you opened the dialog, and show that page when the dialog is
reopened.

STEAM-5208

STEAM-5182

STEAM-4656

STEAM-5081

STEAM-4978

Dorico Version History

User interface: A read-out of the current page size using the user’s preferred measurement unit has been
added to the Page Setup page of Layout Options.
User interface: The view type selector in the status bar no longer gets out of sync with the actual view
used when switching layout.
User interface: When switching between modes, the state of the Hide/Restore Panels button on the
toolbar correctly reflects which panels will be shown or hidden when clicked for that mode.
User interface: Dorico no longer crashes when you right-click on a tab and choose to create either a
vertical or horizontal split.
User interface: Dorico no longer allows the Mixer or Transport windows to be shown as full screen
windows (Mac only).
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ID #
STEAM-4956

STEAM-4908

STEAM-4528

STEAM-4039

STEAM-5166

Issue
User interface: The buttons on the toolbar to hide or show the Mixer and Transport windows now correctly
reflect whether or not the Mixer and Transport windows are actually shown.
User interface: When closing the final project window and the Steinberg Hub is set not to reappear, the
menus no longer disappear (Mac only).
User interface: New Write ▸ Create Voice and Next Voice menu items, intended to make the Shift+V
and V key commands for use in note input more discoverable.
Zoom: The behaviour of zooming in when the selected item is close to the edge of the viewport has been
improved.
Zoom: A problem whereby Dorico could crash when switching window mode when the zoom level is set
to Whole page has been fixed.
Platform support: Dorico now uses DirectWrite to render all text and glyphs in its user interface, which

STEAM-5089

should resolve the problem with icons appearing stretched or out of proportion until Dorico is restarted
(Windows only).

STEAM-4992

STEAM-5305

STEAM-5312

STEAM-4893

STEAM-5310

Localization: The names of templates that appear in the Steinberg Hub are now localised.
Localization: Typing characters that require the use of the Alt modifier (e.g. [, ] and |) into popovers now
works correctly on non-English keyboards.
Localization: A number of problems with keys that produced accented characters when specifying key
commands in the Key Commands page of Preferences have been fixed.
Localization: The handling of key commands in the Japanese language version of Dorico has been
overhauled.
Localization: Changing the keyboard language on the Key Commands page of Preferences now takes
effect immediately, rather than requiring a restart of Dorico.

STEAM-5313,

Localization: The default key commands for French, Spanish, Italian, and Portuguese have been revised in

STEAM-5314

relation to the various keyboard handling fixes.
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Dorico 1.0.0
October 2016
Initial release version.
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Known issues and solutions
Frequently asked questions
Answers to frequently asked questions about Dorico can be found online in the
Dorico forum.

Knowledge base
For the latest information about issues and solutions you may encounter when
running Dorico, please consult the Knowledge Base.

Entering the eLicenser Activation Code (Mac only)
When you first run Dorico and are prompted to enter your Activation Code, you
may find that after you have successfully activated your Soft-eLicenser, you must
quit and restart Dorico for the application to detect that it is fully licensed.

Key commands to transpose notes by an octave (Windows only)
The Intel Graphics Adaptor drivers used by many Windows computers define a
default key command to flip the screen by 90, 180 and 270 degrees via a shortcut
Ctrl+Alt+up/down/left/right arrows.
Ctrl+Alt+up/down option conflicts with the key commands in Dorico note input for
transposing notes by an octave.
For information about how to disable the default Intel Graphics Adaptor key
command, consult the Knowledge Base.

Audio export
No progress dialog appears on Mac during audio export. A busy cursor will appear
for the duration of the export operation. Check that the operation has completed
successfully before you try to play back the exported audio file. You can verify that
the export has completed successfully by checking the file size of the exported file:
if it is reported as 0 bytes, the file is still locked for writing.
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