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Dorico 2.1.10
14 September 2018
This version contains the following issue resolutions.

Issues resolved
ID #

Component

AD-355

Audio engine

AD-356

Audio engine

STEAM-8538

Audio export

STEAM-8454

Dynamics

STEAM-8223

Key
signatures

STEAM-8479

Key
signatures

STEAM-8502

Localization

STEAM-8455

Mixer

STEAM-8516

Percussion

STEAM-8398

Performance

STEAM-8417

Performance

STEAM-8447

Performance

STEAM-8458

Performance

STEAM-8418

Play mode

STEAM-8435

Play mode

STEAM-8432

Print mode
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Issue
A problem whereby the length of the first note in the flow could be truncated in exported
audio files has been resolved.
Under some circumstances, Dorico could crash when waking the computer from sleep.
This problem has now been resolved (Mac only).
Exporting audio would hang or export an empty file if the name of the flow to be exported
ended in a trailing space or multiple full stops; this has now been fixed (Windows only).
Editing unrelated items no longer sometimes causes dynamics to move incorrectly
vertically in galley view.
Key signatures for transposing instruments in divisi staves now appear correctly.
Key signatures created using a custom tonality system no longer sometimes reference the
wrong system of accidentals and set of octave divisions.
When running Dorico in a language where comma is used as the decimal separator, spin
boxes that use decimal values now work correctly.
Outputs for plug-ins added in the VST Instruments panel in Play mode now appear
correctly in Dorico’s Mixer once more.
Percussion playing techniques now play back correctly in the event that one or more
instruments in the kit cannot be mapped to entries in the chosen percussion map.
Deleting notes at the end of a flow that has explicit bar rests near the start is now much
faster.
Inputting notes in scores with large numbers of players is now much faster, at the expense
of reducing the automatic balancing of bars per system at the end of the flow.
Showing the system track in galley view no longer causes editing and redraw to be
significantly slower.
Opening project files with many MIDI controller automation events is now significantly
faster.
Dorico no longer crashes if you do Play ▸ Reset Playback Overrides with items other
than notes selected.
The e button that shows whether a VST plug-in window is open now always correctly
reflects the current state.
Exporting a PDF of a 2-up document using a non-European page size now produces a
PDF of the correct dimensions.
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ID #

Component

STEAM-8429

Project files

STEAM-8475

Project files

STEAM-8419

Rhythmic feel

STEAM-8423

Text
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Issue
Under rare circumstances in projects with divisi and local time signatures, Dorico could
hang when attempting to re-open an existing project; this has now been resolved.
Under rare circumstances, Dorico could crash when attempting to save a project. This
problem has now been resolved.
Dorico no longer crashes if you type a character not included in any of the rhythmic feel
names into the filter control in the Edit Rhythmic Feel dialog.
Under some circumstances, moving a text item on one staff could cause a text item on
another staff to move unexpectedly. This problem has now been resolved.
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Dorico 2.1
10 August 2018
This version contains the following new features, improvements and issue
resolutions.

New features
Swing playback
Dorico 2 now includes support for swing playback. It is possible to set up a
project-wide default swing pattern, or to change the amount of swing (or indeed to
switch between straight and swing) at any point in the music, and it is also possible
for different players to play different swing patterns at the same time.
Based on academic research into how swing is actually rendered by real musicians
by authors Anders Friberg and Andreas Sundström, Dorico’s swing patterns are
tempo-dependent, with the swing feel more pronounced at lower tempos, and
trending towards a straight feel at higher tempos. Swing feels that produce the
same ratio at all tempos are also included, and it’s possible to define your own
swing patterns.
Project-wide swing. To enable swing for your whole project, open Play ▸
Playback Options and choose the Timing page. Choose the desired swing
pattern from the Default rhythmic feel menu:
§

2:1 swing (fixed) – sometimes called triplet swing, this elongates the first
eighth (quaver) in a pair of eighths to be twice as long as the second,
creating a strict triplet 2:1 ratio; this ratio is maintained regardless of the
tempo.

§

3:1 swing (fixed) – this elongates the first eighth in a pair of eighths to be
three times as long as the second, creating a dotted eighth-16th (dotted
quaver-semiquaver) ratio; this ratio is maintained regardless of the tempo.

§

Heavy swing – this produces a tempo-dependent swing ratio of between
3:1 at low tempo and 1.5:1 at high tempo.

§

Light swing – this produces a tempo-dependent swing ratio of between
1.5:1 at low tempo and 1:1 (i.e. straight) at high tempo.

§

Medium swing – this produces a tempo-dependent swing ratio of
between 2:1 at low tempo and 1.5:1 at high tempo.

§

Straight (no swing) – this produces even eighth notes in the ratio 1:1 at
all tempos.
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Changing swing mid-flow. To change the swing pattern for a particular section of
the project, select a note, rest or other item at the location where you want to
change the swing pattern, then type Shift+T for the tempo popover. Type the
beginning of the name of the swing pattern you want to use, e.g. typing med will
show Medium swing in the list of suggestions: use down arrow to select it, then
hit Return to confirm your choice. A signpost will appear on the top staff in the
system, showing the name of the rhythmic feel.
To change the swing pattern used by just one of the players in the ensemble, first
select a note, rest or other item on the staff in question, or position the caret there,
then use the Shift+T popover to select the swing pattern using the down arrow
key. Finally, type Alt+Return to confirm the popover: now a signpost appears on
the chosen staff, showing the name of the rhythmic feel.
Changes in rhythmic feel only take effect from the start of a bar, so if you create a
change of rhythmic feel in the middle of a bar, it will take effect from the start of the
following bar.
To delete a change of swing pattern, simply select the corresponding signpost and
hit Delete. You can choose whether or not rhythmic feel signposts should be
shown via View ▸ Signposts ▸ Rhythmic Feel.
Editing swing patterns. To edit one of the default swing patterns or define your
own, first open the Timing page of Play ▸ Playback Options, then click the Edit
button in the Rhythmic Feel section to open the Edit Rhythmic Feel dialog:

The rhythmic feel definitions in the project are listed on the left. Click New to
create a new default rhythmic feel; click New from Selection to create a copy of
the currently-selected rhythmic feel; click Save as Default to save the currentlyDorico 2 Version History
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selected rhythmic feel into your user library so that it will be available in every new
project you subsequently create.
On the right-hand side of the dialog are some simple controls to define the swing
pattern:
§

Depends on tempo determines whether or not the swing pattern should
use the same ratio at all tempos; when switched off, the Low tempo and
High tempo controls are disabled, and a single swing ratio slider is shown.

§

Low tempo specifies the tempo (in quarters per minute) at and below
which the swing ratio for the slider to the right should be used.

§

High tempo specifies the tempo at and above which the swing ratio for the
slider to the right should be used.

§

The swing ratio sliders cover a range from 1:1 (straight) to 5:1 (sextuplet,
with the first eighth occupying five divisions, and the second eighth
occupying the final division), and display both the ratio and a swing
percentage to its right.

When Depends on tempo is activated, the swing ratio defined for Low tempo is
used at and below that tempo; as the tempo increases, Dorico interpolates the
swing value towards the swing ratio defined for High tempo, until that tempo is
reached. If Depends on tempo is not activated, then the swing ratio defined by the
single slider is used at all tempos.
Notehead set editor
A new Engrave ▸ Notehead Sets dialog has been added, which allows you to
modify the built-in notehead sets and design your own.
A notehead set is a collection of related noteheads: it is important to know that the
same notehead can appear in more than one notehead set, which means that if you
edit a notehead within one notehead set, it will be edited in all notehead sets that
contain that notehead.
A normal notehead set typically contains at least four noteheads: the black
notehead for notes up to a quarter (crotchet) in duration; the white notehead for
half notes (minims); the wider white notehead for whole notes (semibreves); and
the wider white notehead with one or two vertical strokes at either side, or a square
white notehead, for double whole notes (breves). Dorico also supports two other
types of notehead sets: pitched, where the notehead chosen will be different
depending on the pitch of the note; and scale degree, where the notehead chosen
will be different depending on the scale degree of the note, relative to the current
key signature. The most common kind of pitched notehead set is the Note names
notehead set, which shows the letter name (and accidental, if applicable) of the
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current note within the shape of the notehead; an example of a scale degree
notehead set is the Aikin 7-shape set for sacred harp or shape note singing.
A notehead set of a particular type – normal, pitched, or scale degree – can only
contain noteheads of the same type. It is not possible to use, say, a normal
notehead within a pitched notehead set, so you cannot change the type of an
existing notehead set or an existing notehead.
The Engrave ▸ Notehead Sets dialog is split into three areas:

On the left, you can choose which category to work with: the categories here
correspond to the submenus in the Edit ▸ Notehead menu. You can change
which noteheads appear in which submenu by selecting the notehead set in the list
on the left, then changing the Category drop-down in the Notehead Set section at
the top-right.
Below the list on the left are the buttons to create and delete notehead sets:
§

New creates an empty notehead of the Normal type, in the Common
category.

§

New from Selection creates a copy of the currently-selected notehead
set, of the same type and in the current category. Be aware that the
noteheads contained in the new set are the same as the ones in the set the
new set is based on: if you want to make changes to the noteheads only in
the new set, be sure to also create new noteheads based on the ones
currently in the set.

§

Save as Default saves the selected notehead set into your user library, so
that it will be available in all new projects that you subsequently create.
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§

Revert to Factory is only enabled for built-in notehead sets; if you have
made any changes to a built-in set, this reverts it to its default state.

§

Delete allows you to delete custom notehead sets, provided they are not
currently being used by any notes in the project; built-in notehead sets
cannot be deleted.

The Notehead Set section at the top-right shows the noteheads in the current set.
Click

to add an existing notehead to the current set: a menu listing all of the

noteheads of the same type as the current set appears. To remove a notehead
from the current set, click

, which is only enabled when the notehead is not in

use in the project. To specify the category in which this notehead set should
appear, choose the desired entry from the Category list. The Default notehead
specifies which notehead within the set Dorico should use if it is unable to find a
notehead that exactly matches the requirements of a note (for example, if you have
a note longer than a whole note, but no notehead of a suitable duration defined in
the set, the default notehead will be used instead).
You cannot change the Type of a notehead set: if you want to create a pitched or
scale degree notehead set, select an existing notehead set of the desired type and
use New from Selection to create a new notehead set based on it.
The Notehead section at the bottom-right shows the properties for the notehead
currently selected in the grid control in the Notehead Set section above. You can
edit the following properties of each notehead:
§

Name: the name of the notehead as it will appear in the menu in the action
bar for the grid control above.

§

Duration: the primary rhythmic duration for which the notehead is intended
to be used. For most notehead appearances, the same notehead is used
for notes of a quarter (crotchet) and shorter in duration: it is sufficient to
choose 1/4 note for that notehead, then set Use for durations shorter
than and equal directly below.

§

Use for durations shorter than and equal specifies that this notehead
should be used not only for the Duration specified above, but also for
shorter notes.

§

Use for durations longer than and equal specifies that this notehead
should be used not only for the Duration specified above, but also for
longer notes.

§

Stem direction allows you to specify that this notehead should be used
specifically for up-stem or down-stem notes. (For example, in shape note
systems, the triangular notehead points in opposite directions for up-stem
and down-stem noteheads.)
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§

Double whole note allows you to specify that this note is nominally a
Round or Square notehead, which determines which will appear
depending on whether Round or Square is set for Appearance of double
whole note (breve) notehead on the Notes page of Engraving Options.

§

Pitch (only for noteheads of Pitched type) specifies the note name and
accidental for which this notehead should be used.

§

Degree (only for noteheads of Scale Degree type) specifies the scale
degree (an integer from 1 to 7) for which this notehead should be used.

In the action bar at the bottom of the Notehead section are found the following
buttons:
§

New Notehead creates a new notehead of the Normal type, based on the
default black notehead.

§

New from Selection creates a new notehead of the same type and
appearance as the notehead selected in the grid control in the Notehead
Set section above.

§

Edit Notehead opens the notehead editor, allowing you to change the
appearance of the notehead itself; see below.

§

Save as Default saves the selected notehead into your user library, so that
it will be available in all new projects that you subsequently create.

§

Revert to Factory is only enabled for built-in noteheads; if you have made
any changes to a built-in notehead, this reverts it to its default state.

Clicking Edit Notehead opens the notehead editor:
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On the right-hand side, choose between the different types of components that
can be added to the notehead design:
§

Glyph allows you to add a character from any font installed on your
computer; if you choose a SMuFL-compliant font such as Bravura, the
Range list will show all of the SMuFL character ranges, making it easier to
find the character you’re looking for.

§

Text allows you to add one or more characters using any of the font styles
defined in Engrave ▸ Font Styles. This would be an unusual choice for a
notehead, but the option is provided nevertheless.

§

Graphic allows you to add a graphic in PNG, JPG or SVG format. It is
recommended that you use a vector format like SVG so that it will appear
high-resolution at any size.

§

Composite allows you to add any other symbol that is already defined in
the project, though at present you will need to know its name, as no
graphical preview is currently available.

When you have chosen the component you wish to add, click the Add button at
the bottom of the current panel to add the component to the display.
You should position the notehead design such that the left-hand edge is aligned
with the slightly thicker vertical grid line that represents the horizontal origin (you
can think of this as a nominal stem on a stem-down note), and such that the middle
is aligned with the slightly thicker horizontal gridline that represents the vertical
origin (you can think of this as a nominal staff line, with the notehead sitting on the
staff line).
You can specify exactly where the stem should join the notehead on the right-hand
side for a stem-up note and on the left-hand side for a stem-down note; you can
also specify additional attachment points for stems that join the note diagonally
when the notehead is used for a split stem altered unison. Click the Stem button
below the main notehead display to add or delete stem attachment points. For
more information about stem attachment, please consult the SMuFL specification:
https://w3c.github.io/smufl/gitbook/specification/glyphswithanchors.html
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Improvements
Audio export
It is now possible to export individual flows to separate audio files, and to export
individual players to separate audio files as well, with audio files for each flow being
exported to separate folders. This makes it very quick and easy to export “stems”
suitable for dragging and dropping into Cubase or another DAW for further mixing
and mastering. (STEAM-8128)
Accidentals
Cut-outs for accidental tucking. The Edit Accidental dialog now allows the editing
of cut-outs in each of the four corners of the symbol, to instruct Dorico how it can
tuck or kern the accidentals in adjacent columns. (STEAM-8113)

To edit the cut-outs for an accidental, click the Cut-outs tab in the lower area of
the dialog, and click the Create button for the corner of interest (NW = north-west,
SW = south-west, NE = north-east, SE = south-east), then click the handle on the
inner corner of the shaded green area to change the size of the cut-out. To remove
a cut-out, click the Delete button for the corner of interest.
For more information about cut-outs, consult the SMuFL specification at:
https://w3c.github.io/smufl/gitbook/specification/bbox-cut-outs.html
Accidentals and ledger lines. It is now possible to specify that Dorico should not
shorten the left-hand side of ledger lines when an accidental is present: set
Ledger lines on notes with accidentals to Do not adjust ledger lines on the
Dorico 2 Version History
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Notes page of Engraving Options to enable this behavior. Ledger lines will then
use their default length as defined by Ledger lines protrude beyond noteheads
by n spaces instead of the value defined by Ledger lines protrude left of
notehead with accidental by n spaces. Furthermore, the default gap between the
rightmost accidental and a default ledger line is determined by the new Gap to
right of rightmost accidental, if to left of unshortened ledger line option on the
Accidentals page of Engraving Options. (STEAM-8179)
Tucking accidentals on back notes. A new option Gap to right of rightmost
accidental, if to left of back note n spaces has been added to the Gaps section
of the Accidentals page of Engraving Options. Normally accidentals are allowed to
encroach on the usual margin when a back note is present, and this value specifies
the minimum gap that must be present. (STEAM-6902)
Arpeggio signs
A new option Arpeggio signs on slash voices has been added to the Arpeggio
Signs page of Engraving Options, controlling whether or not arpeggio signs
should be shown in slash voices. By default, an arpeggio sign shown on a slash
voice will be very short, but its length can be adjusted in Engrave mode. (STEAM8180)
Barlines
Collision avoidance. Dorico now consistently takes barlines than protrude above
and below the staff (e.g. for single-line percussion instruments) and wings on
repeat barlines, if shown, into account when determining the placement of items
above the staff. (STEAM-5752, STEAM-7413)
Thin-thin repeat barlines. Building on the support for hymnal-style barlines
introduced in Dorico 2.0, a new option Start repeat at start of system has been
added to the Repeats section of the Barlines page of Engraving Options: this
option allows you to choose whether or not both the chosen barline type and the
repeat dots or only the repeat dots should appear for a start repeat at the start of
the system. (STEAM-7668)
Triple barline. Sometimes used in musicological analysis to demarcate structural
units larger than a single bar, it is now possible to create a triple single barline by
typing triple into the Shift+B popover. (STEAM-8139)
Chord symbols
A new option Position of accidental relative to alteration has been added to the
Alterations section of the Chord Symbols page of Engraving Options. This allows
you to follow the recommendations in Russell Garcia’s book series The
Professional Arranger Composer: Garcia advocates the use of minus and plus
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instead of accidentals in intervals and alterations in chord symbols, because they
occupy less horizontal space. However, when using these symbols, it is important
to reverse their usual order relative to the scale degree, i.e. to show 9- instead of
-9, as having the minus or plus precede the degree can cause ambiguity in case
the player expects - to be used to denote a minor quality, or indeed + for an
augmented triad. Therefore, the new option allows you to specify that the
accidental should follow the scale degree if required. (STEAM-8326)
Cues
Rhythmic cues. When creating a rhythmic cue, no octave transposition is now
shown in the cue label by default, even when cueing onto an octave transposing
instrument. (STEAM-8339)
Divisi
Mid-system divisi labels. A new Show divisi change labels above staves option
has been added to the Staves and Systems page of Layout Options. When
switched on, the staff label defined for each divisi soloist or section will appear
above each divisi staff at the point at which the divisi begins, and a corresponding
tutti label will appear above each divisi staff at the point at which the divisi ends.
New options on the Divisi page of Engraving Options allow you to determine the
default distance above the staff for these mid-system divisi change labels. The
labels can also be nudged or dragged freely in Engrave mode. It is also possible to
override the content of an individual divisi change label in Engrave mode by way of
the new Custom text property in the Divisi group of the Properties panel.
(STEAM-8007)
Creating divisi at the caret. You can now create a divisi change when note input is
active: instead of being created at the start of the selection, the divisi change will
be created at the caret’s location. (STEAM-8002)
Tutti signposts. When using Restore Tutti to end a divisi region, the resulting
signpost is now labeled Tutti to differentiate from the start of a divisi range.
(STEAM-8091)
Filters
Filtering slash voices. You can now filter for slash voices by choosing Edit ▸ Filter
▸ Voices ▸ All Slash Voices, or by choosing the specific up-stem, down-stem or
stemless slash voice from the list in the submenu. (STEAM-8078)
Flows
Trim flow. Type trim into the Shift+B popover to execute Write ▸ Trim Flow.
(STEAM-7453)
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Layouts
Default part layouts. In the event that you have inadvertently deleted the part
layouts for your project, the new Setup ▸ Create Default Part Layouts command
provides a quick way of recreating a default set of part layouts: one part layout for
each player, with each flow attached. (STEAM-8226)
Multi-bar rests
Fixed width H-bar. A new H-bar width option has been added to the Multi-bar
Rests section of the Rests page of Engraving Options. When set to Fixed width,
the H-bar will be drawn using the value of Fixed H-bar width instead of being
inset from the barline at either side of the multi-bar rest. (STEAM-8240)
Bar count on grand staff instruments. In published music it is usual for the bar
count for a multi-bar rest to appear only between the two staves of a grand staff
instrument such as piano, but in parts for recording sessions in Hollywood it is
usual to show the bar count above both staves. It is now possible to choose
between these two conventions by way of the new Bar count on grand staff
instruments option in the Multi-bar Rests section of the Rests page of Engraving
Options. (STEAM-8342)
Threshold for “tacet al fine”. A new option Minimum number of bars’ rest at end
of flow to show tacet al fine has been added to the Rests page of Engraving
Options, defaulting to 4 bars in new projects, and defaulting to 1 bar in projects
created in versions of Dorico earlier than 2.1 to preserve their appearance. This
allows you to specify that Dorico should now show “tacet al fine” for very short
multi-bar rests at the end of a flow. (STEAM-8238)
Hidden tempo items. Tempo items that do not appear in Write mode, for example
those that are created in the tempo track in Play mode, are no longer considered
for the purposes of splitting multi-bar rests. (STEAM-8151)
MusicXML import
Text items. A new Text items option has been added to the MusicXML Import
page of Preferences, switched off by default. When switched on, all text items in
the MusicXML file will be imported as Shift+X text items; you will very likely find
that these text items duplicate other items that have been imported using as
tempos, dynamics, etc. (STEAM-8221)
Rhythm slashes. Dorico now imports rhythm slash regions and slash voices as
appropriate from MusicXML files, for both pitched and unpitched instruments.
(STEAM-8212, STEAM-8166)
Bar repeat regions. Dorico now imports one-, two- and four-bar repeat regions
from MusicXML files. (STEAM-7780)
Dorico 2 Version History
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Notes
Rhythm dot consolidation. The Rhythm dot consolidation option in the Rhythm
Dots section of the Notes page of Engraving Options has been revamped, both to
make the behavior clearer and to provide a separate option to specify how rhythm
dots should be handled for unisons in opposing voices.
Rhythm dot consolidation describes how Dorico handles situations whereby dotted
notes of similar pitches in adjacent voice columns can be positioned together, with
their rhythm dots appearing in a single column to the right of both voice columns.
This makes efficient use of horizontal space, but can introduce ambiguity when
reading the music at sight. Dorico provides three settings for rhythm dot
consolidation:
§

Do not consolidate means that rhythm dots should always be shown
immediately to the right of the note or chord to which they apply.

§

Notes of the same duration allows Dorico to consolidate rhythm dots for
notes in adjacent columns, provided they have the same duration (e.g.
provided both are dotted quarters, but not if one is a dotted eighth and the
other is a dotted quarter).

§

Notes of any duration allows consolidation for any combination of note
values (e.g. an up-stem quarter note and a down-stem half note), which
provides the most compact arrangement, but could be considered
ambiguous.

In addition to this, a separate Rhythm dots on unisons in opposing voices
option has been added, which allows you to determine whether two notes of the
same duration and pitch in opposing voices should show a single rhythm dot, or
one rhythm dot per voice. (STEAM-8228)
Horizontal position of rhythm dots. A new Rhythm dot X property has been added
to the Notes and Rests group of the Properties panel, allowing you to adjust the
horizontal position of rhythm dots in Engrave mode. When there are multiple notes
at the same rhythmic position, be aware that the property applies to the whole
group of rhythm dots; the group may have contributing notes from more than one
voice. (STEAM-8214)
Hiding ledger lines. A new Hide ledger line property has been added to the
Notes and Rests group of the Properties panel. This property appears only in
Engrave mode, and when activated all ledger lines associated with a note are
hidden. (STEAM-8137)
Page layout
A new command Propagate Part Formatting dialog has been added, which
copies page formatting and layout options from a source layout to one or more
Dorico 2 Version History
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destination layouts. The dialog can be invoked either by right-clicking a layout in
the Layouts panel in Setup mode (which initializes the selected layout as the
source layout in the dialog) or from the Setup menu. This dialog appears:

Simply choose the source layout in the left-hand list, then select one or more
layouts in the right-hand list. The two checkboxes below the lists determine the
behavior when you confirm the dialog:
§

Include layout options specifies whether key layout options, including
page size and margins, default master page set, space size, vertical
spacing, note spacing, casting off, multi-bar rest behavior, staff label
options, should be copied from the source layout to the destination layouts.

§

Include system formatting specifies whether Dorico should ensure that
the same number of bars should appear on each system, and the same
number of systems should appear in each frame, in the destination layouts
as in the source layout; this is done by creating system and frame breaks at
the start of each system in each destination layout as appropriate. Any
existing system and frame breaks in the destination layouts are removed.
Likewise, note spacing changes are copied from the source layout to all
destination layouts (and any existing note spacing changes in the
destination layouts are removed).

If the source layout’s system formatting is largely un-edited or relies on the Casting
Off settings from Layout Options, you may not need to use the Include system
formatting option, as it is quite likely that using Include layout options will
produce an identical or very similar layout without the use of breaks on every
system.

Dorico 2 Version History

Page 17

Steinberg Media Technologies GmbH

Complex part layouts that use multiple music frame chains are not suitable as
either source or destination layouts for the Propagate Part Formatting dialog;
Dorico will make the best possible automatic determination of the primary chain of
music frame in both the source and destination layouts, but if the setup of the
source and destination layouts differs greatly, you may get unexpected results. In
particular, page overrides made in Engrave mode are not propagated.
However, you should find that for many cases, checking the layout of the first
instrument in a family or section and then using Propagate Part Formatting to
quickly apply those changes to the remainder of the layouts saves a lot of time in
the process of formatting instrumental parts. (STEAM-8315)
Playback
Background sound loading. Dorico now loads sounds into HALion Sonic SE in the
background without locking up the user interface, which makes many operations
feel much faster. For example, starting a new project and adding players is now
much faster because the sounds required for each new player are loaded in the
background, rather than making you wait for them to be loaded before you can add
another player; when opening an existing project, you can start input and editing
right away, without waiting for all of the sounds to be loaded; and when switching
between projects, you can input or edit in the new project right away as the sounds
are loaded in the background. (STEAM-6471)
Playback of bar repeats. Bar repeats now play back automatically. The bar (for a
single bar repeat) or bars (for a two- or four-bar repeat) immediately preceding the
bar repeat region will be played back for the duration of the bar repeat region.
Dorico will follow the dynamics written in the bar repeat region, rather than
repeating any dynamics in the source bars. (STEAM-7916)
Playback of non-standard tonality systems. Building on the playback of microtonal
accidentals introduced in Dorico 2.0, Dorico 2.1 now supports full microtonal
playback of tonality systems beyond 12-EDO or 24-EDO. Using VST3 Note
Expression for HALion family virtual instruments (including the bundled HALion
Sonic SE 3), and the VST2.x detune parameter for other instruments (including
NotePerformer), Dorico now calculates the appropriate pitch delta for every note,
regardless of whether the note is written with an accidental. In addition, it is now
possible to specify the reference pitch for playback, defaulted to 440Hz, on the
new Tuning page of Playback Options. (STEAM-7952)
Phrasing gradual dynamics. Dorico now interprets a series of gradual dynamics of
the same direction in close proximity as phrasing dynamics, resetting to the
prevailing dynamic level at the start of each gradual dynamic, rather than getting
continuously louder or quieter. (STEAM-8220)
Dorico 2 Version History
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Choice of stereo output. A new Stereo Output control has been added to the Edit
▸ Device Setup dialog, allowing you to choose which pair of outputs on your
audio interface should be used for Dorico’s playback. (STEAM-5176)
App Nap. App Nap is a power-saving feature on macOS that automatically reduces
the amount of processor time available to an application once it goes into the
background in order to reduce its energy usage. For Dorico, this could have the
result of causing playback to stutter or even stop altogether after putting Dorico
into the background during playback. Dorico now signals to macOS that it should
not use App Nap if it is playing back, which means that playback can continue
unimpeded when Dorico is put into the background. (STEAM-8034)
Play mode
Restoration of state. The state of which tracks are expanded, the vertical sizes of
lanes, and which MIDI controllers are currently set for each automation lane are
now all saved and restored, so switching away from Play mode and then back
again will retain all of those settings. (STEAM-8100, STEAM-8153)
Special tracks. A new Play ▸ Tracks submenu allows you to choose which of the
four special tracks that can appear above the first player track in Play mode should
appear: Time, Chords, Video, and Markers can now be individually hidden or
shown. When a video is attached to a flow in the project, the Video and Markers
tracks are automatically shown. (STEAM-8149)
Fine control of automation. It is now possible to hold the Alt key while dragging a
point in the tempo or MIDI automation lanes in Play mode to move the point by a
smaller amount, allowing finer adjustment. (STEAM-8124)
Increase/decrease track size. New commands to change the height of the selected
track in Play mode have been added, with the default key commands Shift+G and
Shift+H. (STEAM-8197)
Silence playback template. If you want to prevent Dorico from loading any sounds
in your current project, you can choose the new Silence playback template from
Play ▸ Playback Template. To make a project play back again, simply reopen this
dialog and apply one of the other playback templates. (STEAM-8194)
Choosing which sound to use for MIDI thru. Clicking on a track header in Play
mode now sets the end point that will be used to echo notes played from your MIDI
keyboard when note input is not active. It is also possible to change the sound by
making a selection on a staff in Write mode. (STEAM-8201)
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Playing techniques
Playing techniques that use imported graphics now show an orange outline when
selected, to make their selection state easier to see. (STEAM-8075)
Project files
When opening a project that was last saved in an earlier version of Dorico, an
informational message box appears, informing you of the version of Dorico in which
it was saved (if that can be determined), and alerting you to the fact that opening it
in a later version will automatically update it. The project is opened “clean”, i.e. it
will not prompt you to save if you try to close it immediately after opening it in the
current version, because all of the updates that have been carried out can be
carried out in the same way if you subsequently reopen the project in this later
version. If you don’t want to see this message, it can be disabled by switching off
Warn when opening projects last saved in an earlier or later version in the
Files section of the General page of Preferences.
If you want to guard against inadvertently overwriting a project last saved in an
earlier version of Dorico after opening it in the current version, you can switch on
Prompt to save projects from an earlier or later version to a new location,
found in the same location in Preferences. When this option is switched on, Dorico
will not automatically overwrite the project if you choose File ▸ Save or type
Ctrl+S (Windows) or Command-S (Mac): instead, you will see the standard file
picker dialog and be prompted to choose a new name and save location for the
project. You can of course choose to overwrite the existing project file at this point
if you wish. (STEAM-8193)
Properties
A new command Edit ▸ Propagate Properties has been added, which copies the
properties of the selected item or items from the current layout to all other layouts
in which they appear. When invoked from Write mode, only the properties that
appear in the Properties panel in Write mode will be propagated to other layouts;
when invoked from Engrave mode, the properties that appear in the Properties
panel in both Write and Engrave mode will be propagated.
In general, properties that appear in Write mode (which may apply to all layouts, or
which can vary by layout, but not by chain of music frames) tend to be more
semantic in nature, while properties that appear only in Engrave mode (which can
typically vary not only by layout, but also by chain of music frames) tend to be more
concerned with fine graphical appearance and positioning.
By way of example, slur placement and design (solid, dashed, etc.) are properties
that appear in Write mode and will be applied if Propagate Properties is invoked
from Write mode, while the precise position of slur end and control points are
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properties that appear only in Engrave mode and will only be applied if Propagate
Properties is invoked from Engrave mode. In this way, you can choose whether all
properties should be propagated, or only those that typically can apply regardless
of the specifics of the way each layout is formatted. (STEAM-8314)
Rhythm slashes
Hiding music behind slash regions. By default, slash regions now cause any
existing music in other voices under their span to be hidden: this allows you to
write, say, a possible solo realization for the purposes of playback, and still show
only the slashes in the score and part. If, however, you require other voices to
appear during a slash region, you can activate the Show other voices property in
the Slash Region group of the Properties panel. (STEAM-8138)
Bar count for slash regions. New options to display bar count numbers on rhythm
slash regions have been added via a new Count section on the Notes page of
Engraving Options:
§

Show slash region bar count every n bars specifies the interval at which
the bar count should appear; setting this to 1 will cause the bar count to
be displayed on every bar.

§

Appearance of slash region bar count specifies whether the count
should be shown With parentheses, Without parentheses, or not at all
(Do not show).

§

Placement of slash region bar count determines whether the count
should be shown above or below the staff.

§

Bar count distance outside staff n spaces specifies the distance
between the top or bottom staff line and the bar count number.

If necessary, bar count numbers can be nudged and dragged in Engrave mode.
(STEAM-8114)
Staff labels
Rich text for staff labels. The Edit Instrument Names dialog now provides
additional controls to allow more complex formatting of staff labels. To edit the staff
label that appears in the margin for a given instrument, expand the card of the
player holding the instrument in the Players panel in Setup mode, hover over the
name of the instrument so that the chevron > appears, then click and choose Edit
Names from the context menu. This dialog appears:

Dorico 2 Version History

Page 21

Steinberg Media Technologies GmbH

The text entered in this dialog is used not only for the staff label that appears to the
left of the staff in the margin, but also for labelling changes of instrument above the
staff, in which case any line or paragraph breaks will be removed, and the label
reduced to a single line. Furthermore, the alignment specified in the dialog is
ignored: instead, the alignment of the paragraph style will always be used. This is
to ensure that you can achieve a consistent alignment of staff labels from the top of
the system to the bottom.
To restore an instrument’s labels back to the defaults, click Reset to Default.
(STEAM-8273)
Staff group labels. A new option Staff labels for identical adjacent solo
instruments has been added to the Staff Labels page of Engraving Options.
Setting this to Group between staves will center the name of the instrument
between all of the adjacent staves belonging to identical instruments: for example,
two flutes will show a label “Flute” centered between the two staves, with the
upper staff being labeled “1” and the lower one “2”.
The group label is centered on the staves belonging to the identical instruments:
for an odd number of staves, the group label is centered on the middle staff line of
the middle staff; for an even number of staves, the group label is centered on the
gap between the two central staves.
A new paragraph style Staff labels (inner) is used for the instrument numbers and
for divisi sections, while the existing Staff labels style is used for instruments with
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no grouping, for the group labels, and for divisi group or player labels. This
illustration shows which kinds of labels use which paragraph style:
Staff labels
Staff labels (inner)

1
Flute
2

Bassoon

Solo
Violin
gli altri











The distances for inner and outer staff labels from the systemic barline are
determined using the options under Start of System on the Staff Labels page of
Engraving Options. (STEAM-8324)
Labels at the start of the flow. When a player holds multiple instruments, it is
important that the player knows which instrument he or she should be playing at
the start of each movement. In a full score layout, there will normally be a staff label
to the left of the first system, but in a part layout, this is not normally shown. A new
Show instrument change label at start of flow option has been added to the
Instrument Changes section of the Players page of Layout Options, switched on
by default in part layouts in new projects, but switched off in projects created in
Dorico 2.0 or earlier in order to preserve their appearance. When switched on, an
instrument change label will appear at the start of the first bar, reinforcing for the
player which instrument should be played. (STEAM-8242)
Divisi group labels. The Show player or group name option in the Change Divisi
dialog now takes precedence over the options on the Staves and Systems page
of Layout Options: the default instrument name shown as an outer staff label for a
divided system is the group name for the divisi if no groups are defined; otherwise,
the divisi group name is shown. (STEAM-8070)
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System dividers
It is now possible to specify that system dividers should appear only between
systems of differing numbers of staves (rather than when a flow contains at least a
certain number of staves), a convention that is followed in parts prepared for
recording sessions in Hollywood. To enable this behavior, set Show system
dividers to When number of staves differs in the System Dividers section of the
Staves and Systems page of Layout Options. The previous default behavior is
obtained by instead choosing When minimum number of players present.
(STEAM-8349)
Time signatures
Large time signatures. The option to show a single time signature for unpitched
percussion and keyboard instruments has been refined: now, any and all
instruments in any family between brass and strings will be grouped together and a
single large time signature will be shown. To reflect this change, the option is now
described as Instruments between brass and strings: Treat separately or Treat
as single bracket. (STEAM-7726)
Open meter. Type open into the Shift+M popover to create an open meter that
shows no symbol. (STEAM-8150)
Tuplets
Choice of font for tuplet digits. A new Plain font choice has been added to the
Tuplet digit style option on the Tuplets page of Engraving Options. When this
option is chosen, instead of using the traditional bold or light digits from the current
music font (Bravura, by default), the text font specified for Tuplet plain font in
Engrave ▸ Font Styles will be used instead. (STEAM-8218)
Positioning of tuplet bracket hooks. Two new Engraving Options have been added
under the heading Offsets for Start and End of Bracket in the Horizontal
Position section of the Tuplets page to provide default values for the left and right
delta for tuplet brackets. The Additional offset for start of bracket on stemdown tuplets value is only used when the tuplet bracket is shown and the stems
are down, while the Additional offset for end of brackets on stem-up tuplets
value is only used when the tuplet bracket is shown and the stems are up. The
values are set to zero in existing projects to avoid changing their appearance, and
to 1/4 spaces for new projects. (STEAM-8087)
User interface
Key commands. Three new commands in the Edit category in the Key Commands
page of Preferences have been added, to allow some reasonably common layoutrelated operations to be performed directly via keyboard shortcut without opening a
menu or dialog:
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§

Change Bar Consolidation allows you to set a specific key command for
each of the three states for displaying multi-bar repeats (no consolidation;
multi-bar rests only; multi-bar rests plus bar repeats).

§

Toggle Bar Consolidation can have a single key command assigned, and
which cycles through the three states when repeatedly invoked.

§

Toggle Layout Transposition can have a single key command assigned,
and toggles between Edit ▸ Transposing Pitch and Edit ▸ Concert
Pitch when repeatedly invoked. (STEAM-8239)

Transport display. Clicking on the time display in the mini transport in the toolbar
now cycles between bar.beat.tick, elapsed time, and timecode read-outs. In the
main Transport window, clicking on the right-hand time display toggles between
elapsed time and timecode. (STEAM-8115)
Restoring window sizes and positions. Dorico now more reliably restores the
saved sizes and positions of windows when reopening previously-saved projects.
(STEAM-3213)
Video
Locating missing video files. When opening a project with an attached video, if the
video cannot be found at the original location specified in the project, Dorico will
now look for the video file in the folder alongside the Dorico project itself and
automatically re-attach it if it is located there. (STEAM-7897)
Apple ProRes videos. Videos that use Apple’s ProRes codec will now play back
correctly as the ProRes codec is now distributed with Dorico (required on
Windows only; ProRes files play on Mac without requiring a separate codec).
(STEAM-8177)
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Issues resolved
ID #

Component

STEAM-5341

Accidentals

STEAM-7506

Accidentals

STEAM-8133

Accidentals

STEAM-7673

Articulations

STEAM-8174

Audio engine

STEAM-8162

Audio export

STEAM-8227

Barlines

STEAM-8143

Bars

STEAM-5767

Beaming

STEAM-8148

Beaming

STEAM-5767

Beams

STEAM-8204

Beams

STEAM-8156

Breaks

STEAM-8098

Chord
symbols

Chord symbols no longer incorrectly appear on extra staves added to instruments.

Chord

Chord symbols now correctly cause multi-bar rests to split on grand staff instruments

symbols

where one staff is hidden because it is empty.

STEAM-8213
STEAM-8022

Clefs

STEAM-8069

Clefs

STEAM-8023

Divisi

STEAM-8071

Divisi

Dorico 2 Version History

Issue
Changing the enharmonic spelling of a note with a microtonal accidental now works
reliably.
A number of problems relating to the choice of specific accidental in note input when
multiple accidentals in the tonality system have the same pitch delta have been resolved.
It is once again possible to select the symbols in the Edit Accidental dialog with the
mouse.
Staccato articulations are now positioned correctly under slurs on beamed grace notes.
Switching away from Dorico while it is starting up with the Suspend audio engine in
background preference enabled no longer sometimes causes it to hang (Mac only).
Attempting to switch to another open project while exporting audio from the first no longer
causes a crash.
Start repeat barlines now appear correctly at the start of the system if they coincide with a
time signature that is set to appear above the staff.
When deleting bars at the end of the project, Dorico now ensures that tempos, rehearsal
marks, note spacing changes and breaks in the deleted range are correctly removed.
Further improvements have been made to Dorico’s algorithms for avoiding “beam corners”
when beaming between notes on different staves.
Under some circumstances, stems on notes crossed between staves could appear on the
wrong side of the notehead when reopening an existing project; this is now fixed.
A problem that caused beam corners (where a partial beam is positioned on the wrong
side of a between-staves beam) to appear for some rhythmic patterns has been fixed.
A problem whereby noteheads could draw on the wrong side of notes when crossed to
other staves when first opening an existing project has been fixed.
Moving a system or frame break signpost with Alt+left/right no longer causes the signpost
to be removed altogether.

A problem whereby redundant clefs appear in extra staves belonging to an instrument has
been fixed.
Dorico no longer shows restorative clefs and key signatures at the end of a tutti passage at
the end of a system belonging to the divisi staves that were present earlier in the system.
Staves in galley view will no longer be spaced sufficiently far apart to make room for all
divisi staves, when the last divisi change has been deleted from a section player.
Time signatures at the end of a system that coincides with the end of a tutti range
(following the end of a divisi section on that system) now appear reliably in all staves.
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ID #

Component

STEAM-8085

Divisi

STEAM-8223

Divisi

STEAM-8284

Divisi

STEAM-8288

Divisi

STEAM-8322

Divisi

STEAM-7942

Dynamics

STEAM-8254

Dynamics

STEAM-8325

Dynamics

STEAM-8068

Flows

STEAM-8095

Flows

STEAM-8103

Flows

STEAM-8282

Flows

Issue
Changes of key signature in unison ranges before or after a divisi change on a system no
longer collide with the double barline after reopening the project.
Key signatures on divided transposing instruments in the preamble at the start of the
system now always show the correct transposition.
Disabling instrument changes for a given layout no longer causes the staff labels for divisi
staves to stop appearing correctly.
Pasting a divisi event that references a custom paragraph style into another project no
longer causes a crash.
Under some circumstances, pasting a divisi signpost could cause Dorico to crash; this is
now fixed.
Dynamics will no longer sometimes be positioned incorrectly in galley view after editing
them, e.g. changing their placement.
The cresc./dim. gradual dynamics in the Dynamics panel are no longer incorrectly shown
as hairpins in additional windows opened for a project.
Under some circumstances, edits to notes on one system could cause dynamics on the
previous system to change position incorrectly; this has now been fixed.
Playback is now always initialised correctly when importing flows into an empty project.
Splitting an existing flow no longer causes notes on the left-hand staff of a piano
instrument to be moved incorrectly to the right-hand staff in the new flow.
Layouts that contain only a subset of flows now play back correctly, and can be exported
as audio correctly.
Improvements to the handling of players with multiple identical instruments when importing
flows.

Graphics

Graphics files imported from OneDrive using the “on-demand files” feature now appear

import

correctly (Windows only).

STEAM-8183

Holds and
pauses

Caesuras that are not positioned immediately before a note, rest or barline no longer cause

STEAM-8183

Holds and
pauses

A caesura positioned at an arbitrary rhythmic position within a bar no longer causes the

STEAM-8085

Key
signatures

Key signatures no longer incorrectly collide with double barlines to their left when they

Key

Under rare circumstances, defining a tonality system with specific combinations of

signatures

divisions could cause a crash; this has now been resolved.

STEAM-8223

Key
signatures

Key signatures in divisi staves are now always correctly transposed if required in a

STEAM-8279

Layouts

STEAM-7482

STEAM-8208

Dorico 2 Version History

an unexpected spacing distortion at the following barline.
spacing of a time signature at the start of the following bar to be incorrect.
appear within a tutti range preceding or following a divisi change.

transposing layout.
Reset to Factory in Layout Options now restores staff label options to the correct values
for parts in part layouts; previously it was incorrectly using the defaults for full scores.
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ID #

Component

STEAM-8267

MIDI import

STEAM-8296

MIDI import

STEAM-8178

Mixer

STEAM-8083

Multi-bar
rests

Edits to grace notes close to divisi change events no longer sometimes result in multi-bar

STEAM-8121

Multi-bar
rests

Multi-bar rests no longer disappear at transitions between instruments when the player has

STEAM-8144

Multi-bar
rests

Creating a system break following a divisi change no longer incorrectly causes multi-bar

STEAM-8164

Multi-bar
rests

Divisi changes belonging to players who are cued into the current layout no longer

STEAM-5809

MusicXML
import

Transposing instruments created via MusicXML import are now correctly numbered, taking

STEAM-7884

MusicXML
import

Switching off the Beam groups option on the MusicXML Import page of Preferences

STEAM-8122

MusicXML
import

Some specific combinations of coincident tuplets in MusicXML files exported from Finale

STEAM-8203

MusicXML
import

Importing a MusicXML file into an existing empty project no longer results in some of the

STEAM-8256

MusicXML
import

Under some circumstances, the import of nested tuplets in MusicXML files could fail. This

STEAM-5625

Note input

STEAM-7113

Note input

STEAM-7493

Note input

STEAM-7506

Note input

STEAM-7585

Note input

STEAM-7585
STEAM-8167
STEAM-7852
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Note input

Issue
A problem whereby shorter notes contained entirely within the duration of longer notes on
the same instrument would be omitted when importing MIDI files has been fixed.
The last note in a MIDI file is no longer sometimes incorrectly omitted if its duration is
shorter than a quarter note (crotchet).
For some projects, the initial displayed position of the Video fader in the Mixer did not
match its actual output level when first opened; this problem has now been resolved.
rests being split incorrectly.
local time signature changes.
rests to be split.
incorrectly cause multi-bar rests to be split.
their transposition into account.
now correctly takes effect for all noteheads within a tie chain.
could cause Dorico to crash; this has now been fixed.
required default notehead types being missing from the project.
problem has now been fixed.
The default enharmonic spelling chosen for grace notes now matches the spelling chosen
for normal notes.
It is no longer possible to input notes on a staff not currently visible (e.g. an extra staff,
ossia, or divisi staff, or a staff belonging to another instrument held by the same player.)
It is now possible to lengthen or shorten the duration of an implicit rest repeatedly without
needing to reselect the rest after each edit.
The input of accidentals with equivalent pitch deltas in tonality systems that define multiple
such accidentals has been substantially improved.
Multi-paste now works reliably when copying material crossed from one staff to another.
Under some circumstances, cross-staff notes could be pasted onto the wrong staff; this
problem has now been resolved.
After using Edit ▸ Paste Special ▸ Move to Staff Above/Below, rests that were moved
as part of the selection now correctly remain selected.
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ID #

Component

STEAM-8021

Note input

STEAM-8066

Note input

STEAM-8082

Note input

STEAM-8086

Note input

STEAM-8105

Note input

STEAM-8134

Note input

STEAM-8147

Note input

STEAM-8249

Note input

STEAM-8262

Note input

STEAM-8263

Note input

STEAM-8270

Note input

STEAM-8289

Note input

STEAM-8297

Note input

STEAM-8298

Note input

STEAM-8319

Note input

STEAM-8329

Note input

STEAM-6975

Notes

STEAM-7665

Ornaments

STEAM-8206

Ossias
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Issue
Slurs that end at tuplet positions are no longer incorrectly unscaled when using Edit ▸
Paste Special ▸ Reduce.
Copying and pasting material between instruments with differing numbers of staves now
works correctly.
Attempting to change existing notes into a slash voice no longer sometimes causes Dorico
to crash.
Copying and pasting between instruments with different numbers of staves, or between
divisi staves and regular staves, now works as expected.
Copying and pasting an ossia or extra staff signpost from one instrument to another now
correctly creates additional staves if necessary.
Grace notes are now handled correctly by Edit ▸ Paste Special ▸ Explode.
Edit ▸ Paste Special ▸ Explode now works correctly if invoked on a staff that contains
both notes and dynamics.
The enharmonic spellings chosen for octave-transposing instruments no longer
unexpectedly differ for non-octave-transposing instruments.
It is no longer possible to use N/M to cause notes to disappear because they have been
crossed to an ossia or extra staff that is not visible at the selected rhythmic position.
Inputting notes via MIDI keyboard into a new voice now always produces the expected
enharmonic spelling.
The notes input on one instrument no longer incorrectly affect the enharmonic spellings
chosen for notes input on another instrument during the same input session.
Divisi, ossia and extra staff signposts are now excluded from block selection.
Using Alt+N/M to move items to the staff above or below no longer incorrectly attempts to
move pedal lines or divisi/ossia/extra staff signposts.
Setting articulations and accidentals before specifying the pitch of the grace note to be
input now works correctly.
Edit ▸ Paste Special ▸ Move to Staff Below (Alt+M) now correctly always moves to the
next staff when the selection being moved is not on the first staff of an instrument.
Starting note input via the mouse by clicking the Lock Duration button in the note input
toolbox now works correctly.
Under some circumstances, it was possible for a note’s rhythm dot to be shown twice
when the note is consolidated with a voice column to its left; this is now fixed.
Under some circumstances, single-stem tremolo slashes could collide with noteheads
because the stem was insufficiently lengthened; this has now been fixed (Windows only).
When an ossia is active on a grand staff instrument, only one of the main staves can be
hidden if empty, rather than allowing all regular staves of the instrument to be hidden.
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ID #

Component

STEAM-8063

Page layout

STEAM-8092

Page layout

STEAM-8165

Page layout

STEAM-8200

Page layout

STEAM-8243

Page layout

STEAM-8277

Page layout

STEAM-8278

Page layout

STEAM-8287

Page layout

STEAM-8312

Page layout

STEAM-8251

Percussion

STEAM-8157

Performance

STEAM-8246

Performance

STEAM-8268

Performance

STEAM-8103

Play mode

STEAM-8174

Play mode

STEAM-8285

Play mode

STEAM-7989
STEAM-8224
STEAM-8327
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Issue
A problem whereby editing the position of a tempo mark could cause the vertical spacing
to change unexpectedly has been resolved.
Hiding empty staves now once again works correctly for players holding multiple
instruments in layouts in which instrument changes are disabled.
Spurious additional clefs and key signatures no longer sometimes appear in the middle of
the system when extra staves are set via layout options to start at system breaks.
Changes made to staff spacing for extra staves belonging to an instrument are now
persisted correctly when saving and reopening a project.
Under some circumstances, moving a rehearsal mark in Engrave mode could cause a
tempo mark on another system to move; this is now fixed.
Under some circumstances, repitching music could incorrectly cause lyrics above the staff
to move further away from the staff; this is now fixed.
Under some circumstances, editing or inputting notes directly before a multi-bar rest could
cause the bar count number to move incorrectly away from the staff; this is now fixed.
It is now possible to select the staff spacing handles for multiple instruments held by the
same player independently when instrument changes are not shown for a layout.
A series of fermatas positioned on adjacent barlines no longer sometimes move incorrectly
when one of the fermatas is nudged in Engrave mode.
Under rare circumstances it was possible for Dorico to crash when editing the names of
instruments in a percussion kit from the Edit Percussion Kit dialog. This is now fixed.
The speed of inputting notes in projects that include changes in the number of staves for
an instrument has been improved.
The speed of inputting and editing music in larger projects with percussion kits shown
using the grid presentation type has been improved.
The speed of note input in larger projects with instrument changes has been improved.
A problem whereby layouts that do not have all flows attached could play back with long
periods of silence has been resolved.
A problem that could cause Dorico to hang during start-up if the Suspend audio device
in background preference was set has been fixed (Mac only).
The correct VST Expression Map is now chosen by default when creating a solo double
bass player when using the HALion Symphonic Orchestra playback template.

Playing

Adding an ossia staff above the right-hand staff of a piano no longer incorrectly causes

techniques

pedal lines to stop drawing.

Playing
techniques

Under some circumstances, pedal lines would draw on the top staff in the system in galley

Playing

Editing the default placement of a playing technique in Engrave ▸ Playing Techniques

techniques

now correctly updates any existing playing techniques in the score right away.

view; this is now fixed.
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ID #

Component

STEAM-8136

Print mode

STEAM-8198

Print mode

STEAM-7482

Project files

STEAM-8195

Project files

STEAM-2812

Setup mode

STEAM-8269

Setup mode

STEAM-7501

Slurs

STEAM-7674

Slurs

STEAM-8241

Slurs

STEAM-8155

System track

The appearance of the system track in music in open meter has been improved.

STEAM-8190

System track

The system track now draws correctly for bars that span more than one system break.

STEAM-8271

Text

STEAM-8320

Text

STEAM-8033

Time
signatures

Time signatures local to a single staff now draw correctly when global time signatures are

STEAM-8227

Time
signatures

Start repeat barlines now appear correctly at the start of the system when they coincide

STEAM-8110

User interface

STEAM-8129

User interface

STEAM-8185

User interface

STEAM-8219

User interface
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Issue
Lyrics colored by View ▸ Notes and Rests ▸ Voice Colors are no longer incorrectly
displayed in color in Print mode.
Commands from the Edit menu that can edit the score are now correctly disabled in Print
mode.
Importing a graphic located in OneDrive when using the files on-demand setting now
works correctly (Windows only).
Improvements have been made to the way that Dorico determines the filename to be used
when exporting multiple flows to a new project.
Under certain circumstances, dragging an instrument from one player to another in the
Players panel could cause a crash; this is now fixed.
Changing the instrument held by a player from one kind to another no longer incorrectly
changes any slash voices in that instrument’s music into regular voices.
Creating a slur with a single note selected now always correctly advances the slur to the
next note of a different pitch, instead of ending at the end of the current note if it is tied.
The positioning of slurs on grace notes in multiple voice contexts has been improved.
Attempting to create and extend a slur with the mouse when more than one window is
open on the project no longer causes an error message to appear.

The values for the default distance of text items from the staff were incorrect by half a
space; this has now been corrected.
Clicking Revert to Factory for one of default paragraph styles in Engrave ▸ Paragraph
Styles, no longer causes problems displaying items in the score or even a crash.
set to draw outside the staff.
with a time signature change, and the time signature is shown outside the staff.
It is once again possible to define shortcuts for commands nested two levels deep in the
Key Commands editor, e.g. for articulations, note durations, and so on.
The state of the various buttons in the user interface concerning the Video window now
always correctly stay in sync.
Navigating through the entries in the drum map with the arrow keys now correctly updates
the selection in the panel at the bottom of the Percussion Maps dialog.
Some list controls in Dorico incorrectly caused the Input Method Editor for CJK text input
to become activated; this has now been fixed (Windows only).
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ID #

Component

STEAM-8260

User interface

STEAM-8332

User interface

STEAM-8090

Video

STEAM-8093

Video

STEAM-8132

Video

STEAM-8178

Video

STEAM-8235

Video

STEAM-8101

Views

STEAM-8171

Views

STEAM-8176

Views

Dorico 2 Version History

Issue
Under some circumstances, the instrument labels in expanded player cards in the Players
panel in Setup mode would stop drawing; this is now fixed.
The Stereo output and Sample rate controls in Edit ▸ Device Setup no longer flicker
when changing values.
There is no longer a limit on the length of the path of an attached video file.
Changing the project frame rate via the Video Properties dialog now always correctly sets
timecode offsets for the current flow.
Advancing the playhead position frame by frame now always displays the correct timecode
in a newly-created project.
The position of the video fader in the Mixer is now always correct when opening an existing
project.
Dorico now always correctly detects the framerate of a video at 23.976fps.
The presence of a timecode staff no longer causes staves to become misaligned in galley
view in projects in which instruments have a variable number of staves.
Staff labels shown in the margin in galley view no longer disappear for a moment at certain
points when scrolling music left and right.
When multiple windows are open on the same project, only the window in focus will follow
changes of selection.
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Dorico 2.0
30 May 2018
This version contains the following new features, improvements and issue
resolutions.

New features
Video, markers and timecode
Dorico 2 now includes the same high-performance video engine as Cubase and
Nuendo, providing many new possibilities for composing to picture, together with a
suite of features for managing timecode, markers and tempo.

Supported video formats. The Cubase/Nuendo video engine was introduced last
year to replace the old 32-bit QuickTime-based engine, and currently supports the
most commonly-used video formats, with support for more formats planned for the
future.
H263 and H264 video is supported in both MOV and MP4 containers, while Apple
ProRes, DV/DVCPro and Avid DNxHR codecs are supported in MOV containers.
DV/DVCPro and MJPEG/PhotoJPEG are supported in AVI containers. Videos with
variable frame rates are not supported, but all the common frame rates (including
23.976, 24, 24.975, 25, 29.97, and 30 frames per second) are fully supported.
For more information about precisely which formats are supported, and for
information about how to determine the format of a video and transcode it to a
supported format, please consult the Steinberg support site:
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https://helpcenter.steinberg.de/hc/en-us/articles/115000808250-Video-supportin-Cubase-and-Nuendo
Attaching a video. You can attach a video to each flow in your project; if you a
working with a longer video (for example, a complete reel of a film), you can attach
the same video to multiple flows, and work with different sections of the video with
each flow. There are two ways to attach a video:
§ In Setup mode, right-click the flow in the Flows panel to which you want to
attach a video, and choose Video ▸ Attach Video from the context menu. A file
chooser dialog appears, allowing you to choose the video to be attached: click
Open and the video will be attached to the project.
§ In Play mode, drag the video file from the folder where it is located and drop it
on the timeline at the position where you want the video to be attached.
When you attach a video in Setup mode, the Video Properties dialog opens, with
the following options:

§ The read-only fields for Video file and Video frame rate report the complete
path to the attached video file, and the frame rate detected by the video engine.
§ Project frame rate specifies the frame rate that Dorico will use to determine the
timecode displayed in markers and in the Transport window; click Use video
frame rate to set this to the frame rate detected by the video engine. See
below for more information about the available frame rates.
§ Flow attachment position specifies the point in the flow at which the video will
start playing: you specify this as a multiple of beats of the specified unit. For
example, if you want two bars free at the start of a 4/4 flow, you would specify 8
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in the Beat count field and choose the quarter note (crotchet) from the Beat
unit control.
§ Video start offset specifies the frame of the video that will appear at the Flow
attachment position. For example, it may be a requirement that no sound is
played until the sixth frame of the video, so entering 00:00:00:06 in this field
specifies that when the video starts, it will start from the sixth frame.
§ Timecode start specifies what timecode should appear at the start of the video.
For example, each reel of a film is by convention given a timecode position
starting at a new hour, with the first reel often starting at 01:00:00:00 or
sometimes even at 10:00:00:00, with the second starting at 02:00:00:00 or
11:00:00:00, and so on.
When you have set the properties as needed, click OK.
If you attach the video in Play mode, the Video Properties dialog does not open
automatically, but it can be opened either via right-clicking the flow’s card in Setup
mode and choosing Video ▸ Properties from the context menu, or by clicking the
Video Properties button at the top of the Markers panel in Write mode.
Once a video is attached, a film reel icon appears in the
bottom left-hand corner of the flow’s card in the Flows panel
in Setup mode, together with the timecode of the first frame
of the video, as specified in the Video Properties dialog.
The Video window will also appear as soon as a video has been attached: the
window may appear black at first, but as soon as playback starts, the video will
appear.
Locating attached video files. Attached video files are not embedded in your
Dorico project: if you need to send your project to somebody else and they also
need access to the video, you will need to send the video file or files separately.
When you open a project that has an attached video and
the video cannot be located, the flow’s card in the Flows
panel shows a warning triangle icon in place of the film reel
icon. To restore the video to the project, simply re-attach
the same video file by right-clicking and choosing Video ▸ Attach: the video’s
existing properties will be preserved.
Working without an attached video. All of Dorico’s features for composing to
picture – including markers, timecode and finding tempo – can be used even if you
don’t have a video attached. You can specify a frame rate and initial timecode value
using the Video Properties dialog without attaching a video simply by right-clicking
the flow’s card and choosing Video ▸ Properties.
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Video window. The Video window can be hidden or shown by choosing Window
▸ Video, or using the default key command F4. The window’s size and position are
saved in the application’s preferences, rather than on a per-project basis.
Frame rates and timecode. Dorico supports a wide range of frame rates used in
professional film and TV production, from 23.976fps to 60fps, and includes
supports for drop frame timecode. NTSC video, used in US and Canadian
broadcast, has a frame rate of 29.97fps, and this requires the use of a drop frame
timecode. In non-drop frame timecode, each frame is simply numbered sequentially
from the preceding one; but in drop frame timecode, timecode numbers are
periodically skipped to compensate for the 0.03fps difference between 29.97fps
and 30fps. In every minute except every tenth minute, two timecode numbers are
dropped from the frame count. The same principle applies to the distinction
between 59.94fps and 60fps, a difference of 0.06fps.
In Dorico, non-drop frame timecodes are labeled with the suffix fps, while drop
frame timecodes are labeled with the suffix dfps.
Timecode is displayed in the format hh:mm:ss:ff, i.e. two-digit hours, minutes,
seconds, and frames. Drop frame timecode uses a semicolon separator between
the seconds and frames parts of the timecode rather than a colon, so 00:00:01:05
would be for a non-drop frame timecode, while 00:00:01;05 would be for a drop
frame timecode.
Timecode can be displayed in the Transport window (key command F2) instead of
regular elapsed time: to enable this, set Time display to Timecode on the
Timecode page of Playback Options.
Video soundtrack. The soundtrack of the attached video is played back in sync with
score playback. To control the relative volume of the video’s soundtrack, open the
Mixer (key command F3) and click the Video filter button in the Mixer’s toolbar to
show the video fader, which appears at the right-hand side of the list of faders,
immediately before the Reverb and Output faders. You can of course mute the
video’s soundtrack by muting the video fader.
Advancing through the video. The frame of video displayed in the Video window
always matches the playhead’s current position. If you find that you cannot see the
green playhead line when Dorico is not playing back, activate the Show playhead
when stopped checkbox in the Play section of the General page of Preferences.
The playhead can be moved by clicking the fast-forward and rewind buttons in the
Transport window, or using the + and - keys on your keyboard’s numeric keypad, if
it has one. If your keyboard does not have a numeric keypad, you can use F7 to
rewind and F9 to fast-forward; add Ctrl (Windows) or Command (Mac) to move
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by a single frame, rather than by a whole second. On Mac, you may also need to
add the Fn key, as by default the row of function keys is reserved by the system to
provide features like volume control, screen brightness, and media playback.
Markers. Markers are labels locked to a particular timecode in the video, typically
indicating an important moment that should be given some musical prominence.
Markers can be added at the playhead’s current position by choosing Write ▸
Create Marker or using the default key command Shift+Alt+M. The marker
appears in the score at the appropriate position, and the label in the marker (which
says Marker by default) can be edited either via the Marker text property in the
Markers group of the Properties panel, or via the Markers panel in Write mode.
Markers panel. Markers can also be added directly in the
Markers panel in Write mode by clicking the + button at
the bottom of the table that lists the markers in the current
flow. This can be useful if you have already, for example,
completed a spotting session and so already know the
timecode for each marker in the cue. You can edit both
the timecode and text for each marker directly in-line in
the table in the Markers panel simply by double-clicking
the field you need to edit.
The third column in the table in the Markers panel is
labeled Imp., which is an abbreviation for Important:
important markers are the ones it is most crucial to call
attention to musical terms, and play a vital role in Dorico’s Find Tempo feature. To
designate a marker as important, simply activate its checkbox in the Imp. column.
Marker design. Options for the design of markers can be found on the new
Markers page in Engraving Options, allowing you to determine whether the
timecode or the label should be positioned first, adjust the border thickness and
padding. To adjust the font family, weight or point size, edit the Marker text font or
Marker timecode font in Engrave ▸ Font Styles.
Choosing where markers appear. By default, markers appear above the top staff of
the full score layout, and do not appear in part layouts. To change this, set Vertical
position to Above system or Below system as appropriate, or alternatively you
can choose to display markers on a dedicated timecode staff.
Displaying timecode in the score. Dorico can display timecode in the score on a
special timecode staff. To show the timecode staff, choose the Markers page of
Layout Options and set Vertical position to Timecode staff, then set Position
timecode staff above bracket to the instrument family above which you want the
timecode staff to appear. Finally, you can choose whether you want timecode to
Dorico 2 Version History

Page 37

Steinberg Media Technologies GmbH

appear on every bar, every system, or never (in which case only markers will appear
on the timecode staff), by setting Timecode frequency on timecode staff as
desired.
Dragging markers in Write mode. Markers have a fixed timecode position, and are
effectively locked to a specific frame in the attached video. In order to adjust the
position in the music where a marker appears, you can drag it left or right in Write
mode: to accommodate the desired position for the marker, this adjusts the
immediate tempo preceding the marker (or at the start of the flow, whichever is the
later) and clears any gradual tempo changes between that immediate tempo and
the marker. Dragging a marker to the right increases the tempo, while dragging it to
the left decreases the tempo. This is a simple tool: it is not currently possible, for
example, to drag one marker but lock the position of all previous markers, so that a
tempo change takes effect only after a specific marker. For these kinds of more
sophisticated edits, you can edit the time track in Play mode.
Editing the time track in Play mode. The new time track in Play mode allows fine
graphical control over the tempo changes in the flow. When a video is attached,
tracks for markers and the attached video also appear at the top of the event
display in Play mode. When editing the tempo in the time track, the position of the
markers is updated in real-time, making it easy to adjust the position of each
marker relative to the music by inserting tempo changes at key points.
Find Tempo. Dorico can also help you identify an appropriate tempo for the whole
flow using the new Find Tempo window, which can be opened by clicking the
Find Tempo button in the Markers panel in Write mode:

Dorico 2 Version History

Page 38

Steinberg Media Technologies GmbH

The Find Tempo window can only be used if at least one of the markers is
designated as important (Imp.) in the Markers panel. The window allows you to find
the tempo that is the best fit for the important markers in the flow, such that the
important markers fall as close as possible to beats.
Choose the desired Beat unit from the control on the left, then choose the lower
and upper bounds of the tempos that can be found using the Tempo range slider
on the right. As you adjust the beat unit and tempo range, the Tempos found list
on the left is updated. The found tempos are listed in descending order of average
“frames off” for important markers, i.e. the average number of frames by which the
markers miss being aligned to beats.
The abbreviations IFO, NFO and AFO are for the average number of frames off for
important markers (IFO), non-important markers (NFO), and all markers (AFO).
The Markers list on the right provides a more detailed view of the tempo selected
from the Tempos found list: the list shows each marker, and then, assuming the
selected tempo is used, the number of frames off the beat (Fr. Off), the time
difference between the marker’s position and the beat expressed in fractions of a
second (Time Diff.), and the notated difference between the marker’s position and
the beat expressed in fractions of a whole note (Not. Diff.).
When you have chosen the most appropriate tempo, select it in the Tempos
found list and click the Apply button below the list, which adds the chosen tempo
at the start of the flow, clearing all other tempo markings from the flow.
Time signatures
Dorico 2 introduces new features for the display of time signatures, with two new
placement options, and three new design options. As alternatives to their usual
placement within each staff, time signatures can now be displayed above the same
staves as system items like tempo and rehearsal marks, or a single large time
signature can be centered on each bracket. Both of these options can help to draw
attention to time signatures in music with frequent changes of meter.
Choosing time signature placement. To choose one of the new placement options
for time signatures, open the new Time Signatures page in Layout Options:
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Choose the appropriate type of placement for the type of layout whose options you
are editing: typically Show once per bracket and Show at system object
positions would be used only in score layouts, with the exception that in some part
layouts destined for the recording studio, you may choose to use Show once per
bracket in order to use larger time signatures than normal.
Time signatures shown once per bracket. Large time signatures shown on
brackets occupy horizontal space, and as they are often significantly larger than
normal time signatures, they can occupy significantly more horizontal space. For
this reason, it is usually advisable to choose one of the other design options for
time signatures, which are also found on the new Time Signatures page of Layout
Options:

The Narrow, serif option uses narrow versions of the traditional time signature
numerals, and is similar in look to those used in editions of works by Britten,
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Birtwistle, and other composers around the middle of the 20th century. The
Narrow, sans serif option uses sans serif numerals comparable in appearance to
Helvetica or other grotesque fonts, and is similar in look to those used in music
prepared for film, TV and game recording sessions. You can alternatively choose
the Plain font option, which will use the font defined by the Time signature plain
font style (editable in Engrave ▸ Font Styles), but it is advisable to choose a
narrow or condensed style.
A single time signature will appear on every bracket in the ensemble, by default
centered vertically on the bracket: single, unbracketed staves will show a time
signature, though by default it is larger than a normal time signature; pairs of
braced staves will likewise show a time signature on each staff, larger than a
normal time signature. If instead of showing a single time signature for each
bracket you would prefer Dorico to consider the brackets for unpitched percussion,
pitched percussion and keyboard instruments as a single group that should
together receive only one time signature, open Engraving Options, go to the Time
Signatures page, and set Brackets for percussion and keyboards to Treat as
single bracket.
In score preparation for film, TV and game recording sessions, time signatures are
sometimes aligned with the top of the bracket rather than the middle: to achieve
this, open Engraving Options, go to the Time Signatures page, and set Vertical
alignment relative to bracket to Top.
On the Time Signatures page of Engraving Options, you can also specify the
scale factor for brackets with varying numbers of staves, relative to a normal time
signature on a single staff when using the default Show on every staff option.
Separate scale factors are provided for time signatures on single staves (1 1/4, or
125%), on brackets of two or three staves (4 or 400%), and on brackets of four or
more staves (10 or 1000%).
Time signatures at system object positions. Time signatures shown above the top
staff and, optionally, other staves above which system items such as tempo and
rehearsal marks appear have the advantage of occupying no horizontal or rhythmic
space, at the expense of occupying more vertical space. This type of placement for
time signatures has become increasingly popular in art music through the course of
the 20th century, with editions of works by composers including Carter and Henze
making use of it.
The staves above which the time signatures will appear are the same as those
above which rehearsal marks, tempos, repeat endings, etc. will appear, which can
be controlled using the options in the System Objects section of the Staves and
Systems page of Layout Options.
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By default, time signatures above the staff are shown at twice the size of normal
time signatures, and this can be changed via the Scale factor for time signatures
shown at system object positions option on the Time Signatures page of
Engraving Options.
Because time signatures above the staff do not occupy any rhythmic space, it is
not crucial to use one of the narrower time signature designs, but it is worth
considering that when a time signature coincides with a rehearsal mark or a tempo
instruction, by default the time signature will force any such items to the right, so
using one of the narrower designs will reduce the distance by which these items
are displaced. If you would prefer tempo and rehearsal marks to be positioned
above time signatures instead, change Position of time signatures relative to
coincident tempo and rehearsal marks to Position below on the Time
Signatures page of Engraving Options.
If a time signature above the staff coincides with a bar number, the bar number can
optionally be hidden by activating Hide bar numbers at time signatures at
system object positions on the Bar Numbers page of Layout Options.
Time signatures above the staff can optionally be centered over the barline or leftaligned; time signatures announcing a change of meter at the end of a system will
be right-aligned with the end of the system unless there is also a change of key of
sufficient width that the time signature’s chosen alignment can be used. Alignment
is determined by the Alignment relative to barlines option on the Time
Signatures page of Engraving Options.
When the time signature’s denominator is shown as a note value, it is displayed to
the right of the numerator rather than below, and using an up-stem note. You can
adjust the scale factor of the denominator note independently from the scale factor
of the numerator by changing Scale factor for denominator when shown as
note duration on the Time Signatures page of Engraving Options.
Each time signature can be nudged independently in Engrave mode using
Alt+arrow keys or by dragging it with the mouse. Use Edit ▸ Reset Position to
remove the offset.
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System track
The system track is a new user interface element that makes it easier to add and
delete bars and to select music on all staves in the system.

The system track is shown by default in new projects, and can be hidden or shown
by choosing View ▸ System Track. When shown, the system track appears above
the top staff of the system, and is translucent until you move the mouse pointer
over the track, at which point it becomes opaque. The system track only appears in
Write mode.
If you would prefer the system track not to be shown by default, switch off Show
system track in new projects in the View section of the General page of
Preferences.
Clicking in the system track makes a selection in the system track: hold Shift and
click in the system track above another bar and the selection is extended. Once
there is a selection in the system track, additional buttons appear in and above the
system track: at the left-hand extent of the selection is a delete button; at the righthand extent is a button to select the music on all instruments in the range specified
by the selection on the system track; and a button to insert a bar between the last
bar selected in the system track and the following bar.
If you hold down Alt while the system track is visible, grid lines conforming to the
current rhythmic grid value are drawn on the system track, allowing you to make
partial bar selections by clicking and dragging across the system track. As with
selections of complete bars, when the selection is complete, buttons appear at the
left- and right-hand extents of the selection to delete or select the music
respectively.
Selections on the system track are transitory: they are intended to persist only as
long as needed to perform another action, such as inserting a bar or selecting all of
the music in the system track selection range on all instruments. As such, the
system track selection is cleared whenever you make any other kind of selection, or
when you switch layout, but it is retained when switching between page and galley
view.
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Automation
Dorico 2 includes new tools for fine control over tempo and continuous MIDI
controllers, expanding the capabilities of Play mode and showing the path for future
developments in this area.

Time track. The time track at the top of the event display in Play mode allows you to
edit the tempo of your project. Immediate tempo changes appear as step changes
in the tempo profile, while gradual tempo changes appear as a slope between two
points. You can click and drag any handle to adjust the tempo at that point, and a
small read-out next to the mouse pointer provides visual feedback as to the tempo
at that point.
It is also possible to create new tempo changes in the time track: use the draw tool
to click new tempo changes onto the track; you can keep the mouse button held
down and sweep it across to draw in multiple tempo changes at once. The
frequency of the tempo changes created is determined by the rhythmic grid
setting: the smaller the rhythmic grid value, the greater the number of tempo
changes that will be created as you sweep the mouse across the track.
To create a smoother, linear gradual change, use the line tool: click the point at
which the change should begin, then drag to the position where the gradual
change should end.
Tempo changes inserted with the draw or line tools in Play mode appear as
signposts in Write mode by default, so as to avoid changing the appearance of the
printed score. If you want these tempos to be printed, you can select them in Write
mode and then set the Text property in the Tempo group in the Properties panel
to make them appear.
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To delete tempo changes in Play mode, use the erase tool: simply click on each
point in the time track to delete that tempo change.
MIDI controller tracks. Each instrument can now display a lane for editing MIDI
controller data. Although only a single lane can currently be displayed, it is possible
to create data for multiple MIDI controllers.
To show the MIDI controller lane, click the new button in the track header for the
instrument for which you want to create automation data:

The lane appears

directly below the instrument to which it belongs. Choose the MIDI controller for
which you want to create data from the menu in the controller lane’s track header:
all 127 MIDI continuous controllers are listed. Any controller for which data already
exists is annotated in the menu with an asterisk (*).
Creating automation data for MIDI controllers uses the same tools as creating
tempo change data in the time track: the draw tool creates individual points and
can be used to click and drag across the range, drawing discrete points at each
division of the rhythmic grid; the line tool creates smooth, linear transitions between
two values; and the erase tool can be used to clear any existing points by clicking
on them.
MIDI export. All automation events drawn in the time and MIDI controller tracks are
included when exporting MIDI files.
Divisi
Divisi – from the Italian “to divide” – is a common technique in orchestral string
writing, especially though not exclusively for violins, and occasionally used in other
instruments outside the string section, for example in choirs. By splitting a single
section into multiple smaller sections, each written on its own staff, greater
sonority, color or counterpoint is possible.

Working with divisi passages has historically been quite awkward in music notation
software, but Dorico 2’s unique new features for divisi change that for the better.
In simple terms, you create a divisi in the instrument that will divide, specifying how
many staves should be used, and how each of those staves should be labeled.
Dorico then takes care of managing those staves for you automatically: there is no
need for you to arrange for a change in divisi sections to occur at a system or
frame break, as Dorico will automatically show unison music in each divisi staff as
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required if a divisi either starts or ends in the middle of a system. When the divisi
section ends, you simply create an instruction to restore tutti, and again Dorico
manages the removal of the additional staves completely automatically.
Creating divisi. Divisi can only be created for instruments held by section players:
because a solo player represents only a single person, it’s not possible for that
instrument to be divided, but a section player represents multiple people all holding
the same instrument, so that can be divided. To create a new divisi, select the point
at which the divisi should begin, and choose Edit ▸ Staff ▸ Change Divisi. The
following dialog appears:

The list at the top of the dialog shows the current divisions: when creating a new
divisi, only a single division labeled Tutti is present. The action bar below the list of
divisions allows you to create new divisions of two types: soloists, and sections. To
add a soloist, click the Add Solo Division button ( ), and to add a section, click
the Add Section Division button ( ). Each soloist or section you add corresponds
to an additional staff in the score. There is no limit on the number of soloists and
sections you can create: to make things as simple and flexible as possible, Dorico
doesn’t keep count of the total number of players involved, and simply trusts that
you know what you’re doing.
To change the label shown for a division, select the division from the list at the top
of the dialog, and then edit the text in the Staff labels section below. The section
label, which is normally simply number or possibly a letter to denote which desks or
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players should play this music, appears directly to the left of that section’s staff at
the beginning of every system.
You can additionally group sections together, by selecting multiple adjacent
divisions in the list of divisions at the top of the dialog and clicking the Add Group
button ( ). The group label appears centered on all of the staves belonging to the
divisions in the group, and will appear in place of the instrument name. When
editing the group label, you can edit the Full Name and Short Name
independently, using the buttons that appear directly above the editor.
Finally, the Show player or group name and Show section numbers options at
the bottom of the Change Divisi dialog allow you to specify whether or not the
labels defined for this particular divisi should follow the default options for whether
or not staff and divisi labels should appear as specified on the Staves and
Systems page of Layout Options (Follow Options), or whether they should be
explicitly overridden such that they always appear (Show), or are always hidden
(Hide).
When all the settings have been made to your satisfaction, click OK and the divisi
change will be created. A signpost appears, and this can be dragged with the
mouse or moved with Alt+left/right in Write mode to move the rhythmic position at
which the divisi change occurs. The additional staves specified by the soloists and
sections defined in the divisi change appear from the start of the system, with the
appropriate labels to the left of the system, and if there are any whole or partial
bars of unison music prior to the divisi change, that music is automatically shown in
all of the new divisi staves until the divisi change. You can then simply input music
into the new divisi staves as if they were any other kind of staff.
Editing an existing divisi change. To edit an existing divisi change, simply doubleclick the Divisi signpost, and the Change Divisi dialog will open, allowing you to
make changes. If you remove a divisi section, be aware that the music that was
previously on that staff is not removed, so it will continue to play back: you may
want to delete any music from a divisi staff that you plan to remove before you
remove the section. Conversely, if you subsequently recreate a divisi section that
previously existed, all of its music will be restored.
Changing divisions. If a divisi passage becomes further divided, or indeed if some
but not all divisions come to an end, you can create a further divisi change in the
same way as described above at the appropriate point. Note that the staves that
appear on a system are those defined by only the first divisi change; any further
divisi change on the same system will take effect at the start of the following
system.
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Ending a divisi passage. When the divisi passage has come to an end, select a
note or rest in the main staff at that position, and choose Edit ▸ Staff ▸ Restore
Tutti. This creates a default divisi change with a single tutti section, without
showing the dialog. If this change occurs before the end of the system, unison
music will automatically be shown on the divisi staves for any whole or partial bars
between the divisi change and the end of the system.
Unison passages. When you select unison music on a divisi staff, you will notice
that the same items are selected on the main staff and indeed on all other divisi
staves: the music cannot be edited independently, so any changes made on a divisi
staff will be reflected on all other staves with that music.
To make it clear where unison passages occur, you can switch on View ▸ Note
and Rest Colors ▸ Divisi Unison Ranges. This will show the notes and rests in
unison passages in mid-gray, to help differentiate them from the actual divisi
material.
Due to the complexity of showing the same source music on multiple staves, there
are some modest limitations in what kinds of material Dorico can handle when it
automatically shows unison music on divisi staves, either at the start of the system
before a divisi passage begins or at the end of the system after a divisi passage
ends. The primary limitation is with slurs: any slur that is ongoing at the point that
the divisi passage begins will not be shown on the divisi staves. To work around
this, move the start of the divisi passage to the beginning of the slur, and then
manually copy and paste that music onto the divisi staves. Similar issues exist with
lyrics, and octave lines will only apply on the main staff, though gradual dynamics
(such as hairpins) are handled correctly.
If a divisi staff uses a different clef to the main staff at the point at which it returns
to playing unison material, Dorico automatically creates the appropriate clef on that
staff, but it may sometimes be spaced too close to the note immediately before it. If
possible, try inserting an appropriate clef change somewhere before the end of the
divisi passage to restore the same clef as the main staff.
Divisi and staff labels. Two new options have been added to the Staff Labels
section of the Staves and Systems page of Layout Options:
§ Show group names is only enabled when either or both full and abbreviated
staff labels are set to appear in the current layout; when switched on, the divisi
group label will appear instead of the instrument name.
§ Show section names can be set independently of whether either divisi group
names or the instrument’s name is shown; a typical scenario where divisi
section names should be shown but regular staff labels should not is in part
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layouts, where it is already known that all of the staves should be played by (say)
Violin I, and so showing the staff label adds no further useful information.
These options can be overridden on a per-divisi change basis by the Show player
or group name and Show section numbers options in the Change Divisi dialog.
Playback of divisi. In this release, all divisi material – including material for soloists
– is played on a single channel, so only limited differentiation between the different
sections is possible. In a future release, Dorico will make it possible to assign each
soloist and section within a divisi passage to a separate channel, in order to
provide fully flexible playback of divisi passages.
Divisi on vocal staves. When using divisi on a vocal section player, Dorico will
automatically show choral divide arrows at the end of the system prior to the start
of the divisi passage:

It will show corresponding arrows on each of the divisi staves directing the singers
back to a single staff at the end of the system where the divisi passage ends.
To control this behavior, change the Indicate divisi at end of system on vocal
staves option on the Divisi page of Engraving Options.
Ossias
Ossias show alternative passages that can be played instead of the original
passage; sometimes they are used to show editorial recommendations for realizing
ornaments, or deviations between different sources, or to show an easier version.
Dorico 2 introduces comprehensive features for handling ossia passages.

Adding an ossia. To add an ossia, select the range over which you want the ossia
staff to appear, then choose Edit ▸ Staff ▸ Create Ossia Above or Create Ossia
Below. If you are writing for piano or another grand staff instrument, and require an
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ossia that shows both staves, select material on both the right- and left-hand
staves before you choose Create Ossia Above or Create Ossia Below.
You can create an ossia for an instrument held by a solo or section player, with the
exception that you cannot create an ossia for a percussion kit instrument. An
instrument can show an ossia both above and below if necessary, but only one
ossia on the same side of the staff at once.
A signpost appears at the start of the ossia passage, and another at the end where
the ossia staff disappears again. You can select these signposts and move them by
dragging them in Write mode or nudging them with Alt+left/right, which will also
move the start and end rhythmic position of the ossia.
Removing an ossia. To remove an ossia passage, you can simply delete the
signpost at each end of the ossia passage, or select any note or rest in the ossia
passage and choose Edit ▸ Staff ▸ Remove Staff.
Be aware that when you delete an ossia, unless you first deleted the music within
the ossia, that music still exists but is simply not shown: if you recreate an ossia at
the same position later on, that music will reappear.
Scale factor. By default, ossia staves are scaled to two thirds the size of a regular
staff, and this can be adjusted via the Ossia scale factor option on the Staves
page of Engraving Options.
Deciding where ossias appear. By default, ossia staves will appear in all layouts,
but it may be more appropriate for ossias to appear only in the part layout for an
individual performer, or possibly only in the score. To choose whether ossias
appear in a layout, activate or deactivate Show ossias in the Ossias and Extra
Staves section of the Staves and Systems page of Layout Options as
appropriate.
Barline joins. There are several conventions in use in published music for how
barlines in ossias should be joined to the main staff to which they correspond:
assuming an ossia both starts and ends at whole bar positions, some publishers
join the ossia to the main staff both at the start and the end; others join the ossia
only at the end; and still others do not join the ossia to the main staff at all.
When an ossia is joined to the main staff, some publishers use the same kind of
barline as used for the other staves (typically a single barline), but others instead
join the ossia with a dashed barline.
Dorico provides options to accommodate all of these conventions in the Ossias
section of the Barlines page of Engraving Options.
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When an ossia appears between the main staves of an instrument – for example,
an ossia below the right-hand staff of a piano – then it will always be joined by the
same barline as the main staves, regardless of the options chosen on the Barlines
page of Engraving Options.
Ossia labels. To label the beginning of an ossia staff with the word “ossia”, activate
Show label before ossia in the Ossias and Extra Staves section of the Staves
and Systems page of Layout Options. If you would prefer to use a custom label,
set Ossia label to Custom and then provide the desired text in the Custom ossia
label field.
The ossia label is drawn in the staff labels paragraph style, and is positioned
according to the distances defined in the Ossias section of the Staves page of
Engraving Options, with separate options for labels before single and braced pairs
of ossia staves.
Ossias beginning or ending mid-bar. If an ossia begins or ends in the middle of the
bar, Dorico pads the staff lines to the left and to the right of the musical material to
ensure that notes, accidentals, rhythm dots and other items do not directly abut the
ends of the ossia staff. To adjust the amount of padding to the left and to the right,
change Extend staff lines at start of ossia and Extend staff lines at end of
ossia in the Ossias section of the Staves page of Engraving Options.
Ossias crossing breaks. When an ossia starts on one system and then ends on the
next, you may want to see the ossia’s clef and key signature restated at the start of
the system, as it is for a regular staff; alternatively, to make it clear that the ossia is
not an additional instrument, you may prefer that the ossia should restart following
the fixed preamble of clef and key signature at the start of the system.
Dorico can accommodate either approach: set Ossias crossing a system break
to Include in preamble or Exclude from preamble in the Ossias and Extra
Staves section of the Staves and Systems page of Layout Options.
Vertical spacing. The default distance of an ossia from the main staff to which it
corresponds is determined via the new Ossia staff to staff value on the Vertical
Spacing page of Layout Options. This distance is not subject to vertical
justification.
You can adjust the distance between an individual ossia staff and its main staff
using the staff spacing tools in Engrave mode in the usual way: instead of the
handle appearing at the left-hand side of the system, the handle for the ossia will
appear at the start of the ossia staff on that system.
Ossias and playback. Music on ossia staves is never played back.
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Changing the number of staves for an instrument
Dorico 2 now makes it easy to add or remove staves from an instrument at different
points in the flow, allowing for example the notation of complex works for piano
where three or sometimes more staves are required.
Adding an extra staff. To add an extra staff to an instrument, select a note or rest
on the staff above or below which you want the extra staff to appear, at the
rhythmic position at which you want the extra staff to begin, and choose Edit ▸
Staff ▸ Add Staff Above or Add Staff Below. The extra staff is added from that
position, and a signpost appears, labeled with the number of staves that have been
added (or removed).
The instrument must belong to a solo player: you cannot change the number of
staves of instruments held by section players. It is also not possible to add
additional staves to a percussion kit instrument.
Removing an extra staff. To remove an extra staff, either select the signpost that
corresponds to the point at which the extra staff appears, or select the note or rest
on the staff you want to remove at the point at which you want it to be removed,
and choose Edit ▸ Staff ▸ Remove Staff. This can also be used to remove one of
the primary staves of an instrument, for example either the right- or left-hand staff of
the piano (though of course you cannot remove all of the staves belonging to an
instrument: at least one will always appear).
Choosing when an extra staff should begin. When a staff starts or stops in the
middle of a system, you may want that staff to appear or disappear exactly at that
point, or you may prefer for that system to appear for the whole of that system. This
is controlled by way of the new Show extra staves across full system when
starting or stopping checkbox in the Ossias and Extra Staves section of the
Staves and Systems page of Layout Options.
Hiding empty staves. When extra staves are added to an instrument, it will no
longer be affected by the Allow individual staves of multi-staff instruments to
be hidden option on the Vertical Spacing page of Layout Options.
Rhythmic slashes
Rhythmic slashes are used to indicate that a performer should play something, but
without being especially specific about exactly what they should play: slashes
without stems are generally interpreted as giving the performer complete freedom
to play whatever he or she likes; slashes with stems are generally interpreted as
dictating the rhythm to be played, but without being specific about the pitches. The
former is sometimes called slash notation, while the latter is sometimes called
rhythmic notation. Dorico 2 introduces sophisticated support for both kinds of
rhythmic slashes.
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Slash regions. The quickest way to add rhythmic slashes is to use a slash region,
which allows you to fill a range of bars with slashes, where the rhythm of the
slashes is automatically determined by the prevailing time signature: for example, in
bars of 4/4, four quarter note slashes will be shown, while in 6/8, two dotted
quarter note slashes will be shown. Changing the time signature causes the
durations of the slashes in the region to be updated automatically.
Slash regions are created by selecting one or more bars and choosing Write ▸
Create Slash Region, or by opening the new Shift+R popover, typing slash and
hitting Return to confirm the popover. The slash region is created to the duration of
the selection, and by default shows a green highlight behind the slashes to show
that the slashes are part of a region (to disable this, switch off View ▸ Highlight
Slash Regions). Handles at the start and end of the slash region allow you to
extend the region at either end; you can also use Alt+left/right to move the start of
the slash range, and Shift+Alt+left/right to increase or decrease the duration of
the slash region.
Cutting a slash region. You may find that you need to cut a slash region in two, for
example because you want to write some more specific notation in the middle of
the region. To achieve this, select the slash at the position at which you want to
split the slash region, then click the scissors tool in the notes toolbox, or type U.
The slash region is split in two at that location, and you can then, for example, drag
the start handle of the second half of the region right to make room for whatever
you need to write.
Rhythm dots for slash regions. In compound time signatures, there are different
conventions for whether or not rhythm dots should be shown on slashes; by
default, Dorico will show rhythm dots on slashes of the duration of a compound
beat, but this can be changed via the Slash regions in compound time
signatures option in the Rhythmic Slashes section of the Notes page of
Engraving Options.
Appearance of slashes. Dorico provides several different appearances for rhythmic
slashes, and you can choose between any of the provided designs by setting
Slashes with stems and Slashes without stems to the desired appearance in
the Rhythmic Slashes section of the Notes page of Engraving Options.
Slash voices. When you want to write more specific rhythmic notation than is
provided by a slash region, you can write rhythmic notation using a slash voice.
Input using a slash voice is exactly the same as when using a regular voice, except
that whatever pitch you specify will be overridden, and instead of the note or chord
you input, a single slash will appear on the middle line of the staff by default. You
can convert an existing voice to and from a slash voice, so the underlying pitches of
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the notes and chords are retained and will be restored if you change the voice
back to a regular voice.
To start a new slash voice in note input, choose Write ▸ Create Slash Voice, or
type the default command Shift+Alt+V; this is analogous to the default Shift+V
command to add a new regular voice.

Typing Shift+Alt+V repeatedly cycles through the types of slash voice that can be
added: slashes with stems, stem up; slashes with stems, stem down; and slashes
without stems. As with a regular voice, the indicator to the left of the caret shows
what kind of voice you are about to add.
Once you have input some slashes, the slash voice is available for reuse anywhere
else on that instrument, and when cycling through the voices with V, the slash
voice will be included.
Changing slash voice type. If after inputting rhythmic notation in a slash voice you
want to, say, switch to slashes without stems, you can do so by selecting one of
the slashes and choosing the desired voice type from Edit ▸ Voices ▸ Rhythmic
Slashes: if you choose Normal Notes from this submenu, the voice will be
converted to a regular voice, and the original pitches of the notes and chords as
they were first input will be restored.
For slash regions, you can toggle between slashes with and without stems by
selecting any slash in the region or either the start or end handle, then activating
the Stemless property in the Slash Region group of Properties.
Changing stem direction. For slashes with stems, you can specify whether the
default stem direction for the slash voice should be up or down in the same way as
for a regular voice: choose Edit ▸ Voices ▸ Default Stems Up or Default Stems
Down as desired.
For slash regions, you can specify stem direction by selecting any slash in the
region or either the start or end handle, then activating the Voice direction
property in the Slash Region group of Properties.
Changing staff position. By default, slash regions and slash voices both show
slashes on the middle line of the staff. The staff position can be changed in the
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same way: activate the Slash pos. property in the Slash Region or Notes and
Rests groups respectively, and then set the desired value. A value of 0
corresponds to the middle staff line, with positive numbers moving slashes
upwards, and negative numbers moving them downwards.
Rests before and after slash regions. If a slash region starts or ends in the middle
of the bar, you may or may not want the remainder of that bar to be padded with
rests, depending on whether any other music is going on at the same time in that
staff. By default, slash regions will pad incomplete bars with rests at either end, but
you can suppress these rests by activating the Hide rests before start and Hide
rests after end properties in the Slash Region group in Properties.
Opposing slash voices. In the event that you have a slash voice opposing either
another slash voice or a regular voice, Dorico will override the default staff position
for the slash voice in order to reduce the likelihood of collisions between the
voices. The amount by which the slash voice is offset is determined by the options
in the Rhythmic Slash Voices group of the Voices page of Notation Options.
Slashes and unpitched percussion. To use slashes on a percussion kit, open the
Edit Percussion Kit dialog (expand the card for the percussion player in the
Players panel in Setup mode, and open the dialog from the instrument’s context
menu). You can add slashes with or without stems to the percussion kit using
either of the Slashes buttons in the action bar below the 5-line Staff editor. More
than one set of slashes can be added to a percussion kit and positioned at
different staff positions.
In note input, moving between the different instruments in the kit using the arrow
keys will include any slashes you have added to the kit, and you can input slashes
just as you would input any other music on a percussion kit.
Slashes in percussion kits only appear when using the five-line staff presentation
type: if you switch to the grid or individual instrument presentation types, the
slashes will not appear.
Bar repeats
Bar repeats indicate to the performer that the material in the preceding one, two or
four bars should be repeated exactly: this notational shorthand can be very helpful
to the performer as it is easier to read a bar repeat and understand that the music
is to be repeated exactly than to read multiple bars of written-out music, trying to
spot whether or not it is actually repeated exactly.
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Bar repeat regions. After you have input the music that is to be repeated, make a
selection beginning in the following bar and extending as far as you would like bar
repeats to be shown (though you can of course change this later), and choose
Write ▸ Create Bar Repeat Region. This creates a bar repeat region that shows
the 1-bar repeat sign for the extent of the selection. You can alternatively type
Shift+R to open the new repeats popover, then enter % to repeat the last bar, %2
to repeat the last two bars, or %4 to repeat the last four bars.
To change the number of bars to be repeated after you have created a bar repeat
region, select any of the repeat bar symbols or the circular handle at the start or
end of the region, and change the value of the No. bars property in the Bar
Repeat Region group in the Properties panel.
By default, a light blue highlight appears behind bar repeat regions to help them
stand out: to toggle the visibility of this highlight, choose View ▸ Highlight Bar
Repeat Regions.
Counting bar repeats. Dorico automatically shows a count of the number of
repetitions at intervals above the bar repeat region. By default, it shows the count
every four bars, with the bar or bars of music being counted as “one”; so, for
example, if you have a single bar of music followed by a bar repeat region covering
three bars, the third bar repeat will be counted as “four.” To change the default
count interval, set Show bar repeat count every n bars on the Bar Repeats page
of Engraving Options. To prevent the count from appearing altogether, set
Appearance of bar repeat count to Do not show.
These defaults can be overridden for an individual bar repeat region: activate the
Count frequency or Count appearance in the Bar Repeat Region group of
Properties. You can also specify the number that Dorico should count from by
activating the Count from property.
To change the font, size or style of the bar repeat count, edit the Bar repeat count
font style in Engrave ▸ Font Styles.
The precise position of the numbers above bar repeats can be adjusted in Engrave
mode with the mouse or by nudging with Alt and the arrow keys.
Grouping bar repeats. In music with a very regular phrase structure it may be
desirable to show that structure by grouping bar repeats. For example, in music
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with a regular four-bar structure, you could choose to show two identical phrases
of four bars like this:

Or you could choose to group at four-bar intervals, like this:

Although it is even less conventional, it is also possible to show the first four-bar
phrase using a three-bar repeat, like this:

To enable grouping, select any bar repeat symbol or the handle at either end of the
bar repeat range, then set the Group every property to the desired number of bars.
To show a three-bar repeat when completing a four-bar phrase, set Appearance
for three-bar remainder of group to Use 3-bar repeat on the Bar Repeats page
of Engraving Options.
It is also possible to specify grouping when creating a bar repeat region using the
Shift+R popover: %1,4 will produce a one-bar repeat grouped every four bars,
while %2,4 will produce a two-bar repeat grouped every four bars, and so on. It is
only possible to specify grouping at one, two or four bars, but if Dorico determines
that the requested combination of settings is invalid, it will default to no grouping.
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It must be noted that grouping bar repeats should be exercised with caution, as it
can introduce ambiguity.
The range of bar numbers encompassed by a consolidated bar repeat region can
be shown beneath the consolidated bar repeat by activating the Show ranges of
bar numbers under multi-bar rests and consolidated bar repeats option on the
Bar Numbers page of Layout Options.
New arranging tools
Dorico 2 introduces a number of new note editing tools to assist with common
tasks during arranging, including multi-paste, explode and reduce, and moving and
copying material to the staff above or below.
Multi-paste. When pasting copied material, Dorico can now paste multiple copies
both horizontally and vertically to fill the range described by the extent of the
selection: if only a single item is selected, then pasting works exactly as before, but
if multiple items are selected, Dorico considers the nominal rectangle described by
the contiguous range of instruments on which items are selected, the rhythmic
position of the first selected item on the top instrument and the rhythmic position of
the last selected item on any of the selected instruments, and then fills that
rectangle with as many complete copies of the material as fit within it.
If there is a discontiguous selection of instruments, then Dorico will consider each
contiguous range of instruments as separate regions for pasting: this allows you to
(for example) copy dynamics from one instrument and then multi-paste them to
several instruments, but omitting one or two instruments in the middle of the range.
Even if the rhythmic extent of the selection is shorter than the length of the copied
material, Dorico will paste one complete copy of the material onto each instrument
in the region, but if the selection is longer than the copied material, Dorico will
paste as many complete copies of the material after each other as fit without
overflowing the selected region. (STEAM-7450)
Moving music to the staff above or below. Two new commands have been added
to the new Edit ▸ Paste Special submenu: Move to Staff Above and Move to
Staff Below, which have the default key commands Alt+N and Alt+M (by analogy
with Edit ▸ Cross Staff ▸ Cross to Staff Above and Cross to Staff Below, which
have the default key commands N and M).
These commands cut the selected notes and other items from their current staff,
and then paste them on the staff above or below in a single operation. This is very
useful in a variety of situations: for example, after importing a keyboard part from a
MIDI file, you may want to move individual notes from the right-hand staff to the
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left-hand staff, or vice versa; after using the new explode or reduce features, you
may want to make adjustments to individual voicings; and so on.
When moving notes within tuplets to the staff above or below, beware that unless
the tuplet number/bracket (or signpost) itself is selected, the tuplet will not be
moved to the staff above or below, so the notes will be unscaled and no longer
part of a tuplet.
Duplicating music to the staff above or below. The new Duplicate to Staff Above
and Duplicate to Staff Below commands in the Edit ▸ Paste Special submenu
work similarly to Move to Staff Above and Move to Staff Below, except that
instead of cutting and pasting, these commands copy and paste, so the selected
material remains on the original staff and is duplicated on the staff above or below.
Reduce. Reduction is the process of taking music for more than one instrument
and assigning it to fewer instruments (or even a single instrument, in the case of a
keyboard reduction). The new Edit ▸ Paste Special ▸ Reduce command aims to
partially automate this demanding task.
First, copy the material to be reduced to the clipboard using Edit ▸ Copy. Then
select the instrument or instruments into which the copied material should be
reduced, and choose Edit ▸ Paste Special ▸ Reduce.
Dorico pastes the copied material, and performs some transformations as it does
so: if the rhythms match, it merges the material into a single voice; it removes
unison notes, so that only a single note of the same pitch is pasted at a given
rhythmic position; and it strips out clef changes, octave lines, and cues.
The disposition of the copied material onto the selected instruments for pasting is
determined automatically, and will ensure that every destination instrument receives
at least one instrument’s music, duplicating that instrument’s music if necessary:
for example, if you copy material from four instruments and reduce into two
instruments, the material will be split equally between the two instruments, from the
top downwards in instrument order; if you copy material from five instruments and
reduce into three, the first instrument will be assigned music from the first two
instruments, the second will be assigned music from the third and fourth
instruments, the third will be assigned music from the fifth instrument.
Explode. Exploding is the charming colloquial term for taking music written on a
certain number of instruments (typically one or two) and pasting it onto a larger
number of instruments, and this can now be performed by choosing Edit ▸ Paste
Special ▸ Explode.

Dorico 2 Version History

Page 59

Steinberg Media Technologies GmbH

First, copy the material to explode to the clipboard using Edit ▸ Copy. Then select
the instrument or instruments into which the copied material should be exploded,
and choose Edit ▸ Paste Special ▸ Explode.
Dorico ensures that each destination instrument receives one of the notes in the
source chords, allocated from top to bottom: if the number of notes in the chord
matches the number of destination instruments, then each instrument will receive
one note; if the number of notes in the chord is less than the number of destination
instruments, then the same note will be allocated to more than one instrument.
Non-note items such as slurs and dynamics will also be duplicated to each
destination instrument.
Playing techniques editor
It is now possible to edit existing playing techniques and create your own, with the
new Engrave ▸ Playing Techniques dialog.

Editing an existing playing technique. To edit an existing playing technique, choose
the appropriate category from the Playing Technique Category menu at the top
left-hand corner of the dialog; this corresponds to the categories shown in the
Playing Techniques panel in Write mode. The playing techniques in the chosen
category are displayed in the list directly below the menu: the selected playing
technique is then shown in the main editor that occupies the right-hand side of the
dialog.
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The editor will look different depending on the Type of playing technique chosen:
Text playing techniques show the text to be displayed in the score; Glyph playing
techniques show the graphical symbol (usually one or more characters from the
music font, but this can in fact be any combination of glyphs from music fonts,
characters from text fonts, and even graphics files).
Editing a Text playing technique is done directly in this dialog: simply change the
displayed text by editing the Text field, and specify which font style should be used
by choosing it from the menu immediately to the right of the Text field; by default,
the font style used is Playing technique font.
Editing a Glyph playing technique involves opening a secondary dialog: depending
on whether the playing technique uses the same or a different appearance when
shown above or below the staff, there will either be a single pencil icon in the
action bar in the large preview in the top half of the dialog, or one pencil icon for
each appearance. Click the pencil icon, and the secondary editor opens:

To add a new component to the playing technique, select it from the panel on the
right-hand side of the dialog: you can choose any character from any font in the
Glyph tab, write one or more words in any font style in the Text tab, import a
graphic in SVG, PNG, or JPG format via the Graphic tab, or add any of the existing
other musical symbols that are used throughout the project from the Composite
tab.
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Once you have added a component, you can move it either by dragging it with the
mouse or by using Alt with the arrow keys. Each component can be scaled, either
by clicking and dragging on one of the handles, or using the X scale and Y scale
spin controls; graphics components can be scaled independently in the horizontal
and vertical dimensions, while glyphs, text and composite components must be
scaled a uniform amount in both dimensions.
If you have multiple overlapping components, you can determine which should
draw in front and behind each other using the Z order buttons to move the
selected component towards the front or the back.
Once you have designed the playing technique to your satisfaction, click OK to
close the secondary editor and return to the main dialog.
The other options below the main preview panel are as follows:
§ Category: the choice of category determines which section of the Playing
Techniques panel the playing technique appears in.
§ Default placement: specifies whether the playing technique should appear
Above or Below the staff by default.
§ Appearance only applies to glyph-type playing techniques; Same above and
below means that the same symbol will be used when the playing technique is
shown above or below the staff, and Different above and below allows you to
specify a different symbol for each side of the staff.
§ Popover text: the text that can be typed into the Shift+P popover to create this
playing technique; the editor will warn you if the text you specify is already
assigned to another playing technique.
§ Playing technique: the playing technique that will actually be produced in
playback; see below.
§ Duration: this currently has little effect, since Dorico does not yet provide all of
the planned options for showing the continuation of a playing technique (which
will eventually include solid and dashed lines and arrows of various kinds in
addition to the current repeated glyph appearance), but for future development
this allows you to specify whether this playing technique should show a
continuation by default (Has duration) or should instead apply only to a single
rhythmic position (Has no duration).
§ Shown in cues: determines whether or not this playing technique will appear in
a cue, assuming the cue is set to include playing techniques from the source
instrument.
Playback playing techniques. The playing techniques whose appearance you edit
in the Engrave ▸ Playing Techniques dialog are all bound to a playback playing
technique, which can be chosen from the Playing technique menu when editing a
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playing technique appearance. You can also edit existing playback playing
techniques and define your own by clicking the Edit button to the right of the
Playing technique menu, which shows the following dialog:

The Playing Technique Group menu at the top left-hand corner allows you to
choose which group of playback playing techniques to edit. These groups are
defined in the VST Expression Maps format and specify the type of behavior that
will be produced during playback:
§ Techniques: playing techniques that affect the overall quality of the sound.
§ Dynamics: playing techniques that affect the volume or attack of the sound.
§ Lengths: playing techniques that affect the played duration of notes, and
qualities such as legato and détaché.
§ Ornaments: playing techniques that include additional or different notes to the
written pitch, or changes to the pitch or vibrato of the note.
The Name on the right-hand side determines how this playing technique will
appear in the lists in the Engrave ▸ Playing Techniques, Play ▸ Expression Maps
and Play ▸ Percussion Maps dialogs. The values that can be set for each
playback playing technique are as follows:
§ Alias for: specifies another playback playing technique, with which the present
one is equivalent.
§ Group: specifies which group this playback playing technique appears in.
§ Fallback: specifies another playback playing technique that can be used if the
present playing technique is not available.
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§ Articulation type: specifies the duration over which the playback playing
technique takes effect; Attribute applies only to the note at the rhythmic
position where the playing technique is found (for example, a staccato
articulation), while Direction applies to all following notes until it is
countermanded by another playing technique (for example, a pizzicato
instruction).
Once you have made the necessary changes, click OK. The edited or new
playback playing technique will now be available in this project.
Making edited playing techniques available to other projects. All of the edits made
in Engrave ▸ Playing Techniques apply only to the current project by default. To
make a new or edited playing technique available in all future projects, select the
playing technique from the list on the left-hand side of the dialog and click Save as
Default: this new or edited technique will then be reflected in every new project
created subsequently.
To revert an edit made to one of the default playing techniques, select the playing
technique from the list on the left-hand side of the dialog and click Revert to
Factory.
Petaluma handwritten music font
A new handwritten music font family called Petaluma is included with Dorico 2. The
family consists of three fonts: Petaluma, Petaluma Text, and Petaluma Script.
Petaluma is the main font used for all of the musical symbols in the score; Petaluma
Text is used for musical symbols drawn in text-like items like metronome marks,
chord symbols, dynamics, and so on; Petaluma Script is a script font suitable for
use for all other text in the score.

The Petaluma family is loosely based on the hand copying style of a popular series
of books containing jazz standards, although it contains a repertoire of more than
1350 musical symbols and 500 letter forms, a far greater variety of symbols than
are found in any single set of publications.
To use Petaluma in your project, choose Engrave ▸ Music Fonts, choose
Petaluma from the list of available music fonts, and click OK. Doing so will also set
Petaluma Script as the default text font for the project: if you want to use another
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text font, edit Default text font style in Engrave ▸ Font Styles and Default text in
Engrave ▸ Paragraph Styles.
Petaluma is a SMuFL-compatible music font, and is licensed under the SIL Open
Font License, which means that it can be freely used, modified and distributed,
provided any modifications are also released under the OFL. The Reserved Font
Name for this family is “Petaluma”, and any derivative fonts may not use this name.
Finally, neither the Petaluma font family nor any derivative fonts can be sold
separately, though they can be distributed as part of a package that is sold
commercially.
Support for NotePerformer 3
Dorico 2 also introduces support for NotePerformer 3 from Wallander Instruments.
NotePerformer is a virtual instrument specifically designed to produce playback
from music notation software.

NotePerformer 3 is not included with Dorico 2, but is available for separate
purchase from www.noteperformer.com, from where you can also download a 30day trial version.
After you have purchased and installed NotePerformer 3, to use it in Dorico, open
the project you would like to play back using NotePerformer and choose Play ▸
Playback Templates. Choose NotePerformer from the list of playback templates,
and click OK.
If you would like to use NotePerformer for every new project, set Default playback
template to NotePerformer in the Play section of the General page of
Preferences.
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Improvements
Accidentals
Microtonal accidentals now play back correctly via HALion Sonic SE or other VST
Note Expression-capable VST 3 instruments, both during playback and when
auditioned when notes are selected in the music.
Audio export
A progress dialog now appears during audio export on both Windows and Mac,
and more accurately depicts the actual progress of the operation. (STEAM-5293)
Barlines
Hymnal-style repeat barlines. In some hymnals, such as The New English Hymnal,
repeat barlines are drawn in a particular way: the dots are shown in each space,
and instead of showing some combination of thin and thick barlines, repeats are
indicated by two thin barlines, except at the start of a system, where no barlines are
shown, and only the four dots are shown. This convention can now be followed in
Dorico by setting Coincident repeat barline appearance to Double thin
barlines, and setting Repeat dot frequency to All spaces in the staff, on the
Barlines page of Engraving Options. (STEAM-7668)
Bar numbers
Ranges of bar numbers on multi-bar rests. Dorico can now display the bar
numbers included in a multi-bar rest directly as a range directly below the multi-bar
rest. To enable this, activate Show ranges of bar numbers under multi-bar rests
on the Bar Numbers page of Layout Options.
New options on the Rests page of Engraving Options allow you to change the
default distance below the staff for the range of bar numbers, and specify the
separator to use between the first and last bar numbers in the range. (STEAM7791)
Appearance of bar numbers in different layouts. A new Paragraph style option has
been added to the Bar Numbers page of Layout Options, allowing you to choose
which paragraph style should be used for each layout in your project. In new
projects, full and custom score layouts use the Bar numbers (score) paragraph
style, while part layouts use the Bar numbers (parts) paragraph styles; in existing
projects, both score and part layouts use the Bar numbers (score) paragraph
style, which is updated to match the appearance of the bar numbers font style
used in Dorico 1.x, to ensure that the appearance of bar numbers does not change
when these projects are opened in Dorico 2.
By default, both the Bar numbers (score) and Bar numbers (parts) paragraph
styles look the same, but having separate styles makes it easy to change the font,
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size or style of bar numbers in, say, the part layouts without affecting the full score.
(STEAM-7813)
Chord symbols
Color. Chord symbols now respect the Color property in the Common group in
Properties. (STEAM-6493)
Clefs
Specifying the clef to be used in concert and transposing pitch. Several of Dorico’s
preset instrument types use a different clef when displaying the music in concert
and transposed pitch, and it is now possible for you to specify this directly for each
clef in the flow if necessary. In the Edit ▸ Clef submenu there are now two new
submenus, Concert Pitch and Transposed Pitch, from which you can choose any
of the clefs available from the Clefs panel in Write mode. (STEAM-7676)
Dynamics
Erasing the background behind dynamics. When an immediate dynamic with a
prefix or suffix or a text-based gradual dynamic crosses a barline, or in rare
circumstances when a dynamic must be positioned within the staff, allowing the
dynamic to blank out part of the barline or staff lines can make the dynamic
considerably easier to read.
A new Erase background property has been added to the Dynamics group of the
Properties panel, which appears only in Engrave mode. When activated, a small
area around the dynamic is erased. The default amount of padding around the
dynamic is determined by the new Padding around dynamic with erased
background value on the Dynamics page of Engraving Options, and can be
overridden by activating the new Erasure padding properties, also found in the
Dynamics group of the Properties panel.
When determining the shape of the area to be padded, Dorico considers the prefix
and suffix separately from the bold italic characters that indicate the dynamic level,
which means that, for example, when padding a dynamic such as  risoluto, the
padding will be taller for  than for risoluto. The padding by default takes into
account any ascenders and descenders in the text, so depending on the exact
position at which the dynamic crosses the barline, it may appear that the area of
erasure is larger than it need to be; for example, if a dynamic has the suffix
espressivo, but it crosses the barline at “s” rather than “p”, the padding may appear
too large below the dynamic. To resolve this, you can override the amount of
padding on any of the four sides of the nominal bounding box that surrounds the
dynamic, so you could reduce the bottom padding such that it no longer pads
outside the descender, and thus make the area of erasure appear symmetrical both
above and below the characters.
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The padded area of erasure is considered part of the dynamic’s bounding shape
for the purposes of collision avoidance. (STEAM-7656)
Hairpins with flared ends. A hairpin with a flared open end is used by some
composers to indicate a rapid increase or decrease in dynamic level, sometimes
colloquially referred to as an “exponential hairpin.” To make a hairpin show a flared
end, select it and activate the new Flared end property; this property is only
available for gradual dynamics drawn as hairpins, and only for hairpins drawn with a
solid line.
The default size of the flared end can be specified by changing the options in the
new Flared end design group in the Gradual Dynamics section of the Dynamics
page of Engraving Options. The size of the flared end for an individual hairpin can
also be adjusted in Engrave mode by changing the new Flare size W (width) and
H (height) properties. (STEAM-7778)
Filters
New filters for markers, bar repeat regions and rhythm slash regions have been
added to the Edit ▸ Filter menu. The Filter menu is now also included in the rightclick context menu for easier access.
Fingering
Custom scale factor. A new Scale property has been added to the Fingering
group of the Properties panel, which appears only in Engrave mode, and which
allows the scale factor of a fingering to be changed independently from the scale
factor of the note to which it applies. (STEAM-7346)
Appearance of cautionary fingerings. It is now possible to override the appearance
of individual cautionary fingerings via the new Cautionary property in the Fingering
group of the Properties panel, which appears only when a note (and not a
fingering) is selected, and only in Engrave mode. The property can only be
activated for a note that has a cautionary fingering: it will otherwise be deactivated
automatically. When the property is activated, you can choose between the
following values: (STEAM-7345)
§ Default: uses the appearance for cautionary fingerings defined in Engraving
Options.
§ No parentheses: show the fingering without parentheses.
§ With parentheses: show the fingering enclosed in parentheses.
§ Suppress: hide the cautionary fingering altogether.
Circled or underlined fingerings. It is now possible to specify that a fingering
should either be enclosed in a circle, or underlined; these adornments are
sometimes used for accordion fingering to indicate that a finger is playing in a help
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row. To enable this, select a fingering number and activate the new Decoration
property in the Fingering group of the Properties panel, which appears only in
Engrave mode. A number of options for the size of the circular enclosure, the
thickness of the line, and so on, can be found by disclosing the Advanced Options
subsection of the Design section of the Fingering page of Engraving Options.
(STEAM-7308)
Galley view
The size and position of the staff labels in the margin and the bar numbers above
the top staff has been improved.
HALion Sonic SE (STEAM-7672)
Dorico 2 now includes HALion Sonic SE 3. For an updated Operation Manual for
the new version, please visit:
https://steinberg.help/vst-manuals/halion/halion-sonic-se-3/
Mixer
You can now Ctrl+click (Windows) or Command-click (Mac) on a volume fader or
pan control to reset the value back to its default. (STEAM-8046)
Notes
Stemless notes. A new Hide stem property has been added to the Notes and
Rests group of the Properties panel, only appearing in Engrave mode. When
activated, the stem of the selected note will not be drawn; any flag will also be
hidden. If the selected note is part of a beamed group, then the stem will be
hidden, but the beam will continue to be shown as normal, unless every note in the
beamed group has the Hide stem property set, at which point the beam will also
be hidden. (STEAM-7494)
Note input
Scale existing notes into a tuplet. It is now possible to scale a selection of existing
notes into one or more tuplets: select the notes that should be made into tuplets,
and type ; (semicolon). The tuplet popover opens, with a suggested ratio based on
the number and durations of the selected notes already filled in; you can either
accept the suggested ratio by hitting Return, or type the desired ratio, then hit
Return to confirm the popover. If the selected notes fit into a single tuplet of the
specified ratio, then only one tuplet will be created, but if the specified ratio is
insufficient to scale all of the selected notes, further tuplets will be created until all
of the selected notes are contained within a tuplet.
It is now possible to specify the beat unit of the tuplet directly into the tuplet
popover by appending either the letter that corresponds to a note duration (2h =
double whole, w = whole, h = half, q = quarter, e = eighth, etc.) or the number
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that corresponds to the default key command for that duration in note input (9 =
double whole, 8 = whole, 7 = half, 6 = quarter, 5 = eighth, etc.), and then
appending one or more full stop (period) characters to specify a dotted beat unit.
When using a number to specify the duration, you must separate the beat unit from
the number of beats either using a space or a hyphen. By way of example, 5:4q.
means “5 in the time of 4 dotted quarters”, while 3:2-2w means “3 in the time of 2
double whole notes”. (STEAM-4129)
Note spacing
Opposing stems. Stem tips are now padded a little such that opposing stems on
adjacent staves cannot abut: instead, the staves are forced further apart. (STEAM7490)
Percussion
Percussion legends. Percussion legends are now positioned inside rehearsal
marks and tempo text. (STEAM-7602)
Playback templates (STEAM-7760)
Playback templates describe the rules that Dorico uses to allocate sounds from
VST instruments or MIDI devices to instruments in your project. Until now, there
has been only a single default playback template, which uses instances of HALion
Sonic SE and the included HALion Symphonic Orchestra and HALion Sonic SE
library content to play back your projects. It has been possible to override the use
of this default playback template by making your own assignment of sounds or VST
instruments; thereafter, Dorico would no longer assign sounds on its own, until you
instructed it to apply the default playback template.
Default playback templates. The new entry-level Dorico Elements product does not
include the HALion Symphonic Orchestra sounds, and hence relies entirely on the
HALion Sonic SE library content for default playback. As such, Dorico Pro now
provides two default playback templates: HSSE + HSO (Pro) and HSSE only
(Elements). The former is equivalent to the default playback template in Dorico 1.x;
the latter does not use any sounds from HALion Symphonic Orchestra, and is
equivalent to the default playback template in Dorico Elements.
To specify which playback template Dorico should use for newly-created projects,
a new Default playback template option has been added to the Play section of
the General page of Preferences.
To choose a different playback template for the current project, or to apply one of
the default playback templates, choose Play ▸ Playback Template, and choose
the desired playback template from the list.
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Adding further playback templates. Dorico will load data for further playback
templates from subfolders within folders called PluginPresetLibraries and
PlaybackTemplateGenerators in system-wide or user-specific application data
folders, i.e.
§ Windows: %PROGRAMDATA%\Steinberg\Dorico 2 (system-wide)
or %APPDATA%\Steinberg\Dorico 2 (user-specific)
§ macOS: /Library/Application Support/Steinberg/Dorico 2 (system-wide) or
~/Library/Application Support/Steinberg/Dorico 2 (user-specific)
The name of each subfolder within these folders determines the name of the
playback template as it will appear in Dorico.
The two files loaded from the named subfolder within PluginPresetLibraries are:
§ presets.xml: a list of all of the presets or patches in a virtual instrument’s library,
defining for each the name of its corresponding expression map or percussion
map.
§ presets_for_instruments.xml: a list of all of the default instrument types that
can be created in Dorico and the preset that should be loaded by default for
that instrument.
The named subfolder within PlaybackTemplateGenerators must contain a file
called playbacktemplategen.xml, which specifies the UID of the VST instrument
to load, the PluginPresetLibraries data to use, and some other parameters (such
as the number of MIDI channels provided by the instrument, the number of audio
outputs, and default send levels for the effects channel). The subfolder may also
optionally contain a .pluginstate file that should be loaded into the VST instrument
when it is instantiated.
It is not intended that end users should need to create their own playback
templates using these data files: this information is provided for the benefit of third
party VST instrument and sound library developers.
Playback
Note shortening. The Play as % of written duration option on the Timing page of
Playback Options has been constrained so that longer notes, or music played at a
slow tempo, are not excessively shortened. A note will be shortened to the
specified amount if it is a quarter note (crotchet) or shorter in duration; if it is longer
than a quarter note, then only the final quarter note portion of the note will be
shortened. This quarter note portion also takes the prevailing tempo into account,
so the maximum amount by which a note can be shortened is the defined
percentage of a quarter note at 120 quarters per minute. (STEAM-7984)
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Move playhead to selection. A new default key command, Alt+P, has been added
to move the playhead to the position of the first selected item. This is very useful
when working with attached video, as it allows you to see which frame
corresponds to a specific rhythmic position. (STEAM-5811)
Playing techniques
Hiding playing techniques. It is sometimes desirable to hide playing techniques, for
example to avoid unnecessary repetition. To hide a playing technique, select it and
activate the new Hidden property in the Playing Techniques group in Properties.
A signpost will appear, which can itself be hidden from view if desired by choosing
View ▸ Signposts ▸ Playing Techniques. (STEAM-7646)
Erasing the background behind text-based playing techniques. When a playing
technique crosses a barline, it can be useful to erase the background around the
playing technique to make it easier to read. To allow this, a new Erase
background property has been added to the Playing Techniques group in the
Properties panel, which appears only in Engrave mode. The default amount of
padding around the playing technique is determined by the new Padding around
playing technique with erased background option on the Playing Techniques
page of Engraving Options, and can be overridden for an individual playing
technique by activating the Erasure padding properties. (STEAM-7669)
Horizontal offset for text-based techniques. A new option Horizontal offset for text
playing techniques has been added to the Playing Techniques page of Engraving
Options. This is set to zero spaces by default, but if for example you want textbased playing techniques to appear slightly to the left of the note or chord to which
they apply, set this new option to a small negative value. (STEAM-7709)
Repeats
Repeats playback. Dorico now has limited support for playback of repeat
structures: repeat endings and repeat barlines are now played back. The bar/beat
and time display in the Transport reflects the current position in the repeat
structure. Audio and MIDI export both also include repeats. (STEAM-3910)
Shift+R popover. A new popover has been added with the default key command
Shift+R for the creation of repeat endings, single- and multi-stem tremolos,
rhythmic slash regions and bar repeat regions. The terms that can be input into the
popover are as follows: (STEAM-7636)
Single-stem tremolos
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z

zonstem

Z on stem

0

clear

Remove tremolo

Multi-stem tremolos
/

\

1

One stroke

//

\\

2

Two strokes

///

\\\

3

Three strokes

////

\\\\

4

Four strokes

0

clear

Remove tremolo

Repeat endings
end

New repeat ending

ending

Add segment to existing repeat ending

add
Rhythmic slash region

New rhythmic slash region

slash
Bar repeat region
%

Repeat last bar

%1

%2

Repeat last two bars

%4

Repeat last four bars

%1,2

Repeat last bar, group in twos

%1,4

Repeat last bar, group in fours

Tempo
Editing the beat unit of existing tempos. A new Beat unit property has been added
to the Tempo group of the Properties panel, allowing you to edit the beat unit of a
selected tempo item: for example, to change the note value shown in a metronome
mark from a quarter note (crotchet) to a dotted quarter note, simply select the
tempo item, then activate the rhythm dot button shown in the row of buttons.
(STEAM-7462)
Tempo range separator. By default, Dorico uses an en dash to separate the lower
and upper numbers shown for a tempo range. If you would prefer to use a different
separator, you can set the new Separator for tempo range option on the Tempo
page of Engraving Options to Custom separator, and then specify exactly which
characters should be used. (STEAM-7708)
Metronome marks. The spacing of rhythm dots relative to notes in metronome
marks has been improved. (STEAM-7473)
Text
Borders. A new Border property has been added to the Text group in the
Properties panel. When activated, a border will be drawn around the text item, with
the default thickness of the border determined by the new Border thickness
option on the Text page of Engraving Options. The thickness of the border can
also be overridden for an individual text item by activating the new Border
thickness property, which appears only in Engrave mode. The default padding
between the text and its border is determined by the Padding around text with
erased background value on the Text page of Engraving Options, and can be
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overridden by setting the Erasure padding properties in the Text group of the
Properties panel. (STEAM-7658)
Collision avoidance. A new Avoid collisions property has been added to the Text
group in the Properties panel, allowing you to override the default setting for
collision avoidance as specified on the Text page of Engraving Options. When the
property is unset, text is drawn at its default vertical position above or below the
staff, and no other item will avoid colliding with it: you can tweak its position in
Engrave mode in the usual manner. (STEAM-7670)
Furthermore, a new Minimum distance from protruding items option has been
added to the Text page of Engraving Options, allowing you to specify how much
padding should be left between a text item and another item (such as a note or
slur) that protrudes from the staff; previously, the text item would have been
allowed to touch the protruding item. (STEAM-7696)
Tokens for page numbers. The following new tokens have been added in Dorico 2,
and can be entered in text frames:
§ {@pageCount@} – the total number of pages in the layout
§ {@flowPage@} – the number of this page within the current flow, counting from
1 for the first page of the flow (i.e. not the displayed page number)
§ {@flowPageCount@} – the total number of pages in the current flow
§ {@flownFirstPage@} – the displayed page number of the page on which flow n
begins; insert the number of the flow as shown in the Flows panel in Setup
mode in place of n, e.g. {@flow5FirstPage@}.
The {@flowPage@} and {@flowPageCount@} tokens only consider the flow that
is active at the beginning of the first system of the music frame closest to the top
left-hand corner of the page on which the tokens are used. (STEAM-7755,
STEAM-7766)
Paragraph Styles dialog. The default selection in the Engrave ▸ Paragraph Styles
dialog is initialized from the first selected text item, if any. (STEAM-7972)
User interface
Visual refresh. The look and feel of the Dorico project window has been subtly
updated, reducing the width and height of panels by a small amount where
possible to ensure that the maximum amount of space is available for the music
area. The Hub window has also been redesigned: more space is devoted to the list
of recent projects, and the lists of blog posts and videos, of which only one was
previously visible at once, are now both shown in order to make it easier to see
when new content is available.
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Multiple selections in the Players and Layouts panels. When you need to perform
an operation on multiple selected players or layouts, for example to assign multiple
players to a flow, when clicking on a checkbox to include or exclude the player or
layout, you can then hold Shift and click on another checkbox, which will include or
exclude all players or layouts in the range between the first and second click.
(STEAM-7287)
Multiple selections in the Edit Percussion Kit dialog. A number of operations in the
Edit Percussion Kit dialog can now operate on multiple selected instruments in
the dialog, including changing voice direction and index, setting the size of gaps
between instruments on adjacent grid lines, removing or deleting instruments from
the kit, and changing the order of instruments in the kit. (STEAM-7289)
Undo and redo. Edit ▸ Undo and Redo now bring the selection into view if
necessary. A new preference, Follow selection on undo and redo, has been
added to the Editing section of the General page of Preferences, which can be
switched off to restore the behavior to that of Dorico 1.2.10. (STEAM-7564,
STEAM-8026)
Updating from Dorico 1.x
When you first run Dorico Pro 2, your existing user data and preferences from
Dorico 1.x are automatically migrated to the new update. This includes: key
commands; preferences; the list of recent projects; saved default layout, notation,
engraving, playback and note input options; and any saved default tonality systems,
paragraph styles, and character styles. Furthermore, any VST 2.x plug-ins that you
added to the vst2whitelist.txt file for Dorico 1.x will automatically be added to the
whitelist for Dorico 2. (STEAM-7664)
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Issues resolved
ID #
STEAM-4241
STEAM-4294

Component
Accidentals

Issue
Changing the pitch of a grace note before a barline no longer incorrectly considers the
accidental state of the following bar.
When using the Second Viennese School accidental system, grace notes are now

STEAM-5539

Accidentals

STEAM-7472

Accidentals

STEAM-7910

Accidentals

STEAM-7905

Audio export

STEAM-7047

Barlines

STEAM-7077

Barlines

STEAM-7134

Barlines

STEAM-7301

Barlines

STEAM-4846

Beaming

STEAM-7562

Chord
symbols

Toggling the Show as mode property on and back off again for a diminished half/whole

STEAM-7504

Collision
avoidance

Mysterious problems where deleting an item can cause an item in another bar to move

STEAM-7716

Collision
avoidance

The extent of items is now always correctly considered for collision avoidance when editing

STEAM-7018

Cues

If a cue abuts the end of a flow, a redundant restorative clef change is no longer created.

STEAM-7029

Cues

Cues are now automatically removed if they are invalid under more circumstances.

STEAM-7505

Cues

STEAM-5064

Dynamics

STEAM-6385

Dynamics

STEAM-6651

Dynamics

Dorico 2 Version History

considered correctly when determining whether or not to repeat an accidental.
Under some rare circumstances, it was not possible to change the pitch of a note that had
been respelled in a part layout; this problem has now been resolved.
The enharmonic spelling of rising chromatic passages in minor keys has been improved.
A progress dialog now appears during audio export on both Windows and Mac, and
accurately reflects the actual progress through the operation.
Dashed barlines to show subdivisions in additive time signatures no longer fail to appear if
the bar is split across a break.
Creating a time signature change at a dashed subdivision no longer causes previous
dashed subdivisions to appear in the wrong place.
Repeat barlines no longer draw incorrectly at the end of a system if they coincide with a
key change to a key with no accidentals.
Inserting a barline at the same rhythmic position as an existing dashed subdivision in an
aggregate time signature now works correctly.
Dragging the end of a stemlet now works correctly when the stemlet belongs to an implicit
rest.
scale chord symbol no longer results in the chord symbol showing as a different chord.
vertically in galley view have been resolved.
an item that is graphically wider than its rhythmic position and duration.

Edits that affect where instrument changes occur no longer sometimes cause system
objects to disappear if a cue is located within the range affected by the edit.
Edit ▸ Reset Appearance and Reset Position now work correctly on dynamics.
If a dynamic has a color set via Properties, it now shows correctly in the blue linked color
rather than the orange selection color when another dynamic in the group is selected.
A series of gradual dynamics interspersed with immediate dynamics and shown as a single
hairpin no longer draws incorrectly in galley view.
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ID #

Component

STEAM-7328

Dynamics

STEAM-7742

Dynamics

STEAM-7782

Dynamics

STEAM-7257

Fingering

STEAM-7384

Fingering

STEAM-7409

Fingering

STEAM-7217

Flows

STEAM-7697

Graphics
export

STEAM-7767

Graphics
export

It is no longer possible to change focus to another project in the middle of a graphics

STEAM-7848

Holds and
pauses

In some circumstances, a fermata on a bar rest could be incorrectly positioned at the start

STEAM-4826

Key
signatures

Adding a clef change at the same location as a key change now always correctly updates

STEAM-7618

Key
signatures

Changing the current tonality system in the Tonality System section of the Key

Key

Creating a key signature from the Used in this flow section now always uses the tonality

signatures

system selected in the Tonality System section of the Key Signatures panel.

STEAM-7796

Key
signatures

The tonality system shown in the panel in Write mode is now always used when creating a

STEAM-7374

Localization

STEAM-7563

Localization

STEAM-7361

Lyrics

STEAM-6243

Multi-bar
rests

Multi-bar rests are now broken by both the starts and ends of repeat ending segments.

Multi-bar

The presence of a system break no longer sometimes causes the width of a multi-bar rest

rests

at the end of the previous system to change.

STEAM-7628

STEAM-7065
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Issue
Under rare circumstances, edits that affect the vertical placement of gradual dynamics
would not be propagated to all music frame chains; this has now been resolved.
Adding an immediate dynamic to the end of an existing group of dynamics now correctly
extends the length of the flow if required.
Hairpins that extend precisely to the end of the flow now draw correctly in galley view.
The Indicate shift to next note and Shift direction properties for string fingering shift
indications are now correctly reset when pasting notes onto non-string instruments.
Deferred fingering substitution now works correctly on notes and chords that are tied
between different voices.
Under some circumstances, fingering substitutions could fail to draw as slurs, despite the
options or properties; this problem has been resolved.
Duplicate Flow and Split Flow now correctly copy the flow info for the original flow into
the new one.
Imported graphics are now exported at a much higher resolution when exporting PDF files.

export operation, which could cause graphics from the wrong project to be exported.
of the bar, rather than over the bar rest; this has now been resolved.
the cancellation naturals, if shown.
Signatures panel now always takes effect correctly.

key signature.
Changing the keyboard language on the Key Commands page of Preferences now works
correctly when there are unsaved changes to the key commands in the current language.
The default key command for Write ▸ Respell ▸ Respell Using Note Above now works
correctly in the German-language version (Windows only).
Using the left or right arrow key to navigate off the first or last lyric no longer incorrectly
loses any edit made to that lyric.
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ID #

Component

Issue

STEAM-7423

MusicXML
export

Exporting with Export layouts as separate files switched off now correctly finds and uses

STEAM-6118

MusicXML
import

STEAM-7391

MusicXML
import

the most appropriate full score layout for the selected flow.
Imported MusicXML and MIDI files now respect the Default text font family preference.
A problem that could cause Dorico to crash when importing MusicXML files from
PDFtoMusic Pro has been resolved.
Moving the selection between non-note items with the arrow keys no longer sometimes

STEAM-7957

Navigation

causes the selection to jump unexpectedly to the start of the previous system in page view
or backwards several bars in galley view.

STEAM-7487

Notation
options

The Overlapping notes in the same voice in a kit or grid presentation option on the

STEAM-5499

Note input

Inputting the first note in a new voice between rhythmic grid positions now works correctly.

Percussion page of Notation Options now works correctly for chords split by a barline.

Under some circumstances, extending the duration of a note that ends within a tuplet in
STEAM-5555

Note input

Insert mode could cause other later notes in the same voice to be deleted; this problem
has now been resolved.

STEAM-6546

Note input

STEAM-7411

Note input

STEAM-7411

Note input

STEAM-7425

Note input

STEAM-7449

Note input

STEAM-7561

Note input

STEAM-7609

Note input

STEAM-7657

Note input

STEAM-7748

Note input

STEAM-7880

Note input

STEAM-7939

Note input

STEAM-7490

Notes
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Changing the voice of a selection of notes no longer sometimes causes the notes to be
moved to a different rhythmic position if items already exist in the destination voice.
Pasting a selection beginning with implicit rests immediately followed by a tuplet no longer
causes some non-note items to be offset incorrectly.
Pasting a selection that begins with implicit rests followed by a tuplet no longer results in
non-note items being pasted into incorrect rhythmic positions.
Pasting a selection including tuplets into an existing passage with identical tuplets with
chord mode active no longer sometimes results in some of the material being offset.
Pasting material of the same duration as an existing tuplet will now remove the tuplet,
instead of pasting the material into the tuplet.
Undoing the creation of a tuplet no longer sometimes fails if a non-note item is located
within the range of the added tuplet.
Making a selection on a percussion kit using the five-line staff presentation type now
correctly uses the extent of the selection from all components, rather than only the first.
Copy and paste for instruments within a percussion kit using the single-line instruments
presentation type now works more reliably.
Dorico no longer hangs when attempting to shorten with Shift+Alt+left arrow a note or
rest of the minimum valid duration (1024th note).
Moving the caret after priming a new voice no longer causes a voice with the wrong
direction to be created.
When multiple items are selected, hitting Return now starts note input, rather than
attempting to edit the first selected item.
Stems in opposing directions on adjacent staves are padded by a small amount to prevent
them from becoming so close they may appear to touch.
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ID #

Component

STEAM-7508

Notes

STEAM-7436

Ornaments

STEAM-7568

Pedal lines

STEAM-7684

Pedal lines

STEAM-7487

Percussion

STEAM-7568

Piano
pedaling

STEAM-7516

Players

STEAM-7290

Print mode

STEAM-7323

Print mode

STEAM-7764

Print mode

Cancelling a print or graphics export operation no longer sometimes causes a crash

STEAM-7199

Repeat
endings

It is now possible to create a repeat ending when an explicit bar rest is selected.

STEAM-6760

Rests

STEAM-7012

Rests

STEAM-7545

Rests

STEAM-5501

Setup mode

STEAM-5817

Tempo

STEAM-7473

Tempo

STEAM-7706

Tempo

STEAM-7723

Tempo
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Issue
Rhythm dots on stemless notes– i.e. a whole note (semibreve) or longer – in down-stem
voices are no longer incorrectly snapped to spaces in the wrong direction.
Glissandos between invalid note positions (for example, two notes of the same pitch tied
together) are now correctly automatically removed.
Making a selection on the lower or left-hand staff of a piano instrument and then pasting
the pedal line now works correctly.
Pedal lines that span multiple systems no longer sometimes disappear when making
unrelated edits.
The notation option to remove overlaps for percussion kits did not always work correctly for
a chord split across a barline; this problem has now been resolved.
Pasting piano pedal lines now works correctly when selecting something in the left-hand
staff of the piano.
It is no longer incorrectly possible to use the Shift+I key command to add an additional
instrument to a section player.
The chosen page range for printing is correctly preserved when leaving and re-entering
Print mode.
Choosing a page range that does not include the first page of the layout, then switching
back to All pages now updates the print preview correctly.

Setting a property on an implicit rest no longer causes all other selected items to be
removed from the selection.
The Bar rest design in long time signatures option on the Rests page of Notation
Options now works correctly when adding bars to the end of the flow.
The presence of local time signatures on one staff no longer prevents multi-bar rests from
appearing in the other staff if they line up with the bars of the global time signature.
Expanding a group in the Players panel will no longer cause the cards for the players within
the group to be truncated incorrectly when the group is partially scrolled out of view.
Tempo items with dx/dy offsets are no longer sometimes positioned inconsistently in
relation to other items.
The spacing of rhythm dots in metronome marks has been improved, particularly for
durations shorter than a quarter note (crotchet).
When the font style for gradual tempo items is set to absolute rather than staff-relative size,
the dashed or dotted continuation line is now correctly drawn at absolute size too.
Gradual tempo items with no drawn continuation line now draw a handle and attachment
line at the right-hand end in Write mode.
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ID #

Component

STEAM-6777

Text

STEAM-7536

Text

STEAM-7578

Ties

STEAM-7075

Time
signatures

Under rare circumstances, notes and rests could be grouped incorrectly in irregular time

STEAM-7587

Time
signatures

Undoing the addition of a local time signature to an individual instrument now always

STEAM-7561

Tuplets

STEAM-3656

User interface

STEAM-7510

User interface

STEAM-7637

User interface

STEAM-7647

User interface

STEAM-7663

User interface
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Issue
System-attached text can now be edited correctly if the top staff of the system is hidden
because it is empty.
Right-aligned text is no longer sometimes slightly truncated within a text frame.
When considering ties for the purposes of collision avoidance, the inside of the tie was
incorrectly being considered instead of the outside. This problem has now been resolved.
signatures within an aggregate time signature; this problem has been resolved.
correctly reinstates the previous global time signature.
Undoing the creation of a tuplet where a non-note item’s position overlaps with the new
tuplet will no longer go wrong.
Drop-down menus in dialogs and panels no longer sometimes appear on the wrong
display when running Dorico with multiple displays (Windows only).
Focus no longer gets lost after clicking the buttons in the note input toolbox, resulting in
key commands not working until you click in the score (Windows only).
It is now possible to assign key commands to both File ▸Import ▸Flows and File
▸Export ▸Flows.
The various annotations that appear at the top and bottom of the caret are now correctly
scaled relative to the current staff size.
Maximizing the document window while a modeless dialog was open could in rare
circumstances lead to Dorico hanging; this has now been resolved (Mac only).
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Known issues and solutions
Frequently asked questions
Answers to frequently asked questions about Dorico can be found online in the
Dorico forum.

Knowledge base
For the latest information about issues and solutions you may encounter when
running Dorico, please consult the Knowledge Base.

Entering the eLicenser Activation Code (Mac only)
When you first run Dorico and are prompted to enter your Activation Code, you
may find that after you have successfully activated your Soft-eLicenser, you must
quit and restart Dorico for the application to detect that it is fully licensed.

Key commands to transpose notes by an octave (Windows only)
The Intel Graphics Adaptor drivers used by many Windows computers define a
default key command to flip the screen by 90, 180 and 270 degrees via a shortcut
Ctrl+Alt+up/down/left/right arrows.
Ctrl+Alt+up/down option conflicts with the key commands in Dorico note input for
transposing notes by an octave.
For information about how to disable the default Intel Graphics Adaptor key
command, consult the Knowledge Base.
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